Guidage et perte de l'étoile guide

L'utilisation et la création des scripts.
Répondre
Marc DELDEM
Messages : 1020
Enregistré le : 20 juin 2009, 01:01

Guidage et perte de l'étoile guide

Message par Marc DELDEM » 08 avr. 2017, 22:22

Si on lance le guidage par script, si à un moment, on perd l'étoile guide, que retourne alors la fonction

Code : Tout sélectionner

Get_Guide_Status_EX
Car dans la doc on a:

Code : Tout sélectionner

GET_GUIDE_STATUS_EX  NumCam  CCDNum  Status  LastErrorMessage$

Status = 0 si le guidage a échoué.
Status = 1 si le guidage a réussi.
Est-ce que la fonction retourne alors 0 ou pas ?

Je cherche en fait une alternative à l'observation automatique, où malheureusement, si dans une séquence (par exemple 100 images de 60 sec), à un moment on perd l'étoile guide, l'obs auto continue sur le même champ comme si tout allait bien.

Merci.
Marc

Cyril Cavadore
Messages : 3918
Enregistré le : 18 juin 2009, 22:41
Localisation : 42

Re: Guidage et perte de l'étoile guide

Message par Cyril Cavadore » 09 avr. 2017, 04:31

Elle retournera rien si l'etoile disparaît
Ca peut etre du a un nuage qui passe... Comme en obs auto.
D'ailleurs ton guidage semble pas performant pour perdre l'etoile ?
Cyril Cavadore, ALCOR-SYSTEM, Auteur de PRISM
http://www.alcor-system.com

Pour reporter vos problème, la marche à suivre est ici
viewtopic.php?f=7&t=1403

Marc DELDEM
Messages : 1020
Enregistré le : 20 juin 2009, 01:01

Re: Guidage et perte de l'étoile guide

Message par Marc DELDEM » 09 avr. 2017, 11:26

Cyril Cavadore a écrit :Elle retournera rien si l'etoile disparaît
Ca peut être du a un nuage qui passe... Comme en obs auto.
Ça c'est bien dommage...
Dans les logs, on voit quand il détecte que l'étoile guide est perdue.
Pourquoi, quand la phase de guidage redémarre, ne pas retourner alors une valeur différente de 0 ou 1 quand l'étoile guide est perdue ?
Cela permettrait justement de pouvoir interagir par script (par exemple passer sur une autre séquence, ...).

Cyril Cavadore a écrit : D'ailleurs ton guidage semble pas performant pour perdre l'etoile ?
En fait j'ai un vrai problème dans l'observation automatique.
Par moment cela part en sucette.
Et comme je n'ai jamais eu le problème (de mémoire), quand je fais du guidage mais en dehors de l'observation automatique, cela me laisse perplexe.
Ce n'est pas un problème de nuage, j'ai une petite DMK qui enregistre le ciel en même temps.
Ce n'est pas non plus du vent.


Comme l'observation automatique est utilisée par tout un tas de configurations différentes, je pense plutôt:
- Soit à un problème sur le Gemini2 qui contrôle la monture. Mais alors pourquoi je ne vois pas le problème quand je guide en dehors de l'observation automatique ?
- Soit à un problème d'interaction (multi-threads) entre le driver ASCOM du Gemini2 et l'observation automatique.

Marc

Cyril Cavadore
Messages : 3918
Enregistré le : 18 juin 2009, 22:41
Localisation : 42

Re: Guidage et perte de l'étoile guide

Message par Cyril Cavadore » 10 avr. 2017, 01:19

Il y a des personnes qui utilisent l'obs auto avec le guidage.
Et ca marche ...
Quelle est ta camera principale et de guidage ?
Merci
Cyril Cavadore, ALCOR-SYSTEM, Auteur de PRISM
http://www.alcor-system.com

Pour reporter vos problème, la marche à suivre est ici
viewtopic.php?f=7&t=1403

Marc DELDEM
Messages : 1020
Enregistré le : 20 juin 2009, 01:01

Re: Guidage et perte de l'étoile guide

Message par Marc DELDEM » 10 avr. 2017, 19:56

Salut Cyril,

Je sais bien que l'obs auto fonctionne.
Moi j'ai un problème qui est surement lié à la combinaison Prism obs auto + Gemini2.
Je te ferai passer tous les éléments quand j'aurai fini la synthèse.

Pour la CCD c'est du classique SBig ST8 et guidage avec le second capteur.

Marc

Cyril Cavadore
Messages : 3918
Enregistré le : 18 juin 2009, 22:41
Localisation : 42

Re: Guidage et perte de l'étoile guide

Message par Cyril Cavadore » 10 avr. 2017, 23:16

ST8 et capteur de guidage intégré, OK.
Cyril Cavadore, ALCOR-SYSTEM, Auteur de PRISM
http://www.alcor-system.com

Pour reporter vos problème, la marche à suivre est ici
viewtopic.php?f=7&t=1403

Répondre