Connection to CGX-L via Com 4

CCD cameras (CMOS/CCD), DSLRs, telescope mounts, focusers, autoguiders, domes, Roll off roofs, etc..
Post Reply
StarManFlorida
Posts: 2
Joined: Sun Nov 26, 2017 7:26 pm

Sat Jun 09, 2018 4:24 pm

I am getting the following three (3) errors when attempting to connect my computer via Com 4 to the CGX-L mounting (NOT via hand control):

1) Telescope [encoders], error while closing driver: cannot not terminate created thread
2) Telescope ascom, link error [ascom.celestron.telescope]-> unable to link to telescope
3) error during enabling link - error while initializing telescope control: telescope ascom, link error
[ascom.celestron.telescope]-> unable to link to telescope (please check cable and power supply)

The mounting correctly connects via PMI software. All cabling works fine. Power supply works properly.

Any ideas of what to do to correct this problem ???

Frank
Alnitak
Posts: 10
Joined: Thu Nov 30, 2017 8:19 am
Location: Las Vegas, NV
Contact:

Sun Jun 10, 2018 6:07 pm

Frank,

How are you trying to connect PRISM to the mount if not through the hand controller?
If the CGX-L is anything like my CGX the USB-B connector on the side of the mount is only for use with PWI. Any ASCOM controller software has to be connected via the hand controller.
Also, as I found out with lots of troubleshooting and Hamza's guidance and patience, it may be necessary to use NexRemote software to interface most Celestron mounts with PRISM.
Attachments
CGXL.png
Explore Scientific 127mm ED APO, Celestron CGX, ZWO ASI1600mm camera with ZWO LRGB filters, Orion 50mm mini guide scope with StarShoot AutoGuider.
Post Reply