Fichier / Ouvrir

> Fichier > Ouvrir

Lancement : Menu [Fichier] > [Ouvrir]

But : Ouvrir une image tout format depuis PRiSM.

Cette fonction permet d'ouvrir un fichier dont le format est supporté par PRiSM.

Il est possible de ne garder dans la fenêtre de sélection que les fichiers en :

  • Format images astronomiques : CPA (propriétaire PRiSM) , FITS (transportable) y compris le format FITS1D (spectroscopie en général), PIC (caméras Hi-SiS), ST* (caméras SBIG), T1M (caméra Pic 1M)
  • Format images "classiques" : BMP, TIF, TIFF, IMG, PNG et non sélectionnable (oubli ...) : JPG.
  • Format APN : RAW, ECR, CRW (Canon), NEF (Nikon), MRW (Minolta), RAF (Fuji)

Une explication du menu contextuel est fournie ici.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
OPEN
GETIMAGE

Conditions d'activation :
Connaître le chemin pour atteindre l'image !

Voir aussi :
Importer BMP vers CPA
Importer JPG vers CPA
Importer une image "Format Libre
Importer Image Digitale APN

Menu contextuel d'une image

Décembre 2006


Fichier / Menu contextuel d'une image

> Menu contextuel d'une image

Lancement : Bouton droit de la souris sur une image

Le menu contextuel d'une image a l'apparence suivante. Suivant les options sélectionnées et les instruments utilisés, certaines fonctions pourront être grisées :

Cliquer sur la partie concernée |
Version complète | Version Light

Partie Analyse

  • Centroïde : Lance la fonction de calcul de centroïde gaussien à l'endroit où a été ouvert la fenêtre du menu contextuel. La demi-taille de la fenêtre est celle qui a été indiqué au programme par l'intermédiaire du menu [Analyse] > [Centroïde] > [Taille de la fenêtre (Gauss2D/Moffat)].

  • Zoom : Choix du azoom d'afficahge de l'image.

  • Netteté stellaire : Réalise des calculs statistiques sur les étoiles rencontrées sur toute l'image ou une petite partie centrée sur l'endroit où a été ouvert le menu :

Partie Cosmetique

Ces opérations peuvent être annulées si le menu [Options] > [Activer "défaire" la dernière opération] a été activé.

  • Modifier la valeur d'un pixel : Une fenêtre s'ouvre où la valeur actuelle du pixel est rappelée. L'utilisateur doit alors insérer la nouvelle valeur afin de la modifier. Si on veut que cette modification soit définitive, il faut enregistrer l'image.

  • Cicatriser une colonne : Remplace la colonne pointée par la moyenne des deux colonnes adjacentes.

  • Cicatriser une ligne : Remplace la ligne pointée par la moyenne des deux lignes adjacentes.

  • Boucher zone : La taille carrée utilisée pour la zone à boucher est indiquée entre paranthèses. Elle est modifiable à partir du menu [Traitements] > [opérations cosmétiques] > [Taille de la zone à boucher]. La nouvelle valeur de tous les pixels de la zone dont la taille est rappelée résulte alors de l'opération mathématique suivante :

    • où X,Y sont les coordonnées du pixel pointé et L la demi-Largeur de la zone.

  • Boucher zone par polynome 2D : La taille carrée utilisée pour la zone à boucher est modifiable à partir du menu [Traitements] > [opérations cosmétiques] > [Taille de la zone à boucher] et est rappelée entre paranthèses dans le menu précédent. La nouvelle valeur constituant les pixels de la zone est telle qu'on puisse ajuster au mieux un polynome dans la zone, verticalement et horizontalement, en fonction des valeurs deja existantes. Du bruit sera volontairement introduit dans cette zone à variation polynomiale dont la variance est à indiquer au lancement de la fonction :

  • Boucher zone circulaire : Permet de créer une zone circulaire complètement artificielle (ne dépend pas des pixels environnants ou anciennement présents dans la zone). Après avoir rempli les informations demandées :

    un cercle est créé en fonction des valeurs exigées (Attention : par défaut, c'est l'extérieur du cercle qui sera modifié).

  • Offset sur une colonne : Permet de rajouter une constante à spécifier sur les pixels de la colonne pointée.

  • Copier X,Y : Copie les coordonnées vers le presse-papier windows sous la forme "XXX, YYY".

  • Mémoriser valeur(s) pixels : Copie les valeurs "XXX, YYY" du pixel de l'image à partir duquel on ouvert le menu contextuel. Pour le moment, cette information n'est réutilisée que dans la fonction [Prétraitements] > [Soustraction du fond de ciel (Zonal)]

Partie Telescope

  • Mesurer distance : permet de mesurer la distance entre deux points d'une image. Il faut aller cliquer entre deux parties de l'image pour faire apparaître cette distance. Le curseur est amélioré pour correctement viser les deux parties à pointer.

    Le curseur amélioré

    Le résultat renvoyé dépend du remplissage de l'entête de l'image et/ou de son éventuel étalonnage astrométrique.

    Exemple 1 :
    DX= 199 DY= 233
Distance (Pixels) : 306.41
Distance (mm) : 2.0836
Angle (CCD) ° : 310.4999
Distance sur le ciel (Angle) : 00°03'55'' , 00h00m16s

    Exemple 2 :
    DX= 230 DY= 256
Distance (Pixels) : 344.15
Point 1 : X1=177 Y1=597 19h59m59.330s +22°46'31.68''
Point 2 : X2=406 Y2=342 19h59m01.189s +22°33'52.63''
Angle (CCD) ° : 311.9377
Distance sur le ciel (Angle) : 00°18'26'' PA= 226.72° -> astrometrique

  • Décaler télescope (fonction non accessible depuis la version LIGHT): Pour utiliser cette fonction, un télescope doit être connecté à PRiSM. L'image doit être dans le même sens que le sens d'apparition sur la carte du ciel. A cette fin, on prendra soin de remplir correctement les paramètres d'entêtes d'image : "Repère direct", "Orientation du champ" et de réaliser les "miroirs" X et/ou Y nécessaire pour que ce soit le cas :

    L'image est dans le même sens qu la carte du ciel

    Dans ce cas, en utilisant le curseur amélioré, il suffit d'indiquer les positions de départ et d'arrivé sur l'image. Le télescope se met alors en mouvement pour atteindre le point désiré. Le centre de l'image est indiqué à chaque fois :

    Ceci aide à se repérer sur l'image. La correction est terminée lorsque la fenêtre de pointage disparaît :

    La fenêtre de pointage

    Exemple de fichier de sortie :
    X_debut=267  Y_debut=380  X_fin=570  Y_fin=317
Alpha Centre Image = 07h01m32s Delta Centre Image =+32°22'33''
Angle d'image = 0.00 °
Distance Objet<->Centre =+00°07'28'' Angle=2.46 °
Objet : Alpha =07h02m08s Delta=+32°22'52''
Centre <-> objet à l'arrivée =+00°01'30'' Angle=64.80 °
Nouvel Alpha Centre=07h02m11s Delta Centre Image =+32°24'14''
Distance sur Alpha=+00°09'35''
Distance sur Delta=+00°01'41''
Distance totale = +00°08'16''

  • Recentrer Telescope automatiquement (fonction non accessible depuis la version LIGHT): L'image n'a pas besoin d'être étalonnée au départ. La fonction réalise une calibration astrométrique de l'image à partir des paramètres définis dans le menu [Télescope] > [Paramètres de centrage auto du télescope]. Le décalage avec la position où la souris a été cliquée est alors calculé et le télescope est déplacé alors ce point et correctement calibré.

Vidéo exemple :
Le recentrage automatique (FR, 11.1 Mo)

Partie Coordonnées (fonctions non accessibles depuis la version LIGHT)

  • Recevoir l'entête d'une autre image : Ouvre la fenêtre de sélection d'images ouvertes afin de sélectionner l'image désirée.

  • Mettre à jour l'entête avec Alpha/Delta : Permet de copier les valeurs de alpha/delta données par les encodeurs. Cette fonction est évidemment grisée si les encodeurs ne sont pas déclarés et connectés sous PRiSM.

  • Montrer Alpha/Delta et X/Y : Permet d'afficher une fenêtre avec les renseignements Alpha/Delta et X/Y dans des onglets différents. Pour une présentation graphique, il est possible d'afficher de différente manière les coordonnées directement sur l'image. Si l'image n'est pas calibrée astrométriquement, seul l'onglet X-Y apparaît ...
  • Ajouter Alpha/Delta à la liste des objets [OBJL] : Permet d'ajouter un objet à nommer dans la liste des objets à observer ... (récupérable pour une observation automatique).

  • Chercher l'image du DSS à cette coordonnée RA/DEC : L'image doit être calibrée astrométriquement pour que ce menu soit valide. La fenêtre du menu [Fichier] > [Rappatrier une image DSS] s'ouvre et par défaut, l'image "DSS2-Red" se charge.

  • Charger fichier de positions : Cette fonction permet d'afficher sur une image divers petits carrés dont les positions sont répertoriées dans un fichier texte du type suivant :
1. X=59.7 Y=152.3
2. X=23.5 Y=23.6
  ................

Ce fichier peut, par exemple, être obtenu à l'aide de certaines fonctions de reconnaissance de PRiSM qui créent un fichier du type numéro/X/Y/Flux pour chaque ligne. On obtient un résultat sur l'image de ce style :

  • Envoyer infos image vers infos par défaut CCD principale : Toutes les informations de l'images sont envoyées dans l'entête de la caméra principale en dehors du lieu d'observation qui reste le lieu d'observation par défaut de PRiSM.
    Voir la page sur la définition de l'orientation du CCD.
Partie Image

  • Rafraichir affichage de l'image : Permet de recharger l'image si une modification extérieure a été effectuée.

  • Mémoriser la position de l'image : Cette fonction permet d'afficher une image réouverte à la même position sur l'écran que lors de la mémorisation de sa position.

  • Fermer et effacer cette image du disque (fonction non accessible depuis la version LIGHT): Cette fonction fait ce qu'on lui demande ... ! Attention : L'image sera récupérable non récupérable ...

Images supportant cette fonction :
Image ouverte dans PRiSM

Fonction(s) Script associée(s):
xxxx

Mai 2010


Fichier / Rappatrier une image DSS

> Fichier > Rappatrier une image DSS

Lancement : Menu [Fichier] > [Rappatrier une image DSS]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Rappatrier et ouvrir une image sur le DSS.

Cette fonction permet de télécharger des images du Palomar Digital Sky Survey, qui sont disponibles par Internet.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

Les coordonnées Alpha et Delta du centre du champ à télécharger peuvent être remplis à la main ou en cliquant sur le bouton à gauche si les coordonnées ont été préalablement envoyées dans le presse-papier.

La largeur et la hauteur du champ sont par défaut de 10 minutes d'arc, mais peuvent être modifiées.

En cliquant sur le bouton [Charger] le logiciel va chercher l'image correspondante à la bande sélectionnée.

Attention : une connection à internet doit être ouverte, et si le fichier fait plus de 10 par 10 minutes d'arc, cela risque de prendre un peu de temps. Le champ maximum est de 30 arcmin.

Exemple d'une image du DSS

Une fois l'image rapatriée, le logiciel la décompresse si nécessaire, affiche cette image et la sauve dans le sous repertoire "C:\Users\XXXXX\Documents\Prism\DssFiles" de PRiSM.

Entete FITS de ce fichier 123456789012345678901234567890123456789012345678901234567890
         1         2         3         4         5         6 SIMPLE  =                    T /FITS header
BITPIX  =                   16 /No.Bits per pixel
NAXIS   =                    2 /No.dimensions
NAXIS1  =                  530 /Length X axis
NAXIS2  =                  530 /Length Y axis
EXTEND  =                    T /
DATE    = '22/10/99          ' /Date of FITS file creation
ORIGIN  = 'CASB -- STScI     ' /Origin of FITS image
PLTLABEL= 'J 10265           ' /Observatory plate label
PLATEID = '04I5              ' /GSSS Plate ID
REGION  = 'S602              ' /GSSS Region Name
DATE-OBS= '15/06/85          ' /UT date of Observation
UT      = '18:30:00.00       ' /UT time of observation
EPOCH   =  1.9854542236328E+03 /Epoch of plate
PLTRAH  =                   22 /Plate center RA
PLTRAM  =                   26 /
PLTRAS  =  4.3474570000000E+01 /
PLTDECSN= '-                 ' /Plate center Dec
PLTDECD =                   19 /
PLTDECM =                   44 /
PLTDECS =  4.2059660000000E+01 /
EQUINOX =  2.0000000000000E+03 /Julian Reference frame equinox
EXPOSURE=  7.0000000000000E+01 /Exposure time minutes
BANDPASS=                    0 /GSSS Bandpass code
PLTGRADE=                    1 /Plate grade
PLTSCALE=  6.7200000000000E+01 /Plate Scale arcsec per mm
SITELAT = '-31:16:24.00      ' /Latitude of Observatory
SITELONG= '+149:03:42.00     ' /Longitude of Observatory
TELESCOP= 'UK Schmidt (new optics)' /Telescope where plate taken
CNPIX1  =                 5355 /X corner  (pixels)
CNPIX2  =                 4555 /Y corner
DATATYPE= 'INTEGER*2         ' /Type of Data
SCANIMG = 'S602_04I5_00_00.PIM' /Name of original scan
SCANNUM =                    0 /Identifies scan of the plate
DCHOPPED=                    F /Image repaired for chopping effects
DSHEARED=                    F /Image repaired for shearing effects
DSCNDNUM=                    0 /Identifies descendant of plate scan image
XPIXELSZ=  2.5284450000000E+01 /X pixel size microns
YPIXELSZ=  2.5284450000000E+01 /Y pixel size microns
PPO1    =  0.0000000000000E+00 /Orientation Coefficients
PPO2    =  0.0000000000000E+00 /
PPO3    =  1.7800815369865E+05 /
PPO4    =  0.0000000000000E+00 /
PPO5    =  0.0000000000000E+00 /
PPO6    =  1.7762863283887E+05 /
AMDX1   =  6.7219770175765E+01 /Plate solution x coefficients
AMDX2   = -1.1880355995672E-01 /
AMDX3   = -1.3157645513770E-01 /
AMDX4   = -5.6708509711628E-06 /
AMDX5   =  6.2679885786864E-06 /
AMDX6   = -1.1142206237378E-07 /
AMDX7   =  0.0000000000000E+00 /
AMDX8   =  2.2200418019794E-06 /
AMDX9   =  7.4390602168984E-10 /
AMDX10  =  2.5668005274713E-06 /
AMDX11  = -2.6549905009760E-07 /
AMDX12  =  0.0000000000000E+00 /
AMDX13  =  0.0000000000000E+00 /
AMDX14  =  0.0000000000000E+00 /
AMDX15  =  0.0000000000000E+00 /
AMDX16  =  0.0000000000000E+00 /
AMDX17  =  0.0000000000000E+00 /
AMDX18  =  0.0000000000000E+00 /
AMDX19  =  0.0000000000000E+00 /
AMDX20  =  0.0000000000000E+00 /
AMDY1   =  6.7228009015427E+01 /Plate solution y coefficients
AMDY2   =  1.2873652788750E-01 /
AMDY3   = -3.1950040128023E-01 /
AMDY4   = -3.2645385511415E-05 /
AMDY5   =  8.7305582924401E-06 /
AMDY6   =  1.8171663502226E-05 /
AMDY7   =  0.0000000000000E+00 /
AMDY8   =  2.1698493473859E-06 /
AMDY9   = -3.6671971341692E-08 /
AMDY10  =  2.4125963913336E-06 /
AMDY11  = -1.9511911767187E-08 /
AMDY12  =  0.0000000000000E+00 /
AMDY13  =  0.0000000000000E+00 /
AMDY14  =  0.0000000000000E+00 /
AMDY15  =  0.0000000000000E+00 /
AMDY16  =  0.0000000000000E+00 /
AMDY17  =  0.0000000000000E+00 /
AMDY18  =  0.0000000000000E+00 /
AMDY19  =  0.0000000000000E+00 /
AMDY20  =  0.0000000000000E+00 /
Based on photographic data obtained using The UK Schmidt Telescope.
The UK Schmidt Telescope was operated by the Royal Observatory
Edinburgh, with funding from the UK Science and Engineering Research
Council, until 1988 June, and thereafter by the Anglo-Australian
Observatory.  Original plate material is copyright (c) the Royal
Observatory Edinburgh and the Anglo-Australian Observatory.  The
plates were processed into the present compressed digital form with
their permission.  The Digitized Sky Survey was produced at the Space
Telescope Science Institute under US Government grant NAG W-2166. Investigators using these scans are requested to include the above
acknowledgements in any publications. Copyright (c) 1993, 1994, Association of Universities for Research in
Astronomy, Inc.  All rights reserved.
DATAMAX =                21635 /Maximum data value
DATAMIN =                 3701 /Minimum data value
OBJECT  = 'data              ' /Object ID
OBJCTRA = '22 29 36.000      ' /Object Right Ascension (J2000)
OBJCTDEC= '-20 47 00.00      ' /Object Declination (J2000)
OBJCTX  =              5620.44 /Object X on plate (pixels)
OBJCTY  =              4820.64 /Object Y on plate (pixels)
END

Ces informations donnent (entre autres) les coordonnees du centre de l'image, l'observatoire qui a realise cette plaque, la date de prise de vue, les coefficient de plaque ...

Mai 2010


Fichier / Browser d'images

> Fichier > Browser d'images

Lancement : Menu [Fichier] > [Browser / Explorateur d'images]

But : Ouvrir une visionneuse d'images astronomiques au format CPA et FITS.

Cette fonction permet d'avoir un aperçu de toutes les images presentes dans un répertoire.

Au lancement de cette fonction, la fenêtre suivante apparaît :

La partie gauche de la fenêtre permet de sélectionner le répertoire que l'on veut explorer, tandis que la partie droite contient les imagettes des images présentes dans le répertoire sélectionné.

Si le répertoire n'a jamais été exploré, le browser lit toutes les images et crée un fichier pour chaque répertoire qui contient toutes les information. Cela permet une exploration plus rapide les fois suivantes.

Ces fichiers sont stockés dans le répertoire "\Browse files" du répertoire principal de PRiSM.
Le nom du fichier qui correspond au chemin K:\Nuit_2005_11_20_10CDR\preprocess\ est le fichier suivant [K=^Nuit_2005_11_20_10CDR^preprocess^].brs.

Si on ne prend pas garde après exploration de plusieurs répertoires, ces fichiers peuvent s'accumuler en grand nombre. L'utilité du bouton de droite permet de les effacer tous. On peut aussi effacer une image en la sélectionnant et en pressant la touche DEL.

Il est possible de générer une liste au format ASCII des fichiers du répertoire donné avec un certain nombre d'informations, comme par exemple :

Repertoire : K:\Nuit_2005_11_20_10CDR\preprocess\
Nom                  Dimensions Type data      Date       Heure    Pose (s) Alpha     Delta       Commentaire Version          Mirroir X Mirroir Y Binning X Binning Y
tAlemannia_1.cpa     1092x736   Codage 16 bits 20/11/2005 19:37:31 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_10.cpa    1092x736   Codage 16 bits 20/11/2005 21:53:50 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_11.cpa    1092x736   Codage 16 bits 20/11/2005 22:09:19 120      03h15m08s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_12.cpa    1092x736   Codage 16 bits 20/11/2005 22:24:12 120      03h15m09s +21°05'09''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_13.cpa    1092x736   Codage 16 bits 20/11/2005 22:39:41 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_14.cpa    1092x736   Codage 16 bits 20/11/2005 22:54:33 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_15.cpa    1092x736   Codage 16 bits 20/11/2005 23:10:03 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_16.cpa    1092x736   Codage 16 bits 20/11/2005 23:24:55 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_17.cpa    1092x736   Codage 16 bits 20/11/2005 23:40:23 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_18.cpa    1092x736   Codage 16 bits 21/11/2005 00:09:43 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_19.cpa    1092x736   Codage 16 bits 21/11/2005 00:24:35 120      03h15m09s +21°05'09''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_2.cpa     1092x736   Codage 16 bits 20/11/2005 19:52:24 120      03h15m09s +21°05'09''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_20.cpa    1092x736   Codage 16 bits 21/11/2005 00:40:02 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_21.cpa    1092x736   Codage 16 bits 21/11/2005 00:54:54 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_22.cpa    1092x736   Codage 16 bits 21/11/2005 01:10:22 120      03h15m09s +21°05'09''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_23.cpa    1092x736   Codage 16 bits 21/11/2005 01:25:13 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_24.cpa    1092x736   Codage 16 bits 21/11/2005 01:40:40 120      03h15m08s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_25.cpa    1092x736   Codage 16 bits 21/11/2005 01:51:39 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2
tAlemannia_26.cpa    1092x736   Codage 16 bits 21/11/2005 02:07:37 120      03h15m09s +21°05'08''             V4.D CPA release TRUE      FALSE     2         2

Limitations : Si un nouveau fichier est sauvé, le rafraichissement de la fenêtre n'est pas automatique, est dans ce cas il faut cliquer sur le bouton de mise a jour.

Images supportant cette fonction :
images FITS (1D ou 2D) et CPA uniquement

Oct 2007


Fichier / Re-Ouvrir ...

> Fichier > Re-Ouvrir ...

Lancement : Menu [Fichier] > [Re-Ouvrir ...]

But : Réouvrir une image précédemment ouverte dans PRiSM.

Cette fonction permet de réouvrir une image précédemment ouverte dans PRiSM à partir du menu [Fichier] > [Ouvrir]. Ceci pour des images lors de la même session ou d'une session précédente.
Les informations sont rappelées depuis la base de registre : "HKEY_CURRENT_USER\Software\Prism6\General\Files".

Images supportant cette fonction :
ouverte à partir du menu [Fichier] > [Ouvrir].

Version Novembre 2006


Fichier / Ouvrir une fenêtre du ciel

> Fichier > Ouvrir une fenêtre du ciel

Lancement : Menu [Fichier] > [Ouvrir une fenêtre du ciel]

But : Charger dans PRiSM une fenêtre précédemment enregistrée.

Cette fonction permet d'ouvrir une fenêtre du ciel préalablement enregistrée au format .mapsky. L'enregistrement a été réalisé à partir du bouton [Sauver] des options d'affichage d'objets.

Voir aussi
Nouvelle fenêtre du ciel

Décembre 2006


Fichier / Fenêtre du ciel

> Fichier > Nouvelle fenêtre du ciel

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel]

But : Créer une nouvelle fenêtre du ciel sous PRiSM.

Cette fonction permet de lancer le module de cartographie de PRiSM. C'est un module très complet (voir le sommaire spécial "carte du ciel") qui permet de visualiser une carte du ciel pour un lieu et une date donnée et, grâce à ses très nombreuses fonctions, de préparer les observations.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

Une apparence de la fenêtre du ciel

L'accès aux fonctions de ce module peut se faire soit par la barre d'icones (située sous la barre de titre de la fenêtre), soit par le menu contextuel (qui s'ouvre en cliquant avec le bouton de droite sur la carte du ciel).

Des renseignements sur la fenêtre du ciel ou sur la position de la souris sur la fenêtre sont fournis au bas de cette dernière.

Fonctions accessibles par l'intermédiaire de la barre d'icone :

Diminution du zoom de la fenêtre
Augmentation du zoom de la fenêtre
Accès a de nombreuses fonctions de configuration du module de carte du ciel
Affichage de la carte du ciel en entier (zoom = 1)
Lancement de la recherche d'un objet
Effacement de tous les labels affichés sur la carte du ciel
Impression de la carte du ciel
Ajustement de l'échelle de représentation des étoiles en fonction de leur magnitude. Très utile lorsqu'on utilise des cartes de champ ne contenant que des étoiles de faibles magnitudes.
Retour à la vue précédente de la carte du ciel
Centrage de la carte du ciel sur un point de coordonnées données.
La prochaine visualisation se fait aussitôt ensuite centrée précisément sur ces coordonnées. Ceci est très utile pour réaliser une carte de champ d'un objet non référencé dans aucun catalogue du logiciel.
L'utilisateur peut choisir l'équinoxe correspond aux coordonnées.
Les coordonnées peuvent être reçues du presse-papier WINDOWS grâce au bouton correspondant. Elles auront été notamment copiées grâce à une fenêtre d'identification ou au menu contextuel de la carte du ciel.
Rafraichissement la carte du ciel affichée
Lancement du mode "animation" sur la carte du ciel.
La durée est réglable à partir du menu "Option d'affichage d'objets / lieu et date". A essayer, par exemple, pour une éclipse de Lune ou de Soleil, le passage d'une planète devant ou derrière un astre ou une occulation d'une étoile.
Accès au module de calcul d'éphémérides
Affichage d'une vue d'ensemble du système solaire
L'icône télescope n'est pas grisé si on a établi la communication avec un télescope ou des codeurs.
Centre la carte du ciel sur un point de la carte sur laquelle on clique. Lorsque ce mode est activé, une flèche apparaît sur la fenêtre; Le fait de cliquer à un endroit de la fenêtre où se trouve cette flèche donne les coordonnées du centre de la fenêtre. La fenêtre est redessinée, avec de nouvelles coordonnées centrales.
Sélection d'une zone de la carte, sur laquelle sera effectué un zoom. Dans ce mode, le zoom de la fenêtre ne peut que grandir. En entourant une zone de la fenêtre dans ce mode, la fenêtre grandira pour acquérir un zoom le mieux adapté à la taille de la fenêtre demandée.
Identification d'un objet sur la carte
Donne la distance entre deux objets en degrés, minutes d'arc et secondes d'arc. Dans ce mode, pointer sur un objet et maintenir le bouton gauche de la souris enfoncé jusqu'à atteindre l'objet voulu. Le résultat est affiché en bas à droite de la fenêtre.

Fonctions accessibles par l'intermédiaire du menu contextuel :

cliquer pour aide
  1. Zoom : Cette fonction permet de choisir entre un zoom de 1 x et 2048 x ( utile pour les possesseur de l'USNO-A2.0 ).

  2. Horizon : permet de changer d'horizon ( surtout fait pour les grands zooms ) : on choisit entre le sud, le nord, l'est, l'ouest ou le zénith.

Les quatre fonctions qui suivent ne sont accessibles uniquement si une image est ouverte dans PRiSM.

  3. Envoyer Alpha-Delta dans l'entête de l'image : Si, après avoir réalisé une image, on a repéré le centre de cette dernière sur la carte, il suffit de cliquer sur cette option pour que les coodonnées d'où l'utilisateur a cliqué soient envoyées comme position centrale de l'image (résultats tant utile pour l'astrométrie et la photométrie automatique, dans le cas où ces dernières n'auraient pas été complétées lors de l'observation). Evidement, cette opération se fait automatiquement pour ceux qui ont des codeurs étalonnés ou un télescope sous le protocole LX200 ou MCMT.

  4. Inclure une image CCD dans la carte du ciel : Au contraire, si on possède une image dont on connait toutes les coordonnées de tous les objets c'est-à-dire une image qui a été ETALONNEE ASTROMETRIQUEMENT au moins une fois (les coefficients de plaque étant ensuite sauvegardés dans l'entête CPA de l'image), on connait donc toutes les caractéristiques de l'image. On peut en cliquant sur cette option et en sélectionnant l'image à inclure ( demandé par le programme ) inclure son image en toile fond sur la carte du ciel.

    Prenons un exemple :
    Si on regarde dans la carte du ciel les alentours de la nébuleuse planétaire M27, on remarque que les contours de nébuleuses diffuses ont bien évidemment laissé tomber cette nébuleuse planétaire malgré tout assez étendue. On peut vouloir, pour une raison ou une autre intégrer une image de M27 à la carte du ciel en toile de fond. Ceci peut être pour une raison purement esthétique ou pour vérifier le calibrage astrométrique de son image. Inutile de préciser que ce qui va suivre peut être réalisé pour n'importe quelle image à d'autres fins qu'esthétique !
    Voici les alentours de M27, défini en zoom x128 pour une ST7 et son capteur d'autoguidage :

    la fenêtre du ciel autour de M27

    L'image a introduire est un plan rouge d'une image trichrome de M27 prise par l'auteur de ces lignes. Elle est déjà calibrée astrométriquement et photométriquement comme le prouve les informations sur l'image.
    Il suffit pour celà d'ouvrir l'image concernée et d'aller dans le menu contextuel de la fenêtre et de demander " inclure une image dans la carte du ciel ". Une demande de sélection sur les images ouvertes apparaît alors :

    Sélection de l'image
    Sélectionner l'image désirée et si, comme c'est le cas ici, l'image a été étalonnée astrométriquement (et pas obligatoirement photométriquement) celle-ci est incluse à la carte du ciel :

    L'image incluse dans la carte du ciel
    On voit bien que l'image a d'ailleurs été parfaitement calibrée astrométriquement vu que les étoiles de l'image correspondent bien aux étoiles de la carte du ciel.

  5. Centrer la carte du ciel sur une image CCD : Permet, une fois que l'on a les coordonnées du centre d'une image, de centrer la carte du ciel par rapport au coordonnée du centre de l'image. Le programme demande de sélectionner l'image à partir d'une boite de dialogue. Cette fonction est particulièrement utile si on veut utiliser par la suite "Inclure une image CCD dans la carte".

  6. Mettre la carte à la date d'une image CCD : Pour se repérer facilement, cette fonction met la date de la carte du ciel à celle d'une image CCD.

  7. Recevoir Focale/Orientation CCD depuis une image CCD : Cette fonction permet de compléter automatiquement l'onglet "CCD/Telescope" de la configuration de la carte du ciel, notamment en ce qui concerne la focale, l'angle d'orientation et le type de repère utilisé.

Les quatre fonctions qui suivent sont toujours accessibles.

  8. Envoyer RA-DEC dans le presse-papier : Permet d'envoyer les coordonnées du point à partir duquel on a ouvert le menu contextuel dans le presse-papier. Les coordonnées sont envoyées sous la forme 21h12m53.390s | -18°50'35.82".

  9. Envoyer RA-DEC à la liste des objets : ajoute un objet de la carte du ciel dans la liste des objets à observer. Cette liste des objets à observer est accessible à partir du menu "Télescope". Il sera cependant demandé de compléter le nom et la magnitude de l'objet.

  10. Réglage de la carte : Ouvre la boite de dialogue des options d'affichage de la carte.

  11. Aller au point Anti-solaire : Montre la carte du ciel à l'opposé du soleil sur la ligne Soleil-Terre. C'est l'endroit on a le plus de chance de découvrir des astéroïdes assez brillant encore non découverts !

Les quatre fonctions qui suivent sont uniquement accessibles si un système ou des encodeurs sont en liaison avec PRiSM.

  12. Réaligner encodeurs : réinitialise les encodeurs sur une position de la carte du ciel

  13. Envoyer RA-DEC dans le modèle de pointage : Permet d'envoyer les coordonnées du point à partir duquel on a ouvert le menu contextuel dans le modèle de pointage. Ce dernier est accessible à partir du menu "Telescope".

  14. Déplacer le télescope sur ce point : Pour tout télescope sous le protocole LX200, déplace automatiquement le télescope jusqu'au point à partir duquel on a ouvert le menu contextuel.

  15. Aller sur la position du télescope : Centre la carte du ciel sur la position vers laquelle pointe le télescope.

Les six fonctions qui suivent sont toujours accessibles.

  16. Trouver objets autour de ce point : Cette fonction mérite une page à elle seule.

  17. Ajouter ce point à la liste des objets à observer : Il apparait une boite de dialogue qui doit être complétée avant que l'objet ne soit inclus dans la liste. Cette liste des objets à observer est accessible à partir du menu "Télescope".

  18. Télécharger Champ digital sky survey correspondant : télécharge une image du DSS correspondant à la zone sélectionnée sur la carte du ciel. Une boite de dialogue intuitive apparaît alors, identique à celle obtenue à partir du menu "Fichier / Télécharger image DSS".

  19. Faire une copie haute résolution : copie dans le presse-papier une copie haute résolution de la carte du ciel affichée.

  20. Dupliquer cette carte vers une autre fenêtre du ciel : Permet d'ouvrir une nouvelle carte du ciel avec les mêmes paramètres.

  21. Sauver configuration carte du ciel : Permet de sauver la configuration d ela carte duciel dans un fichier MAPSKY dans le répertoire principal de PRiSM.

Renseignements au bas de la fenêtre :

  • Zoom actuel de la fenêtre ( de 1x à 2048x ).
  • Les coordonnées du pointeur de la souris lorsque ce dernier se déplace sur la fenêtre. Il faut appuyer sur "Shift" en déplaçant la souris sur l'écran afin d'avoir la transcription dans le système azimutal.
  • Le type de coordonnées utilisées pour décrire les coordonnées du pointeur. Attention : la fenêtre doit être rafraichie afin de voir apparaître les coordonnées écliptique et galactique. Pour les coordonnées azimutales, le principe est toujours de déplacer la souris en appuyant sur "Shift".
  • Le nombre d'objets présents sur la carte affichée.
  • L'abréviation latine de la constellation où se trouvent les objets de la fenêtre.
  • Le champ de la fenêtre.
  • ???

Conditions d'activation :
PRiSM ouvert !

Nov. 2005


Fichier / Vue de la Terre

> Fichier > Vue de la Terre

Lancement : Menu [Fichier] > [Vue de la Terre]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Poser un point sur la Terre.

PRiSM possède une option pédagogique et intéressante à la fois : " La vue de la Terre "; celle-ci ne permet pas encore de repérer automatiquement les observatoires numérotés par l'UAI, mais en rentrant ses coordonnées géographiques, on peut tirer plusieurs conclusions de cette carte.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

Une vue de la Terre; celle par défaut

Le lieu d'observation indiqué par défaut est l'Observatoire des Pises ( 30 ).

La Terre apparaît en vue globale et le centre de la vue se situe à la latitude 0° (équateur) et à la longitude 0° (méridien de Greenwich).

Les continents apparaîssent verts et les océans bleus. La nuit est dessinée en grisâtre. La partie gris clair correspond au crépuscule civil lorsque le Soleil est situé entre 0° et -6° apparent sous l'horizon. Après, on rencontre le crépuscule nautique lorsque le Soleil est situé entre -6° et -12° sous l'horizon local. Enfin, on voit le crépuscule astronomique lorsque le Soleil est situé entre -12° et -18° sous l'horizon. Ensuite, en gris foncé, c'est la nuit " noire " ou astronomique.

Description de la fenêtre :

  • Dans la barre de titre est affiché la date et l'heure à laquelle est tracée cette vue.

  • On rencontre ensuite plusieurs icônes dont la signification est identique à celle des fenêtres de l'atlas :

    Signification des icônes de la fenêtre

    On a ensuite la fenêtre décrite ci-dessus.

  • Il apparaît enfin une dernière ligne :

    La dernière ligne de la fenêtre

    Il est indiqué la longitude et la latitude du lieu sélectionné dans la première case. Dans la deuxième, on a éventuellement la distance entre les deux endroits qu'on aura sélectionné.

Insérer son lieu d'observation :

Il est possible de changer le lieu d'observation. Il faut aller changer le site dans les options d'affichage ( Changer le lieu d'observation). Lorsque cet icône est activé, on obtient la fenêtre suivante :

Changer le lieu et la date d'observation

Si le lieu où on se trouve n'est que pour une soirée, autant changer directement les coordonnées géographiques du lieu dans les cases réservées à cet effet (longitude, latitude, altitude).

Si le lieu considéré est le lieu d'observation classique, il vaut mieux le choisir dans une liste. Cliquer sur l'icône correspondant. Il apparaît une fenêtre proposant plusieurs options : sites de France, sites dans le monde, sites des USA et observatoires du monde.

Différents lieux de France proposés

Cliquer sur " sites de France ". On obtient alors les renseignements sur plusieurs villes mais il est bien connu que les meilleurs sites, et donc le vôtre, ne sont pas dans les grandes villes. Se diriger dans ce cas vers " Mon observatoire ". Rentrer les données correspondant à son propre site ainsi que le nom. Ce site sera sauvegardé, même après la fermeture de la fenêtre, sous le nom "Mon observatoire". Il suffit de mettre ce site en surbrillance et d'appuyer sur " OK ".

Les données seront alors inscrites dans la fenêtre "lieu et date" de la figure 5. Par défaut, il sera choisi l'heure locale et la date de l'ordinateur mais en supprimant cette option, libre à l'utilisateur de changer cette contrainte !

En appuyant sur " OK ", on peut alors voir son site préféré apparaître sur la carte de France. Si ce site est dans le gris, c'est qu'il fait nuit (ou va faire nuit pour le gris clair). S'il est dans le vert, c'est qu'il fait jour.

Il peut-être fait la même démarche pour beaucoup de grandes villes du monde et voir s'il fait jour ou non ! En plus, on peut apprendre la géographie ...

Repérer la position de différents observatoires :

Il y a là deux possibilités : soit on recherche un observatoire bien précis, soit on veut savoir où se trouvent les grands observatoires dans le monde.

Si on veut connaître la position d'un observatoire, il suffit de retourner dans "choisir dans une liste" et sélectionner "sites des observatoires". Sélectionner l'observatoire dans la liste et la suite se passe comme dans la section précédente.

Différents observatoires du monde proposés

Si on veut connaître la position de tous les observatoires, celà ne vaut pas le coup de sélectionner les observatoires les uns après les autres. Il faut faire une sélection globales. Aller alors dans l'onglet "Affichage général".

L'onglet affichage général

Sélectionner alors afficher "les observatoires du monde"et cliquer sur "OK". Tous les observatoires s'afficheront alors.

On peut bien évidemment faire de même pour les 3 autres propositions de cet onglet.

Calculer les heures des différents types de crépuscules :

Comme il a été vu dans la première section, il y a une différence de niveaux de gris affichés entre les crépuscules civil (Soleil entre 0° et -6° sous l'horizon), nautique (Soleil entre -6° et -12°) et astronomique (Soleil entre -12° et -18°).

Prenons l'exemple de l'observatoire des Pises le 11/02/98. En demandant à ce que l'heure prise en compte ne soit pas celle de l'ordinateur, on peut la changer à volonté.

On voit qu'en choisissant 17h05 TU, le Soleil se couche à l'observatoire : on rentre dans le crépuscule civil.

Arrivée du crépuscule astronomique le 11/02/98 à 17h05 TU

Le crépuscule nautique, lui, commence à 17h40 TU.

Arrivée du crépuscule nautique sur l'observatoire des Pises

De même, le crépuscule nautique commence à 18h15 TU et la nuit astronomique à 18h48 TU; il faut attendre cette dernière pour réaliser des images du ciel profond.

Arrivée de la nuit astronomique ... enfin ! à 18h48 TU sur l'observatoire des Pises

Il est possible de faire de même pour n'importe quel site en choisissant le site comme on a vu dans une section précédente.

Il est intéressant de noter que dans le nord de la France, aux environs du 21 Juin (solstice d'été), il n'y a pas de nuit astronomique, même au "plus profond" de la nuit.

Il n'y a pas de nuit astronomique dans le nord de la France aux environs du solstice d'été !
Décembre 2006


Fichier / Importer une image au format RAW

> Fichier > Importer une image (Format APN)

Lancement : Menu [Fichier] > [Importer une image] > [Format APN]

But : Charger sous PRiSM une image au format APN non traitée, au format RAW.

Image exemple :
Lune et Vénus

Images supportant cette fonction :
Format d'image RAW

Fonction(s) Script associée(s):
Aucune pour le moment

Version


Fichier / Importer BMP vers image traitable

> Fichier > Importer BMP vers image traitable

Lancement : Menu [Fichier] > [Importer] > [BMP vers CPA]

But : Transformer un fichier image BMP en image traitable comme une autre image.

Cette fonction permet de transformer à l'ouverture une image BMP vers le format CPA-Trichromie 8 bits par plan afin de profiter des traitements astronomiques existant sous ce format et qui ne sont pas disponibles directement sous le format BMP ...

Voir la page concernant la sauvegarde des images BMP

Attention, pour traiter les images couleurs il faudra, pour la majorité des fonctions, convertir l'image CPA couleur en 3 images représentant les plans couleurs Rouge, Vert et Bleu. Cette opération est possible grâce à la fonction [Visualisation] > [Trichromie] > [Séparer les plans couleurs RVB].

A cause du format 8 bits, il n'est pas recommandé d'utiliser ces images dans le but d'un traitement scientifique.

Image exemple :
ici

Images supportant cette fonction :
Image au format BMP

Fonction(s) Script associée(s):
OpenBMP

Nov. 2005


Fichier / Importer JPEG vers image traitable

> Fichier > Importer JPG vers image traitable

Lancement : Menu [Fichier] > [Importer] > [JPG vers image traitable]

But : Charger sous PRiSM une image au format JPEG puis la traiter.

Cette fonction permet de transformer à l'ouverture une image JPEG vers le format CPA-Trichromie 8 bits par plan afin de profiter des traitements astronomiques existant sous ce format et qui ne sont pas disponibles directement sous le format JPEG ...

Voir la page concernant la sauvegarde des images JPEG

Attention, pour traiter les images couleurs il faudra, pour la majorité des fonctions, convertir l'image CPA couleur en 3 images représentant les plans couleurs Rouge, Vert et Bleu. Cette opération est possible grâce à la fonction [Visualisation] > [Trichromie] > [Séparer les plans couleurs RVB].

A cause du format 8 bits, il n'est pas recommandé d'utiliser ces images dans le but d'un traitement scientifique.

Images supportant cette fonction :
Image au format JPEG

Fonction(s) Script associée(s):
xxxxx

Version


Fichier / Importer Format libre

> Fichier > Importer une image (Format Libre)

Lancement : Menu [Fichier] > [Importer une image (Format Libre)]

But : Charger sous PRiSM une image au format à définir.

Cette fonction permet d'importer toute image CCD sous PRiSM. Il faut cependant fournir des paramètres essentiels pour la lecture comme le type de données utilisées, la taille et la taille de l'entête ( entre autres ... ).

PRiSM gere de nombreux formats d'images mais il se peut qu 'un format ne soit pas supporté.
Si on connait la structure du fichier, il est néanmoins possible de charger ce fichier dans la mémoire image de PRiSM, d'afficher et de traiter cette image comme n'importe quelle image.

Tout d'abord il faut définir quel est le format des données des pixels :

Types de données | Intervalle | Taille d'un pixel | Chargé dans PRiSM comme | Troncature par PRiSM
Entier 8 bits non signés | 0-255 | 1 octet | 8 bits non signés | Non
Entier 8 bits signés | -128 + 127 | 1 octet | 16 bits signés | Non
Entier 16 bits signés | -32768 à 32767 | 2 octets | 16 bits signés | Non
Entier 16 bits non signes | 0 à 65535 | 2 octets | Réels / flottants 32 bits | Non
Entier 32 bits signés | -2147483648..2147483647 | 4 octets | Réels / flottants 32 bits | Non, perte de précision pour les grands nombres
Réels / flottants 32 bits | 1.5x10-45 .. 3.4x1038 | 4 octets | Réels / flottants 32 bits | Non
Réel / flottant 6 octets | 2.9x10-39 .. 1.7x1038 | 6 octets | Réels / flottant 32 bits | Non
Double / flottant 8 Octets | 5.0x10-324 .. 1.7x10308 | 9 octets | Réels / flottant 32 bits | Oui

Une fois le type de données connues, il reste à definir la taille de l'image. Si celle ci est incorrecte , cela peut aboutir à une erreur de chargement ou à un affichage incorrect.
La taille de l'entête en octets est aussi à fournir, celle si sera juste "sautée" jusqu'au premier pixel valide.
L'ordre de codage Intel ou Motorola des pixels de plus de 1 octet de taille est à definir (ordre de poids fort vers le poids faible).
Avec ces parametres la taille minimale du fichier s'affiche. Si la taille du fichier à charger est plus petite que celle calculée par PRiSM, le chargement ne s'effectuera pas.

Enfin, il existe des formats prédefinis dans la liste déroulante qui permet d'éviter de rentrer les paramètres précédents comme le format ST4 ou BDF de MiDAS.

Images supportant cette fonction :
Tous formats d'images

Fonction(s) Script associée(s):
OpenFree

Nov. 2005


Fichier / Importer

> Fichier > Importer une image (Nuage de points)

Lancement : Menu [Fichier] > [Importer une image] > [Nuage de points]

But : Charger sous PRiSM une image depuis un fichier texte.

Cette fonction construit une image à partir de l'intensité (aussi appelé "surface") d’une liste de points aléatoires distribués dans l’image. L’intensité (axe Z) représente la hauteur des points de cette surface. Le logiciel réalise l’interpolation des pixels manquants entre les points (X, Y) de cette surface.

Un fichier texte d’entrée fournit les coordonnées X, Y et les intensités en Z sous cette forme :

 5.79687500000000E+0000   6.35546875000000E+0001   6.74050451049805E+0002
 4.90156250000000E+0001   1.16406250000000E+0000   2.28874577026367E+0002
 1.28203125000000E+0001   6.42187500000000E+0000   1.00763307495117E+0002
 4.72031250000000E+0001   1.26398437500000E+0002   1.95437517517090E+0003
 1.27734375000000E+0002   1.02117187500000E+0002   2.04075326843262E+0003
 9.24843750000000E+0001   3.62500000000000E+0001   8.08449807128906E+0002
 2.15156250000000E+0001   4.47656250000000E+0000   1.23992799682617E+0002
 9.42578125000000E+0001   3.90000000000000E+0001   8.51687149047852E+0002
 2.76015625000000E+0001   1.20937500000000E+0002   1.72926179748535E+0003

La première colonne est X, deuxième Y et troisième Z, il n’y a aucun ordre entre les points X et Y.

Le logiciel interpole entre les points de référence du fichier, la valeur de chaque pixel de coordonnées (i,j) de l’image finale.

Il y a deux méthodes pour se faire :

Méthode des distances :

Cette méthode calcule pour le pixel (i,j) une intensité pondérée en fonction des distances d à tous les points d’entrée de référence du fichier texte.
Cette distance se calcule de la façon suivante [image], où « degré à appliquer » est un paramètre de la fonction, xi et yi est un point d’index i de référence contenu dans le fichier texte, X et Y la coordonnée du pixel image à reconstituer.

Par exemple, si « degré à appliquer » = 0.5, d représente la distance naturelle entre deux points. Si un paramètre autre que 0.5 est entré, cela permet de changer la pondération en fonction de la distance entre le point à reconstituer et les points de référence.

Sur l'image finale, les croix vertes représentent les points de référence issus des pixels du fichier texte; ci dessous, une image avec "degré à appliquer" = 0.5 :

Si on change le degré (= la façon de calculer la distance), le passage de 0.5 à 1 donne :

Avec "degré à appliquer" = 2, la restitution est encore meilleure :

Méthode polynomiale (plus lente) :

Cette méthode est plus adaptée aux formes de surfaces plus mouvementées / complexes.
Attention : cette option nécessite un nombre de points suffisants, sinon, l’interpolation sera approximative.
Pour chaque point de l’image d’arrivée, le logiciel calcule l'intensité du pixel par le polynôme d'approximation de moindre carré de dimension 3, 2 ou 1 qui est contraint par le paramètre « Nombre de points (Si méthode des moindres carrés) » points du fichier texte les plus proches du pixel (i,j) à reconstruire.

Le degré du polynôme est déterminé automatiquement suivant la table suivante :

3 à 5 points | Degré 1
6 à 9 points | Degré 2
Plus de 10 points | Degré 3

Pour exemple, un fichier de 300 points, X et Y aléatoirement distribués, dont l’intensité est fixé par la loi :

C'est une simple fonction gaussienne sur une surface inclinée, de 40 pixels à mi-hauteur, dont voici les isobares :

Avec ce jeu de paramètres, une image de 200 x 200 pixels va être réalisée, soit 40 000 pixels à reconstruire avec seulement 300 pixels, soit 0.75% de l’image finale.

Avec un polynôme passant par les trois points les plus proches, et un degré 1, la reconstruction est plus qu’imparfaite : des discontinuités sont présentes :

Avec un polynôme passant par les 8 points le plus proches, et un degré 2, la reconstruction est bien meilleure :

Fichier de test :
Fichier Texte

Fonction(s) Script associée(s):
Aucune

Février 2011


Fichier / Importer des points pour un graphique 2D

> FICHIER > Importer des points pour un graphique 2D

Lancement : Menu [Fichier] > [Importer Image] > [Importer des points pour un graphique 2D]

But : importer un fichier texte où chaque ligne contient 2 valeurs

Cette fonction est utile afin d'importer un fichier texte contenant des données en deux dimensions. Ce fichier peut être créé "à la main" ou résulter d'un précédent enregistrement directement depuis PRiSM.
Les données doivent être rentrées sous la forme :

liste des données
Liste des données

Les trois dernières lignes sont réservées à la légende : titre du graphe, légende axe des X puis légende axe des Y.
En cliquant sur "réglages", tout peut être réglé. A cette fin, voir le dossier sur les graphes

Image exemple :
Spectre 1D de la Nova Vulpeculae 2007

Fonction(s) Script associée(s):
DisplayGraph
OpenGraph
SetGraphRange
SetAxisInc
AddPoint
ClearGraphWindows

Prérequis :
Dossier sur les graphes

Nov. 2005


Fichier / Acquérir une image depuis un scanner

> Fichier > Acquérir une image depuis un scanner (TWAIN)

Lancement : Menu [Fichier] > [Acquérir une image depuis un scanner]

But : Acquérir une image sous PRiSM depuis un scanner.

Cette fonction permet d'acquérir une image à partir d'un scanner gérant le protocole TWAIN. C'est le moyen idéal pour numériser et traiter des images argentiques.

Au lancement de cette fonction, le logiciel de numérisation de votre scanner est lancé. Lorsqu'une numérisation est effectuée, l'image numérisée s'ouvre au format CPA dans une nouvelle fenêtre PRiSM.

Version Décembre 2006


Fichier / Conversion de format

> Fichier > Conversion de format en série

Lancement : Menu [Fichier] > [Conversion de format de fichiers par lot]

But : Convertir le format d'une série d'image.

Cette fonction permet de transformer un lot d'images d'un des formats suivants ... :

  • FITS : format international des images astronomiques
  • CPA : format propriétaire de PRiSM
  • HiSiS : Format propriétaire des caméras HiSiS-11 et 22
  • SBIG : Format propriétaire ST-X des caméras SBIG qui est le format de sauvegarde des images réalisées avec le logiciel d'acquisition CCDOPS.
  • Format Libre : compléter le type de format auparavant à l'aide du bouton [Paramètres format libre].
  • BMP : format Bitmap Windows
  • JPEG : format JPEG.
  • T1M : format propriétaire du télescope de 1m à l'observatoire du Pic du Midi.
  • APN : format des appareils photos numériques
  • TIFF : format TIFF (sans compression)
  • PIC : format utilisé par le logiciel IRIS.

... vers le format FITS ou CPA.

On part d'une série de formats possibles :

Il faut sélectionner le format de départ avant de sélectionner les images. Le bouton [Tout Sélectionner] permet à l'utilisateur de choisir l'ensemble des images du répertoire.

Le choix du format d'arrivé se fait dans le deuxième onglet. Il ne peut être que le format FITS ou CPA. Pour le format FITS, il est possible de régler le constraste automatique afin que les mots clés correspondants puisse être complétés.

le bouton [même répertoire que celui de départ] permet de sélectionner immédiatement le même répertoire que celui choisi dans l'onglet n°1.

Le bouton [Démarrer la conversion] ouvre l'onglet n°3 où est indiqué l'avancement de la conversion.

Images supportant cette fonction :
images au format de l'onglet n°1

Fonction(s) Script associée(s):
Aucune fonction spécifique : ouvrir la série d'image et la sauvegarder à l'aide des "fonctions de sauvegarde" appropriées. Voir ce script.

Septembre 2006


Fichier / Créer une mosaïque

> Fichier > Mosaïque d'images

Lancement : Menu [Fichier] > [Mosaïque d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Créer une image résultant de l'assemblage de plusieurs images.

Attention, page d'aide non revue depuis la version 5

Cette fonction permet de faire une mosaïque d'images n'ayant pas de parties communes.

Elle est donc destiné à faire des simples compositages de fichiers. Elle peut servir dans deux cas :

  • Faire une mosaïque d'images qui n'ont pas de parties communes mais qui se suivent juste les unes après les autres sur la sphère céleste ... au pixel près. Quiconque a fait une image CCD avec un instrument d'amateur ressentira la très grande difficulté à réaliser ce genre d'opération. Bref, pour ce type de réalisation, la fonction ne servirait pas souvent.
  • Réaliser des champs d'images où les images se situent les unes à côté des autres ou les unes en dessous des autres. Prenons l'exemple de l'astéroïde 1998BY07, un bolide qui est passé mi-février 1998 très proche de la Terre ( 0,04 U.A. ) ce qui n'autorisait qu'un temps de pose très court pour un astéroïde sortant à peine du bruit de fond de l'image. On peut présenter ces images soit, sous une image GIF animée, soit sous PRiSM sous forme d'image CPA ( qui n'a donc rien perdu de sa définition ). Une fois dans le menu mosaïque d'images, on obtient la fenêtre suivante :
Les options du menu mosaïques d'images sans partie commune
  1. On rentre le nom générique des différentes images à mosaïquer.
  2. L'index de la première image.
  3. L'index de la dernière image.
  4. Le répertoire où on peut trouver l'image.
  5. Cocher la dernière option si on veut qu'il y ait des cadres autour de chaque image ( comme les images de cette page ).

On doit remplir le nombre d'images que l'on veut mettre dans le sens de la largeur ( ici 2 ).

; on indique le nombre d'images en largeur

L'image est alors représentée comme désirée. A vous de trouver l'astéroïde.

Le résultat ... !

Image exemple :
M81

Version PRiSM 5


Fichier / Ouvrir une fenêtre du ciel

> Fichier > Enregistrer Sous

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format souhaité]

But : Enregistrer une image depuis PRiSM.

Cette fonction permet d'enregistrer une images sous l'un des formats suivants à choisir :

  • Format CPA
  • Format FITS
  • Format BITMAP
  • Format JPEG
  • Format JPEG
  • Format GIF
  • Format Texte
  • Format TIFF
Version Décembre 2006


Fichier / Enregistrer au format CPA

> Fichier > Enregistrer Sous Format CPA

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format compressé PRiSM]

But : Enregistrer depuis PRiSM une image au format CPA.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
SaveCPA

Version


Fichier / Enregistrer au format FITS

> Fichier > Enregistrer Sous Format FITS

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format FITS]

But : Enregistrer depuis PRiSM une image au format FITS et FITS 1D.

La détermination entre les deux types d'images (FITS et FITS 1D) se fait de la façon suivante : si tous les pixels d'une même colonne ont la même intensité, le logiciel déterminera automatiquement que l'image peut être sauvegardée au format FITS 1D.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
SaveFIT


Fichier / Enregistrer au format BMP

> Fichier > Enregistrer Sous Format BITMAP

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format BMP]

But : Enregistrer depuis PRiSM une image au format BMP.

Si on veut pouvoir utiliser une image comme papier peint WINDOWS ou si on désire lui apporter quelques modifications sous un autre logiciel de traitement d'images plus classique, il faut sauvegarder l'image au format BMP ( BITMAP ) bien connu. Ce format est un format 8 bits (256 couleurs) qui ne compresse pas l'image. C'est le format natif des images 8 bits sortants des WEBCAM.

PRiSM propose cette option et l'image devient alors lisible sous n'importe quel logiciel de traitement.

Le format BMP n'altère pas la qualité de l'image, mais il y a quand même un gros défaut à ce procédé : Les images BMP prennent toujours beaucoup de place. Si cette image est destinée à être placée sur une page WEB, on peut imaginer le temps d'importation ... Il vaut mieux dasn ce cas se diriger vers un format type GIF ou JPEG.

En ce qui concerne la gestion des images BMP sous PRiSM, elles ne peuvent pas subir le traitement habituel possible sur les images CPA. Cependant, il y a une possibilité :

On transforme une image BMP monochrome ou trichrome en image CPA respectivement monochrome et trichrome ! L'image CPA trichrome prendra, certes, plus de place sur le dique dur que l'image BMP couleur. Mais, au moins, on pourra lui faire subir des transformations et analyses comme sur toutes images en format CPA. Pour transformer une image BMP en CPA, aller dans le menu "Fichier / Importer BMP en CPA".

Une image BMP monochrome sera importée suivant une image CPA monoplan; par contre, les images couleurs seront importées suivant une image CPA sur trois plans : le plan R, le plan V et le plan B ( voir la représentation d'une image couleur ).

On peut alors traiter l'image comme une image trichrome à part entière ( analyse, transformations, 3 seuils de visualisation en R V et B ... ). Il faut quand même noter que les images BMP sont sauvegardées sous 256 couleurs et quand on les transforme en CPA, on a 256 pas codeurs, c'est-à-dire pas suffisamment de pas pour réaliser une analyse correct des images. C'est pour celà qu'il vaut mieux sauvegarder les images trichromes au format CPA.

ATTENTION : Il faut se méfier de ce genre d'opération sur des images dont on ne connait pas la provenance; en effet, l'image "couleur" peut tout simplement être une image monochrome en fausses couleurs et dans ce cas ... il n'y a pas plus bête qu'un ordinateur !

En conclusion, il est conseillé de n'utiliser cette fonction que pour les images déjà monochromes sous le format BMP, bien qu'il y aura toujours une perte d'information importante au niveau des pas codeurs

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
SaveBMP

Nov. 2005


Fichier / Enregistrer au format JPEG

> Fichier > Enregistrer au Format JPEG

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format JPEG]

But : Enregistrer depuis PRiSM une image au format JPEG.

Lorsqu'on veut placer une image sur une page WEB, il faut s'assurer que cette image prenne le moins de place possible pour que la durée d'importation ne soit pas trop longue. Le format BITMAP est alors mal adapté car ne compresse pas les images. Il existe actuellement deux types de formats qui compressent les images et qui sont compatibles avec les navigateurs internet : les formats GIF et JPEG. Le format GIF est un format compressé 8 bits (256 couleurs) très adapté au WEB : les images 16 bits devront alors être compressée en 8 bits (double dégradation)! Le format JPEG est nettement plus pratique car il permet de compresser les images à volonté.

Cependant, attention, il y a le revers de la médaille : plus une image va être compressée, moins elle va prendre de place mais plus elle va être "altérée". Le logiciel PRiSM nous laisse le choix de la qualité de la compression :

Changer la valeur de la compression | Choisir la qualité de la compression désirée
Changer la valeur de compression | Choisir la qualité de la compression désirée

Plus ce coefficient va être élevé, moins la compression va être faible mais plus l'image restera belle. L'expérience montre que, suivant les images, on peut choisir un coefficient de compression entre 40 et 50 sans altérer de façon importante les images.

A noter qu'une image au format JPEG peut-être ouverte sous PRiSM et sera lue comme dans un programme de traitement d'images "classique". Cependant, ceci ne donne pas accès au fonction de traitement spécifiques de PRiSM.

Afin de pouvoir traiter l'image JPEG comme une image CPA, il est nécessaire d'importer l'image au format CPA grâce à la fonction réservée dasn le Menu "Fichier / Importer / JPEG vers image traitable". A ce moment, toutes les fonctions de traitement des images trichromes seront alors disponibles en gardant à l'esprit que l'image provient d'une image compressée et donc, de valeur scientifique médiocre.

Exemple d'application :

Considérons l'image couleur de l'atlas du Pises-Atlas : M42 en CCD couleur au T250. Cette image est au format BMP ( comme la majorité des images couleurs de l'atlas ). Notons que PRiSM gère le format CPA trichrome en sauvegardant les 3 images RVB séparemment dans un seul fichier compressé ce qui permet de la traiter plus facilement qu'une image couleur au format BMP. Cette image prend 765 Ko au format BMP. Cette taille lassera vite l'internaute qui importera l'image. Il va donc falloir importer l'image sous un format compressé reconnu par les navigateurs internet. On va donc la compresser en JPEG :

Voici un rappel de cette sublime image au format BMP : ( en fait ici en GIF puisque le navigateur ne lit pas directement le BMP; pour retrouver l'image originale, aller dans "Base de Données / Recherche d'un objet" et demander M42 puis sélectionner l'image CCD couleur T250 )

Sublime ... non !

Examinons différentes sauvegarde au format JPEG avec différentes compressions :

JPEG compression 75 :

Qualité de compression 75

L'image, tout en n'ayant pas d'altération apparente ne prend plus que 23,9 Ko. Un gain de place dans un rapport de 32 ! Evidemment, il n'est pas question de faire un zoom sur cette image sinon les défauts apparaîtront tout de suite.

JPEG compression 50 :

Qualité de compression 50

Là encore, l'image est "regardable" et ne prend plus que 14,6 Ko. Encore mieux.

JPEG compression 30 :

Qualité de compression 30

Les premiers défauts commencent à apparaître à ce coefficient de compression. L'image ne prend plus que 10,7 Ko et s'importe en 2 ou 3 secondes seulement. Certaines images monochromes de champ d'étoiles donnent déjà des images déplorables à ce coefficient. A tester suivant les images !

JPEG compression 15 :

Qualité de compression 15

Même si elle ne prend plus que 5,4 Ko, il est impossible de présenter une telle image sur le WEB. Autant ne rien présenter. On se croirait devant une image de référence extraite du Realsky ... !

JPEG compression 5 :

Sans commentaire.

On voit donc qu'un coefficient entre 40 et 50 est le mieux adapté; ceci permet quand même de réduire considérablement la taille d'une image.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
SaveJPG

Nov. 2005


Fichier / Enregistrer au format GIF

> Fichier > Enregistrer Sous Format GIF

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format GIF]

But : Enregistrer depuis PRiSM une image au format GIF.

Lorsqu'on veut placer une image sur une page WEB, il faut s'assurer que cette image prenne le moins de place possible pour que la durée d'importation ne soit pas trop longue. Le format BITMAP est alors mal adapté car ne compresse pas les images. Il existe actuellement deux types de formats qui compressent les images et qui sont compatibles avec tous les navigateurs internet : les formats GIF et JPEG. Le format GIF est un format compressé 8 bits (256 couleurs) très adapté au WEB : les images 16 bits devront alors être compressée en 8 bits (double dégradation)! Le format JPEG, lui, permet de compresser les images à volonté.

Il est juste conseillé d'utiliser ce format afin de ne sauvegarder que des images basiques, qui ne sont plus destinées à être traitées, mais juste destinées à figurer sur une page WEB !!

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
SaveGIF

Conditions d'activation :
xxxxxxx

Prérequis :
xxxxxxx

Voir aussi :
xxxxxxx

Nov. 2005


Fichier / Enregistrer au format Texte

> Fichier > Enregistrer au Format Texte

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format Texte]

But : Enregistrer depuis PRiSM une image sous forme d'un fichier texte.

Cette fonction permet de sauvegarder un image au format texte. Sont sauvegardés, lignes par linges (correpondantes à l'image), les valeurs des pixels en ADU.
Une image résultante exemple au format texte est fournie ici.

Images supportant cette fonction :
Toutes images

Décembre 2006


Fichier / Enregistrer au format TIFF

> Fichier > Enregistrer Sous Format TIFF

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format TIFF]

But : Enregistrer depuis PRiSM une image au format TIFF.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
xxxxx


Fichier / Enregistrer au format RAW

> Fichier > Enregistrer Sous Format RAW

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format RAW]

But : Enregistrer depuis PRiSM une image au format RAW.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
Aucune


Fichier / Enregistrer au format PNG

> Fichier > Enregistrer Sous Format PNG

Lancement : Menu [Fichier] > [Enregistrer Sous] > [Format PNG (16 bits)]

But : Enregistrer depuis PRiSM une image au format PNG au format 16 bits.

Le format PNG (Portable Network Graphics) est un format de fichier graphique bitmap.

Dans PRiSM, le format PNG permet de stocker des images en noir et blanc (16 bits par pixels de profondeur de codage). La compression proposée par ce format est une compression sans perte (lossless compression) 5 à 25% meilleure que la compression GIF.

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
Aucune

Mars 2008


Fichier / Enregistrer Configuration dans base de registre

> Fichier > Enregistrer configuration du logiciel dans la base de registre

Lancement : Menu [Fichier] > [Configuration du logiciel] > [Enregistrer configuration du logiciel]

But : Sauvegarder la configuration actuelle du logiciel PRiSM dans la base de registre.

Cette fonction permet de sauvegarder tous les paramètres définis dans le logiciel, que ce soit paramètres de traitement, d'acquisition ou de carte du ciel. Une fois effectué, l'enregistrement est confirmé.

La configuration est sauvegardée

La sauvegarde a lieu dans la base de registre WINDOWS, au niveau de la clé : "\HKEY_CURRENT_USER\Software\Prism\.......".

Un extrait de la base de registre
Nov 2009


Fichier / Sauver la configuration du logiciel dans un fichier

> Fichier > Sauver la configuration du logiciel dans un fichier

Lancement : Menu [Fichier] > [Configuration du logiciel] > [Sauver la configuration du logiciel dans un fichier]

But : Enregistrer les informations de la base de registre dans un fichier.

Une fenêtre WINDOWS s'ouvre pour indiquer le chemin de création du fichier de sauvegarde.

Attention : contrairement à ce que le nom de famille du fichier créé le laisserait supposer, ce fichier n'est pas un fichier de base de registre "classique" et doit donc être importé à partir du menu [Fichier] > [Configuration du logiciel] > [Charger une configuration depuis un fichier]

Nov 2009


Fichier / Charger une configuration depuis un fichier

> Fichier > Charger une configuration depuis un fichier

Lancement : Menu [Fichier] > [Configuration du logiciel] > [Charger une configuration depuis un fichier]

But : Charger les informations de la base de registre depuis un fichier.

Une fenêtre WINDOWS s'ouvre pour indiquer le chemin de lecture du fichier de sauvegarde.

Attention : contrairement à ce que le nom de famille du fichier créé le laisserait supposer, ce fichier n'est pas un fichier de base de registre "classique" et doit donc être importé exclusivement à partir de cette fonction.

Nov 2009


Fichier / Réinitialiser les numéro de produit - clef

> Fichier > Réinitialiser les numéro de produit - clef

Lancement : Menu [Fichier] > [Configuration du logiciel] > [Réinitialiser le numéro de produit et la clef d'enregistrement]

But : Réinitialiser l'enregistrement du logiciel

Le menu [Aide] > [A propos de ce logiciel] permet d'accéder aux informations d'enregistrement du logiciel :

La configuration est sauvegardée

L'utilisateur, pour le passage par exemple d'une version LIGHT à une version COMPLETE, peut vouloir réinitialiser ses informations d'enregistrement. Ce menu mène à la fenêtre de confirmation suivante :

Un extrait de la base de registre

Après redémarrage du logiciel, les informations sont effacées.

Nov 2009


Fichier / Entête d'une image

> Entête d'une image

Lancement : Barre d'icônes :

Cet entête est celui d'une image ouverte dans PRiSM. C'est l'entête par défaut des images au format CPA.
Beaucoup de paramètres sont fournis automatiquement à partir d'autres paramètres (pour éviter à l'utilisateur de faire les calculs) et pour rappeler les opérations qui ont été effectués sur l'image. Ces deux derniers types ne seront donc pas sauvegardés dans l'entête FITS d'une image.

Sélectionner un onglet

Onglet Général

  • Chemin : Chemin complet où est sauvegardée l'image.

  • Paramètres de l'image : sont indiqués la largeur, la hauteur, la taille sur le disque ainsi que le codage de l'image (entier / réel, monochrome soit nbre de plan à 1 / trichrome soit nbre de plan à 3)

  • Epoque de la prise de vue : Sont indiqués la date du début de la pose, la durée de la pose et le nom éventuel de l'objet si ce dernier a été complété avant la sauvegarde de l'image. Sont calculés automatiquement les paramètres de milieu de pose de l'image (érécupérables dans le presse papier àpartir du bouton "copier").

  • Type de sauvegarde : Il est fourni la version de PRiSM à partir de laquelle l'image a été créée (important pour les debogueurs) ainsi que la place restante dans la zone réservée à l'entête (important pour le programmeur).

Onglet Prise de vue

L'onglet Prise de vue
  • Telescope : Donne le nom du telescope utilisé, son diamètre, sa focale et calcule son rapport F/D. Ces renseignements sont remplis automatiquement à l'acquisition si les renseignements de l'entête des images ont été complétés lors de la déclaration de la caméra (Menu : Caméra / Configuration ou à partir de l'onglet "Entête" du panel d'acquisition).

  • Filtre : Donne les renseignements sur le filtre utilisé si ces renseignements ont été fournis. Il sont complétés automatiquement à l'acquisition si les renseignements de l'entête des images ont été complétés lors de la déclaration de la caméra (Menu : Caméra / Configuration ou à partir de l'onglet "Entête" du panel d'acquisition).

  • Mode TDI : Indique si le mode TDI a été utilisé ainsi que dans ce cas le temps de lecture d'une ligne.

  • Caméra CCD : Divers renseignements sur la caméra (dont certains essentiels) sont complétés. Si les images ont été prise avec une caméra connectée à PRiSM, la plupart des paramètres intrinsèques au capteur sont remplis automatiquement. Le paramètre de conversion doit être rempli par l'utilisateur mais peut être fixé grâce aux réglages d'entêtes à la configuration de la caméra. La température du CCD est remplie automatiquement pour les caméras avec capteur de température. Si un focuser a été déclaré sous PRiSM, la position de ce dernier sera automatiquement complétée à l'acquisition.

Onglet Astrométrie / Photométrie

  • Alpha / Delta : Ce sont les coordonnées approximatives du centre de l'image. La philosophie du programme veut que même si l'étalonnage a été effectué, ces coordonnées ne sont pas remises à jour. Ces coordonnées sont complétées automatiquement à l'acquisition de l'image si des codeurs (ou télescope) ont été connectés durant l'acquisition.

  • Seeing : Ce paramètre est à compléter par l'utilisateur image par image avant sauvegarde.

  • Masse d'air / Hauteur / Azimuth : ces paramètres sont déterminés automatiquement en fonction des coordonnées et de la date de prise de vue de l'image. Les boutons "copier" servent à copier une valeur dans le presse-papier.

  • Echelle X et Y : ces paramètres sont déterminés automatiquement à partir de la focale du telescope utilisé ainsi que la taille des pixels du capteur.

  • Champ X et Y : dimension du champ sur l'image en fonction de la focale ainsi que des hauteur/largeur de l'image. Ce paramètre est déterminés automatiquement.

  • Orientation du champ : Permet de définir l'orientation du capteur. Cette notion d'angle est décrite dans le tutorial sur l'orientation d'une caméra CCD.

  • Repère direct : Le repère est direct quand les directions se succèdent dans le sens NORD -> EST -> SUD -> OUEST lorsque l'utilisateur tourne dans le sens trigonométrique (sens des aiguilles d'une montre). Ceci correspond, lorsque le capteur est virtuellement redressé, à une direction NORD en haut et une direction EST à gauche. Voir le tutorial sur l'orientation d'une caméra CCD.

  • Etalonnage astrométrique / photométrique : ces cases sont cochées si une de ces opérations a été effectuée sur l'image et si l'image a été sauvegardée après l'opération. Dans le cas d'un étalonnage photométrique réussi, les valeurs de référence photométriques retenues sont indiquées.

  • Lieu : Sont indiqués divers renseignements sur le lieu où été effectué l'image. Ces renseignements sont remplis automatiquement à l'acquisition si les renseignements de l'entête des images ont été complétés lors de la déclaration de la caméra (Menu : Caméra / Configuration ou à partir de l'onglet "Entête" du panel d'acquisition).

Onglet Commentaires

  • Lignes de caractères : Possibilité d'écrire 4 lignes de 256 caractères.

  • Valeurs utilisateur : Possibilité de stocker 3 valeurs réelles pour l'utilisateur

Onglet Météo extérieure

Cet onglet permet de stocker automatiquement les informations météo récupérées par PRiSM. Il faut qu'une station météo soit connecté à PRiSM durant l'enregistrement de l'image pour que cette entête soit complétée.

Onglet Spectro

  • Informations approximatives : Ces renseignements sont utiles pour l'étalonnage automatique à partir d'un spectre de référence du néon. Ces valeurs supposent que la calibration est linéaire. Dans le cas où ce n'est pas vrai, il faut adapter ces valeurs afin que la calibration réussisse. Ces renseignements sont remplis automatiquement à l'acquisition si les renseignements de l'entête des images ont été complétés lors de la déclaration de la caméra (Menu : Caméra / Configuration ou à partir de l'onglet "Entête" du panel d'acquisition).

  • Spectrographe : Renseignement sur la résolution du réseau et sur le nom du spectrographe. Ces renseignements sont remplis automatiquement à l'acquisition si les renseignements de l'entête des images ont été complétés lors de la déclaration de la caméra (Menu : Caméra / Configuration ou à partir de l'onglet "Entête" du panel d'acquisition).

    • PRiSM v7.xx.xx -> :
  • Information de calibration : La case à cocher est cochée si la calibration a dejà été effectuée. Dans ce cas, les paramètres de calibration sont différents de zéros. La calibration autorise une distorsion du spectre à l'ordre 4 ce qui est plus que suffisant dans la plupart des cas.

  • Information de normalisation : Si le spectre a été normalisée au sens de l'ajustement de l'échelle à 1 (=scaling en anglais). Dans ce cas, les longueurs d'onde extrêmes qui ont permis le calcul du changement d'échelle sont indiquées dans la fenêtre en dessous.

  • Information de correction telluriques : Si les raies de l'eau de l'eau ont été enlevées au spectre (H2O de l'atmosphère).

  • Information de correction héliocentrique : Si le spectre a été corrigé du mouvement de rotation de la Terre autour du Soleil -> position dans le référentiel héliocentrique.

Images supportant cette fonction :
Toute image ouverte dans PRiSM

Images de test :
Une image CPA spectrale

Fonction(s) Script associée(s):
Liste des fonctions sur l'imformations sur les images.

Révision Novembre 2007


Fichier / Voir une entête FITS

> Fichier > Entête FITS

Lancement : Menu [Fichier] > [Voir entête FITS]

But : Lire les paramètres d'une entête FITS.

Cette commande est utilisée pour visualiser et éventuellement modifier une entête FITS. A l'ouverture et après avoir sélectionner le chemin d'une image FITS, le panel a l'apparence suivante :

Exemple d'ouverture d'une entête FITS
  • Le bouton [image] permet de copier l'intégralité de l'entête dans le presse-papier windows.

Pour sélectionner une ligne de l'entête à modifier, il suffit de cliquer dessus. La ligne vient alors s'insérer dans la ligne dans le bas de la fenêtre ...

La ligne est sélectionnée
  • Le bouton [image] permet de modifier physiquement et immédiatement l'entête en fonction de la correction apportée à la ligne sélectionné.

  • Le bouton [image] permet d'insérer une nouvelle ligne dans l'entête de l'image. La sauvegarde de la nouvelle entête ne s'effectuera qu'après appui sur le bouton [OK].

  • Le bouton [image] permet de supprimer la ligne sélectionnée. La sauvegarde de la nouvelle entête ne s'effectuera qu'après appui sur le bouton [OK].

Images exemple :
exemple

Images supportant cette fonction :
Images FITS

Fonction(s) Script associée(s):
Toutes les fonctions scripts lisant l'entête d'une image

Conditions d'activation :
Connaître le chemin pour atteindre l'image !

Voir aussi :
Entête CPA

Sept 2007


Fichier / Convertir un FITS Cube

> Fichier > Convertir un FITS Cube

Lancement : Menu [Fichier] > [Convertir FITS Cube vers série d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Séparer les différents paramètres d'une image dont Naxis3 est supérieur à 0.

De façon générale, dans un fichier FITS, on a :

  • NAXIS donne la dimension de l'image.
  • NAXIS1 Donne la dimension de la première dimension de l'image
  • NAXIS2 Donne la dimension de la seconde dimension de l'image
  • NAXIS3 Indique le nombre d'images qui suivent. En général, ce paramètre est présent pour les images couleurs et alors, la valeur de ce paramètre vaut 3 (les images rouge, verte et bleue sont présente dans le fichier image).

En construction

Images supportant cette fonction :
xxxxx

Fonction(s) Script associée(s):
xxxxx

Version


Fichier / Remplir l'entête de fichiers images

> Fichier > Remplir l'entête de fichiers images

Lancement : Menu [Fichier] > [Remplir l'entête de fichiers images avec ...]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Modifier en série l'entête CPA d'images.

Les images au format .CPA sont dotées d'un entête contenant diverses informations techniques.

Cette fonction permet de modifier le contenu d'entêtes d'images ou d'une seule image.
Au lancement de cette fonction, la fenêtre suivante s'ouvre :

Il faut dans chaque onglet sélectionner les changement à effectuer. Il est possible, en cochant la case correspondante, de ne faire que simuler le changement de l'entête. Un bouton permet de sélectionner l'ensemble des fichiers.

L'onglet informations importantes | L'onglet Astrometrie
L'onglet CCD/Telescope | L'onglet Spectro

Le dernier onglet permet de passer d'images 16 bits à 32 bits et vice-versa. Il faut faire attention lors du passage de 32 bits à 16 bits à la troncature du réel à l'entier le plus proche. Ceci peut avoir plusieurs conséquences : les images avec des pixels de très forte intensités seront écrêtées et les images qui, après traitement, ont des pixels réels dont la différence d'information se situe dans la partie fractionnaire de l'intensité du pixel seront transformées en image de plage de lumière uniforme !

Le changement ici est activé dans le but de faire apparaître les sous menus

Dans tous les cas, et au vu de la taille des mémoires mortes à l'heure actuelle, on préfèrera travailler avec des images au format réels.

Images exemple :
Prendre des images exemples d'autres fonctions

Images supportant cette fonction :
Images CPA exclusivement

Fonction(s) Script associée(s):
Toutes les fonctions scripts écrivant dans l'entête d'une image

Conditions d'activation :
Connaître le chemin pour atteindre les images !

Voir aussi :
Modifier une entête FITS

Sept 2007


Fichier / Créer un fichier AVI

> Fichier > Créer un fichier AVI

Lancement : Menu [Fichier] > [Créer une animation AVI]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Créer une nouvelle animation AVI à partir d'une série d'image.

Voir la vidéo correspondante.

Fonction(s) Script associée(s):
Aucune pour le moment

Décembre 2010


Fichier / Ajouter Script

> Fichier > Ajouter Script

Lancement : Menu [Fichier] > [Ajouter script]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Ajouter un script dans la base des scripts.

Cette fonction permet d'ajouter un script dans le menu "Fichier" du logiciel.

Au lancement de cette fonction, la fenêtre suivante apparaît, permettant de sélectionner les scripts à ajouter au menu "Fichier" :

Lorsqu'un script est ajouté, il apparait dans le menu [Fichier] > [Scripts enregistrés]

Ici, un seul script a été enregistré

Aide sur les scripts :
ici

Voir aussi :
Supprimer Script
Exécuter Script
Exécuter Script (Mode Debug)
Scripts enregistrés

Octobre 2007


Fichier / Supprimer Script

> Fichier > Supprimer Scripts

Lancement : Menu [Fichier] > [Supprimer Script]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : enlever un script préalablement ajouté au menu [Ajouter un script au menu].

Au lancement, la fenêtre suivante s'ouvre, permettant de sélectionner le ou les script(s) à supprimer du menu "Fichier"

Aide sur les scripts :
ici

Sept 2007


Fichier / Exécuter script

> Fichier > Exécuter un script

Lancement : Menu [Fichier] > [Exécuter script]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Exécuter un script.

Cette fonction permet d'exécuter un script.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de sélectionner le script à exécuter.

Si le script a déjà été ajouté au menu [Fichier] > [Scripts enregistrés], il suffit de cliquer directement sur ce dernier.

Aide sur les scripts :
ici

Voir aussi :
Scripts enregistrés

Octobre 2007


Fichier / Exécuter script en mode débug

> Fichier > Exécuter script en mode débug

Lancement : Menu [Fichier] > [Exécuter script (mode débug)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Exécuter un script en ouvrant la fenêtre de débuggage.

Attention : Page non revue depuis la version 5

Cette fonction permet d'exécuter un script tout en contrôlant son exécution.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de sélectionner le script à exécuter, accompagnée d'une fenêtre de debug.

la fenêtre d'exécution classique

Si le script n'est pas lancé en mode debug, il reste possible d'ouvrir la fenêtre de debuggrace à l'icone [image]. Pour se donner le temps d'ouvrir cette fenêtre à tout moment, on pourra rajouter l'instruction " PAUSE " au début du programme pour que le programme s'arrête momentanément, on pourra alors ouvrir le déboggeur et s'en servir ou ignorer cette commande et relancer l'exécution du programme à partir de l'icône [image].

Une fois le déboggeur ouvert, on peut remarquer qu'il se compose de trois parties principales :

  • La série des 3 boutons désormais classiques : " Exécuter ", " Pause " et " Stop ".
  • La fenêtre de renseignements sur toutes les variables utilisées ( numérique et de chaînes, mais pas de variables d'images ou graphiques) avec leur nom et en face la valeur prise par ces dernières ( il n'y aura que les variables définies par défaut qui apparaîtront à l'ouverture du débggeur ... comme Pi ).
  • La fenêtre de commandes qui retrace toutes les lignes du programme.
On rappelle qu'il est impossible, à l'heure actuelle, de modifier le programme à partir de la fenêtre du déboggeur.

L'exécution du programme peut être vue à partir de ce dernier bien que les résultats dus à l'instruction " PRINT " s'affiche dans la fenêtre d'exécution classique. En voici la description des différents éléments :

  • Le bouton [image] permet de lancer le programme à partir du niveau où se situe le pointeur rouge
  • Pour exécuter le programme pas à pas, il suffit d'appuyer à chaque fois sur le bouton pause [image]. Les lignes du programme seront exécutée une à une. Les résultats des variables seront fournis au fur et à mesure dans la fenêtre prévue à cet effet et les renseignements de liaison avec l'utilisateur ( commande " PRINT " ) seront également inscrits dans la fenêtre au fur et à mesure.
  • Pour faire repartir le programme , il suffit d'appuyer sur le bouton " Start " :
  • On peut vouloir exécuter un bloc de fonctions sans devoir appuyer sur le bouton " Pause " à chaque instant. Par contre, on peut désirer s'arrêter à un instant bien précis. Il suffit pour celà de placer ce qu'on appelle " un point d'arrêt " dans le déboggeur.
    A cette fin, repérer la ligne à la fin de laquelle on désire que le programme s'arrête ( le programme s'arrêtera après l'exécution de cette ligne ). Cliquer une fois sur les commandes de cette ligne et un bouton rouge apparaît à gauche de la ligne : . Ce bouton indique que cette ligne sera désignée comme point d'arrêt de l'exécution du programme. En appuyant alors sur le bouton " Start ", le programme s'exécutera jusqu'à rencontrer ce bouton, auquel cas il arrêtera son exécution à la fin de la ligne.
    Pour poursuivre le programme, appuyer de nouveau sur le bouton " Start " et le programme continuera jusqu'au prochain point d'arrêt ... ou jusqu'à la prochaine erreur qui aura pour effet de vider alors complètement le déboggeur de son contenu.
  • Sinon, le carré noir permet de tout arrêter :

Durant l'exécution du Script, au fur et à mesure que les fonctions sont exécutées, le déboggeur affiche les variables numériques et de chaînes utilisées, ainsi que leur valeur numérique ou de caractères en face. Attention : les variables images et les variables graphiques ne sont pas affichées.

Remarque :
L'utilisation du déboggeur ralenti un peu l'exécution du script ... même si l'exécution a lieu d'un trait.

Aide sur les scripts :
ici

Voir aussi :
Supprimer Script
Exécuter Script

Version


Fichier / Scripts enregistrés

> Fichier > Scripts enregistrés

Lancement : Menu [Fichier] > [Scripts enregistrés]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de sélectionner les scripts ajoutés.

Ici, un seul script a été enregistré

Aide sur les scripts :
ici

Voir aussi :
Supprimer Script
Ajouter Script

Octobre 2007


Fichier / Fermer

> Fichier > Fermer

Lancement : Menu [Fichier] > [Fermer]

But : Fermer un élément du programme PRiSM.

Cette fonction permet de fermer une image ou une fenêtre du ciel préalablement sélectionnée.

Images supportant cette fonction :
Tout format d'image ou de carte du ciel

Fonction(s) Script associée(s):
Close, ClearImgWindows

Conditions d'activation :
Une image ou une fenêtre du ciel doit être ouverte.

Nov. 2005


Fichier / Quitter PRiSM

> Fichier > Quitter

Lancement : Menu [Fichier] > [Quitter]

But : Quitter le programme.

Version Octobre 2007


Edition / Annuler

> Edition > Annuler

Lancement : Menu [Edition] > [Annuler]

Cette fonction permet d'annuler le dernier traitement effectué sur une image. Attention, cette fonction n'est pas valide pour tous les traitements

Pour pouvoir l'utiliser, il faut avoir préalablement cocher l'option [Activer "Défaire" la dernière opération] dans le menu [Options]

Octobre 2007


construction

En construction


Edition / Copier image

> Edition > Copier une image

Lancement : Menu [Edition] > [Copier une image]

Cette fonction copie l'image courante dans le presse-papier, en vue d'une récupération dans un autre logiciel de traitement d'image par exemple.

Fonction script associée :
Duplicate

Voir aussi
Coller une image

Version Octobre 2007


Edition / Coller image

> Edition > Coller une image

Lancement : Menu [Edition] > [Coller une image]

Cette fonction permet d'ouvrir dans PRiSM une image contenue dans le presse-papier. Cette fonction ne fonctionne que pour des images copiées depuis PRiSM (image ouverte dans le logiciel).

Les images nouvellement crées ne sont ni traitables ni modifiables.

Fonction script associée :
Duplicate

Voir aussi
Copier une image

Version Octobre 2007


Edition / Effacer une image du presse-papier

> Edition > Effacer une image du presse-papier

Lancement : Menu [Edition] > [Effacer image du presse-papier]

Cette fonction permet d'effacer le contenu du presse-papier.

Fonction script associée :
Close
ClearImgWindows

Version Octobre 2007


Prétraitement / Moyenne identique entre images

Prétraitement > Moyenne identique entre images

Lancement : Menu [Prétraitements] > [Moyenne identique entre images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction s'applique à une série d'images, et multiplie chacune d'elle par un coefficient de façon à ce que toutes les images aient la même moyenne.
La moyenne identique remet donc un groupe d´images à la même intensité moyenne, en vue, par exemple, d´une Pile Médiane ou d´une Addition Sigma-Kappa.
Le principe mathématique est le suivant : Le logiciel prend la moyenne de chacune des images et mets les images à la même moyenne à l'aide d'un coefficient multiplicateur. L'image de base est la première image dans la boîte de dialogue.

Au lancement de la fonction, la boîte de dialogue suivante apparaît :

L´icône [image] permet de sélectionner le répertoire où se trouvent les images

Les images doivent avoir un même préfixe et doivent être numérotées consécutivement. L'index de la première image de la série et de la dernière image de la série doivent être indiqués dans les champs correspondants.

Une des images (l'image de référence) ne sera pas modifiée (sa moyenne restera la même), il faut indiquer son index dans le champ "Image de référence"

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
N'importe quelle série d'images !

Fonction script associée :
SameAverage

Version Janvier 2008


Prétraitement / Fond du ciel identique

Prétraitement > Fond du ciel identique

Lancement : Menu [Prétraitements] > [Fond du ciel identique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction s'applique à un ensemble d'image en multipliant chacune d'elle par un coefficient de façon à ce que toutes les images aient une même valeur de fond du ciel.
Le principe mathématique est le suivant : Le logiciel cherche le fond de ciel de chacune des images (parties des images entre les étoiles). Un coefficient multiplicateur est alors appliqué aux images, l'image de référence étant celle apparaissant en premier dans la boite de dialogue.

Au lancement de la fonction, une boîte de dialogue apparaît :

L'icône [image] permettant de sélectionner le répertoire où se situent les images à traiter.

La première image de la liste (l'image de référence) ne sera pas modifiée donc son fond du ciel restera le même. Le fond de ciel des autres images sera adapté à celle là.

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
N'importe quelle série d'images !

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Pile Ecart-Type

Prétraitement > Opérations sur une pile d'images

Lancement : Menu [Prétraitements] > [Opérations sur une pile d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Ce panel réunit plusieurs anciennes fonctions du menu "Prétraitements" agissant sur une pile d'image. Chacune des opérations est décrite ensuite point par point.

Pile médiane

Cette fonction s'applique sur une série d'image et calcule la médiane de cette série.

Description de la fonction :

Un exemple de médiane de 3 images de 2x2 pixels est donné ci-dessous :

Image 1 |  | Image 2 |  | Image 3 |  | Médiane
370 | 275 | 395 | 380 | 420 | 375 | 395 | 375
380 | 390 | 450 | 385 | 365 | 370 | 380 | 385

On remarque dans l´exemple ci-dessus que chaque image contient un pixel de valeur aberrant. L´image médiane permet d´éliminer les valeurs hors normes.

Cette méthode est donc plus efficace pour éliminer des valeurs discordantes qu´une simple Pile moyenne. Cette fonction est très utile pour l´obtention d´images de NOIR, d´OFFSET mais surtout de la P.L.U. En effet lors du prétraitement des images, l´obtention de la P.L.U., avec la Pile moyenne de plusieurs images élémentaires, peut donner des résultats médiocres. Il suffit effectivement qu´il reste quelques étoiles sur une des images pour que celles-ci se retrouvent sur le résultat de la moyenne. C'est d'ailleurs cette fonction qui est utilisée lors de la création de master : [Prétraitement] > [Master]

Par convention, le temps de pose pour l'image finale est celui de la première image. Il sera cependant indiqué, dans les commentaires sur l'image, que l'image résultante est une image qui provenant de " X poses T1 +s + T2 s + T3 s + ... ".

Après avoir sélectionné les images, le calcul de la médiane se lance en cliquant sur le bouton [OK].

Il est conseillé de vérifier que les images ont la même moyenne. Si les images n'ont pas toutes la même moyenne, alors utilisez la fonction [Prétraitement] > [Moyenne Identique] avant de lancer le calcul de la médiane.

Le calcul de la médiane des images est tracé dans la fenêtre de suivi :

L'image finale s'affiche sous le nom de la dernière image de la série.

Il est recommandé de sauvegarder cette image finale avec la fonction [Fichier] > [Enregistrer sous].

Diverses applications :

Lors du prétraitement des images, l'obtention d'un bon " flat-field " avec la moyenne simple de plusieurs " flat-field" élémentaires peut donner des résultats médiocres. En effet, il suffit qu'il reste quelques étoiles sur un des "flat-field" pour que celle-ci se retrouvent sur le résultat de la moyenne des " flat-field".
La moyenne par pile médiane permet d'enlever ces résidus ( étoiles, trace de rayons cosmiques ) qui se trouvent sur une image et pas sur les autres.
Ceci évite la pollution de la moyenne entre les images par des éléments présents seulement sur une seule image.
Cette fonction est aussi utile pour éliminer des parasites ( rayons cosmiques ) entre plusieurs images.

Pile moyenne

Cette fonction calcule, pixel par pixel, la moyenne d'une série d'images (ou la "simple" somme des intensités si l'option de normalisation n'est pas cochée).

En ce qui concerne le temps de pose de l'image résultante, il a été décidé d'indiquer un temps de pose qui est la somme de tous les temps de pose. Il sera cependant indiqué, dans les commentaires sur l'image, que l'image résultante est une image qui provenant de " X poses T1 +s + T2 s + T3 s + ... ".

Normaliser la somme : Cocher cette option si on désire réaliser la moyenne des intensités des images pour un pixel donné. Dans le cas contraire, PRiSM fera la somme des intensités des images pour un pixel donné sans diviser par le nombre d'image.

Soustraire une valeur : permet de soustraire une intensité en ADU à chaque image avant d'en réaliser la moyenne (ou la somme si la précédente option n'es tpas cochée).

Pile minimum

Cette fonction garde, pixel par pixel, le minimum en intensité d'une série d'images.

Comme indiqué, il faut que les images aient la même moyenne. Si les images n'ont pas toutes la même moyenne, alors utilisez la fonction [Prétraitement] > [Moyenne Identique] avant de lancer le calcul.

Pile maximum

Cette fonction garde, pixel par pixel, le maximum en intensité d'une série d'images.

Comme indiqué, il faut que les images aient la même moyenne. Si les images n'ont pas toutes la même moyenne, alors utilisez la fonction [Prétraitement] > [Moyenne Identique] avant de lancer le calcul.

Pile écart-type

Cette fonction calcule, pixel par pixel, les écart-types d'une série d'images.

Comme indiqué, il faut que les images aient la même moyenne. Si les images n'ont pas toutes la même moyenne, alors utilisez la fonction [Prétraitement] > [Moyenne Identique] avant de lancer le calcul.

Pour rappel, l'écart type d'une série est une grandeur statistique de valeur définie dans la page sur les statistiques.

Pile Sigma-Kappa

En cours de développement ...

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
N'importe quelle série d'images recalées les unes par rapport aux autres !

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Additions et recalages en série

> Prétraitement > Recalage en série d'une pile d'images

Lancement : Menu [Prétraitement] > [Recalage en série d'une pile d'images]

Description : Cette fonction recentre les images les unes par rapport aux autres.

Application : Cette fonction peut avoir une grande utilité dans la diminution du bruit d'une image. En effet, cette fonction permet de compositer des poses d'un même objet avec des temps de poses courts.
En effet, une pose de 9 minutes peut être considérée comme la résultante de 3 poses de 3 minutes. Le rapport signal/bruit est alors meilleur puisque ce dernier augmente comme la racine carrée du nombre d'images additionnées. Le prix à payer est une détectivité plus faible qu'une pose unique de 9 minutes (mais ce qui est détecté ressort mieux !) ... Il n'y a pas de remèdes parfaits !

Attention : l'heure de l'image résultante sera le barycentre des heures, c'est-à-dire l'heure de l'image du milieu dans le cas de l'addition d'un nombre impair d'images.

Au lancement, la fenêtre suivante s'ouvre :

  • L'icône [image] permet de sélectionner le dossier contenant les images à additionner : seul le nom des images est affiché. L'image de référence est la première image sélectionnée. C'est l'image à partir de laquelle toutes les autres images seront recentrées.

  • Le coefficient de normalisation est le coefficient par lequel le résultat de l'addition sera divisé.

  • Type de recentrage :

    Si la case à cocher "Recalage automatique" est cochée, alors la fonction assurera un recalage automatique basé sur les étoiles de l'image, soit en effectuant seulement une translation, soit en combinant une translation et une rotation pour chaque image par rapport à la première de la série.

    Si la case à cocher "Intercorrélation (FFT)" est cochée, la recherche de "pixels communs" entre les images se réalise par une transformée de Fourier interne permettant de localiser les "détails communs" de chaque image. De ce fait, le recalage par intercorrélation est mieux adapté aux images planétaires.

    Enfin pour un recalage "manuel", il est nécessaire de compléter les 2 cases en dessous.

  • Le décalage sur X en pixels par heures est l'indication de la dérive en X, qui peut être indiquée si elle est connue. Cette information n'est nécessaire que pour un recalage manuel.

  • Le décalage sur Y en pixels par heures est l'indication de la dérive en Y, qui peut être indiquée si elle est connue. Cette information n'est nécessaire que pour un recalage manuel.

Le recalage est lancé en cliquant sur le bouton [OK].

Une fenêtre de dialogue permet alors de choisir entre 2 possibilités :

  • Les images recalées remplacent les images d'origine
  • Les images recalées sont enregistrées sous un nom de fichier constitué du nom de l'image d'origine, précédé d'un suffixe.

Dans le cas d'un recalage non automatique les images sont affichées l'une après l'autre, et l'utilisateur est invité à sélectionner une étoile sur l'image, qui permettra à PRiSM de recentrer toutes les images en utilisant cette étoile. Bien entendu, c'est la même étoile qu'il faudra sélectionner sur chaque image !

Images de test :
Images d'étoiles à recaler
Images à recaler manuellement
Images à recaler par intercorrélation.

Images supportant cette fonction :
images RVB ou monochromes

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Avoir un minimum de 3 images à additionner.

Voir aussi :
Addition en série

Décembre 2010


Prétraitement / Addition Sigma-Kappa

> Prétraitement > Addition Sigma-Kappa

Lancement : Menu [Prétraitement] > [Addition Sigma-Kappa]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction s'applique sur une série d'au moins 3 images d'une même région du ciel et permet de les additionner en retirant les objets parasites (Rayons cosmiques, pixels chauds, astéroïdes ...) présents sur une des images et pas sur une autre.

C'est une fonction extrêmement puissante. Elle nécessite :

  • Un minimum de trois images d’un même format et d’une même région du ciel. Un nombre supérieur ne peut être que mieux !
  • Recentrées par la fonction de Recalage en série.
  • Ayant la même moyenne en utilisant si besoin est la fonction de moyenne identique : il est conseillé de prendre comme référence l'image qui a la plus petite moyenne; voir les remarque importante.

Après lancement de cette fonction, la fenêtre suivante s'ouvre :

La fenêtre d'option
  • Normalisation : Case à cocher afin de normaliser l'addition pour ne pas dépasser le codage des valeurs autorisées (0 à 32767 par exemple pour des images en entier 16 bits signés). Cette case n'a plus d'importance pour les images codées en réels.
  • Nombre de sigmas de réjection : Facteur ‘Nbre’ déterminant le rejet des pixels.
  • Valeur Minimum de l’ecart type : Facteur ‘Sigmin’ déterminant le rejet des pixels.
  • Dossier des images : Une boite windows s'ouvre. Sélectionner la série des images à traiter.

L'addition des images se fait alors en cliquant sur le bouton [OK]

Exemples d'utilisation :

Les exemples d'utilisation ne manquent pas ! Avant de considérer un exemple particulier, examinons-en plusieurs :

  • Apparition de rayons cosmiques sur certaines images. Ce n'est pas très drôle surtout si ces images sont à des fins esthétiques ou destinées à être publiées. En général, celà n'arrive pas à toutes les images et ce phénomène reste très localisé (points ou traits fins !). On peut alors choisir un critère très souple : un SigMin de 2000 ou plus suivant l'intensité du rayon.
  • Traversé d'un satellite sur l'image; on obtient une image traversée par une ligne en général de forte intensité. Comme précédemment, un critère très souple peut également être appliqué. Si la trace est trop large et lumineuse et passe sur la partie intéressante de l'image, il vaut mieux "jeter" la prise de vue !
  • Il reste maintenant le cas des petits objets du système solaire. Ce cas va être examiné comme exemple de traitement par la suite.

Description des paramètres :

La connaissance du fonctionnement de cette fonction permet de mieux comprendre le réglage des paramètres.

Cette fonction calcule l’écart-type d’une série de pixels ayant les mêmes coordonnées dans chacune des (n) images de la série. Cette série s’appellera une pile de (n) pixels : (V1, V2, ... Vn)

On calcule, comme critère de dispersion, l’écart type σ pour tous les pixels de mêmes coordonnées sur chaque des n images. On rappelle, à cette fin, les quelques formules mathématiques utiles :

Pour la coordonnée [X,Y] choisie pour la pile, on donne la moyenne des pixels : , la moyenne quadratique : , et on en déduit le nombre σ : . Cette dernière valeur sera multipliée par le paramètre Nbre = "Nombre de sigmas de réjection" pour donner une valeur notée V = σ*Nbre.

Pour illustrer les paramètres à remplir, prenons pour exemple la suite de pixels Vi (101,100,105,104,120) à une coordonnée [X,Y] donnée. Le pixel de la dernière des 5 images, de valeur 120, est celui que l'on voudrait enlever lors de l'addition. Il est volontairement proche des autres pour illustrer les cas de faibles intensités. Pour cette série, on calcule la moyenne valant 106, la moyenne quadratique valant 106,25 soit un écart type σ de 7,24 ADU ...

Premier paramètre : La médiane de la série notée Med vaut Med = 104. SI (Vi - Med) > V (= σ*Nbre) ALORS on écarte la valeur considérée. On voit apparaître ici le caractère atténuateur du paramètre Nbre qui permet d'écarter moins de valeur que ne le ferait le seul calcul de σ. Plus ce paramètre sera proche de 1 et plus la sélection sera sévère. Ici, il ne faudra donc pas dépasser Nbre = 2,2 pour que seul le pixel V5 = 120 puisse être écarté. En contre partie, prendre Nbre = 1 serait à la limite d'écarter la valeur V2 = 100 que l'on ne cherche pas à écarter. Il faut donc faire attention au choix de ce paramètre. Le pixel V5 sera alors remplacé par la moyenne des autres valeurs ce qui sera problématique du point de vue photométrique si une majorité des pixels de la série d'images subissent un tel traitement sur une des images.

Deuxième paramètre : Revenons sur le dernier point en rapport avec le pixel de valeur V2. Le paramètre SigMin (= "valeur minimum de l'écart type") permet de fixer la valeur pour laquelle le paramètre V sera pris en compte tel quel. SI V < SigMin ALORS la valeur de V sera forcément mise à SigMin. Ceci permet d'éviter les "accidents" comme il pourrait arriver ici pour le pixel considéré de l'image n°2 de valeur V2. On fixera cette valeur en fonction de ce qu'on désire faire : elle sera prise d'autant plus importante qu'on ne cherchera pas à écarter des pixels très différents de la médiane, ce qui restera d'autant meilleur d'un point de vue photométrique !

En résumé, on en déduit que plus la valeur du paramètre "Nombre de sigmas de réjection" ou celle de "Valeur Minimum de l’écart type" seront faibles, plus la fonction rejettera un grand nombre de pixels dans les images à empiler.

Lors de l’exécution de la fonction, les points marqués de rouge indiquent les zones de l’image ou au moins un pixel aura été remplacé par la moyenne des autres.

Remarque :
Même avec une moyenne identique pour toutes les images, pour des objets proches de la saturation, il se trouve souvent que la valeur des pixels de même coordonnée peuvent accuser une très grande différence (jusqu'à 5000 ADU). Ces pixels rentreront alors souvent dans le critère de sélection. C'est pour celà qu'il faut choisir un SigMin le plus grand possible, juste ce qu'il faut pour éliminer ce qu'on veut.
Il ne faut donc tout de même pas croire que cette fonction résoud tous les problèmes. Elle a beau être évoluée, elle doit être maniée avec précaution et ne peut pas tout supprimer. Le meilleur champ d'action de cette fonction a lieu lorsqu'on a un phénomène lumineux sur une des images et pas sur les autres. Par contre, on pourra difficilement enlever un objet faible indésirable sans intervenir aussi sur les objets lumineux ce qui peut dénaturer totalement les caractéristiques d'une image !

Utilisation en photométrie :

Quand on fait de la photométrie, il n'est pas très important d'avoir une traînée sur l'image finale à moins que cette traînée intervienne juste à l'endroit de ce qu'on veut mesurer. Cela ne veut pas dire que l'on ne peut pas utiliser cette fonction pour faire de la photométrie mais alors l'essentiel est que le nombre de pixels traités restent fortement minoritaires sur la série d'images. Mais utiliser cette fonction peut être préférable que d'avoir des points photométriquement faux. Deux cas se présentent :

  • Si on n'a pas imposé de normalisation, il n'y a en général aucun problème ! En effet, les étoiles faibles ne présentent pas de grandes différences entre pixels de même coordonnées. Les étoiles de fortes luminosités pourront rentrer dans le critère de sélection mais de toute façon seront saturées sur l'image finale. On pourra donc réaliser une étude photométrique automatique sans crainte.

  • Si on a imposé une normalisation, le phénomène se complique. Voyons-le dans les grandes lignes :

    En réalisant une "moyenne identique", il peut arriver que pour une étoile proche de la saturation dans l'image de référence, cette étoile soit saturée pour certaines poses. Celle-ci pourra (comme les autres) rentrer dans le critère de sélection de correction suivant le SigMin imposé; pire, elle pourra ne plus paraître saturée dans l'image finale puisque la valeur de ces pixels sera la moyenne des pixels non saturés ! Il sera donc possible de faire des études photométriques sur cette étoile, alors que ces dernières seront totalement fausses. Rester donc très vigilent.

    Il ne faut donc pas travailler sur toute étoile saturée dans une des poses car celle-ci peut très bien ne plus apparaître saturée dans l'image finale. Pour détecter les étoiles saturées dans une image, le mieux est de repérer toutes les étoiles saturées des images que l'on additionne. Soit on regarde les étoiles qui semblent brillantes une à une (peut vite devenir fastidieux), soit on réalise une étude photométrique de masse sur toutes les étoiles de l'image et on regarde les étoiles brillantes qui ne sont pas retenues : ce sont des étoiles saturées. Il faudra prendre soin de les saturer soit même sur l'image finale pour que lors d'une analyse photométrique automatique, elles ne soient pas considérée comme des étoiles "normales".

    Pour les étoiles brillantes mais non saturées, il arrive, même après une moyenne identique qu'il y ait de grandes différences entre les pixels de même coordonnée pour chaque image. Ces pixels vont donc répondrent au critère de sélection et seront marqués en rouge. Les étoiles correspondantes ne seront donc pas additionnées "normalement" et ne pouuront donc pas faire l'objet d'une analyse photométrique.

    Ce qui ressort de cette étude est le point suivant : on peut utiliser cette fonction pour faire de la photométrie automatique, mais il faut éviter d'utiliser la "normalisation" sous peine d'avoir des grosses erreurs dans le résultat final !

Exemple d'addition d'images:

On prend une série d'images où il apparait un astéroïde sur chacune des images (attention, ici, les images sont bien évidemment recalées auparavant) ... On veut le faire disparaître en additionnant les images.

le principe est le même lors du traitement de rayons cosmiques ou de passage d'un satellite artificiel.
Un inconvénient des astéroïdes est le plus souvent leur très faible magnitude. Cela oblige à choisir un petit SigMin pour les supprimer et donc de traiter également beaucoup d'étoiles environnantes. Il est donc parfois plus rapide de faire une correction cosmétiques sur les 3 pixels environnants pour supprimer directement l'astéroïde sur chaque image, plutôt que de toucher à la magnitude des autres étoiles. Mais ce n'est pas le cas ici !

Si on fait un blink sur les trois images, on voit la présence de l'astéroïde :

Malgré la description des paramètres ci-dessus, on comprend que l'usage de cette fonction mérite plusieurs essais avec des paramètres différents. Ici, on désire enlever l'astéroïde mais uniquement que lui et on acceptera alors de voir, à haut contraste, la présence des résidus de l'objet à cause des bords, à peine plus lumineux que le fond de ciel. Les paramètres ne seront pas choisis sévèrement. Il a été fait le choix de prendre les valeurs suivantes : SigMin = 150 et Nbre = 1.8, mais il est conseillé à l'utilisateur de tester plusieurs situations. En forçant sur le contraste, on remarque la trace de l'astéroïde sur l'image résultante. Prendre des valeurs plus restrictives est possible mais le nombre de pixels ayant subi une réjection est déjà de 0,83 % de l'image ce qui n'est pas dramatique mais non négligeable (attention à la photométrie !). Le résultat est le suivant :

Feu les astéroïdes !

En conclusion, la fonction Sigma-kappa est une fonction très puissante, mais il ne faut pas croîre qu'elle va résoudre tous les problèmes ( voir l'exemple ci-dessus ). Elle est à manier avce beaucoup de précautions. Il n'y a en général aucun problème avec les rayons cosmiques et passages de satellites. Le problème a lieu lorsque l'on veut faire disparaître des objets errants faibles qui se cheuvauchent d'une image à l'autre.

Images supportant cette fonction :
images RVB ou monochromes

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Avoir un minimum de 3 images à additionner.

Images de test :
Lot de 3 images

Prérequis :
Exemples d'utilisation

Voir aussi :
Addition en série

Version Aout 2006


Prétraitement / Addition avec recalage en série

Prétraitement > Addition avec recalage en série

Lancement : Menu [Prétraitements] > [Addition et recalage en série]

But :Addition d'images en série après un éventuel recalage automatique ou manuel des images entre elles.

Cette fonction fait l'addition, pixel par pixel, d'une série d'images, après les avoir recentrées, si nécessaire, les unes par rapport aux autres.

Application : Cette fonction peut avoir une grande utilité dans la diminution du bruit d'une image. En effet, cette fonction permet de compositer des poses d'un même objet avec des temps de poses courts.
En effet, une pose de 9 minutes peut être considérée comme la résultante de 3 poses de 3 minutes. Le rapport signal/bruit est alors meilleur puisque ce dernier augmente comme la racine carrée du nombre d'images additionnées. Le prix à payer est une détectivité plus faible qu'une pose unique de 9 minutes (mais ce qui est détecté ressort mieux !) ... Il n'y a pas de remèdes parfaits !

Attention : l'heure de l'image résultante sera le barycentre des heures, c'est-à-dire l'heure de l'image du milieu dans le cas de l'addition d'un nombre impair d'images.

Après le lancement de cette fonction, la boîte de dialogue suivante apparaît :

  • L'icône [image] permet de sélectionner le dossier contenant les images à additionner : seul le nom des images est affiché. L'image de référence est la première image sélectionnée. C'est l'image à partir de laquelle toutes les autres images seront recentrées.

  • Le coefficient de normalisation est le coefficient par lequel le résultat de l'addition sera divisé.

  • Type de recentrage :

    Si la case à cocher "Recalage automatique" est cochée, alors la fonction assurera un recalage automatique basé sur les étoiles de l'image, soit en effectuant seulement une translation, soit en combinant une translation et une rotation pour chaque image par rapport à la première de la série.

    Si la case à cocher "Intercorrélation (FFT)" est cochée, la recherche de "pixels communs" entre les images se réalise par une transformée de Fourier interne permettant de localiser les "détails communs" de chaque image. De ce fait, le recalage par intercorrélation est mieux adapté aux images planétaires.

    Enfin pour un recalage "manuel", il est nécessaire de compléter les 2 cases en dessous.

  • Le décalage sur X en pixels par heures est l'indication de la dérive en X, qui peut être indiquée si elle est connue. Cette information n'est nécessaire que pour un recalage manuel.

  • Le décalage sur Y en pixels par heures est l'indication de la dérive en Y, qui peut être indiquée si elle est connue. Cette information n'est nécessaire que pour un recalage manuel.

Cliquer sur le bouton [OK] pour lancer l'addition en série. L´image résultante s´affiche alors sous le nom générique de la série d´images et peut être sauvegardée en exécutant la commande [Fichier] > [Enregistrer sous]

Remarque :
L'heure de l'image résultante sera le barycentre des heures, c'est-à-dire l'heure de l'image du milieu dans le cas de l'addition d'un nombre impair d'images.

Images de test :
Lot de 3 images décalées les unes par rapport aux autres (auteur : S. Charbonnel)

Images d'étoiles à recaler
Images à recaler manuellement
Images à recaler par intercorrélation.

Images supportant cette fonction :
Images monochromes CPA/FITS

Fonction script associée :
Aucune

Décembre 2010


Prétraitement / Addition morphing

Prétraitement > Addition par la technique du morphing

Lancement : Menu [Prétraitements] > [Addition Morphing (plusieurs images)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Le but de cette partie est de redimensionner des images essentiellement planétaires, de façon à pouvoir les comparer ensuite plus facilement, par une technique de "clignotement" par exemple.

Il est conseillé de lire le dossier sur le "morphing planétaire" avant d'aborder cette partie.

Les images de test proposées sont issues d'une webcam et étant prises seules, leur définition est très mauvaises. Celà n'empêche pas de faire des tests avec ... D'ailleurs, un "blink" sur ces images fait apparaître une distorsion des deux images l'une par rapport à l'autre.

Afin de pouvoir lancer la fonction, il faut que l'image de référence ait été importées dans PRiSM. Au démarrage de la fonction, l'utilisateur doit sélectionner une image de référence parmi toutes les images ouvtes dans PRiSM. Une fois l'image de référence sélectionnée, PRiSM propose la fenêtre classique du morphing planétaire dans lequel vient s'ajouter le chemin des fichiers à traiter ainsi que le fait de renommer les images résultantes du traitement. Il est en effet conseillé de renommer ces images car le traitement pourrait "ne pas plaire" !

Les informations à remplir

Le traitement des images commence ensuite et peut être plus ou moins long suivant les paramètres décrits dans le dossier sur le morphing planétaire.

Dans l'exemple, "frame3.cpa" est l'image déclarée comme image de référence. L'image "frame4.cpa" est recalée par rapport à l'image de référence et renommée. Les informations sont les suivantes :

Les paramètres de changement

Pour preuve, si on essait de recaler deux mêmes images (frame3 par rapport à frame3), on obtient les résultats suivants :

Des coefficients nuls pour le recalage d'une même image

Une fois les images recalées, on peut les récupérer dans le répertoire d'origine des images.

Images de test :
Lot de 2 images décalées les unes par rapport aux autres
Lot d'images décalées les unes par rapport aux autres

Images supportant cette fonction :
Images monochromes CPA/FITS

Fonction script associée :
Aucune

Prérequis :
Dossier sur le morphing planétaire
Eventuellement, équations du morphing.

Version Janvier 2008


Prétraitement / Addition drizzle

Prétraitement > Addition par la technique du drizzle

Lancement : Menu [Prétraitements] > [Addition Drizzle (plusieurs images)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Addition d'images sous-échantillonnées par la technique du drizzle. La résolution de l'image résultante sera alors artificiellement meilleure que chacune des N images de départ, décalées statistiquement les unes par rapport aux autres.

C'est une fonction très puissante, qui consiste à compositer efficacement des images individuelles provenant d'un système optique/detecteur sous-echantillonnant, c'est à dire un système optique/detecteur qui produit des images trop fines parce que la focale est trop courte ou que les pixels sont trop grands.

Le but du Drizziling est d'additionner ces images sans perdre leur résolution initiale en profitant du fait qu'elles sont sous-echantillonnées et en nombre suffisant. En resumé, les avantages de cette technique sont les suivants :

  • La résolution peut être multipliée par deux.
  • Préserve l'astrométrie et la photométrie.
  • Produit des images à haute resolution sans sacrifier le rapport signal à bruit final.
  • Est capable d'éliminer des pixels défectueux ou des rayons cosmiques.
  • Très bonne correction géometrique des images.

Les images à compositer doivent être prétraitées et doivent avoir le même offset (ou fond de ciel) et le même flux (pour cela on pourra utiliser la fonction [Prétraitement] > [Fond du ciel identique]

Après le lancement de la fonction, la fenêtre suivante apparaît :

  • L'icône [image] permet de sélectionner les images à additionner : seul le nom des images est affiché. L'image de référence est la première image sélectionnée. C'est l'image à partir de laquelle toutes les autres images seront recentrées.
  • La Fraction de pixel valide (fp) : Cette valeur est très critique. Si elle est égale a 0, le drizzle agit comme si on interlacait les images les unes au dessus des autres. Si cette valeur vaut 1, on revient a l'algorithme classique de recalage et addition. Il faut choisir cette valeur la plus petite possible de façon a ne pas dégrader la qualite finale de l'image value et aussi grande que possible pour avoir une couverture uniforme du super pixel equivalent. Le choix doit être typiquement de 1.0 / facteur d'aggrandissement, mais tenter tout d'abord entre 0.5 et 0.7

  • Le facteur d'aggrandissement (fa) : Il donne l'echelle de l'image qui sert au re-échantilonnage et aussi au super-pixel = fa * Pixel.

  • Si la case à cocher "Recalage automatique" est coché alors la fonction assurera un recalage automatique basé soit sur la recherche d'images communes à toutes les images de la série (si la case à cocher "Recalage par intercorrélation n'est pas cochée), soit par une techniques d'intercorrélation (si la case à cocher "Recalage par intercorrélation est cochée). Le recalage par intercorrélation est mieux adapté aux images planétaires.

  • Le décalage sur X en pixels par heures est l'indication de la dérive en X, qui peut être indiquée si elle est connue et n'est valide que si recalage automatique n'est pas coché.

  • Le décalage sur Y en pixels par heures est l'indication de la dérive en Y, qui peut être indiquée si elle est connue et n'est valide que si recalage automatique n'est pas coché.

Avec les images d'exemples fournies, et en accentuant volontairement le zoom de l'image, on obtient la différence suivante :

Addition Simple | Addition avec Drizzle
Addition et recalage simple | Addition et recalage avec Drizzle

Remarques:
L'image finale est au format flottant 32 bits (= format réel) par pixels.

Pour plus d'informations :
http://www.stsci.edu/ftp/science/hdf/combination/drizzle.html
http://www.stsci.edu/~fruchter/dither/dither.html
http://www.stsci.edu/instruments/wfpc2/Wfpc2_driz/wfpc2_driz.html

Images de test :
Lot de 8 images décalées les unes par rapport aux autres (auteur : L. Bernasconi avec des images volontairement sous-échantillonnées)

Images supportant cette fonction :
Images monochromes CPA/FITS

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Addition dédistorsion

Prétraitement > Addition d'images distordues

Lancement : Menu [Prétraitements] > [Addition déformation turbulence (plusieurs images)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Addition d'images distordues, dû à la turbulence.

Cette fonction additionne une série d’image par rapport à une image de référence en déformant les autres images à l’aide d’une transformation spéciale capable de compenser les effets de la distorsion par la turbulence.
L’utilisateur doit entrer des zones de référence dans lesquelles le logiciel calcule les différents décalages entre une zone donnée et celle de l’image de référence.

Pour illustrer l’aide de cette fonction, un exemple avec un film AVI issue d’une webcam va être utilisé. Ce fichier est un AVI montre une petite portion de la Lune. Cette séquence comporte 460 images, et il ne va être gardé ici que les meilleures images de cette séquence.

Etape 1 :

Ouvrir l’interface [Prétraitements] > [Traiter les fichiers films AVI], puis charger le fichier AVI

Sélectionner une zone de l’image dans laquelle se trouvent des détails.

Puis cliquer sur le bouton, « Selection (Best of) » en ayant préalablement entré 150 images (c’est le meilleur nombre d’images qui va être sélectionné). La translation-addition de l’ensemble de ces 150 images sera conservé afin de comparer les résultats entre une addition simple et une addition ou la distorsion de turbulence a été enlevée.

Cette séquence est alors traitée par le logiciel, et l’affichage successif des images montre des ondulations (ou distorsions) dues à la turbulence.
La fonction va donc prendre les 150 meilleures images (sur le critère de netteté) de la séquence et les additionner. Ceci peut prendre un certain temps.

Une fois l’opération terminée, l’image résultat sera sauvée en vue d’une future comparaison.

Image résultat avec un meilleur rapport signa à bruit, et les 150 meilleures images.

L’étape suivante consiste à sauvegarder au format CPA les 150 images considérées comme les meilleures de la séquence. Pour se faire, choisir le répertoire de destination et cocher la case [CPA N&B], puis [Sauver trames sélectionnées]

Le logiciel crée trois fois 150 images au format CPA sur le disque et dans le répertoire désiré. Seules les images en tramesV-XX.cpa seront conservées pour la suite des opérations, les autres pouvant être effacées, elles ne nous seront plus utiles. Il est possible maintenant de fermer la fenêtre de traitement des fichiers AVIs.

Etape 2 : recalage/registration des 150 images

A cause des erreurs de suivi du télescope, et du mouvement propre de la Lune, les images ne sont très probablement pas alignées. Pour se faire ouvrir [Prétraitement] > [Recalage en série d'une pile d'images], sélectionner toute les images, et cocher la case « Intercorrélation FFT », puis « OK ». A la question « Donner un autre nom aux images ? » répondre par l’affirmative.

Le logiciel va recaler (ou réaliser la registration) de toute les images par rapport à la première et sauver les images.
Les 150 fichiers résultats appelés « Decal_TramesV-XX.cpa » vont se trouver dans le répertoire.

Etape 3 : faire l’addition des images en tenant compte de la distorsion induite à la turbulence

Selectionner le menu correspondant à cette page (prétraitement/Addition déformation turbulence) :

Choisir les 150 fichiers à traiter, puis choisir l’image de référence. Laisser à 64x64 la taille de calcul de la FFT de la zone image.
L’ordre du polynôme d’ajustement est important: il détermine le degré de liberté de la forme de la grille de distorsion. Plus le degré est élevé, plus la forme de la distorsion sera complexe, mais plus le nombre de zone à sélectionner devra être obligatoirement important et plus long seront les calculs.
Comme nous n’avons pas de liste de centre de zone à fournir, l’image de référence apparait, et il faut sélectionner plus de 15 zones au curseur (avec un degré 3 de polynôme, il en faut au moins 25 avec un degré 4, ….).

L’utilisateur doit entrer des zones de référence dans lesquelles le logiciel calcule les différents décalages entre cette zone donnée et la même dans l’image de référence.

Les zones de 64x64 pixel apparaissent après click, et doivent correspondre à des zones avec des détails, ne pas sélectionner une plage uniforme, elle sera rejetée. Une fois plus de 15 zones sélectionnées, cliquer droit sur la souris ou appuyer sur la touche « Echap »
Les zones peuvent se chevaucher, et ce n’est pas un problème.

Sélection des zones de détails pour le calcul de la grille de distorsion.

Le paramètre « Nbre Sigma » s’occupe d’éliminer automatiquement les décalages de zones aberrantes en calculant un écart type des déviations de toutes les zones. Si le décalage de la zone DX ,DY pixels est supérieur à Nbre_Sigma fois cet écart type, le décalage de cette zone ne sera pas pris en compte dans le calcul de la grille de dédistorsion.
Il est possible de sauvegarder les images intermédiaires qui auront subi la dédistorsion.
Puis cliquer sur « OK ». Le calcul démarre.
Pour chaque zones un calcul de décalage est effectué, ce décalage ne doit pas être trop grand (en général inferieur a 2/3 pixels).
Un panneau d’état du calcul apparait et pour chaque image :

Translations Locales, Image 5 sur 5  (dx=-0.4 dy=0.8)
Zone n°1   DX= -0.1 DY=0.0   DDX=0.3  DDY=-0.9
Zone n°2   DX= -1.3 DY=0.1   DDX=-0.9 DDY=-0.8
Zone n°3   DX= 0.9  DY=2.0   DDX=1.3  DDY=1.2
Zone n°4   DX= 0.2  DY=0.4   DDX=0.6  DDY=-0.5
Zone n°5   DX= 0.0  DY=0.5   DDX=0.4  DDY=-0.4
Zone n°6   DX= 0.5  DY=1.2   DDX=0.9  DDY=0.3
Zone n°7   DX= -0.3 DY=-0.1  DDX=0.1  DDY=-1.0
Zone n°8   DX= 0.0  DY=0.0   DDX=0.4  DDY=-0.8
Zone n°9   DX= -0.1 DY=0.1   DDX=0.3  DDY=-0.8
Zone n°10  DX= 0.4  DY=1.5   DDX=0.8  DDY=0.6
Zone n°11  DX= -0.6 DY=1.0   DDX=-0.2 DDY=0.2
Zone n°12  DX= -0.6 DY=1.0   DDX=-0.2 DDY=0.2
Zone n°13  DX= -0.1 DY=0.5   DDX=0.3  DDY=-0.3
Zone n°14  DX= -0.6 DY=0.5   DDX=-0.2 DDY=-0.3
Zone n°15  DX= -0.2 DY=0.6   DDX=0.2  DDY=-0.3
Zone n°16  DX= 0.7  DY=0.1   DDX=1.1  DDY=-0.7
Zone n°17  DX= 0.0  DY=0.1   DDX=0.3  DDY=-0.8
Zone n°18  DX= 0.0  DY=0.7   DDX=0.4  DDY=-0.2
Zone n°19  DX= -0.8 DY=0.6   DDX=-0.4 DDY=-0.2

Decal_TramesV-5.cpa-> Corrélation=0.32 pixels -> 17 zone(s) gardée(s) sur 19
Pixels conservés de l'image aprés transformation -> 98.88 %

Il indique pour chaque zone les décalages, et en bas le nombre de zones conservées. Le nombre de pixels conservés dans la transformation est fondamental, s’il est inférieur à 80%, le résultat final de la fonction va être médiocre ou l’image sera trop dedistordue (se reporter au paragraphe « Causes d’échec de la fonction »)
Le calcul est en général assez long car il y a de nombreuses opérations mathématiques.
Voici le résultat final de notre liste d’image d’illustration :

Résultat de la somme des images dédistordues.

Si un masque fou est appliqué a l’image précédente, voici le résultat :

Et si le même masque flou est appliqué sur le résultat simple de l’addition recalée des 150 images, voici le résultat :

En comparant, les images de très pres dans les zone concernés (plutôt vers le centre), la premiere image presente plus de details que cette image

A gauche addition avec dedistorsion, à droite l’addition simple. La faille est plus nette.

Si le résultat ne convenait pas, le logiciel sauve la liste précédemment utilisée des points représentant le centre de chaque zone de détail. Il est possible de rappeler cette liste de points et d’éviter des rentrées au curseur fastidieuses et répétitives en cochant la case dédiée.

Causes d’échec de cette fonction :

Il est conseillé au début de ne prendre qu’une dizaine d’images pour faire un test rapide. Le message qui traduit une erreur s’affiche dans la fenêtre de calcul de cette façon :

Pixels conservés de l'image après  transformation -> 0.00 %
Dédistorsion de l'image problématique, degré  trop grand, sigma trop petit, pas assez de zones...

Les causes d’échec les plus courantes de cette fonction sont :

  • Une sélection de zones sans détails
  • Un sigma de rejection trop petit (éliminant toute les zones)
  • Trop peu de zones sélectionnées pour un degré de polynôme trop important : augmenter le nombre de zones de détails ou diminuer l’ordre du polynôme.

Images de test :
Images de la Lune

Images supportant cette fonction :
Images monochromes CPA/FITS

Fonction script associée :
Aucune

Version Janvier 2011


Prétraitement / Créer Flat, Dark, Offset Maître

> Prétraitement > Créer Flat, Dark, Offset Maître

Lancement : Menu [Prétraitement] > [Créer Flat, Dark, Offset Maître]

Ce menu permet de créer les 3 images essentielles pour le prétraitement que sont les noir (= dark en anglais), offset ou bias ( = constante en français) et plage de lumière uniforme (= flat en anglais). Ces images sont créées à partir d'une série d'image de chaque type et le résultat consiste à obtenir les images maîtres suivantes :

  • Pour l'Offset : médiane de N images d'offsets réalisées avec un temps de pose nul (ou très faible suivant la vitesse de réponse de la caméra). Ces images doivent être réalisées obturateur fermé. Elles peuvent être obtenues en utilisant la fonction [Caméra] > [Acquisition des Offsets]

  • Pour le Dark : médiane de N images de dark réalisées dans le noir (obturateur fermé). Ces images peuvent être obtenues en utilisant la fonction [Caméra] > [Acquisition des Noirs]. Au noir maître sera retranché l'offset.

  • Pour le Flat : médiane de N images de flat d'une plage lumineuse uniforme. Ces images peuvent être obtenues en utilisant la fonction [Caméra] > [Acquisition des Flats]. A noter qu'il ne sera rien retranché au flat et qu'il faudra penser à retrancher le dark maître des flats si le temps de pose est conséquent.

Cette fonction permet de construire l'Offset, le Dark et le Flat, à partir des images qui ont été réalisées dans les conditions décrites ci-dessus.

Au lancement, la fenêtre suivante s'ouvre :

Pour créer l'Offset, cliquer sur la case à cocher " Créer offset de référence", puis sélectionner les fichiers correspondant aux images dont le temps de pose est nul ou très faible (ces images doivent toutes avoir un temps de pose identique). Cependant, si cette image existe déjà, il suffit juste d'indiquer le chemin où elle se situe plutôt que de cocher la case " Créer offset de référence".

Pour créer le Noir (ou Dark), cliquer sur la case à cocher "Créer image Noir de référence", puis sélectionner les fichiers correspondant aux images effectuées pour le noir (ces images doivent toutes avoir un temps de pose identique). Si cette case n'est pas cochée, c'est que le noir maître existe déja !

Pour créer le Flat, cliquer sur la case à cocher "Créer image Flat de référence", puis sélectionner les fichiers correspondant aux images d'une plage de luminosité uniforme (ces images peuvent avoir des temps de pose différents). Si cette case n'est pas cochée, c'est que le flat maître existe déja !

Animations FLASH :
Créations des fichiers maitres (6,8 Mo)

Images supportant cette fonction :
Images CPA et FITS

Images de test :
Images : Noirs, Offsets, Flats (auteur : S. Charbonnel)

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Avoir fait des images élémentaires de darks, offsets et flats !

Prérequis :
Qu'est-ce qu'un prétraitement ?

Voir aussi :
[Caméra] > [Acquisition des Offsets], [Caméra] > [Acquisition des Noirs] et [Caméra] > [Acquisition des Flats]

Version Aout 2006


Prétraitement / Enlever ONF Auto

> Prétraitement > Enlever ONF Auto

Lancement : Menu [Prétraitement] > [Enlever Offset, Flat, Noir (Auto)]

BUT : Cette fonction très importante contient TOUS les prétraitements qui peuvent être appliqués de façon automatique à une image ou à une série d'images.
RESULTATS : De façon générale, le résultat des prétraitements de base sera sauvegardé dans un dossier "PreProcess" dans le répertoire où se situent les images à prétraiter. Les résultats et images résultants d'un prétraitement plus approfondi fournissant des recalages, additions ou création de fichiers seront sauvegardés dans un dossier "Results".
Comme cette fonction est très complète, le remplissage se fait à partir de plusieurs onglets dont tous ne sont pas indispensables pour chaque prétraitement ...

Cliquer pour aller directement Cliquer pour aller directement Cliquer pour aller directement

Onglet Image de calibration (1)

L'onglet image de calibration

Cette fonction permet d'appliquer à une série d'images brutes les prétraitements indispensables suivants :

  • La soustraction de l'image de précharge (également appelée bias ou offset)
  • La soustraction de l´image du Noir
  • La division par la P.L.U. (Plage de Luminosité Uniforme, ou Flat field), dont on aura préalablement ôté l´image de précharge. à cette image est associée une contante de normalisation, dont la valeur sert à compenser la perte de dynamique provoquée lors de la division par la P.L.U. (en règle générale, cette valeur est égale à la moyenne de la valeur de tous les pixels de la P.L.U.).

Ces trois étapes sont réalisées automatiquement à partir de cet onglet. On prendra soin, au préalable, de placer l'image de préchage, l'image de noir et la PLU dans un même répertoire.

Toutes les images doivent avoir le même format en Pixels (LxH) au pixels près.

Le noir, flat et l'offset doivent avoir été réalisés à la même position de départ de la fenêtre et avec les mêmes miroirs à l'acquisition des images.

Suivant ce qui est coché dans les options générales de PRiSM, il sera rappelé si les différences de miroirs entre les images, dark, offset et flat seront prises en compte et corrigés ou sinon, si aucune correction n'est effectuée :
  • Le chemin des image de calibration est le nom du dossier contenant les images de calibration (image de Noir, image d'Offset et image de PLU)

  • Les champs Offset, Noir et Flat contiennent respectivement le nom du fichier de l'image d'Offset, de l'image de Noir et de l'image de Flat (ou PLU) situées dans le répertoire spécifié au point précédent.

  • Dans le cas de l'existence d'un fichier cosmétique, on se réfèrera à l'onglet "Cosmétique (2)".

  • Si la case à cocher "Optimisation du noir", alors un coefficient multiplicateur sera appliqué à l'image de noir avant sa soustraction. Ce coefficient sera calculé automatiquement si la case à cocher "Optimisation manuelle" n'est pas cochée. Si l'utilisateur souhaite choisir lui-même ce coefficient, alors il faut cocher la case "Optimisation manuelle" : dans ce cas, l'utilisateur devra sélectionner une zone de fond de ciel sur les images brutes pour obtenir ce coefficient ou fixer à l'avance dans la case prévue à cet effet le coefficient.

  • Le champ Flat interférentiel contient le nom du flat interférentiel et ne concerne que les caméras CCD avec matrice CCD amincie. Cette fois encore, les coefficients sont réglables manuellement et parlent d'eux-mêmes !

Remarque importante : si une des images "noir", "offset" ou "flat" vient à manquer, ceci ne plantera pas le prétraitement. Elle ne sera juste pas pris en compte pour ce dernier !

Onglet Cosmétique (2)

L'onglet Cosmétique
  • Fichier script cosmétique :
    Ce point permet de tenir compte d'un fichier cosmétique, pour la correction des points chauds d'une image. Ce fichier peut être généré à l'aide de la fonction [Prétraitements] > [Générer la liste des points chauds].

  • Forcer pre/over scan à 0 :
    On définit trois régions pour un capteur CCD : les colonnes "prescans" représentées par les colonnes CCD qui sont masquées de la lumière. La partie "active" du CCD, là où seront lus les pixels. Les colonnes "overscans" qui sont produites en continuant à lire la base de registre après le dernier pixel "actif" de chaque colonne. La position du prescan et de l'overscan peut varier suivant les amplificateurs de lecture utilisés pour le CCD.

  • Blooming :
    Cette fonction doit supprimer les rayures verticales causées par les étoiles trop brillantes SANS ajouter d'artéfacts (ou du moins les minimiser) ! Attention : Cette fonction n'a pour vocation que des applications pour les belles images et il ne faut pas l'utiliser pour une exploitation scientifique des images.
    Pour plus de renseignements sur l'utilisation de cette partie et de ses paramètres, l'utilisateur consultera le dossier sur le blooming.

Onglet Images couleurs APN (3)

L'onglet images couleurs APN

La première case à cocher permet de faire tenir compte des informations en dessous lors du prétraitement.

Un dossier étant consacré au traitement des images d'appareils photos numériques, il est conseillé de s'y rendre pour l'utilisation de cet onglet.

Onglet Tri (4)

L'onglet Tri

à venir

Onglet Recalage / Registration (5)

L'onglet Recalage / Registration

à venir

Onglet Addition (6)

L'onglet Addition

à venir

  • La case à cocher "filtre script cosmétique" doit être cochée s'il existe un tel filtre donnant l a liste des colonnes et des pixels défectueux du CCD. Si cette case est cochée, le champ situé en dessous doit contenir le nom complet du fichier en question

  • La case àcocher "Addition des images" permet de demander une addition en série des images. Si elle est cochée, il est possible de demander la normalisation de l'image finale en cochant la case "Somme normalisée" (dans ce cas l'image finale sera divisée par le nombre total d'images)

  • La case à cocher "Pile médiane" permet de demander qu'une pile médiane soit effectuée sur les images.

  • La case à cocher "Recalage par intercorrélation" permet de demander que le recalage des images soit effecutée par la technique d'intercorrélation (adaptée aux images planétaires)

  • La case à cocher "Addition Sigma-Kappa" permet de demander que les images soient additionnées par la méthode Sigma-Kappa (voir fonction [Prétraitement] > [Addition par Sigma-Kappa])

Onglet Fichier (7)

L'onglet Fichier

A partir du bouton de parcours [image], on doit sélectionner tous les fichiers images par lot à prétraiter de la manière sélectionnée.

Les fichiers à traiter par lots doivent posséder des noms du type "XXX-nnnn", où nnnn désigne le numéro de l'image dans la liste (une dénomination du type "XXX_nnnn" ne fonctionnera pas).

Il ne reste plus qu'à cliquer sur le bouton [OK] pour que le traitement soit lancé.
La fenêtre de suivi affiche l'état d'avancement du traitement : Les nouvelles images résultant du traitement de base correspondant aux onglets 1 et 2 sont enregistrées dans le répertoire "PreProcess" avec un préfixe "t" alors que le résultat des autres onglets sont enregistrées dans le répertoire "Results".

Fonction(s) Script associée(s):
Voir la partie sur les scripts et les fonctions de prétraitement

Conditions d'activation :
Aucune

Prérequis :
Qu'est qu'un prétraitement ?

Version Septembre 2006


Prétraitement / Enlever ONF

> Prétraitement > Enlever ONF

Lancement : Menu [Prétraitement] > [Enlever Offset, Flat, Noir]

BUT :Cette fonction permet d'appliquer à image brute les prétraitements suivants :

  • La soustraction de l'image de précharge (également appelée bias ou offset)
  • La soustraction de l´image du Noir
  • La division par la P.L.U. (Plage de Luminosité Uniforme, ou Flat field), dont on aura préalablement ôté l´image de précharge. à cette image est associée une contante de normalisation, dont la valeur sert à compenser la perte de dynamique provoquée lors de la division par la P.L.U. (en règle générale, cette valeur est égale à la moyenne de la valeur de tous les pixels de la P.L.U.).

Ces trois étapes sont réalisées automatiquement dans cette fonction. On prendra soin, au préalable, de placer l'image de préchage, l'image de noir et la PLU dans un même répertoire.

Toutes les images doivent avoir le même format en Pixels (LxH) au pixels près.

Le noir, flat et offset doivent avoir été réalisé à la même position de départ de la fenêtre.

Avant de lancer cette fonction, l'image à traiter doit être sélectionnée. Après le lancement de la fonction, la fenêtre suivante s'ouvre :

  • Les champs Offset, Noir et Flat contiennent respectivement le nom du fichier de l'image d'Offset, de l'image de Noir et de l'image de Flat (ou PLU)

  • Si la case à cocher "Optimisation du noir automatique", alors un coefficient multiplicateur sera applique à l'image de noir avant sa soustraction.

  • Le champ "Dossier des images" doit contenir le nom complet du dossier contenant les images d'Offset, de Noir et de PLU.

  • Il est possible de se définir des profils pouvant être réutilisés lors d'un prochain prétraitement d'une future image.

Le traitement est lancé en cliquant sur le bouton [OK]. l'image résultant du traitement sera ensuite affichée. Il ne restera plus qu'à l'enregister avec la fonction [Fichier] > [Enregistrer Sous]

Images de test :
Image + Fichiers FNO

Fonction(s) Script associée(s):
Voir la partie sur les scripts et les fonctions de prétraitement

Conditions d'activation :
Que l'image à prétraiter soit ouverte.

Prérequis :
Qu'est qu'un prétraitement ?

Version Septembre 2006


Prétraitement / Nettoyer Répertoire de prétraitement

Prétraitement > Nettoyer Répertoire de prétraitement

Lancement : Menu [Prétraitements] > [Nettoyage des répertoires de prétraitement]

Cette fonction permet de nettoyer le répertoire "preprocess" à l'interieur d'un répertoire racine.
Il faut alors définir le répertoire de travail choisi à l'intérieur duquel se situe le répertoire "preprocess".

Version Janvier 2008


Prétraitement / Créer faux flats

Prétraitement > Créer faux flats

Lancement : Menu [Prétraitements] > [Synthétique (Créer faux flat)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de modéliser le fond du ciel d'un image préalablement sélectionnée. L'image de test a un défaut central volontairement sévère. Cette fonction ne fera pas des "miracles" sur un tel défaut qui ne pourra être corrigé que par un vrai flat. En effet, ce défaut ne fait pas parti de ce qu'on peut appeler le fond de ciel et ne sera donc pas corrigé.

Avant de lancer la fonction, une image doit être préalablement sélectionnée. Il est nécessaire de repérer le niveau maximum de fond de ciel à l'aide de la fonction [Analyse] > [Histogramme] > [Histogramme Global]. Un exemple sur l'image de test fournie fourni l'histogramme suivant :

Il apparaît sur cet histogramme que le fond de ciel maximum se situe aux environ de 4500 ADU. Après ce repérage, on peut lancer la fonction ...

Après le lancement de la fonction, la fenêtre suivante s'ouvre :

1er cas : Placement automatique des points

Si on demande le placement automatique des points, alors la fenêtre suivante s'ouvre :

  • Le nombre de pointages est le nombre de points que le logiciel va sélectionner sur l'image pour construire le fond du ciel synthétique.
  • Le seuil maximum est la valeur maximale des points sélectionnés par le logiciel. On le fait correspondre au maximum de fond de ciel repéré sur l'image.
  • On précise le choix de créer l'image de fond de ciel en évitant un certain nombre de pixels limitrophe à l'image : les points sont alors placés dans un rectangle en évitant le nombre de pixels précisé aux alentours de l'image.
  • Division directe : on fait le choix de diviser immédiatement après traitement l'image par le "faux flat" créé ou alors de voir le résultat du flat et de diviser ultérieurement grâce à la fonction [Traitement] > [Division par une image]

En cliquant sur le bouton [OK], une fenêtre s'affiche montrant quels sont les points qui ont été sélectionnés par le logiciel :

Un curseur apparait et permet de sélectionner des zones à supprimer de la liste des points automatiquemen sélectionnés.

Un clic du bouton de droite de la souris (ou bouton "Esc") permet de valider la sélection des points. La fenêtre suivante s'affiche alors :

Il ne reste qu'à choisir le degrès du polynome qui sera utilisé pour modéliser le fond du ciel et à cliquer sur le bouton [OK]. L'image de fond du ciel synthètique s'affiche :

2ème cas : Pointage manuel des points

Si on sélectionne le mode de placement manuel des points, alors un curseur apparaît sur l'image, il permet de sélectionner les points à utiliser pour fabriquer une image de fond du ciel synthètique.

Un clic du bouton de droite de la souris permet de valider la sélection des points. La fenêtre suivante s'affiche alors :

Il ne reste qu'à choisir le degrès du polynome qui sera utilisé pour modéliser le fond du ciel et à cliquer sur le bouton [OK]. L'image de fond du ciel synthètique s'affiche :

On notera que cette deuxième permet un traitement plus rapide que la première, et à moins de vouloir d'un traitement spécial (enlever des zones spécifiques, régler le fond de ciel maximal ...) ne change pas fondamentalement le résultat.

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
Image avec Flat non effectué.

Fonction script associée :
Aucune

Décembre 2010


Prétraitement / Soustraction du fond de ciel

Prétraitement > Soustraction du fond de ciel

Lancement : Menu [Prétraitements] > [Soustraction du fond de ciel]

Cette fonction permet de soustraire le fond du ciel à une image préalablement sélectionnée en le modélisant sous la forme d'un polynôme. Le fond du ciel soustrait est une image synthétique calculé par le logiciel.

Cette fonction est une façon de créer une image en enlevant le fond de ciel de manière plus directe que la fonction [Prétraitements] > [Synthétique (Créer faux flat)].

Au lancement de cette fonction, le logiciel ouvre une fenêtre demandant le nombre de points à répartir sur l'image et le degré du polynôme choisi pour le flat synthétique :

Après traitement, le fond de ciel est retiré à l'image de départ afin de fournir l'image "prétraitée". Il est important que les traitements de Noir / Offset aient été réalisé avant d'appliquer cette fonction.

Voici une application de cette fonction sur l'image de test, avec des seuils ressérés après traitement (avant = à gauche, après = à droite) :

Images supportant cette fonction :
Images monochromes et RVB CPA/FITS

Images de test :
Image avec Flat non effectué, pouvant s'apparenter à un fond de ciel non uniforme.

Fonction script associée :
Aucune

Décembre 2010


Prétraitement / Soustraction du fond de ciel (Zonal)

Prétraitement > Soustraction du fond de ciel (Zonal)

Lancement : Menu [Prétraitements] > [Soustraction du fond de ciel (Zonal)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Soustraire le fond de ciel d'une image en le simulant par partie.

Cette fonction permet de modéliser le fond du ciel d'un image préalablement sélectionnée.

Avant de lancer la fonction, une image doit être préalablement sélectionnée. Il est nécessaire de repérer le niveau maximum de fond de ciel à l'aide de la fonction [Analyse] > [Histogramme] > [Histogramme Global]. Un exemple sur l'image de test fournie fourni l'histogramme suivant :

Il apparaît sur cet histogramme que le fond de ciel considéré maximum se situe aux environ de 12900 ADU (tous pixels appartenant aux étoiles ou à la galaxie sont plus brillants que le seuil choisi). Après ce repérage, on peut lancer la fonction ...

Après le lancement de la fonction, la fenêtre suivante s'ouvre :

  • On définit la taille de chaque zone permettant de modéliser le fond de ciel dans cette partie.
  • Le seuil maximum est la valeur maximale des points sélectionnés par le logiciel. On le fait correspondre au maximum de fond de ciel repéré sur l'image.

Une fois la fonction appliquée, l'image de fond de ciel apparaît (image de départ = à gauche et fond de ciel synthétique = à droite) :

Attention : Il faut, par la suite, soustraire ce fond de ciel à l'image de départ et non réaliser la division de l'image de départ par le fond de ciel synthétique.

Images supportant cette fonction :
Images monochromes et RVB CPA/FITS

Images de test :
Image avec Flat non effectué, pouvant s'apparenter à un fond de ciel non uniforme.

Fonction script associée :
Aucune

Décembre 2008


Prétraitement / Suppression bruit fixe colonne-colonne

Prétraitement > Suppression bruit fixe colonne/colonne

Lancement : Menu [Prétraitements] > [Suppression bruit fixe colonne/colonne]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Il existe des capteurs (comme des capteurs APS CMOS) qui ont la propriété d'avoir un niveau différent sur chaque colonne. Ceci est très bien visible lorsqu'on réalise une image dans l'obscurité (ou Bias/Offset).

Ce défaut peut se présenter dans le cas d'une acquisition d'images en mode TDI, où l'on trouve ce genre de cas de figure à enlever (défauts sur le CCD qui se sont dispersés sur toute l'image).

L'image a alors l'allure suivante :

Elle présente des traînées verticales, qui agissent comme un motif de bruit fixe (ou FPN comme Fixed Pattern Noise en anglais).

Une coupe comme ci-dessus montre bien le problème, au lieu d'être plate le niveau change selon la colonne considérée.

Si on réalise une image du ciel, ce motif se superpose à l'image, ce qui est très gênant :

La fonction "Suppression Bruit fixe" permet de :

  • Générer une image synthétique du FPN, par calcul médian (pas de moyenne) sur chaque colonne de l'image, ce calcul s'effectue a partir d'un certain seuil que le logiciel réclame. Prendre ce seuil comme le maximum du FPN et suffisamment bas pour ne pas inclure le signal d'étoiles brillantes qui peuvent altérer le calcul. Ici le seuil a été prit 10% supérieur a la valeur retourné par le pixel sur la croix rouge.

  • Soustraire cette image de l'image originale.

L'image suivante montre le résultat de cette fonction avec un seuil de 855 :

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
Une image en mode TDI

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Créer liste de pixels chauds

> Prétraitement > Générer liste de pixels chauds

Lancement : Menu [Prétraitement] > [Générer une liste des pixels chauds] > [Méthode manuelle] ou [Prétraitement] > [Générer une liste des pixels chauds] > [Méthode automatique]

Cette fonction permet d'enregistrer la liste des pixels chauds d'une matrice CCD.

Avant de lancer cette fonction, il faut ouvrir et sélectionner une image de noir générique (ou dark) réalisée avec la caméra CCD concernée. Cette image aura en fait été créée à partir de plusieurs noirs de même temps de pose en utilisant la fonction [Prétraitement] > [Créer Flat, Dark, Offset Maître]

Méthode automatique

Après avoir indiqué le nom et le chemin du fichier de sauvegarde en *.cos, il faut indiquer le nombre de sigmas" de sélection. En termes plus simple, le logiciel essaie alors de modéliser l'histogramme de l'image sous forme gaussienne. L'algorithme considérera que tous les pixels en dehors d'une zone statistique définie comme étant ce nombre de fois l'écart type de la gaussienne, sera considéré comme pixel chaud (ou froid pour les valeurs négatives). (voir la méthode manuelle).

Le fichier est alors sauvé dans le répertoire choisi et pourra être rappelé lors du prétraitement automatique (onglet n°2) : [Prétraitement] > [Enlever Offset, Flat, Noir (Auto)]

Méthode manuelle

L'histogramme de l'image est alors affiché. Pour les modifications, se référer à la fonction [Analyse] > [Histogramme] > [Histogramme Global]

Un aperçu de l'histogramme montre qu'il est possible de modéliser le fond de ciel par une gaussienne. Les pixels largement en dehors de cette gaussienne pourront être considérés comme des points défectueux de la caméra. En sélectionnant des valeurs de pixels depuis l'histogramme (en cliquant sur l'histogramme et en jouant avec les boutons de zoom), on se définit alors des pixels froids et des pixels chauds :

Le seuil maximum est le niveau au dessus duquel un pixel est considéré comme un "pixel chaud", c'est à dire dont la sensibilté est trop grande.
Si on entre un seuil trop bas, le nombre de points détecté va être trop important et s'il dépasse 5000 le logiciel renverra un message d'erreur. De façon générale, le taux de "pixel chaud" ne doit pas dépasser environ 0,1%.

Un clic sur le bouton [sauver la liste] de l'histogramme permet de sauvegarder la liste dans un répertoire de son choix. Lorsque la liste de ces pixels a été déterminée, le logiciel affiche le nombre de pixels trouvés, et enregistre la liste dans le fichier. Il pourra être rappelé lors du prétraitement automatique (onglet n°2) : [Prétraitement] > [Enlever Offset, Flat, Noir (Auto)]

Un tel fichier ressemble à :

fill 125 6 1
fill 582 12 1
fill 587 21 1
fill 81 27 1
fill 317 37 1
fill 317 59 1
.............

Les instructions sont identiques à celle rencontrées à partir des menus : [Traitements] > [Opérations cosmétiques]

Images de test :
Image de Dark + les fichiers cosmétiques

Animations FLASH :
Générer une liste de pixels chauds (6,3 Mo)

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
GetHotPixels

Conditions d'activation :
Avoir une image de noir générique !

Image Exemple :
Noir générique en prenant des pixels chauds au dessus de 400 ADU.

Version Aout 2006


Prétraitement / Infos statistiques sur une série d'images

Prétraitement > Infos statistiques sur une série d'images

Lancement : Menu [Prétraitements] > [Infos statistiques sur une série d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction renvoie à partir d'un lot d'images des informations statistiques. Ceci peut servir a faire des études rapides sur :

  • Surveiller l'évolution du fond de ciel au cours de la nuit (à temps de pose constant)
  • Mesurer le niveau d'un lot d'images de Bias, de Dark ou de Flat
  • Controler la régularite d'un obturateur
  • etc ...

Au lancement de cette fonction, la fenêtre suivante s'affiche :

Elle permet de définir la liste des images à analyser et de déterminer une fenêtre sur laquelle seront effectuées les mesures.

Un clic sur le bouton [OK] permet de lancer le calcul. Le résultat est affiché sous 2 formes :

Résultat sous forme textuelle :

Fenêtre : X1= 1 X2= 100 Y1= 1 Y2= 100
Chargement :D:\CCavadore\FORS1\Shutter\CC_bias_0s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_0,05s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_0,1s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_0,2s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_0,5s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_1s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_2s_cw100x100.cpa
Chargement :D:\CCavadore\FORS1\Shutter\CC_800nm_0,025s_cw100x100.cpa

Exp.time (sec) Moyenne  Variance  Median Median-Mean Filename             Date
0              217.315  44718.9   196    -21.3153    CC_bias_0s_cw100x100 10/18/99 12:04:30 PM
0.05           1752.31  46219.8   1731   -21.313     CC_800nm_0,05s_cw100 10/18/99 12:04:30 PM
0.1            2875.45  46638.2   2855   -20.453     CC_800nm_0,1s_cw100x 10/18/99 12:04:30 PM
0.2            5278.73  49089.1   5259   -19.7332    CC_800nm_0,2s_cw100x 10/18/99 12:04:30 PM
0.5            12965.8  58123.2   12949  -16.7877    CC_800nm_0,5s_cw100x 10/18/99 12:04:30 PM
1              25240    79266.1   25227  -12.9599    CC_800nm_1s_cw100x10 10/18/99 12:04:30 PM
2              50738.6  155859    50737   -1.5809    CC_800nm_2s_cw100x10 10/18/99 12:04:30 PM
0.025          742.405  45003.9   721     -21.4049   CC_800nm_0,025s_cw10 10/18/99 12:04:30 PM

Résultat sous forme de 4 graphiques :

Un des 4 graphiques, donnant l'intensite moyenne
en fonction du temps de pose (test rapide d'un shutter).

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
N'importe quelle série d'images !

Fonction script associée :
StatWindow

Version Janvier 2008


Prétraitement / Fenêtrer une série d'images

Prétraitement > Fenêtrer une série d'images

Lancement : Menu [Prétraitements] > [Fenêtrer une série d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But :Cette fonction s'applique à une série d'images. Elle retourne pour chacune d'elle une zone correspondant à une fenêtre définie.

Lors de son lancement, la fenêtre suivante s'affiche :

Cette fenêtre permet de sélectionner les images concernées, et de définir les coordonnées de la zone à conserver, (X1,Y1) étant les coordonénes du coin en bas à gauche, et (X2, Y2) étant les coordonnées du coin en haut à droite.

Les nouvelles images sont sauvegardées dans le même répertoire que celles d'origine et le préfixe «d» est accolé au nom de l´image correspondante.

Images de test :
N'importe quelle série d'images !

Images supportant cette fonction :
Images monochromes et trichromes CPA/FITS

Fonction script associée :
Window

Version Janvier 2008


Prétraitement / Enlever "Prescans"

Prétraitement > Enlever "Prescans"

Lancement : Menu [Prétraitements] > [Enlever "Prescans"]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de supprimer la zone de préscan qui se trouve sur les images fournies par certaines caméra.

Parfois l'électronique de lecture d'une camera CCD, lit de "faux pixels" avant de commencer à lire réellement le CCD. Ces faux pixels ne représentent rien de physique sur l'image, ils sont utiles pour donner le niveau de référence ou d'offset de la camera en même temps qu'une image est réalisée. Cette zone de faux pixels (appelé "zone de prescan") est visible comme la bande noire à gauche de cette image d'un flat (par exemple) :

Au lancement de cette fonction, une fenêtre s'ouvre et permet de sélectionner le ou les fichiers à traiter, et de définir le nombre de pixels de préscan (ceux qui sont noirs) et le nombre de pixels sensibles (c'est à dire le nombre de colonnes contenant un signal réel).

Dans le cas de l'image ci-dessus, le nombre de pixels de prescan est de 50 pixels et le nombre de pixel sensibles est de 836 pixels.

Dans le cas des CCDs ayant plusieurs sorties et ayant un prescan, l'image peut se présenter sous la forme suivante :

Ce CCD réalisé pour l'optique adaptative possède 5 sorties qui lisent le CCD en parallèle. Chaque sortie possède 4 pixels de prescan. L'élimination dans PRiSM de ce prescan se réalise de manière itérative : 4 pixels de prescan, 16 pixels sensibles. Une fois atteint ce motif élémentaire de 4+16=20 pixels, le logiciel recommence sur le bloc suivant, puisque que la taille de l'image lui permet, ainsi il enlève toute les zones de prescan de chaque bloc :

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
Image avec prescan et une combinaison de 4 CCD (auteur : C. Cavadore, ESO)

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Corriger les gains

Prétraitement > Corriger les gains

Lancement : Menu [Prétraitements] > [Corriger les gains]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Il arrive que des cameras produisent les pixels sur plusieurs sorties du CCD. Ceci aboutit a des différences de réponses sur plusieurs quadrants. Ceci est dû à des gains différents sur les chaînes de lecture. On peut corriger ça aisément avec une division par un flat field, mais il est bien commode d'avoir une image corrigée sans spécialement avoir le flat field correspondant.

Exemple d'un flat issu de CCD a 4 sorties (ou d'une caméra composée de 4 CCD),
le carre noir défini au milieu le dernier pixel(X,Y)
en haut à droite du quadrant A

Cette fonction permet d'appliquer des coefficient de correction pour chaque quadrant.

Au lancement de la fonction, la fenêtre suivante s'ouvre :

Elle permet de sélectionner les fichiers à traiter, et de définir les cadrans et les gains à leur appliquer.Le logiciel supporte aussi des images à deux quadrant.

Images supportant cette fonction :
Images monochromes CPA/FITS

Images de test :
Image avec prescan et une combinaison de 4 CCD (auteur : C. Cavadore, ESO)

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Traiter les fichiers films AVI

Prétraitement > Traiter les fichiers films AVI

Lancement : Menu [Prétraitements] > [Traiter les fichiers films AVI]

But : Traiter les films AVI : séparer les images une à une, les sauvegarder, créer une nouvelle animation, etc ...

Cette page ne traite qu'un exemple mais ne traite pas tous les boutons présents dans ce panel. La très grande majorité d'entre eux sont facile à comprendre et un simple essai permet d'en comprendre l'utilité.

Une fois l'acquisition d'un fichier AVI réalisé, il est possible de le charger par la fonction "pretraitement/traiter fichiers films AVIs". Le panel suivant apparaît.
Ici, nous avons à faire à un film de Saturne realisé avec un Intes de 180mm de diamètre. Ce film est proposé ici en compressé (14 Mo). Ce film se compose de 1189 images. Nous allons en garder les 100 meilleures : il faut entrer "100" dans la case entourée de rouge.

Avec la souris, cliquer dans l'image pour créer un rectangle; ce rectangle définit la zone de calcul de la netteté. Si l'objet bouge, regarder tout au long de l'AVI en cliquant sur les "FrameXXX" à gauche : prendre la zone où l'objet se déplace.

Une fois la zone de netteté definie, cliquer sur les trois cases definies en rouge. Comme l'objet ne s'est pas trop deplacé durant l'acquisition, on coche aussi "Empilage rapide (petits décalages)". Dans ce cas, il faut cliquer sur "Options", et une fenêtre de "Sélection de la taille de FFT" apparaît. Une zone avec une croix se dessine : c'est dans cette zone que le calcul du décalage de l'objet d'une trame à une autre va s'effectuer. Il est possible de définir la taille de cette zone et de la centrer parfaitement dans l'image; ici, la zone est centrée en X=328 et Y=293.

Cliquer sur "OK" et cliquer sur "Selection (best of)". Accepter ensuite l'addition des images, et prendre toutes les images de la séquence soit de 1 à 1189.
Le calcul de netteté débute image par image et la zone de calcul s'affiche.

Une fois le calcul terminé, il choisit les 100 meilleures images. Le calcul de recentrage commence, les images étant vues comme les 100 meilleures sur 1189 sont additionées au fur et à mesure. La zone de calcul de centrage s'affiche : elle est différente de la zone de calcul de netteté.

Et voilà le résultat à la fin :

Vidéo de test :
Séquence film AVI

Voir aussi :
Addition par morphing

Version PRiSM 5


Prétraitement / Trouver les meilleures images

Prétraitement > Trouver les meilleures images

Lancement : Menu [Prétraitements] > [Trouver les meilleures images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Détecter les meilleurs images (planétaires) d'une série d'image.

Il faut définir le rectangle utilisé sur l'image dans lequel on va se baser pour déterminer les meilleures images ainsi que sélectionner les images à vérifier :

La reconnaissance est basée sur la notion d'entropie. L'entropie moyenne est calculée pour chaque image :

Plus cette dernière est élevée pour une image, plus l'image est censée être détaillée. Donc au début de la fonction, PRiSM calcule l'entropie de chaque image :

Chargement :J:\XXXXXXX\Frames-1.cpa
Fenêtre remise a : (X1=200,X2=450,Y1=100,Y2=400)
Frames-1.cpaEntropie = 6.17
Chargement :J:\XXXXXXX\Frames-2.cpa
Fenêtre remise a : (X1=200,X2=450,Y1=100,Y2=400)
Frames-2.cpaEntropie = 5.91
............................................

Après avoir classé les images par ordre d'entropie décroissante, le programme sauvegarde le pourcentage des meilleures images dans le répertoire "sorted" du répertoire où se trouvent les images.

Tri des images...
Frames-1.cpa Entropie = 6.17
Frames-38.cpa Entropie = 6.12
Frames-36.cpa Entropie = 6.10
Frames-37.cpa Entropie = 6.10
Frames-14.cpa Entropie = 6.00
Frames-29.cpa Entropie = 5.99
Frames-41.cpa Entropie = 5.96
Frames-2.cpa Entropie = 5.91
Frames-30.cpa Entropie = 5.89
Frames-25.cpa Entropie = 5.88
Frames-35.cpa Entropie = 5.85

.......................................

Fichiers copié vers : J:\XXXXXXX\sorted\
Frames-1.cpa : fichier copié avec succès
Frames-38.cpa : fichier copié avec succès
Frames-36.cpa : fichier copié avec succès
Frames-37.cpa : fichier copié avec succès
Frames-14.cpa : fichier copié avec succès

Images supportant cette fonction :
Images monochromes CPA/FITS (contrairement à la même fonction à l'intérieur de "Traitement / Fichier AVI" qui accepte les images RVB).

Images de test :
Série d'images

Fonction script associée :
Aucune

Version Janvier 2008


Prétraitement / Séparer film CCD vidéo en imagettes

> Prétraitement > Séparer film CCD vidéo en imagettes

Lancement : Menu [Prétraitement] > [Séparer film CCD vidéo en imagettes]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

EN CONSTRUCTION

Version Avril 2009


Visualisation / Seuils de visualisation

> Visualisation > Seuils de visualisation

Lancement : Menu [Visualisation] > [Luminosité / Contraste]

Touche de raccourci : F4

But : Cette fonction permet de modifier les paramètres de visualisation d'une image.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

les différents paramètres réglables; Cliquer sur une option pour en avoir de l'aide ...

Les paramètres sont les suivants :

  • Seuil Bas : Valeur du seuil bas de l'image

  • Seuil Haut : Valeur du seuil haut de l'image

  • Ascenseurs : L'ascenseur de gauche permet de modifier la valeur du seuil bas, l'ascenseur de droite permet de modifier la valeur du seuil bas.

  • L'icone [image] permet de rendre la LUT négative par rapport à la LUT prise en compte au moment où l'option est demandée ( pas nécessairement monochrome ... voir suite ).

  • L'icone [image] permet de régler automatique les seuils bas et haut pour que l'apparence de l'image s'approche de ce qu'on peut faire de mieux avec la LUT courante.
    Pour les images codées en valeurs entières, le seuil bas est pris à 5% de l'histogramme. Le seuil haut est pris à 99,5% de l'histogramme.
    Pour les images codées en valeurs réelles, la technique est basée sur la médiane de l'image. PRiSM calcule la médiane et l'écart-type dans l'image. le seuil bas est égal à la médiane soustrait d'un certain nombre de fois l'écart-type. Le seuil haut est égal à la médiane ajoutée d'un certain nombre de fois l'écart-type.

  • L'icone Noir et Blanc permet de sélectionner une LUT en 256 niveaux de gris :

    les 256 niveaux de gris

  • L'icone palette thermique permet de sélectionner une LUT dite "thermique" composée de 256 couleurs :

    les 256 couleurs de la LUT

  • L'icone patette rosée permet de sélectionner une LUT dite "rosée" sur 256 couleurs :

    les 256 couleurs de la LUT

  • L'icone LUT arc-en-ciel permet de sélectionner une LUT dite "Arc-en-ciel" composée de 256 couleurs :

    les 256 couleurs de la LUT

  • L'icone bouton éditer permet de construire et sauvegarder sa propre palette.

  • Le bouton [OK] Permet de valider le changement des paramètres.

  • Le bouton [Annuler] permet de sortir sans valider les changements effectués

Fonction(s) Script associée(s):
Visu, AutoVisu

Conditions d'activation du menu :
Qu'une image soit ouverte.

Prérequis :
la LUT.

Version Janvier 2008


Visualisation / Loupe

> Visualisation > Loupe

Lancement : Menu [Visualisation] > [Loupe]

But : Agrandir une image sur la fenêtre pour accentuer les détails.

Cette fonction permet d'activer une loupe sur une image préalablement sélectionnée.

Au lancement de cette fonction, une fenêtre s'ouvre et contient un agrandissement (10 fois) de la partie de l'image située sous le curseur :

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Visualisation / Grille

> Visualisation > Grille sur l'image

Lancement : Menu [Visualisation] > [Grille sur l'image]

But : Cette fonction permet d'afficher une grille rectangulaire sur l'image.

L'origine commence en bas à gauche de l'image. Ne pas oublier que les coordonnées rectangulaires X et Y du pixel pointé sont en plus affichées constamment au bas de l'image (en plus de l'intensité et des coordonnées équatoriales si l'image a été étalonnée).

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2007


Visualisation / Afficher masque

> Visualisation > Afficher masque

Lancement : Menu [Visualisation] > [Afficher masque]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet d'afficher un masque sur une image, ce dernier étant préalablement enregistré dans la base de données.

Le résultat avant et après ressemble au suivant :

Avant affichage du masque Après affichage du masque

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Montrer les pixels saturés

> Visualisation > Montrer les pixels saturés

Lancement : Menu [Visualisation] > [Montrer les pixels saturés]

But : Faire apparaître les pixels saturés d'une image.

Au démarrage, le choix est laissé à l'utilisateur de définir un seuil au dessus duquel un pixel sera considéré comme saturé :

Tous les pixels de l'image ayant une intensité supérieure à la valeur choisie seront alors colorés en rouge :

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Visualisation / Palette Noir et Blanc

> Visualisation > Palette Noir et Blanc

Lancement : Menu [Visualisation] > [Palette] > [Noir et Blanc]

But : Visualiser l'image avec une palette Noir et Blanc.

Cette fonction permet de choisir la palette Noir et Blanc pour la visualisation des images.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2007


Visualisation / Palette Rose

> Visualisation > Palette Rose

Lancement : Menu [Visualisation] > [Palette] > [Rose]

But : Visualiser l'image avec une palette Rose.

Cette fonction permet de choisir la palette Rose pour la visualisation des images.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2007


Visualisation / Palette thermique

> Visualisation > Palette thermique

Lancement : Menu [Visualisation] > [Palette] > [thermique]

But : Visualiser l'image avec une palette thermique.

Cette fonction permet de choisir la palette thermique pour la visualisation des images.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2007


Visualisation / Palette Arc-En-Ciel

> Visualisation > Palette Arc-En-Ciel

Lancement : Menu [Visualisation] > [Palette] > [Arc-En-Ciel]

But : Visualiser l'image avec une palette Arc-En-Ciel.

Cette fonction permet de choisir la palette Arc-en-ciel pour la visualisation des images.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2007


Visualisation / Isophote

> Visualisation > Tracé des isophotes

Lancement : Menu [Visualisation] > [Isophotes]

But : Tracer les isophotes sur une image.

Au lancement de la fonction (une image doit être sélectionnée) la fenêtre suivante apparaît :

Les options d'isophotes

  • Le pas entre les isophotes est le nombre d'isophotes tracées entre les seuils bas et haut. Le nombre limite d'isophotes est de 300.

  • Le seuil haut est le pas codeurs à partir duquel on arrête de dessiner les lignes isophotes. Le seuil haut par défaut est le seuil haut sous lequel est représentée l'image.

  • Le seuil bas est du même type que le seuil haut sauf qu'ici on désigne l'intensité minimum des isophotes. La valeur par défaut est celle correspondant à l'image en cours.

  • La case à cocher "Garder l'image en fond" permet de conserver l'image d'origine sous les isophotes.

Exemple de résultat :

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Visualisation / visualisation 3D dynamique

> Visualisation > Visualisation 3D

Lancement : Menu [Visualisation] > [Visualisation 3D] > [Par méthode dynamique]

Cette fonction permet de visualiser une image en 3 dimension instantanément. Le rendu est modifiable en faisant tourner le graphe avec la souris. La 3ème dimension (Hauteur) représente l'intensité du pixel concerné.

Image de départ Un exemple de vue en perspective 3D

Les paramètres peuvent être modifiés instantanément et l'image s'en trouvera alors corrigé immédiatement. Ces paramètres parlent d'eux-mêmes et ne seront pas décrits ici.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Visualisation / visualisation 3D statique

> Visualisation > Visualisation 3D

Lancement : Menu [Visualisation] > [Visualisation 3D] > [Par méthode statique]

Cette fonction permet de visualiser une image en 3 dimension. La 3ème dimension (Hauteur) représente l'intensité du pixel concerné.

Au lancement de la fonction, la fenêtre suivante s'ouvre :

Les options de la visualisation 3D
  • Le champ "Largeur" contient la largeur (en pixel) de la fenête qui va contenir l'image 3D finale.

  • Le champ "Longueur" contient la longueur de la fenête qui va contenir l'image 3D finale

  • Le champ "Azimuth" désigne l'emplacement où on se place pour observer l'image de profil. Cet angle est défini par rapport à l'angle que l'on désire faire avec la demi-droite partant du centre de l'image et allant vers la droite de l'image. Avec un azimuth de 0°, on regarde l'image en se plaçant à sa droite. Ces angles peuvent s'étendre entre -179,999... et 180°.

  • Le champ "Elévation" contient la hauteur du point de vue par rapport au plan horizontal formé par l'image. On définit la hauteur par un angle qui représente l'angle entre le lieu d'observation et le plan horizontal formé par l'image. Cet angle ne peut donc que varier entre 0° et 90°.

  • Le champ "Seuil Bas" contient l'intensité en dessous duquel on considére que les intensités des pixels seront inclus dans le plan horizontal de base de l'image.

  • Le champ "Seuil Haut" contient l'intensité au dessus de laquelle on considére que les intensités des pixels seront inclus dans le plan d'altitude maximal de l'image.

  • Le champ "Pas" permet de tracer une "ligne de vision" entre tous les pixels séparés par une valeur égale au "pas"

  • La case à cocher "perspective" permet d'activer le mode de visualisation 3D en perspective.

  • La case à cocher "Traits en couleur" permet de demander l'affichage des "lignes d'intensités" avec une luminosité dépendant de l'intensité du pixel considéré.

  • La case à cocher "Faces en couleurs" permet de demander le coloriage des faces reliant les points des lignes d'intensités avec une couleur dépendant de l'intensité entre les pixels rejoint.

Pour exemple, on peut voir l'allure de la répartition d'énergie en fonction de l'éloignement au noyau d'une galaxie spirale. Le résultat est explicite pour l'exemple suivant : ARP 271 qui est une réunion de NGC 5426 et NGC 5427. On peut également obtenir ce type de visualisation avec la fonction isophote :

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Visualisation / Visualisation partie réelle

> Visualisation > Visualisation complexe - Partie réelle

Lancement : Menu [Visualisation] > [Type de visualisation complexe] > [Partie réelle]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet d'afficher la partie réelle d'une image codées en complexe.

Images de test :
Image codée en complexe, résultant d'une transformée de Fourier d'une image classique.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Visualisation partie imaginaire

> Visualisation > Visualisation complexe - Partie imaginaire

Lancement : Menu [Visualisation] > [Type de visualisation complexe] > [Partie imaginaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet d'afficher la partie imaginaire d'une image codées en complexe.

Images de test :
Image codée en complexe, résultant d'une transformée de Fourier d'une image classique.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Visualisation module

> Visualisation > Visualisation complexe - Module

Lancement : Menu [Visualisation] > [Type de visualisation complexe] > [Module]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet d'afficher le module d'une image codées en complexe.

Images de test :
Image codée en complexe, résultant d'une transformée de Fourier d'une image classique.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Visualisation argument

> Visualisation > Visualisation complexe - Argument

Lancement : Menu [Visualisation] > [Type de visualisation complexe] > [Argument]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet d'afficher l'argument d'une image codées en complexe.

Images de test :
Image codée en complexe, résultant d'une transformée de Fourier d'une image classique.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Visualisation / Présentation planétaire

> Visualisation > Présentation planétaire

Lancement : Menu [Visualisation] > [Présentation planétaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de mettre en page des planisphères de planète (en vue, par exemple d'une publication).

Le style de la mise en page retenu est celui de la commission des planètes de la Société Astronomique de France (SAF), sur les indications de Gino Farroni, coordinateur des observateurs de Jupiter de la SAF.

Cette fonction travaille uniquement sur 2 types de documents :

  • Les planisphères W1 au format 360x30 pixels (ou des multiples)

  • Les planisphères W2 au format 360x180 pixels (ou des multiples)

Ci-dessous, on peut voir 2 exemples de tels planisphères, générés à partir d'une série de 7 images en couleurs prises par Antonio Cidadao les nuits du 14 et du 15 octobre 1999.

Planisphère W1

Planisphère W2

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

  • Le champ "Titre" permet d'insérer un titre en haut de la présentation.

  • Le champ "Initiales" est utilisé pour générer un planisphère au format SAF. Il permet de générer le nom de l'image au format bmp qui sera sauvegardée si vous cochez la case "Archiver".

  • Le champ "Préfixe" permet d'indiquer la première partie du nom de l'image au format bmp qui sera sauvegardée si vous cochez la case "Archiver". Dans le format SAF, il faut donner le préfixe J pour Jupiter, M pour Mars et S pour Saturne.

  • La case à cocher "Seuils inversés" permet de demander l'affichage du planisphère en négatif.

  • La case à cocher "Fond blanc" permet de demander l'affichage du planisphère sur un fond blanc (par défaut le fond est noir)

  • La case à cocher "Jour Julien" permet d'afficher en bas et à droite de la présentation le jour julien de la première image utilisée pour créer le planisphère.

  • La case à cocher "Date" permet de demander l'affichage en bas et à droite de la présentation la date de la première image utilisée pour créer le planisphère.

  • Cochez la case "Archiver" pour créer automatiquement une image bmp de la présentation qui apparaîtra à l'écran.Le nom de ce fichier sera : <préfixe> + <année> + <numjour> + <initiales> + .bmp
    Par exemple, le planisphère d'Antonio étant pris à partir du 14 octobre 1999, le nom du fichier sera J99287AC.bmp ( J + 99 + 287 + AC + .bmp ).

  • La case à cocher "Image Couleur" permet d'indiquer au logiciel qu'il doit chercher le ou les planisphères dans les images couleurs déjà ouvertes.

  • La case à cocher "Jupiter" ne doit être cochée que si les planisphères sont des planisphères de Jupiter. Dans le cas contraire (planètes Mars ou Saturne) un seul planisphère sera utilisé au lieu de 2.

Après avoir cliqué sur le bouton [OK], Prism vous demande alors de désigner le ou les planisphères à utiliser puis il crée la présentation.
Voici la présentation des planisphères d'Antonio selon le format de la SAF :

Le fond est noir, le jour julien et la date sont affichés. L'archivage à été demandé, donc le nom du fichier est indiqué en bas et à droite.

Voici une présentation différente avec seulement un fond blanc et un titre :

Fonction(s) Script associée(s):
Aucune

Type d'images :
images CPA

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Paramètres d'impression

> Visualisation > Paramètres d'impression

Lancement : Menu [Visualisation] > [Paramètres d'impression]

But : Régler les paramètres d'impression pour imprimer une image directement depuis PRiSM.

Une fenêtre s'affiche laissant le choix d'un certains nombres de paramètres :

Ces paramètres sont validés après appui sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Visualisation / Paramètres de l'imprimante

> Visualisation > Paramètres de l'imprimante

Lancement : Menu [Visualisation] > [Paramètres de l'imprimante]

But : Régler les paramètres de l'imprimante pour imprimer une image directement depuis PRiSM.

Le panel classique WINDOWS de réglage des paramètres de l'imprimante s'affiche alors. Après avoir sélectionné son imprimante, aller dans les propriétés de l'imprimante pour les réglages. Valider en cliquant sur [OK].

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Visualisation / Imprimer

> Visualisation > Imprimer une image

Lancement : Menu [Visualisation] > [Imprimer]

But : Imprimer une image directement depuis PRiSM.

Cette fonction permet d'imprimer une image préalablement sélectionnée.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

  • Les cases à cocher de la zone "Format du papier" permettent de spécifier le format du papier utilisé
  • Le champ "Echelle" permet d'ajuster la taille de l'image sur la page
  • La case à cocher "Echelle autour de l'image" permet d'indiquer si l'on souhaite que des graduations soient ou non présentes autour de l'image. Les deux champs associés (juste au dessous) permettent d'indiquer l'échelle des graduations.
  • La case à cocher "Nom de l'image" permet d'indiquer si l'on souhaite que le nom de l'image soit affiché sur la page
  • La case à cocher "Date de prise de vue" permet d'indiquer si l'on souhaite que la date de prise de vue soit indiquée sous l'image
  • La case à cocher "Commentaire" permet d'indiquer si l'on souhaite qu'un commentaire soit ajouté au-dessous de l'image. Si cette case est cochée, on entrera le commentaire dans le champ situé au dessous.
  • La case à cocher "Nom du programme" permet d'indiquer si l'on souhaite que la mention du nom du logiciel (PRiSM) soit ajouté au-dessous de l'image
  • La case à cocher "Alpha-Delta" permet d'indiquer si l'on souhaite que les coordonnées du centre du champ soient indiquées sous l'image. Pour que cette mention soit indiquée, il faut que l'information soit présente dans l'entête de l'image.

Lorsque toutes les options sont définies, il suffit de cliquer sur le bouton "Prévisualisation". Une fenêtre de prévisualisation s'ouvre, donnant un aperçu de la page avant l'impression :

Il reste possible d'ajuster le facteur de zoom de l'image et éventuellement de copier l'image dans le presse-papier (en cliquant sur le bouton "Copy to Clipboard"

  • Le bouton [Print] permet de lancer l'impression de l'image
  • Le bouton [Annuler] permet d'annuler l'impression.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2007


Visualisation / Zoom avant

> Visualisation > Zoom avant

Lancement : Menu [Visualisation] > [Zoom avant]

But : Cette fonction permet d'agrandir une image préalablement chargée. Il s'agit d'un simple agrandissement de l'image affichée à l'écran (le fichier de l'image n'est pas modifié).

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Zoom arrière

> Visualisation > Zoom arrière

Lancement : Menu [Visualisation] > [Zoom arrière]

But : Cette fonction permet de réduire une image préalablement chargée. Il s'agit d'une simple réduction de l'image affichée à l'écran (le fichier de l'image n'est pas modifié).

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Ajuste la fenêtre

> Visualisation > Ajuste la fenêtre

Lancement : Menu [Visualisation] > [Ajuste la fenêtre]

But : Cette fonction permet d'ajuster automatiquement la taille d'une fenêtre de façon à l'adapter à la taille de l'image qu'elle contient.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Voisisnage

> Visualisation > Voisinage

Lancement : Menu [Visualisation] > [Voisinage]

But : Cette fonction permet de visualiser l'intensité (en ADU) d'un pixel et de ses voisins à l'intérieur d'une zone carrée de pixels à définir<

Une image étant chargée et sélectionnée, il suffit de lancer la fonction et la fenêtre suivante s'ouvre :

Un exemple de voisinage

Il est possible de déplacer le curseur sur l'image, l'intensité du pixel se trouvant sous le curseur est indiquée en bleu, les intensités des pixels voisins étant indiqués en noir. Il est également possible de choisir la taille de la fenêtre analysée autour du curseur de la souris.

Fonction(s) Script associée(s):
GetPixelValue

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Statistiques locales

> Visualisation > Statistiques locales

Lancement : Menu [Visualisation] > [Statistiques locales]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet d'obtenir des informations statistiques sur une petite zone de l'image.

Un intérêt de cette fonction arrive lorsqu'on veut faire plusieurs statistiques fenêtrées : au lieu de redéfinir une fenêtre à chaque fois, on déplace juste la souris et la fenêtre se déplace en même temps.
Une image doit être préalablement chargée et sélectionnée.

  • Les champs "Taille de l'image en X" et "Taille de l'image en Y" permettent de définir la taille de la zone d'analyse. La statistique sur la fenêtre sera définie en appuyant sur la touche [Shift] et en déplaçant la souris sur l'image.

  • Le champ "Electron / ADU" indique le nombre d'électron par ADU pour la caméra concernée mais cette donnée est optionnelle.

  • Les statistiques sur la zone où on déplace la souris sont fournies : Moyenne, Médiane et Ecart-Type. Le logiciel affiche alors ces informations statistiques concernant les pixels se trouvant dans la zone d'analyse centrée sur le curseur, qui doit être déplacé tout en maintenant la touche "Shift" enfoncée.

  • Une statistique sur toutes les statistiques qui ont été réalisées depuis le dernier appui du bouton [reset].

  • Des renseignements sur la loupe d'affichage et sur la sauvegarde du fichier de données.

Fonction(s) Script associée(s):
StatWindow

Prérequis :
Notions de statistiques d'image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Transformations / Translation

> Transformation > Translation

Lancement : Menu [Transformation] > [Translation]

Cette fonction permet de décaler une image dans une direction quelconque.

L'image à traiter doit être préalablement chargée et sélectionnée.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de saisir le déplacement à effectuer, dans le sens des X et/ou des Y :

L'utilisateur peut choisir le type d'interpolation entre "linéaire" ou "bspline".

L'opération est lancée en cliquant sur le bouton [OK].

Application : Opération de base avant compositage, mosaïquage ou simple comparaison.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Translate

Image de test:
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Miroir X

> Transformation > Miroir axe X

Lancement : Menu [Transformation] > [Miroir axe X]

Cette fonction permet modifier une image préalablement chargée et sélectionnée, en la transformant en son image symétrique par rapport à un axe vertical.

Application : Redresse l'image dans le sens horizontal lorsque des systèmes optiques ont inversé l'image.

Images supportant cette fonction :
images monochromes ou Couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
MirrorX

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Miroir Y

> Transformation > Miroir axe Y

Lancement : Menu [Transformation] > [Miroir axe Y]

Cette fonction permet modifier une image préalablement chargée et sélectionnée, en la transformant en son image symétrique par rapport à un axe horizontal.

Application : Redresse l'image dans le sens vertical lorsque des systèmes optiques ont inversé l'image.

Images supportant cette fonction :
images monochromes ou Couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
MirrorY

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Quart de tour

> Transformation > Quart de tour

Lancement : Menu [Transformation] > [Quart de tour]

Cette fonction permet modifier une image préalablement chargée et sélectionnée, en la faisant tourner d'un quart de tour dans le sens horaire.

Application : Opération de base avant compositage, mosaïquage ou simple comparaison.

Images supportant cette fonction :
images monochromes ou Couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
QuaterRot

Image de test:
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Rotation

> Transformation > Rotation

Lancement : Menu [Transformation] > [Rotation]

Cette fonction permet de modifier une image préalablement chargée et sélectionnée, en lui appliquant une rotation d'un angle donné.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

  • Les champs "Centre de rotation X" et "Centre de rotation Y" permettent d'indiquer les coordonnées du centre de rotation de l'image

  • Le champ "Angle de rotation" permet de spécifier l'angle de la rotation (en degrés)

  • Les boutons [image] et [image] permettent d'indiquer le sens de la rotation

L'opération de rotation est lancée en cliquant sur le bouton [OK].

Application : Opération de base avant compositage, mosaïquage ou simple comparaison.

Images supportant cette fonction :
images monochromes ou Couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Rotate

Image de test:
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Agrandissement - Réduction

> Transformation > Agrandissement - Réduction

Lancement : Menu [Transformation] > [Agrandissement - Réduction]

Cette fonction permet d'agrandir ou de réduire la taille d'une image préalablement chargée et sélectionnée. Contrairement aux fonctions "Zoom Avant " et "Zoom Arrière", cette fonction modifie physiquement l'image.

De plus, cette fonction est capable d'interpoler l'intensité des nouveaux pixels, aux fonctions "Zoom Avant " et "Zoom Arrière".

Image agrandie avec la fonction "Zoom avant"

Image agrandie avec la fonction "Agrandissement/Réduction"

Au lancement de cette fonction, la fenêtre suivante s'ouvre

  • Le champ "Facteur d'agrandissement" permet de choisir le facteur d'agrandissement de l'image(si >1) ou de réduction (si <1)

  • La case à cocher "Utiliser interpolation" permet de sélectionner le mode d'interpolation des pixels créés. Au final, pour un même coefficient d´agrandissement ou de réduction, l´aspect des objets garde un contour plus ou moins régulier; l´aspect des fins détails est lissé pour des interpolations linéaires ou Bspline.

L'opération d'agrandissement ou de réduction est lancée en cliquant sur le bouton [OK]

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Scale

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Homothétie

> Transformation > Homothétie

Lancement : Menu [Transformation] > [Homothétie]

Cette fonction permet d'agrandir ou de réduire une image avec des facteurs différents selon l'axe des X et l'axe des Y.

L'image à traiter doit être préalablement chargée et sélectionnée.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

  • Le champ Facteur d'agrandissement X permet de choisir le facteur d'agrandissement dans l'axe des X
  • Le champ Facteur d'agrandissement Y permet de choisir le facteur d'agrandissement dans l'axe des Y
  • Proposition de ne pas changer la taille finale de l'image. Elle sera alors coupée afin de garder la même taille
  • Centre X de l'homothétie : Définit le point qui restera inchangé en X
  • Centre Y de l'homothétie : Définit le point qui restera inchangé en Y

La modification est effectuée en cliquant sur le bouton [OK]

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Homothetie

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Transformation de Radon

> Transformation > Transformation de Radon

Lancement : Menu [Transformation] > [Transformation de Radon]

Cette fonction permet d'effectuer une transformation de radon sur une image. La transformation de Radon peut être utilisée pour réduire une transformation de Fourier bidimensionnelle à une série de transformations de Fourier à une dimension. C'est un algorithme de restitution d'images à partir de l'ensemble de ses projections suivant différentes directions (transformation de Radon). Les projections sont ici les images unidimensionnelles issues d'un télescope à pupille fente (TPF), supposé placé dans l'espace et en rotation autour de son axe optique.

Pour plus d'informations, voir la page correspondante sur wikipédia.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Transformation géométrique polynomiale

> Transformation > Transformation géométrique polynomiale cartésienne

Lancement : Menu [Transformation] > [Transformation polynomiale] > [Cartésienne]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction effectue une transformation géométrique cartésienne définie par l'utilisateur

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, l'utilisateur doit fournir les coefficients désirée pour sa transformation :

La transformation dépendra ensuite des coefficients entrés par l'utilisateur ainsi que de la position origine de la transformation.

Images supportant cette fonction :
images monochromes 16, 32 ou 64 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Transformation géométrique polynomiale

> Transformation > Transformation géométrique polynomiale polaire

Lancement : Menu [Transformation] > [Transformation polynomiale] > [Polaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction effectue une transformation géométrique polaire définie par l'utilisateur

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, l'utilisateur doit fournir les coefficients désirée pour sa transformation :

La transformation dépendra ensuite des coefficients entrés par l'utilisateur ainsi que de la position origine de la transformation.

Images supportant cette fonction :
images monochromes 16, 32 ou 64 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Transformation rectangulaires vers polaires

> Transformation > Transformation rectangulaires vers polaires

Lancement : Menu [Transformation] > [Transformation polaire] > [Rectangulaires vers Polaires]

Cette fonction effectue une transformation géométrique d'une image de coordonnées cartésiennes (X,Y) en coordonnées polaires (r,q).

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, certains paramètres sont demandés :

  • Centre X : Centre de la transformation suivant X.
  • Centre Y : Centre de la transformation suivant Y.
  • Echelle axe des angles : Dilatation de l'axe des X (représentant l'évolution de q). Par exemple, pour une valeur de 1, l'axe des X s'étend de 1 à 360.

Le calcul donne une image dont l'axe des X représente un angle entre 0° et 360° (l'image fait 360 pixels de large) et l'axe Y la distance d'un point de l'image de départ au centre de la transformation. L'axe des X sera dilaté d'un facteur correspondant au facteur d'échelle demandé. L'image finale sera légèrement lissée.

Application :
Tous les objets à symétrie de révolution.

Il est aussi possible d'appliquer cette fonction sur des images autres qu'astronomiques comme le montre l'image d'une caméra all-sky (donc à axe de révolution) ci-dessous :

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
Image paysage

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Transformation polaires vers rectangulaires

> Transformation > Transformation polaires vers rectangulaires

Lancement : Menu [Transformation] > [Transformation polaire] > [Polaire vers Rectangulaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction effectue une transformation géométrique d'une image de coordonnées polaires (r,q) en coordonnées cartésiennes (X,Y).

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, la transformation a lieu immédiatement car aucun paramètres n'est à fournir. La largeur X de l'image de départ doit représenter un angle q de 0° à 360° et la longueur Y est le module ou la distance r
L'image d'arrivée est une image carrée dont la taille d'un côté fait (2*Largeur_image_de_depart)+1. Le centre de l'image d'arrivée est la première ligne de départ en partant du bas. L'image finale sera légèrement lissée.

Application :
Tous les objets à symétrie de révolution. Dans le cas de galaxies vues de face, ceci permet de mettre en évidence les effets de marée et/ou d'anormalité à la symétrie circulaire.
Toutes les transformations cartésiennes de filtrage, d'opérations géométriques en X et Y peuvent être effectuées dans le système polaire.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
NGC1232 après l'avoir transformé à partir de la fonction réciproque Rectangulaire vers Polaire.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Fenêtrage

> Transformation > Fenêtrage

Lancement : Menu [Transformation] > [Fenêtrage]

Cette fonction permet d'extraire une partie d'une image préalablement chargée et sélectionnée. Trois sous menus sont proposés :

  • Intéractif par curseur : Au lancement de cette fonction, un curseur apparait. Il permet de sélectionner la partie de l'image à extraire. La zone à extraire doit être définie en utilisant le bouton de gauche de la souris. Il est possible d'annuler la définition de la zone à extraire à l'aide de la touche "ESC".

  • Par valeurs : Définir les coordonnées du pixel inférieur gauche ainsi que celui du pixel supérieur droit.

  • Fenêtre glissante : Après avoir défini la taille de la fenêtre, la faire glisser sur l'image.

Lorsque la zone à extraire est définie, le logiciel extrait automatiquement la zone sélectionnée :

Application : Pour une iamge trop grande ou dont l'information principale n'occupe qu'une petite partie de celle-ci, le fenêtrage est une bonne solution pour réduire la taille physique de l'image et permettre ainsi des traitements plus rapides.

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Window

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Redimension

> Transformation > Redimension

Lancement : Menu [Transformation] > [Redimension]

Cette fonction permet de redimensionner une image (elle n'est ni agrandie, ni réduite physiquement, mais seulement retaillée).

Au lancement de la fonction, une boîte de dialogue s'ouvre :

Les tailles en pixels affichées en X et Y à l'ouverture sont celles de l'image sélectionnée.

Après avoir entré la nouvelle taille de la fenêtre en X et en Y, il suffit de cliquer sur le bouton [OK] pour que l'image soit retaillée.

La nouvelle image sera un fenêtrage de la précédente des coordonnées inférieures (X=1,Y=1) aux coordonnées supérieures (X=Taille en X; Y = Taille en Y).

Application : Redimensionner des images dont la taille ne conviendrait pas.
Amener deux images à la même taille.
Réduire une image de taille trop importante suite à un assemblage d'images ...

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
ChgImgDim

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Seuillage

> Transformation > Seuillage

Lancement : Menu [Transformation] > [Seuillage]

Cette fonction met au même niveau tous les pixels d'une image qui sont situés au-dessus d'un certain seuil (c'est le seuillage haut) ou au dessous d'un certain seuil (c'est le seuillage bas).

Cette fonction peut être utilisée, en particulier, pour harmoniser une image d'offset. En effet, après avoir fait la médiane des images d'offset, l'image résultante est bien représentative de l'offset, mais elle est aussi assez fortement bruitée. Un seuillage haut suivi d'un seuillage bas de cette image permet d'éliminer ces parasites.

Au lancement de cette fonction, une boîte de dialogue s'ouvre :

Si la case à cocher "Seuillage haut" est cochée, tous les pixels dont l'intensité est supérieure à la valeur de seuillage sont remplacés par un pixel d'intensité égale à la nouvelle valeur.

Si la case à cocher "Seuillage haut" n'est pas cochée, tous les pixels dont l'intensité est inférieure à la valeur de seuillage sont remplacés par un pixel d'intensité égale à la nouvelle valeur.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
ClipH
ClipL

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Détourage intérieur

> Transformation > Détourage intérieur

Lancement : Menu [Transformation] > [Détourage (rectangle)] > [Intérieur]

Cette fonction permet de remplacer les pixels situés à l'intérieur d'une zone rectangulaire d'une image, par des pixels d'une intensité donnée.

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, un curseur permet de définir (avec le bouton de gauche de la souris) une zone rectangulaire, puis une fois la sélection effectuée, la fenêtre suivante apparaît :

Le champ "Valeur de remplissage" permet de définir l'intensité qui sera donnée aux pixels situés à l'intérieur de la zone rectangulaire sélectionnée.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
DetourageInt

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Détourage extérieur

> Transformation > Détourage extérieur

Lancement : Menu [Transformation] > [Détourage (rectangle)] > [Extérieur]

Cette fonction permet de remplacer les pixels situés à l'extérieur d'une zone rectangulaire d'une image, par des pixels d'une intensité donnée.

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, un curseur permet de définir (avec le bouton de gauche de la souris) une zone rectangulaire, puis une fois la sélection effectuée, la fenêtre suivante apparaît :

Le champ "Valeur de remplissage" permet de définir l'intensité qui sera donnée aux pixels situés à l'extérieur de la zone rectangulaire sélectionnée.

Application : Cette commande sert principalement à éliminer les artefacts ou les résidus provoqués par des traitements comme le masque flou au bord de l'image.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
DetourageExt

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Détourage circulaire

> Transformation > Détourage circulaire

Lancement : Menu [Transformation] > [Détourage cercle]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de remplacer les pixels situés à l'intérieur ou à l'extérieur d'une zone circulaire d'une image, par des pixels d'une intensité donnée.

Une image doit avoir été préalablement chargée et sélectionnée.

Au lancement de cette fonction, la fenêtre suivante apparaît :

  • Centre X et Centre Y : Coordonnées du centre de la zone circulaire; par défaut, ce sont les coordonnées du centre de l'image.
  • Bruit gaussien (ADU) : intensité du bruit gaussien à rajouter au détourage.
  • Valeur : Intensité du détourage.
  • Rayon : Taille du détourage
  • Détourage intérieur ou extérieur au cercle.

Application : Cette commande sert principalement à éliminer les artefacts ou les résidus provoqués par des traitements comme le masque flou au bord de l'image.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Homothétie

> Transformation > Incruster du texte dans une image

Lancement : Menu [Transformation] > [Incruster du texte dans une image]

Cette fonction permet d'incruster du texte (uniligne) à n'importe quel endroit d'une image. Le menu de présentation permet de fixer la position, la taille et la police :

Le texte à écrire est à définir dans la première partie de la fenêtre. Des informations importées de l'entête de l'image peuvent être ajoutées à ce qui est présent grâce aux trois boutons réservés à cet effet : "Date/Heure", "Temps de pose", "Coordonnées".

Le choix de la taille et la couleur des caractères est à sélectionner ainsi que la couleur d'arrière plan qui sera utilisée pour fabriquer le rectangle autour du texte. Cette couleur sera adaptée par des niveaux de gris pour les images monochromes.

La position permet de choisir l'endroit où placer ce texte.

Le bouton "Aperçu" fixe l'allure du texte tel qu'il apparaitra.

Un exemple d'insertion de texte dans une image monochrome :

Images supportant cette fonction :
Tout type d'images.

Fonction(s) Script associée(s):
Aucune

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2011


Transformations / Binning

> Transformation > Binning

Lancement : Menu [Transformation] > [Binning]

Cette fonction permet de changer la résolution en changeant ou non la taille de l'image. Cette fonction comporte 4 sous menus :

  • Réduction par moyenne : permet de réduire la taille, le facteur de réduction étant un nombre entier, chaque pixel résultant ayant comme valeur la moyenne des valeurs des pixels voisins.
  • Réduction par médiane : permet de réduire une image, le facteur de réduction étant un nombre entier, chaque pixel résultant ayant comme valeur la médiane des valeurs des pixels voisins
  • Réduction et somme : permet de réduire une image, le facteur de réduction étant un nombre entier, chaque pixel résultant ayant comme valeur la somme des valeurs des pixels voisins. Cette fonction ne peut fonctionner que pour des images 32 bits. Afin de passer d'un codage 16 bits à un codage 32 bits, il faut utiliser la fonction : [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]
  • Expansion par moyenne : permet d'agrandir une image, le facteur d'agrandissement étant un nombre entier, chaque pixel résultant ayant comme valeur la moyenne des valeurs des pixels voisins.
  • Expansion par médiane : permet d'agrandir une image, le facteur d'agrandissement étant un nombre entier, chaque pixel résultant ayant comme valeur la moyenne des valeurs des pixels voisins.

Au lancement de la fonction choisie, la fenêtre suivante s'ouvre, permettant de choisir le facteur d'agrandissement ou de réduction (qui peut être différent en X et en Y)

Application : Ces commandes permettent de renforcer le rapport signal sur bruit de l'image et permet ainsi de faire ressortir des objets comme de faibles nébuleuses juste à la limite du rapport signal sur bruit.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Paramètres d'entête d'image :
L'astrométrie de l'image n'est conservée que si les 2 paramètres de binning sont identiques mais il est conseillé (dans la mesure du possible et pour les images réduites) de la refaire.
La photométrie n'est pas conservée.
Les paramètres d'acquisition ne changent pas mais la taille des pixels est changée en fonction de la valeur retenue pour le binning.

Fonction(s) Script associée(s):
BinningExpand
BinningReduce
BinningSum

Image de test :
Toute image !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Novembre 2010


Transformations / Egalisation linéaire d'histogramme

> Transformation > Egalisation linéaire d'histogramme

Lancement : Menu [Transformation] > [Egalisation d'histogramme] > [Linéaire]

Cette fonction permet d'égaliser l'histogramme d'une image.

Cette égalisation a pour but d'harmoniser la répartition des niveaux de luminosité de l'image, de telle manière à tendre vers un même nombre de pixel pour chacun des niveaux de l'histogramme. Cette opération vise à augmenter les nuances de l'image. Avec une image astronomique qui n'est deja pas au départ très linéaire et de plus discrète, il est quasi impossible d'avoir une égalisation stricte de l'histogramme. L'algorithme fait ça "le mieux possible".

Au lancement, cette fonction s'exécute immédiatement. Il est possible de comparer les résultats à l'aide de la fonction [Analyse] > [Histogramme] > [Histogramme Global] dont un exemple est fourni ci-après à l'aide de l'image de test :

Images supportant cette fonction :
images monochromes 16 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
M27

Bibliographie :
WEB 1
WEB 2

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Egalisation gaussienne d'histogramme

> Transformation > Egalisation gaussienne d'histogramme

Lancement : Menu [Transformation] > [Egalisation d'histogramme] > [Gaussienne]

Cette fonction permet d'égaliser l'histogramme d'une image.

Cette égalisation a pour but de gérer la répartition des niveaux de luminosité de l'image, de telle manière à tendre vers un nombre de pixel pour chacun des niveaux de l'histogramme qui s'étale de façon gaussienne. Cette opération vise à cibler les nuances de l'image. Avec une image astronomique qui est discrète, il est quasi impossible d'avoir une égalisation gaussienne stricte de l'histogramme. L'algorithme fait ça "le mieux possible".

Au lancement, cette fonction deamnde les valeurs extrêmes considérées pour la gaussienne :

Il est possible de comparer les résultats à l'aide de la fonction [Analyse] > [Histogramme] > [Histogramme Global] dont un exemple est fourni ci-après à l'aide de l'image de test :

Images supportant cette fonction :
images monochromes 16 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
M27

Bibliographie :
WEB 1
WEB 2

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Digital Developpment Processing

> Transformation > Digital Developpment Processing

Lancement : Menu [Transformation] > [Digital Developpment Processing (DDP)]

Cette fonction très puissante permet d'appliquer l'algorithme de traitement d'image appelé "Digital Development Processing", qui est un filtre non linéraire.

Cet algorithme permet de faire ressortir des détails tant dans les zones brillantes que les zones sombres des images du ciel profond.

Pour plus de détail sur l'algorithme, on pourra se reporter au site suivant :

http://www.asahi-net.or.jp/~rt6k-okn/its98/ddp1.htm

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

Il est alors possible de faire bouger les niveaux des curseurs afin de régler les coefficients de l'algorithme. La visualisation sur une partie de l'image est immédiatement visible (cette partie peut être changée à l'aide d'un glissement de la souris). Après application de l'algorithme, la valeur du fond de ciel est renvoyée.

Le principe de fonctionnement est grossièrement le suivant : la nouvelle valeur d'un pixel dépend de l'ancienne valeur, de la valeur obtenue à partir d'un masque flou, de la moyenne des valeurs obtenues à partir du masque flou autour du pixel désiré ainsi que de constantes aléatoires ou réglables par l'utilisateur. C'est pour cela que l'on retrouve des paramètres à régler type "masque flou" comme le sigma et le facteur d'amplification de la netteté.

Avec l'image de test fournie, on peut en partant d'une image de la gauche obtenir une image où les détails ressortent comme sur la droite :

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
DDP

Image de test :
Image M81 (Laurent Bernasconi)

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Compositage stellaire

> Transformation > Compositage stellaire

Lancement : Menu [Transformation] > [Compositage automatique] > [Stellaire]

Cette fonction permet de compositer très simplement 2 images stellaires.

Chargez les 2 images concernées, puis sélectionnez la première. Au lancement de la fonction, la fenêtre suivante s'ouvre :

Sélectionnez alors la seconde image en utilisant les flèches en bas à droite de la fenêtre.

L'image compositée est affichée dans la fenêtre de la 1ère image. Dans le cas d'un compositage stellaire, le programme détermine automatiquement les translation, rotation et changement d'échelle à appliquer à la 1ère image. Un fichier de sortie est alors fourni en indiquant les corrections (obtenu ici à partir des images exemples) :

[Zoom = 1]
Translation DX= -57.83
Translation DY= 7.9443
Xp=1.0007*X+-0.0016004*Y
Yp=0.00047894*X+1.0002*Y
échelle Xp= 1.0007
échelle Yp= 1.0002
Rotation= 0.091696°

La fonction de compositage automatique est sensible aux pramètres de reconnaissance stellaire accessibles à partir de [Options] > [Reconnaissance des champs d'étoiles]

Application : Comparer deux images provenant de deux télescopes différents.

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
CompositeAuto

Image de test :
2 champs stellaires proches de la pleine lune.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Compositage planétaire

> Transformation > Compositage planétaire

Lancement : Menu [Transformation] > [Compositage automatique] > [Planétaire]

Cette fonction permet de compositer très simplement 2 images planétaires.

Chargez les 2 images concernées, puis sélectionnez la première. Au lancement de la fonction, la fenêtre suivante s'ouvre :

Sélectionnez alors la seconde image en utilisant les flèches en bas à droite de la fenêtre.

L'image compositée est affichée dans la fenêtre de la 2ème image. Le programme détermine automatiquement les translation, rotation et changement d'échelle à appliquer à la 2ème image. Un fichier de sortie est alors fourni en indiquant les corrections (obtenu ici à partir des images exemples) :

Image décalée : JUPITER2 263x255 - Monochrome - Entiers(16bits signés)   [Zoom = 1]
DX=-1.2179, DY=-1.2192

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
2 images de Jupiter.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Compositage planétaire par morphing

> Transformation > Compositage planétaire par morphing

Lancement : Menu [Transformation] > [Compositage automatique] > [Planétaire par morphing]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de compositer très simplement 2 images planétaires par la méthode du morphing, exposée à partir de la fonction [Prétraitements] > [Addition Morphing (plusieurs images)].

Chargez les 2 images concernées. Au lancement de la fonction, la fenêtre suivante s'ouvre :

Il est nécessaire de remplir le degré du polynome de reconnaissance ainsi que le nombre maximum d'itérations autorisé afin d'y arriver. Il s'agit ensuite de sélectionner chacune des images à partir de la fenêtre de sélection :

L'image compositée est affichée dans la fenêtre de la 2ème image. Le programme détermine ainsi une sorte de polynome de passage d'une image à une autre. La transformation est appliquée à la 2ème image. Un fichier de sortie est alors fourni en indiquant les corrections :

Dimension polynôme 2
Temps de calcul=1.187s

X=P(x,y)=6.98181+0.195021.x^0.y^1+0.762682.x^1.y^0+0.000723416.x^1.y^1+0.000569837.x^2.y^0+-0.000997027.x^0.y^2
Y=G(x,y)=27.7123+0.835164.x^0.y^1+-0.0554538.x^1.y^0+0.00128463.x^1.y^1+-0.000506997.x^2.y^0+5.35446E-6.x^0.y^2
Image changée : JUPITER2 263x255 - Monochrome - Entiers(16bits signés)   [Zoom = 1]

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
2 images de Jupiter.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Transformations / Mosaïque stellaire

> Transformation > Mosaïque stellaire

Lancement : Menu [Transformation] > [Mosaïque] > [Stellaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de réaliser la mosaïque de 2 images stellaires.

Lorsque le CCD est trop petit pour faire entrer un objet trop grand, la prise de vues multiples en décalant le CCD à chaque fois (en gardant une zone commune à chaque image) permet de compenser cette faiblesse des CCD et des optiques. Grâce à cette commande, cette opération peut être possible.

Attention : dans tous les cas, pour réaliser une mosaïque d'images, il faudra respecter les conditions suivantes :

  • Les images doivent avoir le même échantillonnage (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Agrandissement - Réduction]).
  • Les images doivent avoir la même orientation (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Rotation]).
  • Les images devront avoir une partie suffisamment commune pour les relier !
  • Par contre, les images n'ont pas besoin d'avoir le même niveau radiométrique ! ( c'est-à-dire qu'au départ, les pixels communs n'ont pas besoin d'avoir à peu près la même intensité )

Chargez les 2 images concernées, puis sélectionnez la première. Au lancement de la fonction, la fenêtre suivante s'ouvre :

Sélectionnez alors la seconde image en utilisant les flèches en bas à droite de la fenêtre.

Considérons deux images de M81 (exemple des images de test); l'une représente la partie inférieure et l'autre la partie supérieure. La partie commune se trouve dans la partie inférieure de la galaxie. On représente ci-dessous les deux images en zoom x1/2 :

Les 2 images à mosaïquer

Il faut repérer au moins une étoile commune au deux images. Il est conseillé de réaliser la mosaïque en zoom x1. On doit alors indiquer une étoile commune à chaque image. On devra d'abord la sélectionner dans la première image soit M81_1 puis dans la deuxième image M81_2. Il sera appliqué la fonction centroïde sur cette étoile dans les 2 images. Ceci permettra de connaitre la position précise des 2 étoiles dans chaque image, le flux et le valeur du fond de ciel. En effet, connaissant ces valeurs, le logiciel va pouvoir organiser l'image finale de la façon suivante :

  • Afin que le chevauchement des images n'apparaissent pas, il va falloir transformer la deuxième image de telle façon que le fond du ciel de chaque image soit identique et que la même étoile appartenant aux deux images ait le même flux dans chaque image.

    La fonction centroïde permet de mesurer le flux moyen de l'étoile (E1 et E2 dans chaque image) et le bruit de fond de ciel (F1 et F2).

    On doit multiplier la deuxième image par un coefficient C égal à (E1 / E2).

    Il va falloir ajouter un offset (une constante) à tous les pixels de l'image égal à (F1 - (F0*C)). Le fait de ne pas faire directement F1 - F0 permet de mieux transcrire le fond de ciel en fonction de la luminosité. On peut évidemment ajouter un offset négatif.

  • Il va être créé une nouvelle fenêtre dont le coin en bas à gauche représentera comme d'habitude le pixel (1,1). La fenêtre va avoir une dimension de telle façon à accepter l'image résultante. Soit ( X1, Y1 ) les coordonnées de l'étoile au centième de pixel dans la première image et ( X2, Y2 ) ses coordonnées dans la deuxième image. Soit également ( DIM_X1, DIM_Y1 ) les dimensions de la première image et ( DIM_X2, DIM_Y2 ) les dimensions de la deuxième image.
    On va devoir considérer quatre cas :

    1. Si ( X1 > X2 ) et ( Y1 > Y2 ), alors la fenêtre mosaïquée aura l'image 1 en bas à gauche et l'image 2 en haut à droite. Le pixel ( 1, 1 ) correspondra au pixel ( 1, 1 ) de l'image 1. Comme le pixel central de l'étoile sélectionné n'aura sûrement pas une valeur " ronde " les valeurs de l'intensité des pixels de l'image 2 seront recalculées par interpolation. La dimension totale de la fenêtre sera :

      DIM_X = INT ( X1 + ( DIM_X2 - X2 ) )
      DIM_Y = INT ( Y1 + ( DIM_Y2 - Y2 ) )
    2. Si ( X1 > X2 ) et ( Y1 < Y2 ), alors la fenêtre mosaïquée aura l'image 1 en haut à gauche et l'image 2 en bas à droite. Le pixel ( 1, 1 ) ne correspondra à rien ! Son intensité sera nulle. Par contre, le pixel ( 1, DIM_Y ) correspondra au pixel ( 1, DIM_Y1 ) de l'image 1 et le pixel ( DIM_X, 1 ) correspondra au pixel ( DIM_X2, 1 ) de l'image 2. Comme le pixel central de l'étoile sélectionné n'aura sûrement pas une valeur " ronde " les valeurs de l'intensité des pixels de l'image 2 seront recalculées par interpolation. La dimension totale de la fenêtre sera :

      DIM_X = INT ( X1 + ( DIM_X2 - X2 ) )
      DIM_Y = INT ( ( DIM_Y1 - Y1 ) + Y2 )
    3. Si ( X1 < X2 ) et ( Y1 < Y2 ), les commentaires seront les mêmes qu'en 1. mais il faut inverser les indices 1 et 2.
      La dimension totale de la fenêtre sera :

      DIM_X = INT ( ( DIM_X1 - X1 ) + X2 )
      DIM_Y = INT ( ( DIM_Y1 - Y1 ) + Y2 )
    4. Si ( X1 < X2 ) et ( Y1 > Y2 ), les commentaires seront les mêmes qu'en 2. mais il faut inverser les indices 1 et 2.
      La dimension totale de la fenêtre sera :

      DIM_X = INT ( ( DIM_X1 - X1 ) + X2 )
      DIM_Y = INT ( Y1 + ( DIM_Y2 - Y2 ) )
  • La partie commune aux deux images doit maintenant avoir le même fond de ciel et les étoiles doivent avoir le même flux. La superposition peut alors être effectuée de plusieurs façons :

    1. en gardant la partie commune de la première image et en supprimant celle de la deuxième image. ( versa-vice ).
    2. vice-versa !
    3. en faisant une moyenne des deux parties communes.
    4. en faisant une interpolation entre les deux parties communes.

La valeur du pixel résultant va dépendre de la valeur des pixels de la zone en commun.

image 1 | image 2 | image finale
0 | 0 | 0
0 | V <> 0 | V
V <> 0 | 0 | V
V1 <> 0 | V2 <> 0 | V3

V3 = ( V1 + V2 ) / 2 si ( V2 - V1 ) < Sup ( V1, V2 ) / 10
V3 = Sup ( V2, V1 ) si ( V2 - V1 ) > Sup ( V1, V2 ) / 10
( Sup ( V1, V2 ) renvoie la plus forte valeurs des deux valeurs V1 et V2 )

Le cas de nos deux images est le cas exposé au point 1. Il n'est pas possible de montrer ici le résultat.
Cependant, le programme affiche, avant d'effectuer le compositage, les résultats de ses calculs sous forme de deux coefficients :

Les coefficients de mosaïque

Les coefficients ont la signification suivante :

  • L'offset est un nombre qui va être ajouté à la deuxième image ( celle qui n'est pas par défaut ). Ce nombre peut être négatif. ( = " Traitements / Ajouter une constante " )
  • Le coefficient est un nombre par lequel on multipliera tous les pixels de la deuxième image. ( = " Traitements / Multiplication" )

En cliquant sur "OK", la mosaïque stellaire apparaît. L'image résultante est fournie pour exemple.

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
2 images de M81 à raccorder dont le résultat est donné.
2 autres images de M81 résultant de la séparation d'une image de départ. Les paramètres n'ayant pas été modifiés, les coefficients renvoyés doivent être de 1 pour le coefficient multiplicatif et 0 pour l'Offset ...

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Mosaïque planétaire

> Transformation > Mosaïque planétaire

Lancement : Menu [Transformation] > [Mosaïque] > [Planétaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de réaliser la mosaïque de 2 images planétaires.

Lorsque le CCD est trop petit pour faire entrer un objet trop grand, la prise de vues multiples en décalant le CCD à chaque fois (en gardant une zone commune à chaque image) permet de compenser cette faiblesse des CCD et des optiques. Grâce à cette commande, cette opération peut être possible.

Attention : dans tous les cas, pour réaliser une mosaïque d'images, il faudra respecter les conditions suivantes :

  • Les images doivent avoir le même échantillonnage (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Agrandissement - Réduction]).
  • Les images doivent avoir la même orientation (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Rotation]).
  • Les images devront avoir une partie suffisamment commune pour les relier !
  • Par contre, les images n'ont pas besoin d'avoir le même niveau radiométrique ! ( c'est-à-dire qu'au départ, les pixels communs n'ont pas besoin d'avoir à peu près la même intensité )

Chargez les 2 images concernées, puis sélectionnez la première. Au lancement de la fonction, on doit sélectionner les images à mosaïquer.

Dans l'exemple suivant, on repère les 2 parties communes :

Il va donc falloir indiquer au logiciel l'endroit sur les images où se situe cette partie commune.
Lancer la fonction de mosaïque planétaire. Cette fonction ne peut être ouverte qu'à partir d'une image. Cette image sera considérée comme l'image par défaut. Cependant, la fonction a besoin d'une deuxième image pour fonctionner.
Le programme demande alors de sélectionner la deuxième image sous forme de choix parmi toutes les images ouvertes suivant le processus habituel.

La fonction demande alors dessiner un rectangle de taille inférieure à 100 x 100 pixels afin d'encadrer une partie sur la première image ( image par défaut ). Cette partie sera considérée comme une partie commune aux deux images. Une fois ce travail effectué, le rectangle passera automatiquement dans la deuxième image en gardant la même dimension. L'utilisateur doit alors ajuster, au mieux ( mais non au pixel près ! ), la partie commune dans la deuxième image.
La fonction affiche alors des renseignements sur la mosaïque planétaire que le programme compte effectuer :

Ces renseignements sont au nombre de deux :

  • L'offset est un nombre qui va être ajouté à la deuxième image ( celle qui n'est pas par défaut ). Ce nombre peut être négatif. ( = " Traitements / Ajouter une constante ")
  • Le coefficient est un nombre par lequel on multipliera tous les pixels de la deuxième image. ( = " Traitements / Multiplication" )

Ces deux nombres permettront de mettre la deuxième image au même niveau que la première. Il peuvent être modifiés manuellement mais il est tout de même conseillé de les laisser à la valeur qui est proposée.

En cliquant sur " OK ", la mosaïque planétaire apparaît ne souffrant normalement d'aucun défaut ...

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
2 images de La Lune à raccorder.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Mosaïque manuelle

> Transformation > Mosaïque manuelle

Lancement : Menu [Transformation] > [Mosaïque] > [Manuelle]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de réaliser la mosaïque manuelle sur des images stellaires ou planétaires.

Lorsque le CCD est trop petit pour faire entrer un objet trop grand, la prise de vues multiples en décalant le CCD à chaque fois (en gardant une zone commune à chaque image) permet de compenser cette faiblesse des CCD et des optiques. Grâce à cette commande, cette opération peut être possible.

Attention : dans tous les cas, pour réaliser une mosaïque d'images, il faudra respecter les conditions suivantes :

  • Les images doivent avoir le même échantillonnage (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Agrandissement - Réduction]).
  • Les images doivent avoir la même orientation (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Rotation]).
  • Les images devront avoir une partie suffisamment commune pour les relier !
  • Pour cette opération manuelle, les images ont besoin d'avoir le même niveau radiométrique ! ( c'est-à-dire qu'au départ, les pixels communs n'ont pas besoin d'avoir à peu près la même intensité ). Ce même niveau peut être obtenu en partie avec la commande [Prétraitements] > [Fond du ciel identique]. Une autre possibilité est de réaliser auparavant une statistique fenêtrée sur une partie la plus commune à chaque image. On note la valeur moyenne des deux images et on multiplie (" Traitement / Multiplication") l'image de valeur moyenne la plus faible par une constante de façon à ce que les deux images aient la même moyenne.

Chargez les 2 images concernées, puis sélectionnez la première. Au lancement de la fonction, la fenêtre suivante s'ouvre :

Sélectionnez alors la seconde image en utilisant les flèches en bas à droite de la fenêtre.

Une fois que les 2 images ont la même moyenne, il s'agit de répérer des pixels identiques : dans le cas d'image stellaire, il est alors possible de cibler à la fraction de pixels près la position d'un objet stellaire en commun (à l'aide de la commande [Analyse] > [Centroïde] > [Gauss 2D (Rayon=..p)]); dans le cas d'images planétaires, il faut faire au mieux ... PRiSM demande alors de remplir le pixel considéré en commun (nombres réels acceptés) :

En cliquant sur "OK", la mosaïque stellaire apparaît. L'image résultante est fournie pour exemple.

Il y a éventuellement des défauts cosmétiques qui apparaissent à la jonction des images ... Ces derniers peuvent être corrigés à l'aide de la commande "cicatriser une ligne" ou "cicatriser une colonne" du menu contextuel d'une image.

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
2 images de M81 résultant de la séparation d'une image de départ. Les paramètres n'ayant pas été modifiés, les coefficients renvoyés doivent être de 1 pour le coefficient multiplicatif et 0 pour l'Offset ...

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Mosaïque automatique

> Transformation > Mosaïque automatique

Lancement : Menu [Transformation] > [Mosaïque] > [Automatique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de réaliser la mosaïque de 2 images planétaires ou stellaires de manière automatique.

Lorsque le CCD est trop petit pour faire entrer un objet trop grand, la prise de vues multiples en décalant le CCD à chaque fois (en gardant une zone commune à chaque image) permet de compenser cette faiblesse des CCD et des optiques. Grâce à cette commande, cette opération peut être possible.

Attention : dans tous les cas, pour réaliser une mosaïque d'images, il faudra respecter les conditions suivantes :

  • Les images doivent avoir le même échantillonnage (si ce n'est pas le cas, utiliser à cette fin la transformation [Transformation] > [Agrandissement - Réduction]).
  • Les images devront avoir une partie suffisamment commune pour les relier !
  • Par contre, les images ne doivent pas nécessairement avoir la même orientation.
  • Les images n'ont pas besoin d'avoir le même niveau radiométrique ! ( c'est-à-dire qu'au départ, les pixels communs n'ont pas besoin d'avoir à peu près la même intensité )

Au démarrage, il faut que toutes les images soient ouvertes et faire coulisser les imagettes pour former l'image :

Il est nécessaire de faire glisser les imagettes dans le bon cadran (planétaire ou stellaire) de façon à former l'image.

L'image finale apparaît alors.

Images supportant cette fonction :
images monochromes ou couleurs 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
4 images d'un cratère de la Lune à raccorder.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Projection planétaire : Cartographie sur sphère

> Transformation > Projection planétaire : Cartographie sur sphère

Lancement : Menu [Transformation] > [Cartographie] > [Cartographie sur une sphère]

But : Cette fonction permet d'afficher une grille de coordonnées planétocentriques (latitudes et longitudes) sur une image de planète.

Nous allons utiliser cette fonction pour afficher une grille de coordonnées sur une image de Jupiter :

Cette image à été prise par Gino Farroni le 7 août 1998 sur son T400.

Pour pouvoir insérer la grille de coordonnées sur cette image, il faut tout d'abord l'ouvrir dans Prism. Vous pourrez alors lancer la fonction "Cartographie sur une Sphère". La boite de dialogue de projection planétaire apparaît :

Pour apprendre à utiliser cet outil, reportez vous à la page d'aide de la fonction "Projection planétaire".

Le champs "pas" permet de régler le pas de la grille en degrés :

Et voici le résultat qui apparaît finalement à l'écran :

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
image de Jupiter.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Projection planétaire : Projection sphère planétaire

> Transformation > Projection planétaire : Projection sphère planétaire

Lancement : Menu [Transformation] > [Cartographie] > [Projection sphère planétaire]

But : Cette fonction est la fonction de base utilisée par Prism pour tracer des cartes des surfaces planétaires et dessiner des grilles sur les planètes. Elle permet de générer une partie de la carte d'une planète à partir d'une image unique. Elle est très facile à utiliser car elle est basée sur un calcul d'éphémérides physique des planètes qui permet un réglage quasiment automatique de la projection. De plus, tous les paramètres de la projection sont réglés de manière interactive.
Elle est utilisée par les fonctions [Transformation] > [Cartographie] > [Cartographie sur une sphère] et [Analyse] > [Planisphère Planétaire].

Algorithme utilisé

Voici le principe général de l'algorithme utilisé sous forme d'organigramme :

La première étape consiste à procéder aux calculs d'éphémérides physiques de la planète photographiée grâce à la date et à l'heure de prise de vue. Les paramètres physiques calculés ici permettront de préparer la projection en préréglant la position d'une grille sur la planète

La deuxième étape consiste à affiner les valeurs des paramètres physiques et à régler les paramètres de projection. Le résultat de la projection est mis à jour en temps réel pour faciliter ces réglages.

La projection utilisée est la projection cylindrique simple. Elle consiste à développer tous les points de la sphère planétaire sur un cylindre dont l'axe passe par l'axe planétaire :

Le maillage est régulier et identique en longitude et en latitude. Par conséquent un carré de 20 degrés de longitude sur 20 degrés de latitude est représenté par un carré sur le planisphère :

Maillage sur la planète | Maillage sur la carte

Par exemple, si l'échantillonnage de la carte est de 1 degrés par pixels, le carré précédent aura 20 pixels de côté.

L'inconvénient de cette projection est la déformation excessive de la carte aux pôles. En effet les pôles qui sont des points sur la planète sont transformés en droites sur la carte. Les pôles nord et sud deviennent les côtés nord et sud de la carte.

Cependant, cette projection reste très pratique car le maillage régulier permet de mesurer facilement la position des détails sur la carte. En effet la relation entre la position des pixels et les cordonnées planétaires reste linéaire.

Pour plus de détails sur l'algorithme de projection, je vous conseille la lecture de l'excellent livre "Astronomie CCD" de Christian Buil pages 199 à 203.

Utilisation

Nous allons utiliser cette fonction pour générer un partie de planisphère de Jupiter à partir de l'image suivante :

Cette image est le résultat du compositage de 7 images prises par Philippe Buttani le 8 août 1998 entre 1h01m04s et 1h05m04s. Elle à été traitée par les ondelettes pour en rehausser les contrastes.

Après avoir lancé la fonction "Projection sphère planétaire" la boite de dialogue apparaît :

Le premier réglage à effectuer consiste à indiquer quelle planète nous allons "torturer", ici Jupiter :

Le deuxième réglage consiste à ajuster la focale, l'inclinaison et les coordonnées du centre de la planète pour que les contours extérieurs de la grille rouge suivent au mieux les contours de la planète.

Si vous avez entré la focale de votre télescope dans l'entête de l'image, vous n'aurez pas à la régler ici. C'est le cas de notre exemple.
Si vous avez au préalable trouvé l'inclinaison de votre CCD grâce à la fonction Inclinaison CCD, vous n'aurez pas à la régler ici.
Par contre, l'algorithme de recherche du centre de la planète de la version 4 est assez simple. Il faudra certainement ajuster ces coordonnées.

Vous avez plusieurs possibilités pour régler ces paramètres.
D'abord, vous pouvez rentrer directement leurs valeurs dans les champs :

Ou utiliser la raquette :

L'affectation des boutons, ainsi que les raccourcis clavier sont présentés dans le tableau suivant :

Boutons | Action | Conséquence | Touche du clavier
 | Incliner la grille sur la gauche | Augmentation de l'inclinaison | Touche /
 | Incliner la grille sur la droite | Réduction de l'inclinaison | Touche *
 | Réduire la grille | Réduction de la focale | Touche -
 | Agrandir la grille | Augmentation de la focale | Touche +
 | Déplacer la grille vers le haut | Augmentation de centre y | Touche 8
 | Déplacer la grille vers le bas | Réduction de centre y | Touche 2
 | Déplacer la grille vers la gauche | Réduction de centre x | Touche 4
 | Déplacer la grille vers la droite | Augmentation de centre x | Touche 6

Lorsque l'on clique sur l'un des ces boutons c'est la valeur indiquée dans la raquette [image] qui vient s'ajouter ou se retrancher du centre x, du centre y, de l' inclinaison ou de la focale. Cette valeur peut être réglée entre 0.1 et 10 pour affiner ou accélérer les réglages.

Pour régler le centre de la grille et ses dimensions, commencez par prérégler grossièrement l'inclinaison. Cochez ensuite l'option " Resserre seuils " qui règle les seuils de façon à mettre en évidence les bords de la planète.
Voici la fenêtre une fois ces paramètres réglés :

La ligne verte que l'on devine sur la droite de la planète matérialise sa phase au moment de l'observation. Cette ligne permet de régler la grille sur une image prise en dehors de la période d'opposition pour prendre en compte la phase de la planète.

Pour régler l'inclinaison enlevez l'option "Resserre seuils" et cochez l'option " Avec Grille ". Vous pourrez alors régler l'inclinaison en plaçant les lignes des latitudes parallèlement aux bandes équatoriales de Jupiter :

Il faut maintenant régler les limites de la projection en cliquant sur l'onglet "Planisphère" :

Où vous réglez la largeur et la hauteur de la projection. Le principe de ce réglage est de maximiser ces paramètre pour avoir la plus grande partie possible de la carte. On est limité par les déformations qui apparaissent aux bords de la projection. Pour notre exemple, nous pouvons prendre le réglage :

Les images planétaires sont toujours plus sombres au bord qu'au centre du disque. Si l'on veut pouvoir créer des cartes à partir de plusieurs projections, il faut corriger cet assombrissement en augmentant l'intensité des pixels du bord. Sans cette correction, les différentes parties de la carte provenant de différentes images ne s'accordent pas à leurs bords.
La loi d'assombrissement utilisée est : I(theta) = cosk(theta). Pour régler cette loi d'assombrissement, il faut régler le paramètre k. Sa valeur peut varier entre 0 et 1.
Ce paramètre k est à rentrer dans le champs "Assombrissement". Il faut donc régler ce coefficient d'assombrissement de manière à corriger l'effet de l'assombrissement centre-bord pour avoir une projection aussi "plate" que possible.

Dans notre exemple, un coefficient de 0.5 semble donner un bon résultat :

La dernière étape consiste à choisir les dimensions de l'image finale qui contiendra le planisphère en choisissant son échantillonnage. Les choix possibles varient entre 1 et 4 pixels par degrés. Les tailles des planisphères seront :

échantillonnage | Taille W1 | Taille W2
1 | 360 x 30 | 360 x 180
2 | 720 x 60 | 720 x 360
3 | 1080 x 90 | 1080 x 540
4 | 1440 x 120 | 1440 x 720

Vous avez intérêt à choisir un échantillonnage plus grand quand vous avez beaucoup de détails sur votre planète. Pour régler cet échantillonnage, vous entrez la valeur désirée dans le champs "Pixels/degré". En choisissant 1 pixel par degré puis en cliquant sur le bouton "OK" nous obtenons finalement les deux planisphères suivants :

Planisphère W1

Planisphère W2

Pour Mars et Jupiter nous n'obtiendrions que le planisphère du bas.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
image de Jupiter.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Transformations / Projection planétaire : Cylindre vers sphère

> Transformation > Projection planétaire : Cylindre vers sphère

Lancement : Menu [Transformation] > [Cartographie] > [Cylindre vers sphère]

But :Cette fonction permet de créer une vue télescopique d'une planète à partir de son planisphère. Elle permet donc de recréer une image d'une planète telle qu'on la voit dans un télescope. Elle permet aussi de voir cette planète sous des angles impossibles à obtenir depuis la terre comme des vues des pôles.

Utilisation

Nous allons utiliser cette fonction pour créer une image télescopique de Jupiter à partir du planisphère suivant :

Ce planisphère a été créé à partir d'une série d'images prises par Antonio Cidadao les 14 et 15 octobre 1999. Le planisphère original était en couleur. Nous avons extrait la composante rouge de l'image originale car la fonction n'accepte pour l'instant que des planisphères en niveaux de gris.

Pour pouvoir créer une image de jupiter telle que l'on peut la voir dans un télescope, il faut tout d'abord l'ouvrir dans Prism. Vous pourrez alors lancer la fonction. La boite de dialogue apparaît :

Les champs " Angle de latitude du pole en ° " et " Angle de longitude du pole en ° " permettent de définir l'angle de visualisation de la planète. Ces angles sont représentés dans la figure suivante :

Où lp est l'angle de longitude du pôle et fp l'angle de latitude du pôle. Le plan XY est le plan de l'écran de l'ordinateur. L'axe Z est perpendiculaire à cet écran.

Le champs " Angle de longitude de décalage en ° " permet de faire tourner la planète sur son axe de rotation.
C'est la longitude du méridien central ou longitude planétocentrique si l'on règle à 0 l'angle de longitude du pôle.

Grâce à cette fonction, l'on peut par exemple régénérer une des images qui ont servi à créer le planisphère. C'est le cas de l'image suivante :

Les fonctions [Transformation] > [Cartographie] > [Cartographie sur une sphère] et [Transformation] > [Cartographie] > [Projection sphère planétaire] permettent de trouver la latitude du centre et la longitude du méridien central de Jupiter au moment de la prise du vue. La latitude du centre est de 3.33° , donc l'angle de latitude du pôle doit être de 90°-3.33=86.77. La longitude du méridien central du système 2 est de 116.59 °.
Par conséquent, la boite de dialogue doit être complétée comme indiqué ici :

Et nous obtenons l'image suivante :

Ou les zones qui n'ont pas été cartographiées on été grisées avec la fonction [Transformation] > [Seuillage]. Nous pouvons remarquer que l'aplatissement n'est pas encore pris en compte et que le coefficient d'assombrissement choisit pour la création du planisphère était sans doute trop faible puisque l'on remarque des zones plus sombres au nord et au sud. La grille de coordonnées qui est affichée sur la planète est celle de la version 3 et a un pas fixe de 20°. Pour l'effacer il suffit de traiter l'image ( Faire deux miroir X pour l'effacer sans affecter l'image ).

On peut aussi créer des vues de la planète d'un vaisseau spatial comme cette vue du pôle nord :

Dans les mois qui suivront la sortie de la version 4 de Prism, cette fonction sera modifiée pour en accroître la convivialité, prendre en compte l'aplatissement des planètes, la nouvelle grille de coordonnée et les images en couleur.

Images supportant cette fonction :
images monochromes 16 ou 32 bits.

Fonction(s) Script associée(s):
Aucune

Image de test :
image de Jupiter.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Tranformations / Conversion format Entier vers format Réel

> Transformations > Conversion du format Entier au format Réel.

Lancement : Menu [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Quelques définitions :

  • Images au format entier : Tous les pixels de l'images sont codés par valeurs entières de -32767 à +32767. Lors de l'aquisition, les valeurs obtenues sont nécessairement positives (de 0 à 32767) et les valeurs négatives sont réservées lors de traitement successifs (par exemple, une soustraction d'image pourra fournir des valeurs résultantes négatives). Le problème principal d'un tel codage réside dans le fait qu'il n'y a pas d'intermédiaire entre deux valeurs et que l'image "sature" dès que la valeur de 32767 est atteinte. Ceci oblige pour la majeure partie des traitements à normaliser l'image résultante après traitement. En consultant les infomrations sur une image, l'utilisateur sait sous quelle forme est codé chacun des pixels.
  • Images au format réel : Ces images sont codées avec un format réel et chaque pixel a donc une valeur attribuée codée sur 4 octects (au lieu de 1 pour le format entier). Le traitement des images ne demande donc aucune précaution particulière et se ait en toute simplicité. Historiquement, le défaut d'un tel format est la place prise par une image sur le disque dur et en mémoire de l'ordinateur. A l'heure actuelle, une telle place ne pose plus aucun problème au vu de la puissance actuelle des ordanteurs. En consultant les infomrations sur une image, l'utilisateur sait sous quelle forme est codé chacun des pixels.
    Ce format est supporté tant en CPA qu'en FITS.

Cette fonction permet de changer le format de représentation interne des pixels d'une image. Ici, on passe d'un format Entier à un format Réel.
Le menu doit être sélectionné à partir de l'image au format entier. La tranformation est immédiate et l'image doit être sauvegardée si l'utilisateur désire conserver cette transformation. Il suffit de consulter les informations sur l'image pour se persuader du changement de format.

Images supportant cette fonction :
Images au format entier !

Fonction(s) Script associée(s):
INT2REAL

Conditions d'activation :
Que l'image soit ouverte sous PRiSM

Prérequis :
voir haut de la page

Voir aussi :
Transformation du format Réel au format Entier

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2007


Tranformations / Conversion format Réel vers format Entier

> Transformations > Conversion du format Réel au format Entier.

Lancement : Menu [Transformations] > [Conversion de type de pixels] > [Image pixels réels vers entiers]

Quelques définitions :

  • Images au format entier : Tous les pixels de l'images sont codés par valeurs entières de -32767 à +32767. Lors de l'aquisition, les valeurs obtenues sont nécessairement positives (de 0 à 32767) et les valeurs négatives sont réservées lors de traitement successifs (par exemple, une soustraction d'image pourra fournir des valeurs résultantes négatives). Le problème principal d'un tel codage réside dans le fait qu'il n'y a pas d'intermédiaire entre deux valeurs et que l'image "sature" dès que la valeur de 32767 est atteinte. Ceci oblige pour la majeure partie des traitements à normaliser l'image résultante après traitement. En consultant les infomrations sur une image, l'utilisateur sait sous quelle forme est codé chacun des pixels.
  • Images au format réel : Ces images sont codées avec un format réel et chaque pixel a donc une valeur attribuée codée sur 4 octects (au lieu de 1 pour le format entier). Le traitement des images ne demande donc aucune précaution particulière et se ait en toute simplicité. Historiquement, le défaut d'un tel format est la place prise par une image sur le disque dur et en mémoire de l'ordinateur. A l'heure actuelle, une telle place ne pose plus aucun problème au vu de la puissance actuelle des ordanteurs. En consultant les infomrations sur une image, l'utilisateur sait sous quelle forme est codé chacun des pixels.
    Ce format est supporté tant en CPA qu'en FITS.

Cette fonction permet de changer le format de représentation interne des pixels d'une image. Ici, on passe d'un format Réel à un format Entier.
Le menu doit être sélectionné à partir de l'image au format réel. La tranformation est immédiate et l'image doit être sauvegardée si l'utilisateur désire conserver cette transformation. Il suffit de consulter les informations sur l'image pour se persuader du changement de format.

Mise en garde importante : Tous les pixels dont la valeur est supérieure en valeur absolue à 32767.0 sera donné à la valeur de 32767. Cette fonction aura donc 2 conséquences importantes :
* Ecréter l'image.
* Rendre l'image codée "en escalier" car les valeurs seront arrondies à l'entier le plus proche.
Il est donc fortement conseillé d'utiliser cette fonction UNIQUEMENT pour un besoin bien précis et AVEC beaucoup de précaution ! D'autant que toutes les fonctions de PRiSM manipulent parfaitement le format réel (dit "32 bits").

Images supportant cette fonction :
Images au format réel !

Fonction(s) Script associée(s):
REAL2INT

Conditions d'activation du menu :
Que l'image soit ouverte sous PRiSM

Prérequis :
voir haut de la page

Voir aussi :
Transformation du format Entier au format Réel

Avril 2007


Tranformations / Conversion vers format complexe

> Transformations > Conversion vers format complexe

Lancement : Menu [Transformations] > [Conversion de type de pixels] > [Image à pixels complexes crée à partir de deux images]

Cette fonction permet de combiner deux images en une image codées en valeurs complexes.
Au lancement de la fonction, il est nécessaire de préciser les images utilisées :

Il est possible de choisir de coder soit (partie réelle, partie imaginaire) soit la représentation (module,phase). Le choix est laissé à l'utilisateur. Il faut cocher la case si on veut coder l'image en (partie imaginaire, partie réelle).

Choix du codage

La tranformation est immédiate et l'image doit être sauvegardée si l'utilisateur désire conserver cette transformation.

Images supportant cette fonction :
Images aux formats entiers ou réels

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Que les images soient ouvertes sous PRiSM

Images de test :
2 images : une représentant la partie réelle d'une transformation de Fourier et l'autre la partie imaginaire.

Mars 2008


Dossier / Trichromie / Constraste-Luminosité

> Dossier > Trichromie > Constraste-Luminosité

But : Réglage des contraste/luminosité d'une image RVB.

La fenêtre de réglage classique ( mais en trois couleurs ) apparaît.

Le réglage des seuils de visualisation d'une image trichrome; Cliquer sur l'option désirée pour plus de détails
Le réglage des seuils de visualisation d'une image trichrome

Comme les images trichromes sont le compositage de trois images R, V et B, on peut régler le contraste pour chacune de ces couleurs. On peut, avec les seuils de visualisation, essayer de faire apparaître l'image comme dans la réalité. Cependant, cette fonction permet surtout de donner une dimension esthétique à l'image qui est supérieure.

La description des options est la suivantes :

  • Rouge, Vert et Bleu :
    Les barres permettent de régler, grace à la souris, les valeurs des seuils hauts et des seuils bas pour chacune des trois couleurs précitées.

  • Auto RVB :
    Cette option permet de régler automatiquement les seuils haut et bas pour chacune des 3 couleurs en même temps. Le principe est identique au réglage automatique pour chacune des couleurs.

  • Auto R :
    Cette option permet de régler automatiquement les seuils haut et bas pour la couleur rouge. Le fait d'appuyer sur ce bouton laisse les seuils haut et bas des 2 autres couleurs tout en replaçant leur barre à des niveaux intermédiaires.
    Pour les images codées en valeurs d'intesités entière, La technique de réglage automatique est basée sur l'histogramme de l'image. Le seuil bas est pris à 5% de l'histogramme ( afin de représenter le fond de ciel par une même couleur ... noire lorsqu'on utilise la palette noir et blanc positive ). Ceci signifie qu'on prend la valeur de l'intensité du pixel qui se situe à la place 5 sur 100, si on classe les pixels par ordre croissant d'intensité. Le seuil haut est pris à 99,5% de l'histogramme.
    Pour les images codées en valeur d'intensités réelles, la technique est basée sur la médiane de l'image. PRiSM calcule la médiane et l'écart-type dans l'image. le seuil bas est égal à la médiane soustrait d'un certain nombre de fois l'écart-type. Le seuil haut est égal à la médiane ajoutée d'un certain nombre de fois l'écart-type

  • Auto V :
    Cette option permet de régler automatiquement les seuils haut et bas pour la couleur verte. Le fait d'appuyer sur ce bouton laisse les seuils haut et bas des 2 autres couleurs tout en replaçant leur barre à des niveaux intermédiaires.
    Pour les images codées en valeurs d'intesités entière, La technique de réglage automatique est basée sur l'histogramme de l'image. Le seuil bas est pris à 5% de l'histogramme ( afin de représenter le fond de ciel par une même couleur ... noire lorsqu'on utilise la palette noir et blanc positive ). Ceci signifie qu'on prend la valeur de l'intensité du pixel qui se situe à la place 5 sur 100, si on classe les pixels par ordre croissant d'intensité. Le seuil haut est pris à 99,5% de l'histogramme.
    Pour les images codées en valeur d'intensités réelles, la technique est basée sur la médiane de l'image. PRiSM calcule la médiane et l'écart-type dans l'image. le seuil bas est égal à la médiane soustrait d'un certain nombre de fois l'écart-type. Le seuil haut est égal à la médiane ajoutée d'un certain nombre de fois l'écart-type

  • Auto B :
    Cette option permet de régler automatiquement les seuils haut et bas pour la couleur bleue. Le fait d'appuyer sur ce bouton laisse les seuils haut et bas des 2 autres couleurs tout en replaçant leur barre à des niveaux intermédiaires.
    Pour les images codées en valeurs d'intesités entière, La technique de réglage automatique est basée sur l'histogramme de l'image. Le seuil bas est pris à 5% de l'histogramme ( afin de représenter le fond de ciel par une même couleur ... noire lorsqu'on utilise la palette noir et blanc positive ). Ceci signifie qu'on prend la valeur de l'intensité du pixel qui se situe à la place 5 sur 100, si on classe les pixels par ordre croissant d'intensité. Le seuil haut est pris à 99,5% de l'histogramme.
    Pour les images codées en valeur d'intensités réelles, la technique est basée sur la médiane de l'image. PRiSM calcule la médiane et l'écart-type dans l'image. le seuil bas est égal à la médiane soustrait d'un certain nombre de fois l'écart-type. Le seuil haut est égal à la médiane ajoutée d'un certain nombre de fois l'écart-type

  • Négatif :
    Permet d'inverser les valeurs des euils haut et bas pour chacune des couleurs. L'image est alors obtenue en négatif

  • Seuil haut :
    Indique les valeurs en ADU donné au seuil haut pour chacune des 3 couleurs.
    Ces dernières peuvent être changées par la souris ou manuellement dans les cases prévues à cet effet. Il suffit de cliquer par la suite sur le bouton " Appliquer " pour que la transformation puisse prendre effet.

  • Seuil bas :
    Indique les valeurs en ADU donné au seuil bas pour chacune des 3 couleurs.
    Ces dernières peuvent être changées par la souris ou manuellement dans les cases prévues à cet effet. Il suffit de cliquer par la suite sur le bouton " Appliquer " pour que la transformation puisse prendre effet.

Les icônes permettant l'obtention de " fausses " couleurs des images ne sont pas présents, puiqu'en toute rigueur, on peut assimiler ici les couleurs aux vraies couleurs.

Images nécessaires :
images CPA et FITS trichromes

Images exemple :
M27 RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Assemblage RVB

> Trichromie > Assemblage RVB

Lancement : Menu [Trichromie] > [Assembler trois images RVB]

Cette fonction permet de construire une image couleur à partir de 3 images monochromes contenant les composantes Rouge (R), Vert (V) et Bleu (B).

Les trois images composantes R, V et B doivent être ouvertes dans PRiSM.

Au lancement de la fonction, la fenêtre suivante s'ouvre, permettant de sélectionner les 3 composantes R, V et B de l'image :

Quand les 3 composantes ont été sélectionnées l'une après l'autre, il reste à cliquer sur le bouton [OK].

L'image couleur résultante est alors affichée en couleur.

Il est fortement conseillé d'enregistrer l'image couleur au format .CPA. En effet, les 3 composantes seront stockées séparément (mais dans le même fichier) et avec toute leur dynamique. Il est toutefois possible d'enregister l'image couleur aux formats .BMP ou .JPG.

Fonction(s) Script associée(s):
Combine_Color_Img

Images nécessaires :
images CPA et FITS N&B

Images de test :
Lot de 3 images : M27 R, M27 V, M27 B

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Assemblage LRVB

> Trichromie > Assemblage LRVB

Lancement : Menu [Trichromie] > [Assembler 4 images LRVB]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de construire une image couleur haute résolution, à partir :

  • de 3 images R, V et B basse résolution.
  • une image noir et blanc de haute résolution.

L'algorithme est très simple : On convertit les 3 images RVB en 3 images HSI, et on remplace l'image I par l'image noir et blanc de haute résolution, puis on convertit les 3 composantes HSI ainsi obtenues en une image RVB.

Avant de lancer cette fonction, il faut que les 4 images L, R, V et B soient chargées, et qu'elle soient de même taille, recalées les unes par rapport aux autres et toutes au même format interne (représentation en nombres entiers ou réels).

Après le lancement de la fonction, une fenêtre s'ouvre permettant de sélectionner les 4 composantes LRVG qui sont ensuite assemblées, puis le résultat de l'assemblage est affiché.

Exemple de compositage LRGB :

Composante L haute résolution | Composante R basse résolution | Composante V basse résolution | Composante B basse résolution
Résultat du compositage LRVB |  | Résultat d'un compositage traditionnel RVB

En savoir plus :
Le site de Kunihiko Okano
Le site de McLaughlin

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS N&B

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Séparer les plans de couleur d'une image RVB

> Trichromie > Séparer les plans de couleur d'une image RVB

Lancement : Menu [Trichromie] > [Séparer les plans de couleur d'une image RVB]

But : Cette fonction permet de séparer les composantes RVB d'une image trichromique.

Une image et trichromie doit être chargée et sélectionnée. Dès le lancement de la fonction, le logiciel calcule les composantes RVB de l'image et les affiche.

Fonction(s) Script associée(s):
Split_Color_Img

Images nécessaires :
images CPA et FITS trichromes

Image de test :
M27 RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.


Trichromie / Image N&B

> Trichromie > Transformer en image N&B

Lancement : Menu [Trichromie] > [Image Noir&Blanc]

But : Cette fonction transforme une image trichrome en une image monochrome. L'action de la fonction est immédiate.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Image de test :
M27 RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Assemblage RVB

> Trichromie > Ajuster la saturation

Lancement : Menu [Trichromie] > [Ajuster la saturation]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet de régler les paramètres de saturation d'une image couleur.

Il est possible de choisir une visualisation automatique ou alors de régler les seuils avec les boutons sur la droite de la fenêtre d'exécution.
Le seuil de saturation se règle grâce au curseur en déplaçant la souris.

On voit apparaître le résultat sur l'encart de droite de la fenêtre. Pour valider le résultat, il faut cliquer sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Image de test :
Image RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Décembre 2010


Trichromie / Equilibrer les pixels de la matrice de Bayer

> Trichromie > Equilibrer les pixels de la matrice de Bayer

Lancement : Menu [Trichromie] > [Equilibrer les pixels de la matrice de Bayer]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet d'équilibrer les pixels de la matrice de Bayer.

Un fenêtre exemple

La couleur de référence est le Vert. Il n'est donc possible que d'appliquer un offset à ce plan.

Pour les autres plans, on peut non seulement appliquer un offset mais aussi un coefficient multiplicatif.

Fonction(s) Script associée(s):
Combine_Color_Img

Images nécessaires :
images CPA et FITS N&B

Images de test :
Image RAW (motif n°1)

Prérequis :
Les images au format RAW et la matrice de Bayer

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Trichromie / Translation des plans de couleur

> Trichromie > Translation des plans de couleur

Lancement : Menu [Trichromie] > [Translation des plans de couleur]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de recaler manuellement les plans de couleurs les uns par rapport au autres de façon à rendre les étoiles les plus ponctuelles possibles. La fenêtre de saisie des valeurs de translation en pixels est ouverte :

Paramètres à fournir

L'opération est effectuée et l'image résultante remplace la précédente (cette opération peut être annulée).

Cette opération permet d'effectuer manuellement celle proposée au menu [Trichromie] > [Recalage Auto des plans de couleur]

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Image de test :
M27 RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Recalage Auto des plans de couleur

> Trichromie > Recalage Auto des plans de couleur

Lancement : Menu [Trichromie] > [Recalage Auto des plans de couleur]

But : Cette fonction permet de recaler les plans de couleurs les uns par rapport au autres de façon à rendre l'image la plus "nette possible". Cette fonction fonctionne aussi bien sur des objets ponctuels comme les étoiles que sur des objets étendus comme des images planétaires.

L'opération est effectuée et le résultat renvoyé dans une fenêtre script :

Un exemple de résultat

Sur l'image ci-dessous, on voit immédiatement le résultat d'une telle fonction :

Fonction(s) Script associée(s):
RecalageAuto_Inter

Images nécessaires :
images CPA et FITS trichromes

Image de test :
Image RVB "floue"

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Trichromie / RVB vers HSI

> Trichromie > Convertir de l'espace RVB vers l'espace HSI

Lancement : Menu [Trichromie] > [RVB (type réel) vers HSI]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de convertir une image couleur au format RVB en une image HSI.

L'image doit être chargée et sélectionnée avant le lancement de la fonction, et doit être au format "Nombres réels". Si nécessaire on pourra utiliser la fonction [Traitement] > [Conversion de type] > [Entier vers Réels]

Dès le lancement de la fonction, le logiciel calcule et affiche les composantes RVB de l'image

Pour plus d'informations sur les espaces de couleur RVB et HSI, voir la page dédiée à ce sujet.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Images exemple :
M27 RVB Reel

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / HSI vers RVB

> Trichromie > Convertir de l'espace HSI vers l'espace RVB

Lancement : Menu [Trichromie] > [HSI (type réel) vers RVB]

Cette fonction permet de convertir une image couleur au format HSI en une image RVB.

L'image doit être chargée et sélectionnée avant le lancement de la fonction, et doit être au format "Nombres réels". Si nécessaire on pourra utiliser la fonction [Traitement] > [Conversion de type] > [Entier vers Réels]

Dès le lancement de la fonction, le logiciel calcule et affiche les composantes RVB de l'image

Pour plus d'informations sur les espaces de couleurs RVB et HSI, voir la page dédiée à ce sujet.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Images exemple :
Lot de 3 images : M27H, M27S, M27I

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Echanger Plans R et V

> Trichromie > Echanger plans R et V

Lancement : Menu [Trichromie] > [Echanger Plan R et Plan V]

But : Cette fonction échange le plan R avec le plan V d'une image.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Image de test :
M27 RVB

Prérequis :
Luminosité et contraste d'une image trichrome

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Echanger Plans R et B

> Trichromie > Echanger plans R et B

Lancement : Menu [Trichromie] > [Echanger Plan R et Plan B]

But : Cette fonction échange le plan R avec le plan B d'une image.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Image de test :
M27 RVB

Prérequis :
Luminosité et contraste d'une image trichrome

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Echanger Plans B et V

> Trichromie > Echanger plans B et V

Lancement : Menu [Trichromie] > [Echanger Plan B et Plan V]

But : Cette fonction échange le plan B avec le plan V d'une image.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Image de test :
M27 RVB

Prérequis :
Luminosité et contraste d'une image trichrome

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / Créer matrice de Bayer

> Trichromie > Créer matrice de Bayer

Lancement : Menu [Trichromie] > [Créer matrice de Bayer]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Permet de reformer une image RAW d'APN à partir d'une image RVB.

L'image RVB :::::::::::::::>>>>>>>>> L'image bayerisée

Cette fonction permet de simuler la création d'une image RAW mais cette fois en colorisant le pixel correspondant à la matrice de Bayer.

Pour se faire, le logiciel part d'une image trichrome et pour chaque pixel, une intensité R, V ou B n'est pas annulée. La matrice de référence pour une telle opération est la matrice n°1 dont on trouve les arrangements dans le menu, par exemple, [Prétraitement] > [Enlever Offset, Flat, Noir (Auto)].

Fonction(s) Script associée(s):
Balance_Bayer

Images nécessaires :
images CPA et FITS trichromes

Prérequis :
Les images au format RAW et la matrice de Bayer

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / N&B ==> RVB

> Trichromie > N&B ==> RVB

Lancement : Menu [Trichromie] > [image RGB à partir d'une image Bayer N&B] > [Avec interpolation bi-linéaire]

Touche de raccourci : MAJ + F12

But : Permet de créer une image RVB à partir d'une image N&B et de la connaissance de la matrice de Bayer.

Il faut choisir la matrice de Bayer au démarrage de la fonction :

La fenêtre proposée

L'image s'affiche ensuite :

Fonction(s) Script associée(s):
Debayer

Images nécessaires :
images CPA et FITS monochromes

Image de test :
Image RAW (motif n°1)

Prérequis :
Les images au format RAW et la matrice de Bayer

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Trichromie / N&B ==> RVB

> Trichromie > N&B ==> RVB

Lancement : Menu [Trichromie] > [image RGB à partir d'une image Bayer N&B] > [Avec interpolation (Gradient)]

But : Permet de créer une image RVB à partir d'une image N&B et de la connaissance de la matrice de Bayer.

Il faut choisir la matrice de Bayer au démarrage de la fonction :

La fenêtre proposée

En construction

Fonction(s) Script associée(s):
Debayer

Images nécessaires :
images CPA et FITS monochromes

Image de test :
Image RAW (motif n°1)

Prérequis :
Les images au format RAW et la matrice de Bayer

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Trichromie / N&B ==> RVB

> Trichromie > N&B ==> RVB

Lancement : Menu [Trichromie] > [image RGB à partir d'une image Bayer N&B] > [Sans interpolation (bin 2x2)]

But : Permet de créer une image RVB à partir d'une image N&B et de la connaissance de la matrice de Bayer.

Il faut choisir la matrice de Bayer au démarrage de la fonction :

La fenêtre proposée

En construction

Fonction(s) Script associée(s):
Debayer

Images nécessaires :
images CPA et FITS monochromes

Image de test :
Image RAW (motif n°1)

Prérequis :
Les images au format RAW et la matrice de Bayer

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Trichromie / N&B Bayer ==> R, V et B

> Trichromie > N&B Bayer ==> R, V et B

Lancement : Menu [Trichromie] > [3 images RGB à partir d'une image Bayer N&B]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de créer 3 image R, V et B à partir d'une image N&B et d'une matrice de Bayer. Les 3 images s'affichent alors à l'écran après lancement de la fonction

Cette fonction est très utile lors de la transformation d'une image résultante d'un APN.
Elle rejoint la fonction du menu [Trichromie] > [Séparer les plans de couleur d'une image RVB], cette dernière concernant directement les images obtenues à partir d'une addition d'images à travers différents filtres.

A l'ouverture, cette fonction demande de connaître la matrice de Bayer correspondante à l'appareil utilisé : le choix du motif (CNY ou RVB) et s'il est nécessaire de convertir une matrice CNY en RVB : permet de sélectionner une matrice de Bayer d'appareil utilisant le codage CMY.

Les 3 images créées ne font que séparer les pixels en fonction de la matrice de bayer indiquée. Deux des trois images auront pour dimension la moitié de celle de l'image RAW de départ. La troisième (correspondante au double pixel de la matrice de Bayer) aura alors une longueur égale à celle de l'image et une autre longueur moitié de celle de l'image).
Les images peuvent ensuite être traitées comme toute image monochrome.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS monochromes

Image de test :
M31 APN

Prérequis :
Les images au format RAW et la matrice de Bayer

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / RVB vers YUV

> Trichromie > Convertir de l'espace RVB vers l'espace YUV

Lancement : Menu [Trichromie] > [Convertir image RGB en YUV 4:2:2]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de convertir une image couleur au format RVB en une image YUV.

L'image doit être chargée et sélectionnée avant le lancement de la fonction.

Dès le lancement de la fonction, le logiciel calcule et affiche les composantes YUV de l'image. Sur l'image résultante, lors du déplacement du curseur, les intensités RVB sont toujours affichées mais correspondent en fait respectivement aux valeurs YUV.

Pour plus d'informations sur les espaces de couleur RVB et YUV, voir la page dédiée à ce sujet.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Images exemple :
M27 RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Trichromie / YUV vers RVB

> Trichromie > Convertir de l'espace YUV vers l'espace RVB

Lancement : Menu [Trichromie] > [Convertir image YUV 4:2:2 en RVB]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de convertir une image couleur au format YUV 4:2:2 en une image RVB.

L'image doit être chargée et sélectionnée avant le lancement de la fonction.

Dès le lancement de la fonction, le logiciel calcule et affiche les composantes RVB de l'image dont les valeurs peuvent être vues à partir du déplacement du curseur de la souris.

Pour plus d'informations sur les espaces de couleurs RVB et YUV, voir la page dédiée à ce sujet.

Fonction(s) Script associée(s):
Aucune

Images nécessaires :
images CPA et FITS trichromes

Images exemple :
M27 YUV

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Traitement / Addition avec une image

> Traitement > Addition avec une image

Lancement : Menu [Traitement] > [Addition]

Cette fonction permet d'additionner 2 images : chaque pixel de coordonnées (X,Y) de l'image finale a une intensité égale la somme des pixels des 2 images de départ situés aux coordonnées (X,Y).

Les images à additionner doivent avoir la même taille et le même format de données et doivent être chargées.

La première des images à additionner étant sélectionnée, la fenêtre suivante s'ouvre dès le lancement de la fonction :

A l'aide des flèches situées en bas à droite de la fenêtre, il faut sélectionner l'image à additionner, puis cliquer sur le bouton [OK].

L'entête de l'image finale est égale à celle de l'image sélectionnée avec le lancement de l'opération.

Dans le cas d'une image en format entier 16 bits, le résultat de la soustraction ne pourra être supérieure à 32767 ou inférieure à -32768 et le résultat du coefficient diviseur est à régler en conséquence. Pour transformer l'image auparavant en format réel 32 bits, aller à la fonction [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels].

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Add

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Soustraction par une image

> Traitement > Soustraction par une image

Lancement : Menu [Traitement] > [Soustraction]

Cette fonction permet de soustraire 2 images : chaque pixel de coordonnées (X,Y) de l'image finale a une intensité égale la différence des pixels des 2 images de départ situés aux coordonnées (X,Y).

Les images à soustraire doivent avoir la même taille et le même format de données et doivent être chargées.

La première des images étant sélectionnée, la fenêtre suivante s'ouvre dès le lancement de la fonction :

A l'aide des flèches situées en bas à droite de la fenêtre, il faut sélectionner l'image qui doit être soustraite à la première, puis cliquer sur le bouton [OK].
L'entête de l'image finale est égale à celle de l'image sélectionnée avec le lancement de l'opération.

Dans le cas d'une image en format entier 16 bits, le résultat de la soustraction ne pourra être supérieure à 32767 ou inférieure à -32768 et le résultat du coefficient diviseur est à régler en conséquence. Pour transformer l'image auparavant en format réel 32 bits, aller à la fonction [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels].

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Sub

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Diviser par une image

> Traitement > Diviser par une image

Lancement : Menu [Traitement] > [Division par une image]

Cette fonction permet de diviser 2 images : chaque pixel de coordonnées (X,Y) de l'image finale a une intensité égale à la division des intensité des pixels des 2 images de départ situés aux coordonnées (X,Y).

Les images à diviser doivent avoir la même taille et le même format de données et doivent être chargées.

La première des images étant sélectionnée, la fenêtre suivante s'ouvre dès le lancement de la fonction :

A l'aide des flèches situées en bas à droite de la fenêtre, il faut sélectionner la deuxième l'image , puis cliquer sur le bouton [OK].

PRiSM demande alors le coefficient multiplicateur à appliquer au résultat avant d'afficher l'image résultante :

Le coefficient multiplicateur

L'entête de l'image finale est égale à celle de l'image sélectionnée avec le lancement de l'opération.

Dans le cas d'une image en format entier 16 bits, le résultat de la multiplication ne pourra être supérieure à 32767 ou inférieure à -32768 et le résultat du coefficient diviseur est à régler en conséquence. Pour transformer l'image auparavant en format réel 32 bits, aller à la fonction [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels].

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Div

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Multiplication par une image

> Traitement > Multiplication par une image

Lancement : Menu [Traitement] > [Multiplication par une image]

Cette fonction permet de multiplicer 2 images : chaque pixel de coordonnées (X,Y) de l'image finale a une intensité égale au produit des pixels des 2 images de départ situés aux coordonnées (X,Y)

Les images à multiplier doivent avoir la même taille et le même format de données et doivent être chargées.

La première des images étant sélectionnée, la fenêtre suivante s'ouvre dès le lancement de la fonction :

A l'aide des flèches situées en bas à droite de la fenêtre, il faut sélectionner la deuxième l'image , puis cliquer sur le bouton [OK].

PRiSM demande alors le coefficient diviseur à appliquer au résultat avant d'afficher l'image résultante :

L'entête de l'image finale est égale à celle de l'image sélectionnée avec le lancement de l'opération.

Dans le cas d'une image en format entier 16 bits, le résultat de la multiplication ne pourra être supérieure à 32767 ou inférieure à -32768 et le résultat du coefficient diviseur est à régler en conséquence. Pour transformer l'image auparavant en format réel 32 bits, aller à la fonction [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels].

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
MultImg

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Multiplication par une constante

> Traitement > Multiplication par une constante

Lancement : Menu [Traitement] > [Multiplication par une constante]

Cette fonction permet de multiplier l'intensité de tous les pixels d'une image par une constante.

L'image à traiter doit être chargée et sélectionnée

Au lancement de l'image, la fenêtre suivante s'ouvre :

Indiquer le coefficient de multiplication

Après avoir entré la constante par laquelle l'image doit être multipliée, il faut cliquer sur le bouton [OK]

Dans le cas d'une image en format entier 16 bits, le résultat de la multiplication ne pourra être supérieure à 32767 ou inférieure à -32768. Pour transformer l'image auparavant aen format réel 32 bits, aller à la fonction [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Mult

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Ajouter une constante

> Traitement > Ajouter une constante

Lancement : Menu [Traitement] > [Ajouter constante]

Cette fonction permet d'ajouter une valeur constante (positive ou négative) à tous les pixels d'une image.

L'images concernée étant chargée et sélectionnée, le lancement de cette fonction provoque l'ouverture d'une fenêtre qui permet d'entrer la valeur constante à ajouter à tous les pixels:

Donner la valeur de la constante

L'opération est effectuée dès qu'on clique sur le bouton [OK].

Dans le cas d'une image en format entier 16 bits, le résultat de la multiplication ne pourra être supérieure à 32767 ou inférieure à -32768. Pour transformer l'image auparavant aen format réel 32 bits, aller à la fonction [Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Offset

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Diviser par une image

> Traitement > Inversion cadrans

Lancement : Menu [Traitement] > [Inversion cadrans]

Cette opération sépare une image (préalablement chargée et sélectionnée) en 4 cadrans et échange ces cadrans comme illustré ci-dessous:

1 | 2
3 | 4
->

4 | 3
2 | 1

Cette fonction permet, par exemple, de vérifier la collimation de son instrument.

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Puissance

> Traitement > Puissance

Lancement : Menu [Traitement] > [Puissance]

But : Permet d'élever toutes les intensités des pixels d'une image à une certaine puissance.

Fonction(s) Script associée(s):
Aucune

Décembre 2010


Traitement / Assembler deux images à histogramme tronqué

> Traitement > Assembler deux images à histogramme tronqué

Lancement : Menu [Traitement] > [Assembler deux images à histogramme tronqué]

Cette fonction permet d'assembler deux images à histogramme tronqué afin de "reconstituer" l'image :

Attention à commencer la jonction à partir de l'image ayant l'histogramme le plus élevé.

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Deux images ouvertes.

Décembre 2010


Traitement / Convlution

> Traitement > Convolution (FFT)

Lancement : Menu [Traitement] > [Convolution (FFT)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

La fonction Convolution permet la convolution de deux images complexes de même taille. Ceci consiste, dans l’espace de Fourier, en une simple multiplication des pixels complexes telle que [image]. Une multiplication dans l'espace de Fourier est équivalent à une convolution dans le domaine spatial. Cette fonction permet de réaliser des convolutions évoluées sans effets de bords (sans perte d’information sur les bords de l’image).

Ceci sert à effectuer des opérations mathématiques des images dans [image]; voir les fonctions spécifiques à l'espace de Fourier pour les applications.

Fonction(s) Script associée(s):
Aucune

Février 2011


Traitement / Complémentaire

> Traitement > Complémentaire (FFT)

Lancement : Menu [Traitement] > [Complémentaire (FFT)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

La fonction Complémentaire multiplie toute la partie imaginaire des pixels d’une image complexe par -1, ce qui est en fait le conjugué des pixels complexes. Le conjugué du complexe [image] est le nombre complexe

Ceci sert à effectuer des opérations mathématiques des images dans [image]; voir les fonctions spécifiques à l'espace de Fourier pour les applications.

Fonction(s) Script associée(s):
Aucune

Fevrier 2011


Traitement / Module

> Traitement > Module (FFT)

Lancement : Menu [Traitement] > [Module (FFT)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Afficher le module d'une image complexe en format 64 bits. De ce fait, cette fonction ne sera accessible que pour des images 64 bits.

Cette fonction convertit une image complexe en une image de nombre réels représentant le module de chaque pixel de l’image de départ. Si [image] est le pixel de départ, le pixel d’arrivée est [image], la partie imaginaire est mise à zéro et l‘image devient une image sur un plan de réels.

Fonction(s) Script associée(s):
MODULE

Février 2011


Traitement / Prduit d'intercorrelation

> Traitement > Produit d'intercorrelation (FFT)

Lancement : Menu [Traitement] > [Produit intercorrelation (FFT)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

La fonction Produit d’intercorrélation (Normalisé) permet le produit d’intercorrélation de deux images complexes de même taille, cela consiste dans l’espace de Fourier a calculer une simple multiplication des pixels [image], où [image] est le complexe conjugué de [image].

Ceci sert à effectuer des opérations mathématiques des images dans [image]; voir les fonctions spécifiques à l'espace de Fourier pour les applications.

Fonction(s) Script associée(s):
InterCor

Février 2011


Traitement / Plans de couleurs cosmétiques

> Traitement > Plans de couleurs cosmétiques

Lancement : Menu [Traitement] > [Opérations cosmétiques] > [Plans de couleurs à traiter]

Cette fonction permet de définir les plans de couleurs pour lesquels des opérations cosmétiques auront lieu sur une image (ces dernières sont accessibles par l'intermédiaire du menu contextuel d'une image).

Au lancement de cette fonction, une fenêtre s'ouvre permettant de sélectionner les plans retenus.

Le choix des plans de couleurs

Les opérations n'auront lieu que sur les plans "cochés".

Images supportant cette fonction :
images trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Image de test :
Toute image RVB

Conditions d'activation du menu :
Qu'une image RVB soit ouverte.

Mars 2008


Traitement / Taille de la zone cosmétique

> Traitement > Taille de la zone cosmétique

Lancement : Menu [Traitement] > [Opérations cosmétiques] > [Taille de la zone à boucher]

Cette fonction permet de définir la taille de la zone à boucher lors des opérations cosmétiques (qui sont accessibles par l'intermédiaire du menu contextuel d'une image).

Au lancement de cette fonction, une fenêtre s'ouvre permettant d'entrer la taille de la zone à boucher.
Cette valeur est en réalité sauvegardée par demi-largeur qui est égale à la division entière de la valeur saisie par 2. La taille de la zone à boucher sera ensuite affichée comme étant égale à 2*demi_largeur+1. Ainsi, saisir comme taille de zone à boucher : 3 ou 4, cela reviendra au même car la taille de la zone à boucher sera au final égal à 3.

Lors d'une opération de bouchage d'une zone, le logiciel bouchera une zone dont la taille sera celle définie précédemment.

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Image de test :
Toute image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Enregistrer des opérations cosmétiques

> Traitement > Enregistrer des opérations cosmétiques

Lancement : Menu [Traitement] > [Opérations cosmétiques] > [Enregistrer opérations]

Cette fonction permet de lancer l'enregistrement d'un ensemble d'opérations cosmétiques effecutées sur une image (les fonctions cosmétiques sont accessibles par l'intermédiaire du menu contextuel d'une image). L'enregistrement peut être sauvegardé dans un "fichier de script cosmétique" (format .COS). Un tel enregistrement pourra être ré-exécuté sur une autre image, grace à la fonction [Traitement] > [Opérations cosmétiques] > [Exécuter un script cosmétique]

Au lancement de cette fonction, un panel de statut apparaît :

Au fur et à mesure ou les opérations cosmétiques (boucher, cicatriser, etc) sont effectuées (grace au menu contextuel sur l'image), le panel se remplit des actions qui sont effectuées :

Voici un exemple d'informations qui sont enregistrées (avec les commentaires après les ":") :

fill 295 242 3         : remplissage du pixel X=295,Y=242 de 3 pixels = boucher zone (3)
fill 179 385 3         : remplissage du pixel X=179,Y=385 de 3 pixels = boucher zone (3)
cicatc 121             : remplissage de la colonne X=121 par le voisinage = cicatrisation colonne
cicatl 276             : remplissage de la ligne Y=276 par le voisinage = cicatrisation ligne
cicato 193 20          : Ajout de l'offset 20àla colonne 193 = offset sur une colonne
fill2D 137 358 3 5.00  : remplissage polynomial X=179,Y=385 de 3 pixels, bruit de 5 sigmas = boucher zone par polynome 2D
fill 137 359 3         : remplissage du pixel X=137,Y=359 de 3 pixels = boucher zone (3)

Lorsque toutes les opérations cosmétiques sont terminées, il faut sauver cet enregistrement en cliquant sur l'icône disquette. Le fichier sera enregistré au format ASCII avec un suffixe ".cos".

Pour désactiver un enregistrement en cours, il suffit de sélectionner à nouveau l'opération [Traitement] > [Opérations cosmétiques] > [Enregistrer opérations]

Attention : si vous oubliez de sauver ce fichier avant de désactiver cet enregistrement, vos opérations seront perdues.

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Voir aussi :
[Prétraitement] > [Générer une liste des pixels chauds]

Image de test :
Toute image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Exécuter script cosmétique

> Traitement > Exécuter script cosmétique

Lancement : Menu [Traitement] > [Opérations cosmétiques] > [Exécuter un script cosmétique]

Cette fonction permet de lancer l'exécution d'un script cosmétique préalablement enregistré avec la fonction [Traitement] > [Opérations cosmétiques] > [Enregister un script cosmétique]

L'image à traiter doit être chargée et sélectionnée.

Au lancement de la fonction, une fenêtre s'ouvre permettant de sélectionner le script cosmétique à utiliser. Quand le script est sélectionné, il suffit de cliquer sur le bouton [OK] pour que le script soit lancé sur l'image.

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Voir aussi :
[Prétraitement] > [Générer une liste des pixels chauds]

Image de test :
Toute image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Taille de la zone cosmétique

> Traitement > Correction d'entrelacement

Lancement : Menu [Traitement] > [Correction d'entrelacement]

Cette fonction permet de corriger les effets obtenus avec des images entrelacées. Ces images sont notamment obtenues en les isolant depuis des vidéos oùles images sont entrelacées de façon à doubler le nombre d'images perçues par seconde sans augmenter le débit de la vidéo.

Le menu prpose différentes options :

  • Offset : permet d'appliquer un offset sur les lignes corrigées.
  • Facteur de correction : Le facteur de correction à apporter à ces lignes avant application de l'offset.
  • Les types de lignes à corriger : trame paire ou impaire.

Une telle correction apportée à l'image précédente va corriger l'entrelacement visible :

Un autre exemple est proposé ci-après :

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Image de test :
Image de la Lune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2011


Traitement / Filtre Utilisateur

> Traitement > Filtre utilisateur

Lancement : Menu [Traitement] > [Filtre] > [Utilisateur]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de lancer un filtre de convolution à partir d'une matrice de convolution préalablement enregistrée dans un fichier (au format .MAT).

Le fichier, au format ASCII, doit contenir les informations suivantes :

  • 1ere ligne : la demi-largeur de la matrice de convolution (1 pour une matrice 3x3, 2 pour une matrice 5x5, etc)
  • Lignes 2 à N-1 : coéficients entiers, de la matrice à raison d'une ligne du fichier par ligne de la matrice. Les coéficients doivent être séparés par un blanc.
  • Avant-dernière ligne : coefficient réel, par lequel doit être divisée l'image
  • Dernière ligne : valeur constante à ajouter à l'image

Exemple de format d'un fichier contenant une matrice de convolution :

1
1 -1 1
-1 9 -1
1 -1 1
1
0

Au lancement de cette fonction, une fenêtre s'ouvre permettant de sélectionner le fichier contenant la matrice de convolution à effectuer sur l'image sélectionnée. En cliquant sur le bouton [Ouvrir], le traitement est immédiatement lancé.

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Image de test :
Filtre laplacien

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Filtre passe-haut

> Traitement > Filtre passe-haut

Lancement : Menu [Traitement] > [Filtre] > [Passe-Haut]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de lancer un filtre Passe-Haut sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de définir la puissance du filtre (de 1 à 4) :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Il ya rehaussement des contrastes, amélioration de la netteté de simages. Ce filtre est redoutablement efficace avec des images présentant un bon rapport signal/bruit comme des images de la Lune ou des planètes. Il peut être avantageusement utilisé plusieurs fois de manière itérative sur l'image.

La puissance d'un filtre passe-haut dans PRiSM :

En électronique, appliquer un filtre linéaire passe-haut dans un circuit laisse passer les fréquences hautes sans les atténuer et "bloque" les basses fréquences. Un signal (qui d'après le théorème de Fourier peut toujours être décomposé en une somme de signaux sinusoïdaux de différentes fréquences hautes et basses) verra ses hautes fréquences "sortir indemme" du filtre et, au contraire, ses fréquences basses "ne pas le franchir".
En traitement d'image (qui n'est rien d'autre qu'un signal) , le principe en est le même. On sait que toute image possède sa transformée de Fourier où les basses fréquences sont au centre de l'image du domaine fréquentiel et les hautes fréquences vers l'extérieur. Passer un filtre passe-haut revient à supprimer ces basses fréquences " centrales ". Seulement, les détails d'une image sont des hautes fréquences du signal. En appliquant alors le filtre, on va faire apparaitre ces détails. TOUS ces détails, de celui qui nous intéresse à celui qui nous incommode, comme le bruit. C'est pour celà que le filtre passe-haut a, en général, une utilité réduite car il fait largement ressortir le bruit, d'autant plus que le prétraitement de l'image n'a pas été effectué soigneusement.

Evidemment, ce type de filtre possède quand même son utilité : les petits détails de l'image ressortent mais à quel prix sur des images bruitées ... Comme on pourra le voir, il ne faut pas non plus dramatiser. Le filtre passe-haut rend beaucoup de service notammment sur des images qui ont un bon rapport Signal/Bruit, c'est-à-dire des images planétaires ou lunaires. Sur de telles images, on pourra même faire passer le filtre plusieurs fois afin de faire ressortir les détails voulus. La encore, il ne faut pas exagérer car on risquerait à force de faire ressortir des détails ... qui n'existent pas !

Pour faire ressortir un petit détail, il faut réhausser un pixel par rapport à ses plus proches voisins. A cette fin, on utilise à cette fin une matrice de convolution avec certains coefficients négatifs. Ainsi, les intensités pondérées par des coefficients négatifs auront l'effet inverse de moyennage. Les fins détails ressortiront alors.

Il existe une quasi-infinité de filtre passe-haut. Cependant, on choisit en général des coefficients raisonnables et dépendant de la force du filtre. De plus, pour obtenir un filtre linéaire, on devra diviser le résultat par la somme des coefficients de la matrice (qui devra être non nulle).
Il ne faut pas oublier que le filtre passe-haut va donc provoquer des effets de bords; dans le cas d'une matrice 3 x 3 (ce qui est le plus courant), ce sera sur les premières et dernières lignes et colonnes.

La politique des programmeurs de PRiSM a été la suivante : plutôt que de laisser l'utilisateur rentrer tous les coefficients du filtre à chaque utilisation, on propose quatre filtres de forces différentes. Bien évidemment, on n'empêche aucunement l'utilisateur de choisir son propre filtre, mais il devra utiliser la fonction "[Traitements] > [Filtres] > [Filtre utilisateur]".
La force d'un filtre passe-haut dépend non seulement de l'importance de l'élément central du noyau de convolution par rapport aux autres mais aussi de la force des coeffcients négatifs. En effet si ces derniers sont importants, le pixel considéré va être beaucoup réhaussé par rapport à ses voisins. Le filtre passe-haut sera alors fort. Au contraire, si le coefficient central est peu différent de celui de ses voisins et si les coeffcients négatifs sont petits alors le pixel considéré va être peu changé et donc le filtre passe-haut sera dit fort. On voit donc que ce qui compte, c'est la différence entre le pixel central et les pixels négatifs; plus cette dernière sera grande, plus le filtre sera puissant.

PRiSM propose donc 4 différents filtres passe-haut dont l'action au fur et à mesure des numéros de vient de plus en plus forte :

numéro du filtre
1
2
3
4
coefficients du filtre

-1 | -3 | -1
-3 | 55 | -3
-1 | -3 | -1

-1 | -3 | -1
-3 | 40 | -3
-1 | -3 | -1

-1 | -3 | -1
-3 | 30 | -3
-1 | -3 | -1

-1 | -3 | -1
-3 | 20 | -3
-1 | -3 | -1

On voit donc que le filtre n°4 aura une très grande action sur l'image alors que le filtre n°1 n'en aura que très peu. On répète encore que le fait d'avoir imposer des filtres n'est pas du tout contraigantes pour l'utilisateur. Si ce dernier désire utiliser son propre filtre ,il faut passer par la commande [Traitements] > [Filtres] > [Filtre utilisateur]. Cependant, les filtres proposés par PRiSM sont suffisants dans la plupart des cas.

Examinons l'action des filtres n°1 et n°4 :

considérons les filtres " plans " [ -3 , 55 , -3 ] ( équivalent du n°1 ) et [ -3, 20 , -3 ] ( équivalent du n°4 ).

Description des filtres passe-haut

On voit que le bruit ( 1er pic ) ressort davantage par rapport au reste de l'image surtout avec l'équivalent du filtre n°4 ainsi que le détail désiré . Le filtre n°1, lui, fait moins ressortir le bruit mais fait également moins ressortir le détail. Il faut en général tester 2 ou 3 filtres avant d'arriver au bon à moins que le résultat de chacun soit vraiment évident sur l'image à traiter.

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
HighPass

Image de test :
Image de M27

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Filtre passe-bas

> Traitement > Filtre passe-bas

Lancement : Menu [Traitement] > [Filtre] > [Passe-Bas]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de lancer un filtre Passe-Bas sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de définir la puissance du filtre (de 1 à 4) :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Ce filtre permet d'atténuer du bruit ou d'éliminer de façon expéditive de parasites ...

La puissance d'un filtre passe-bas dans PRiSM :

En électronique, appliquer un filtre linéaire passe-bas dans un circuit laisse passer les basses fréquences sans les atténuer et " bloque " les hautes fréquences. Un signal (qui d'après le théorème de Fourier peut toujours être décomposé en une somme de signaux sinusoïdaux de différentes fréquences hautes et basses) verra ses fréquences basses "sortir indemme" du filtre et, au contraire, ses fréquence "ne pas le franchir".
En traitement d'image (qui n'est rien d'autre qu'un signal), le principe en est le même. On sait que toute image possède sa transformée de Fourier où les basses fréquences sont au centre de l'image du domaine fréquentiel et les hautes fréquences vers l'extérieur. Passer un filtre passe-bas revient à supprimer ces hautes fréquences. Seulement, les détails d'une image sont des hautes fréquences du signal. En appliquant alors le filtre, on va supprimer ces détails. TOUS ces détails, de celui qui nous intéresse à celui qui nous incommode, comme le bruit. Et c'est là où le filtre passe-bas à son utilité : supprimer le bruit indésirable de l'image.

Mais toute solution pour supprimer de façon attive le bruit ou les parasites d'une image ont leur revers de la médaille : non seulement, comme on l'a vu, on supprime le bruit mais en plus, on supprime des détails de l'image qui peuvent être important. (le filtre passe-bas a une autre utilité dans la technique du [Traitements] > [masque flou]).

Pour attenuer le bruit ( ou les petits détails ), il faut pondérer un pixel avec ses plus proches voisins. Comme on ne veut justement pas le faire ressortir, il faut moyenner l'intensité de ce pixel avec ses voisins. On utilise à cette fin une matrice de convolution à coefficients positifs.

Il existe une quasi-infinité de filtre passe-bas. Cependant, on choisit en général des coefficients raisonnables et dépendant de la force du filtre. De plus, pour obtenir un filtre linéaire, on devra diviser le résultat par la somme des coefficients de la matrice (qui devra être non nulle).
Il ne faut pas oublier que le filtre passe-bas va donc provoquer des effets de bords; dans le cas d'une matrice 3 x 3 (ce qui est le plus courant), ce sera sur les premières et dernières lignes et colonnes.

La politique des programmeurs du PRiSM a été la suivante : plutôt que de laisser l'utilisateur rentrer tous les coefficients du filtre à chaque utilisation, on propose quatre filtres de forces différentes. Bien évidemment, le programme n'empêche aucunement l'utilisateur de choisir son propre filtre, mais il devra utiliser la fonction "[Traitements] > [Filtres] > [Filtre utilisateur]".
La force d'un filtre dépend l'importance de l'élément central du noyau de convolution par rapport aux autres. En effet si celui-ci est important, le pixel considéré va être peu "perturbé" par ses voisins. Le filtre passe-bas sera alors peu fort. Au contraire, si le coefficient central est peu différents de celui de ses voisins, le pixel considéré va être fortement changé et donc le filtre passe-bas sera dit fort.

PRiSM propose donc 4 différents filtres passe-bas dont l'action au fur et à mesure des numéros de vient de plus en plus forte :

numéro du filtre 1 2 3 4
coefficients du
filtre
1 | 3 | 1
3 | 20 | 3
1 | 3 | 1

1 | 3 | 1
3 | 15 | 3
1 | 3 | 1

1 | 3 | 1
3 | 10 | 3
1 | 3 | 1

1 | 3 | 1
3 | 5 | 3
1 | 3 | 1

On voit donc que le fintre n°4 aura une très grande action sur l'image alors que le filtre n°1 n'en aura que très peu. On répète encore que cette " imposition " des filtres n'est pas du tout contraigantes pour l'utilisateur. Si ce dernier désire utiliser son propre filtre ,il faut passer par la commande Transformation / Filtres / Filtre utilisateur. Cependant, les filtres proposés par PRiSM sont suffisant dans la plupart des cas.

Examinons l'action des filtres n°1 et n°4 :

considérons les filtres " plans " [ 3 , 20 , 3 ] ( équivalent du n°1 ) et [ 3, 5 , 3 ] ( équivalent du n°4 ).

On voit que le bruit ( 1er pic ) est davantage atténué par l'équivalent du filtre n°4 mais l'image est davantage lissée. Le filtre n°1, lui, atténue moins le bruit mais lisse moins l'image. Il faut en général tester 2 ou 3 filtres avant d'arriver au bon à moins que le résultat de chacun soit vraiment évident sur l'image à traiter.

Images supportant cette fonction :
images monochromes ou trichromes en 16 ou 32 bits

Fonction(s) Script associée(s):
LowPass

Image de test :
Image de M27

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Filtre Adaptatif haut

> Traitement > Filtre Adaptatif haut

Lancement : Menu [Traitement] > [Filtres] > [Adaptatif haut]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un filtre adapatatif haut sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de le rapport Signal/Bruit maximal et le pas d'incrément du filtre :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Image de test :

Avril 2008


Traitement / Filtre Adaptatif bas

> Traitement > Filtre Adaptatif bas

Lancement : Menu [Traitement] > [Filtres] > [Adaptatif bas]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un filtre adapatatif bas sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de le rapport Signal/Bruit maximal et le pas d'incrément du filtre :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Image de test :

Dec 2010


Traitement / Filtre Gaussien

> Traitement > Filtre Gaussien

Lancement : Menu [Traitement] > [Filtres] > [Gaussien]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un filtre gaussien sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de définir le sigma utilisé pour le filtre (plus le sigma est grand, plus l'image finale sera "floue"):

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Image de test :

Avril 2008


Traitement / Gradient

> Traitement > Gradient

Lancement : Menu [Traitement] > [Filtres] > [Gradient]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : >Cette fonction permet de lancer un filtre de type "gradient directionnel" sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de définir la direction du filtre gradient à appliquer :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Image de test :

Avril 2008


Traitement / Filtre Médian

> Traitement > Filtre Médian

Lancement : Menu [Traitement] > [Filtres] > [Médian]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un filtre médian sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de choisir le type de masque à utiliser et la taille de la matrice de convolution à appliquer :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Image de test :

Déc 2010


Traitement / Filtre Erosion

> Traitement > Filtre Erosion

Lancement : Menu [Traitement] > [Filtre] > [Erosion]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Ce filtre réalise une érosion sur l'image.
Il s'agit d'un filtre statistique qui agit sur une zone de pixel à définir.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de choisir le type de masque à utiliser et la taille de la matrice de convolution à appliquer :

Le pixel central de la zone de pixel défini prend la valeur minimale par rapport au type de masque défini. Ceci a pour conséquence d'éroder les objets ...
Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Associé avec une dilation, on peut obtenir ce qu'on appelle en traitmeents d'images :

  • Erosion puis dilatation = ouverture
  • Dilatation puis érosion = fermeture.

On peut utiliser ces deux filtres de manière itérative. Ce filtre permet d'éliminer des étoiles, de relier des objets, de séparaer des classes d'objets ayant des tailles différentes ...

Images supportant cette fonction :
images monochromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Erosion

Voir aussi :
[Traitement] > [Filtre] > [Dilatation]

Image de test :
Toute image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Filtre de dilatation

> Traitement > Filtre de dilatation

Lancement : Menu [Traitement] > [Filtre] > [Dilatation]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Ce filtre réalise une dilatation sur l'image.
Il s'agit d'un filtre statistique qui agit sur une zone de pixel à définir.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de choisir le type de masque à utiliser et la taille de la matrice de convolution à appliquer :

Le pixel central de la zone de pixel défini prend la valeur maximale par rapport au type de masque défini. Ceci a pour conséquence de dilater les objets ...
Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Associé avec une érosion, on peut obtenir ce qu'on appelle en traitements d'images :

  • Erosion puis dilatation = ouverture
  • Dilatation puis érosion = fermeture.

On peut utiliser ces deux filtres de manière itérative.

Images supportant cette fonction :
images monochromes en 16 ou 32 bits

Fonction(s) Script associée(s):
Dilatation

Voir aussi :
[Traitement] > [Filtre] > [Erosion]

Image de test :
Toute image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Filtre Gradient rotationnel

> Traitement > Filtre Gradient rotationnel

Lancement : Menu [Traitement] > [Filtres] > [Gradient rotationnel]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un filtre gradient rotationnel sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de sélectionner l'angle de rotation, le décalage radial et les coordonnées du centre (X,Y) :

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Fonction(s) Script associée(s):
Aucune

Image de test :

Avril 2008


Traitement / Filtre Extraction de contours

> Traitement > Filtre Extraction de contours

Lancement : Menu [Traitement] > [Filtres] > [Extraction de contours]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de lancer un filtre capable d'extraire le contour des objets présents sur une image.

Au lancement de cette fonction, une fenêtre s'ouvre permettant de choisir la demi-largeur du noyau de convolution, d'indiquer si on veut ou non appliquer un filtre gaussien (pour limiter le bruit, donc la détection de faux contours), d'indique le sigma de l'éventuelle gaussienne et enfin, le facteur de seuillage qui permet également d'affiner la précision de la détection des contours :

La fonction est lancée dès qu'on clique sur le bouton [OK].

On obtient un résultat du type sur une image planétaire :

Fonction(s) Script associée(s):
Aucune

Image de test :

Déc 2010


Traitement / Filtre Gradient unidirectionnel

> Traitement > Filtre Gradient unidirectionnel

Lancement : Menu [Traitement] > [Filtres] > [Gradient unidirectionnel]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un filtre gradient unidirectionnel sur une image.

Fonction(s) Script associée(s):
Aucune

Image de test :

Avril 2008


Traitement / Logarithme

> Traitement > Logarithme

Lancement : Menu [Traitement] > [Logarithme]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet d'effectuer un logarithme sur une image : l'intensité de chaque pixel est remplacé par le logarithme de (la valeur de ce pixel - la valeur du fond du ciel).

Au lancement de cette fonction, un curseur apparaît sur l'image. Il permet de sélectionner un pixel dont l'intensité sera prise comme référence pour la mesure du fond du ciel :

Il faut cliquer à l'endroit que l'on veut faire ressortir par rapport aux autres endroits. Dans ce cas, un curseur apparaît que l'on peut pondérer avant de valider le choix :

L'offset est réglable de façon à accentuer ou diminuer le phénomène logarithmique. Après calcul, il faut régler à nouveau les seuils de l'image :

Il faut que l'image soit la moins bruitée possible sinon ce dernier ressortira avec l'effet logarithme !

Fonction(s) Script associée(s):
Aucune

Image de test :
Image

Janvier 2011


Traitement / Bruit Uniforme

> Traitement > Bruit uniforme

Lancement : Menu [Traitement] > [Bruit] > [Uniforme]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet d'ajouter du bruit uniforme sur une image.

Au lancement, une fenêtre s'ouvre permettant de choisir la variance de bruit à appliquer :

Régler la variance du bruit

Attention, cette valeur ne correspond pas à un véritable écart-type comme dans le cas d'un bruit gaussien. Elle correspond plutôt à un coefficient multiplicatif appliqué à une valeur aléatoire.

Cette fonction est lancée dès qu'on clique sur le bouton [OK]

Une image avec du bruit uniforme

L'histogramme après application du bruit sur une image uniforme

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Noise

Voir aussi :
Histogramme global

Image de test :
Images uniforme + résultat d'un bruit uniforme

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Bruit Gaussien

> Traitement > Bruit gaussien

Lancement : Menu [Traitement] > [Bruit] > [Gaussien]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet d'ajouter du bruit gaussien sur une image.

Au lancement, une fenêtre s'ouvre permettant de choisir la variance de bruit à appliquer :

Régler la variance de la gaussienne

Cette fonction est lancée dès qu'on clique sur le bouton [OK]

Une image avec du bruit gaussien

L'histogramme après application du bruit sur une image uniforme

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
NoiseGauss

Voir aussi :
Histogramme global

Image de test :
Images uniforme + résultat d'un bruit gaussien

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Seuillage à N sigmas

> Traitement > Seuillage à N sigmas

Lancement : Menu [Traitement] > [Seuillage à N sigmas]

But : Seuiller l'image en valeur inférieure en fonction du fond de ciel.

La valeur "Seuil" de seuil calculée est telle que : Seuil = Fond de ciel + Nbre Sigma * Sigma de l'image.

Les valeurs à fournir sont "Nbre Sigma" ainsi que les détourages en X et Y : ces deux dernières valeurs correspondent à la définition des marges à appliquer sur l'image pour le calcul. Ceci permet d'éviter de tenir compte des lignes/colonnes du bord de l'image qui parfois ne correspondent pas à l'image.

Fonction(s) Script associée(s):
Aucune

Image de test :
Image 16 bits

Type d'image :
Image 16 bits CPA ou FITS.

Janvier 2011


Traitement / Masque flou

> Traitement > Maque Flou

Lancement : Menu [Traitement] > [Masque Flou]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser un "filtre" masque flou sur une image.

Cette opération consiste à créer une image de détails résultant de l'image d'origine à laquelle on a soustrait un filtre gaussien de cette même image d'origine. Un filtre gaussien donnant un effet floutée à l'image, on en garde dans cette image de détails que les détails de l'image d'origine. Il suffit ensuite d'additionner cette image de détail (à un coefficient multiplicatif près) à avec l'image prétraitée d'origine (à un coefficient multiplicatif près).

On a alors : [Image traitée] = A * [image prétraitée] + B * ([image prétraitée] - [image prétraitée floue]), A et B étant des coefficients multiplicatifs.

On voit apparaître 2 cadrans montrant un extrait de l'image avant et après traitements en fonction des paramètres choisis. La visualisation automatique peut être choisie ou si la visualisation est manuelle, les seuils sont réglés à l'aide des curseurs à droite de la fenêtre.

Le facteur de netteté est relatif à la gaussienne appliquée pour flouter l'image d'origine (d'où le terme "sigma"). Plus ce facteur sera important, et plus l'image d'origine sera floutée afin de faire ressortir les détails les plus fins mais attention cependant à ne pas trop accentuer le bruit de l'image.

Le facteur d'amplification de netteté correspond au rapport des coefficients ci-dessus = B / A. Ceci permet d'additionner de façon plus ou moins forte l'image de détail à l'image d'origine.

Pour le traitement des images stellaires, la technique du masque flou a tendance a former des anneaux sombres sur les objets ponctuels (comme des étoiles) sur fond nébuleux ce qui donne une impression désagréable. Le réglage du seuil d'application par rapport au fond de ciel permet de limiter fortement l'apparition de ces anneaux autour des étoiles.

Fonction(s) Script associée(s):
Aucune

Image de test :
Image de Jupiter

Janvier 2011


Traitement / Van Citter

 S
> Traitement > Van Citter

Lancement : Menu [Traitement] > [Van Citter]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de lancer un filtre de type "Van Citter" sur une image afin de déconvoluer une image par une PSF. En effet, ce filtre est une procédure itérative qui permet de reformer une image qui aurait été "floutée" (on dit mathématiquement convoluée) par une PSF connue ("Point Spread Function" = réponse d'un système à un point objet source ponctuel).

Au lancement de cette fonction, une fenêtre s'ouvre permettant d'indiquer si l'on souhaite utiliser une PSF provenant de l'image :

Utilisation du filtre avec une PSF provenant de l'image
Si on choisit cette option, alors un curseur s'affiche et il faut entourer une zone de façon à créer la PSF à partir d'un centroïde d'objet.

Lorsque cette sélection est faite, il faut choisir le nombre d'itération pour le calcul :

Le nombre d'itération choisi

Le traitement démarre alors après ces réglages.

Utilisation du filtre sans PSF provenant de l'image
Si on choisit cette option, le programme demande alors de préciser les caractéristiques choisies pour la PSF :

Les caractéristiques de la PSF à remplir

Lorsque cette sélection est faite, il faut choisir le nombre d'itération pour le calcul :

Le nombre d'itération choisi

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Cet algorithme est très bien adapté pour les images planétaires et déconseillé pour les images stellaires. Cet algorithme est équivalent à un masque flou lorsque le nombre d'itérations est égal à un. C'est une sorte de masque flou itératif ... Attention à ne pas faire trop d'itération car c'est un algorithme relativement fort.

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Richardson Lucy

> Traitement > Van Citter

Lancement : Menu [Traitement] > [Richardson-Lucy]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de lancer un filtre de type "Richardson-Lucy" sur une image afin de déconvoluer une image par une PSF. En effet, ce filtre est une procédure itérative qui permet de reformer une image qui aurait été "floutée" (on dit mathématiquement convoluée) par une PSF connue ("Point Spread Function" = réponse d'un système à un point objet source ponctuel).

Au lancement de cette fonction, une fenêtre s'ouvre permettant d'indiquer le nombre de sigmas de réjection :

Après avoir saisie la valeur souhaitée, cliquer sur le bouton [OK]. Une fenêtre s'ouvre permettant d'indiquer si l'on souhaite utiliser une PSF provenant de l'image :

Utilisation du filtre avec une PSF provenant de l'image
Si on choisit cette option, alors un curseur s'affiche et il faut créer la PSF à partir d'une étoile à partir d'un centroïde (pour le réglage de la taille de la fenêtre, voir le menu : [Analyse] > [Centroïde] > [Taille de la fenêtre (Gauss2D/Moffat)]).

Lorsque cette sélection est faite, il faut choisir le nombre d'itération pour le calcul :

Le nombre d'itération choisi

Le traitement démarre alors après ces réglages.

Utilisation du filtre sans PSF provenant de l'image
Si on choisit cette option, le programme demande alors de préciser les caractéristiques choisies pour la PSF :

Les caractéristiques de la PSF à remplir

Lorsque cette sélection est faite, il faut choisir le nombre d'itération pour le calcul :

Le nombre d'itération choisi

Le traitement de l'image démarre dès qu'on clique sur le bouton [OK].

Cet algorithme a été utilisé pour restaurer les images du télescope spatial Hubble dans le but de rehausser les détails dans une image. Cet algorithme est beaucoup mieux adapté pour les images stellaires car il est moins "violent" que le masque flou ou encore l'algorithme Van-Citter. L'image de départ soit avoir un bon rapport signal sur bruit.

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Ondelettes

> Traitement > Ondelettes

Lancement : Menu [Traitement] > [Ondelettes]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la transformée en ondelette d'une image. Le résultat est une succession de "plans" avec, dans chacun d'eux, un niveau de détail différents.

Voici un exemple avec différents plans :

On voit clairement que le premier plan d'ondelettes, en haut et à gauche, contient les détails de l'image de dimension inférieure à 1 pixel environs. Ceci s'apparente plus à du bruit. Le deuxième plan d'ondelettes, en haut et au milieu, contient les détails de l'image de dimension 3 pixels environs. Le troisième plan d'ondelettes, en haut et à droite, contient les détails de l'image de dimension 6 pixels environs. Et ainsi de suite pour les autres plans.

Finalement, la méthode est très similaire au masque flou, où l'on extrait les détails de l'image que l'on veut amplifier. Par contre, avec les ondelettes, l'utilisateur peut maintenant avoir acces à une série de détails à différentes échelles. En agissant plus finement sur ces détails, on peut amplifier différemment les différentes échelles. Il est même possible de supprimer certains plans et en particulier le premier qui contient 90 % de bruit et 10 % de signal utile. Evidemment, en supprimant ce plan, l'image finale aura un aspect plus flou puisque nous supprimons ces 10% de détails très fins. Mais ce désavantage est largement compensé par la possibilité de pouvoir amplifier à loisir les autres plans sans être trop limité par la montée du bruit.

Pour réaliser ce traitement sur PRiSM, on sélectionne le menu Traitements | Ondelettes, la fenêtre suivante apparaît :

En haut de la fenêtre, le type d'ondelette nous est demandé. Pour avoir un minimum de détails dans le premier plan, il faut choisir la forme Spline de degré 1. La forme Spline de degré 3 sépare moins finement les différentes échelles.

Les différents plans sont alors calculés et gardés en mémoire en vu de la reconstruction de l'image. A la fin des calculs la fenêtre suivante apparaît :

En haut de la fenêtre, lebouton du milieu permet de sélectionner un des plans puis le bouton de gauche permet de visualiser ce plan. Il est donc possible d'extraire un des plans en le visualisant puis en sortant de la fenêtre en appuyant sur OK.

Viennent ensuite au milieu de la fenêtre une série de champs permettant d'indiquer le facteur multiplicateur de chaque plan par réglage grâce à un curseur : par exemple, le premier plan est supprimé en introduisant la valeur 0. Le deuxième plan est multiplié par 8 car c'est celui qui contient les détails les plus fin. Les autres plans sont multipliés par des valeurs de plus en plus petites pour limiter les artefacts.

Et voilà le résultat en comparaison avec le masque flou à droite :

L'image traitée avec le masque flou est un peu plus nette mais plus bruitée. Le traitement par ondelette semble légèrement supérieur à celui par masque flou.

Pour exemple, observons une décomposition en ondelettes de M51.

Les 3 premiers plans d'ondelettes sur M51

On remarque sur ces images que tous les détails de l'image apparaissent dans l'ondelette plan n°1 ( à gauche ). Certains sont très atténués dans l'ondelette de plan n°2. A partir du plan n°3, l'image devient de plus en plus lissée, comme si on regardait l'objet de plus en plus loin et que l'on distinguait alors de moins en moins de détails ...

Plus le numéro du plan de l'ondelette augmente, plus on représente un intervalle de fréquence situé vers les basses fréquences. Chaque plan peut être grossièrement comparé au résultat d'un filtre passe-bande sur l'image. C'est comme celà que l'on peut comparer la transformation en ondelettes avec celle de Fourier.

Fonction(s) Script associée(s):
Aucune

Image de test :
Image

Janvier 2011


Traitement / Fourrier

> Traitement > Fourrier

Lancement : Menu [Traitement] > [Fourrier]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la transformée de Fourrier d'une image.

Cette fonction réalise la transformée de Fourier (ou Fast Fourier Transform) d’une image monochrome spatiale vers l’espace de Fourier des fréquences/phases où chaque pixel est stocké sous forme de partie réelle et imaginaire en nombres à virgules sur 32 bits.
La FFT requière une image carrée de coté égal à une des puissances de 2 (32x32 pixels, 64x64 pixels, 128x128 pixels, 256x256 pixels, ...). Le logiciel propose de fenêtrer l’image si nécessaire vers la taille la plus proche d’une image carrée multiple de deux.
Chaque pixel résultat occupe 64 bits (2x32) d’espace mémoire car le résultat d’une FFT est une image composée de pixels complexes. Plus exactement, tout pixel possède une partie réelle et une partie imaginaire de la forme [image], avec i (symbole imaginaire) est défini tel que [image] (x et y sont les coordonnées discrètes des pixels de l’image).

Les détails d'une image correspondant à un signal haute fréquence, ces derniers sont donc codées et ressortent grâce à la transformation FFT. Le terme de phase est là pour reconstruire le signal spatial.

L’image spatiale bidimensionnelle de Jupiter se transforme en une image de Fourier.
L’image suivante montre l’image module, amplitude des fréquences, c'est-à-dire [image] de chaque pixel résultant :

Les fréquences sont nulles au centre de l’image, et les fréquences élevées sur les 4 bords de l’image (les détails de l'image seront donc davantage sur les bords).

Le type de visualisation de l’image (qui est de type Complexe) peut être changé à partir du menu suivant :

Par défaut, la visualisation est de type module/amplitude (qui correspond à l’intensité [image] de chaque pixel), mais d’autre type de visualisation comme l’angle de la phase (en radians où chaque pixels est de la forme [image]), la partie réelle (a) de chaque pixel ou imaginaire (b) sont aussi possibles.

La précédente image est une visualisation de type « angle » ou phase [image]), en radians, de la FFT de Jupiter. Il est difficile intuitivement de se figurer une image de ce type, elle représente le décalage de phase à l’origine de chaque fréquence de l’image initiale.

Avec un tel type particulier d’images dans le corps des complexes [image] contenant la phase et l’intensité des fréquences, un nombre d’opérations mathématiques est possible, comme additionner deux images complexes, ajouter une constante réelle ou imaginaire (= ajouter une constante réelle à l'image imaginaire) .... On se référera à l’aide usuelle de ces fonctions d’opération image-image.

Les opérations cosmétiques sont possibles pour supprimer des parasites dans une image, par exemple, une image fortement parasitée.

A suivre une image de Saturne affectée par des parasites électroniques dus à la lecture du CCD. Deux types de parasites y sont visibles, un parasite a haute fréquence, et un parasite de fréquence basse :

Parasite haute fréquence | Parasite basse fréquence

Corriger cette image manuellement est impossible.

Si une FFT est effectuée sur cette image, l’image des amplitudes des fréquences montre un groupe de points, ils dénotent en fait deux fréquences proches de forte amplitude, et qui battent entre elles en une basse fréquence.

Si les points sont éliminés avec la fonction de remplissage pixel (CTRL+S) :

et une FFT inverse est réalisée, l’image résultante est totalement débarrassée des parasites de basse et haute fréquences ! Et ce, assez radicalement !

Même si le fond de ciel est examiné, celui-ci est débarrassé des parasites :

Un menu spécifique aux images de type Complexes (pixel codé en partie réelle/partie imaginaire) s’affiche et propose les opérations suivantes :

Pour avoir accès à ces fonctions, aller dans le menu de l'aide sous la fonction documentée ici.

Annexes
Une application de la FFT sur des étoiles doubles est décrite ici :
http://www.astrosurf.com/rondi/t60/crabe-tambour/speckle.htm
http://astrosurf.com/rondi/binary_cross-correl.htm
http://homepages.inf.ed.ac.uk/rbf/HIPR2/fourier.htm
http://www.cs.unm.edu/~brayer/vision/fourier.html
http://www.dspguide.com/ch24/5.htm

Fonction(s) Script associée(s):
Liste des fonctions de l'espace des complexes.

Image de test :
Toute image.

Février 2011


Traitement / Convlution

> Traitement > Fourier > FFT Inverse

Lancement : Menu [Traitement] > [Fourier] > [Calcul FFT Inverse]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

La fonction FFT inverse converti une image complexe dans [image] des fréquences (phase/module, ou partie réelle /imaginaire) en une image dans l’espace.

devient ceci par FFT inverse :

Fonction(s) Script associée(s):
FFTInverse

Février 2011


Traitement / Convlution

> Traitement > Convolution par une gaussienne (FFT)

Lancement : Menu [Traitement] > [Fourier] > [Convolution par une gaussienne]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

La fonction Convolution par Gaussienne réalise un simple produit dans [image] par une gaussienne de largeur a mi hauteur spécifiée par l’utilisateur du logiciel.

Image de Jupiter

Fonction(s) Script associée(s):
Aucune

Février 2011


Traitement / Supprimer "Smearing"

> Traitement > Supprimer "Smearing"

Lancement : Menu [Traitement] > [Supprimer "Smearing"]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But :Cette fonction permet de supprimer les traînées verticales qui apparaissent sur les images réalisées sans obturateur (on appelle ces traces "smearing").

Une image étant préalablement chargée et sélectionnée, au lancement de cette fonction provoque l'affichage de la fenêtre suivante :

Le facteur de smearing peut être calculé automatiquement par le logiciel, sous réserve que le temps de pose et le temps de lecture soient connus (et renseignés dans l'entête de l'image). Dans ce cas, on pourra cocher la case "Calcul automatique" et le logiciel se chargera du calcul du facteur de smearing).

Dans le cas contraire, on saisira le facteur de smearing dont la valeur est :

(Temps de lecture du CCD en s) / (Temps de pose en s) * (Hauteur de l'image en pixels)

Le traitement de l'image est lancé en cliquant sur le bouton [OK].

Cette fonction fonctionne aussi avec des images autres qu'astronomiques :

Fonction(s) Script associée(s):
Aucune

Image de test :

Dec 2010


Traitement / Supprimer blooming sur les étoiles

> Traitement > Supprimer blooming sur les étoiles

Lancement : Menu [Traitement] > [Supprimer blooming sur les étoiles]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Supprimer le blooming des étoiles.

Pour une description de la fonction, voir la page du tutoriel correspondant.

Fonction(s) Script associée(s):
Aucune

Image de test :

Sept 2009


Traitement / Mesure du tilt

> Traitement > Mesure du tilt

Lancement : Menu [Traitement] > [Spectroscopie] > [Mesure du tilt]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Mesurer l'angle d'inclinaison du spectre par rapport à l'horizontale.

Résultat : Angle dont est orienté le spectre par rapport à l'horizontal. Cet angle est orienté positivement dans le sens trigonométrique.

Après le lancement de la fonction, il faut sélectionner un rectangle entourant une partie du spectre. Ce n'est pas la peine de trop faire déborder le rectangle suivant Y par rapport au spectre. Cependant, comme il faut englober tout le spectre, il faut prendre un rectangle suffisamment large pour tenir compte des paramètres de visualisation, le spectre étant réellement plus large qu'il n'apparaît à l'écran :

Un exemple de choix de sélection

Le résultat est alors fourni dans une fenêtre en degré. Cette valeur correspond à l'orientation du spectre par rapport à l'horizontale. C'est l'opposé de ce résultat qu'il faudra fournir lors de la correction du tilt ...

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune ... pour le moment !

Prérequis :
PRiSM et la spectroscopie

Voir aussi :
Correction du tilt

Image de test :
Spectre légèrement penché.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Aout 2006


Traitement / Correction du tilt

> Traitement > Correction du tilt

Lancement : Menu [Traitement] > [Spectroscopie] > [Correction du tilt]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Corriger l'inclinaison du spectre par rapport à l'horizontale.

Résultat : Spectre horizontal.

Il est demandé deux indications avant de rendre le spectre horizontal :

  • Angle de tilt : angle dont il faut tourner le spectre dans le sens trigonométrique pour le rendre horizontal. C'est l'opposé de l'indication fournie par la fonction de mesure du tilt.
  • Colonne neutre : Position suivant X du pivot de la rotation effectuée pour rendre le spectre horizontal. De bons résultats sont obtenus avec pour colonne neutre, la colonne milieu de l'image.

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Voir aussi :
Mesure du tilt

Image de test :
Spectre légèrement penché.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Aout 2006


Traitement / Mesure du slant

> Traitement > Mesure du slant

Lancement : Menu [Traitement] > [Spectroscopie] > [Mesure du slant]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Mesurer l'angle d'inclinaison des raies du néon par rapport à la verticale.

Résultat : Angle dont sont orientées les raies par rapport à la verticale. Cet angle est orienté positivement dans le sens trigonométrique.

Après le lancement de la fonction, il faut sélectionner un rectangle entourant une raie du spectre. Il faut englober toute une raie pour la mesure :

Exemple de sélection

Le résultat est alors fourni dans une fenêtre en degré. Cette valeur correspond à l'orientation du spectre par rapport à la verticale. C'est l'opposé de ce résultat qu'il faudra fournir lors de la correction du slant ...

La dernière valeur affichée sera enregistrée dans la base de registre windows de façon à pouvoir être réutilisée lors de la correction du slant.

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune ... pour le moment !

Prérequis :
PRiSM et la spectroscopie

Voir aussi :
Correction du slant

Image de test :
Spectre d'une image de référence.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Aout 2006


Traitement / Correction du slant

> Traitement > Correction du slant

Lancement : Menu [Traitement] > [Spectroscopie] > [Correction du slant]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Corriger l'inclinaison des raies par rapport à la verticale.

Résultat : Raies verticales.

Il est demandé deux indications avant de rendre les raies verticales :

  • Angle de slant : angle dont il faut tourner les raies dans le sens trigonométrique pour les rendre verticales. C'est l'opposé de l'indication fournie par la fonction de mesure du slant.
  • Ligne neutre : Position de la ligne qui restera inchangée. Les autres lignes seront translatées une à une d'une valeur différente de façon à rendre les raies verticales. De bons résultats sont obtenus avec la ligne du milieu de l'image.

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Voir aussi :
Mesure du slant

Image de test :
Spectre d'une image de référence.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Aout 2006


Traitement / Correction du smile

> Traitement > Correction du smile

Lancement : Menu [Traitement] > [Spectroscopie] > [Correction du smile]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Corriger une image d'un effet de "sourire" pour les raies spectrales.

Cet effet de sourire n'est pas inquiétant et dépend de l'instrumentation utilisée. C'est un effet d'ordre 2. Une image exemple est fournie à cet effet.

Remarque : il vaut mieux éviter cet effet sur les images de calibration quitte à les fenêtrer suffisamment de telle façon à ce que l'effet devienne négligeable (et il le devient !). Seul un slant (correction d'ordre 1) permettra alors de redresser les raies.

Cet effet doit être corrigé, de plus, à "vue d'oeil" ... Une fenêtre de correction apparaît alors :

  • Rayon de courbure : Il faut estimer le rayon du cercle dont un arc correspondrait à une raie. Dans l'exemple fourni, il faut compter que les raies formeraient un cercle de 1100 pixels de rayon. Le rayon de courbure étant initialement positif, il faut faire la correction avec un signe négatif.
  • Ligne neutre : ligne choisie pour rester sans transformation. Une ligne correcte correspond à la ligne milieu de l'image mais on peut choisir n'importe quelle ligne au niveau du spectre à traiter.

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Image de test :
Apparition du smile.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Aout 2006


Traitement / Binning optimal

> Traitement > Binning optimal

Lancement : Menu [Traitement] > [Spectroscopie] > [Binning optimal]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Créer un spectre 2D de niveau 0c.

Il est demandé de tracer au mieux une fenêtre rectangulaire contenant le spectre (attention, à cause des paramètres de visualisation, ce dernier déborde même sur les parties noires proches du spectre !) :

Exemple de fenêtre de sélection

La taille en hauteur du rectangle de sélection est alors rappelé :

et le résultat du binning apparaît alors ... ceci peut être utilisé pour obtenir un spectre de niveau 0c.

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Image de test :
Spectre Image à diviser par lui-même.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Aout 2006


Traitement / Linéariser un spectre

> Analyse > Linéariser un spectre

Lancement : Menu [Analyse] > [Spectroscopie] > [Linéariser un spectre]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de linéariser un spectre non linéaire. L'image à linéariser doit être calibrée ! On peut vérifier avant calibration la non linéarité de l'image :

Et après linéarisation :

Suivant la non-linéarité intiale, la linéarisation est nettement visible :

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie.

Image de test :
Spectre non linéaire.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Diviser un spectre par un autre

> Traitement > Diviser un spectre par un autre

Lancement : Menu [Traitement] > [Spectroscopie] > [Diviser un spectre par un autre]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de diviser un spectre par un autre. Elle a toute son utilité par exemple lors de la recherche de la réponse instrumentale.
Les deux spectres doivent avoir une partie commune mais il n'y a pas d'exigence quant à cette partie commune. Le spectre résultant ne portera alors que sur cette partie ! Les images doivent bien sûr être toutes deux calibrées en longueur d'onde.

A l'ouverture de la fonction, les marges extrêmes de longueur d'onde et l'échantillonnage sont indiqués :

La fenêtre à son ouverture

Il faut ouvrir le fichier de réponse instrumentale. Pour ce dernier, il est aussi indiqué les marges extrêmes de longueur d'onde et l'échantillonnage :

les marges extrêmes de longueur d'onde et l'échantillonnage

Il est possible de calculer la zone de longueurs d'onde en commun entre les deux spectres. Cette opération n'est pas nécessaire car elle se fait automatiquement lors de la division des spectres. Cependant, ces valeurs indiquent à l'utilisateur la zone retenue :

Calculer les longueurs d'onde extrêmes

Il est possible de normaliser la réponse de façon automatique ou par fenêtrage. Cependant, pour une réponse instrumentale, cette opération n'a que peu d'intérêt ... :

Une éventuelle normalisation

Des fichiers résultants sont créés dans le répertoire de celui à diviser. Les formats retenus sont CPA, FITS et JPEG. Un fichier texte de valeurs en TXT est également créé. Les noms commencent comme celui du spectre à diviser suivant de "Div".

Fonction(s) Script associée(s):
Aucune pour le moment

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Spectre Image à diviser par lui-même.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Traitement / Spectro - Filtre passe-bas

> Traitement > Spectro - Filtre passe-bas

Lancement : Menu [Traitement] > [Spectroscopie] > [Filtre Passe-Bas]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction est utilisée dans le but de lisser un spectre bruité en y faisant passer un filtre passe-bas. La puissance du filtre est demandée avant traitement :

Le réglage de la puissance du filtre

L'algorithme consiste à faire, sur une ligne et pour chaque pixel, une moyenne de largeur égale à la valeur de la puissance du filtre.

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Image de test :
Spectre bruité ....

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Normalisation automatique d'un spectre

> Traitement > Scaling Automatique d'un spectre

Lancement : Menu [Traitement] > [Traitements Spectro] > [Normalisation du spectre] > [Normalisation automatique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Normaliser une image automatiquement.

Dans la normalisation, il faut comprendre ici le terme anglais scaling comme remise à l'échelle de telle façon que le début du continuum du spectre soit égal à 1. En aucun cas le continuum (résultant du corps noir) est enlevé au spectre.
La zone de normalisation a pour largeur 5% de l'image. L'algorithme teste la zone au début de l'image et si celle-ci n'est pas assez constante, il change de zone jusqu'à en trouver une zone suffisamment constante qui définira la zone de normalisation.
En cas d'échec (l'utilisateur sera prévenu), il faudra se diriger vers la normalisation par fenêtrage (voir le lien ci dessous).

Après normalisation, le spectre est remis à l'échelle et la fenêtre de sortie indique un minimum d'information :

Fenêtre de sortie

L'image résultante n'est pas sauvegardée automatiquement. C'est à l'utilisateur de le faire.
L'opération peut être annulé à l'aide du menu [Edition] > [Annuler].

L'entête de l'image indique alors que le spectre a été normalisé et donne l'intevalle de longueur d'onde où cette normalisation a eu lieu :

L'intervalle de normalisation

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie.
L'entête des images.

Voir aussi :
Normalisation par fenêtrage

Image de test :
Spectre.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Normalisation d'un spectre par fenêtrage

> Traitement > Scaling d'un spectre par fenêtrage

Lancement : Menu [Traitement] > [Traitements Spectro] > [Normalisation du spectre] > [Normalisation par fenêtrage]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Normaliser une image par fenêtrage.

Dans la normalisation, il faut comprendre ici le terme anglais scaling comme remise à l'échelle de telle façon que le début du continuum du spectre soit égal à 1. En aucun cas le continuum (résultant du corps noir) est enlevé au spectre.
La zone de normalisation est défini par l'utilisateur. Il doit la sélectionner sur l'image à l'aide de la souris.
La normalisation ne peut échouer.

Après normalisation, le spectre est normalisé et la fenêtre de sortie indique un minimum d'information :

Fenêtre de sortie

L'image résultante n'est pas sauvegardée automatiquement. C'est à l'utilisateur de le faire.
L'opération peut être annulé à l'aide du menu [Edition] > [Annuler].

L'entête de l'image indique alors que le spectre a été normalisé et donne l'intevalle de longueur d'onde où cette normalisation a eu lieu :

L'intervalle de normalisation

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie.
L'entête des images.

Voir aussi :
Normalisation automatique

Image de test :
Spectre.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Largeur à mi-hauteur d'une raie

> Traitement > Mesure d'une largeur de raie

Lancement : Menu [Traitement] > [Spectroscopie] > [Mesure rapide d'une largeur de raie]

Touche de raccourci : CTRL + P

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Modélisation simplement et rapidement une raie pour en connaître sa largeur.

Cette fonction est destinée à servir d'introduction au module de focalisation spectral.
Beaucoup de raies ne peuvent être modélisées de façon purement gaussienne, notamment en raison des divers mouvements de matières autour de l'étoile. Cependant, lors du réglage du collimateur à partir des raies d'étalonnages de la lampe spectrale, les raies qui apparaissent ont un profil gaussien. De façon à rendre ces raies les plus "fines" possible, cet outil est utilisé.

Une image faisant apparaître les raies doit être ouverte. Lors du lancement de la fonction, l'utilisateur doit positionner le curseur vertical sur une raie et le profil sera effectué sur la ligne horizontale du curseur :

Le positionnement du curseur

Une fois le profil gaussien calculé, le résultat est présenté de deux manières :

  • Visualisation graphique :

    La raie fittée

    La courbe noire est la représentation à une dimension de l'intensité des pixels sur une ligne alors que la courbe rouge représente la courbe modélisée. Ceci permet à l'utilisateur de valider à l'oeil ou non la modélisation effectuée.

  • Résultats calculés :

    Les résultats calculés

L'utilisateur peut alors, lors d'un réglage, rendre la raie la plus fine possible en comparant ses valeurs !

Images supportant cette fonction :
images monochromes avec des raies spectrales à profil gaussien.

Fonction(s) Script associée(s):
Gauss1D

Voir aussi :
Réglage des graphes sous PRiSM
Outil de focalisation sur raie

Image de test :
Image d'une lampe de calibration spectrale

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Octobre 2007


Traitement / Spectro - Modélisation d'une raie

> Traitement > Spectro - Modélisation d'une raie

Lancement : Menu [Traitement] > [Spectroscopie] > [Modélisation et paramètres de raie]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction a pour but de modéliser une raie incluse dans un spectre. Elle permet de régler les paramètres de façon plus développée que la fonction [Traitement] > [Spectroscopie] > [Mesure rapide d'une largeur de raie]. Il peut être nécessaire de repérer la zone d'encadrement de la raie à partir d'un zoom sur l'endroit désiré à l'aide de la fonction [Analyse] > [Coupe d'image] > [Spectrale]. Dans l'image de test fournie, on commence par repérer la raie désirée et on réalise un zoom autour de cette zone :

Une zoom autour de la raie

Ici, on repère une raie d'absorption avec un fond de ciel pentu entre X=190 et X=198. Ces paramètres seront alors fourni à l'ouverture de la fonction :

Il est nécessaire de définir :

  • Type de raie : raie d'absorption ou raie d'emission.
  • Type de sélection : La sélection automatique montre une barre verticale sur le spectre et il faut sléectionner le centre approximatif de la raie pour en avoir des informations. Dans l'exemple choisi, on pointerait au niveau de X=194 ou 195. La sélection par fenêtrage oblige l'utilisateur à définir la zone de modélisation. Dans l'exmple ci-dessus, on peut par exemple choisir une modélisation entre X=190 et X=198. Cette dernière sélection permet de forcer la sélection lors de l'échec de la modélisation automatique ou de préciser exactement la zone que l'on désire modéliser.
  • La case à cocher si on estime que le fond est "penché" ce qui a lieu par exemple lorsqu'on cherche à modéliser ue raie incluse dans une autre raie plus large. Dans l'exemple choisi, on choisira ce cas.

On obtient alors un graphe du type suivant :

Un exemple de graphe

où la ligne verte représente le fond de la raie, la courbe rouge la modélisation gaussienne et la courbe noire la liaison point par point de la raie.

Des informations sur la raie sont fournies dans la fenêtre de sortie :

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie
Paramétrage des graphes sous PRiSM.

Image de test :
Série de raie. On peut par exemple prendre la raie d'absorption entre X=190 et X=198 ou la raie d'émission en automatique autour de X=182.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Spectro - Raies fines d'un spectre

> Traitement > Spectro - Raies fines d'un spectre

Lancement : Menu [Traitement] > [Spectroscopie] > [Repérer raies fines d'un spectre]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Faire apparaître les raies fines d'un spectre.
Dans ces raies, on fera donc apparaître certaines raies telluriques ainsi que d'autres raies que l'utilisateur peut éventuellement identifier. Le spectre peut être calibré ou non. Cette fonction supprime le profil global du spectre et ceci permet alors de dégager les "petits" profils. Dans tous les cas, les données fournies pour l'encadrement des raies ne provient pas d'une modélisation gaussienne.

Cas des spectres calibrés : Si le spectre est calibré, le résultat est immédiat et un graphe apparaît afin de distinguer ces raies ainsi qu'une fenêtre se sortie renseignant sur l'encadrement des raies à 2 sigmas :

Le graphe des raies fines La fenêtre de sortie

Cas des spectres non calibrés : Si le spectre est non calibré, il est demandé un échantillonnage approximatif au premier ordre. Meilleur sera cet échantillonnage et mieux les raies seront repérées :

L'échantillonnage à compléter

Le graphe apparaît ensuite afin de distinguer ces raies ainsi qu'une fenêtre se sortie renseignant sur l'encadrement des raies à 2 sigmas :

Le graphe des raies fines La fenêtre de sortie

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Prérequis :
PRiSM et la spectroscopie
Paramétrage des graphes sous PRiSM.

Image de test :
2 Spectres, dont un calibré et l'autre pas.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Avril 2008


Traitement / Spectro - Superposer les raies telluriques

> Traitement > Spectro - Superposer les raies telluriques

Lancement : Menu [Traitement] > [Spectroscopie] > [Superposer les raies telluriques au spectre]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Ajouter les raies de l'eau sur un spectre étalonné de façon à vérifier la calibration.

Après avoir ouvert un spectre calibré, le graphe se créé automatiquement ...

... dans le but de vérifier la qualité de la calibration en faisant un zoom sur les raies telluriques si ces dernières sont présentes. Sur le graphe ci-dessous, on voit clairement que la calibration n'est pas superbe :

Images supportant cette fonction :
Images CPA et FITS

Fonction(s) Script associée(s):
Aucune

Prérequis :
PRiSM et la spectroscopie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2011


Traitement / Paramètres d'autoguidage sur fente

> Traitement > Paramètres de guidage

Lancement : Menu [Traitement] > [Spectroscopie] > [Paramètres de guidage]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Tester le futur autoguidage sur une image fixe. De plus, un test sur une image fixe permet de régler les paramètres énergétiques d'autoguidage.

Le centroïde d'une étoile ayant quasiment disparu derrière la fente est repéré. En cas d'échec total de la fonction, ceci signifie que l'astre a totalement disparu dans la fente. Dans le cas d'un autoguidage, il faut s'arranger pour poser sur la caméra d'autoguidage de façon à ce que les bords de l'astre apparaissent (même légèrement) en dehors de la fente.

Plusieurs exemples sont proposés en fin de page et dans le cas de l'étoile de Mag 1, les paramètres sont à régler de la façon suivante :

Les paramètres des images exemples

Alors que dans les cas suivants, les paramètres sont :

Le pointage initial avant ouverture de la fenêtre de renseignements est important uniquement perpendiculairement à la fente afin de localiser le point central de la fenêtre d'étude perpendiculairement à cette fente :

Les paramètres essentiels à indiquer ici sont :

  • Position entière de la fente : Indique la position approximative du centre de la fente sur l'image.

  • Largeur de la fente : Largeur totale de la fente repérée sur l'image.

  • Orientation de la fente : Si la fente est verticale ou horizontale.

Dans le cas d'un autoguidage, ces paramètres seront toujours les mêmes durant toute la nuit.

Par exemple, on obtient les données suivantes pour un décalage à gauche :

Pour un exemple de décalage à droite :

Dans le cas où l'étoile disparaîtrait totalement dans la fente, le calcul des paramètres énergétiques perd son sens et il ne faut donc pas se fier aux résultats renvoyés.

Le principe calcul est résumé dans le schéma ci-dessous.

  • Parallèlement à la fente : L'image est écroulée sur une colonne. Le barycentre et le centre gaussien sont calculés (courbe verte si réussi). Le centre gaussien, s'il est réussi, est préféré au barycentre et donc gardé.

  • Perpendiculairement à la fente : Sur la ligne retenue par le calcul précédent, il est calculé le barycentre ce qui permet d'avoir un aperçu du centre de l'astre. Cependant, dans le cas où l'étoile a quasiment disparu dans la fente, ce calcul est peu puissant. Le calcul énergétique est alors effectué et conservé si le barycentre renvoie un résultat intérieur à la fente (ce qui prouve alors que l'étoile a quasiment disparu). Pour fournir les ordres de rattrapages énergétiques, il faut aller voir la page sur l'autoguidage
    Le résultat du rapport énergétique est alors multiplié par le coefficient énergétique pour simuler la position du centroïde de l'étoile perpendiculairement à la fente. Cette information permet à l'utilisateur de vérifier la validité du coefficient énergétique fourni.

REMARQUE : En conclusion, plus les paramètres énergétiques seront importants et plus l'ordre de rattrapage donné à la monture sera important pour un même rapport énergétique sur une image. Si l'utilisateur note que le rattrapage est trop violent avec les paramètres énergétiques fournis, il faut les diminuer car cette fonction n'a qu'une valeur indicative de façon à déterminer un paramètre moyen, le paramètre "exact" dépendant de la luminosité de l'étoile, son étendu, la taille des fenêtres choisies ... etc ...

Animations FLASH exemples :
détermination du paramètre énergétique à droite (1,5 Mo)
détermination du paramètre énergétique à gauche (1,5 Mo)

Image exemple :
Etoile Mag 1 : étoile
Autre étoile : A gauche, A droite

Images supportant cette fonction :
Toutes images

Fonction(s) Script associée(s):
xxxxx

Version Aout 2008


Traitement / Traitement par plugin

> Traitement > Traitement par plugin

Lancement : Menu [Traitement] > [Traitement par plugin]

But : Réaliser un traitement personnel sur une image.

Il faut alors programmer sa fonction personnelle en langage DELPHI ou C++. Il est proposé l'exemple d'un traitement logarithmique base 10 sur tous les pixels de l'image

  • Charger le code en Delphi
  • Charger le code en C++

A l'aide du compilateur, la compilation de chacun de ces projets créera une DLL. Cette dernière devra se situer dans le répertoire principal de PRiSM et porter le nom "ImageProc.dll" avant le lancement du programme.

Quelques points sont incontournables pour la base du code :

  • L'image demandée par PRiSM devra satisfaire au type TComplete_Image : La dimension en X, la dimension en Y, le type de données, un pointeur pointant vers des valeurs mémoires correspondantes aux pixels de l'image, le nombre de plan de l'image, le tableau de seuil et le type de visualisation.
  • Le type d'image est un entier qui est défini dans les constantes pour comparaison.
  • Les types de pointeur doivent être définis dans les types de données.
  • Le nombre de plan correspond aux images monochromes (1) ou couleurs (3).
  • SeuilBas et SeuilHaut sont des tableaux de dimension 3 dont éventuellement une seule valeur est complétée (suivant une image monochrome ou couleur).

La fonction peut ensuite être complétée : il suffit alors de récupérer les valeurs, les mettre éventuellement dans un tableau, les transformer et recompléter les valeurs du pointeur en fonction des nouvelles valeurs.

Cette façon de procéder permet d'éviter de passer par des scripts car beaucoup plus rapide dans l'exécution en tant que langage compilé par rapport à un langage interprété comme le langage script.

Images supportant cette fonction :
Images ouvertes dans PRiSM

Fonction(s) Script associée(s):
Aucune ... pour le moment !

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Septembre 2007


Analyse / Blink

> Analyse > Blink d'images

Lancement : Menu [Analyse] > [Blink (Comparaison d'images)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Faire apparaître à l'oeil des différences entre les images et effectuer des mesures simples.

Version minimum pour les changements astrométriques : 7.00.22

Cette fonction permet de repérer les différences entre 2 (ou plus) images d'une même zone du ciel. Le principe du blink consiste à afficher l'une après l'autre les images concernées, à une certaine fréquence à définir, de façon à ce que les différences entre les images apparaissent comme des détails qui "clignotent".

Les images concernées doivent être préalablement chargées sous PRiSM et la première d'entre elles doit être sélectionnée. Au lancement de la fonction, la fenêtre suivante s'affiche :

Les paramètres à fournir

  • Le champ "Intervalle de rafraichissement" permet d'indiquer le temps qui va s'écouler entre l'affichage de 2 images consécutives
  • Le champ "Nombre d'images" permet d'indiuer le nombre d'images que l'on veut comparer
  • La case à cocher "Mettre les images à luminosité/contraste identique" : Elle permet de forcer les seuils de toutes les images au même niveau.
  • La case à cocher "Produire les sorties astrométriques au format MPC" permet de créer une suite de ligne sur un objet répondant au format MPC d'un objet.
  • Le champ "Code MPC" : à compléter pour que ce numéro apparaisse directement dans la suite de ligne au format MPC.
  • La case à cocher "Utiliser les informations entête de décalages" : Utilise des infos "cachées" dans l'entête de l'image sur la translation de cette dernière mais deja calculé lors d'une précédente comparaison des images. En effet, lors d'un matching ou d'une addition d'image pour repérer un astéroïde, cette opération est déjà effectuée.
  • La case à cocher "Réalignement stellaire" permet de demander au logiciel de recentrer entre-elles, automatiquement, les images.

En cliquant sur le bouton [OK], l'opération de blink est lancée. La fenêtre suivante s'ouvre alors :

Un exemple de blink à partir des 3 images fournies
Exemple de blink des 3 images exemples fournies, mettant en évidence un astéroide potentiel

Les boutons en haut à droite de la fenêtre permettent de sélectionner les images qui doivent ou non faire partie de la série des images à blinker. Durant l’animation, l’utilisateur peut « décocher » une image afin de la rendre inopérante.

En haut à gauche de la fenêtre, on trouve : le bouton [STOP] qui arrête l’animation sur l’image présentée au moment où on clique sur le bouton. le bouton [GO] relance l'animation sur les images sélectionnées. L'incrémenteur [image déplacée] permet de préciser le numéro de l’image à déplacer (peut être utilisé dans le cas où le recentrage n’a pas été demandé ou n’a pu être effectué). Le déplacement de l’image retenue se réalise grâce aux flèches au bas de la fenêtre :

Lorsque le mode blink est suspendu, 2 ascenseurs apparaissent sur la gauche de la fenêtre. Ils permettent de modifier les seuils de visualisation de l'image courante. Le zoom est laissé au choix de l'utilisateur et est utilisable durant une animation.

On définit l'image survolée comme l'image prise en compte lorsqu’on passe la souris dessus. Afin d’atteindre l’image survolée désirée, il faut stopper l’animation sur la série d’image. Il est possible de connaître la position du curseur sur l'image indiquée ainsi que les coordonnées si l'étalonnage astrométrique a été réalisé :

Attention : il ne faut pas demander le recentrage des images par rapport à la première sélectionnée si on veut garder l'étalonnage astrométrique mémorisé autre que pour l'image de référence (la première). Cette remarque est particulièrement valable pour le blink sur des images à partir desquelles on cherche à créer un fichier de sortie au format MPC.

Afin de passer à l'image suivante ou si l’image indiquée n’est pas celle désirée, il faut cliquer sur le bouton correspondant : . Le nom de l'image ne change alors que lorsqu’on passe la souris dessus.

Il est enfin possible de créer une série de mesures au format MPC sur un objet. Sur les images proposées, on le trouve à l'endroit suivant :

En cliquant avec le bouton droit de la souris sur l'image survolée, on réalise le centroïde de l'objet et si demandé, on crée une ligne au format MPC correspondant à l'objet :

On a réalisé le centroïde sur l'image n°1

En réalisant l'opération sur la suite des images :

Lignes au format MPC

Il suffit alors de cliquer sur l'icône de copie afin de copier les lignes dans le presse-papier. Les lignes deviennent alors récupérables dans un fichier texte.

Focntion script associée :
Blink

Images de test :
Images de test

Conditions d'activation du menu :
Qu'une image soit ouverte.

Octobre 2008


Analyse / Histogramme fenêtré

> Analyse > Histogramme fenêtré

Lancement : Menu [Analyse] > [Histogramme] > [Histogramme Fenêtré]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Fournir un histogramme sur une partie d'une image.

Cette fonction permet d'obtenir un histogramme d'une partie d'une image.

Au lancement de cette fonction, un curseur apparaît sur l'image, il permet de sélectionner la zone à analyser. Lorsque la sélection est terminée, l'histogramme est affiché et son utilisation est identique à celle d'un histogramme pour image entière.

Fonction script associée :
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Octobre 2007


Analyse / Histogramme global

> Analyse > Histogramme global

Lancement : Menu [Analyse] > [Histogramme] > [Histogramme Global]

Touche de raccourci : [Ctrl] + [Alt] + [Z]

But : Fournir un histogramme sur toute une image.

1 ) Présentation :

Un histogramme correspond à la répartition des pixels dans une image en fonction de leur valeur.

2 ) Interface :

La partie sur la liste de pixels froids/chauds est définie dans une autre fonction : [Prétraitement] > [Générer une liste des pixels chauds] > [Méthode manuelle]

Visualisation :

La boite de dialogue ci-dessus ne montre qu`une partie de l`histogramme. Ici, il s`agit d`une fenetre dont les pixels ont des valeurs comprises entre 1068 et 1295.
Il est possible de changer la visualisation grâce à la partie suivante de la boite de dialogue :

  • Max sur X : Valeur maximum de l'intensité des pixels en ADU représentée en abscisse sur le graphe. Les flèches verticales permettent de faire varier cette valeur suivant le pas imposé ci-dessous.
  • Min sur X : Valeur minimum de l'intensité des pixels en ADU représentée en abscisse sur le graphe. Les flèches verticales permettent de faire varier cette valeur suivant le pas imposé ci-dessous.
  • Pas : pas de variation de "Max de X" ou "Min de X" lorsqu'on appuie sur les flèches afin de faire augmenter ou diminuer une de ces valeurs.
  • : Permet de faire varier simultanément "Max de X" et "Min de X" d'un certain pas. La flèche de gauche permet de diminuer "Max de X" et "Min de X" d'un certain pas. La flèche de droite permet d'augmenter "Max de X" et "Min de X" d'un certain pas. Elles ont pour but de translater horizontalement le graphe.
  • : La flèche de gauche permet de faire varier "Min de X" à la valeur située dans la fenêtre "Valeur pixel". La flèche de droite permet de faire varier "Max de X" à la valeur située dans la fenêtre " Valeur pixel ".
  • : Permet simultanément de diminuer "Max de X" et d'augmenter "Min de X".
  • : Permet simultanément d'augmenter "Max de X" et de diminuer "Min de X".
  • Reset : Impose les valeurs intiales à "Max de X" et "Min de X"
  • PRNU : Critère d'étalement de l'histogramme.

En cliquant sur la boite "Echelle axe Y log", l`axe de réprésentation Y sera logarithmique. Cela permet de voir en meme temps les hautes et les faibles valeurs de l`histogramme.

Visualisation linéaire

Visualisation logarithmique

Manipulation des valeurs :

En cliquant sur l`histogramme, vous faites apparaitre un curseur. Des statistiques sont affichées associées aux pixels sélectionnés par ce curseur.

  • La valeur en ADU correspondant à la barre jaune ( réglable à partir des flèches verticales ).
  • Le nombre de pixel qui ont cette valeur sur l'image ou la zone d'image.
  • le pourcentage cumulatif de pixels ( de l'image ou de la zone ) qui ont une valeur en ADU inférieure ou égale à celle indiquée.
  • L'indication " cumulatif -oo " indique dans un premier temps le nombre de pixels ( de l'image ou de la zone ) dont l'intensité est inférieure ou égale à la valeur indiqué (= nombre de pixel total de la zone * pourcentage). Il est indiqué ensuite le nombre de pixels de la zone dont l'intensité est strictement supérieure à la valeur indiquée.

En cliquant sur le bouton : vous faites apparaitre en rouge dans l`image les pixels dont l`intensité est inférieur ou égale à celle du curseur.
En cliquant sur le bouton : vous faites apparaitre en rouge dans l`image les pixels dont l`intensité est égale à celle du curseur.

Il est possible de mettre a 0 la valeur des pixels en dessous du curseur en cliquant sur le bouton : .
De même, si vous cliquez, sur le bouton : , les pixels dont la valeur est au dessus de celle du curseur passe a 32767.
Il est également possible de sauvegarder l'histogramme sous la forme d'un fichier de données à partir du bouton "Sauver".

Remarque importante : La fonction histogramme de PRiSM prend en compte les images codées en réels et affiche donc les valeurs de pixels négatifs ( mais entiers en valeur absolue ). Par contre, comme cette fonction est surtout utilisable avec les images codées en réels, l'intensité maximum en ADU ne dépassera pas 65535 pas codeurs et l'intensité minimum ne descendra pas en dessous de -65535 pas codeurs.

3 ) Utilisation :

L`histogramme d`une image peut avoir plusieurs applications.

Une utilisation typique pour quelqu`un qui veut tester sa caméra CCD, est de détecter un bug dans le convertisseur analogique/numérique de sa caméra.
Si certains bits parmis les valeurs des pixels apparaissent plus souvent que d`autres, cela peut un histogramme comme ceci :

On voit que statistiquement, certaines valeurs aparaissent plus souvent que d'autres et de facon périodique. Si l`histogramme d`une image provenant de votre caméra CCD apparait comme ceci, il est vivement conseillé de retourner celle-ci a son fabricant...

Un histogramme d'une image astronomique peut aussi servir a détecter le niveau du fond de ciel. Celui-ci se situe au sommet de l`histogramme. Celui-ci possède en général la forme d`une gaussienne et l'écart-type de cette gaussienne correspond au bruit de fond de ciel.

Fonction script associée :
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Analyse / Coupe d'image verticale

> Analyse > Coupe verticale d'une image

Lancement : Menu [Analyse] > [Coupe d'image] > [Verticale]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser une coupe verticale d'une image.

Cette fonction permet de visualiser une coupe verticale d'une image.

L'image à analyser étant préalablement chargée et sélectionnée, lorsqu'on lance cette fonction, la fenêtre suivante apparaît :

Pour visualiser une coupe verticale de l'image, il faut placer la souris au-dessus de l'image tout en maintenant la touche "shift" enfoncée. Au fil des déplacement de la souris, la coupe verticale de l'image passant par le curseur de la souris est affichée :

  • Les champs X et Y indiquent les coordonnées du pixel situé sous le curseur de la souris
  • Le champ "Valeur" indique l'intensité du pixel situé sous le curseur de la souris
  • Les champs "Seuils" sont les seuils (haut et bas) utilisés pour visualiser l'image
  • Le champ "Moy" donne la moyenne des intensités des pixels situés sur la ligne de coupe
  • Le champ "Sigma" donne la valeur du sigma des intensités des pixels situés sur la ligne de coupe
  • La case à cocher "Point" permet de visualiser la coupe sous forme de points au lieu d'une ligne.

Il est possible de sauvegarder une coupe en cliquant sur le menu [Sauver].

Il est possible de représenter la coupe au sein d'un graphe statique (en vue de modifier sa représentation par exemple) en cliquant sur le menu [Envoyer vers un graphe statique]

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Prérequis :
Les graphiques sous PRiSM

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version PRiSM 5


Analyse / Coupe d'image horizontale

> Analyse > Coupe horizontale d'une image

Lancement : Menu [Analyse] > [Coupe d'image] > [Horizontale]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser une coupe horizontale d'une image.

Cette fonction permet de visualiser une coupe horizontale d'une image.

Son principe est identique à celui de la fonction de coupe d'image verticale, à laquelle on se reportera. La seule différence est que la coupe est effectuée le long d'une ligne horizontale.

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Prérequis :
Les graphiques sous PRiSM

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Octobre 2007


Analyse / Coupe d'image en diagonale

> Analyse > Coupe diagonale d'une image

Lancement : Menu [Analyse] > [Coupe d'image] > [Diagonale]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser une coupe diagonale d'une image.

Cette fonction permet de visualiser une coupe de l'image entre 2 points librement choisis.

Son principe est identique à celui de la fonction de coupe d'image verticale, à laquelle on se reportera. La seule différence est que la coupe est effectuée entre 2 points sélectionnés sur l'image. La sélection des points se fait juste après le lancement de la fonction, avec le bouton de la souris, en cliquant sur l'image aux emplacements choisis.

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Prérequis :
Les graphiques sous PRiSM

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Octobre 2007


Analyse / Coupe d'image spectrale

> Analyse > Coupe spectrale d'une image

Lancement : Menu [Analyse] > [Coupe d'image] > [Spectrale]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser une coupe spectrale d'une image.

Cette fonction permet de tracer un graphe donnant une coupe spectrale d'une image 2D d'un spectre.

Il faut l'utiliser sur une image 2D spectrale de type FITS 1D, où tous les pixels sont identiques sur une colonne.

Un exemple de coupe spectrale

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Prérequis :
Les graphiques sous PRiSM

Images de test :
Spectre FITS 1D d'Altair (non corrigé de la réponse instrumentale).

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Mars 2008


Analyse / Statistique globale sur l'image

> Analyse > Statistiques fenêtrées

Lancement : Menu [Analyse] > [Statistiques] > [Statistiques globales]

Touche de raccourci : [F10]

But : Cette fonction permet d'obtenir quelques informations statistiques sur une image entière préalablement chargée et sélectionnée.

Au lancement de la fonction une fenêtre s'ouvre contenant diverses informations statistiques concernant l'ensemble de l'image :

Ce quadrant indique toutes les propriétés statistiques de l'image :

  • La moyenne de toutes les valeurs des pixels.
  • La médiane des valeurs des pixels de l'image
  • Le minimum et le maximum de l'image ainsi que leur position sur l'image.
  • La moyenne quadratique est indiquée juste en-dessous.
  • Le flux total de l'image.
  • L'écart-type : ici, celà signifie que la très grande majorité des pixels (70%) se situent entre -326 et 644.
  • Le nombre total de pixel de l'image.
  • L'entropie de l'image : L'entropie est la quantité moyenne d'information par pixel en partant du principe que tous les pixels ont la même probabilité ou importance. Elle est une mesure de l'information « intrinsèque » du signal et notamment du détail de l'image.
  • Gain S/B² = Moyenne / Ecart-Type^2 : Dans une image, le bruit est aléatoire et suit une loi normale. Le rapport signal sur bruit peut alors se définir par le rapport entre l'intensité moyenne mesurée et l'écart type suivant la relation précédente.
  • Gain 2S/B² = 2 * Gain S/B².

Fonction script associée :
Stat

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Bruit de lecture

Prérequis :
Les statistiques

Janvier 2008


Analyse / Statistiques fenêtrées

> Analyse > Statistiques fenêtrées

Lancement : Menu [Analyse] > [Statistiques] > [Statistiques fenêtrées]

Touche de raccourci : [F12]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Fournir une statistique sur une partie de l'image.

Cette fonction permet d'obtenir quelques informations statistiques sur une zone rectangulaire d'une image préalablement chargée et sélectionnée.

Après le lancement de la fonction il faut sélectionner une zone rectangulaire sur l'image à l'aide du bouton gauche de la souris. Une fenêtre s'ouvre contenant diverses informations statistiques concernant la zone sélectionnée de l'image :

Les informations fournies sont identiques aux informations fournies pour une statistique globale.

Fonction script associée :
StatWindow

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Bruit de lecture

Prérequis :
Les statistiques

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Statistique polygonale sur l'image

> Analyse > Statistiques polygonales

Lancement : Menu [Analyse] > [Statistiques] > [Statistiques polygonales]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet d'obtenir quelques informations statistiques sur une zone polygonale d'une image préalablement chargée et sélectionnée.

Après le lancement de la fonction il faut sélectionner la zone polygonale de l'image sur laquelle doit porter l'analyse. Un curseur apparaît et permet de définir le contour de la zone d'analyse (par clics successifs du bouton gauche de la souris) :

Lorsque la sélection de la zone polygonale est terminée, une fenêtre s'affiche, avec les données statistiques concernant l'image :

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Bruit de lecture

Prérequis :
Les statistiques

Janvier 2008


Analyse / Statistique globale sur l'image

> Analyse > Ecrouler l'image sur une ligne/colonne

Lancement : Menu [Analyse] > [Statistiques] > [Ecrouler l'image sur une ligne/colonne]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet chaque pixel d'une zone rectagulaire déterminée par la somme (ou la médiane) des valeurs des pixels situés sur la même ligne (ou colonne) de la zone.

Au lancement de la fonction, l'image étant préalablement chargée et sélectionnée, la fenêtre suivante s'ouvre :

  • Les valeurs X1, Y1, X2 et Y2 sont les coordonnées des points définissant la zone rectangulaire de travail : (X1,Y1) et (X2,Y2) étant les coordonnées respectives de 2 coins de la zone rectangulaire. Le point (0,0) est en bas à gauche de l'image.

  • Si la case à cocher "Utiliser la médiane", c'est la médiane des pixels qui est utilisée, dans le cas contraire, c'est la moyenne des pixels

  • Si la case à cocher "Somme/Médiane parallèle à la verticale" est cochée, alors chaque pixel de la zone est remplacé par la médiane (ou la moyenne) des pixels situés sur la même colonne que lui. Dans le cas contraire, chaque pixel de la zone est remplacé par la médiane (ou la moyenne) des pixels situés sur la même ligne que lui.

On peut voir ci-dessous un exemple d'utilisation de cette fonction :

Image originale

Image finale

Cette fonction est particulièrement utile dans le cadre de la réalisation de spectres.

Pour exemple, On considère un spectre d'étoile, l'image étant déjà prétraitée :

L'image brute mais prétraitée

Afin de supprimer le bruit résiduel de l'image (essentiellement dû à la turbulence) et comme ce qui nous interesse est le profil horizontal de l'image, on ramène toute l'image en une seule ligne bien que l'image résultante conserve la même taille. Seulement, tous les pixels de même abscisse auront même valeur.

L'image réduite à une ligne

Pour arriver à cette fin, les options suivantes ont été remplies :

Les options utilisées

Il est possible ensuite de réaliser une coupe d'image horizontale à partir du menu [Analyse] > [Coupe d'images] > [Horizontale].

On obtient alors la coupe du type suivant qui peut être étudiée à partir de la partie graphique de PRiSM.

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Spectre exemple

Prérequis :
Les statistiques

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Statistique annulaire sur l'image

> Analyse > Statistiques annulaires

Lancement : Menu [Analyse] > [Statistiques] > [Statistiques annulaires]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet d'obtenir quelques informations statistiques sur une zone annulaire d'une image préalablement chargée et sélectionnée. Cette zone se situe entre deux cercles de diamètres définis.

Après le lancement de la fonction il faut sélectionner la zone annulaire de l'image sur laquelle doit porter l'analyse. Un curseur apparaît et permet de définir le contour de la zone d'analyse (par clics du bouton gauche de la souris) :

Paramètres à fournir Sélectionner la zone

Lorsque la sélection de la zone annulaire est terminée, une fenêtre s'affiche, avec les données statistiques concernant l'image :

Les résultats fournis

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Bruit de lecture

Prérequis :
Les statistiques

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Statistique de fond de ciel sur l'image

> Analyse > Statistiques de fond de ciel

Lancement : Menu [Analyse] > [Statistiques] > [Fond de ciel]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet d'obtenir quelques informations statistiques sur le fond de ciel d'une image entière préalablement chargée et sélectionnée.

Au lancement de la fonction une fenêtre s'ouvre contenant les informations statistiques du fond de ciel de l'image :

Ce quadrant indique toutes les propriétés statistiques du fond de ciel de l'image :

  • Sa valeur sur toute l'image en ADU.
  • Son ecart-type sur l'image en ADU

Si l'étalonnage photométrique de l'image a été effectué, on peut connaître la valeur du fond de ciel en magnitude à partir de la fonction [Analyse] > [Photométrie] > [Fond de ciel]

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Image

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Créer un catalogue d'étoiles

> Analyse > Créer un catalogue des objets stellaires

Lancement : Menu [Analyse] > [Créer un catalogue des objets stellaires] ou [Analyse] > [Catalogue des étoiles issus d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Créer un catalogue d'étoile à partir des étoiles repérées sur une image.

Ce menu peut être obtenu sans qu'une image ne soit ouverte (mais le menu ne porte pas le même nom dans les deux cas).

Seuil de détection :Il s'agit du seuil au-dessus duquel les sources vont devenir détectables. Le logiciel est capable de calculer la valeur du fond de ciel ainsi que le bruit de fond ciel qui correspond à un écart type. Au dessus d'un certain nombre de fois la valeur cet écart type au dessus du fond de ciel, on considère qu'un objet est détecté. Cette valeur est généralement de 3 mais peut être ramenée à 2.5 si l'on veut détecter des objets plus faibles.

Appliquer un modèle gaussien : Cette option est fortement conseillée. Elle permet d'appliquer un modèle de forme gaussienne sur les sources détectées. Ceci facilite la discrimination entre les objets de forme stellaire et les autres, et donc d'améliorer considérablement la détection. De plus, cela permet de calculer avec précision la position des objet, ainsi que leur magnitude. Vous pouvez ne pas cocher cette option dans le cas ou la largeur a mi-hauteur des étoiles est tres faible (sous-échantillonage), ou lorsque la densité d'étoile est tres importante (observations dans la Voie Lactée).

Taille du plan d'ondelette de détection : Le plan d'ondelette sur lequel le logiciel va se baser pour reconnaître les étoiles.

Largeur à mi-hauteur des étoiles : Ce paramètre n'est valable que si l'utilisateur a décoché l'option "recherche automatique de la FWHM". Il doit avoir la valeur de la largeur à mi-hauteur moyenne des étoiles dans vos images. Pour la connaitre, vous pouvez utiliser la fonction "centroide gaussien" de PRiSM : [Analyse] > [Centroïde] > [Gauss 2D (Rayon=..p)]
Pour les grandes images pour lesquelles cette valeur varie en fonction de la position dans l'image, cette valeur est recalculée automatiquement. Vous devez tout de même mettre une valeur de départ correcte.

Seuil de saturation des étoiles : Ce paramètre n'est valable que si vous avez coché l'option "Appliquer un modèle gaussien". Il doit correspondre à la valeur de saturation de vos images et pemet de traiter de facon différente les étoiles saturées.

Eliminer les étoiles saturées : Cet paramètre n'est valable que si vous avez coché l'option "Appliquer un modèle gaussien". Le fait de cocher cette option, permet d'éliminer directement les étoiles saturées. Celles-ci peuvent en effet biaiser l'étalonnage astrométrique et photométrique.

Taille du buffer image (nbre de ligne) : Ce paramètre est utilisée pour les grandes images. En effet, pour ne pas surcharger l'ordinateur, celles-ci sont d'abord découpées en morceaux avant d'être traitées. Le paramètre détermine le nombre de ligne pour chacun des morceaux.

Le résultat :
le fichier apparaît dans le répertoire où se situe les images. Ce fichier porte le même nom que l'image auquel il correspond et doit porter l'extension .cat.
Son format est de la forme suivante :
Le première colonne indique le numéro d'ordre de l'objet.
La deuxieme et la troisième colonne indique successivement la position sur l'axe des X et sur l'axe des Y.
La quatrième et la dernière colonne indique une valeur de magnitude. Celle-ci n'est pas absolue, mais est relative par rapport aux autres objets.

Fonction script associée :
Aucune

Images de test :
Image astrométrie - photométrie

Résultat :
Fichier CAT résultant

Janvier 2008


Analyse / Positions astrométriques à partir d'un catalogue

> Analyse > Positions astrométriques à partir d'un catalogue

Lancement : Menu [Analyse] > [Positions astrométriques à partir d'un catalogue]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet d'étalonner astrométriquement et photométriquement des catalogues d`étoiles contenus dans des fichiers au format ".cat", tels que ceux fournis par la fonction de recherche des astéroïdes ou par la fonction d'extraction d`objets stellaires dans une image.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

  • Les champs "Position Alpha" et "Position Delta" sont les coordonnées approximatives d'un point de référence dans le catalogue

  • Les champs "Position pixélique de la référence astrométrique", en X et en Y sont les coordonnées (en pixels) du point de référence dans le catalogue

  • Le champ "Focale de l'instrument" permet d'indiquer la focale de l'instrumentation utilisée pour réaliser le catalogue

  • Les champs "Découpe du catalogue" en X et en Y, permettent de définir des zones à l'intérieur du catalogue. Ces valeurs permettent de définir la taille de ces zones.

  • Le champ "catalogue" permet de choisir le catalogue de référence à utiliser.

  • Les "Fichiers catalogues" sont les fichiers à traiter par le logiciel. Ils portent l'extension .cat et ils doivent avoir le format suivant :

    1 | 1.61128494262695E+0002 | 7.61783790588379E+0000 | -6.25162696838379E+0000
    2 | 3.46888793945313E+0002 | 8.88834762573242E+0000 | -7.48398780822754E+0000
    3 | 4.67933624267578E+0002 | 1.01075286865234E+0001 | -7.40681552886963E+0000
    4 | 2.68732547760010E+0001 | 1.06235733032226E+0001 | -9.27642154693604E+0000
    5 | 2.07370254516602E+0002 | 1.08290052413940E+0001 | -1.13452119827270E+0001
    ... ... ... ...
    Le permier champ est le numéro de l'étoile, le second et le troisième sont les positions X et Y (en pixels) de l'étoile, le 4ème champ est la luminosité relative de l'étoile

Les résultats sont fournis dans 2 fichiers possédant le même nom que le catalogue CAT de départ, mais avec une extension différente. La signification est renvoyé dans la fenêtre de sortie de PRiSM :

  • Les fichiers avec l'extention ".ast" fournissent la position astrométrique et photométrique des étoiles du catalogue de départ, au format suivant :

    1 | 5.99513832147174E+0000 | -1.04301998543910E-0001 | 1.98893609528439E+0001
    2 | 5.99327027493146E+0000 | -1.04198843265538E-0001 | 1.98893609528439E+0001
    3 | 5.99205455857829E+0000 | -1.04130471934357E-0001 | 1.91645612655917E+0001
    4 | 5.99648632741711E+0000 | -1.04337503737055E-0001 | 1.71242008493846E+0001
    5 | 5.99467327311791E+0000 | -1.04247755814807E-0001 | 1.51000003814697E+0001
    ... ... ... ...
    Le permier champ indique le numéro de l'étoile, le second et le troisième indiquent les coordonnées Alpha et Delta et le quatrième indique la magnitude de l'étoile.
  • Les fichiers avec l'extention ".ref" fournissent les étoiles du catalogue de référence (GSC, USNO, etc) et celles qui leur correspondent dans le catalogue image, au format suivant :

    1 | 8.92980499267578E+0001 | 4.44772834777832E+0001 | 5.99585866928101E+0000 | -1.03957746177911E-0001 | 1.33999996185302E+0001 | -1.34055652949415E+0001
    2 | 2.83440063476563E+0002 | 1.38063247680664E+0002 | 5.99395442008972E+0000 | -1.02928698062896E-0001 | 1.43999996185302E+0001 | -1.17921638118550E+0001
    3 | 8.92224349975586E+0001 | 2.12765686035156E+0002 | 5.99593973159790E+0000 | -1.02276120334863E-0001 | 1.26999998092651E+0001 | -1.42701368118395E+0001
    4 | 2.05678512573242E+0002 | 9.87937068939209E+0000 | 5.99467110633850E+0000 | -1.04249127209186E-0001 | 1.51000003814697E+0001 | -1.13400869984564E+0001
    ... ... ... ... ... ... ...
    La première colonne indique le numéro de l`étoile de référence. La deuxième et la troisième colonne donnent la position X et Y de l`étoile dans l`image (en pixels). La quatrième et la cinquième colonne donnent la position Alpha et Delta de l`étoile du catalogue de référence. La sixième colonne donne la magnitude de l`étoile de référence. La dernière colonne donne la magnitude relative de l`étoile dans le catalogue de départ.

Fonction script associée :
Aucune

Exemple de catalogue CAT :
Image astrométrie - photométrie

Résultats :
Fichiers résultant

Janvier 2008


Analyse / Réduction d'un groupe d'étoiles

> Analyse > Réduction d'un groupe d'étoiles

Lancement : Menu [Analyse] > [Réduction d'un groupe d'étoiles] > [Modélisation]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de modéliser un champ d'étoiles contenues dans une image. Le résultat est une nouvelle image de synthèse contenant uniquement les modèlisations des étoiles repérées dans l'image d'origine.

Au lancement de la fonction, un ensemble de rectangles rouges apparaissent sur l'image aux emplacements sur lesquels le logiciel a repéré une étoile. Le résultat est affiché après un temps de calcul qui peut atteindre plusieurs minutes :

Image de départ

Identification des étoiles

Modélisation des étoiles contenues dans le champ

Le réglage des options de reconnaissance de champ est important : [Options] > [Reconnaissance des champs d'étoiles]

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Fonction(s) Script associée(s):
Voir TrigMatch

Exemple d'image :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Etalonnage manuelle photométrique d'une image

> Analyse > Etalonnage manuelle photométrique d'une image

Lancement : Menu [Analyse] > [Photométrie] > [Etalonnage]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de faire l'étalonnage photométrique d'une image à partir d'étoiles de magnitude connue contenues dans l'image.

Au lancement de la fonction, la fenêtre suivante permet d'indiquer combien d'étoiles seront utilisées pour l'étalonnage :

Après avoir indiqué le nombre d'étoiles de référence et avoir cliqué sur le bouton [OK], un curseur apparaît et permet de sélectionner la première des étoiles dont la magnitude est connue :

Lorsque l'étoile est sélectionnée (d'un clic du bouton gauche de la souris), la fenêtre suivante apparaît, donnant diverses informations sur l'étoile sélectionnée :

Après avoir cliqué sur le bouton [OK], la fenêtre suivante apparaît, permettant d'indiquer la magnitude de l'étoile :

Après avoir cliqué sur le bouton [OK], soit le curseur apparaît pour désigner l'étoile de référence suivante (si plusieurs étoiles sont utilisées pour l'étalonnage), soit l'étalonnage est terminé et il devient possible de demander la magnitude de n'importe quelle étoile de l'image, grace à la fonction [Analyse] > [Photométrie] > [Mesure]

Dans la mesure du possible, cette méthode est à prendre avec précaution car l'erreur sur la magnitude mesurée par la suite sera assez importante. En effet, le nombre d'étoile utilisé est ici forcément faible et pour qu'une image soit correctement étalonnée, il faut que cet étalonnage ait lieu sur un maximum d'étoiles et donc soit au moins réalisée avec l'étalonnage photométrique automatique : [Analyse] > [Astrométrie] > [Etalonnage automatique]

Images supportant cette fonction :
images monochromes

Fonction(s) Script associée(s):
EtalonPhotometrieF

Exemple d'image :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Etalonnage photométrique automatique

> Analyse > Etalonnage photométrique automatique

Lancement : Menu [Analyse] > [Photométrie] > [Etalonnage automatique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet d'effectuer un étalonnage photométrique d'une image. Contrairement à la fonction [Analyse] > [Photométrie] > [Etalonnage], il n'est pas besoin de sélectionner des étoiles étalons, le logiciel le fait automatiquement.

1ère étape CONSEILLEE : compléter correctement l'entête de l'image à étalonner

Il n'est pas obligatoire de compléter l'entête de l'image pour réaliser un étalonnage automatique. Cependant, ceci est fortement conseillé, afin d'éviter de devoir rentrer les paramètres manuellement et de plus, à chaque fois ! Le mieux est que l'entête de l'image à étalonner contienne :

  • la position Alpha/Delta approximative du centre de l'image. Si ce n'est pas le cas, le moyen le plus simple consiste à le faire à partir du menu contextuel de la carte du ciel ou de les fournir directement depuis les informations de l'image.
  • La focale de l'instrument à fournir directement depuis les informations de l'image.
  • La taille des pixels du capteur à fournir directement depuis les informations de l'image.
2ème étape : le choix du catalogue d'étalonnage

On peut maintenant utiliser simplement la fonction [Analyse] > [Astrométrie] > [Etalonnage automatique]. La fenêtre suivante s'ouvre alors :

Le tableau d'étalonnage photométrique | Catalogue avec un seul type de magnitude Catalogue avec différentes bandes de magnitude
Le tableau d'étalonnage photométrique | La bande de magnitude n'est pas toujours sélectionnable suivant le catalogue utilisé !
  • Les champs "Alpha" et "Delta" contiennent la position approximative du centre de l'image. Si cette position n'a pas été préalablement renseignée dans l'entête de l'image (voir 1ère étape), il reste possible de la saisir à cet instant.

  • Il en est de même pour les données comme la focale du télescope et la taille des pixels en X et en Y qui, si elles ont été renseignées lors de la prise de vue, sont automatiquement présentes dans les champs correspondants de cette fenêtre.

  • Le catalogue de référence est le catalogue qui sera utilisé pour l'étalonnage.

    PRiSM nous laisse le choix entre plusieurs catalogues : GSC, USNO SA2, USNO A1 (obsolète maintenant !), USNO A2, Hipparcos, SAO, BSC, Tycho1, GSC-ACT, Tycho2, UCAC 1 et 2. Seuls les catalogues GSC, SAO, BSC, Tycho 1 et 2 sont compilés sous PRiSM et il n'est donc pas nécessaire d'indiquer le chemin d'accès. Par contre, pour les autres catalogues, le chemin d'accès fourni dans les options est indiqué en dessous et peut encore être changé. Chaque catalogue a ses propres défauts :

    • Le GSC indique toutes les étoiles jusqu'à la magnitude 16, Bande V, et est compilé directement sous PRiSM. A cause de son âge, il n'est pas conseillé de l'utiliser en tant que catalogue photométrique. Il en est de même du catalogue GSC-ACT téléchargeable sur internet et plus précis seulement astrométriquement.
    • Le catalogue USNO-SA contient des étoiles régulièrement espacées sur la sphère céleste jusqu'à la magnitude 20, mais il ne les contient pas toutes. Il peut donc apparaître sur l'image des étoiles qui ne sont pas dans le catalogue. Le choix de ce catologue pourra donc, mais très rarement, ne pas fonctionner. Plus précis que l catalogue GSC, on lui préfèrera le catalogue USNO A2 : plus d'étoiles pour un champ donné donc un plus grand choix pour la comparaison afin de limiter les erreurs.
    • Les autres catalogues sont décrits dans la section sur les catalogues. On remarque que, d'un point de vu astrométrique, les catalogues à privilégier sont Hipparcos et Tycho 1 et 2. Cependant, le nombre d'étoiles de référence parfois insuffisant mène à continuer à privilégier l'utilisation de catalogue comme USNO A2.
3ème étape : compléter les autres paramètres
  • Le nombre d'étoiles maximum les plus brillantes du catalogue de référence avec lesquels PRiSM formera des triangles. Ces derniers seront comparés avec les triangles obtenus à l'aide du nombre maximum d'étoiles les plus brillantes de l'image. La méthode utilisée est la méthode des triangles.

  • Redéfinir les niveaux de messages : Cette option permet de choisir d'avoir toutes les informations essentielles lors de l'étalonnage (niveau 4) ou alors, le minimum (niveau 1). Le niveau choisi est indiqué au dessus du bouton correspondant. Un exemple de niveau 4 d'information est fourni.

  • Réglage de la reconnaissance auto : permet d'afficher le menu option de reconnaissance automatique sans avoir à fermer la fenêtre d'étalonnage automatique.

  • Si l'image est orientée Nord en haut, alors on cochera la case "Image orientée Nord/Sud". Ceci permet de réduire le temps de calcul. Cependant, ce paramètre est pondéré par celui de l'option de reconnaissance auto : Marge d'erreur sur la rotation

  • Si on souhaite voir l'avancement des calculs, alors on cochera la case "Voir état du calcul" et les informations seront fournies en fonction du niveau des messages définis.
4ème étape : le choix du polynôme de passage

L'étalonnage se lancera alors en cliquant sur le bouton [OK], et à l'issue des calculs et en plus de l'éventuelle fenêtre d'information, la fenêtre suivante apparaîtra :

Les étoiles reconnues

Il faut noter cependant qu'il est impossible de changer le nombre d'étoiles étalons, même en faisant apparaître un signe de sélection à la place d'une croix. Les étoiles choisies doivent rester autour d'une certaine erreur ( résidu ) par rapport à l'étoile choisie.
Pour fixer la différence entre la magnitude d'une étoile et celle du catalogue, il est calculé le flux de toutes les étoiles de l'image et celle du catalogue. On réalise une sorte d'algorithme des moindres carrés pour approximer relier ces magnitudes les unes par rapport aux autres. L'étoile choisie aura donc un résidu très faible et qui plus est , par conception de l'algorithme, valeur médiane des résidus de toutes les étoiles.

Après validation, le nombre d'étoiles étalons retenu est indiqué dans la fenêtre de sortie et toutes les étoiles sont indiquées sur l'image :

Le fichier de sortie

Un exemple d'image étalonnée

Un fichier de renseignement sauvegardable au format texte (voir un exemple avec le maximum d'information ) est renvoyé uniquement si on a demandé à voir l'" état des calculs" et suivant le niveau des messages d'information.

Une fois étalonnée, il est possible de mesurer la magnitude de tout objet ponctuel d'une image à partir des fonctions [Analyse] > [Centroïde] > [Gauss 2D (Rayon=..p)] ou [Analyse] > [Centroïde] > [Moffat (Rayon=..p)]

Fonction(s) Script associée(s):
EtalonAstrometrieAuto

Prérequis :
La méthode des triangles
Options de reconnaissance

Condition d'activation :
Image monochrome en 16 ou 32 bits.

Image de test :
Champ stellaire

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Mars 2006


Analyse / Mesure photométrique

> Analyse > Mesure photométrique

Lancement : Menu [Analyse] > [Photométrie] > [Mesure photométrique Moffat]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de mesurer la magnitude d'une étoile se trouvant sur une image sur laquelle un étalonnage photométrique a été préalablement effectué avec la fonction [Analyse] > [Photométrie] > [Etalonnage] ou la fonction [Analyse] > [Photométrie] > [Etalonnage automatique]

Au lancement de cette fonction, un curseur apparaît, permettant de sélectionner l'étoile pour laquelle une mesure photométrique doit être effectuée :

La sélection s'effectue en cliquant avec le bouton de gauche de la souris. La fenêtre suivante s'affiche, indiquant diverses informations concernant l'étoile sélectionnée, dont la magnitude :

Images supportant cette fonction :
images monochromes codées en 16 ou 32 bits

Fonction(s) Script associée(s):
GetPhotometrie

Image de test :
Image astrométrie - photométrie

Prérequis :
Le centroïde de moffat

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Mesure photométrique

> Analyse > Mesure photométrique

Lancement : Menu [Analyse] > [Photométrie] > [Mesure photométrique du fond de ciel]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de mesurer la magnitude (par seconde d'arc au carré) du fond de ciel d'une image sur laquelle un étalonnage photométrique a été préalablement effectué avec la fonction [Analyse] > [Photométrie] > [Etalonnage] ou la fonction [Analyse] > [Photométrie] > [Etalonnage automatique]

Au lancement de cette fonction, une fenêtre s'ouvre indiquant la valeur estimée pour la magnitude du fond de ciel :

Images supportant cette fonction :
images monochromes codées en 16 ou 32 bits

Fonction(s) Script associée(s):
Aucune

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Mesure photométrique

> Analyse > Mesure photométrique

Lancement : Menu [Analyse] > [Photométrie] > [Mesurer/Extraire toutes les étoiles]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de mesurer la magnitude de toutes les étoiles (et objets ponctuels) d'une image sur laquelle un étalonnage photométrique a été réalisée avec la fonction [Analyse] > [Photométrie] > [Etalonnage] ou la fonction [Analyse] > [Photométrie] > [Etalonnage automatique]

Au lancement de la fonction, le logiciel repère automatiquement toutes les étoiles de l'image et calcule leurs magnitudes. Le calcul peut être relativement (quelques minutes) s'il y a de nombreuses étoiles sur l'image. Lorsque le calcul est terminée deux fenêtres s'ouvrent, indiquant les magnitudes des étoiles graphiquement (sur l'image elle-même) et sous forme textuelle :

Les informations sous forme textuelles sont présentées à raison d'une ligne par étoile, chaque ligne comportant les champs suivants :

  • Numéro de l'étoile
  • Position X et Y de l'étoile sur l'image (en pixels)
  • Sigma X et Sigma Y
  • Angle d'inclinaison de l'étoile
  • Magnitude de l'étoile
  • Flux de l'étoile
  • OMC : "observé moins calculé"; plus ce paramètre est nul, meilleur est la correspondance entre la réalite et le modèle de calcul
  • Le rapport Signal sur Bruit

Ces données peuvent être sauvegardées dans un fichier, pour cela il suffit de cliquer sur l'icone de disquette (en bas à gauche de la fenêtre). De plus, des graphiques sont fournis pour réaliser certaines statistiques numériques (les indications sur les graphes parlent d'eux mêmes) :

Les FWHM mesurées Le nombre d'étoiles à une magnitude donnée

Le logarithme du rapport signal sur bruit

Images supportant cette fonction :
images monochromes codées en 16 ou 32 bits

Fonction(s) Script associée(s):
GetPhotometrie

Image de test :
Image astrométrie - photométrie

Prérequis :
Le centroïde gaussien
Les graphes sous PRiSM

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Taille de la fenêtre

> Analyse > Photométrie > Taille de la fenêtre de mesure

Lancement : Menu [Analyse] > [Photométrie] > [Taille de la fenêtre de mesure (Gauss2D/Moffat)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de régler la taille de la fenêtre d'analyse pour la réalisation des centroïdes de type Gauss2D ou Moffat.

Une fenêtre apparaît au lancement :

Le réglage de la taille de la fenêtre

Il suffit alors d'imposer la taille désirée pour la fenêtre.

Accès :
Images monochromes FITS/CPA ouverte et étalonnée photométriquement

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Mesure photométrique

> Analyse > Mesure photométrique

Lancement : Menu [Analyse] > [Photométrie] > [Photométrie d'ouverture]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de mesure la magnitude d'un objet étendu, à partir d'une mesure du flux de lumière reçu de cet objet et du flux du fond du ciel.

L'image à étudier doit être préalablement chargée et sélectionnée.

La photométrie d'ouverture rectangulaire :

Au lancement de la fonction, la fenêtre suivante s'ouvre :

La première étape consiste à effectuer un étalonnage photométrique, grace à la zone "Etalonnage" de la fenêtre :

  • Le champs "Nombre d'étoile étalons" permet d'indiquer combien d'étoiles vont être utilisées pour effectuer l'étalonnage.
  • Le champ étoile courante permet d'indiquer le numéro de l'étoile étalon sur laquelle on va travailler.
  • Le bouton "Etoile" permet de désigner l'étoile étalon : après avoir cliqué sur le bouton [Etoile], un curseur apparaît sur l'image, il faut alors tracer une zone rectangulaire autour de l'étoile étalon. Dès que cela est fait, le flux total reçu à l'intérieur de cette zone et le nombre de pixels situés dans la zone sont affichés à droite du bouton [Etoile]
  • Le bouton "Fond" permet de désigner le fond du ciel : après avoir cliqué sur le bouton [Fond], un curseur apparaît sur l'image, il faut alors tracer une zone rectangulaire représentative du fond du ciel. Dès que cela est fait, le flux total recu a l'intérieur de cette zone et le nombre de pixels situés dans la zone sont affichés à droite du bouton [Fond]
  • Le champ "Magnitude" permet d'entrer la valeur de la magnitude de l'étoile étalon, qui est supposée connue. Cette valeur est à fournir avant de compléter le contenu des informations sur "Etoile" et "Fond" pour chaque objet.

Lorsque les mesures de flux et de fond du ciel on été effectuées pour toutes les étoiles étalon, il devient possible de mesurer la magnitude d'un objet de l'image, grace à la zone "Mesures" de la fenêtre :

  • Après avoir cliqué sur le bouton "Etoile", un curseur apparaît sur l'image, il faut alors tracer une zone rectangulaire autour de l'étoile ou de l'objet dont on veut mesurer la magnitude. Dès que cela est fait, le flux total recu a l'intérieur de cette zone et le nombre de pixels situés dans la zone sont affichés à droite du bouton [Etoile].
  • Il faut ensuite cliquer sur le bouton "Fond" : un curseur apparaît sur l'image, il faut alors tracer une zone rectangulaire représentative du fond du ciel. Dès que cela est fait, le flux total recu a l'intérieur de cette zone et le nombre de pixels situés dans la zone sont affichés à droite du bouton [Fond].
  • En cliquant sur le bouton "Magnitude", le logiciel calcule la magnitude de l'objet sélectionné.
  • La valeur "Sigma" affichée en bas de l'écran est l'ecart type de la derniere zone de selection dans l'image. Pour une sélection sur le fond de ciel, Sigma doit rester faible. Par contre, lors de la sélection sur l'étoile, sigma peut prendre n'importe quelle valeur.

La photométrie d'ouverture circulaire :

Au lancement de la fonction, la fenêtre suivante s'ouvre :

Les rayons des cercles sont à régler au bas de la fenêtre. Le cercle intérieur doit contenir entièrement les étoiles alors que l'aire entre les 2 cercles doit contenir uniquement du fond de ciel. La première étape consiste à effectuer un étalonnage photométrique, grace à la zone "Etalonnage" de la fenêtre :

  • Le champs "Nombre d'étoile étalons" permet d'indiquer combien d'étoiles vont être utilisées pour effectuer l'étalonnage.
  • Le champ étoile courante permet d'indiquer le numéro de l'étoile étalon sur laquelle on va travailler.
  • Le bouton "Etoile" permet de désigner l'étoile étalon : après avoir cliqué sur le bouton [Etoile], un curseur apparaît sur l'image, il faut alors cibler l'étoile étalon. Il est rappelé que cette dernière doit faire intégrante du premier cercle. Dès que cela est fait, le flux total reçu à l'intérieur de cette zone est affiché à droite du bouton [Etoile]
  • Le champ "Magnitude" permet d'entrer la valeur de la magnitude de l'étoile étalon, qui est supposée connue. Cette valeur est à fournir avant de compléter le contenu des informations sur "Etoile" et "Fond" pour chaque objet.

Lorsque les mesures de flux ont été effectuées pour toutes les étoiles étalon, il devient possible de mesurer la magnitude d'un objet de l'image, grace à la zone "Mesures" de la fenêtre :

  • Après avoir cliqué sur le bouton "Etoile", un curseur apparaît sur l'image, il faut alors cibler l'étoile ou l'objet dont on veut mesurer la magnitude. Les rayons des cercles peuvent être modifiés entre l'étalonnage et la mesure. Il est rappelé que l'étoile ou l'objet doit faire intégrante du premier cercle. Dès que cela est fait, le flux total recu à l'intérieur de cette zone et le nombre de pixels situés dans la zone sont affichés à droite du bouton [Etoile].
  • En cliquant sur le bouton "Magnitude", le logiciel calcule la magnitude de l'objet sélectionné ainsi qu'une estimation de l'erreur sur la magnitude.

Animations FLASH :
Photométrie d'ouverture annulaire (3,0 Mo)
Photométrie d'ouverture rectangulaire (7,7 Mo)

Images supportant cette fonction :
images monochromes codées en 16 ou 32 bits

Fonction(s) Script associée(s):
APC

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Calcul de diagramme HR

> Analyse > Calcul de diagramme HR

Lancement : Menu [Analyse] > [Photométrie] > [Calcul de diagramme HR]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de tracer le diagramme HR d'un amas d'étoiles.

Il est nécessaire d'avoir une image de l'amas étudié dans le Rouge et dans le Bleu. Le diagramme qui sera établi sera relatif et non absolu. Il est important que les temps de pose des 2 images soient déterminés de façon à tenir compte de la différence de détectivité des filtres utilisés. Par ailleurs, les images doivent être soigneusement prétraitées et les étoiles présentes sur les images ne doivent pas être saturées.

Les 2 images (bleu et rouge) doivent être chargées. Au lancement de la fonction, une fenêtre s'ouvre permettant de sélectionner les 2 images (bleu et rouge) à partir desquelles le diagramme doit être calculé :

Ensuite, PRiSM va identifier les étoiles présentes sur les 2 images, tout en affichant l'avancement sur les calculs en cours dans la fenêtre de suivi :

Lorsque toutes les étoiles présentes sur l'image ont été identifiées, le logiciel affiche des carrés rouges autour de chacune d'elle:

Après quelques instants de calcul, le logiciel affiche enfin le diagramme HR sous la forme suivante :

  • En abscisse est porté l'indice de couleur de chaque étoile c'est à dire la différence entre les valeurs de magnitude bleu et rouge mB-mR. Cet indice caractérise la température des zones superficielles des étoiles.

  • En ordonnée est portée la magnitude bleu de chaque étoile. La luminosité d'une étoile étant liée à sa masse, les étoiles situées en haut du diagramme sont plus massives que celle situées en bas.

En analysant le diagramme HR obtenu, on distingue très nettement deux populations d'étoiles de caractéristiques différentes correspondant sur le graphe à deux nuages de points distincts. Le nuage le plus important occupant une diagonale du graphe est constitué par des étoiles de la séquence principale où les étoiles passent la majorité de leur vie. Le deuxième nuage , beaucoup moins dense, indique la présence d'étoile plus massives, ayant brûlé leur hydrogène beaucoup plus rapidement. La combustion de l'hélium ayant commencé, les couches extérieures se sont dilatées et leur température à diminué. Par conséquent, elles se sont décalées vers la droite du diagramme. Se sont des géantes rouges et elles sont situées en haut et à droite de la séquence principale. Pour plus de renseignements sur l'interprétation d'un diagramme HR, l'utilisateur est invité à consulter la littérature abondante disponible en librairie.

  • Le bouton [image] permet de lancer l'impression du diagramme
  • Le bouton [image] permet de sauvegarder le diagramme HR dans un fichier texte pour une utilisation ultérieure, par exemple dans Excel.
  • Le bouton [image] permet de copier le diagramme dans le presse-papier au format bitmap, en vue d'une récupération ultérieure dans un logiciel de dessin.
  • Le bouton [image] permet d'ouvrir la fenêtre des options d'affichage :

    Dans cette fenêtre :

    • le champ "Titre" permet de redéfinir le titre du graphe
    • le champ "Axe X" permet de redéfinir le titre de l'axe des abscisses
    • le champ "Axe Y" permet de redéfinir le titre de l'axe des ordonnées.
    • Le champ "Points" permet de modifier l'aspect des points représentant les étoiles
    • Le champ "Longueur" et le champ "Hauteur" permettent de modifier la longueur et la hauteur des points
    • Le bouton droit de la souris permet d'afficher le menu contextuel qui permet de faire un zoom arrière sur le diagramme.

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA filtrées

Image de test :
Images de NGC752 du DSS

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Mesure photométrique

> Analyse > Mesure photométrique

Lancement : Menu [Analyse] > [Photométrie] > [Mesure photométrique Gauss]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de mesurer la magnitude d'une étoile se trouvant sur une image sur laquelle un étalonnage photométrique a été préalablement effectué avec la fonction [Analyse] > [Photométrie] > [Etalonnage] ou la fonction [Analyse] > [Photométrie] > [Etalonnage automatique]

Au lancement de cette fonction, un curseur apparaît, permettant de sélectionner l'étoile pour laquelle une mesure photométrique doit être effectuée. Il suffit alors de cliquer sur l'étoile, et la fenêtre suivante s'ouvre :

Une série de paramètres classiques est indiquée.
A la fin, la magnitude de l'objet est indiquée avec une erreur estimative.

Images supportant cette fonction :
images monochromes codées en 16 ou 32 bits

Fonction(s) Script associée(s):
GetPhotometrie

Image de test :
Image astrométrie - photométrie

Prérequis :
Le centroïde gaussien

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Etalonnage manuelle astrométrique d'une image

> Analyse > Etalonnage manuelle astrométrique d'une image

Lancement : Menu [Analyse] > [Astrométrie] > [Etalonnage]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Etalonner astrométriquement une image manuellement.

Cette fonction permet de réaliser un étalonnage astrométrique d'une image. Elle permettra alors d'établir un lien entre les coordonnées intrinsèques de l'image ( c'est-à-dire les coordonnées sphériques telles l'ascension droite et la déclinaison ) et les coordonnées rectangulaires de l'image ( décrit par les variables X et Y ). On l'utilisera chaque fois que la fonction d'étalonnage automatique ne fonctionnera pas (par exemple s'il n'y a pas assez d'étoiles, ou si l'on est dans une zone peu pourvue en étoiles de référence).

On utilisera donc une technique manuelle afin d'établir les coefficients de deux polynômes de transformation entre ces deux systèmes de coordonnées. Les étoiles pour la reconnaissance du champ sont imposées. On aura alors directement un système de deux équations ( une équation pour chacun des axes ). On obtiendra un polynôme pour chacun des deux axes X et Y. Pour des polynômes de degré 1 il faut au moins 3 étoiles reconnues mais ceci est clairement insuffisant pour contrer les "distorsions" de l'image et il est conseillé de choisir au moins 6 étoiles. S'il n'y a pas assez d'étoiles fournies, le message renvoyé est : " Prenez des étoiles étalons sur la carte du ciel ". Ici, le peu d'étoiles reconnues doivent être imposées au programme ...

L'étalonnage se déroule en 2 étapes :

1ère étape : choix des étoiles étalon sur la carte du ciel

La première étape consiste à repérer sur la carte du ciel (et dans la zone correspondant à l'image à étalonner ...) les étoiles étalon. On aura au préalable sélectionné l'affichage des étoiles d'un catalogue d'étoiles (par exemple le GSC) et choisi un affichage des étoiles jusqu'à une magnitude élevée (par exemple la magnitude 16 pour le GSC si on est à un niveau de zoom de l'ordre de 128).

Il faut ensuite sélectionner la prémière étoile étalon à l'aide de l'outil d'identification des objets (icone [image]). La fenêtre d'identification s'ouvre :

Il faut alors cliquer sur le bouton "Ajouter cette étoile à la base de réduction".

On répètera cette procédure de sélection pour chaque étoile étalon. Au fur et à mesure de leur désignations, les étoiles étalons sont identifiées sur la carte du ciel par un numéro d'ordre :

2ème étape : Repérage des étoiles étalon sur l'image

Lorsque toutes les étoiles étalon ont été sélectionnées, on peut alors lancer la fonction d'étalonnage elle-même en cliquant sur le menu [Analyse] > [Astrométrie] > [Etalonnage]. La fenêtre suivante s'ouvre alors, récapitulant la provenance des étoiles étalons :

Dans la barre de statut de la fenêtre, l'indication "Choisir l'étoile numéro 1" apparaît :

Un curseur apparaît permet de sélectionner l'étoile 1 sur l'image :

Après avoir cliqué sur une étoile étalon sur l'image, la fenêtre suivante s'ouvre, affichant les informations concernant l'étoile sélectionnée :

Lorsque toutes les étoiles ont été sélectionnées, la fenêtre suivante s'ouvre :

Si le nombre d'étoiles étalons est suffisant, il est possible de choisir le degrè du polynome utilisé pour l'étalonnage. On peut alors cliquer sur le bouton [Calcul]. La fenêtre suivante s'ouvre alors :

En cliquant sur [OK], l'opération d'étalonnage est terminée. Il est alors possible d'utiliser la fonction [Analyse] > [Photométrie] > [Mesure] pour obtenir la position d'une étoile de l'image.

De plus, les coordonnées Alpha/Delta du point de l'image sur laquelle se trouve le curseur sont affichées dans la barre de statut de la fenêtre de l'image :

Il est également affiché une carte de distorsion éventuellement accentuée à volonté, au même titre que pour l'étalonnage automatique.

Images supportant cette fonction :
images monochromes

Fonction(s) Script associée(s):
Aucune

Exemple d'image :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Etalonnage astrométrique automatique

> Analyse > Etalonnage astrométrique automatique

Lancement : Menu [Analyse] > [Astrométrie] > [Etalonnage automatique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Etalonner astrométriquement une image de façon automatique.

Cette fonction permet d'effectuer un étalonnage astrométrique d'une image. Contrairement à la fonction [Analyse] > [Astrométrie] > [Etalonnage], il n'est pas besoin de sélectionner des étoiles étalons, le logiciel le fait automatiquement.

1ère étape CONSEILLEE : compléter correctement l'entête de l'image à étalonner

Il n'est pas obligatoire de compléter l'entête de l'image pour réaliser un étalonnage automatique. Cependant, ceci est fortement conseillé, afin d'éviter de devoir rentrer les paramètres manuellement et de plus, à chaque fois ! Le mieux est que l'entête de l'image à étalonner contienne :

  • la position Alpha/Delta approximative du centre de l'image. Si ce n'est pas le cas, le moyen le plus simple consiste à le faire à partir du menu contextuel de la carte du ciel ou de les fournir directement depuis les informations de l'image.
  • La focale de l'instrument à fournir directement depuis les informations de l'image.
  • La taille des pixels du capteur à fournir directement depuis les informations de l'image.
2ème étape : le choix du catalogue d'étalonnage

On peut maintenant utiliser simplement la fonction [Analyse] > [Astrométrie] > [Etalonnage automatique]. La fenêtre suivante s'ouvre alors :

  • Les champs "Alpha" et "Delta" contiennent la position approximative du centre de l'image. Si cette position n'a pas été préalablement renseignée dans l'entête de l'image (voir 1ère étape), il reste possible de la saisir à cet instant.

  • Il en est de même pour les données comme la focale du télescope et la taille des pixels en X et en Y qui, si elles ont été renseignées lors de la prise de vue, sont automatiquement présentes dans les champs correspondants de cette fenêtre.

  • Le catalogue de référence est le catalogue qui sera utilisé pour l'étalonnage.

    PRiSM nous laisse le choix entre plusieurs catalogues : GSC, USNO SA2, USNO A1 (obsolète maintenant !), USNO A2, Hipparcos, SAO, BSC, Tycho1, GSC-ACT, Tycho2, UCAC 1 et 2. Seuls les catalogues GSC, SAO, BSC, Tycho 1 et 2 sont compilés sous PRiSM et il n'est donc pas nécessaire d'indiquer le chemin d'accès. Par contre, pour les autres catalogues, le chemin d'accès fourni dans les options est indiqué en dessous et peut encore être changé. Chaque catalogue a ses propres défauts :

    • Le GSC indique toutes les étoiles jusqu'à la magnitude 16 et est compilé directmement sous PRiSM. A cause de son âge, on ne peut pas faire de l'astrométrie précise ( c'est-à-dire à moins de 1" d'arc d'erreur). On lui préfèrera le GSC-ACT téléchargeable sur internet et plus précis.
    • Le catalogue USNO-SA contient des étoiles régulièrement espacées sur la sphère céleste jusqu'à la magnitude 20, mais il ne les contient pas toutes. Il peut donc apparaître sur l'image des étoiles qui ne sont pas dans le catalogue. Le choix de ce catologue pourra donc, mais très rarement, ne pas fonctionner. Plus précis que l catalogue GSC, on lui préfèrera le catalogue USNO A2 : plus d'étoiles pour un champ donné donc un plus grand choix pour la comparaison afin de limiter les erreurs.
    • Les autres catalogues sont décrits dans la section sur les catalogues. On remarque que, d'un point de vu astrométrique, les catalogues à privilégier sont Hipparcos et Tycho 1 et 2. Cependant, le nombre d'étoiles de référence parfois insuffisant mène à continuer à privilégier l'utilisation de catalogue comme USNO A2.

  • Voir état du calcul : Permet de régler la densité d'information sur la calibration qui apparaissent dans la fenêtre de renseignements lors de la calibration. Le niveau est de 1 à 4 et se règle grâce au bouton correspondant.

  • Orientation Nord / Sud : Permet de faciliter la reconnaissance de l'image. Cette option doit être cochée lorsque l'axe des abscisses de l'image est orienté Nord - Sud (Orientation de la caméra vers 90° ou 270°).

  • Mise à jour paramètres par défaut de l'entête de la caméra : Change les informations suivantes dans l'entête du capteur principal : focale, angle du CCD et orientation du repère.
    Voir la page sur la définition de l'orientation du CCD.
3ème étape : compléter les autres paramètres
  • Le nombre d'étoiles maximum les plus brillantes du catalogue de référence avec lesquels PRiSM formera des triangles. Ces derniers seront comparés avec les triangles obtenus à l'aide du nombre maximum d'étoiles les plus brillantes de l'image. La méthode utilisée est la méthode des triangles.

  • Redéfinir les niveaux de messages : Cette option permet de choisir d'avoir toutes les informations essentielles lors de l'étalonnage (niveau 4) ou alors, le minimum (niveau 1). Le niveau choisi est indiqué au dessus du bouton correspondant. Un exemple de niveau 4 d'information est fourni.

  • Réglage de la reconnaissance auto : permet d'afficher le menu option de reconnaissance automatique sans avoir à fermer la fenêtre d'étalonnage automatique.

  • Si l'image est orientée Nord en haut, alors on cochera la case "Image orientée Nord/Sud". Ceci permet de réduire le temps de calcul. Cependant, ce paramètre est pondéré par celui de l'option de reconnaissance auto : Marge d'erreur sur la rotation

  • Si on souhaite voir l'avancement des calculs, alors on cochera la case "Voir état du calcul" et les informations seront fournies en fonction du niveau des messages définis.
4ème étape : le choix du polynôme de passage

L'étalonnage se lancera alors en cliquant sur le bouton [OK], et à l'issue des calculs et en plus de l'éventuelle fenêtre d'information, la fenêtre suivante apparaîtra :

Polynôme de passage à régler

Si le nombre d'étoiles identifiées sur l'image est suffisant, on pourra choisir le degré du polynome de passage utilisé pour l'étalonnage. La fonction cherche alors une relation mathématique entre les coordonnées mesurées ( X , Y ) sur l'image et les coordonnées attendues ( alpha , delta ) sur cette même image; A l'heure actuelle, dans PRiSM, cette relation est un polynôme dont il faut déterminer les coefficients (appelés constantes de plaque).
Pour un polynôme de degré 1, les relations sont les suivantes :

relations de passage pour un polynôme de degré 1

Alors que pour un polynôme de degré 2, les relations sont les suivantes :

les coefficients de passage pour un polynôme de degré 2

Pour ce dernier, on doit donc trouver 12 coefficients ... En se basant sur 6 étoiles, on pourra donc les avoir (pour chaque étoile, on a alpha et delta à la fois, ou X et Y à la fois ). Pour un polynôme de degré 2, il faudra donc un minimum de 6 étoiles.
Pour un polynôme de degré 3, il faudra alors rajouter des termes en X3, Y3, X2.Y, X.Y2 et il faudra donc considérer 12 + 4 x 2 = 20 coefficients ( 4 coefficients de plus par équation ). D'où, il faudra au minimum 10 étoiles de référence.
Pour un polynôme de degré 4, il faudra, en plus du précédent, rajouter les termes en X4, Y4, X.Y3, Y.X3, X2.Y2 soit considérer 20 + 5 x 2 = 30 coefficients soit un minimum de 15 étoiles.
De même, pour un polynôme de degré 6, il faudra calculer 56 coefficients soit avoir 28 étoiles de référence ...
Plus on aura d'étoiles de comparaison, plus le degré du polynôme pourra être élevé.

Choix du degré du polynôme

L'utilisateur arrive sur une fenêtre lui donnant plusieurs renseignements. Notamment, le nombre d'étoiles communes trouvées entre l'image de synthèse et l'image réelle est ici de 50. Le degré du polynôme pourra donc être au maximum de 8. Il suffit alors d'appuyer sur le bouton " Calcul " pour que les coefficients du polynôme soient calculés.

Avec un polynôme de degré 2

Le nombre d'étoiles utilisées (forcément inférieur à celui des étoiles trouvées) est alors indiqué. Cependant, on notera que si on demande un polynôme de degré quelconque, le nombre d'étoiles utilisées sera toujours le même. Ceci permet permet d'ajuster au mieux les coefficients du polynôme en fonction de TOUTES les étoiles qui ont pu être reconnues. (ces derniers sont fournis lors du calcul)
Il est indiqué dans la fenêtre des calculs :

  • Le degré du polynôme choisi. Ce dernier peut être changé et les calculs doivent être réitérés en appuyant sur le bouton "Calcul".

  • Les résidus en Alpha et Delta en seconde d'arc sur l'ensemble des étoiles en ascension droite et en déclinaison. C'est l'écart quadratique moyen, par rapport au modèle, de tous les résidus suivant chacun des axes ( alpha et delta ) trouvés pour chaque étoile. Les étoiles avec une croix devant n'ont pas été prise en compte pour l'établissement du modèle. La valeur de résidu maximal se règle à partir des Options de reconnaissances de champ.
    Comme les étoiles de référence servent à la fois au calcul du modèle et à celui de l'erreur sur ce modèle, la valeur va nettement diminuer pour des degrés élevés du polynôme choisi. Ce n'est pas nécessairement pour celà que le degré choisi sera le meilleur (ces renseignements ont été introduit pour que l'utilisateur s'inquiète s'il trouve de grandes valeurs même pour un faible degré du polynôme).

  • Le nombre total d'étoiles utilisées pour trouver les coefficients.

  • La focale du télescope résultante trouvée après l'étalonnage astrométrique. Ces résultats ne veulent rien dire si l'image est distordue. Encore une fois, il vaut mieux dans ce cas utiliser un degré de polynôme faible pour la calculer (ne prendra en compte que les distortions de l'image au premier ordre ... donc indiquera une focale comme si l'image n'était pas distordue).

  • L'angle de rotation de la caméra trouvée après l'étalonnage astrométrique. Ces données peuvent désormais remplacer les anciennes. Il est cependant conseillé de faire plusieurs étalonnages du même type pour confirmer ces deux dernières valeurs.

  • On trouve enfin des indications sur les étoiles qui ont servi à faire l'étalonnage. Un numéro fictif qui a permis au programme de les repérer, leur position sur l'image et enfin le résidu entre le centroïde réel de l'étoile et celui obtenu avec le polynôme.

    Avec un polynôme de degré 4

    Les résidus de chacune des étoiles peuvent prendre des valeurs abbérantes pour certains d'entre eux. Cependant, ils doivent être le moins nombreux possible à prendre de telles valeurs. Il est possible (en plus du réglage de l'option correspondante) de ne pas tenir compte de ces étoiles qui donne des résultats abbérants dans les calculs en cliquant sur le numéro de l'étoile. Une croix se positionne alors devant le numéro et la fonction ne tiendra pas compte de l'étoile. Cette possibilité est à utiliser avec précaution car on a vite fait d'en supprimer de trop ! Le nombre d'étoiles utilisées s'en trouve modifié et le degré maximum du polynôme ajustable aussi car il y a moins d'étoiles étalons.

  • Il est indiqué (pour information) la valeur des coefficients de passage du polynôme.

    les coefficients du polynôme

    A partir du degré 2, les coefficients devant les termes d'ordre 2 ou plus doivent être très faibles (de l'ordre de 10-4 ou 10-5 pour l'ordre 2 et de plus en plus faible pour les autres).

  • Une carte de distorsion est présentée à chaque calcul. Pour vraiment voir apparaître les distorsions de l'image par rapport à ce que devrait ête une image "parfaite", il faut l'amplifier, ce que propose le "facteur d'échelle". A l'échelle X1 (case de rotation et changement d'échelle non cochée), on voit apparaître des points bleus symbolisant l'image avec en fond les étoiles du catalogue retenues. La distorsion apparaît avec un facteur d'échelle plus important (case de rotation et changement d'échelle cochée), et pour les polynômes de fort degré, on remarque que l'étalonnage de l'image n'a plus beaucoup de sens (même si les résidus sont faibles) et c'est pour cela qu'il est conseillé de choisir un degré de polynôme le plus petit possible !

    On ne fait pas apparaître la rotation et le changmeent d'échelle (degré 7)
    On fait apparaître la distorsion optique (degré 7) et on l'amplifie !

Un fichier de renseignement sauvegardable au format texte (voir un exemple avec le maximum d'information ) est renvoyé uniquement si on a demandé à voir l'" état des calculs" et suivant le niveau des messages d'information.

On obtient alors l'image suivante où les étoiles de calibrations retenues sont entourées et repérées en vert, alors que les étoiles rejetées le sont en rouge :

Sont affichés le numéro de l'étoile en interne et le résidu correspondant.

Si on remarque que les étoiles de calibration sont toutes quasiment dans un même coin de l'image alors, on a toutes les chances d'avoir une optique un peu distordue. On serait alors tenté d'utiliser le polynôme de degré maximum mais alors les coefficients seraient calculés sur une zone distordue de l'image et non sur toute l'image un peu distordue. De façon générale, on choisira le polynôme qui permet de tenir compte d'une petite distorsion de l'image, celle-ci n'étant quand même pas exagérée : le polynôme de degré 2 convient le mieux ( le polynôme de degré 1 est à peine suffisant quoique possible ). Si l'utilisateur choisit un degré de 3 ou supérieur, la fonction sera mieux ajustée en fonction des distorsions d'optique mais les résultats peuvent être trompeur puisque dans ce cas, la moindre variation sera prise en compte (même lors du centroide de l'étoile).
L'expérience prouve que le polynôme de degré 2 est suffisant et permet de se rapprocher le plus possible des 0,1" d'arc de résidu. Il n'est donc pas nécessaire de vouloir à tout pris atteindre le degré maximum pour les raisons précitées. De plus, comme l'ajustement se fait de façon statistique, il faudrait pour bien faire considérer 3 à 4 fois plus d'étoiles que le nombre minimum imposé par le calcul des coefficients. Ceci fonctionne toujours très bien avec un polynôme de degré 2 mais sûrement moins bien avec un polynôme de degré 4 ou 5 ...

Une fois l'étalonnage effectué, des informations astrométriques apparaissent au bas de l'image :

Fonction(s) Script associée(s):
EtalonAstrometrieAuto

Prérequis :
La méthode des triangles
Options de reconnaissance

Condition d'activation :
Image monochrome au format CPA ou FITS.

Image de test :
Image astrométrie - photométrie.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Mars 2006


Analyse / Etalonnage astrométrique automatique en série

> Analyse > Etalonnage astrométrique automatique en série

Lancement : Menu [Analyse] > [Astrométrie] > [Série d'images]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Etalonner astrométriquement une série d'images de façon automatique.

Cette fonction permet d'effectuer un étalonnage astrométrique d'une série d'image.

Avant lancement de la fonction, il faut :

  • Préciser les paramètres astrométriques choisis, notamment le catalogue choisi et le nombre d'étoiles d'étalonnage; voir la fonction [Télescope] > [Paramètres de centrage auto du télescope].
  • Choisir le degré du polynôme d'étalonnage.
  • Sélectionner les fichiers à étalonner

Les images sont automatiquement enregistrées au format standard par défaut.

Fonction(s) Script associée(s):
EtalonAstrometrieAuto

Prérequis :
La méthode des triangles
Options de reconnaissance

Condition d'activation :
Image monochrome au format CPA ou FITS.

Image de test :
Image astrométrie - photométrie.

Conditions d'activation du menu :
Aucune.

Version Mars 2006


Analyse / Paramètres astrométriques depuis une image bin2x2

> Analyse > Paramètres astrométriques depuis une image bin2x2

Lancement : Menu [Analyse] > [Astrométrie] > [Paramètres depuis une image réduite x2]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de récupérer les paramètres astrométriques de la même image, mais réduite d'un facteur 2 (binning 2x2). Il arrive sur certaines images que les étoiles soient "trop grosses" de part la turbulence importante qui a tendance à empâter les étoiles ou à cause d'une optique ou un suivi médiocre. Une astrométrie sur une telle image échoue irrémédiablement ! "L'artifice" consiste à réaliser le binning 2x2 (attention, seul le binning par somme n'entraînera aucune perte photométrique), réaliser une astrométrie sur une telle image où les étoiles ont une FWHM 2 fois inférieure à l'image originale et se servir de ces coefficients pour les transmettre à l'image originale.

Il faut cependant être averti que l'astrométrie sera en conséquence légèrement moins précise dans ce cas et cette fonction est réellement à réserver pour les images dont l'astrométrie a échouée.

L'image originale étant sélectionnée, la fenêtre suivante s'ouvre dès le lancement de la fonction où il s'agit de sélectionner l'image réduite d'un facteur 2 (seules de telles images pourront être sélectionnées ...) :

A l'aide des flèches situées en bas à droite de la fenêtre, il faut sélectionner l'image réduite, puis cliquer sur le bouton [OK].

L'entête astrométrique de l'image originale est alors complétée avec le lancement de l'opération (et en fonction de l'image réduite ... si cette dernière n'est pas étalonnée astrométriquement, l'entête astrométrique de l'image originale ne sera pas complétée).

Voici quelques résultats :

Pour l'image originale calibrée directement astrométriquement : 00h32m11.804s +18°39'04.62"

La même étoile pour l'image réduite : 00h32m11.802s +18°39'04.77"

Et pour l'image originale calibrée à partir de l'image réduite : 00h32m11.839s +18°39'04.88" : ceci montre que la calibration astrométrique à partir d'une image bin 2x2 est moins correcte que directement permet quand même de "dépanner" si on ne cherche pas une astrométrie précise.

Images supportant cette fonction :
images monochromes 16 ou 32 bits

Paramètres d'entête d'image :
L'astrométrie de l'image justement conservée (la fonction est là pour ça !).
La photométrie n'est pas conservée.
Les autres paramètres ne changent pas.

Fonction(s) Script associée(s):
Astrom_From_Bin2

Voir aussi :
[Transformations] > [Conversion de type de pixels] > [Image pixels entiers vers réels]

Conditions d'activation du menu :
Il faut que l'image originale soiut ouverte ainsi que l'image réduite d'un facteur 2.

Novembre 2010


Analyse / Mesure astrométrique

> Analyse > Mesure astrométrique

Lancement : Menu [Analyse] > [Astrométrie] > [Mesure]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Mesure de la position d'un astre sur une image.

Cette fonction permet de mesurer la position d'une étoile sur une image préalablement étalonnée grace à la fonction [Analyse] > [Astrométrie] > [Etalonnage] ou à la fonction [Analyse] > [Astrométrie] > [Etalonnage Automatique]

Avant de lancer la fonction elle-même, il faut sélectionner le type de centroïde à utiliser (Gaussien ou Barycentrique). Pour cela, on utilisera la fonction [Analyse] > [Astrométrie] > [Type de Centroïde]

Au lancement de la fonction, un curseur apparait sur l'image, afin de sélectionner l'étoile dont on souhaite connaître la position.

1er cas : le type de centroïde est gaussien. La sélection s'effectue alors en cliquant sur l'étoile dont on souhaite connaitre la position, et les fenêtres suivantes s'ouvrent, donnant diverses informations sur l'étoile (dont la position alpha/delta) :

2ème cas : le type de centroïde est barycentrique. Dans ce cas, la sélection de l'étoile se fait en tracant un rectangle contenant l'étoile. Le logiciel calculera alors le barycentre des pixels situés dans ce rectangle. Lorsque la sélection est faire, la fenêtre suivante s'ouvre, donnant la position alpha/delta de l'étoile :

Dans les 2 cas, une fenêtre de rapport MPC s'ouvre que l'utilisateur est libre de remplir ou non.

Rapport MPC :

Il est proposé ensuite de créer automatiquement un fichier de données dont il faudra alors faire un "copier-coller" et l'envoyer par mail au MPC. Le fichier est alors formaté à la bonne dimension. Pour plus d'information, se référer à la partie "Submitting observer setup information" de cette page.
La fenêtre de gestion est la suivante :

La création du rapport MPC

Les élements à définir sont les suivants :

  • Le chemin de sortie du fichier de données

  • Le type d'objet dont il est fait référence : astéroïde, comète ou satellite d'une planète.

  • La description de l'astéroïde si l'objet en est un : le numéro ou la dénomination provisoire, un objet fraichement découvert et si il est nécessaire d'en fournir la magnitude.

  • L'entête du fichier : A rectifier dans la fenêtre prévue à cet effet ou l'importer depuis un fichier de données externe.

  • Le code de l'observatoire.

  • La bande spectrale de l'observation ... par défaut, sans filtre, choisir la bande V.

Images supportant cette fonction :
images monochromes FITS/CPA

Fonction(s) Script associée(s):
GetAstrometrie

Image de test :
Image astrométrie - photométrie

Prérequis :
[Analyse] > [Astrométrie] > [Type de Centroïde]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Mesures globales astrométriques

> Analyse > Mesures globales astrométriques

Lancement : Menu [Analyse] > [Astrométrie] > [Mesures sur toutes les étoiles [Rayon=..p] ]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Mesures des positions des astres ponctuels d'une image.

Cette fonction permet de mesurer la position d'une étoile sur une image préalablement étalonnée grace à la fonction [Analyse] > [Astrométrie] > [Etalonnage] ou à la fonction [Analyse] > [Astrométrie] > [Etalonnage Automatique]
Le type de centroïde utilisé est forcément gaussien.

Au lancement de la fonction, le logiciel repère toutes les étoiles situées sur l'image et affiche un rectangle rouge autour de chacune d'elles.

Après quelques temps de calcul, le logiciel affiche la position alpha/delta de toutes les étoiles dans la fenêtre de suivi :

Les positions ainsi obtenues peuvent être enregistrées dans un fichier en cliquant sur l'icone [image].

Images supportant cette fonction :
images monochromes FITS/CPA

Fonction(s) Script associée(s):
GetAstrometrie

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Type de centroïde

> Analyse > Astrométrie > Type de centroïde

Lancement : Menu [Analyse] > [Astrométrie] > [Type de centroïde]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de définir le type de centroïde à utiliser lors des mesures astrométriques. Il y a deux possibilités :

  • Centroïde gaussien : le logiciel modélise l'étoile sous la forme d'une gaussienne afin de définir la position de son centre

  • Centroïde barycentrique : le logiciel calcule le barycentre les pixels situés dans un rectangle de sélection contenant l'étoile. C'est ce barycentre qui est considéré comme le centre de l'étoile

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Taille de la fenêtre

> Analyse > Astrométrie > Taille de la fenêtre de mesure

Lancement : Menu [Analyse] > [Astrométrie] > [Taille de la fenêtre de mesure (Gauss2D/Moffat)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de régler la taille de la fenêtre d'analyse pour la réalisation des centroïdes de type Gauss2D ou Moffat.

Une fenêtre apparaît au lancement :

Le réglage de la taille de la fenêtre

Il suffit alors d'imposer la taille désirée pour la fenêtre.

Accès :
Images monochromes FITS/CPA ouverte

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Taille de la fenêtre centroïde gaussien

> Analyse > Taille de la fenêtre centroïde gaussien

Lancement : Menu [Analyse] > [Centroïde] > [Taille de la fenêtre (Gauss2D/Moffat)]

But : Fixer la taille de la fenêtre d'analyse pour un centroïde gaussien.

On définit la taille de la zone rectangulaire utilisée pour les mesures photométriques ou les mesures astrométriques par centroïde gaussien.

Au lancement de la fonction, une fenêtre s'ouvre permettant de définir la taille de la fenêtre d'analyse

Utilisation :
Une image monochrome doit être ouverte pour que le menu apparaisse.

Fonction script associée :
La taille de la fenêtre d'analyse est définie à l'intérieur des fonctions script qui l'utilise.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Taille de la fenêtre centroïde barycentrique

> Analyse > Taille de la fenêtre centroïde barycentrique

Lancement : Menu [Analyse] > [Centroïde] > [Taille de la fenêtre (barycentrique)]

But : Fixer la taille de la fenêtre d'analyse pour un centroïde barycentrique.

On définit le nombre de pixels utilisé dans la zone rectangulaire pour les mesures photométriques ou les mesures astrométriques par centroïde barycentrique.

Au lancement de la fonction, une fenêtre s'ouvre permettant de définir la taille de la fenêtre d'analyse

Utilisation :
Une image monochrome doit être ouverte pour que le menu apparaisse.

Fonction script associée :
La taille de la fenêtre d'analyse est définie à l'intérieur des fonctions script qui l'utilise.

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Centroïde barycentrique

> Analyse > Centroïde barycentrique

Lancement : Menu [Analyse] > [Centroide] > [Barycentrique [Nbre pixels=..px]]

But : Calculer un centroïde barycentrique.

Cette fonction permet d'analyser une étoile avec une modélisation par centroïde barycentrique.

Chaque pixel de la fenêtre possède une intensité proportionnelle à un poids, et le barycentre de ces poids est ainsi calculé. Ce centroïde prend les N pixels dont la valeur est la plus importante dans une fenêtre d'une certaine taille. Il suppose que ces N pixels apprtiennent à l'objet.Ce centroïde sert lorsque la forme des étoiles n'est pas très bien définie ou pour des objets qui n'ont pas de forme stellaire proprement dite. Ce centroïde n'est de plus pas très précis (±0.1 pixels) et ne renvoie pas de barres d'erreurs.

Au lancement de la fonction, un curseur permet de définir une zone rectangulaire autour d'une étoile :

Lorsque la sélection est terminée, la fenêtre suivante s'ouvre, avec diverses informations sur l'étoile :

  • X et Y sont les coordonnées (en pixels) de l'étoile dans l'image

  • L'étoile ayant été modélisée sous la forme d'une élipse le grand axe et le petit axe sont calculés et affichés par le logiciel

Aide sur les scripts :
CentroidBarycentre
CentroidBarycentreThresholding

Image de test :
Etoile focalisée

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Centroïde gaussien

> Analyse > Centroïde Gauss 2D

Lancement : Menu [Analyse] > [Centroïde] > [Gauss 2D (Rayon=..p)]

But : Réaliser la détermination des paramètres d'un objet ponctuel par modélisation gaussienne.

Prérequis : Réglage de la taille de la fenêtre d'analyse pour le centroïde. (Voir lien en fin de page).

Cette fonction permet d'analyser une étoile avec une modélisation par centroïde calculé par une fonction de GAUSS. Pour une fonction à deux dimensions, la fonction gaussienne a pour équation :

Au lancement de la fonction, un curseur permet de sélectionner l'étoile à analyser :

Un exemple de sélection

Lorsque la sélection est terminée, la fenêtre suivante s'ouvre, avec diverses informations sur l'étoile :

Une analyse par centroïde gaussien
  • Les images de modélisation apparaissent d'abord, avec dans l'ordre : L'image de départ carrée de largeur (2*Rayon_Fenêtre+1) puis, l'image de modélisation otée de l'image CCD puis, l'image de départ moins le fond de ciel et enfin le modèle où le plus axe est tracé.
  • Degré représente le degré du polynome modélisant le fond de ciel, Itération donnant le nombre d'itération de l'algorithme des moindres carrés pour arriver au résultat (ce nombre n'est là que pour renseigner !) et le rayon de la fenêtre d'analyse est rappelé.
  • Centre X et Centre Y sont les coordonées "exactes" calculée de l'étoile (en pixel) dans l'image
  • Une étoile peut être considérée sur une image comme l'ellipsoide ci-dessous :

    La signification de certains paramètres

    • FwhmL : signifie Taille du grand axe de la largeur à mi hauteur de l'étoile.
    • FwhmH : signifie Taille du petit axe de la largeur à mi hauteur de l'étoile.
    • Angle (Théta) : est l'angle que fait cette ellipsoide avec l'horizontale.

    Ces trois paramètres définissent très bien la forme des étoiles : FWHM signifie en anglais : Full Width Half Maximum. En fait, si FwhmH et FwhmL ne sont pas égaux et l'angle est non nul, cela traduit un suivi défectueux ou un problème optique.
    Dans cet exemple on a la valeur 4.63 et 3.25 et on a donc 1.64 pixel de différence, soit un ellipsoide a 30% de facteur de forme ou un rapport L/H = 1.42 comme indiqué dans la fenêtre des résultats. L'angle est de 32° mais ce nombre ne peut que renseigner sur un défaut éventuel en poursuivant l'analyse sur plusieurs objets de l'image.
    De plus, si la taille des pixels et la focale du télescope ont été précisés dans l'entête de l'image, la fonction indique ensuite FwhmL et FwhmH en seconde d'arc.

    Le Reshift (ici de -1,2) indique l'endroit (en décalage X , décalage Y) où la modélisation a été considérée comme la meilleure par rapport à l'endroit où l'utilisateur a pointé.

  • Le flux de l'étoile, et le rapport signal/bruit sont également indiqués. La fonction renvoie aussi le flux de l'étoile (sans le fond de ciel), le rapport signal sur bruit de cette étoile et le paramètre O-C ("observé moins calculé") de cette fonction (plus ce paramètre est nul, meilleur est la correspondance entre la réalite et le modèle de calcul).

Cette fonction peut échouer , en voici les raisons principales :

  • Etoile saturée
  • Etoile trop proche d'une autre.
  • Fenêtre trop petite, pour cela on peut élargir la fenêtre (voir lien ci dessous)
  • Fenêtre trop grande, voir ci dessus
  • Etoile trop petite, sous échantillonnage de l'image, FWHM inférieure à 1.5; remède : augmenter la focale du télescope ou reduire le binning.

Cet algorithme de centroïde est utilisé dans toutes les fonctions d'astrométrie et de photométrie de PRiSM, c'est une des briques de calcul de base du logiciel.

Prérequis :
Régler la taille de la fenêtre du centroïde

Type d'images acceptées :
Images monochromes FITS/CPA

Fonction script associée :
CentroideGauss

Image de test :
Etoile focalisée

Conditions d'activation du menu :
Qu'une image soit ouverte.

Octobre 2007


Analyse / Centroïde Moffat

> Analyse > Centroïde par fonction Moffat

Lancement : Menu [Analyse] > [Centroïde] > [Moffat (Rayon=..p)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la détermination des paramètres d'un objet ponctuel par modélisation par fonction de Moffat.

Prérequis : Réglage de la taille de la fenêtre d'analyse pour le centroïde. (Voir lien en fin de page).

Cette fonction permet d'analyser une étoile avec une modélisation par centroïde calculé par une fonction de Moffat. Globalement, une fonction de Moffat 1D a une forme qui ressemble à une gaussienne (mais n'en est pas une !). A deux dimensions, l'équation de cette dernière est de la forme :

La fonction Moffat 2D où a et b sont les coefficients de Moffat

Au lancement de la fonction, un curseur permet de sélectionner l'étoile à analyser :

Un exemple de sélection

Lorsque la sélection est terminée, la fenêtre suivante s'ouvre, avec diverses informations sur l'étoile :

Une analyse par centroïde de moffat où pour comparaison l'étoile choisie est la même que celle du centroïde gaussien.
  • Les images de modélisation apparaissent d'abord, avec dans l'ordre : L'image de départ carrée de largeur (2*Rayon_Fenêtre+1) puis, l'image de modélisation otée de l'image CCD puis, l'image de départ moins le fond de ciel et enfin le modèle où le plus axe est tracé.
  • Degré représente le degré du polynome modélisant le fond de ciel, Itération donnant le nombre d'itération de l'algorithme des moindres carrés pour arriver au résultat (ce nombre n'est là que pour renseigner !) et le rayon de la fenêtre d'analyse est rappelé.
  • Centre X et Centre Y sont les coordonées "exactes" calculée de l'étoile (en pixel) dans l'image
  • Une étoile peut être considérée sur une image comme l'ellipsoide ci-dessous :

    La signification de certains paramètres

    • FwhmL : signifie Taille du grand axe de la largeur à mi hauteur de l'étoile.
    • FwhmH : signifie Taille du petit axe de la largeur à mi hauteur de l'étoile.
    • Angle (Théta) : est l'angle que fait cette ellipsoide avec l'horizontale.

    Ces trois paramètres définissent très bien la forme des étoiles : FWHM signifie en anglais : Full Width Half Maximum. En fait, si FwhmH et FwhmL ne sont pas égaux et l'angle est non nul, cela traduit un suivi défectueux ou un problème optique.
    Dans cet exemple on a la valeur 4.47 et 3.16 et on a donc 1.31 pixel de différence, soit un ellipsoide a 30% de facteur de forme ou un rapport L/H = 1.41 comme indiqué dans la fenêtre des résultats. L'angle trouvé à la modélisation est de -58° mais ce nombre ne peut que renseigner sur un défaut éventuel en poursuivant l'analyse sur plusieurs objets de l'image par des gaussiennes.
    De plus, si la taille des pixels et la focale du télescope ont été précisés dans l'entête de l'image, la fonction indique ensuite FwhmL et FwhmH en seconde d'arc.

    Le Reshift (ici de -1,2) indique l'endroit (en décalage X , décalage Y) où la modélisation a été considérée comme la meilleure par rapport à l'endroit où l'utilisateur a pointé.

  • Le flux de l'étoile, et le rapport signal/bruit sont également indiqués. La fonction renvoie aussi le flux de l'étoile (sans le fond de ciel), le rapport signal sur bruit de cette étoile et le paramètre O-C ("observé moins calculé") de cette fonction (plus ce paramètre est nul, meilleur est la correspondance entre la réalite et le modèle de calcul).

Cette fonction peut échouer , en voici les raisons principales :

  • Etoile saturée
  • Etoile trop proche d'une autre.
  • Fenêtre trop petite, pour cela on peut élargir la fenêtre (voir lien ci dessous)
  • Fenêtre trop grande, voir ci dessus
  • Etoile trop petite, sous échantillonnage de l'image, FWHM inférieure à 1.5; remède : augmenter la focale du télescope ou reduire le binning.

Cette fonction de Moffat a été rajoutée car elle est censé donner des résultats "plus proche" de la réalité qu'une gaussienne..

Prérequis :
Régler la taille de la fenêtre du centroïde

Type d'images acceptées :
Images monochromes FITS/CPA

Fonction script associée :
CentroideMoffat

Image de test :
Etoile focalisée

Conditions d'activation du menu :
Qu'une image soit ouverte.

Octobre 2007


Analyse / Photométrie par méthode de demi-flux

> Analyse > Photométrie par méthode de demi-flux

Lancement : Menu [Analyse] > [Centroïde] > [Diamètre demi-flux [rayon=..p]]

Touche de raccourci : CTRL + Z

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Calculer la largeur d'un objet par la méthode du demi-flux.

Prérequis : Réglage de la taille de la fenêtre d'analyse pour le centroïde. (Voir lien en fin de page).

Cette fonction est utile lorsque les étoiles sont défocalisées (au point de distinguer l'image du miroir secondaire dans l'image de l'étoile). Les modèles Gaussien ou moffat ne peuvent alors être appliquées et on mesure le rayon du cercle fictif le flux de l'étoile à l'intérieur de cercle sera égal à la moitié du flux total de l'objet. Cettte fonction est à la base de l'outil de focalisation automatique.

Le calcul se passe en plusieurs étapes :

  • Déterminer le centre de l'objet le mieux possible à l'aide d'un calcul barycentrique.
  • Mesurer le flux total de l'étoile (moins le fond de ciel) dans la fenêtre de calcul.
  • Créer un ensemble de cercle dont le rayon varie d'1/100 ème de pixel a chaque itération. Calculer le flux de l'objet à l'intérieur de ce cercle et le comparer au flux total de l'objet.
  • Le résultat final correspond au rayon dont le flux calculé à l'intérieur du cercle est égal à 50% du flux total.

Les résultats sont fournis dans une fenêtre et un graphe représentant le flux de l'objet en fonction de l'éloignement au centre est fourni :

Le graphe résultat

Le résultat dessiné !

Dans la représentation sur l'étoile, le carré rouge indique la zone de calcul alors que le cercle jaune donne le cercle retenu pour considérer que la moitié du flux est à l'intérieur de ce cercle jaune. Cette fonction donne de bons résultats aussi avec des étioles focalisées et on remarque que dans ce cas, le résultat obtenu est proche de la FWHM de l'objet. Par contre, cette méthode ne permet bien sûr pas d'avoir l'orientation de l'étoile.

Des images de test sont fournies afin de comparer les résultats.

Fonction script associée :
PRC_Flux_Radius

Exemples d'image :
Etoile focalisée
Etoile défocalisée

Prérequis :
Régler la taille de la fenêtre du centroïde

Conditions d'activation du menu :
Qu'une image soit ouverte.

Octobre 2007


Analyse / Largeur à mi-hauteur d'une raie

> Analyse > Largeur à mi-hauteur d'une raie

Lancement : Menu [Analyse] > [Centroïde] > [Largeur à mi-hauteur d'une raie]

Touche de raccourci : CTRL + P

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Modélisation simplement et rapidement une raie pour en connaître sa largeur.

Cette fonction est destinée à servir d'introduction au module de focalisation spectral.
Beaucoup de raies ne peuvent être modélisées de façon purement gaussienne, notamment en raison des divers mouvements de matières autour de l'étoile. Cependant, lors du réglage du collimateur à partir des raies d'étalonnages de la lampe spectrale, les raies qui apparaissent ont un profil gaussien. De façon à rendre ces raies les plus "fines" possible, cet outil est utilisé.

Une image faisant apparaître les raies doit être ouverte. Lors du lancement de la fonction, l'utilisateur doit positionner le curseur vertical sur une raie et le profil sera effectué sur la ligne horizontale du curseur :

Le positionnement du curseur

Une fois le profil gaussien calculé, le résultat est présenté de deux manières :

  • Visualisation graphique :

    La raie fittée

    La courbe noire est la représentation à une dimension de l'intensité des pixels sur une ligne alors que la courbe rouge représente la courbe modélisée. Ceci permet à l'utilisateur de valider à l'oeil ou non la modélisation effectuée.

  • Résultats calculés :

    Les résultats calculés

L'utilisateur peut alors, lors d'un réglage, rendre la raie la plus fine possible en comparant ses valeurs !

Images supportant cette fonction :
images monochromes avec des raies spectrales à profil gaussien.

Fonction(s) Script associée(s):
Gauss1D

Voir aussi :
Réglage des graphes sous PRiSM
Outil de focalisation sur raie

Image de test :
Image d'une lampe de calibration spectrale

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Octobre 2007


Analyse / Largeur à mi-hauteur d'une raie

> Analyse > Largeur à mi-hauteur d'une ligne

Lancement : Menu [Analyse] > [Centroïde] > [Largeur en 1/cosh (1D)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Modélisation simplement et rapidement une ligne sous la forme d'une fonction en 1/cosh.

La fonction cosh est la fonction "cosinus hyperbolique". Dans PRiSM, elle est cherchée sous la forme :

où k prend une valeur de façon à coller le mieux possible aux profils.

Une image de test est fournie (voir lien en fin de page).

La position retenue pour le calcul : position en X du curseur de la souris et ligne correspondant au curseur en Y de la souris.

Une fois le profil en 1/cosh calculé, le résultat est présenté de deux manières :

  • Visualisation graphique :

    Le graphe fourni

    La courbe noire est la représentation à une dimension de l'intensité des pixels sur une ligne alors que la courbe rouge représente la courbe modélisée. Ceci permet à l'utilisateur de valider à l'oeil ou non la modélisation effectuée.

  • Résultats calculés :

Images supportant cette fonction :
images monochromes avec des profil en 1/cosh.

Fonction(s) Script associée(s):
CosH_1D

Image de test :
Etoile focalisée

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Octobre 2007


Analyse / Recherche automatique d'astéroïdes

> Analyse > Recherche automatique des astéroïdes > Recherche astéroïdes

Lancement : Menu [Analyse] > [Recherche automatique des astéroïdes] > [Recherche astéroïdes]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de lancer la recherche automatique d'astéroïdes à partir d'au moins 3 images d'une même région du ciel, réalisées à un intervalle de temps suffisant (au moins 20 minutes en général).

Au lancement de la fonction, la fenêtre suivante s'ouvre :

Le bouton [...] permet de sélectionner les images qui seront utilisées pour la recherche d'astéroïdes.

Il faut ensuite configurer la recherche des astéroïdes en 4 étapes :

  • Paramètres de recherche des étoiles
  • Paramètres de recherche des astéroïdes
  • Paramètres astrométriques
  • Paramètres MPC
Paramètres de recherche des étoiles

paramètres de recherche des étoiles

Cette boite de dialogue permet de définir les paramètres liés à la recherche de toutes les sources stellaires dans les images.

  • Seuil de détection : Il s'agit du seuil au-dessus duquel les sources vont devenir détectables. Le logiciel est capable de calculer la valeur du fond de ciel ainsi que le bruit de fond ciel qui correspond à un écart type. Au dessus d'un certain nombre de fois la valeur cet écart type au dessus du fond de ciel, on considère qu'un objet est détecté. Cette valeur est généralement de 3 mais peut être ramenée à 2.5 si l'on veut détecter des objets plus faibles.

  • Appliquer un modèle gaussien : Cette option est fortement conseillée. Elle permet d'appliquer un modèle de forme gaussienne sur les sources détectées. Ceci facilite la discrimination entre les objets de forme stellaire et les autres, et donc d'améliorer considérablement la détection. De plus, cela permet de calculer avec précision la position des objet, ainsi que leur magnitude. Vous pouvez ne pas cocher cette option dans le cas ou la largeur a mi-hauteur des étoiles est tres faible (sous-échantillonage), ou lorsque la densité d'étoile est tres importante (observations dans la Voie Lactée).

  • Largeur à mi-hauteur des étoiles : Ce paramètre n'est valable que si vous avez coché l'option précédente. Il doit avoir la valeur de la largeur à mi-hauteur moyenne des étoiles dans vos images. Pour la connaitre, vous pouvez utiliser la fonction "centroide gaussien" de PRiSM.
    Pour les grandes images pour lesquelles cette valeur varie en fonction de la position dans l'image, cette valeur est recalculée automatiquement. Vous devez tout de même mettre une valeur de départ correcte.

  • Seuil de saturation des étoiles : Ce paramètre n'est valable que si vous avez coché l'option "Appliquer un modèle gaussien". Il doit correspondre à la valeur de saturation de vos images et pemet de traiter de facon différente les étoiles saturées.

  • Eliminer les étoiles saturées : Cet paramètre n'est valable que si vous avez coché l'option "Appliquer un modèle gaussien". Le fait de cocher cette option, permet d'éliminer directement les étoiles saturées. Celles-ci peuvent en effet biaiser l'étalonnage astrométrique et photométrique.

  • Taille du buffer image (nbre de ligne) : Ce paramètre est utilisée pour les grandes images. En effet, pour ne pas surcharger l'ordinateur, celles-ci sont d'abord découpées en morceaux avant d'être traitées. Le paramètre détermine le nombre de ligne pour chacun des morceaux.

Paramètres de recherche des astéroïdes

paramètres de recherche des astéroïdes

Ces paramètres sont utilisés lors de la reconnaissance des astéroides proprement dite, une fois que les catalogues d'objets dans chacune des images ont été créé (les fichiers CAT sauvés dans le même répertoire que le répertoire principal). En effet, il ne suffit pas de détecter les astéroides dans les images, il faut aussi savoir les reconnaitre. Ces paramètres sont les plus délicats à manipuler et vont influencer sur le nombre de détection.

  • Vitesse maximale des astéroides ("/heure) : Ce paramètre permet d'éliminer les astéroides qui auraient des vitesses trop importantes que l'on pourraient considérer comme irréalistes. Le fait de diminuer ce paramètre permet de diminuer le nombre de fausses détections. A l'opposé, si celui-ci est trop faible, il peut éliminer un certain nombre d'astéroides des critères de détection.

  • Distance minimale entre les position (") : Il s'agit de la distance minimale que doit parcourir un astéroide pour être détecté. Une valeur trop faible entrainera un nombre important de fausses détections alors qu'une valeur trop importante limitera le nombre d'astéroide détectés.

  • Erreur sur la position (") : Ce paramètre indique l'erreur de position de l'astéroide. Cette erreur est généralement liée à l'instrumentation et à la qualité de l'image. Plus on augmente ce paramètre et plus le nombre de fausses détections augmente. Si on le diminue de facon trop importante c'est le nombre d'astéroides détectés qui diminue.

  • Erreur sur la trajectoire (") : Ce paramètre doit être du même ordre que celui sur l'erreur de position, sauf si l'espacement en temps entre chacune des images est tres important. Dans ce cas de figure, on ne considère plus que les astéroides se déplacent en ligne droite et le paramètre doit alors avoir une valeur plus élevée. Même remarque que pour le paramètre précédent en ce qui concerne l'influence sur le nombre de fausses détections.

  • Erreur sur la magnitude : Il s'agit ici de la marge d'erreur sur la brillance des astéroides dans chacune des images. Il convient ici de mettre une valeur suffisament élevée pour permettre la détection des astéroides de faibles luminosité.

  • Taille max segments X et Taille max segments Y :
    Lorsque les images ont une taille importante ce qui est le cas par exemple lorsque l'on utilise la méthode du drift scan pour prendre des images de larges portions de ciel, le logiciel découpe les images en morceaux pour mieux les recaler. En effet, du fait de la réfraction atmospherique, le décalage entre les images n'est plus lineaire. Ces paramètres déterminent la taille de ces blocks en pixels sur l'axe des X et sur l'axe des Y.

  • Confirmer les astéroides par blink : Si vous cochez cette option, le logiciel vous permettra de confimer ou non la détection d'un astéroide en vous montrant la portion d'image le concernant,par la méthode du "blink".

  • Ne pas effacer les fichiers blink : Cette option permet de garder les imagettes utilisées pour la confirmation des astéroides. Cela permet entre autre de revenir par la suite sur cette confirmation.
    Il sera alors créé un sous répertoire "blinkfiles" dans lequel sera sauvegardé toutes les imagettes qu'elles aient été validées ou invalidées. Pour chaque imagette, il sera sauvegardé N fichiers, correspondant aux N imagettes pour former le " blink " à partir des bouts des N images de recherche d'astéroïde. Les noms seront de la forme nom génériques-numéro d'astéroïdes_numéro image de provenance. Un fichier masque .MSQ sera créée pour chaque imagette sauvegardée. Ce dernier renseigne sur les propriétés de l'imagette.

Paramètres Astrométriques

PRiSM permet de faire automatiquement l'astrométrie et la photométrie des astéroides à partir des catalogues GSC (Guide Star Catalogue) ou USNO (US Naval Observatory).
La méthode utilisée fait automatiquement certains choix que l'utilisateur a l'habitude de faire lui même dans PRiSM. Elle choisi le nombre et les meilleurs étoiles, ainsi que le degré du polynome de passage pour la réduction. Si vous mettez le niveau de message d'information superieur ou égal à 3, vous aurez alors l'information sur les paramètres utilisés.

  • Calcul des position astrométriques : Si vous cochez cette option, le logiciel calculera les données astrométrique et photométriques des astéroides. Dans le cas contraire, les autres paramètres de la boite de dialogue ne seront pas valables.

  • Catalogue : Choisir le catalogue que l'on désire utiliser. Tous les catalogues sont sur le CD de PRiSM, sauf les catalogues de l'USNO.
    L'étalonnage astrométrique est plus délicat avec le catalogue USNO-SA qu'avec le catalogue GSC. En effet, même si il contient un plus grand nombre d'étoiles, certaines d'entre elles n'y sont pas ce qui peut faire échouer la fonction. En ce qui concerne les autres catalogues que l'USNO ou GSC, il faut avoir un champ suffisamment important car ce ne sont pas des catalogues qui contiennent beaucoup d'étoiles.

  • Répertoire du catalogue USNO : Indiquez ici le répertoire qui contient le catalogue USNO (généralement sur CD-ROM). Les autres catalogues ne nécessite pas de compléter cette option car ils sont déjà sur le CD de PRiSM.

  • Taille max segments X et Taille max segments Y :
    Comme pour la recherche des astéroides, on découpe l'image en morceaux pour être plus précis et palier ainsi aux problèmes de réfractions astmopshériques.
    Ces paramètres indiquent donc la tailles de ces morceaux d'images en pixels sur l'axe des X et l'axe des Y.
    Une bonne taille de ces moceaux d'image facilite aussi la reconnaissance entre les étoiles du catalogue et de l'image, ce qui améliore donc la fiabilité de l'algorithme. Si la taille des blocks est trop petite, il n'y aura alors plus assez d'étoiles dans le catalogue. Dans le cas contraire, il y a aura trop d'étoiles et le logiciel aura du mal à les reconnaitre.
Paramètres MPC

Ce menu vous permet de définir la forme du message que vous voulez éventuellement envoyer au MPC (Minor Planet Center), qui est l'organisme dans le monde qui s'occupe de regrouper les données sur les astéroides.

Exemple de message a envoyer au MPC :

123456789 123456789 123456789 123456789 123456789 123456789 123456789 123456789

COD 910
CON Charles DUPONT, 10 rue de l'Observatoire, 06000 NICE, FRANCE
CON [c.dupont@internet.com]
OBS C. Dupont
MEA C. Dupont
TEL 0.20m f/d4.5 reflector + CCD Kaf 400
NET GSC
ACK Batch

       dupon1 * C1997 09 09.02070 22 53 57.51 -05 49 22.1          19.3        910
       dupon1   C1997 09 09.02376 22 53 57.31 -05 49 21.9          19.2        910
       dupon1   C1997 09 09.02671 22 53 57.11 -05 49 21.1          19.3        910
       dupon2 * C1997 09 09.02070 22 53 34.14 -05 48 36.5          20.0        910
       dupon2   C1997 09 09.02376 22 53 34.00 -05 48 37.6          19.6        91
       dupon2   C1997 09 09.02671 22 53 33.86 -05 48 38.1          19.9        910
       dupon3 * C1997 09 09.02070 22 53 24.71 -05 57 40.6          18.0        910
       dupon3   C1997 09 09.02376 22 53 24.57 -05 57 41.9          17.8        910
       dupon3   C1997 09 09.02671 22 53 24.45 -05 57 43.2          18.3        910
       dupon4 * C1997 09 09.02070 22 53 18.69 -05 48 12.8          20.0        910
       dupon4   C1997 09 09.02376 22 53 18.52 -05 48 13.6          20.0        910
       dupon4   C1997 09 09.02671 22 53 18.35 -05 48 14.1          20.3        910

Pour plus d'informations sur la forme de ces messages, vous pouvez aller voir a l'adresse suivante :

http://perso.wanadoo.fr/christophe.demeautis/asterfaq.htm
  • Préfixe de la désignation donnée aux astéroides : PRiSM donne des désignations d'astéroides non répertoriés par le MPC.
    A vous de leur donner un autre nom apres avoir les avoir identifier. Ainsi, PRiSM utilise la forme recommandée par le MPC. Le nom que vous leur donnez n'est pas important. Etant donné que celui-ci ne doit pas dépasser 6 lettres, il sera tronqué. Il est important de ne pas mettre de tiret dans le nom.
  • Numéro de sîte MPC : Il s'agit du numéro de site délivré par le MPC. Si vous n'en possédez pas, mettez 0.
  • Entête message MPC : Il s'agit de l'entête du message que l'on veut envoyer au MPC. PRiSM s'occupe de la générer automatiquement. Parmis les mots clés importants de l'entête on trouve : COD : numéro de code référencé au MPC. Lors de la première soumission, on n'en possède pas et l'on remplace les trois chiffres du code par XXX
    CON : nom, adresse postale et e-mail de la personne qui contacte le MPC.
    OBS : nom des observateurs. Mettre l'initiale du prénom suivie par un point et un blanc puis le nom avec seulement la première lettre en majuscule. Le MPC tient à ce que
    l'on suive rigoureusement cette régle. On peut mettre plusieurs noms séparés par des virgules.
    MEA : nom de la personne qui a effectué la réduction astrométrique. Même syntaxe que pour OBS.
    TEL : renseignements concernant l'instrument d'observation. Notamment indiquer le diamètre, le f/d et le type de télescope (reflector, etc.)
    NET : nom du catalogue qui a servi à réduire les données (GSC catalogue GSC, USNO pour le catalogue USNO)
    ACK : ce mot-clé est très important car c'est lui qui déclenche le traitement automatique de votre observation au MPC. On le fait suivre par Batch suivi d'un commentaire
    quelconque entre parenthèses.

    Un mini interpréteur vous permet de remplir cette entête avec des mots clés génériques. Par exemple, si vous mettez le mot clé suivant : [Numero MPC], le PRiSM le remplacera par le numéro de site MPC.
    On trouve donc les mots clés suivants :

    [Numero MPC] : numéro de site MPC
    [Nom des Observateurs] : nom des observateurs (d'après l'entête des images)
    [Caractéristiques du téléscope + capteur] : description du téléscope (d'après l'entête des images)
    [Catalogue] : Catalogue utilisé (GSC ou USNO)
Lancement de la recherche des astéroïdes

Le paramètrage de la fonction de recherche automatique des astéroides étant terminée, il suffit de cliquer sur le bouton [OK] pour lancer la recherche.

Une fenêtre d'information s'ouvre avec le détail des opérations effectuées pendant la phase de recherche, et une autre s'ouvre pour proposer à l'utilisateur de confirmer manuellement la détection des astéroides (si cette option a été choisie dans la partie "Paramètres de détection des astéroides") :

Chaque astéroide est présenté sous la forme d'une animation mettant en évidence son déplacement d'image en image. Il suffit de valider ou invalider l'astéroides en cliquant sur le bouton correspondant.
Suivant les paramètres, certains objets sont détectés comme astéroïdes alors que ce ne sont que des points chauds :

Un point chaud sur une image

Quand tous les astéroides ont été passés en revue, la fenêtre suivante s'ouvre :

Un simple copier/coller (CTRL + SHIFT + C) permet de récupérer la partie du message à envoyée au MPC !

Un exemple de fichier de sortie est ici, résultant des images des test récupérables ci-dessous

Des graphes changeables avec PRiSM indiquent différents renseignements sur les objets trouvés :

La vitesse des astéroïdes

Les fichiers de sorties sont les suivants :

  • Des fichiers CAT crées dans le répertoire où se situe les images, des fichiers du même style que ceux créés à partir de la fonction [Analyse] > [Créer un catalogue des objets stellaires].
  • Si l'option de sauvegarde des blinks a été cochée, un répertoire "BlinkFiles" dans le répertoire où se situent les images : seront sauvegardées toutes les imagettes qu'elles aient été validées ou invalidées. Pour chaque imagette, il sera sauvegardé N fichiers, correspondant aux N imagettes pour former le "blink" à partir des bouts des N images de recherche d'astéroïde. Les noms seront de la forme nom génériques-numéro d'astéroïdes_numéro image de provenance. Un fichier masque .MSQ sera créée pour chaque imagette sauvegardée. Ce dernier renseigne sur les propriétés de l'imagette. Ces imagettes pourront être visualisée à partir de la fonction [Analyse] > [Recherche automatique des astéroïdes] > [Vérification Blink]

Type d'images acceptées :
Images monochromes en 16 ou 32 bits

Fonction script associée :
Aucune

Image de test :
3 images

Voir aussi :
Les graphes sous PRiSM

Janvier 2008


Analyse / Recherche automatique d'astéroïdes sur scan

> Analyse > Recherche automatique des astéroïdes > Recherche astéroïdes sur scan

Lancement : Menu [Analyse] > [Recherche automatique des astéroïdes] > [Recherche astéroïdes sur scan]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction est identique à la fonction [Analyse] > [Recherche automatique des astéroïdes] > [Recherche astéroïdes], sauf qu'elle permet de rechercher des astéroïdes sur les images provenant d'acquisitions en mode TDI (Drift Scan).

Au lancement de la fonction, la fenêtre qui s'ouvre présente le bouton suplémentaire [Paramètre Scan], qui permet d'indiquer les caractéristiques des images réalisées en mode TDI :

Les valeurs complétées avec les exemples d'images fournies

Une fois la fonction lancées sur les images scan, ces dernières étant plus volumineuses, l'analyse est plus longue mais le nombre d'astéroïdes potentiels est forcément plus important. La taille des segments d'analyse prend ici tout son sens !
Si le nombre d'astéroïde potentiel est trop important et avant de se lancer dans la validation, il est rappelé le nombre de vérifications qu'il faudra effectuer :

Si l'utilisateur refuse, la fonction s'arrête ici et l'utilisateur pourra eventuellement revoir ses paramètres afin de diminuer le nombre d'astéroïde potentiel.

Une fois toutes les vérifications effectuées, les résultats sont en tout point identiques aux résultats fournis par la fonction [Analyse] > [Recherche automatique des astéroïdes] > [Recherche astéroïdes].
Un fichier de sortie est fourni pour exemple, créé à l'aide des images de test.

Type d'images acceptées :
Images monochromes en 16 ou 32 bits

Fonction script associée :
Aucune

Image de test :
4 images scan, non prétraitées (source : L. Bernasconi)

Voir aussi :
Les graphes sous PRiSM

Janvier 2008


Analyse / Recherche automatique d'astéroïdes - Vérification des blinks

> Analyse > Recherche automatique des astéroïdes > Vérification Blink

Lancement : Menu [Analyse] > [Recherche automatique des astéroïdes] > [Vérification Blink]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Après avoir effectué une opération de recherche automatique d'astéroïdes, si l'option de sauvegarde des fichiers blink a été sélectionnée, il est possible d'utiliser cette fonction pour revoir les astéroïdes détectés.

Au lancement, la fenêtre suivante s'ouvre :

Le bouton [...] permet de sélectionner les fichiers blink précécemment sauvegardés au cours d'une recherche automatique d'astéroïdes.

La fenêtre suivante s'ouvre alors :

Il est alors possible de valider ou invalider des détections d'astéroïdes.

A la fin de l'analyse, il est rappelé le nombre d'astéroïde validé et le fichier à fournir au MPC est fourni en fenêtre de sortie. On retrouve aussi les graphes obtenus depuis la recherche automatique des astéroïdes.

Type d'images acceptées :
Images monochromes en 16 ou 32 bits

Fonction script associée :
Aucune

Image de test :
Liste de blink

Janvier 2008


Analyse / Recherche automatique d'astéroïdes - Compositage des blinks

> Analyse > Recherche automatique des astéroïdes > Vérification Blink

Lancement : Menu [Analyse] > [Recherche automatique des astéroïdes] > [Compositage Blink]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Après avoir effectué une opération de recherche automatique d'astéroïdes, si l'option de sauvegarde des fichiers blink a été sélectionnée, il est possible d'utiliser cette fonction pour compositer les images mettant en évidence les astéroides détectés.

Au lancement, la fenêtre suivante s'ouvre :

Le bouton [...] permet de sélectionner les fichiers blink précécemment sauvegardés au cours d'une recherche automatique d'astéroïdes.

Après avoir cliqué sur le bouton [OK], le résultat du compositage est enregistré dans le sous-dossier blinkfiles sous le nom générique des fichiers composités.

Type d'images acceptées :
Images monochromes en 16 ou 32 bits

Fonction script associée :
Aucune

Image de test :
Liste de blink

Janvier 2008


Analyse / Addition d'images pour la détection d'astéroïdes

> Analyse > Addition d'images pour la détection d'astéroïdes

Lancement : Menu [Analyse] > [Addition d'images pour la détection d'astéroïdes]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Le but de cette fonction est d'additionner une série d'images dont chacune contient un astéroïde donné mais dont le signal (ou le flux) serait trop faible pour être modélisé voire même identifié.

Il est fourni une série d'images dont chacune permet de repérer la position de l'astéroïde n°7968 (Elst-Pizarro). En effet, cet astéroïde a attiré l'attention de par la présence d'une mini-queue de 20" d'arc quelques jours auparavant. Les images ont été prises à l'observatoire du Pic du Midi, avec le télescope amateur de 60cm et d'une caméra SBIG ST10XME équipée d'un filtre Rouge. A cause du mouvement rapide du satellite et de l'échantillonnage des images, les poses ne pouvaient dépasser 2 minutes et comme le montre l'animation ci-dessous, avec une magnitude supérieure à 19 dans le rouge, l'astéroïde est à peine visible sur chaque pose (le contraste est poussé à son maximum) :

L'astéroïde est au centre de la pose

L'opération consiste donc, pour pouvoir mesurer la position de l'objet, à additionner les images une à une en les décalant de telle façon à ce que l'objet à mesurer reste fixe. Ceci aura pour conséquence de faire des trainées au niveau des étoiles. Les deux paramètres importants fournis par PRiSM (et indépendamment par le MPC) sont les paramètres "sky motion" fournis par le MPC, soit la vitesse et l'angle par rapport au nord fournis par PRiSM.

Première méthode d'accès aux paramètres de vitesse et d'angle : (2ème méthode)

Pour avoir accès à ces paramètres, il est nécessaire de repérer l'objet dans la liste des astéroïdes (mettre à jour la base si besoin). La carte du ciel doit être à l'heure de la première image à l'aide du menu contextuel de la carte du ciel (ouvrir l'image auparavant) :

Extrait du menu contextuel

Une fois ce travail effectué, afin de repérer les paramètres de l'objet, il suffit de se diriger vers l'icône de configuration de la carte du ciel ( [image]), d'aller repérer l'objet dans l'onglet désiré et d'en demander les paramètres. On notera alors les deux paramètres recherchés :

Paramètres de l'objet pour la première image

On recommence l'opération pour la dernière image (ici, plus de 90 min plus tard) :

Paramètres de l'objet pour la dernière image

On réalise une moyenne des 2 valeurs mesurées sachant qu'au vu de l'échantillonnage des images et du seeing des images, une très grande précision est inutile. Dans le cas de la vitesse, on varie entre 29,313 et 29,279"/heure. La moyenne est prise à 29,3"/heure. La différence maximum de 0,03"/heure est imperceptible sur 1,5 heure avec un sseing de 5" (env 4 pixels). Il en est de même pour les 257,1° choisis. Le fichier de sortie rappelle les valeurs retenues ....

Première méthode d'accès aux paramètres de vitesse et d'angle : (1ère méthode)

L'autre méthode est plus simple : elle consiste à connaître le numéro ou le nom de l'objet et à avoir chargé la base d'astéroïde auparavant. A partir de cette base et de la date des images, PRiSM déterminera alors automatiquement les paramètres de vitesse et d'angle. Le nom est alors à rentrer lorsque l'on complète la fenêtre ... Cette méthode exige de l'utiliser avec un astéroïde connu sinon, il faut passer par le remplissage manuel des rapamètres de vitesse et d'angle.

Remplir les paramètres de la fonction :

La fenêtre à compléter est du type suivant :

La fenêtre à compléter et les options d'étalonnage

L'étalonnage astrométrique de la première image (image de référence) est effectuée. Ceci permet de garder le même étalonnage astrométrique pour l'image finale. En effet, l'image finale sera recalée sur l'image de départ.

L'étalonnage astrométrique est effectué

Ainsi le temps de pose indiqué pour l'image finale est aussi le temps de pose de l'image n°1.

Le temps de pose n'a pas changé

Une note indiquant que l'image finale résulte d'une série stackée est fournie dans les commentaires. Cette fonction permet donc de réaliser de l'astrométrie même sur l'image stackée mais pour le moment, il est impossible de faire de la photométrie directement avec (même si l'image finale ne résulte que de la pure addition de chacune des images intermédiaires).
L'image finale peut être sauvée ou non. Un fichier texte résultant est fourni du type :

.................................................
Chargement en cours de : t133P_44.cpa
Astrométrie sur l'image : t133P_1.cpa
Extrait les étoiles de l'image..
Extraction rapide des étoiles terminée, 1008 trouvées, débute l'extraction avancée...
Nombre d'étoiles extraites de l'image : 923 -> 1.5 sec
Nbre d étoiles limité à : 60 pour la comparaison champ-catalogue.
48 étoiles après test, 60 avant test de centroide...
Ok astrometrie valide focale = 2111.98 mm
Echelle = 1.33 "/pixel
Angle PA = 257.10°   Deplacement ("/h) = 29.30
Centre x=546.00 -> RA=20h02m36.840s    y=368.00 -> DEC=-18°50'10.67''

Image de référence : t133P_1.cpa

Image : t133P_2.cpa, 7 étoiles correspondantes
Translation : dx=2.0598, dy=0.66656
Decalage du au mvt : dx=-0.74825, dy=0.21948  DT=0.04h

Image : t133P_3.cpa, 7 étoiles correspondantes
Translation : dx=3.4726, dy=1.9754
Decalage du au mvt : dx=-1.4952, dy=0.43855  DT=0.07h
............................................................

Le fichier résultat en fonction des images de test fournies est lisible ici.

L'image finale fait apparaitre l'astéroïde qui apparemment a perdu sa "queue" :

 | La modélisation | L'astrométrie faisable sur l'objet; Ecriture MPC
Le résultat | La modélisation | L'astrométrie

L'image résultante complète est téléchargeable ici
Cette image résultante aura la date exacte de la première image et son temps de pose retenu sera celui de chaque image prise séparemment.

Type d'images acceptées :
Images monochromes FITS/CPA

Fonction(s) Script associée(s):
Aucune

Série d'images de test :
Images de test (non deflatées ce qui ne présente pas de conséquences majeures pour de l'astrométrie)
Image résultante

Version Juillet 2007


Analyse / Montrer les astéroïdes sur une image

> Analyse > Montrer les astéroïdes sur une image

Lancement : Menu [Analyse] > [Centroïde] > [Montrer les astéroïdes]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la détermination des paramètres d'un objet ponctuel par modélisation gaussienne.

Prérequis : L'image doit être préalablement étalonnée grace à la fonction [Analyse] > [Astrométrie] > [Etalonnage] ou à la fonction [Analyse] > [Astrométrie] > [Etalonnage Automatique]. Par contre, la base d'astéroïde n'a pas besoin d'avoir été chargée.

Cette fonction permet de montrer les astéroïdes connus sur une image datée et étalonnée. Après un temps de calcul non négligeable (voir le lent défilement de la barre de progression !), les astéroïdes s'affichent sur l'image :

Les astéroïdes connus sur l'image

Prérequis :
Régler la taille de la fenêtre du centroïde

Type d'images acceptées :
Images monochromes 16 ou 32 bits

Fonction script associée :
Aucune

Image de test :
Image astrométrie - photométrie

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Collimation

> Analyse > Collimation optique

Lancement : Menu [Analyse] > [Collimation optique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Vérifier la collimation de l'instrument.

Cette fonction permet de controler les divers défauts d'alignement optiques (défaut de collimation, mauvais alignement de la caméra, etc) à partir de l'élongation des étoiles sur l'image, qui est définie comme le rapport FWHMH / FWHML et de l'angle theta (voir dessins ci-dessous) :

Cette fonction doit être lancée sur une image réalisée avec un bon seeing. Au lancement, la fenêtre suivante s'ouvre :

Dans un premier temps, il est conseillé de laisser les paramètres par défaut proposés par le soft.

  • On peut spécifier le signal sur bruit minimal des étoiles qui seront analysées

  • De même, on peut spécifier l'élongation maximale que devront avoir les étoiles qui seront analysées.

  • Les dégrés maximums des polynômes 2D utilisés pour la modélisation devront être précisés.

Après avoir cliqué sur le bouton [OK], PRiSM repère les étoiles valides de l'image et calcule pour chacune d'elle leur élongation et leur angle théta, et affiche le résultat sous 2 formes :

Une représentation textuelle avec quelques informations sur le étoiles utilisées pour l'analyse :

Les zones numérotées correspondent à la représentation graphique sur l'image analysée elle-même :

Pour chaque étoile, une valeur numérique représente l'élongation de l'étoile, et un trait rouge est placé avec une orientation égale à celle de l'angle théta. En modifiant les seuils de visualisation, on peut obtenir une image ne contenant que les élongations des étoiles sous forme de traits rouges, comme sur l'image ci-dessous, caractéristique d'une optique présentant une coma importante (les traits rouges sont tous orientés vers un point central, l'axe optique de l'instrumentation) :

De façon à préciser visuellement les zones les moins touchées par un défaut de collimation, d'autres graphiques sont définis. A commencer par celui de l'uniformité de mise au point.

Ce graphique montre en zone foncé les endroits où la mise au point semble la plus reproductible et donc la plus uniforme possible. Le but est que cette zone soit la plus centrée possible.

Le graphique donnant La FWHM en X par rapport à celle en Y est aussi fourni :

La zone foncée doit être la plus centrée possible donnant le rapport minimal entre FWHM max et FWHM min obtenu sur l'image.

Fonction script associée :
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Décembre 2010


Analyse / Réduit les 4 côtés

> Analyse > Réduit les 4 côtés

Lancement : Menu [Analyse] > [Réduit les 4 côtés]

A partir d'une image de grande taille (image1) dont on aura du mal à inspecter les 4 coins (parce que l'on est obligé d'utiliser des ascenseurs), il est possible de la réduire en 5 zones, definies sur l'image suivante :

La grande image de départ
Image 1

L'utilisateur donne la taille de la zone en pixels (largeur=hauteur), et la fonction de PRISM produit l'image ci dessous (image 2):

Image résultante
Image 2

L'avantage est que l'on peut inspecter visuellement les 4 coins et le centre d'une image d'un seul coup d'oeil et donc inspecter la qualité de la collimation (defauts optiques comme la coma) bien plus facilement que sur une grande image.

Bien que l'image soit suffisamment petite, il est proposé un exemple pour mettre en évidence un défaut de collimation; il est choisit un carré de largeur 100 sur l'image et le résultat parle de lui-même :

Le défaut de collimation

Images supportant cette fonction :
images monochromes FITS/CPA

Fonction(s) Script associée(s):
Reduc_Coll

Image de test :
un coin de ciel

Voir aussi :
[Analyse] > [Collimation]

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Nov 2005


Analyse / Inclinaison CCD

> Analyse > Inclinaison de la caméra CCD

Lancement : Menu [Analyse] > [Inclinaison caméra CCD]

But : Cette fonction permet de mesurer l'inclinaison de la caméra CCD par rapport à l'axe d'ascension droite :

La mesure se fait à partir d'une image réalisées en pointant une étoile brillante à fort grossissement et en coupant l'entraînement du télescope jusqu'à ce que la trace de l'étoile sorte du champ de la caméra CCD. Il est souhaitable qu'une seule étoile soit présente sur l'image.

Voici un exemple d'image réalisée dans ces conditions :

L'image à analyser doit être préalalablement chargée et sélectionnée. Au lancement de la fonction, la fenêtre suivante s'ouvre :

Elle indique l'inclinaison de la caméra modulo 180, ainsi que l'inclinaison donnée en angle trigonométrique.

L'inclinaison de la caméra est conservée en mémoire pour une future utilisation dans les fonctions de cartographie planétaire.

Type d'images acceptées :
Images monochromes FITS/CPA

Fonction script associée :
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Shark Hartmann

> Analyse > Shark Hartmann

Lancement : Menu [Analyse] > [Shark Hartmann]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser une analyse complète de l'optique de son instrument.

Pour de amples renseignements, aller voir le tutorial écrit par Cyril Cavadore de façon à en expliquer le principe.

Fonction script associée :
Aucune

Type d'images acceptées :
Images monochromes FITS/CPA

Prérequis :
Pages de Cyril Cavadore

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Energie encerclée

> Analyse > Energie encerclée

Lancement : Menu [Analyse] > [Energie encerclée]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Détecter l'intensité lumineuse sur différentes parties d'une image.

En construction

L'image de départ Après calcul de l'énergie encerclée

Le graphe résultant

Fonction script associée :
Aucune

Image de test :
Image d'une étoile.

Prérequis :
Les graphes sous PRiSM

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version


Analyse / Supprimer la distorsion géométrique optique

> Analyse > Supprimer la distorsion géométrique optique

Lancement : Menu [Analyse] > [Supprimer la distorsion géométrique optique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction est capable de mesurer et d'enlever la distorsion des images. Elle n'est efficace uniquement que sur des images à caractère solaire ou lunaire.

Les images formées par une optique, quelle qu'elle soit, presentent de la distorsion géométrique. Les plus connus sont les effets de la distorsion en barillet ou en croissant. En imagerie Astronomique, les effets de la distorsion sont toujours présents et spécialement avec des focales courtes. On peut résumer la distorsion à une sorte de changement d'echelle dans l'image. Le centre de l'image (là où se trouve l'axe optique), defini l'endroit où la distorsion est nulle, et les 4 bords de l'image celle où elle est la plus élevée. Il est possible de dire qu'au centre de l'image l'echelle par pixel (= le nombre de secondes d'arc par pixels) est différent par rapport aux coins de l'image.

L'exemple fourni est une image issue d'un teleobjectif CANON 200mm F2.8 dont l'échantillonnage est de 6.7 arcsec par pixel de 6.5µm. C'est une image de la région des dentelles du cygne.
Comme cela, à l'oeil, la distorsion n'est pas visible. Le champ fait 6.5° par 4.3° issu c'est une pose unique de 30s.
Il est fortement recommandé d'enlever le noir, le bias et le flat à une telle image. Les pixels chauds non enlevés peuvent poser des problemes ultérieurs si l'image n'est pas deflatée et dénoirée.
Pour exemple et pour une telle image, les paramètres recommandés sont les suivants :

Les paramètres optimaux

La plupart des paramètres à fournir sont généraux aux fonctions d'étalonnage de PRiSM et on les retrouve dans les menus comme [Analyse] > [Astrométrie] > [Etalonnage automatique]

  • Choisir le catalogue d'étoiles retenu; ici, prendre le catalogue SAO, pour avoir une couverture en etoile adaptée, les autres catalogues auront soit trop d'étoiles faibles (et non utilisables) ou trop peu (trop brillantes).
  • Il faut indiquer le nombre d'étoiles retenues : ici, mettre 200 etoiles pour la comparaison image/catalogue. Si on choisit moins d'étoiles, on s'expose à des erreurs de calcul trop importante. Si on choisit trop d'étoiles (on peu aller jusqu'a 512), on s'expose à des temps de calculs plus longs.
  • Les coordonnées du pixel central definissent là où se trouve l'axe optique; généralement pour une optique bien reglée, le centre de l'image.
  • Le degré du polynome radial : comme la distorsion optique est symétrique de révolution, le polynome de distorsion est défini comme D(r) = a.r + b.r3 + c.r5 + d.r7 + ...... Le degré maximal du polynôme de distorsion à chercher est celui à fournir dans la fiche; ici, il est de 5. On notera que, après calcul, "a" est très proche de 1.0, et que b, c et d sont très proches de zéro. Une image dont la distorsion est nulle doit obéir à un polynôme de distorsion de la forme D(r) = a.r .

r = distance radiale

Le résidu tolérable signifie que toutes étoiles deviant du polynôme théorique de plus de 0.5 pixels sera éliminée.

Pour une image à grand champ faite avec un téléobectif, il est nécessaire de changer les paramètres de reconnaissance des etoiles à l'aide du menu [Options] > [Reconnaissance des champs d'étoiles] : seules les etoiles entre magnitude 8 et 10 du catalogue seront prises en comptes dans l'image exemple :

paramètres de centrage utilisés

Une fois la fonction lancée, le logiciel trouve automatiquement la correspondance des etoiles entre le champ et le catalogue, et calcule la distance théorique qu'elle devrait avoir par rapport au centre et compare avec la mesure sur l'image de cette distance au centre.

Nombre d'étoiles validées par centroide : 182
Calibration astrometrique réussie, Focale : 196.1mm, Residus Alpha : 4.92", Residus Delta : 3.46"
Coordonnées "centre", Xc=1761 Yc=1174 RA/DEC =20h50m25.140s +32°05'16.40''

182 étoiles ont été validées et le résidu astrométrique fait moins de un pixel (6.7"/pixel); de plus, les coordonnées du centre sont connues tres précisemment, ainsi que la focale du teleobjectif.

Nbre d'étoiles pour le calcul de dé-distorsion : 182
Nbre d'iterations : 2, nbre d'etoiles gardées pour le calcul des coef de distorsion : 173
Coefficient de degré 1 : 0.00273321744081902 (1.00273321744082)
Coefficient de degré 3 : 9.46585640369389E-010
Coefficient de degré 5 : 2.35527835400619E-017
Residu de distorsion : 0.201 pixels

Le polynôme de distorsion est maitenant connu, et il vaut D(r) = 1.0027.r + 9.46.10-10.r3 + 2.35.10-17.r5 , l'écart moyen des 173 étoiles gardées pour le calcul par rapport au polynôme théorique est de 0.2, ce qui dénote un très bon calcul, et un bon réalisme. Ces coefficients sont la signature de l'objectif.
Attention : avec des focales courtes et près de l'horizon, la distorsion optique risque d'être entaché par la distorsion due à la refraction atmosphérique, qui elle, n'est pas symetrique par rapport au centre de l'image !

PRiSM propose aussi la courbe de distorsion avec en X la distance au centre de l'image, et en Y l'écart en pixel par rapport à la position où il n'y aura pas de distorsion.
On peut simplement dire qu'une étoile à 2000 pixels du centre de l'image à sa position décalée de 13 pixels par rapport à sa position nominale.

La courbe de distorsion

Pour être plus précis, ici, le premier coefficient dans D(r) = 1.0027.r + 9.46.10-10.r3 + 2.3510-17.r5, vaut non pas 1.0 mais 1.0027, ce qui dénote une erreur de 0.27% dans le calcul de la focale et tend a éxagerer les erreurs. Si G(r) = 1.0.r + 9.46.10-10.r3 + 2.3510-17.r5, l'erreur n'est pas de 13 pixels mais en réalité de 8.

Cependant, 8 pixels restent un effet de distorsion important : 8/2000 = 0.4% et va empêcher tout assemblage des images pour une mosaïque, par exemple.

Voici l'image résultat : les carrés verts sont des étoiles valides et les carrés rouges sont des étoiles éliminées. Il faut que la couverture en étoile valide sur l'image soit complet : ici le coté gauche est un peu dépeuplé, mais le coté droit est correctement couvert. Ne pas oublier que tout se fait par rapport à une distance "r" au centre de l'image.

L'image est ainsi corrigée de la distorsion, et la zone rouge montre des pixels qui serait présents sur l'image comme si l'objectif avait une distorsion nulle. Ici, La distorsion est en croissant.

Si on additionne l'image corrigée de la distorsion à l'image initiale, la différence est édifiante !! :

Fonction script associée :
Aucune

Images de test :
Image de test

Conditions d'activation du menu :
Qu'une image soit ouverte.

Septembre 2008


Analyse / Test CCD / Linéarité

> Analyse > Test CCD > Linéarité

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Linéarité]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Vérifier la linéarité d'une caméra CCD.

Acquerir au moins 10 images de type FLAT, chacune doublée, ayant des temps d'expositions différents, la camera doit disposer d'un obturateur dont le temps d'ouverture est inférieur à 0.1 sec. La source de lumière doit être la plus stable possible (pas de FLAT avec la lumière du ciel du crépuscule !!)

Par exemple : (cas d'une camera 16 bits allant de 0 à 65535 ADU)

Fichier image Prism | Temps de pose (Sec) | Moyenne (ADU)
image1.cpa | 10 | 12152
image2.cpa | 10 | 12155
image3.cpa | 2 | 2178
image4.cpa | 2 | 2185
image5.cpa | 50 | 62535
image6.cpa | 50 | 62534
....... | ....... | .......

Realisez ainsi au moins 16 paires d'images et allez jusqu'à 95% de la saturation de la caméra pour explorer toute la linéarité du CCD.

Eviter de réaliser des images avec des temps de pose qui se suivent par ordre croissant ou décroissant comme 2,5,10,50 sec, préferez plutôt un ordre aléatoire 2,50,10,5 sec.

La zone requise X1,X2,Y1,Y2 est la fenêtre dans laquelle va s'effectuer la statistique (afin de ne pas tenir compte des défauts cosmétiques du CCD). La statistique peut être soit du type médian ou classique (préferez le médian pour éviter des ennuis avec des pixels abérants).

L'intervalle (offset min et max), provient de la moyenne d'une image offset (dans ce cas fournir : Offset min = Offset -10% et Offset max= offset +10%) et permet d'optimiser l'offset vis a vis des erreurs de l'obturateur.

Prism calcule automatiquement le facteur de convertion en e-/ADU et la non-linéarite résiduelle en % sur l'ensemble des données images et sur les deux séries.

Voici les résultats renvoyés par PRiSM (en anglais, mais evident)
Optimum offset(ADU) (1): 368
Non linearity (Peak to peak) : (1): 0.4367% / -0.8695%
Optimum offset(ADU) (2): 368
Non linearity (Peak to peak) : (2): 0.3741% / -0.1807%
Convertion factor e-/ADU : 1.9926
-> RMS error : 0.12428
Readout noise (e-) : 4.7822

Les courbes suivantes sont produites par PRiSM, nul besoin de faire appel à un tableur comme "Excel".

Courbe de linearite en fonction du temps de pose :

Courbe résiduelle de linearité :

Courbe de transfert photonique, cette courbe sert pour calculer le facteur de convertion en électron par ADU du système :

Essai avec une caméra SBIG ST7E

L'essai de cette fonction a été réalisé par l'auteur de ces pages avec une caméra de la marque SBIG : la ST7E. Le capteur n'étant pas antiblooming, la linéarité de ce dernier devrait se poursuivre quasiment jusqu'à saturation.
A cette fin, 16 images ont été réalisée comme préconisées : Les temps de pose sont dans l'ordre de prise de vue : 10s, 2s, 20s, 5s, 25s, 8s, 14s et 4s.Elles résultent de la réflexion d'une lumière sur un plafond en plâtre. La lumière est très faible pour atteindre des poses de pose conséquents. Le télescope n'est bien évidemment pas bougé entre chaque prise de vue.

Les images ont été sauvegardées sous le nom générique LIN_ avec l'enregistrement automatique proposé par PRiSM. Celà donne donc 16 images de LIN_1.CPA à LIN_16.CPA
Le rectangle d'étude utilisé est : coin inférieur gauche ( 134,196) et coin supérieur droit ( 478,504). Attention au choix du rectangle (en plus d'éviter les défauts cosmétiques).
La moyenne des offsets à la température considérée étant de 107.8 ADU, on prend pour Offset Min : 97 ADU et pour Offset Max : 118 ADU. Le bruit RMS est estimé à 5.1 ADU.

On obtient alors, avant traitements, la boite de dialogue complétée suivante :

Les options complétées

On lance alors le traitement en appuyant sur "OK".
Le temps de traitement est normalement très rapide ( quelques secondes ) avec un pentium de seconde génération.
Comme prévu, trois types de graphe sont alors renvoyés :

  • La courbe de linéarité ( but initial de la manipulation ):

    La courbe de linéarité de la ST7E

    Comme prévu, cette courbe devie peu de l'idéalité. ( pour la ST7E sous PRiSM, la capacité des pixels varie de 0 à 32767 ADU ).

  • La courbe de transfert photonique est également une droite ( ce qui est rassurant ) sauf lorsqu'on se rapproche de la saturation du capteur. La pente de la droite traduit le facteur de convertion ADU/e-.

    La courbe de transfert photonique

  • Les courbes résiduelles de linéarité :

    Les plus grosses erreurs ont lieu pour des poses courtes.

  • Le fichier de données rendu par le logiciel :

    Résultats du traitement des images

    Ce sont les données directement obtenues à partir du traitement direct des 16 images.

    Ensuite, les résultats du traitement sont indiqués :

    Les données sur la linéarité de la caméra

    Ces données reprennent les 3 courbes précédentes. Notamment, on obtient le facteur de conversion d'environ 3 e-/ADU avec une erreur RMS de 0.2 e-/ADU soit en fait ici un résultat compris entre 2.90 et 3.36 e-/ADU. L'erreur semble importante. Cependant, on voit qu'une mesure ( pose de 2s ) provoque un fort écart à la linéarité. En supprimant cette mesure qui semble abbérante ( ou en la refaisant dans les mêmes conditions ) on peut diminuer l'erreur RMS mais la moyenne ne change que très peu ... d'où l'utilité de faire le plus de mesure possible ( 16 images s'avère un minium. Sur la notice technique de C. Cavadore, on voit qu'il a été fait 30 images pour arriver à un résultat très correcte.

Focntion script associée :
GetLinearity

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Linéarité par la méthode TDI

> Analyse > Test CCD > Linéarité par la méthode TDI

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Linéarité (méthode TDI)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Mesurer la linéarité de son CCD.

Cette méthode produit les mêmes resultats que la mesure de la linéarite methode classique, les différences portant sur ces points :

  • Une seule image est nécessaire (alors que pour l'autre méthode plusieurs images sont nécessaires).
  • La courbe qui donne les non linearités en fonction du signal mesuré est continue ( alors que l'autre méthode ne produit que des points discrets)
  • La précision de la mesure de la linearité est bien meilleure que celle obtenue par la methode classique.

Cette méthode a aussi des contraintes, dont les principales sont :

  • Le CCD doit avoir une PRNU inferieure a 1% sur une bande verticale donnée et pour une longueur d'onde donnée.
  • Le CCD doit etre exposé a une plage de lumière uniforme dont les variations spatiales sur une bande verticale du CCD doivent etre inférieure a 1%, typiquement ce qui est produit à la sortie d'une sphère intégrante.
  • On doit avoir la possibilité d'ouvrir l'obturateur lorsque la lecture du CCD a déjà commencé, l'obturateur doit être placé à l'entrée de la sphère intégrante, mais en aucun cas partager le même plan focal que le CCD.

Méthode : La méthode consiste à placer le CCD sur une plage de lumiere trés uniforme. L'intensite de cette plage (Flux=Fl) doit être telle que, si T est le temps de lecture du CCD, si on expose le CCD durant un temps T avec cette intensite Fl, l'image résultante doit produire un flat field d'intensité égale a 95% de la dynamique du convertisseur analogique numérique du système. Par exemple, si la dynamique est de 16bits, l'image doit montrer un Flat Field très uniforme spatialement (<1.5%) de 62000 ADUs avec ce temps d'exposition T et le flux egal à Fl.
L'image qui va servir à la mesure doit etre acquise de la facon suivante : on commence à lire le CCD obturateur fermé, et des que la lecture à déja été effectuée sur les 100 premieres lignes, on ouvre l'obturateur et on laisse lire completement le CCD avec le flux incident Fl. Je conseille aussi de cacher ces 100 premieres lignes par un masque, parce que le circuit de lecture peut être parfois perturbé par l'arrivée continue de ce flux Fl, et ainsi peut perturber les resultats.

Image résultante avec les seuils de visualisation proches à +/-1% du niveau d'offset. | Même image résultante avec les seuils de visualisation égaux a 0 et 65535, le dégradé doit être trés uniforme.

Pour reduire les données issues de cette image, on entre (voir image au dessus) :

  • la fenêtre de définition X1 et X2
  • la derniere et la premiere ligne exposée à la lumière
  • la derniere ligne qui defini le niveau d'offset du CCD.
  • Minimum flux value is meant to threshold the lower range of the intensity dynamic, to be taken into account for computations and plots.
  • Filter : sets how far the output plot curve will be filtered.
  • Flat field image is mandatory to correct the data from pixel to pixel non uniformity, it must be an image taken with the same wavelength and bandwidth as the TDI image and subtracted from by its bias image.
  • Folder : location of the flat field folder (TBC).

Les résultats obtenu sont affichés sous cette forme :

Courbe des residus de non linearite, le CCD est lineaire a +0.43/-0.3 peak-peak et 0.16% rms :

Ce graphe renvoie une coupe verticale de la zone selectionne, en fait la mediane :

Resultats renvoyees par cette fonction

Loading :G:\CCDtest\UvesRed\NewLin\eevLeftPort.cpa
Regression slope :17.978; regression Offset :-5956.5
Regression slo

Methods used :

The TDI image is median collapsed towards a single column : a 1D slope is achieved. The flats field image is used to correct the slope from the fact that all the pixels of the CCD does not have the same sensitivity. A best linear fit is found from the slope and non-linearity plot computed. Beware that an infinity of slope can be found out of a cloud of points, depending on the criteria : less mean square, weighted points, etc etc...

Focntion script associée :
CCDTest_TDI_Linearity

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Efficacité de transfert de charges

> Analyse > Test CCD > Efficiacité de transfert de charges ou CTE (EPER)

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Efficacité de transfert (CTE) EPER]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Tester l'efficacité du transfert de charge d'un CCD d'un pixel à un autre.

Ceci represente l'efficacité de transfert des charges d'un pixel à un autre, ce nombre est proche de 1 (plus exactement 0.999999), plus le transfert de charges est parfait, plus ce nombre tend vers 1.0.

Acquerir une seule image d'une plage de lumiere uniforme à 95% de la dynamique de la camera. La camera doit etre capable d'effectuer une lecture au dela de la fin de l'image contenant les pixels sensibles. Cette zone au dela de l'image "dite OVERSCAN" ne contient que des "faux pixels" qui representent l'offset du CCD. Cette zone doit s'etendre a la fois en X et en Y. C'est ce type d'images qui doit etre fourni a PRiSM pour mesurer le CTE.

Y1,Y2 est l'intervalle pour effectuer la moyenne de la derniere colonne et X1,X2 est l'intervalle pour effectuer la moyenne de la derniere colonne. Le nombre de transfert en X et Y represente typiquement la taille de la zone image.

Voici les resultats de cette fonction Loading :F:\Images\Frankie\CTE\Cte_0001
Mean -> Last X :58491.6583936574 Last X+1 :469.123061013444 Overscan area :449.922095829024
Horizontal CTE = 0.999999838470179
Mean -> Last Y :65510.6978248089 Last Y+1 :495.093474426808 Overscan area :445.12810646144
Vertical CTE = 0.999999625037444

Méthode utilisée : La méthode employée ici est l'EPER (Extended Pixel Edge Response). Cette méthode n'est pas vraiment précise et les tests à partir de Fe55 sont beaucoup plus fiables.

Focntion script associée :
GetCTE

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Efficacité de transfert de charges

> Analyse > Test CCD > Efficiacité de transfert de charges ou CTE (Fe55)

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Efficacité de transfert (CTE) Fe55]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Tester l'efficacité du transfert de charge d'un CCD d'un pixel à un autre.

This is a very powerful experiment used to derive the vertical and horizontal CCD charge transfer efficiency (CTE) and also can provide a extremely accurate measurement of the conversion factor. An Iron (Fe55) radioactive source is installed 100 mm from the CCD, in the vacuum. This source produces X-rays (5.9Kev photons) that reaches the CCD surface, creating inside the CCD bulk 1620e- in a 0.5/1um sphere. If those 1620e- are produced within a single pixel, they should be detected at the output of the CCD readout node as 1620e- times the conversion factor. Because of "failures" during the charge transfer, some electrons are lost and remains in the next pixel, and this is not . This can happen either during the vertical transfer or the horizontal transfer (serial register). Since the amount of electrons produced by the Fe55 are well defined, it is possible to compute the horizontal and vertical CTE.

A 30 sec exposure image, CCD in front of a Fe55 source :

Histogram plot of the whole CCD, pixels from the bias level and the two peeks of Fe55 (Ka1620e- Kb1778e-) are visible :

In the dialog form, enter the window to be processed (X1,Y1,X2,Y2). Then the readout direction (CCD output port direction left/right). The conversion factor must be known within 5% accuracy. The bias offset level as also to be provided (accurate, from overscan areas or master bias frame). Select more than one image is recommended for better accuracy, as so as to enter more than 2 lines for each packet. Those packet are used to bin the histogram of a line/column N times.

Results :

Console output:
Load image: iron-1.cpa
Load image: iron-3.cpa
Load image: iron-2.cpa
Load image: iron-4.cpa
CTEV=1.000000101
CTEH=0.999997222
Conversion factor=0.680809

Horizontal CTE histogram as an image the fact that the slope is left tilted showed that CTE is lower than 1.0 :

Vertical CTE histogram as a printable plot (very good V.CTE) :

Horizontal CTE histogram as a printable plot (H.CTE =0.999997222 ) :

Method used :
The software performs vertical histogram gathering N columns so as to have a better Signal to Noise measurement, it also uses more than one image to improve the measurement Then displays an image where the X axis is the counts in ADUs, Y the column number and Z the number of pixels having the given X counts. The softwarefinds the histogram peaks for every column and fits the best slope. As you can see on the image above, the slope that joins all the peak is slightly tilted to the left, showing that the 1620e- created at the end of the serial register (column 2048) are indeed less than 1620e-, thus showing a CTE not equal to 1. The software, according to the histogram peak slope can compute the HCTE.

The same method applies for the horizontal CTE, just swap the word vertical with horizontal and the word column with rows.

Focntion script associée :
GetCTE

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Bruit de lecture

> Analyse > Test CCD > Bruit de lecture

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Bruit de lecture]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Connaître le bruit de lecture de son CCD.

La procédure d'acquisition des images est simple : réaliser au moins 5 images dans l'obscurité et avec un temps de pose nul.

Prendre une fenêtre X1,X2,Y1,Y2 sans défauts graves.

Cette courbe est une moyenne de toutes les lignes sur une seule colonne, et permet de visualiser des effets noyés dans le bruit.

Cette image montre les défauts du CCD sur une image d'offset qui sont 5 sigmas de bruits au dessus de la moyenne.

Résultats renvoyés par PRiSM:

Pixel amount taken to provide median frame :
noise0005 ->1 42.53%
noise0003 ->2 57.43%
noise0004 ->3 57.65%
noise0002 ->4 42.39%
Noise : 2.286 ± 0.005463 ADU
Pixel amount above 5 sigmas : 17100 threshold (ADU) : 6.584

Methods used :

The RMS value is computed throughout the selected area. The final noise is the median noise from the set of the images. To trace bias defect, a median stack is performed to get rid of cosmic rays, and every pixel which is above or below five (5) sigmas is referenced as a bad pixel and mapped.

Focntion script associée :
GetNoise

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Courant d'obscurité

> Analyse > Test CCD > Courant d'obscurité

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Courant thermique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Connaître le courant thermique de son CCD.

As input image data, at least 3 images in total darkness has to be achieved, having the same exposure time for each (from 5 minutes to 2 hours depending on the cooling efficiency and CCD temperature).

A mean clean Offset or Bias image MUST to be done as the result of the median stack of many individual bias frames. Also the conversion factor must be known accurately.

Be aware that sometimes residual image can disturb dark current measurement, especially if the CCD is cooled at -120C . Avoid to acquire the data just after having acquired high level flat fields. To watch this out : take ten dark frames at the same temperature and check whether or not the mean dark level is decreasing. Wipe the CCD many times before in the darkness. For instance take 10 darks exposure of one hour exposure, and do not use the first images (do not select the first four images).

La zone de calculs X1, X2, Y1, Y2 devra être exempte de graves défauts, comme une colonne chaude.

Voici les résultats renvoyés par le logiciel:

Ceci est la moyenne des lignes projetées sur une colonne. On voit ici les effets dus aux colonnes défectueuses...

Ici les pixels chauds signalés par une croix verte sur l'image, au dessus de 5 sigmas.

Résultats renvoyés par la fonction Loading :F:\Images\Frankie\dark\run1@-120\dark0004.fits
Pixel size information NOT present or NULL in file header, so I take : 15 x 15(µm)
Loading :F:\Images\Frankie\dark\run1@-120\dark0003.fits
Loading :F:\Images\Frankie\dark\run1@-120\dark0002.fits
Loading :F:\Images\Frankie\dark\run1@-120\NoiseMedian.cpa
Integer data type...
Median search :
Compute median frame...
Pixel amount taken to provide median frame :
dark0004.fits ->1 27.92%
dark0003.fits ->2 44.71%
dark0002.fits ->3 27.37%
Offset -> Mean :327.1 Median : 327 ADU
Exposure time (s) = 1800
Dark current : 1.333 ± 0.4714 ADU
Dark current : 5.333 ± 1.886 e-/hour/pixel
Cosmic event rate : 1.195 ± 0.04297 events/min/cm²
Pixel amount above 5 sigmas : 10659 threshold (ADU) : 10.51
Dark current using median frame after median filtering : 5.128 e-/hour/pixel

Methods used :

The software compute a median stack out of the N provided images and subtract the bias file to it. The dark current is the remaing amount of adus above the bias image (positive data). the defects are subtracted automatically as the difference between individual frames and the median stacked frame.

Focntion script associée :
GetDark

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Rendement quantique et PRNU

> Analyse > Test CCD > Rendement quantique et PRNU (uniformité spatiale de réponse)

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Rendement quantique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Mesurer le rendement quantique de son CCD.

This is a really difficult measurement, because the result has to be provided in absolute figures, and you MUST have to input calibration data.

Basic knowledge regarding QE measurement must be known !!

The usual scheme is to use an absolute quantum efficiency calibrated photodiode installed at the same position as the CCD will be, and to use flat field images made in the front of an integrating sphere, fed by one or two monochromators. This setting allows you to get different flat field images at different wavelengths and short bandwidth.

The incoming light wavelength is typically ranging from 300 to 1100 nm, with a short bandwidth, such as 5nm. The photodiode current is measured, and the photodiode manufacturer calibration curve enables you to compute the amount of photons per square centimeter and per second. This is an example of a photodiode calibration file (as a text file) :

# No TABS
# ratio bdw 4 # col 1 Wavelength
# col 2 Flux on the CCD surface, expressed in photons/sec/cm2
# col 3 Current that is measured at integrating sphere level or closeby to the CCD
320    1.1e+8   0.209e-9
340    2.55e+8  0.544e-9
360    5.18e+8  1.115e-9
380    9.27e+8  2.124e-9
400    1.44e+9  3.646e-9
450    2.9e+9   7.94e-9
500    3.54e+9  10.207e-9
550    3.9e+9   11.5e-9
600    3.97e+9  11.74e-9
650    3.6e+9   10.85e-9
700    3.09e+9  8.96e-9
750    2.35e+9  6.67e-9
800    1.54e+9  4.224e-9
850    1.66e+9  4.52e-9
900    1.42e+9  3.871e-9
950    3.4e+9   8.6e-9
1000   3.16e+9  7.65e-9
1100   2.42e+9  1.224e-9 Afterward, the optical transmission of the dewar window according to the wavelength as to be provided (as a text file).# Window transmission
# col 1 Wavelength
# col 2 Relative transmission
320    0.94
340    0.97
360    0.98
380    0.98
400    0.99
450    0.99
500    0.99
550    0.996
600    0.9856
650    0.9615
700    0.926
750    0.889
800    0.8517
850    0.8153
900    0.7873
950    0.7627
1000   0.7466
1100   0.723

IMPORTANT : For all the wavelengths used, calibration photodiode text file and window calibration transmission text file MUST match each other. It means that the same wavelengths must be entered in the two calibration files (Otherwise an error will occur). FITS files must include the following HEADER Keywords :

WAVLG = 550 // Central wavelength : Expressed in mn
BANDW = 5 // Bandwith : Expressed in mn
FLUX = 1.2E-5 // Photodiode current expressed in Amps
or
1_FLUX = 1.2E-5 // Photodiode current expressed in Amps

Regarding the CPA image file : if images have been acquired with PRISM, the previous figures are entered automatically into the CPA file header.

A reference offset/Bias image (resulting from a median stack of 10 offset/bias images) is mandatory, also the integration time must be limited in a way that the CCD dark current remains negligible.

Once having entered all the calibration files in the software dialog box, the analysis window X1,X2,Y1,Y2 must be chosen in the way that it must not have any serious defects (black hole, bright pixels).

Conversion factor must have been measured previously (see method 1 or 2).

Distance during calibration/measurements allows the reference photodiode not to be at the same distance as the CCD, and to apply a 1/d^2 correction. This correct for few centimeters effects.

Results :

This is the console output results, for each FITS files, it yields to :

Wavelength in nm ; Flux in Amps ; Exposure in sec ; Count values in e-
Filename         Wavelength  Flux       Exposure  Mean    Stddev.Rms  Median  Mean-Median
QE0002.fits      320         1.749E-10  180       21400   484.08      21400   -0.051972
QE0034.fits      340         4.754E-10  180       60662   1281.8      60678   -15.768
QE0004.fits      360         1.0234E-9  79.523    60965   1260.3      60976   -11.264
QE0032.fits      380         2.0072E-9  36.67     60579   832.35      60568   10.537
Qe0006.fits      400         3.5871E-9  20.472    60341   578.48      60342   -1.3613
QE0030.fits      450         8.4612E-9  9.223     60576   473.26      60582   -6.0853
QE0008.fits      500         1.1307E-8  7.248     60050   462.21      60052   -2.3795
QE0028.fits      550         1.3328E-8  6.904     64220   478.24      64226   -5.6408
QE0010.fits      600         1.4012E-8  6.438     59948   446.82      59952   -4.0484
QE0026.fits      650         1.3279E-8  7.296     59910   442.79      59914   -4.2144
QE0012.fits      700         1.1196E-8  9.48      59680   450.23      59686   -5.5382
QE0024.fits      750         8.4697E-9  14.39     59830   481.27      59838   -8.0172
QE0014.fits      800         5.4537E-9  27.831    59990   533.66      60004   -13.601
QE0022.fits      850         5.9775E-9  33.177    59951   508.76      59960   -9.061
QE0016.fits      900         5.1913E-9  58.056    59327   941.36      59162   165.3
Qe0020.fits      950         1.2662E-8  49.111    61606   2471.5      62156   -549.94
QE0018.fits      1000        1.0568E-8  171.99    62739   3667.6      64178   -1438.6
QE0036.fits      1100        1.7114E-9  180       1006    82.472      994     12.022

Image #1 Bandwith :5
PhotoDiode calibration Bandwith :4
Filename         Wav.  PRNU%      QE%       FDio/FDio.cal   Ph/pix/sec e-/pix/sec  %Wind
QE0002.fits      320   2.262      61.065    0.83684         207.12     118.89      94
QE0034.fits      340   2.1125     69.312    0.87389         501.4      337.1       97
QE0004.fits      360   2.0669     73.139    0.91787         1069.8     766.77      98
QE0032.fits      380   1.3742     85.51     0.94499         1971       1651.7      98
Qe0006.fits      400   0.95867    93.401    0.98385         3187.7     2947.5      99
QE0030.fits      450   0.7812     95.421    1.0656          6953.3     6568.6      99
QE0008.fits      500   0.76969    94.847    1.1078          8823.7     8285.3      99
QE0028.fits      550   0.74462    91.842    1.1589          10170      9302.7      99.6
QE0010.fits      600   0.7453     88.622    1.1935          10661      9312.2      98.56
QE0026.fits      650   0.73904    86.151    1.2239          9913.7     8211.9      96.15
QE0012.fits      700   0.75434    78.263    1.2496          8687.5     6296        92.6
QE0024.fits      750   0.8043     69.666    1.2698          6714.2     4158.3      88.9
QE0014.fits      800   0.88938    56.584    1.2911          4473.7     2156        85.17
QE0022.fits      850   0.8485     44.878    1.3225          4939.4     1807.3      81.53
QE0016.fits      900   1.5912     30.209    1.3411          4284.7     1019.1      78.73
QE0020.fits      950   3.9762     14.732    1.4724          11264      1265.6      76.27
QE0018.fits      1000  5.7147     5.0888    1.3814          9821.7     373.16      74.66
QE0036.fits      1100  8.297      0.10033   1.3982          7613.2     5.5222      72.3

Le logiciel renvoie une courbe de rendement quantique (rendement de rêve...) :

et aussi une courbe d'uniformité de réponse photonique :

Voici quelques images à différentes longueurs d'ondes d'une MEME zone (bande passante de 5nm et CCD EEV44 aminci ) : à 320 nm (uniformite dégradée par l'implentation P+ d'un CCD apres son amincissement) :

à 650 nm (très bonne uniformité) :

à 950 nm (belles franges ? non ) :

Methods used :

The method employed here for QE is straightforward and based on the ratio between the amount of photon falling to the CCD surface for a given wavelength and the effective amount of photoelectrons read out at the output of the CCD. This is achieved by all the data coming from the calibration text files and figures found in the image file header, such as pixel size, exposure time, flux, wavelength, etc etc ...

The PRNU computes the histogram of the selected (X1,X2,Y1,Y2) area, and provide two figures : the intensities at 5% and 95% percentile. Let's call those figures Int1 and Int2, the PRNU is (Int2-Int1)/(Int1+Int2)*100%

Focntion script associée :
GetQE

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Test CCD / Facteur de conversion

> Analyse > Test CCD > Facteur de conversion

Lancement : Menu [Analyse] > [Test/Caractérisation de CCD] > [Facteur de conversion (multifenêtre)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Evaluer le facteur de conversion d'une caméra CCD à partir de plusieurs fichiers.

This method is very useful for computing the conversion factor during system development because it is fast and the accuracy is pretty good.

It just needs two biases and two flat field images. It performs conversion factor measurement using NxM sub windows to avoid any problems due to local defects. PRISM asks for the amount of windows that is needed across the X and Y axis. Note that subwindows less than 50x50 pixels can lead to false results, so for a 1x2K CCD for instance, set 10 windows for the X direction and 20 for the Y direction. To remove any prescan/overscan area set the X1,Y1,X2,Y2 windows so as to avoid them. then select the files.

Console output:
Loading :Flat1.fits
Loading :Flat2.fits
Loading :Bias1.fits
Loading :Bias2.fits
For all the windows (540) the results are the following :
window 1=4.49799e-/ADU X1=120 Y1=50 X2=158 Y2=78
window 2=4.11412e-/ADU X1=120 Y1=79 X2=158 Y2=107
window 3=4.31269e-/ADU X1=120 Y1=108 X2=158 Y2=136
window 4=4.14792e-/ADU X1=120 Y1=137 X2=158 Y2=165
window 5=4.0549e-/ADU X1=120 Y1=166 X2=158 Y2=194
..........
window 536=4.45689e-/ADU X1=1836 Y1=253 X2=1874 Y2=281
window 537=4.55087e-/ADU X1=1836 Y1=282 X2=1874 Y2=310
window 538=4.23658e-/ADU X1=1836 Y1=311 X2=1874 Y2=339
window 539=4.01395e-/ADU X1=1836 Y1=340 X2=1874 Y2=368
window 540=4.50764e-/ADU X1=1836 Y1=369 X2=1874 Y2=397
Conversion Factor=4.3775e-/ADU ± 0.012608 for 3457.054ADU
RMS noise =7.0774e- ± 0.092687

Method used :
Note that the algorithm supports flats fields that have different levels of illuminations, tests have been carried out with flats having means with factor of 50 between the two images and the feature passed it pretty well ! This method subtracts the biases from the flat field images, divides the two previous flat images and computes the RMS value (named N here) and the mean Signal for each window. Then computes the D=2*S/N^2 figure, from D, the bias noise is removed and yields to the conversion factor. The corrections due to the different flat field levels are performed by the software, but not mentioned in this explanation (to remain clear).

Focntion script associée :
GetConvertFactor

Images de test :
Images de test

Conditions d'activation du menu :
Aucune

Décembre 2010


Analyse / Modélisation couronne solaire

> Analyse > Modélisation couronne solaire

Lancement : Menu [Analyse] > [Modélisations photométriques] > [Couronne solaire : totalité eclipse]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la modélisation de la couronne solaire lors d'une éclipse totale de Soleil.

A l'ouverture, la fenêtre de renseignement est la suivante :

Un exemple de fenêtre à compléter à l'ouverture

De façon à prendre en compte les cas d'éclipses annulaires ou totales, il peut être défini des valeurs différentes quant au centre du Soleil et celui de la Lune. Il en est de même pour les rayons. L'exemple des paramètres ci-dessus est utilisé pour la totalité d'une éclipse où le diamètre lunaire est indentique au diamètre solaire.

Le résultat de la fonction modélise la couronne solaire.

Type d'images acceptées :
Images monochromes en 16 ou 32 bits

Fonction script associée :
Aucune

Image de test :
Etoile focalisée

Conditions d'activation du menu :
Qu'une image soit ouverte.

Février 2008


Analyse / Planisphère Planétaire

> Analyse > Planisphère Planétaire

Lancement : Menu [Analyse] > [Planisphère Planétaire]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Cette fonction permet de générer automatiquement un planisphère planétaire, c'est à dire une carte d'une planète à partir de plusieurs images prises à intervalles réguliers.
Pour la planète Jupiter, il faut disposer d'images prises sur deux nuits consécutives avec des intervalles réguliers d'un quart d'heure à une heure.
La planète Mars ayant une période de rotation proche de 24 heures, il faut prendre des photos pendant plusieurs semaines pour pouvoir générer son planisphère. Heureusement, les détails visibles à sa surface évoluent beaucoup plus lentement que les formations nuageuses de Jupiter.

Cette fonction à été programmée grâce aux conseils de Gino Farroni, coordinateur des observateurs de Jupiter de la Société Astronomique de France.

Nous allons illustrer l'utilisation de cette fonction pour générer une partie du planisphère de Jupiter à partir d'une série de 7 magnifiques images en couleurs prises par Antonio Cidadao les nuits du 14 et du 15 octobre 1999. Voici la première image de la série :

Au lancement de la fonction "Planisphère planétaire" la fenêtre suivante apparaît :

Cliquez sur le bouton "..." pour sélectionner vos images :

Puis cliquez sur OK. La première image de la série apparaît alors dans la fenêtre de projection :

Si vous avez cliqué sur la case à cocher "Automatique" dans la fenêtre précédente, tous les autres calculs seront automatiques. Vous n'avez plus qu'à attendre l'affichage des planisphères.
Dans le cas contraire vous aurez à régler la projection de chaque image de la série.

Voici le résultat obtenu pour la série d'Antonio Cidadao prise en exemple :

Planisphère W1

Planisphère W2

Vous remarquez que le décalage du système W1 par rapport au système W2 à été corrigé sur le planisphère en W2. Ce décalage est dû aux différences de vitesse de rotation des deux systèmes.

Fonctions scripts :
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Janvier 2008


Analyse / Importer un spectre de données UVES

> Spectroscopie > Importer un spectre de données UVES

Lancement : Menu [Analyse] > [Spectroscopie] > [Importer un spectre de données UVES]

Touche de raccourci : [Ctrl] + [Alt] + [U]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Créer dans PRiSM une image correspondant à un fichier UVES provenant de l'ESO.

Cette fonction permet d'importer un spectre de données TXT provenant de la base de données UVES. Un exemple d'un tel fichier est fourni en bas de page.

Il est rappelé ici la marche à suivre de façon à importer depuis le site de l'ESO un fichier de données UVES.

Les fichiers de données UVES sont formatés d'une certaine manière :

PRiSM permet de lire ces fichiers et de le transformer en image spectrale. Cette image sera nécessaire pour déterminer la réponse instrumentale de l'installation.
Sont sauvegardés dans le même répertoire que le fichier texte UVES, l'image crée par le logiciel aux formats CPA et FITS1D (nom_PRiSM.cpa et nom_PRiSM.fits),

Exemple d'image obtenue

ainsi que le fichier texte TXT formaté pour être lisible directement depuis le logiciel (nom_PRiSM.txt).

Enfin, il est rappelé que ce traitement est essentiel afin de diviser un spectre de référence de son instrument par ce spectre sorti de la base de référence UVES.
De façon à déterminer la réponse instrumentale, l'étape suivante consiste alors en cette division ...

Fonction(s) Script associée(s):
Aucune pour le moment

Fichier exemple :
Spectre données UVES de Régulus de 6500 à 6700 Å

Version Mai 2007


Traitement / Diviser un spectre par un autre

> Traitement > Diviser un spectre par un autre

Lancement : Menu [Traitement] > [Spectroscopie] > [Créer un fichier de réponse instrumentale]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de créer un spectre de réponse instrumentale. Les renseignements à fournir sont les suivants :

Les 3 renseignements à compléter La fenêtre complétée
  • Indiquer le spectre de référence de niveau 1b prise avec l'instrument
  • Indiquer le spectre de référence ESO UVES; ce fichier texte ne doit pas être traité précédemment par PRiSM. La façon d'obtenir ce spectre est décrit ici.
  • Le filtre passe-bas permet de lisser la réponse obtenue. Une puissance d'environ 15 donne de bons résultats.

Le répertoire de création de fichier est celui de l'image de référence de niveau 1b. Il est créé une suite de fichiers UVES lisibles directement par PRiSM, au nom générique du fichier UVES suivi de "_PRiSM.XXX" avec XXX = CPA ou FITS ou TXT pour un graphe. Le fichier de réponse instrumentale porte le nom générique de l'objet suivi de "_RI". Il est créé au format CPA, FITS ou JPG. Un fichier texte de données TXT est aussi créé afin de générer un graphe comme celui ci-dessous :

Un exemple de réponse instrumentale

Fonction(s) Script associée(s):
Aucune pour le moment

Prérequis :
Récupérer un fichier UVES de référence de l'objet correspondant.

Type d'images acceptées :
Images monochromes FITS/CPA et fichier UVES non traité

Image de test :
Images

Mars 2008


Analyse / Création d'un spectre 1D à partir d'une série

> Analyse > Création d'un spectre 1D à partir d'une série

Lancement : Menu [Analyse] > [Spectroscopie] > [Spectre 1D à partir d'une série (--> niveau 0c)]

Touche de raccourci : [Ctrl] + [Alt] + [S]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Obtenir une image spectrale à partir d'une série de spectres élémentaires.

Cette fonction permet d'obtenir un spectre 1D corrigé de toute abération géométrique à partir d'une série de spectres élémentaires.

Prérequis IMPORTANT : Les images des spectres élémentaires doivent être prétraitées des noirs, offsets, flats et éventuel fichier cosmétique. Ceci s'obtient à partir des onglets (1), (2) et (8) du prétraitement automatique. Les images des lampes de calibration, elles, n'ont pas besoin d'être prétraitées d'autant que la durée de la pose est très faible.
Les images élémentaires devront être débarassées, pour le moment manuellement, des points cosmiques importants situés sur le spectre.
Pour éviter des problèmes de saturation lors de l'addition des spectres élémentaires, il est fortement conseillé d'acquérir les images au format 32 bits ou de les transformer du format entier 16 bits au format réel 32 bits si l'acquisition a eu lieu au format entier 16 bits. Pour de plus amples explications, on se réfèrera à la partie concernée.

L'étude proposée va se faire à partir de la série n°1 d'images de test (prétraitées) et dont l'image n°3 a été débarassée d'un cosmique important sur le spectre lui-même. Le résultat est aussi fourni en bas de page.

La fenêtre de traitement apparaît de la façon suivante :

Le menu proposé; cliquer sur une partie pour plus d'explication

Avant toute chose, les niveaux de traitement ont été définis sur le site ARAS de façon à uniformiser tous les spectres créés par différents logiciels : site de définition.

I. Niveau 0a : c'est la simple addition des spectres élémentaires. Ce niveau ne renseigne pas sur grand chose ...

II. 1) Niveau 0b / Correction TILT et SMILE : cette correction géométrique est "obligatoire" et à préférer choisir complètement automatique. Cette phase sera d'autant plus longue en temps que l'image aura une taille en hauteur importante. Cette série de correction est à la base du niveau défini 0b.

Pour les utilisateurs avertis et dans le cas d'échec des traitements automatiques, il est possible de fixer partiellement ou entièrement les valeurs de correction TILT et SMILE :

Les images de test fournies peuvent être corrigées de façon automatique comme de façon manuelle (en ayant pris soin de déterminer les paramètres de correction à partir des menus [Traitements] > [Spectroscopie].

La correction du tilt consiste à corriger le défaut d'horizontalité du spectre. Cette correction est effectué au même titre sur toutes le simages élémentaires ainsi que sur le néon de référence. Cette correction est accessible indépendamment sur une image à partir du menu de traitement pour sa mesure et sa correction.
La correction du smile consiste à redresser les raies de référence de la lampe de calibration et à les rendre verticales.

La correction du smile
La correction du smile par rapport à la ligne neutre

Ainsi, une fois les spectres corrigés de leur orientation non horizontale, les raies seront redressées pour être rendues verticales quelque soit la position du spectre élémentaire sur l'image. Cette dernière correction sera effectuée sur les spectres élémentaires et sur le néon de référence. Ce dernier sera alors sauvegardé sous son nom + "_0b" au format CPA. Ces opérations de verticalité des raies peuvent être obtenues séparemment à partir des menus de transformations sur la mesure et la correction du slant ainsi que la correction du smile. Pour les images exemples, les rensignements fournis sont les suivants :

Niveau 0b : Traitement géométrique :
Nova-1 : Position verticale du spectre-> Y1=145 Y2=178
Tilt de 0.37 ° trouvé
Nova-1 : Fichier dé-tilté !
Nova-2 : Fichier dé-tilté !
Nova-3 : Fichier dé-tilté !
Nova-4 : Fichier dé-tilté !
Nova-5 : Fichier dé-tilté !
Ficher néon chargé : C:\Temp\Nova Cygnus\Neon_Avant.cpa
Ligne neutre Y=3 -> raie utilisée sur le néon X=1112
Nova-1 : Fichier corrigé du "Slant" et du "Smile"
Nova-2 : Fichier corrigé du "Slant" et du "Smile"
Nova-3 : Fichier corrigé du "Slant" et du "Smile"
Nova-4 : Fichier corrigé du "Slant" et du "Smile"
Nova-5 : Fichier corrigé du "Slant" et du "Smile"

Niveau 0b : Registration horizontale :
Ficher néon chargé : C:\Temp\Nova Cygnus\Neon_Apres.cpa
Ficher néon chargé : C:\Temp\Nova Cygnus\Neon_Avant.cpa
Décalage temporel de calibration en X (Pixels) : 2.72
Nova-1 -> Décalage temporel en X (Pixels) : 0.14
Nova-2 -> Décalage temporel en X (Pixels) : 0.66
Nova-3 -> Décalage temporel en X (Pixels) : 1.17
Nova-4 -> Décalage temporel en X (Pixels) : 1.68
Nova-5 -> Décalage temporel en X (Pixels) : 2.19
Décalage temporel de calibration en X (Pixels) de l'image de calibration : 0.00

II. 2) Niveau 0b / Registration verticale : Le principe utilisé est le suivant :
corrections à apporter …
Un exemple de coupe verticale d’un spectre élémentaire

Lors de l'acquisition des spectres élémentaires, notamment lorsque l'autoguidage n'est pas lancé, chaque spectre élémentaire n'est pas nécessairement "centré" sur la même ligne. Lors d'une addition future, le rapport Signal/bruit sera alors d'autant plus diminué que le spectre sera étendu. En cochant cette case, PRiSM calculera, pour chacun des spectres élémentaires, le décalage de la ligne du spectre de plus forte intensité par rapport à une ligne de référence. Cette ligne de référence est la ligne de plus forte intensité pour le premier spectre élémentaire fourni. Les zones de spectres sont déterminées automatiquement et représentées par les valeurs de Y1 et Y2 :

La signification des valeurs de Y1 et Y2

Pour exemple :

Niveau 0b : Registration verticale :
Nova-1 -> Décalage vertical en Y (Pixels) : Y1=150  Y2=177   Yref=163.50
Nova-2 -> Décalage vertical en Y (Pixels) : Y1=172  Y2=204   DY=24.50
Nova-3 -> Décalage vertical en Y (Pixels) : Y1=196  Y2=230   DY=49.50
Nova-4 -> Décalage vertical en Y (Pixels) : Y1=222  Y2=246   DY=70.50
Nova-5 -> Décalage vertical en Y (Pixels) : Y1=242  Y2=270   DY=92.50

Il ne faut bien sûr pas utiliser cette fonction dans le cas de spectre d'un objet étendu. Cette correction reste donc optionnelle.

II. 3) Niveau 0b / Registration horizontale : L'expérience prouve qu'il existe une dérive de la longueur d'onde des centres des pixels de la caméra. Cette dérive temporelle dépend de beaucoup de paramètres mais reste quasi linéaire dans le temps. L'idée est donc de faire un spectre de lampe d'étalonnage avant la série de pose et un autre après la série. En se répérant par rapport à une raie bien précise de la lampe de calibration, il est alors possible de connaître l'évolution temporelle de la longueur d'onde considérée. Connaissant la date de pose de chacune des images, ceci permet d'effectuer une translation pour ces images. La translation a été choisie car on considère que tous les pixels évoluant de la même manière doivent être identiquement décalés. Le résultat obtenu est le suivant :

Niveau 0b : Registration horizontale :
Ficher néon chargé : C:\Temp\Nova Cygnus\Neon_Apres.cpa
Ficher néon chargé : C:\Temp\Nova Cygnus\Neon_Avant.cpa
Décalage temporel de calibration en X (Pixels) : 2.72
Nova-1 -> Décalage temporel en X (Pixels) : 0.14
Nova-2 -> Décalage temporel en X (Pixels) : 0.66
Nova-3 -> Décalage temporel en X (Pixels) : 1.17
Nova-4 -> Décalage temporel en X (Pixels) : 1.68
Nova-5 -> Décalage temporel en X (Pixels) : 2.19
Décalage temporel de calibration en X (Pixels) de l'image de calibration : 0.00

Cette correction reste optionnelle car il faut avoir pris deux images de la lampe de calibration à deux moments bien distincts.

Pour terminer le traitement, Le fond de ciel est retiré à l'image et les valeurs Y1 et Y2 du spectre résultant sont mémorisées.

Image résultat 0B, spectre entre Y1=142 et Y2=186, fond de ciel 0.00 ADU

III. Niveau 0c :Le niveau 0c consiste à fournir une image-spectre où chaque ligne est identique et une coupe horizontale représente le spectre à une dimension. Cette image a une hauteur de 20 pixels et consiste en ce qui est appelé "un binning optimal" du niveau 0b.

Niveau 0c :
Image résultat 0C, Y1=142 et Y2=186, Centre moyen Y=166, largeur retenue 20 ligne(s).

IV. Fichiers de sortie :Il existe deux répertoires de sauvegardes créés dans le répertoire contenant les images spectrales élémentaires :

  • Le répertoire "Preprocess" : Dans ce répertoire sont sauvegardés chaque spectre élémentaire corrigés géométriquement et donc de niveau 0b.
    Produit image sauvé : C:\Temp\Nova Cygnus\preprocess\Nova-1_0b.cpa
Produit image sauvé : C:\Temp\Nova Cygnus\preprocess\Nova-2_0b.cpa
Produit image sauvé : C:\Temp\Nova Cygnus\preprocess\Nova-3_0b.cpa
Produit image sauvé : C:\Temp\Nova Cygnus\preprocess\Nova-4_0b.cpa
Produit image sauvé : C:\Temp\Nova Cygnus\preprocess\Nova-5_0b.cpa
  • Le répertoire "Results" : Dans ce répertoire sont sauvegardés tous les fichiers résultants du traitement. En ce qui concerne le spectre lui-même, on y rencontre les images résultantes de niveau 0a, 0b et 0c. Pour le dernier niveau, la sauvegarde est au format CPA et au format FITS 1D (sans les mots-clés de calibration). Les images de la lampe de calibration sont également sauvegardées en ce qui concerne le niveau 0b (corrections géométriques) et le niveau 0c (spectre 1D) tant au format CPA qu'au format FITS 1D.
    Produit image sauvé : C:\Temp\Nova Cygnus\results\Nova_0a.cpa
Produit image sauvé : C:\Temp\Nova Cygnus\results\Nova_0b.cpa
Produit image sauvé : C:\Temp\Nova Cygnus\results\Nova_0c.cpa

Pour la calibration, il sera réutilisé l'image de niveau 0c ainsi que l'image du néon corrigée géométriquement (de niveau 0b) au format CPA (sauvegardée dans le répertoire "Results").
La date de l'image finale est celle de l'image de référence. Le temps de pose est le cuml des temps de pose de chacune des images.

Passage au niveau 1b --->

Fonction(s) Script associée(s):
Aucune pour le moment

Prérequis :
Voir début de page

Séries d'images de test :
Série 1 (Nova Cygnus 2007) (22,8 Mo) --> Résultat (12,3 Mo)
Série 2 (64 Ser) (15,5 Mo) --> Résultat (8,3 Mo)

Condition d'activation :
Images au format CPA ou FITS, codées en entiers ou réels.

Version Février 2008


Analyse / Calibration d'un spectre 1D

> Analyse > Calibration d'un spectre 1D

Lancement : Menu [Analyse] > [Spectroscopie] > [Calibration spectrale automatique (--> niveau 1b)]

Touche de raccourci : [Ctrl] + [Alt] + [C]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la calibration d'une image spectroscopique.

Cette fonction permet de calibrer un profil spectral. Il est nécessaire d'avoir ce profil spectral disponible (la fonction ne sera disponible que si une image est ouverte). Il faut également avoir une image des raies de la lampe de calibration corrigée des mêmes effets géométriques que ne l'a été l'image profil spectral à calibrer. Le but est de trouver une relation pour l'image de la forme " Lambda = a0 + a1.X + a2.X2 + a3.X3 + a4.X4 " linéarisée ensuite en " Lambda = a0 + a'1.X "

Prérequis IMPORTANT : les images doivent être prétraitées ET corrigées géométriquement, que ce soit l'image à calibrer ou l'image de calibration. Voir la partie consacrée à cet effet.

Le traitement est destiné à atteindre le niveau de traitement 1b (pour la description des niveaux). L'étude proposée va se faire à partir de la série n°1 d'images de test. Le résultat est aussi fourni en bas de page.

Lors de l'ouverture du menu depuis une image, l'apparence est la suivante :

La fenêtre d'intialisation; Cliquer pour avoir de l'aide
  1. Fichier de la lampe de calibration :

Indiquer le chemin où situer le fichier de calibration associé au fichier image spectre de niveau 0c. Ce fichier a du être corrigé géométriquement de manière strictement identique aux images qui ont permises d'obtenir l'image à calibrer.

  2. Raies de calibration :
  • A partir d'un fichier Texte (fichier de calibration) :
    Le bouton radio correspondant doit être coché et le chemin du fichier texte contenant les positions des raies de calibration doit être indiqué. Ce fichier est un fichier texte où chaque ligne est composée des deux valeurs qui s'affichent dans le tableau : la première valeur est la coordonnée horizontale approximative de la raie reconnue (par l'utilisateur) de la lampe spectrale et la deuxième sa longueur d'onde correspondante. Cette coordonnée n'étant qu'approximative, pour plusieurs séries spectrales différentes dans la nuit, il n'est pas nécessaire de changer ce fichier même si les raies du néon ont été très légèrement décalées. Un fichier exemple est fourni sous le nom "Nova_Cyg_03_2007_NEON.txt", à partir d'un des fichiers téléchargeables ci-dessous ...
  • Raies déterminées automatiquement :
    Les renseignements de l'entête "Spectro / Longueur d'onde X = 1" et "Spectro / Résolution spectrale" doivent être complétés. Ces dernières sont d'ailleurs rappelées au bas du panel des raies de calibration. Si ces dernières restent à zéro, il faut alors absolument remplir ces données avant de lancer la calibration
Calibration avec les raies dans un fichier texte | Calibration avec recherche automatique des raies - L'entête doit être complétée
Calibration avec les raies dans un fichier texte (cas de la Série n°1 d'images de test) | Calibration avec recherche automatique des raies - L'entête doit être complétée (cas de la Série n°2 d'images de test)
  3. Renseignements spectro de l'entête de l'image :

Les renseignements fournis dans ce panel sont obtenus depuis l'entête de l'image à calibrer. Ils seront utilisés pour enregistrer l'image au format FITS 1D (BeSS). Dans le cas où certains de ces renseignements sont erronés, il faut "annuler" la calibration et les compléter dans l'entête de l'image avant d'ouvrir à nouveau la calibration. (cas des 2 séries)

  4. Utiliser les coefficients de calibration d'une autre image :

Ce panel est utile si l'utilisateur désire utiliser les coefficients de calibration d'une autre image. Ceci peut être rendu nécessaire si une seule raie est présente dans l'image de la lampe de calibration.

Une seule raie de calibration est utilisée --> il faut utiliser une autre image pour déterminer tous les coefficients

Il est alors possible de calibrer l'image mais seulement si une image obtenue avec le même télescope + même spectrographe a été obtenue dans des conditions similaires. Il faut alors indiquer le chemin où trouver l'image contenant les coefficients de calibration à utiliser. La largeur des pixels est aussi mémorisée.
Cette partie n'empêche pas de devoir indiquer au logiciel le chemin de l'image de la lampe de calibration.

Dans le cas de la Série n°1 + usage des coefficients ..., on utilisera le spectre non linéaire d'une autre image afin de calibrer le spectre présent où une seule raie a été repérée.

Utiliser les coefficients de calibration d'une autre image
  5. Cases à cocher :
  1. Affiner la calibration à partir des raies de l'eau :

Attention : comme indiqué dans la fenêtre, cette calibration supplémentaire n'intervient qu'entre 6408 et 6628 Angströms. Elle devient utile lorsque la dispersion du spectroscope est faible (bien inférieure à 1 Angström par Pixel).
Après avoir effectué une première calibration à la lampe spectrale, PRiSM utilise les raies de l'eau les plus intenses dans ce domaine de longueurs d'onde pour affiner la calibration. Le résultat est alors très précis et ne tient plus compte des déformations mécaniques du spectroscope durant les prises d'images.
Les raies de l'eau utilisées sont les suivantes avec leurs intensités relatives :

(Wavelength:6472.5   ; Intensity : 0.23   ), (Wavelength:6475.14  ; Intensity : 0.455  ),
(Wavelength:6475.81  ; Intensity : 0.45   ), (Wavelength:6480.07  ; Intensity : 0.3625 ),
(Wavelength:6483.24  ; Intensity : 0.37   ), (Wavelength:6483.86  ; Intensity : 0.31   ),
(Wavelength:6490.79  ; Intensity : 0.375  ), (Wavelength:6492.92  ; Intensity : 0.2725 ),
(Wavelength:6495.86  ; Intensity : 0.34   ), (Wavelength:6508.59  ; Intensity : 0.245  ),
(Wavelength:6514.74  ; Intensity : 0.53   ), (Wavelength:6516.57  ; Intensity : 0.85   ),
(Wavelength:6519.45  ; Intensity : 0.33   ), (Wavelength:6523.843 ; Intensity : 0.30   ),
(Wavelength:6532.359 ; Intensity : 0.3475 ), (Wavelength:6543.907 ; Intensity : 0.515  ),
(Wavelength:6552.629 ; Intensity : 0.45   ), (Wavelength:6557.171 ; Intensity : 0.251  ),
(Wavelength:6564.196 ; Intensity : 0.271  ), (Wavelength:6572.072 ; Intensity : 0.3375 ),
(Wavelength:6574.847 ; Intensity : 0.489  )

Afin de déterminer ces raies, PRiSM soustrait l'allure du spectre au spectre lui-même. Les raies de faible FWHM restent alors. Ceci permet à PRiSM de mieux repérer automatiquement les raies de l'eau :

Les raies de l'eau sont sur ce graphe
  2. Afficher le spectre de niveau 1b :

Pour afficher immédiatement le résultat final après calibration. L'entête est alors modifiée.

  3. Insérer du texte dans le spectre graphique :

Pour insérer le nombre de renseignements nécessaires à la publication de l'image. Voir les images résultats de type JPG fournies dans les séries d'images résultantes.

Renseignements sur le spectre graphique
  4. Enregistrer FITS 1D à partir du nom courant :

Choix, lors de l'enregistrement du spectre au format FITS 1D, d'utiliser le mot clé "BSS_NAME" ou les mots-clés "RA" et "DEC" indiquant seulement les coordonnées connues du centre de l'image, tirés de l'entête de cette dernière.

  6. Résultats du traitement :

Dans le répertoire "Results" sont incluses les images de niveau 1c, au format CPA, FITS 1D et en données au format TXT. Ces images se terminent par le suffixe "1c" et elles sont linéaires (coefficients a2, a3 et a4 nuls). Il est sauvegardé également les images non linéarisée (détermination des coefficients seuls) mais ces images se terminent avec le suffixe "notlinear_1b". Ce dernier cas a lieu avec des images au format CPA ainsi que pour les fichiers de données au format TXT. Pour toutes ces images, il est indiqué dans l'entête "Spectro" que la calibration a été effectuée ainsi que des commentaires essentiels dans l'entête "commentaires".

L'entête spectro complétée : la calibration a été effectuée L'entête commentaire

Passage au niveau 1c --->

Fonction(s) Script associée(s):
Aucune pour le moment

Prérequis :
Voir début de page

Séries d'images de test :
Série 1 + Néon associé (Nova Cygnus 2007) (12,3 Mo) --> Résultat sans correction raie H2O (0,46 Mo) et Résultat avec correction raie H2O (0,46 Mo)
Série 1 (12,3 Mo) + usage de coefficients d'une autre image calibrée de la série 2 (0.34 Mo)
Série 2 (64 Ser) (8,3 Mo) --> Résultat (0,40 Mo)

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Mai 2007


Analyse / Calibration d'un spectre 1D

> Analyse > Calibration d'un spectre 1D

Lancement : Menu [Analyse] > [Spectroscopie] > [Calibration spectrale manuelle (--> niveau 1b)]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Réaliser la calibration manuelle d'une image spectroscopique.

En construction

Fonction script associée :
Aucune

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version


Analyse / Diviser un spectre par la réponse instrumentale

> Analyse > Diviser un spectre par la réponse instrumentale

Lancement : Menu [Analyse] > [Spectroscopie] > [Diviser un spectre par la réponse instrumentale (--> niveau 1c)]

Touche de raccourci : [Ctrl] + [Alt] + [D]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de créer un spectre de niveau 1c à partir d'un spectre de niveau 1b (pour la description des niveaux). Pour cela, il est nécessaire de disposer du spectre de niveau 1b et de la réponse instrumentale de l'ensemble optique (voir les images de test au bas de la page)et les images doivent bien sûr être toutes deux calibrées en longueur d'onde ...
La réponse instrumentale peut être créée à partir du menu [Traitement] > [Spectroscopie] > [Créer un fichier de réponse instrumentale]. Il faut bien sûr que le spectre et la réponse ait une zone de longueur d'onde en commun et seule cette zone sera retenue au final.

A l'ouverture de la fonction, les marges extrêmes de longueur d'onde et l'échantillonnage sont indiqués :

La fenêtre à son ouverture

Il faut ouvrir le fichier de réponse instrumentale. Pour ce dernier, il est aussi indiqué les marges extrêmes de longueur d'onde et l'échantillonnage :

les marges extrêmes de longueur d'onde et l'échantillonnage

Il est possible de calculer la zone de longueurs d'onde en commun entre les deux spectres. Cette opération n'est pas nécessaire car elle se fait automatiquement lors de la création de la réponse instrumentale. Cependant, ces valeurs indiquent à l'utilisateur la zone retenue :

Calculer les longueurs d'onde extrêmes

Il est possible de normaliser la réponse de façon automatique ou par fenêtrage. Cependant, pour une réponse instrumentale, cette opération n'a que peu d'intérêt ... :

Une éventuelle normalisation

Des fichiers de niveau 1c sont créés dans le répertoire de celui de niveau 1b. Les formats retenus sont CPA, FITS et JPEG. Un fichier texte de valeurs en TXT est également créé.

Fonction(s) Script associée(s):
Aucune pour le moment

Type d'images acceptées :
Images monochromes FITS/CPA

Image de test :
Images

Conditions d'activation du menu :
Qu'une image soit ouverte.

Mars 2008


Les caméras CCD, CMOS, WEBCAM et APN supportées par PRiSM

Les caméras reconnues dans PRiSM sont les suivantes :

Caméras CCD | Win 95/98/Me | Win NT/2000/XP
Audine port parallèle | Oui | Oui(1)
Quickaudine | Oui | Oui
HISIS 22 (14/12 bits) | Oui | Non
SBIG STX et STL | Oui | Oui
Cookbook TC245 | Oui | Non
FIERA CCD Controler (ESO) | Oui | Oui
HISIS 24/44/33/42/63 | Oui | Non
MX5 StarLight Xpress | Oui | Non
MX916 StarLight Xpress | Oui | Non
Chungara tout CCD | Oui | Oui
DLL camera v1.0 (via CCD_Driver.dll) | Oui | Oui(2)
Webcams (AVICAP.DLL) | Oui | Oui

(1) Nécessite d'installer Portalk
(2) Si le driver qui accède aux ressources système est compatible Win 2000.

Il est proposé un driver de test pour permettre à chacun de s'entraîner sur PRiSM ...

Les différents points abordés seront les suivants :

  1. Le menu Caméra / Configuration
  2. Le menu "caméra".
    • Acquisition (Ancien Format); partie spéciale sur l'autoguidage.
    • Acquisition (Nouveau format)
    • Acquisition des Flats, Offsets et Noirs
  3. La DLL caméra
  4. L'autoguidage avec les caméras de type SBIG, Chungara
  5. L'autoguidage avec les WEBCAMS
Nov. 2005


Caméra / Configuration

> Caméra > Configuration Caméra

Lancement : Menu [Caméra] > [Configuration Caméra]

Au lancement de cette fonction, la fenêtre suivante apparaît, permettant de sélectionner le type de caméra utilisée :

Cette fonction permet de sélectionner le type de caméra CCD utilisée pour les acquisitions. Elle doit être lancée avant qu'une acquisition puisse être lancée.

Il est fortement conseillé de remplir avec soin l'entête de toutes les images qui seront saisies avec cette caméra. En effet, ces dernières figureront automatiquement dans les entêtes ce qui évite de saisir à nouveau ces données pour chaque image.

Dans cette entête se succèdent les onglets suivants :

  • Dans l'onglet "Caméra", on pourra saisir le facteur de conversion (électrons par ADU). les informations comme le nom de la caméra, la taille des pixels en X et Y sont maintenant déterminés automatiquement suivant la caméra sélectionnée.

  • L'onglet Telescope

    Dans l'onglet "Telescope", on pourra saisir les informations concernant l'instrumentation utilisée : Telescope, Nom de l'observateur, Focale de l'instrument, Diamètre de l'instrument. Le lieu d'observation est déterminé à partir de l'option du lieu d'observation par défaut. L'angle d'orientation entre l'axe des Y et le nord Celeste (entre 0° et 359°) ainsi que la direction du repère. Ces deux dernières informations sont très utiles pour les étalonnages astrométriques et photométriques ainsi que pour les rattrapages automatiques comme recentrage du télescope.
    Voir la page sur la définition de l'orientation du CCD.
    L'entête peut être entièremement rappatriée depuis les informations d'une image CCD (menu contextuel d'une image) ou seulement pour la focale, l'angle CCD et l'orientation du repère à l'aide d'un étalonnage astrométrique automatique.

    Les paramètres d'orientation dépendent de la position du tube par rapport à la monture pour les montures allemandes : ces paramètres peuvent être déclarés pour un côté de la monture. La correction se fera automatiquement pour l'autre côté du tube.
    Si l'option de gestion des miroirs par retournement est cochée, les 2 cases à cocher sur les miroirs seront prise en compte suivant l'orientation du tube. Ces paramètres servent aussi lors d'une observation automatique.

    La focale de l'instrument est particulièrement importante à remplir car ne pas remplir ce champ perdrait le bénéfice de beaucoup de fonctions de PRiSM.

  • Dans la zone "Filtres/Spectro", on pourra préciser les filtres utilisés ainsi que préciser la bande passante du filtre utilisé.
    Pour la partie spectro, des parties très utiles de l'entête de l'image doivent être complétées comme le nom du spectrographe utilisé, la résolution du réseau utilisé ainsi que les paramètres approximatifs de calibration.     		L'onglet Spectro

  • L'onglet Divers ! Enfin, une zone commentaire est prévue pour les commentaires sous forme de textes. De même, il est maintenant prévu dans la même zone une partie pour rajouter des paramètres sous forme de chiffres. Ces derniers sont accessibles facilement à partir de fonctions script.

  • L'icone [image] permet de sauvegarder les données de l'entête dans un fichier

  • L'icone [image] permet de récupérer des données d'entête précédemment sauvegardées.

Les informations placées dans l'entête peuvent être sauvegardées dans un fichier (cliquer sur le bouton)

Le type de caméra ainsi sélectionné est mémorisé dans la base de registre relative à PRiSM et il n'est donc pas nécessaire de le sélectionner à chaque nouvelle utilisation de PRiSM.
Les paramètres de base de liaison et autres sont à régler à l'avance pour éviter de devoir les ressaisir à chaque fois. C'est pourquoi le panel "Setup" dépend totalement du type de caméra sélectionné.

Remarque importante : Il est fortement conseillé, dès que possible, d'utiliser l'acquisition directe des images en réels. Lors de l'acquisition, les limites seront toujours imposées par le convertisseur du CCD mais lors du traitement, ceci permet d'éviter des traitements du style "normalisation" car la limite du format 32 bits ne pourra être atteinte. De plus, PRiSM gère parfaitement le format monochrome 32 bits, que ce soit pour le format CPA ou le format FITS.

Décembre 2010


Caméra / Activer panneau d'acquisition

> Caméra > Activer Panneau Acquisition Caméra (nouveau format)

Lancement : Menu [Caméra] > [Activer Panneau Acquisition Caméra]

Cette fonction permet de lancer les acquisitions d'images avec la caméra CCD; il est rappelé que cette page concerne la gestion des caméras supportant le nouveau panel d'acquisition : Maya 2000 Ethernet, Chungara, SBIG (tous modèles) et les caméras gérées au travers de la DLL CCD_Driver.dll.

Avant de pouvoir utiliser cette fonction, il faut définir le type de caméra, à l'aide de la fonction [Caméra] > [Configuration Caméra]

Au lancement de cette fonction, la fenêtre de choix de port de communication ne s'ouvre pas car complétée dans le "setup" de la caméra. En même temps que la connexion a lieu, une fenêtre de renseignements s'ouvre (exemple). Cette fenêtre sera complétée dès qu'une action sera effectuée à partir du panel d'acquisition de la caméra.

La fenêtre suivante s'ouvre alors :

La fenêtre d'acquisition à l'ouverture; cliquer pour aide Cliquer pour aide Cliquer pour aide

Deux onglets supérieurs permettent de choisir le capteur que l'utilisateur désire utiliser. Pour chaque capteur, il est possible de lancer les acquisitions d'images :

  • Le bouton [DéMARRER] pour lancer la pose. Dès que celle-ci est lancée, ce bouton devient [ABANDONNER] pour arrêter la pose à n'importe quel moment ou [STOP] pour arrêter la pose mais lire quand même la matrice. Dix secondes avant la fin de la pose, l'ordinateur émettra un bip sonore (bruit critique de WIN_XP) et aussi à la fin de la lecture de la matrice. Ce beep peut être supprimé à partir de l'onglet "Options".

  • Le champ "Pose" permet d'indiquer la durée de la pose, en secondes.

  • Les champs "Binning" (en X et en Y) permettent de définir le mode de binning utilisé. Si la case à cocher "lier" est cochée, le binning en X et en Y seront identiques.

  • Lorsqu'on réalise le pointage d'une étoile, il suffit d'appuyer sur le bouton [Pointage]. L'acquisition se met alors en temps de pose 2s et en binning 2x2. L'expérience montre que la solution ( 1s, bin 3x3 ) donne des résultats aussi correctes et le chargement des valeurs des pixels va plus vite ... Ces données peuvent se régler à partir de l'onglet Entête. Le bouton "Longue Pose" permet d'obtenir une pose de 300s avec un bin 1x1. Le réglage est cependant identique au précédent. Tous ces temps sont enregistrés dans l'éditeur de registre WINDOWS !

  • En cliquant sur "bouclage", on fait un nombre d'images en série correspondant à la donnée "nombre d'images". Le logiciel permet un délai entre le moment où on commence la pose et le moment où l'obturateur s'ouvre. C'est à l'observateur de définir cette variable. Initialement, celle-ci est à zéro. Ces fonctions peuvent être utilisées pour prendre par exemple trois images d'un même champ à des instants différents pour retrouver les astéroïdes présents sur l'image. On peut choisir une pose de 150 à 200s, un nombre de 3 images avec bouclage et un délai de 600s entre chaque pose. Pour se permettre une pose de 3 minutes sans autoguidage, il faut que la monture suive très bien ou que le système possède un autoguidage. Attention : PRiSM permet de faire l'autoguidage automatiquement entre chaque pose du bouclage. Le logiciel part du principe suivant : entre deux images, le télescope aura une dérive somme toute assez faible et le logiciel reprendra l'étoile de guidage initiale. On obtiendra automatiquement, au final, trois images de 300s prises chacune à 10 minutes d'intervalles et on aura pu faire autre chose pendant ce temps !

Attention : les onglets ci-dessous ne sont décrits qu'une seule fois. Cependant, ces paramètres peuvent être réglés indépendamment (y compris pour le guidage) pour chacun des capteurs d'imagerie et de guidage.

Onglet Fichier

L'onglet Fichier

Cet onglet rassemble les fonctions concernant la sauvegarde des images. Pour voir ce qui est visé dans la carte du ciel, aller à la partie correspondante.

  • Le bouton [image] permet de définir le répertoire d'enregistrement des images. A partir du bouton [Rep Nuit], il est également possible de définir automatiquement ce répertoire en fonction de la date, le répertoire contenant les images étant inclus dans le répertoire indiqué dans les options générales de PRiSM.

  • Le nom générique des images associé à l'index permet de construire le nom des images. Dans l'exemple ci-contre, les images seront enregistrées sous le nom N7300-0001.CPA, N7300-0002.CPA, etc. Les index seront toujours des index à 4 chiffres.

  • Si plusieurs fenêtres d'image sont ouvertes, on peut sélectionner celle dans laquelle l'image acquise sera visualisée

  • L'option sauvegarde automatique permet de lancer un enregistrement systématique des images après leur acquisition.

  • Le bouton [Sauver] se dégrise après chaque pose. Il permet de remplacer ponctuellement la sauvegarde automatique.

Après chaque enregistrement (en mode automatique ou non), l'index augmente d'une unité.

Onglet Caméra

L'onglet Caméra

Cet onglet rassemble les fonctions concernant le fonctionnement de l'obturateur et de la lecture du capteur. Il peut varier suivant la caméra utilisée (ici, caméra SBIG) :

  • La case à cocher "Garder l'obturateur fermé" permet de lancer des poses tout en maintenant l'obturateur fermé (par exemple pour la réalisation d'images de noir)

  • La case à cocher "Joue un son à la fin de la pose" permet de choisir de garder ou non le son à la fin de la pose !.

Onglet Fenêtrage

L'onglet fenêtrage

Cet onglet rassemble les fonctions permettant d'effectuer une acquisition sur une partie de la matrice CCD seulement.

  • Les champs "X1", "Y1" permettent de spécifier les coordonnées du pixel inférieur gauche de la zone d'acquisition

  • Les champs "X2" et "Y2" permettent de spécifier les coordonnées du pixel supérieur droit de la zone d'acquisition

  • Le bouton "Définir fenêtre" sur l'image permet de définir la zone d'acquisition directement sur l'image : un curseur apparaît sur l'image, il suffit alors de tracer le rectangle correspondant à la zone d'acquisition.

  • Les cases à cocher du bas de cet onglet permettent de limiter les acquisitions à des zones de la matrice de tailles prédéfinies et centrées sur la fenêtre de pleine trame.

Onglet Options

En mode vidéo ...

Cet onglet rassemble diverses options :

  • La case à cocher "Réécrire l'image après lecture" permet d'indiquer qu'à chaque acquisition, l'image lue écrasera l'image précédente (de façon à n'utiliser qu'une fenêtre pour la visualisation des images successives).

  • Les cases à cocher "Miroir X" et "Miroir Y" permettent de réaliser un miroir sur l'axe X ou l'axe Y pour chaque image acquise

  • La case à cocher "Rotation de 90°" permet d'effectuer un quart de tour à l'image juste après lecture.

  • La case à cocher "Grille sur l'image" permet de faire apparaître une grille sur l'image juste après lecture

Onglet Guidage

Il est à noter que cet onglet peut être utilisé à partir du capteur principal ou du capteur de guidage. La calibration sera donc réalisé avec le capteur principal ou de guidage, celui à partir duquel l'onglet sera ouvert. Ceci permet d'élargir l'autoguidage aux caméras qui ont un unique capteur et serviront donc alors uniquement de caméra de guidage ainsi qu'aux caméras de type webcams.

Les paramètres de calibration

Ci-dessus, le guidage est pris en charge par les relais de la caméra SBIG.

Le guidage peut se faire avec chacun des capteurs.
Les deux calibrations sont donc indépendantes.

Avant de démarrer le guidage, il est nécessaire de calibrer l'instrument sauf si ce dernier n'a pas changé depuis la dernière calibration.

La caméra doit être orientée de telle façon qu'un mouvement sur chacun des axes ne soit quasiment détecté que suivant X OU Y.

La calibration ne pourra être effectuée par l'AO que si ce dernier a été déclaré dans la configuration de la caméra SBIG :

Déclarer l'AO de SBIG

Il faut d'abord lancer la calibration. La fenêtre des paramètres de calibration ci-contre apparaît alors.

Le dispositif de guidage est indiqué. Pour l'aide, les saisies d'écran ont été effectuées avec le dispositif de simulation ... ce qui est indiqué. Les autres dispositifs sont :

  • soit le télescope : système complet (type LX200 ou MCMT), ASCOM ou par DLL. Dans ce dernier cas, la fonction "PulseGuideDevice_DLL" doit être complétée de telle façon à permettre un autoguidage. De plus, il ne faut pas cocher alors "Ne pas utiliser les possibilités d'autoguidage du télescope" lors de la configuration de l'instrument. Ce point est signalé lors du lancement du télescope :

    Ce principe est obligatoire pour les caméras n'ayant pas de relais type SBIG.

  • Soit la monture est directement cablée pour l'usage des relais des caméras SBIG. Dans ce cas, la caméra SBIG doit déjà être activée avant de vouloir lancer la calibration. Si l'utilisateur utilise un instrument de pointage en plus de la caméra, la case "Ne pas utiliser les capacités de pointage" doit être cochée. A la liaison avec le télescope, il est indiqué le type d'ordre utilisé :

Delta actuel : Les rattrapages futurs en ascension droite dépendront de ce paramètre. Si un système de codeurs est connecté et déclaré, la case est grisée car la déclinaison est lue directement. Dans le cas contraire, l'utilisateur doit remplir la case par lui même.

Si un dérotateur existe, l'angle actuel du dérotateur est indiqué.

Il en est de même si le programme sait que l'on utilise une monture allemande.

La durée des mouvements doit amener l'étoile à se déplacer sur une zone suffisante de capteur de guidage. Dans ce cas, les paramètres de guidage pourront être calculés avec une précision suffisante.

Pour la calibration, l'utilisateur choisira les options de miroir et de binning qu'il désirera conserver pour le guidage.

Il est possible de régler les paramètres de calibration manuellement. Ceci est particulièrement utile si ces derniers ont été perdus pour une raison ou une autre car évite de refaire la calibration. Attention cependant dans le cas de l'usage d'un dérotateur à rentrer manuellement les paramètres pour la même valeur d'angle de l'accessoire que celle actuelle.

La page sur l'autoguidage reprend une partie de ces paramètres.

Le noir est oté de chaque image durant la calibration et c'est pour cela qu'il est réalisé une fois en début de calibration. On obtient ensuite un rapport durant cette calibration où l'utilisateur doit pointer l'étoile de calibration après chaque mouvement :

Durant la calibration

Après la calibration, il est fourni divers résultats comme saisi ci-dessous à l'aide du mode simulation :

Graphique de calibration

Les paramètres de calibration sont alors calculés.

Les paramètres de calibration

L'utilisation de la calibration peut se faire à partir du bouton [Suivi].

Les paramètres d'autoguidage sont sauvegardés dans la base de registre suivant le nom de la caméra, ce qui permet d'avoir plusieurs jeux de paramètres suivant la caméra utilisée. On trouvera ces paramètres dans la clé : "HKEY_CURRENT_USER\Software\Prism6\CCD\Tracking\Nom_Caméra".

Pour arrêter la procédure d'autoguidage, il faut cliquer sur le bouton [Abondon] ... une erreur souvent comise est de se tromper de bouton [Abandon]. Il faut bien cliquer sur bouton du capteur à partir duquel l'autoguidage a été effectué. Cet erreur a souvent lieu lors de l'usage d'une camera SBIG où le capteur principal et le capteur d'autoguidage apparaissent dans la même fenêtre.
Onglet Filtre

L'onglet Filtre

Cet onglet n'est utile que si une roue à filtre CFW8 est connectée au PC. Sinon, il faut se reporter au menu [Télescope / Contrôle de la roue à filtre]

Il suffit de sélectionner le filtre concerné, et il se place automatiquement devant la matrice.

Pour les utilisateurs qui n'ont pas changé l'ordre de leur filtre, la roue se place sur le filtre rouge à chaque initialisation du menu "Caméra/Acquisition". Viennent ensuite les filtres verts et bleus.
Le filtre 4 est un filtre Neutre pour éviter de recommencer la focalisation dès que l'on n'utilise pas les filtres colorés (le chemin optique a ainsi la même longueur pour toutes les combinaisons du porte-filtres).
Enfin, dans le dernier emplacement, il n'y a pas de filtres.
Par contre, il est impératif de faire un flat pour chaque filtre, y compris le neutre. Les filtres colores sont des filtres BVRI.

Que l'utilisateur ait changé ou non l'ordre initial des filtres colorés, il faut indiquer au premier lancement du menu Acquisition les noms des filtres. En effet, les noms sont sauvegardés dans l'éditeur de registre WINDOWS et doivent donc être enregistrés une fois pour toute. Il suffit pour cela de se placer sur le filtre concerné et d'en indiquer le nom dans la boite de saisie en bas.

Onglet Informations

L'onglet informations

Dans cet onglet, tous les renseignements connus sur les capteurs sont fournis. Sont indiqués :

  • La vitesse de lecture; il est à noter que cette vitesse est actualisée suivant que l'on consulte les informations à partir du capteur principal ou du capteur de guidage.
  • Le pilote utilisé actuellement avec la caméra.
  • Des informations sur les capteurs principal et de guidage.
  • Le niveau de saturation : la barre d'ascenseur horizontale représente la valeur du pixel ayant retourné la plus grande valeur, exprimée en pourcentage de la capacité maximale d'un pixel.

Onglet Journal de nuit

Onglet du journal de bord

Dans cet onglet, il est possible de rajouter des informations au fur et à mesure de la nuit. Chaque caméra a son propre journal. Il est à noter qu'à chaque action sur la caméra, des informations sont complétées dans la fenêtre s'ouvrant initialement avec la connexion de la caméra.

Onglet Entête

Le réglage des options

Cet onglet permet de modifier les informations apparaissant dans l'entête de l'image.

Il suffit de se rapporter à la partie sur la configuration de la caméra.

Il est également possible de régler les options pour les boutons [Exp longue] et [Exp courte] du panel d'acquisition.

Onglet Temp. CCD

L'onglet Temp CCD

Cet onglet permet de visualiser la température du capteur.

  • Température CCD :
    Donne la température du capteur en °C ainsi que celle du milieu extérieur donné par la caméra. En cliquant sur le bouton "G", il est possible de faire tracer le graphe d'évolution de la température CCD dans le temps. Ce dernier s'enregistre qu'au moment où le graphe est demandé.

  • Puiss ( % ) :
    Puissance électrique reçue par le système de refroidissement. Plus cette puissance sera proche de 100%, plus les peltiers refroidiront au maximum. Cependant, pour conserver une température constante durant toute la nuit, il est conseillé de garder une valeur de 95% en régime permanent. En cliquant sur le bouton "G", il est possible de faire tracer le graphe d'évolution de la puissance dans le temps. Ce dernier s'enregistre qu'au moment où le graphe est demandé.

  • SetPoint CCD Temp :
    permet de fixer la température à laquelle on désire refroidir le capteur. Lorsque cette température sera atteinte, la puissance ne restera pas à 100% mais diminuera jusqu'à réaliser un équilibre avec le capteur de telle façon que la température de ce dernier reste constante.

  • Boutons de régulation de température :
    donnent accès au réglage de la mise en température dont le principe est décrit ci-dessous.
L'onglet Temp CCD

Fenêtre de réglage de la mise en température :

De façon générale, dans ce processus, il faut faire les réglages pour un refroidissement. Pour un réchauffement par étape, les précédents processus seront exécutés dans l'ordre inverse.

  • Température Extérieure :
    Cette valeur donne une indication de la température extérieure. Un appui sur le bouton de "MAJ" permet de mettre à jour les valeurs (de température finale) fournie dans la table.

  • Température finale :
    Cette température est une "température plancher" comme indiquée. La température de la caméra ne descendra jamais en dessous de cette valeur même si le nombre d'étapes et la température finale fournis dans la table pourraient le laisser penser. Ceci permet d'éviter de régler ces étapes chaque nuit. On peut multiplier les étapes en fonction de ce que l'on cherche à avoir, dépasser son seuil minimal dans la table en dessous, la température de la caméra sera bloquée à la valeur plancher.

  • Durée totale du processus :
    Donnée indicative si tous les processus de la table sont exécutés (voir remarque de la température plancher).

  • Les étapes :
    Une sélection d'étape dans la table permet de l'éditer ou de l'effacer. Pour valider une édition d'étape, cliquer sur le bouton de mise à jour.
    Le bouton "Ajouter" permet d'ajouter une nouvelle étape de mise en température à la suite des autres. Il est rappelé que l'on peut rajouter autant d'étape que désirées mais la température minimale donnnée au capteur CCD sera définie par la "température plancher".

Animations FLASH :
Mise en température d'un capteur CCD (4,0 Mo)

Fonction(s) Script associée(s):
Voir la partie sur les scripts et les fonctions "caméra"

Conditions d'activation :
Avoir déclaré la caméra utilisée

Voir aussi :
Le type de panel suivant le type de caméra
Acquisition avec l'ancien panel

Version Nov 2005


Caméra / Dossier Autoguidage

DOSSIER > Autoguidage dans PRiSM

Pour réaliser une session d'autoguidage, le matériel nécessaire doit être le suivant :

  • Une caméra CCD du type SBIG ou Chungara. Pour le moment, seules ces caméras ont un capteur d'autoguidage intégré en plus du capteur principal pour l'acquisition d'image. Cependant, même pour de telles caméras, il est possible de réaliser un guidage avec le capteur principal à l'aide de l'onglet réservé à cet effet.
  • Une caméra CCD avec capteur unique. Le guidage sera réalisé à partir d'un fenêtrage du capteur. La caméra ne pourra alors être utilisé pour une autre acquisition.
  • Une caméra type WEBCAM. Le guidage aura lieu dans une fenêtre de l'image renvoyée par le capteur. La WEBCAM ne pourra alors être utilisé à un autre usage que le guidage.

De façon générale, les ordres de guidage peuvent être envoyés soit vers les relais de la caméras comme les caméras SBIG (relais intégrés à la caméra), soit à la monture si cette dernière supporte les mouvements de rappels par la liaison avec le PC. La méthode et l'ordre de déclaration sont alors particuliers.

Le principe de fonctionnement de cette fonction est simple: après avoir calibré les 4 axes, la fonction prend des poses successives du capteur de guidage, calcule le déplacement de l'étoile de guidage et corrige. Pour que le programme sache dans quelle(s) direction(s) effectuer la correction, les axes de la matrice doivent être orientés suivant les 2 axes de rotation de la monture. Une matrice, orientée à 45° par rapport aux axes de rotation provoquera un autoguidage sûrement voué à l'échec.
Le guidage par rapport à une fente est plus particulier et mérite la lecture de ce passage ...

Prérequis:
Calibration avec ancien panel d'acquisition (plus d'actualité).
Calibration avec nouveau panel d'acquisition.
Calibration avec une caméra de type WEBCAM (à venir !)

Une fois la calibration réalisée, on peut demander à commencer l'autoguidage. Le principe est parfaitement identique que le capteur de guidage soit intégré dans la caméra avec le capteur principal (SBIG, Chungara), que le capteur soit le capteur principal de la caméra ou qu'il soit celui d'une caméra de type WEBCAM.

Une animation FLASH en fin de page est proposée permettant de décrire la calibration et le démarrage de l'autoguidage.

La première information est sur la date et la déclinaison déclarée de la précédente calibration. Afin de revoir les paramètres de calibration, il faut cliquer sur le bouton [voir les coordonnées] :

Il est ensuite indiqué le système d'axe utilisé : soit les caméras de type "SBIG, Chungara" qui sont dans la capacité d'envoyer des informations par port externe (exemple : "SBIG camera relays guider"), soit le guidage par gestion DLL ou système (exemple : "ASCOM compliant guider").

Une remarque importante concerne l'utilisation des relais d'une caméra type SBIG qui peuvent être utilisés même avec une caméra d'autoguidage type WEBCAM (il faut déclarer alors la caméra SBIG comme relais d'autoguidage).

Acquisition :

  • Taille de la fenêtre d'autoguidage : Taille de la fenêtre d'acquisition. Cette taille est prise en compte lors de l'image fenêtrée comme ci-dessous. Cette valeur doit être assez importante si le suivi est mauvais notamment dans le cas de poses en bouclage.
  • Délai entre acquisition : délai entre deux acquisitions de guidage en secondes
  • Niveau minimum de l'étoile guide : fixe un niveau minimum pour le flux total de l'étoile. Ceci permet d'empêcher un guidage aléatoire en cas de passage nuageux !
  • Rayon de calcul de barycentre (valeur < 30) : demi-taille de la zone autour du centre approximatif de l'étoile pour le calcul exact du barycentre du niveau des pixels.
  • Paramètres : Paramètres important sur la gestion des miroirs et du binning. Une modification de ces valeurs est donc indiquée et est parfaitement prise en compte par le logiciel.
  • Nbre de pixels de mouvement (dithering) : C'est le nombre de pixels, en distance, par rapport à la position intiale dont sera décalé l'étoile de guidage lors d'un guidage entre deux poses successives (lors d'un bouclage déclaré).

Axe Alpha :

  • Agressivité de correction : permet de régler le rattrapage effectif en alpha en fonction de ce que le logiciel calcule "réellement". Lors de la calibration, PRiSM a calculé les coefficients de rattrapage en fonction de l'instrumentation utilisée. Une agressivité de 1 correspond à un rattrapage exact par rapport au décalage mesuré. Cependant, en fonction du temps de pose et du rapport signal/bruit, en prenant en compte la turbulence, une telle correction n'est pas nécessaire. Seul des essais peuvent déterminer "la meilleure valeur" mais une valeur de 0.7 est en général suffisante.
  • Décalage min de correction (pixels) : Si la correction en alpha doit être inférieure à cette valeur, elle n'aura pas lieu (de petites valeurs de correction sont en général dues à la turbulence).
  • Décalage max de correction : Si la correction en alpha doit être supérieure à cette valeur, elle n'aura pas lieu (faudrait-il que la monture suive très mal ou qu'il y ait un voile nuageux très turbulent et insuffisant pour rendre le flux de l'étoile inférieur au niveau minimum).
  • Déclinaison actuelle : valeur remplie automatiquement si la liaison avec des codeurs est effectuée. Dans le cas contraire, l'utilisateur doit fournir cette valeur.

Axe Delta :

  • Agressivité de correction : permet de régler le rattrapage effectif en delta en fonction de ce que le logiciel calcule "réellement". Lors de la calibration, PRiSM a calculé les coefficients de rattrapage en fonction de l'instrumentation utilisée. Une agressivité de 1 correspond à un rattrapage exact par rapport au décalage mesuré. Cependant, en fonction du temps de pose et du rapport signal/bruit, en prenant en compte la turbulence, une telle correction n'est pas nécessaire. Seul des essais peuvent déterminer "la meilleure valeur" mais une valeur de 0.7 est en général suffisante.
  • Décalage min de correction (pixels) : Si la correction en delta doit être inférieure à cette valeur, elle n'aura pas lieu (de petites valeurs de correction sont en général dues à la turbulence).
  • Décalage max de correction : Si la correction en delta doit être supérieure à cette valeur, elle n'aura pas lieu (faudrait-il que la monture suive très mal ou qu'il y ait un voile nuageux très turbulent et insuffisant pour rendre le flux de l'étoile inférieur au niveau minimum).
  • Retournement de la monture depuis la calibration : réservé aux montures équatoriales de type allemandes pour prendre en compte une inversion des mouvements en delta lors d'un retournement au méridien sud.
  • Ne pas utiliser le déplacement en delta : permet de ne tenir compte que du guidage en alpha, pour la mesure de l'erreur périodique par exemple.
  • Une seule direction : Choisir le type de guidage en delta retenu. La correction automatique ne se fera qu'après un certain nombre d'image réalisée (fixé par l'utilisateur) ainsi qu'après un certain mouvement (lui aussi fixé par l'utilisateur).

Alarmes sonores :

  • Alarmes sonores : Alarmes de guidage. Les fichiers sonores sont au choix de l'utilisateur. On les nommera "Tracking_alarm_toofaint.wav" (alarme étoile faible) et "Tracking_alarm_lost.wav" (alarme étoile perdue) pourront être placé dans le répertoire principal de PRiSM. Cela permet d'avoir des alarmes sonores en cas de perte de l'étoile guide.

AO tip tilt :

Paramètres à régler en cas d'utilisation du correcteur Tip Tilt AO7 ou AOL de chez SBIG. Pour plus de détails sur l'autoguidage en boucle avec l'AO7, voir le tutorial.

Guidage sur fente :

Le guidage sur fente a ceci de particulier qu'il est nécessaire de garder l'étoile disparu derrière la fente. Le rattrapage tient compte des vitesses calibrées sur les axes ainsi que de deux paramètres énergétiques. De façon à comprendre et à calibrer ces 2 paramètres, il est nécessaire de se référer à la page sur la détermination des paramètres énergétiques.
Le guidage aura toujours lieu avec comme point de référence (point où le logiciel tentera de ramener le telescope ) :

  • Suivant la fente : la valeur de Y (ou de X si la fente est horizontale) où l'utilisateur a cliqué avec la souris.
  • Perpendiculairement à la fente : la valeur indiquée lors du réglage des paramètres de guidage sur fente (= position entière de la fente).

L'autoguidage sur fente peut être utilisé avec une fente horizontale ou verticale. Par expérience, il est conseillé de placer la fente le long de l'axe DELTA de façon à ce que le backlash sur cet axe soit minimisé (le backlash n'existe pas en ALPHA).

La description des paramètres de réglages est la suivante :

  • Position entière de la fente : il doit être fourni le centre de la fente (valeur de X pour les fentes verticales ou de Y pour les fentes horizontales).
  • Largeur entière de la fente : Largeur estimée pour la fente utilisée (attention, ce n'est pas la demi-largeur demandée).
  • Paramètre de guidage inférieur : C'est un des 2 paramètres énergétiques à régler comme indiqué dans la page dont le lien est ici. Il est rappelé que le résultat du rapport énergétique est alors multiplié par le coefficient énergétique pour simuler la position du centroïde de l'étoile perpendiculairement à la fente lorsque l'astre est dévié vers la gauche (ou vers le bas). Cette information permet à l'utilisateur de vérifier la validité du coefficient énergétique fourni.
  • Paramètre de guidage supérieur : C'est un des 2 paramètres énergétiques à régler comme indiqué dans la page dont le lien est ici. Il est rappelé que le résultat du rapport énergétique est alors multiplié par le coefficient énergétique pour simuler la position du centroïde de l'étoile perpendiculairement à la fente lorsque l'astre est dévié vers la droite (ou vers le haut). Cette information permet à l'utilisateur de vérifier la validité du coefficient énergétique fourni.
  • Fente verticale : Définit l'orientation de la fente : horizontale ou verticale.

Le principe de cet autoguidage particulier fonctionne de façon identique que la fente soit verticale ou horizontale. La notion "d'algorithme énergétique" est utilisé dans la direction perpendiculaire à la fente alors qu'un "simple" algorithme barycentrique classique est utilisé le long de la fente.
Le rattrapage perpendiculairement à la fente aura lieu à chaque action si besoin est. Par contre, le long de la fente, le rattrapage ne pourra avoir lieu que si l'étoile sort de cette fente ... en attendant ce moment, il n'y aura pas de tel rattrapage.
Cet algorithme permet d'envoyer l'étoile, dans la fente même si au départ cette étoile n'est pas dans la fente; cependant, elle ne doit pas non plus en être trop loin à cause de la taille du choix de la fenêtre d'autoguidage. De tels paramètres comme la taille de la fenêtre de guidage ou le rayon de calcul de barycentre doivent donc être le plus important possible. Le niveau minimum n'a pas d'intérêt pour l'algorithme de guidage sur fente et donc, il faut être vigilent qu'il n'y aura pas d'alerte sonore ou non de perte d'autoguidage avec une telle méthode (puisque l'étoile doit disparaître !).

Guidage sur consigne :

Cette option est à cocher si on désire guider sur un pixel fractionnaire particulier du CCD de guidage. Ceci ramène automatiquement l'étoile vers ce point à condition que l'étoile soit dès le départ dans le cadran d'autoguidage !

Bouclage des acquisitions :

Cette partie concerne les autoguidages successifs entre deux poses.

Lancement de l'autoguidage :

Après validation des paramètres et après acquisition du noir et de la première image, le champ du CCD apparaît et l'utilisateur doit cliquer sur l'étoile choisie pour le guidage. Le guidage commence alors en fonction de la taille de la fenêtre fournie :

La fenêtre d'acquisition et l'étoile de guidage Le tracking inspector

Suivant les panels, il s'affiche l'inspecteur de suivi. Dans le nouveau panel, son affichage est automatique. Dans le panel classique, il faut cliquer sur le bouton [?..].

Dans cet inspecteur de suivi sont fournis les renseignements suivants :

  • Le graphe d'évolution dans le temps de la position en alpha de l'étoile guide surmonté de sa valeur pour la dernière image acquise. Ce dernier n'apparaît pas dans le cas d'un guidage sur fente car ce dernier peut partir de loin.
  • Le graphe d'évolution dans le temps de la position en delta de l'étoile guide surmonté de sa valeur pour la dernière image acquise. Ce dernier n'apparaît pas dans le cas d'un guidage sur fente car ce dernier peut partir de loin.
  • Le graphe d'évolution du flux de l'étoile guide. Ceci permet de jauger la turbulence lors de l'enregistrement ou le passage d'un nuage.
  • Un appui sur le bouton "Plus" permet de donner à chaque rattrapage les corrections effectuées en DX et DY.
  • Le schéma de répartition des positions du barycentre de l'étoile guide sur le capteur durant tout l'enregistrement. La taille du carré blanc est de 1 pixel. L'échelle de la répartition peut être modifiée en cliquant sur les boutons "+" ou "-".

    Le graphe de répartition

    Le point vert représente la position courante du barycentre de l'étoile.
  • Les valeurs fournies sou ce schéma parlent d'elles-mêmes. La "Direction RMS" indique l'angle de dérive moyen de l'étoile. L' "erreur de suivi RMS" indique l'erreur RMS (des erreurs négatives peuvent également faire augmenter ce nombre) du suivi au cours du temps. Pour une meilleure interprétation, cette erreur est indiquée en fraction de pixel.
  • Le bouton "Lier" permet de lier tous les points de la fenêtre de répartition dans le temps entre eux.
  • Les boutons [+] et [-] permettent de changer l'échelle de la fenêtre de répartition (attendre entre chaque changement que la dernière acquisition et le calcul soient terminés).
  • Le bouton [sauver] enregistre un fichier texte où apparaissent les divers corrections
  • Le bouton [graphique] affiche un graphe modifiable comme tout graphe de PRiSM, et affichant l'évolution des corrections alpha et delta dans le temps.

    Le graphe d'évolution

  • La représentation des mouvements permet d'avoir des renseignements sur les divers types de rattrapage cumulés ou au contraire, à chaque acquisition comme à la fenêtre écrite en dessous. Lors d'une correction, les boutons de correction sont en surbrillance :

    Les corrections courantes sont suivant RA- et DEC-

un fichier de sortie contenant toutes les positions de l'étoile guide est fourni en fin de page.

Le bouton [Abondon] ou [Stop] suivant les panels permettent d'arrêter l'autoguidage.

Pour le guidage sur fente, le principe est identique :

Cas des poses en bouclage :
L'autoguidage peut être effectué lors d'une série de poses prises en boucle. Dans ce cas, l'autoguidage s'arrête lorsque le capteur principal se vide. Il reprend immédiatement lorsque la lecture est terminée (que l'utilisateur ait imposé un délai ou non entre chaque pose de la boucle).
Lorsque l'autoguidage reprend, la position de référence de l'étoile guide est celle de la reprise de l'autoguidage (et non celle du début de la boucle). Cependant, pour le moment, l'étoile peut sortir de la fenêtre durant la lecture du capteur et PRiSM n'ira pas la chercher pour autant ... Pour palier à cet inconvénient, l'utilisateur doit choisir une fenêtre de lecture assez grande en fonction des capacités de suivi de sa monture.
Une partie spéciale sur l'autoguidage avec images en boucles est présentée dans le tutorial.

Animations FLASH :
Calibration et démarrage de l'autoguidage (guidage classique) (7,7 Mo)
Réglages des paramètres pour l'autoguidage sur fente (spectroscopie) (0,70 Mo)
Centrer une étoile hors fente (spectroscopie) (0,30 Mo)

Fichier :
Position en alpha et delta de l'étoile de guidage

Fonction script associée :
StartGuide
StopGuide
Get_Guide_Status

Conditions d'activation :
Avoir déclaré la caméra utilisée

Tutoriaux :
Guidage en boucle
Guidage en boucle avec l'AO7
Guidage sur fente en spectroscopie

Version Janvier 2008


Caméra / Focalisation manuelle

> Caméra > Focalisation (Manuelle)

Lancement : Menu [Caméra] > [Foclisation / Mesure Erreur Périodique]

Cette fonction permet de faire une mise au point manuelle sur une étoile. Elle permet en même temps d'obtenir des graphes dont un sur le comportement de la monture : l'erreur périodique.

Avant de pouvoir utiliser cette fonction, il faut :

  • Avoir déjà lancé la fonction d'acquisition d'image [Caméra] > [Activer Paneau Acquisition Caméra]
  • Avoir lancé une acquisition en binning 1x1, sans miroir horizontal ou vertical, avec un temps de pose assez court (1s par exemple)

Si le télescope est complètement défocalisé, il faut commencer par un binning 3x3 et réaliser une focalisation la meilleure possible. Revenir ensuite au binning 1x1, et prendre une pose. Les étoiles ne doivent alors plus apparaître parfaitement comme des points. A partir de l'onglet "Fenêtre" ( un des onglets du menu d'acquisition ), sélectionner une fenêtre encadrant une étoile qui va servir à la focalisation. Cette manipulation a pour but de diminuer la fenêtre à lire et donc de la lire beaucoup plus vite qu'une fenêtre de taille normale. Essayer d'approcher une bonne focalisation à partir de cette nouvelle fenêtre.
Enfin, une fois que l'étoile semble focalisée et après avoir cliqué sur le menu [caméra] > [Focalisation manuelle], une croix va circuler sur l'image courante. Il faut amener la croix sur l'étoile que l'on désire focalisée ( si cette étoile est focalisée, les autres le seront aussi ! ). Cliquer lorsque l'étoile est au centre de la croix. L'étoile choisie ne doit pas être saturée.

La fenêtre suivante s'ouvre alors :

Le panel Focalisation; cliquer pour atteindre la description
  • Le titre de la fenêtre indique le temps de pose de la focalisation.

  • La première fenêtre ( en haut à gauche ) donne l'image de l'étoile agrandie dans un carré de 50 pixels de côté et permet donc de repérer l'étoile sur laquelle on focalise ( utile lorsqu'on a deux étoiles très proches l'une de l'autre ). Il est quand même conseillé d'éviter de choisir deux étoiles très proches sous peine de voir passer la croix rouge de focalisation d'une étoile à l'autre. La fenêtre contient l'image de l'étoile en temps réel.

  • Les deux fenêtres en dessous donne l'apparence de l'étoile sur le fond de ciel et pour la petite fenêtre de droite la modélisation de l'étoile ( le fond de ciel est enlevé ).

  • Le rectangle sous les 2 fenêtres permet de situer le cadran utilisé par rapport au capteur CCD. Cela peut être important pour les instruments qui présentent de fortes distorsion sur les bords du champ. Dans le cas où le bouton [fenêtre fixe] est coché, la fenêtre se déplace sur le fond de la matrice de telle façon que l'étoile reste au centre de la fenêtre où elle apparaît; Cette fenêtre se déplace notamment au gré de l'erreur périodique de la monture et du seeing.

  • Effacer Graphique : Cette touche permet d'effacer les trois graphiques de droite : FWHM Grand axe, FWHM Petit axe, et Surface de l'étoile.

  • La fenêtre intensité : Dans cette fenêtre est indiqué le pixel d'intensité minimum ( en ADU ) , le pixel d'intensité maximum ( en ADU ) et enfin le flux de l'étoile modélisée. Il n'est pas conseillé sur ce point de choisir une étoile qui sort à peine du fond de ciel. Ces valeurs nous permettent de le savoir ! Il est indiqué également la position sur le capteur de l'étoile sur laquelle on réalise la focalisation, la focale du télescope ( demandée si elle n'a pas été remplie dans l'entête ) ainsi que la taille de la fenêtre de calcul pour modéliser l'étoile de focalisation par un centroïde gaussien.

  • Reset Diagnostics : Permet d'effacer les diagnostics et conseils que l'on rencontre dans les deux fenêtres du bas en "profondeur". Les diagnostics sont alors repris comme s'il n'y avait pas eu de mesures jusqu'alors. Seules les nouvelles mesures donneront lieu à un diagnostic.

  • Pause : Permet de demander à la focalisation assistée de faire une pause ( ... passage d'un nuage à l'humeur vagabonde ! ).

  • Pas de conseil : Permet d'éviter les conseils dans la fenêtre conseil ! Ceci dit, ces derniers sont bien utiles !

  • Stop : permet de fermer le menu focalisation. On peut également utiliser le bouton classique de fermeture de la fenêtre.

  • FWHM Grand axe : Donne la largeur à mi-hauteur la plus grande de l'étoile au cours du temps lors de la focalisation. Le but est évidemment de réussir à le rendre le plus petit possible. Les chiffres indiqués sont l'amplitude de cette largeur en micromètre.

  • FWHM Petit axe : Donne la largeur à mi-hauteur la plus petite de l'étoile au cours du temps lors de la focalisation. Le but est évidemment de réussir à le rendre le plus petit possible. Les chiffres indiqués sont l'amplitude de cette largeur en micromètre.

  • Surface de l'étoile : Donne l'évolution de la surface de l'étoile en micron2 au cours du temps lors de la focalisation.

  • Largeur à mi-hauteur / FWHM : Donne la mesure instantanée de ce qui est résumé dans les trois graphiques ci-dessus. Il est indiqué la taille du grand axe en pixel , en micromètre et en arc secondes. C'est pour cette raison qu'il faut compléter dans l'entête la taille des pixels et la focale du télescope. Il en est de même du petit axe. En dessous, il est alors indiqué l'inclinaison du grand axe par rapport à l'horizontale ( donnée "angle" ) et la surface de l'étoile provenant de la mesure instantanée précédente. Dans un fenêtre à droite sont indiquée les valeurs minimum obtenues depuis le début de la mesure : respectivement les mesures du grand axe, petit axe et surface de l'étoile.

  • Diagnostics : différents renseignements comme le temps écoulé depuis le début de la focalisation ( plus précisément depuis que "reset diagnostic" n'a pas été saisi ), les moyennes sur le grand axe, le petit axe et la surface de l'étoile ( surface à mi-hauteur ) et enfin le décalage entre chaque mesure en fraction de pixel.

  • Conseils : Conseils permettant d'améliorer son montage optique ...

  • En dessous, on trouve des renseignements quantitatifs sur la fenêtre choisie pour réaliser la focalisation ( fenêtre représentée en haut à gauche ).

Onglet "Simple": Cet onglet permet aux observateurs qui n'ont pas un focuser motorisé de voir des informations essentielles de loin ...

Onglet "Assistance à la mise en station": Cet onglet est une aide à la mise en station :

  • L'axe X doit être celui d'ascension droite alors que l'axe Y doit être celui de déclinaison.
  • Au méridien, à la déclinaison 0°, ceci permet de régler l'azimuth de la monture.
  • A +/- 6H, ceci permet de régler la hauteur de la monture.

Tous ces renseignements doivent permettrent de réaliser une focalisation parfaite.

En ce qui concerne la technique de focalisation, il ne faut pas hésiter à dépasser la focalisation et revenir en arrière pour savoir exactement où se trouve le meilleur point de focalisation. La variation de la focalisation ne doit pas être jugée trop hâtivement. Il faut attendre deux poses après avoir tourné le moteur de focalisation et faire attention aux effets de la turbulence.

Il est possible de visualiser en temps réel, l'évolution de la position de l'étoile sur la matrice (en X et en Y). Pour cela, cliquer sur les boutons [Graphique X tp réel] ou [Graphique Y tp réel]>.

Lorsque la mise au point est considérée comme correcte, il suffit de cliquer sur le bouton [STOP]. Le logiciel propose alors d'afficher les courbes de position de l'étoile sur la matrice (en X et en Y), ainsi que la courbe d'évolution de la surface totale de l'étoile au cours du temps.

Exemple d'analyse des graphes :

Il est quasi obligatoire, même pour ceux qui ne possède pas de fonction d'autoguidage, d'orienter les lignes ou colonnes de sa caméra suivant un des axes (déclinaison ou ascension droite) ne serait-ce pour une analyse plus simple de l'image astrométriquement par la suite.
Le graphe de la position de l'étoile suivant une des directions permet d'analyser le défaut de la mécanique de la monture, c'est-à-dire l'erreur périodique en ascension droite.
Dans notre exemple, les lignes de la caméra étaient orientées suivant la direction de l'ascension droite. L'analyse de la position de l'étoile en Y permet de connaître l'erreur périodique de la monture. Le graphe traduisant l'erreur périodique peut ensuite être analysé à l'aide du menu [Télescope] > [Analyse de l'erreur périodique] .

erreur périodique de la monture

Le graphe en X donne ici quelque chose de totalement anarchique qui montre au moins que la monture est correctement mise en station :

Graphe en X

Enfin la surface de l'étoile permet d'estimer le degré de turbulence surtout si on laisse défiler les mesures en ne touchant plus à la focalisation du télescope :

degré de turbulence

Ici , le graphe montre que la turbulence est loin d'être négligeable puisque dans les dernières mesures, même si on ne touche pas à la focalisation du télescope, la surface varie continûment !
Ces graphes peuvent être modifiés et arrangés grâce au module graphique de PRiSM qui apparaît en dessous de chacun d'eux.

Animation FLASH :
Un exemple de focalisation manuelle (886 Ko)

Conditions d'activation :
Avoir déclaré la caméra utilisée et réalisé une acquisition en binning 1x1

Prérequis :
Réaliser une acquisition


Caméra / Focalisation automatique

Caméra >
Focalisation
Focalisation automatique

Lancement : Menu [Caméra] > [Focalisation] > [Focalisation automatique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de faire une mise au point automatique sur une étoile.

Avant de pouvoir utiliser cette fonction, il faut :

  • Avoir déjà lancé la fonction d'acquisition d'image [Caméra] > [Activer Paneau Acquisition Caméra]
  • Avoir lancé une acquisition en binning 1x1 avec un temps de pose assez court (entre 1 et 5 secondes). Ce temps sera la durée de pose de toutes les images servant à la focalisation.
  • Avoir connecté le focuser à partir du menu [Telescope] > [Etablir communication] et l'avoir initialisé en mode "Parking".

Une animation FLASH en fin de page est proposée pour donner un exemple de connexion d'instruments.

PRiSM propose deux méthodes pour faire la focalisation automatique :

  • La modélisation par FWHM = régression parabolique : les étoiles doivent rester modélisables par une gaussienne durant tout le parcours de focalisation. A utiliser avec de très bon instruments de type Newton.
  • La modélisation par HFD = régression polynomiale de degré 4 : Cette modélisation est moins contraignante mais légèrement moins précise que la précédente. A utiliser avec des instruments optiquement moyens tels des configurations Schmidt-Cassegrain.

1ère méthode : La modélisation par FWHM = régression PARABOLIQUE :

Cette méthode est privilégiée par des tubes optiques de bonne qualité.
Si le télescope est complètement défocalisé, il faut commencer par un binning 3x3 et réaliser une focalisation telle que la modélisation des étoiles devienne possible. Il faut recommencer l'opération en binning 1x1. Ces mouvements doivent se faire à l'aide du focuser. Ceci permet de noter la position du focuser au début du lancement de la focalisation et d'extrapoler pour celui de la fin de focalisation où l'étoile devra être encore modélisable.
Enfin, une fois ces valeurs notées, et les prérequis ci-dessus éffectués, il est possible de lancer la fonction de focalisation automatique.

Le principe repose sur le tracé d'une parabole de FWHM des étoiles (intra et extra-focale). Le minimum de la parabole sera alors le point de meilleure focalisation et une fois déterminé, PRiSM ira sur ce point automatiquement. Il est donc obligatoire que l'étoile soit modélisable en permanence durant l'intervalle de déplacement du focuser afin de pouvoir en calculer la FWHM.

1. Réglages des paramètres :

La fenêtre suivante s'ouvre alors :

Cliquer sur les paramètres à régler

Les paramètres à régler sont sur fond blanc :

Tous ces paramètres seront retenus dans la base de registre pour une nouvelle focalisation automatique.

  • Le point de départ de focalisation pour le tracé de la courbe, donné en mm et noté précedemment. Le focuser se règlera sur ce point avant toute mesure.

  • Le point d'arrivée est la dernière position du focuser pour laquelle sera effectuée une mesure.

  • Le pas dont variera chaque position du focuser. Bien évidemment, différence entre les positions d'arrivée et de départ doit être un multiple du pas. Un minimum de 6 déplacements est demandée pour lancer la fonction. PRiSM peut à la volonté de l'utilisateur calculer lui-même cette valeur en cliquant sur le bouton [Optimum] : permet de choisir suffisamment d'itérations ainsi qu'une valeur sous-multiple.

  • Rayon d'analyse : Fenêtre d'analyse de la FWHM de l'étoile : L'étoile devra à chaque fois être incluse dans cette fenêtre. Sa demi-taille maximum (son rayon) sera de 20 pixels. Cette valeur correspond a la même signification que celle de la taille de la fenêtre du centroïde.

  • Demi-taille de la fenêtre : une fenêtre montrant la zone d'image analysée sera affichée dans l'emplacement prévu en haut à gauche du cadre. On indique sa demi-taille en pixels.

  • [<<Optimum] : voir la partie concernée.

  • Utiliser HFD pour centroïde : NE PAS cocher pour la méthode parabolique.

  • Bouton à cocher Tenir compte du prescan :Dépend du type de caméra utilisée. Pour la plupart des caméras du commerce, cette case devra rester non cochée.

  • Bouton à cocher Sauver les imagettes : Durant l'établissement de la courbe de réglage , PRiSM prendra des images autour de l'étoile concernée et affichera les différentes poses. Ces poses peuvent ou non être sauvegardées automatiquement dans le répertoire au choix de l'utilisateur (à régler). L'entête de ces images n'est pas remplie. Un exemple est fourni ici.

  • Graphique en fin de processus : Pour afficher le graphique de la parabole avec les valeurs mesurées lorsque la focalisation automatique est terminée. Ceci n'est pas obligatoire dans le but d'observations automatiques. Un fichier LOG sera aussi affiché et pourra être sauvegardé.

2. Informations durant la focalisation :

Pour lancer la focalisation, il faut cliquer sur le bouton [Exécuter]. Durant l'exécution, une telle fenêtre apparaît :

Cliquer sur les indications

la fenêtre dont la demi-taille a été réglée apparait en haut à gauche. Sur cette fenêtre est dessinée le rectangle d'analyse de la FWHM de l'étoile dont le rayon analyse a été réglé dans les paramètres. Il est fournit aussi la position de la fenêtre sur le capteur de type X1=nnnn Y1=nnnn (coordonnées inférieures gauches) | X2=nnnn Y2=nnnn (coordonnées supérieures droites) | CX=nnnn CY=nnnn (coordonnées du centre de la fenêtre). Pour l'image affichée sur cette fenêtre, PRiSM a calculé le pixel d'intensité maximale ainsi que sa position. La FWHM de l'étoile dans le rectangle jaune est fournie.

Dans les renseignements de sortie, la série des opérations et calculs effectués est fournie : le nombre d'itérations à effectuer, les déplacements successifs du focuser ainsi que pour chaque image analysée, les renseignements calculés comme ci-dessus. Le bouton [Copier Sortie] permet de copier, par l'intermédiaire du presse-papier WINDOWS, les renseignements de sortie dans un ficher texte. Un fichier texte de sortie est fourni comme exemple.

  • Temps de pose pour chaque image.

  • Position en cours du focuser.

  • Dernière FWHM en pixels calculée pour la denière image analysée.

  • La focale du sytème utilisé fournie à la configuration de la caméra et qui sera enregsitrée dans l'entête de l'image.

  • Le diamètre du télescope fourni à la configuration de la caméra et qui sera enregsitré dans l'entête de l'image.

  • La taille des pixels en μm

Ces trois derniers paramètres permet à PRiSM de déteminer un pas optimal pour le réglage de la focalisation de type parabolique : le bouton [<<Optimum] calcule alors directement un "pas = taille_pixel * Focale / Diamètre". Attention cependant à fixer des valeurs de départ et de fin de façon à ne pas dépasser les 30 mesures autorisées par PRiSM.

3. Résultats de la modélisation parabolique :

Une fois le processus de focalisation terminé, la position optimale (ainsi que la FWHM correspondante) est indiquée et PRiSM bouge le focuser sur cette position.

Un graphe d'évolution de la FWHM en fonction de la position du focuser est alors tracé. Si PRiSM n'arrive pas à modéliser la parabole, alors le graphe apparaîtra avec les points non reliés. Un exemple en est fourni :

Ces graphes peuvent être analysés et modifiés comme tout graphe de PRiSM. Cependant, la modification du graphe n'entraînera nullement un nouveau calcul du meilleur point de focalisation.
Un fichier LOG est également fourni pour indiquer les divers valeurs de FWHM mesurées.

Durant le processus de focalisation, on peut l'interrompre en cliquant sur le bouton [abandonner] et sortir de la fonction en cliquant sur [Sortir]

2ème méthode : La modélisation par HFD = régression polynomiale de degré 4 :

Cette méthode devrait fonctionner avec un instrument de moyenne qualité comme avec un instrument de bonne qualité. Cependant, à moins de multiplier les points de mesure de façon excessive (limité à 30 mesures de toute façon), cette méthode sera moins précise que la précédente mais suffisante quand même ...

La méthode repose sur le principe de la largeur énergétique à mi-hauteur (nommé HFD = "Half Flux Diameter") : Le flux de l'étoile à l'intérieur du cercle de diamètre HFD est égal au flux à l'extérieur de ce cercle. Durant la focalisation, il faut que le focuser se déplace de telle façon à être en intra puis en extra focale (ou vice-versa) MAIS il n'est pas grave d'avoir des étoiles en forme de beignet durant la focalisation. La différence entre les positions de fin et de départ sera donc beaucoup plus importante que dans le cas de la modélisation type parabole.

Une animation FLASH en fin de page est proposée pour donner un exemple de focalisation automatique par HFD.

La fenêtre suivante s'ouvre alors :

1. Réglages des paramètres :

Le réglage des paramètres se réalise de façon identique au type de modélisation parabolique avec les différences suivantes :

  • [<<Optimum] : Bouton inutile dans ce cas. Le pas fourni doit être suffisamment important pour obtenir le polynôme. Il est conseillé durant une telle focalisation d'avoir des étoiles clairement en forme de beignet en début et fin de mouvements. Pour exemple, une imagette de début de courbe est fournie ici :

  • Utiliser HFD pour centroïde : Cocher une telle case pour une modélisation polynomiale. Le principe de mesure est réalisé à l'aide de cette fonction.

  • Attention, ne pas oublier que les étoiles vont être plutôt larges aux extrémités de mouvement. On veillera à choisir une "demi-taille de fenêtre" suffisamment grande et surtout un "rayon d'analyse FWHM" assez grand. PRiSM affichant ces fenêtres en temps réel, seuls des essais peuvent permettre de trouver des valeurs raisonnables. Pour exemple, sur la fenêtre suivante :

    la demi-taille de la fenêtre correspond au demi-fenêtrage total sur la caméra. Le rayon d'analyse correspond à la demi-taille du carré jaune, carré dans lequel doit se trouver l'étoile défocalisée durant tout le trajet du focuser. On règlera les tailles en conséquence. Le rayon d'analyse devra être inférieur à 30 pixels. La croix au centre du carré jaune correspond à la valeur maximale des pixels dans toute la fenêtre.
    Un exemple de saisie d'écran est fourni durant la focalisation :

2. Informations durant la focalisation :

Les informations fournies sont parfaitement identiques à la méthode parabolique. Pour exemple, une série d'imagettes enregistrées est fournie ici.

3. Résultats de la modélisation polynomiale :

Une fois le processus de focalisation terminé, la position optimale (ainsi que la FWHM correspondante) est indiquée et PRiSM bouge le focuser sur cette position.

Un graphe d'évolution de la FWHM en fonction de la position du focuser est alors tracé. Si PRiSM n'arrive pas à modéliser la parabole, alors le graphe apparaîtra avec les points non reliés. Un exemple en est fourni :

Ces graphes peuvent être analysés et modifiés comme tout graphe de PRiSM. Cependant, la modification du graphe n'entraînera nullement un nouveau calcul du meilleur point de focalisation.
Un fichier LOG est également fourni pour indiquer les divers valeurs de HFD mesurées (les valeurs de celui présenté ici ne correspondent pas à la courbe ci-dessus) :

Pos mm = 5.00  PSF =  27.95
Pos mm = 5.50  PSF =  23.00
Pos mm = 6.00  PSF =  17.82
Pos mm = 6.50  PSF =  17.82
Pos mm = 7.00  PSF =  11.97
Pos mm = 7.50  PSF =  5.87
Pos mm = 8.01  PSF =  6.31
Pos mm = 8.51  PSF =  10.82
Pos mm = 9.01  PSF =  15.09

Polynom -> -745.8053 * x^0
Polynom -> 478.6430 * x^1
Polynom -> -105.5237 * x^2
Polynom -> 9.7581 * x^3
Polynom -> -0.3221 * x^4
Polynom -> 0.0000 * x^5

Durant le processus de focalisation, on peut l'interrompre en cliquant sur le bouton [abandonner] et sortir de la fonction en cliquant sur [Sortir]

Condition d'activation | Avoir déclaré la caméra utilisée et réalisé une acquisition en binning 1x1. Avoir déclaré un focuser.
Fonction script associée | gestion du focuser, gestion de caméra, AutoFoc
Tutoriaux vidéos | Un exemple de focalisation automatique (FR, 10.1 Mo). Les imagettes de l'exemple (211 Ko). Exemple de déclaration de caméra et focuser (FR, 914 Ko, les menus datent de 2006 mais toujours d'actualités).
Voir aussi ... | Modifier un graphe sous PRiSM

Version Novembre 2006


Caméra / Acquisition des flats

> Caméra > Acquisition des Flats

Lancement : Menu [Caméra] > [Acquisition des Flats] (La caméra doit être connectée pour accéder à ce menu).

Cette fonction permet de lancer l'acquisition automatique d'images de PLU (Plages de Luninosité Uniforme, ou Flats).

Il faut au préalable avoir lancé la fonction [Caméra] > [Activer Panel Acquisition Caméra].

Au lancement de cette fonction, la fenêtre suivante apparaît :

Le panel des flats
Le premier onglet

Ce premier onglet permet de saisir les informations suivantes :

  • Le dossier dans lequel les images à conserver doivent être enregistrées
  • Le nombre d'images à prendre et à valider pour faire un flat
  • le temps d'exposition maximum
  • le temps d'exposition de départ
  • Le nom générique des images

En cliquant sur [Démarrer], PRiSM va faire une pose correspondant au temps de pose fixé. Si l'intensité moyenne mesurée sur l'image ne se situe pas entre la valeur "min" (1/2 de la dynamique) et la valeur "max" (9/10 de la dynamique), l'image ne sera pas conservée et donc ne sera pas validée. Cette intensité est représentée par une barre de progression. Suivant la dynamique, le temps de pose va être progressivement augmenté jusqu'à ce que la dynamique se situe entre les valeurs min et max. Cependant, s'il fait trop nuit, on peut empêcher au temps d'exposition d'augmenter indéfiniment en remplissant l'option correspondante.

La case [Annuler] permet de stopper l'algorithme et donc de stopper l'exposition. La case [Effacer le Log] permet d'effacer les informations données.

Le deuxième onglet permet de Régler les paramètres de lecture du capteur :

Le panel des flats
Le deuxième onglet

Il est possible de choisir les valeurs suivantes :

  • Le domaine de définition en pixel de la fenêtre d'acquisition.
  • La fenêtre de calcul des grandeurs statitstiques.
  • Le binning et la lecture par miroir
  • le type de statistique à appliquer pour le calcul de la dynamique qui servira à estimer s'il faut garder l'image ou non

Exemple :

L'acquisition se déroule dès que l'on appuie sur le bouton "Démarrer" :

L'acquisition se déroule
La barre de progression

Comme expliqué ci-dessus, le temps de pose va se régler de telle façon à ce que la dynamique représentée par la barre de progression reste toujours entre les valeurs min et max.

Le réglage de la dynamique
Le réglage de la dynamqiue (bien jaugée dès le début !) ... Les falts sont enregistrés depuis le début.

Les images sont automatiquement sauvées avec les noms suivants :

Flat-0001.cpa
Flat-0002.cpa
Flat-0003.cpa
.......

Une fois acquises, les images peuvent être additionnées par une pile médiane (Menu [Prétraitement] > [Pile médiane (plusieurs images)]).

Remarque importante :
Il faut obtenir plusieurs flats afin d'avoir un flat générique exploitable pour les prétraitements. Pour obtenir le "flat générique", l'étape suivante consiste à soustraire l'image d'offset générique à ce flat, voire le noir si le temps de pose du flat est suffisamment long pour ne pouvoir négliger le noir. Afin d'obtenir l'image d'offset générique, on se reportera à la partie concernée. Le "flat générique" pourra alors servir dans les prétraitements :

Exemple de flat générique
Ce denier pourra alors être appelé "Flat.cpa"

PRiSM réalise, si l'utilisateur le désire, cette opération automatiquement à partir du menu [Prétraitement] > [Créer Flat, Dark, Offset maîtres]

Images supportant cette fonction :
Images CPA

Fonction(s) Script associée(s):
SaveCPA, PreProcess

Conditions d'activation :
Avoir déclaré la caméra utilisée

Prérequis :
Aucun

Voir aussi :
[Prétraitement] > [Créer Flat, Dark, Offset maîtres]

Version Nov 2005


Caméra / Calcul de l'heure des flats

> Caméra > Calcul de l'heure pour les flats

Lancement : Menu [Caméra] > [Calcul de l'heure pour les flats] (La caméra n'a pas besoin d'être connectée pour accéder à ce menu).

Cette fonction permet de calculer le moment optimal pour lancer les flats.

Au lancement de cette fonction, la fenêtre suivante apparaît (les options des deux premières colonnes sont à régler par l'utilisateur et retenues par la suite dans la base de registre windows) :

Le lieu choisi est celui sélectionné à partir du menu "Option / Lieu d'observation par défaut".
Un appui sur le bouton "Calcul" permet d'obtenir les heures optimales à partir desquels l'acquisition des flats pourra être lancée afin de satisfaire à la hauteur du Soleil choisi.

On obtient alors un résultat du style suivant :

Le calcul des heures de flat

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Prérequis :
Aucun

Voir aussi :
[Caméra] > [Acquisition des Flats]

Version Décembre 2009


Caméra / Acquisition des noirs

> Caméra > Acquisition des Noirs

Lancement : Menu [Caméra] > [Acquisition des Noirs] (La caméra doit être connectée pour accéder à ce menu).

Cette fonction permet de lancer l'acquisition automatique d'images de Noirs (en anglais : "Darks").

Il faut au préalable avoir lancé la fonction [Caméra] > [Activer Panel Acquisition Caméra].

Au lancement de cette fonction, la fenêtre suivante apparaît :

Le panel d'acquisition
Le premier onglet

Ce premier onglet permet de saisir les informations suivantes :

  • Le dossier dans lequel les images à conserver doivent être enregistrées
  • Le nombre d'images à prendre et à valider pour faire un flat
  • le temps d'exposition
  • Le nom générique des images

En cliquant sur [Démarrer], PRiSM va effectuer une série de poses correspondant au temps de pose fixé. Les informations sont marquées dans la fenêtre d'information et chaque image est automatiquement sauvegardée dans le répertoire spécifié.

La case [Annuler] permet de stopper l'algorithme et donc de stopper l'exposition. La case [Effacer le Log] permet d'effacer les informations données.

La fenêtre d'acquisition
La fenêtre d'information en cours d'acquisition

Le deuxième onglet permet de Régler les paramètres de lecture du capteur :

Le deuxième onglet
Le deuxième onglet

Il est possible de choisir les valeurs suivantes :

  • Le domaine de définition en pixel de la fenêtre d'acquisition.
  • La fenêtre de calcul des grandeurs statitstiques.
  • Le binning et la lecture par miroir
  • le type de statistique à appliquer pour le calcul de la dynamique qui servira à estimer s'il faut garder l'image ou non

Ici, Les images sont automatiquement sauvées avec les noms suivants :

Dark-0001.cpa
Dark-0002.cpa
Dark-0003.cpa
.......

Une fois acquises, les images peuvent être additionnées par une pile médiane (Menu [Prétraitement] > [Pile médiane (plusieurs images)]).

Remarque importante :
Il faut obtenir plusieurs noirs afin d'avoir un noir générique exploitable pour les prétraitements. Pour obtenir le "noir générique", l'étape suivante consiste à soustraire l'image d'offset générique à ce flat. Afin d'obtenir l'image d'offset générique, on se reportera à la partie concernée. Le "noir générique" pourra alors servir dans les prétraitements :

Noir générique
Exemple de noir générique; ce denier pourra par exemple être appelé "Noir.cpa"

PRiSM réalise, si l'utilisateur le désire, cette opération automatiquement à partir du menu [Prétraitement] > [Créer Flat, Dark, Offset maîtres]

Images supportant cette fonction :
Images CPA

Fonction(s) Script associée(s):
SaveCPA, PreProcess

Conditions d'activation :
Avoir déclaré la caméra utilisée

Prérequis :
Aucun

Voir aussi :
[Prétraitement] > [Créer Flat, Dark, Offset maîtres]

Version Nov 2005


Caméra / Acquisition des offsets

> Caméra > Acquisition des Offsets

Lancement : Menu [Caméra] > [Acquisition des Offsets] (La caméra doit être connectée pour accéder à ce menu).

Cette fonction permet de lancer l'acquisition automatique d'images "constantes" (en anglais : "Offsets").

Il faut au préalable avoir lancé la fonction [Caméra] > [Activer Panel Acquisition Caméra].

Au lancement de cette fonction, la fenêtre suivante apparaît :

Le panel d'acquisition
Le premier onglet

Ce premier onglet permet de saisir les informations suivantes :

  • Le dossier dans lequel les images à conserver doivent être enregistrées
  • Le nombre d'images à prendre et à valider pour faire un flat
  • Le nom générique des images

En cliquant sur [Démarrer], PRiSM va effectuer une série de poses correspondant au temps de pose fixé. Les informations sont marquées dans la fenêtre d'information et chaque image est automatiquement sauvegardée dans le répertoire spécifié.

La case [Annuler] permet de stopper l'algorithme et donc de stopper l'exposition. La case [Effacer le Log] permet d'effacer les informations données.

La fenêtre d'acquisition
La fenêtre d'information en cours d'acquisition

Le deuxième onglet permet de Régler les paramètres de lecture du capteur :

Le deuxième onglet
Le deuxième onglet

Il est possible de choisir les valeurs suivantes :

  • Le domaine de définition en pixel de la fenêtre d'acquisition.
  • La fenêtre de calcul des grandeurs statitstiques.
  • Le binning et la lecture par miroir
  • le type de statistique à appliquer pour le calcul de la dynamique qui servira à estimer s'il faut garder l'image ou non

Ici, Les images sont automatiquement sauvées avec les noms suivants :

Offset-0001.cpa
Offset-0002.cpa
Offset-0003.cpa
.......

Une fois acquises, les images peuvent être additionnées par une pile médiane (Menu [Prétraitement] > [Pile médiane (plusieurs images)]).

Remarque importante :
Il faut obtenir plusieurs offsets afin d'avoir un offset générique exploitable pour les prétraitements. L'"offset générique" pourra alors servir dans les prétraitements :

L'offset générique
Exemple d'offset générique; ce denier pourra par exemple être appelé "Offset.cpa"

PRiSM réalise, si l'utilisateur le désire, cette opération automatiquement à partir du menu [Prétraitement] > [Créer Flat, Dark, Offset maîtres]

Images supportant cette fonction :
Images CPA

Fonction(s) Script associée(s):
SaveCPA, PreProcess

Conditions d'activation :
Avoir déclaré la caméra utilisée

Prérequis :
Aucun

Voir aussi :
[Prétraitement] > [Créer Flat, Dark, Offset maîtres]

Version Nov 2005


Caméra / Acquisition avec un APN CANON

> Caméra > Acquisition avec un APN

Lancement : Menu [Caméra] > [Acquisition avec APN CANON digital]

But : Acquérir une image avec PRiSM à l'aide d'un appareil photo numérique CANON série EOS.

Fonction(s) Script associée(s):
xxxxx

2008


Caméra / Acquisition en mode Vidéo

> Caméra > Acquisition avec une webcam

Lancement : Menu [Caméra] > [Acquisition avec webcam (VFW)]

But : Acquérir et "travailler" une image avec PRiSM à l'aide d'une WEBCAM.

Attention : Page en construction

Cette fonction permet de lancer les acquisitions d'images avec une caméra de type webcam.

Au lancement de cette fonction, la fenêtre "Vidéo capture" s'ouvre :

Ouverture du "Vidéo Capture"
<Cas particulier :

Si la WEBCAM n'es tpas connectée, le message suivant s'affiche :

Cliquez [OK] et la fenêtre "Vidéo capture" se ferme. Connecter la WEBCAM et relancer l'acquisition.
Configuration

L'onglet acquisition
  • Le bouton [Format vidéo] permet de définir le format des images capturées. En cliquant sur ce bouton, on obtient la fenêtre suivante qui permet en particulier de sélectionner la taille des images. Il est fortement conseillé d'utiliser le format 640x480 :

    Régler le format

  • Le bouton [Source vidéo] permet de définir les réglages de la caméra : temps de pose, nombre d'images affichées par secondes, luminosité, etc. L'aspect de cette fenêtre dépend de la caméra utilisée. Pour les caméras VestaPro ou Toucam, cliquer ici pour voir les détails des réglages possibles

  • Le bouton [Compression Vidéo] permet de définir le type de compression utilisé pour les fichiers d'acquisition en mode vidéo (fichiers AVI). Il est fortement conseillé de ne pas utiliser de compression, car tous les modes de compression proposés déteriorent les images.

    Possibilité de compression

  • Le bouton [Choisir driver WEBCAM] permet de choisir le driver de la WEBCAM.

    Choix du driver

Prévisualisation

  • La case à cocher [Prévisualisation] permet de demander l'affichage en temps réel de "ce que voit la caméra".
  • Le champ [Taux de rafraichissement] permet de définir la taux d'images par secondes pour la prévisualisation. Ce taux peut aller de 1 à 30 images par secondes
  • Si la case à cocher [à la taille de la fenêtre] est cochée, l'image de prévisualisation sera déformée de façon à occuper toute la place disponible dans la zone de prévisualisation
  • Si la case à cocher [Taille proportionnelle] est cochée, l'image de prévisualisation occupera l'espace disponible dans la zone de prévisualisation, mais sans que ses proportions soient modifiée.
Acquisition Simple
Acquisition AVI
Acquisition images par images

L'onglet acquisition images par images

Il est possible d'acquérir des images l'une après l'autre, chaque image étant alors enregistrée sous la forme d'un fichier au format BMP. Le mode opératoire est le suivant :

  • Dans la zone "Single Frame", cliquer sur le bouton [image] qui permet de définir le nom et l'emplacement à donner aux fichiers des images acquises.
  • Cliquer sur le bouton [Save to file] pour lancer l'acquisition d'une image. Vous pouvez cliquer plusieurs fois sur ce bouton. A chaque click, une image est acquise et enregistrée dans un fichier BMP. Vous pouvez aussi cliquer sur le bouton [To Clipboard] pour lancer l'acquisition d'une image qui sera placée dans le presse papier.

Acquisitions en mode "vidéo"

Il est possible de faire des acquisitions en mode vidéo. Dans ce mode des images vont être acquises et enregistrées dans un fichier unique au format AVI, contenant toutes les images. Le mode opératoire est le suivant :

  • Dans la zone "AVI", cliquer sur le bouton [image] qui permet de définir le nom et l'emplacement à donner fichier AVI qui contiendra la vidéo.
  • Cliquer sur le bouton [Parameters] pour définir les parmètres de l'acquisition. Une fenêtre s'ouvre permettant de définir le nombre d'images par seconde qui doivent être numérisées, et la durée de l'acquisition.
  • Cliquer sur le bouton [Start] pour lancer l'acquisition des images.

Fonction(s) Script associée(s):
Voir la partie sur les scripts et les fonctions "caméra"

Conditions d'activation :
Avoir déclaré la webcam

Prérequis :
Aucun

Voir aussi :
Traitement d'une séquence vidéo

Version Mai 2005


Caméra / Acquisition en mode Vidéo

> Caméra > Acquisition en mode Vidéo

Lancement : Menu [Caméra] > [Acquisition DirectShow]

But : Acquérir et "travailler" une image avec PRiSM à l'aide d'une WEBCAM ou d'une caméra DMK/DFK.

Les onglets sont les suivants :

L'onglet principal permet de gérer les répertoires de sauvegardes d'image et de vidéo ainsi que la surveillance des paramètres d'intensité d'enregistrement.
L'onglet Guidage est en construction de programmation.
L'onglet Divers permet d'ajouter des options qui n'existaient pas avec l'ancien panel des WEBCAM.
L'onglet sources vidéo permet de sélectionner le driver utilisé pour la caméra.

Onglet Principal

Les réglages de cet onglet sont les suivants :

  • Répertoire sav : Réglage du répertoire où seront sauvegardées les vidéos.

  • Nom de base : Réglage du nom de sauvegarde de la vidéo suivi de son index (au cas où plusieurs vidéos porteraient le même nom).

  • Option de capture : Temps maximum de la capture.

  • Boutons Capturer et Stop : Lancer et arrêter l'enregistrement.

  • Bouton Temps de pose : Régler le temps de pose de chaque image pour les caméras qui le permettent (ce panel est moins adapté à l'usage d'une webcam que le panel de saisie qui lui est dédié).

  • Case Montrer l'histogramme : Une fois cette case cochée, un histogramme représentant simultanément les trois composantes couleurs est représenté. Cet histogramme évolue dans le temps au même rythme que le temps de pose choisi pour chacune des images.

  • Rouge / Vert / Bleu : Statistique pour chacune des couleurs pour l'image représentee.

  • Valeurs X,Y -> R, V, B : Valeurs de l'intensitée dans les trois couleurs à l'endroit où pointe le curseur de la souris.

  • Duree d'enregistrement : Durée qui s'est écoulée depuis la saisie du bouton capturer.

Onglet Guidage

Le bouton calibration a la même description que pour une caméra CCD classique.

Le bouton Guidage permet de lancer le guidage une fois la calibration effectuée, l'autoguidage s'arrêtant à l'aide du bouton Stop Guidage.

La partie paramètre permet de rappeler le dispositif d'autoguidage ainsi que l'échantillonnage. Ce dernier est réglable et une petite fenêtre de calcul est fournie afin de faciliter le calcul :

Une fois le guidage lancé, la fenêtre de tracking "classique" apparait :

Onglet Divers

Les réglages de cet onglet sont les suivants :

  • Voir un réticule : Permet de faire apparaître un réticule au centre de l'image avec éventuellement un fond blanc si l'option est cochée.

  • Voir un zoom : Puissance du zoom pour l'agrandissement dans la fenêtre supérieure.

  • Copie sur image : Permet de dupliquer ce qui est vu dans une fenêtre image monochrome ou couleur. Les seuils peuvent être réglés automatiquement :

Onglet Sources vidéo

Cet onglet permet de choisir le driver utilisé pour la caméra ainsi que le temps de pose pour les caméras dont il est réglable ...

Fonction(s) Script associée(s):
Aucune pour le moment.

Version Octobre 2008


Caméra / Configuration

> Caméra > Configuration Caméra secondaire

Lancement : Menu [Caméras] > [Configuration Caméra secondaire (guidage)]

Cette fonction permet de sélectionner une caméra secondaire (avec un éventuel capteur d'autoguidage). Cette caméra peut être identique ou non à la première. Il est donc possible de faire fonctionner 2 caméras CCD sous la même instance de PRiSM. Ce menu a surtout été créé dans le but d'utiliser une caméra de guidage différente de la caméra principale.

Pour les réglages, on se reportera à la configuration de la caméra principale.

Remarque 1 : L'utilisation de deux caméras SBIG d'après Cyril Cavadore :

Depuis la version 7.1.5 de Prism, il est possible de piloter en même temps deux caméra SBIG sous une seule instance de PRISM (c'est-à-dire le logiciel lancé une seule fois)

Ici nous avons connecté deux caméras USB, une ST-8 et une ST-2K, je recommande :

  • de ne pas débrancher les caméras du PC et laisser sur le port USB qui leur est "attitré".
  • si on débranche les caméras, se souvenir sur quel port USB elles se trouvent.

Dans le gestionnaire de périphériques de Windows, nous voyons les deux caméras branchées en même temps.

Ce qu'il ne faut surtout pas faire dans les panneaux de configuration de caméra principale et secondaire (ou de guidage), c'est de laisser en automatique la détection d' interface (USB AUTO).. on peut se retrouver avec la même caméra en caméra principale et en caméra secondaire !!! Une curiosité du driver SBIG !! Il faut forcer les ports (Prism va ensuite les mémoriser). Voilà pourquoi il ne vaut mieux ne pas débrancher les caméras après utilisation ou les rebrancher sur les mêmes ports USB.

Par exemple, ici, la caméra principale est sur le Port USB1 (on fera des essais depuis le port USB1 à USB4) :

La caméra secondaire se trouve sur le port USB2 mais attention, cela peut varier d'un PC à un autre ... faire des essais en caméra solo pour déterminer le bon port :

Et voila ! On a les deux panneaux d'acquisitions des deux caméras prêtes à fonctionner en même temps :

Attention : le driver SBIG, propre à la société SBIG, a ses propres limitations : la lecture de deux images des deux caméras en même temps n'est pas possible. PRISM le gère mais ne pas s'étonner qu'une caméra semble bloquée pendant la lecture de l'image de l'autre ...

Version Avril 2009


Caméra / Activer panneau d'acquisition

> Caméra > Activer Panneau Acquisition Caméra secondaire

Lancement : Menu [Caméras] > [Activer Caméra de guidage]

Cette fonction permet d'activer la caméra secondaire sous PRiSM, une fois que cette dernière a été configurée.

La gestion de la caméra se fait comme la gestion de la caméra principale (avec son éventuel capteur de guidage intégré) !

Ce menu a surtout été créé dans le but d'utiliser une caméra de guidage différente de la caméra principale.

Remarque 1 : L'utilisation de deux caméras SBIG d'après Cyril Cavadore :

Depuis la version 7.1.5 de Prism, il est possible de piloter en même temps deux caméra SBIG sous une seule instance de PRISM (c'est-à-dire le logiciel lancé une seule fois)

Ici nous avons connecté deux caméras USB, une ST-8 et une ST-2K, je recommande :

  • de ne pas débrancher les caméras du PC et laisser sur le port USB qui leur est "attitré".
  • si on débranche les caméras, se souvenir sur quel port USB elles se trouvent.

Dans le gestionnaire de périphériques de Windows, nous voyons les deux caméras branchées en même temps.

Ce qu'il ne faut surtout pas faire dans les panneaux de configuration de caméra principale et secondaire (ou de guidage), c'est de laisser en automatique la détection d' interface (USB AUTO).. on peut se retrouver avec la même caméra en caméra principale et en caméra secondaire !!! Une curiosité du driver SBIG !! Il faut forcer les ports (Prism va ensuite les mémoriser). Voilà pourquoi il ne vaut mieux ne pas débrancher les caméras après utilisation ou les rebrancher sur les mêmes ports USB.

Par exemple, ici, la caméra principale est sur le Port USB1 (on fera des essais depuis le port USB1 à USB4) :

La caméra secondaire se trouve sur le port USB2 mais attention, cela peut varier d'un PC à un autre ... faire des essais en caméra solo pour déterminer le bon port :

Et voila ! On a les deux panneaux d'acquisitions des deux caméras prêtes à fonctionner en même temps :

Attention : le driver SBIG, propre à la société SBIG, a ses propres limitations : la lecture de deux images des deux caméras en même temps n'est pas possible. PRISM le gère mais ne pas s'étonner qu'une caméra semble bloquée pendant la lecture de l'image de l'autre ...

Fonction(s) Script associée(s):
Aucune pour le moment

Conditions d'activation :
Avoir déclaré la caméra utilisée

Voir aussi :
Le type de panel suivant le type de caméra
Acquisition avec l'ancien panel

Version Avril 2009


Les télescopes et accessoires supportés par PRiSM

Les systèmes télescope, les encodeurs, moteurs et autres accessoires supportés par PRiSM sont les suivants :

  1. Les systèmes de télescope complets :
    • LX-200 Meade et compatibles (y compris les modèles GPS).
    • Monture commandée par le système MCMT : "MMMT Telescope".
    • Système dont une DLL (Dynamic Link Library) a été développée par les utilisateurs (Voir point n°3). On se reportera alors aux points 3. et 4. de cette page pour que l'instrument soit intégré par ses codeurs et ses moteurs.
    • Telescope ASCOM : Tous les télescope accessibles depuis cette page.

  2. Codeurs :
    • Sky Commander
    • Eureka 2001
    • Ouranos
    • Codeurs dont une DLL a été développée par les utilisateurs (Voir point n°3)
    • Codeurs des sytèmes cités précedemment !

  3. Moteurs :
    • Moteurs dont une DLL a été développée par les utilisateurs (Voir point n°3)
    • Moteurs des systèmes cités précedemment !

  4. Focuser :
    • externe par librarie DLL : à l'heure actuelle, Focuser MCMT, Robofocus, Focuser OPTEC.
    • externe par driver ASCOM

  5. Roue à filtre :
    • externe par librarie DLL : à l'heure actuelle, OPTEC et True Technology.
    • externe par driver ASCOM.

  6. Pilotage dome :
    • externe par librarie DLL : à l'heure actuelle, le dome ethernet.
    • externe par driver ASCOM.

  7. GPS :
    • A l'heure actuelle, seuls les GPS Garmin sont supportés.

  8. Station Météo :
    • A l'heure actuelle, seuls les stations Lacrosse de la série WS2600 et WS3200 sont supportées.

  9. Moniteur de nuages :
    • Sont supportés les moniteurs de nuages : Boltwood CloudSensor, Sentinel Shelyak et AAG CloudWatcher.

  10. Moniteur de nuages :
    • Seul est supporté le dérotateur OPTEC.

Remarque :

Le protocole de pilotage de télescope le plus efficace à l'heure actuelle est le protocole LX200. Pour qu'un nouveau protocole de pilotage de télescope soit implémenté dans PRiSM, il faut qu'une documentation technique complète soit fournie et qu'un télescope mettant en oeuvre ce protocole soit mis à la disposition de l'équipe de développement pendant quelques semaines.

Les différents points abordés seront les suivants :

  1. Le menu Télescope / Configuration.
  2. Le panel de gestion et menus des télescope pris en charge.
  3. Le panel de gestion des focusers.
  4. Le panel de gestion des roues à filtres.
  5. Le panel de gestion des dérotateurs de champ.
  6. Le panel de gestion des domes et abris.
Version Avril 2009


Télescope / Configuration

Télescope > Configuration

Lancement : Menu [Télescope] > [Configuration]

Ce menu est utile pour déclarer à PRiSM la monture et les accessoires qui devront être pris en compte. La connexion pourra être établie après avoir complété ce menu ...

Les menus de configuration
  • TELESCOPE :

Ceci est le premier réglage proposé et concerne les systèmes complets : . Lorsque qu'un système est complété, PRiSM prévient l'utilisateur que les codeurs et moteurs indépendants sont désactivés puisqu'intégrés au système :

En ce qui concerne le système "LX200", le focuser externe est lui aussi désactivé :

Trois systèmes complets sont accessibles :

Le système LX200 :

Système LX200
  • Port de communication à régler

  • Temps entre deux interrogations de position des codeurs

  • Temps de lecture et d'écriture à régler : certains systèmes compatibles LX200 ne supportent pas d'être interrogé très peu de temps après une instruction en écriture. Ces paramètres doivnet donc être réglés en fonction du système (lire le manuel!). Si ces derniers sont trop longs, la réaction du matériel risque d'être très longue. S'ils sont trop courts, la lecture risque d'être erronée et donc ceci risque d'entraîner une déconnexion.

  • La prise en compte ou non du focuser du LX200 (de façon à prendre en compte éventuellement un focuser externe).

  • Case à cocher [Ne pas utiliser les capacités de contrôle des axes RA/DEC de la motorisation] : Cette case spécifie l'instrument qui va lancer les ordres d'autoguidage au LX200 : soit les moteurs du télescope, soit les relais de la caméra CCD :
    • L'utilisateur peut exploiter la capacité du LX200 d'envoyer des mouvemnts lents en fonction de ce qui est calculé par PRiSM pour l'autoguidage. Pour utiliser de telles capacités, la case doit être cochée. L'ordre de connexion obligatoire dans ce cas est d'abord le télescope (ou moteurs seuls) PUIS la caméra.
    • Si l'utilisateur veut passer directement par la gestion de l'autoguidage par les relais de la caméra (dont la sortie autoguidage est reliée au LX200), il ne faut pas cocher cette case. L'ordre de connexion obligatoire dans ce cas est d'abord avec la caméra PUIS avec les moteurs du télescope.
    • Le mode compatible LX200 ne tient compte que des commandes de base du LX200 pour le matériel juste compatible avec un tel protocole.
Le système ASCOM :

Pour les sytèmes ASCOM, il faut cliquer sur le bouton radio "ASCOM Telescopes". Afin de choisir le type de télescope désiré, il est nécessaire que la plate-forme soit installée. L'installation doit se réaliser de la façon suivante :

  • Aller sur le site d'ascom initiative.
  • Télécharger la plate forme (à cette heure, la version 6.1 SP1).
  • Si après installation de la plateforme, le driver n'est pas dans la liste, il faut aller dans la partie de télechargement des drivers de montures, le charger et l'installer ou directement sur le site du fabricant de la monture.

Pour de plus amples renseignements sur l'installation de la plate forme ASCOM, aller à la page ici.

Le réglage ASCOM

Il faut régler les propriétés du système. l'ensemble ne pourra être validé que si ces dernières ont été réglées :

Ces propriétés dépendant du système utilisé, il est impossible de toutes les décrires ici. Cependant, toutes les propriétés possibles sont résumées ensuite dans les différents onglets proposés :

Onglet décrivant les fonctions de pointages accéssibles | Onglet décrivant les actions possibles dans la raquette du télescope, onglet "Parking". | Onglet décrivant les possibilités d'autoguidage, notamment si l'autoguidage peut être réalisé sans utiliser les éventuels relais du boitier d'autoguidage.
L'onglet prise en charge des Vitesses
La prise en charge de vitesses différentielles, retranscrite dans l'onglet "vitesses différentielles" de la raquette du télescope. | Le réglage des vitesses.

Attention : suivant le type d'instrument et la version ASCOM supportée, toutes les fonctionnalités présentées ci-dessus ne sont pas nécessairement présente. Seules seront présentes les fonctionnalités avec un "Oui" comme indication !

  • MOTORISATION / POINTAGE :

Afin que le panel de réglage Codeurs/Moteurs séparé apparaissent, il faut choisir dans "Type de télescope" : "Avec codeurs/moteurs séparés"

Dans le cas d'un système non complet (ou séparé en plusieurs parties), il faut déclarer les accessoires un par un :

Sélectionner un point ...

Un petit apparté avant ....

La question que l'on peut se poser : pourquoi une DLL dans certains cas ?
La réponse est plutôt simple : chaque appareil possède ses propres spécificitées et il est très difficile d'intégrer les spécificitées de chacun d'eux dans un panel de réglages généraux à tous les appareils. Le programmeur de PRiSM ne pouvant posséder tous les accessoires existants sur le marché (sûrement à son grand désespoir !), il était donc nécessaire de créer un moyen afin que l'utilisateur, qui possède normalement l'instrument sur place, puisse, par lui-même, adapter son système au logiciel.

A l'heure actuelle, seuls les télescopes Meade LX200, MCMT et MCMT II sont parfaitement pris en compte par le logiciel. Certes, beaucoup de télescopes fonctionnent suivant ce principe (et d'ailleurs le "langage" LX200 a été dérivé et complété suivant les instruments). Cependant, ces instruments possèdent pour la plupart des spécificités qui ne sont pas nécessairement pris en compte ...

DLL = Dynamic Link Library. Ce terme peut faire peur mais le principe de la DLL reste simple : il s'agit d'une suite de fonction à compléter (ou non) permettant d'ordonner certaines commandes à la monture. Ces commandes sont imposées dans la documentation de la DLL mais elles doivent être intégralement complétées à l'intérieur de cette dernière. PRiSM viendra ensuite "piocher" à volonté les instructions qu'il a besoin suivant la demande de l'utilisateur ...

Suivant la philosophie du programmeur, il est clairement séparé la notion de codeurs, de moteurs et de fonctions GOTO pour les télescopes le permettant. Ceci permet d'ailleurs de ne programmer qu'une partie de la DLL suivant que l'on veuille ne tenir compte que de codeurs, que des moteurs voire du système télescope en entier.

Pour chaque accessoire, une DLL de simulation est proposée pour vérification du fonctionnement de la liaison.

  • Codeurs :

Il faut choisir parmi la liste des codeurs proposés. Pour chacun, l'utilisateur doit compléter un minimum d'information avant d'établir la liaison.

Les divers codeurs

En ce qui concerne la prise des codeurs par DLL, sont actuellement disponibles les codeurs correspondant aux systèmes : MCMT II, codeurs Ouranos et T55 (Pic Du Midi).
Les DLL correspondantes se situent dans le sous-répertoire "Plugins/Telescope" du répertoire principal de PRiSM.

Il ne faut pas oublier de compléter le bouton [Accéder à la configuration de ce matériel]. Toutes ces DLL sont automatiquement mises à jour par internet lorsque cette dernière est acceptée.

  • Moteurs :

Il faut choisir parmi la liste des moteurs proposés. Pour chacun, l'utilisateur doit compléter un minimum d'information avant d'établir la liaison.

Les divers moteurs

En ce qui concerne la prise des moteurs par DLL, sont actuellement disponibles les moteurs correspondant aux systèmes : MCMT II et T55 (Pic Du Midi).
Les DLL correspondantes se situent dans le sous-répertoire "Plugins/telescope" du répertoire principal de PRiSM.

Moteurs par DLL

Il ne faut pas oublier de compléter le bouton [Accéder à la configuration de ce matériel] qui pour les mêmes systèmes mèneront aux mêmes réglages que pour les codeurs! Toutes ces DLL sont automatiquement mises à jour par internet lorsque cette dernière est acceptée.

POINT IMPORTANT :
Case à cocher [Ne pas utiliser les capacités de contrôle des axes RA/DEC de la motorisation] :
Cette case spécifie l'instrument qui va lancer les ordres d'autoguidage : Soit les moteurs du télescope, soit les relais de la caméra CCD :

  • L'utilisateur peut exploiter la programmation de la fonction de la DLL si elle est disponible (mouvement en vitesse d'autoguidage d'une certaine durée dans un certain sens). Cette fonction ne sera disponible uniquement si la variable "AbleToGuide" de la DLL a été mise à "True". Pour savoir si cette variable a été déclarée à "True" pour la DLL, il faut demander au programmeur de la DLL ou faire des essais ! Pour utiliser de telles capacités, la case ne doit pas être cochée. L'ordre de connexion obligatoire dans ce cas est d'abord le télescope (ou moteurs seuls) PUIS la caméra.
  • Si l'utilisateur veut passer directement par la gestion de l'autoguidage par les relais de la caméra sur sa monture précablée (câble entre la caméra et la monture), il faut cocher cette case. L'ordre de connexion obligatoire dans ce cas est d'abord avec la caméra PUIS avec les moteurs du télescope.

  • Modèle de pointage (accessible pour tout type de télescope) :

Si un modèle de pointage a été réalisé, il faut l'intégrer au système utilisé AVANT d'établir la communication avec ce dernier.
Pour cela, il faut cocher la case correspondante et fournir le chemin complet du fichier de correction.

La correction par modèle de pointage

Si la monture est une monture allemande, il est nécessaire de saisir un modèle dans chacune des 2 cases afin qu'un modèle différent soit pris suivant le côté du tube par rapport à la monture.

Par défaut, laisser vide le chemin du deuxième modèle si l'utilisateur ne veut prendre en compte qu'un seul modèle (monture à fourche, monture allemande dont le côté du tube par rapport à la monture n'est pas implémenté).

A noter que ce fichier de correction fonctionne également avec tout système gouverné par la DLL.

Pour obtenir ce fichier de correction, il faut le créer SANS correction à partir du menu "Telescope / Correction Codeurs".

  • Limite de pointage (accessible pour tout type de télescope) :

Cette partie est très importante car elle va donner les limites de pointages du système. En effet, en observation automatique géré par script, il nécessaire de préciser de telles données sous peine de voir son tube optique heurter quelque chose.

Les limites de pointage
  • La hauteur limite : hauteur en dessous de laquelle la monture ne pourra être ni calibrée, et ne pourra pointer sur un tel objet à l'aide, par exemple, du menu "identificateur d'objet".

  • La hauteur critique : Hauteur en dessous de laquelle tout pointage sera stoppé. Cette fonction est surtout utile lors de l'exécution de script automatique et, contrairement à la hauteur limite qui ne provoquera dans ce cas aucun arrêt du pointage, la hauteur critique provoquera un arrêt du pointage. Un message averti alors l'utilisateur et il faudra "la main" de l'utilisateur pour relancer le script.

  • La déclinaison maximale : donnée surtout utile pour les utilisateurs de montures à fourche. Elle peut être cependant aussi utile aux utilisateurs de montures allemandes qui désirent empêcher un retournement au méridien et qui veulent bien sûr empêcher le tube de taper dans le pied dans ce cas.
  • Bouton [info] : Rappelle les infos du lieu d'observation.

  • Type de guidage automatique (accessible pour tout type de télescope) :
Système de guidage automatique

Défini un éventuel système utilisé pour le guidage automatique.

Attention : Les fonctions de rappel fins de MCMT II, ASCOM, LX200 et Plugin DLL seront désactivées. Si la caméra CCD possède des ports de guidages ET que la caméra est activée avant le télescope, ce système de guidage sera ignoré.
  • FOCALISATION :

Ceci permet de configurer l'éventuel système de focalisation utilisé.

Dans le cas d'existence de deux focusers sur le système, il faut régler séparemment les deux accessoires. Le principe de réglage est parfaitement identique pour les deux systèmes. Il est rappelé à quelle caméra correspond les réglages.

Cette configuration peut aussi être utilisé avec un système complet LX200 à condition de déconnecter le système de focalisation du LX200 à la configuration (c.f. les systèmes).

Différentes configurations sont proposées :

Le focuser par DLL

En ce qui concerne la prise des moteurs par DLL, sont actuellement disponibles les focusers correspondant aux systèmes : MCMT II, OPTEC TCF-S et HOMEDOME RoboFocus.
Les DLL correspondantes se situent dans le sous-répertoire "Plugins/Focuser" du répertoire principal de PRiSM.

Il ne faut pas oublier de compléter le bouton [Accéder à la configuration de ce matériel] qui mènera aux réglages du focuser! Toutes ces DLL sont automatiquement mises à jour par internet lorsque cette dernière est acceptée.

Le focuser par ASCOM

Il faut régler les propriétés du système. l'ensemble ne pourra être validé que si ces dernières ont été réglées.

Ces propriétés dépendant du système utilisé, il est impossible de toutes les décrires ici. Cependant, toutes les propriétés prises en compte par PRiSM sont résumées dans la fenêtre ci-contre.

Il ne faut pas oublier avant la connexion de compléter la configuration à partir du bouton [configuration].

Séparemment de la configuration ASCOM, il est possible de régler l'intervalle de temps entre deux interrogations du système et le déplacement en µm par pas codeurs.

De façon générale, si une roue à filtre est déclarée, à l'intialisation du focuser, ce dernier va aller à sa position de référence et de plus, mettre la roue à filtre sur le filtre de référence. Ceci permet de régler la focalisation pour l'épaisseur de référence. Il est donc conseillé de bien remplir les parties de configuration de la roue à filtre si cette dernière est utilisée.
  • ROUE A FILTRES :

Ceci permet de configurer l'éventuel roue à filtres utilisée.

Plusieurs types de configuration sont proposées :

Roue à filtre par DLL

En ce qui concerne la prise des roues à filtres par DLL, sont actuellement disponibles les roue à filtres correspondant aux systèmes : True Technology et OPTEC IFW.
Les DLL correspondantes se situent dans le sous-répertoire "Plugins/Filter" du répertoire principal de PRiSM.

Il ne faut pas oublier de compléter le bouton [Accéder à la configuration de ce matériel] qui mènera aux réglages de la roue à filtre ! Toutes ces DLL sont automatiquement mises à jour par internet lorsque cette dernière est acceptée.

Roue à filtre par ASCOM

Il faut régler les propriétés du système. L'ensemble ne pourra être validé que si ces dernières ont été réglées.

Ces propriétés dépendant du système utilisé, il est impossible de toutes les décrires ici. Comme stipulé ci-dessous, un minimum d'information est très important sur les filtres dans le but d'utiliser la focalisation automatique. Notamment, ces informations ne faisant pas partie du driver ASCOM, elles sont réglables indépendamment de ce dernier : le filtre de référence et la position de la focalisation lors de l'utilisation du filtre de référence. PRiSM fera le calcul lui-même pour les autres filtres, même si le filtre utilisé dès le départ n'est pas le filtre de référence.

Le point de focalisation de référence ne concerne que le focuser primaire.
Roue à filtre par ASCOM Roue à filtre par ASCOM

La roue à filtre est étroitement liée au focuser. Si les filtres n'ont pas la même épaisseur, la focalisation sera ajustée en fonction de ce qui est indiqué dans la configuration. On trouve dans la configuration des filtres un filtre de référence et une position de focalisation de référence. Si on utilise ce système, il faut savoir qu'à l'initialisation du focuser, ce dernier va aller sur cette position de référence, et mettre la roue a filtre sur le filtre de référence. Ensuite, lorsqu'on change de filtre, la focalisation se déplace pour compenser la différence d'épaisseur du filtre.

  • DOME / ABRIS :

Ceci permet de configurer l'éventuel dome utilisé.

A l'heure actuelle, deux configurations sont proposée :

Le dome par DLL | Est actuellement disponible par DLL le dome par Ethernet. Il ne faut pas oublier de compléter le bouton [Accéder à la configuration de ce matériel] qui mènera aux réglages du dome ! Toutes ces DLL sont automatiquement mises à jour par internet lorsque cette dernière est acceptée.
Les options possibles par Dome ASCOM | Il faut régler les propriétés du système. L'ensemble ne pourra être validé que si ces dernières ont été réglées. Ces propriétés dépendant du dome utilisé, il est impossible de toutes les décrires ici. Cependant, toutes les propriétés prises en compte par PRiSM sont résumées dans la fenêtre ci-contre. Il ne faut pas oublier avant la connexion de compléter la configuration à partir du bouton [configuration].
  • GPS :

Ceci permet de configurer l'éventuel GPS utilisé. Cette partie a déja été abordée.

  • LOCALISATION GEOGRAPHIQUE :
La localisation géographique

Cette fenêtre ne fait que reprendre les données remplies dans l'option "Site d'observation par défaut". En plus, il est fourni le temps local et universel.

  • STATION METEO :

Les seules stations météos prises en compte dans PRiSM sont actuellement les stations Lacrosse Technology WS2600 et WS3200. Il est nécessaire de définir le chemin du fichier "CUR.LST", fichier où se trouvent les derniers relevés de température, pression et vent. Ces données seront intégrées dans l'entête de l'image CPA (onglet "Météo Extérieure").

  • MONITEUR DE NUAGES :
La déclaration du moniteur de nuages

Seuls les moniteurs de nuages classiques sont pris en compte : soit en utilisant une connexion à distance sur un autre PC dont il faudra préciser l'adresse attribuée par le routeur (système ActiveX qui ne fonctionne que lorsque le moniteur est relié à une version windows PRO) et dans ce cas, l'utilisateur devra préciser l'adresse IP du PC, soit en lisant un fichier créé par le moniteur (éventuellement en réseau en partageant le répertoire auparavant).

  • DEROTATEUR DE CHAMP :

En dehors du dérotateur de simulation, seul le dérotateur PYXIS de chez la société OPTEC est pris en compte par PRiSM : Il faut juste préciser le port COM où est branché l'accessoire ainsi que le sens de rotation choisi pour ce dernier.

  • Interrupteurs :
La déclaration des interrupteurs

Ce passage permet de déclarer les interrupteurs liés à l'instrumentation.

Attention : La déclaration des interrupteurs se fait dans la fenêtre de configuration du télescope. Cependant, la gestion de ces interrupteurs est indépendante de l'instrument. En effet, ces derniers servent souvent, par exemple, pour lancer le télescope. Le contrôle peut donc être lancé, que l'instrument soit connecté ou non.
De plus la plupart de ces interrupteurs n'ont pas de retour à savoir s'ils sont réellement connectés ou non. Il ne faut donc pas s'attendre à une quelconque information sur la connexion de ces accessoires sur la fenêtre de configuration de l'instrument.

Pour le moment sont gérés les interrupteurs suivants : AVIOSYS IPPOWER type 9258S - 9258HP - 9258 DS et VELLMAN K8056.

Pour la configuration, lancer la vidéo de démonstration.

Voir aussi ... | Installer ASCOM sous PRiSM
Fonction script associée | Open_Telescope_Devices
Vidéo tutorial | La configuration des interrupteurs (288 Ko) L'utilisation des interrupteurs (425 Ko)
Version Décembre 2008


Télescope / Etablir la communication

> Télescope > Etablir la communication

Lancement : Menu [Télescope] > [Etablir la communication]

Prérequis :

Les accessoires doivent être déclaré sous PRiSM. Leur déclaration se fait à partir du menu "Telescope / Configuration".

Une fois la connexion établie :

La connexion établie est indiquée une fois TOUS les instruments déclarés connectés. Pour exemple :

Les instruments connectés

Le dispositif de guidage est indiqué. Les dispositifs possibles sont :

  • soit le télescope : système complet (type LX200 ou MCMT), ASCOM ou par DLL. Il ne faut pas cocher alors "Ne pas utiliser les possibilités d'autoguidage du télescope" lors de la configuration de l'instrument et l'ordre de connexion des instrument est important. Ce point est signalé lors du lancement du télescope :

    Ce principe est obligatoire pour les caméras n'ayant pas de relais type SBIG.

  • soit la monture est directement cablée pour l'usage des relais des caméras SBIG. L'ordre de connexion est important. Si l'utilisateur utilise un instrument de pointage en plus de la caméra, la case "Ne pas utiliser les capacités de pointage" doit être cochée. A la liaison avec le télescope, il est indiqué le type d'ordre utilisé :

Cette fenêtre d'information n'apparaîtra que si la case correspondante de l'onglet Telescope du menu [Options] > [Options générales de PRiSM] est cochée.

Fonction(s) Script associée(s):
Open_Telescope_Devices, Close_Telescope_Devices

Conditions d'activation :
Configuration du télescope et accessoires

Version Décembre 2008


Télescope / Raquette de télescope

> Télescope > Raquette télescope

Lancement : Menu [Télescope] > [Raquette télescope (contrôle)]

La raquette de commande du télescope ne peut apparaître uniquement que lorsque la communication avec le télescope est établie. Cette page est très générale et certains onglets pourront ne pas apparaître avec certains télescope.

Il apparaît alors une série d'onglets :

  • Raquette
  • Pointage
  • Vitesses différentielles
  • Parking
  • Etat moteurs
Onglet RAQUETTE

L'onglet Raquette

Cet onglet peut être séparé en plusieurs parties :

  • la première partie remplace la raquette de commande classique d'un télescope. Il est possible d'utiliser les 4 directions possibles. Pour les vitesses de centrage choisies, on utilise le pointeur glissant pour choisir entre Vmin, Vméd et Vmax. Les valeurs de ces trois vitesses sont préréglées à l'intialisation ou à partir de l'icône "max".

  • La valeur sélectionnée est indiquée dans le cadran sous la raquette.

  • Il est également possible d'inverser les directions en Alpha et en Delta séparément.

  • Il faut cocher la case "Stop sidéral" pour stopper le suivi de l'instrument.

Onglet POINTAGE

L'onglet pointage

Cet onglet peut être séparé en plusieurs parties :

  • Un faible déplacement en Alpha et Delta ... ce qui est appelé un offset. Le pointage s'effectue à la dernière vitesse sélectionné à partir de l'onglet "Raquette"

  • Un pointage aux coordonnées voulues à la vitesse de pointage choisie pour le télescope ... Un onglet permet de récupérer les coordonnées de l'objet depuis le presse-papier.

Onglet VITESSES DIFFERENTIELLES

L'onglet Vitesses différentielles
  • Le panel de changement de vitesses différentielles est utilisé afin d'imposer la vitesse de la monture. Certaines monturespeuvent changer leur vitesse de suivi (par une commade toute simple !) pour s'accorder sur la vitesse de La Lune ou celle du Soleil. Il suffit alors de cocher le bouton correspondant et de choisir le bouton radio désiré (avant ou après avoir coché le changement de vitesse ...). La vitesse libre est programmée pour correspondre à l'arrêt des moteurs.
    Pour revenir à une vitesse de suivi sidérale, il suffit de décocher la case de changement de vitesse. Un renseignement sur la durée de changement de vitesse est fourni ... :
  • La vitesse de King permet de faire varier la vitesse en ascension droite pour satisfaire à la réfraction atmosphérique. Pour de amples explications, on se reportera à la documentation sur MCMT II : "C'est quoi la vitesse de KING".

  • Pour utiliser les options sur l'erreur périodique présentées par PRiSM, on se reportera à la documentation du MCMT II : "Réglage du PEC version PRiSM V6". Pour désactiver ces corrections, il faut à nouveau cocher sur la case correspondate.

  • L'option "Arrêter si Télescope trop bas" doit être cochée si on désire que le télescope s'arrête lorsque ce dernier est trop bas par rapport à l'horizon lors d'un pointage automatique ... Cette option utilise la fonction STOP_ALL_Telescope (Arrêt moteur). Comme PRiSM empêche de pointer sous une hauteur critique (réglable au début depuis la configuration dans l'onglet "Pointage Auto"), cette option n'a donc que peu d'importance.

  • Permet d'accéder à la fenêtre "CONSOLE" de la monture. Cette partie est spécifique, accessible qu'à partir une connexion par DLL et dépend de chaque monture.

  • Permet d'accéder aux réglages des vitesses durant l'observation. Cette partie est spécifique, accessible qu'à partir une connexion par DLL et dépend de chaque monture.

Onglet PARKING

Il faut compléter avec des entiers/réels les valeurs de l'angle horaire et de la déclinaison vers lesquelles l'utilisateur désire pointer le télescope avant de le parker. Une fois que le télescope a pointé vers ces valeurs cibles, les moteurs s'arrêtent. Le bouton [Parking] est alors grisé.

L'utilisateur peut alors "dé-parker" le télescope en cliquant sur le bouton correspondant.

Une fois la monture de nouveau en fonctionnement, les valeurs de déclinaison et d'ascension droite connues par PRiSM sont alors affichées en valeurs fractionnaires.

Onglet ETAT MOTEURS

L'onglet Etat moteurs

Rappelle les vitesses de centrage disponibles suivant chacune des directions. Le logiciel fournit également la vitesse de suivi en cours d'utilisation.
Décembre 2010


Télescope / Contrôle d'un focuser

> Télescope > Contrôle du focuser

Lancement : Menu [Télescope] > [Contrôle du Focuser]

Prérequis :

Ce menu ne prend en compte que les focusers définis par des pas codeurs (ce qui n'est pas le cas du la sortie de focalisation type LX200). Le focuser doit être déclaré sous PRiSM. Sa déclaration se fait à partir du menu "Telescope / Configuration". Sa liaison se réalise à partir du menu "Telescope / Etablir communication". Pour rappel, un tel focuser peut être soit géré par le plugin ASCOM ou par une DLL PRiSM.

Une fois la connexion établie :

Une animation flash est proposée pour la gestion du focuser.

La connexion établie est indiquée au lancement par une fenêtre du type : ou [image].

Une fois le menu ouvert, la fenêtre de gestion du focuser apparaît :

Ouverture de la gestion du focuser
Ouverture de la gestion du focuser

Les informations fournies sont celles renvoyées par le focuser. Le petit rectangle qui s'allume en rouge indique la communication avec le focuser. Durant un mouvement du focuser, seul "Déplacement" s'affiche montrant le mouvement du focuser : . Il faut attendre la fin du mouvement pour que les informations soit actualisée (dans ce cas, l'état est à "En attente"). La position de parking n'est réellement définie que pour les focusers gérés par DLL. Elle correspond à la position courante pour les focusers gérés par le plugin ASCOM.

Sont indiqués :

  • Position courante : La position depuis une position de référence de la crémaillère (ou du primaire) en mm et en pas codeurs. Pour les focuser gérés par plugin ASCOM, la position de référence correspond au pas codeur "0". Pour les focuser gérés par DLL, la position de référence est la position de parking, obtenue uniquement si cette dernière a été appelée au moins une fois grâce au bouton [position parking].

  • La température notée par le focuser (attention à l'échauffement des moteurs dû au faible courant circulant dans ces derniers à l'arrêt afin d'éviter une dérive de la focalisation). Ce paramètre se règle simplement à l'aide du programme fourni avec le focuser.

  • Le rappel de nombre de pas codeurs et la distance correspondante pour aller du minimum au maximum de focalisation.

  • L'augmentation (Positif) ou la diminution (Négatif) du chemin optique en fonction de l'augmentation des pas codeurs ainsi que l'état du focuser.

  • Bouton "Position Parking" : suivant le principe utilisé (focuser géré par plugin ASCOM ou par DLL), le focuser va bouger. Lors d'une gestion par ASCOM, ce bouton n'aura aucun effet. Lors d'une gestion par DLL, le focuser va aller au pas codeur correspondant à la valeur définie pour la position de parking. Durant le mouvement du focuser (et suivant la conception de ce dernier), aucune information ne s'affiche. Seul "Déplacement" s'affiche montrant l'éventuel mouvement du focuser si ce dernier n'est pas déjà à sa position de parking. Une fois cette position de parking atteinte, elle correspondra à la position de référence du focuser de position absolue nulle (attention : la position absolue ne pouvant être que positive, il sera impossible d'aller vers des positions absolues négatives ... donc attention de bien régler cette valeur).

  • Les dernières commandes permettent de bouger le focuser. Le mouvement de ce dernier est obligatoirement en distance en mm (et non en pas codeurs). Ce mouvement peut être défini de façon absolue (en fonction de la position de parking) ou de façon relative (dans ce cas, le logiciel raisonne par pas en mm, dans un sens comme dans l'autre). Certaines valeurs sont prédéfinies, notamment utiles lors du rajout de filtre donc d'une augmentation du chemin optique. Pour confirmer le déplacement, il faut cliquer sur "Appliquer". Afin de définir de nouvelles valeurs, il faut cliquer sur le bouton [Changer les positions] et la fenêtre suivante apparaît :

    Définir les nouvelles positions

Un exemple à 10 mm de la position de Parking Ici le focuser Simulator ASCOM (géré par plugin ASCOM) | Durant le mouvement pour passer en absolu de 10 mm à 16,58 mm. Soit un mouvement relatif de 6,58 mm. | Après le mouvement à 16,58 mm de la position de Parking.

Animations FLASH :
La gestion du focuser. (410 Ko)

Fonction(s) Script associée(s):
fonctions accessoires

Conditions d'activation :
Avoir déclaré le focuser

Voir aussi :
Configuration du télescope et accessoires

Version Décembre 2006


Télescope / Contrôle d'une coupole

> Télescope > Contrôle du dôme

Lancement : Menu [Télescope] > [Contrôle du Dôme]

Prérequis :

Le dôme doit être déclaré sous PRiSM. Sa déclaration se fait à partir du menu "Telescope / Configuration". Sa liaison se réalise à partir du menu "Telescope / Etablir communication". Pour rappel, un tel dôme peut être soit géré par le plugin ASCOM ou par une DLL PRiSM.

Un exemple d'utilisation et de mise en oeuvre d'un tel système de dôme avec PRiSM est décrit ici ou en Fichier PDF.

Animations FLASH :
La gestion du dôme.

Fonction(s) Script associée(s):
fonctions accessoires

Conditions d'activation :
Avoir déclaré le dôme

Voir aussi :
Configuration du télescope et accessoires

Version Décembre 2006


Télescope / Contrôle de la roue à filtres

> Télescope > Contrôle de la roue à filtres

Lancement : Menu [Télescope] > [Contrôle de la roue à filtres]

Prérequis :

La roue à filtre doit être déclarée sous PRiSM. Sa déclaration se fait à partir du menu "Telescope / Configuration". Sa liaison se réalise à partir du menu "Telescope / Etablir communication".

Une fois la connexion établie :

La connexion établie est indiquée au lancement : .

Une fois le menu ouvert, la fenêtre de gestion de la roue à filtre apparaît :

La gestion des filtres
Gestion de la roue à filtre

Pour chaque filtre, sont indiqués les noms de chacun des filtres ainsi que leur épaisseur. Ces données ont été fournies lors de la configuration de la roue à filtre. Il ne reste plus qu'à choisir le filtre à sélectionner.

Si un focuser a été déclaré, et ayant rempli la valeur de l'épaisseur du filtre lors de la configuration (connaissance de la différence de chemin optique), il est possible de bouger la focalisation en fonction de l'épaisseur du filtre choisi. Il faut que l'option de synchronisation de focalisation soit alors cochée.

Fonction(s) Script associée(s):
SetFilter

Conditions d'activation :
Avoir déclaré la roue à filtres

Voir aussi :
Configuration du télescope et accessoires

Version Déc 2005


Télescope / Contrôle d'un dérotateur de champ

> Télescope > Contrôle du dérotateur de champ

Lancement : Menu [Télescope] > [Contrôle du dérotateur de champ]

Prérequis :

Le dérotateur doit être déclaré sous PRiSM. Sa déclaration se fait à partir du menu "Telescope / Configuration". Sa liaison se réalise à partir du menu "Telescope / Etablir communication". Pour rappel, un tel dérotateur est pour le moment soit le Pyxis de chez OPTEC, soit le dérotateur de test.

Utilisation du dérotateur

La fenêtre de controle a l'apparence suivante :

Cette fenêtre rappelle la position courante du dérotateur. Pour bouger le dérotateur, il faut fournir la valeur dans la partie position désirée et cliquer sur le bouton [Appliquer]. Le bouton [Zéro] permet de retourner à la position de base qui a été définie. Le bouton [M] permet de minimiser la fenêtre sans la fermer afin de faire de la place sur l'écran.

Ajuste dérotateur sur angle paralactique : Ce bouton permet d'ajuster le dérotateur en fonction de l'angle paralactique du télescope. Cet angle est ...

Tourne le dérotateur de 180° après retournement : Dans le cas où une monture allemande a été définie (pour le moment, ce type de monture n'est défini que par l'intermédiaire d'une DLL ou par la gestion ASCOM), le dérotateur va effectuer une rotation de 180° dans le cas où la monture va effectuer un retournement au méridien dans le cas où le bouton est coché.

Animations FLASH :
La gestion du dérotateur.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Avoir déclaré le dérotateur.

Voir aussi :
Configuration du télescope et accessoires

Version Décembre 2008


Télescope / Contrôle d'un GPS

> Télescope > Contrôle d'un GPS

Lancement : Menu [Télescope] > [Contrôle d'un GPS] (Le GPS doit être déclaré comme existant depuis la configuration des accessoires).

Prérequis :

Le GPS doit être déclaré à partir de la configuration des accessoires du menu Télescope. Seuls les GPS de type GARMIN (en protocle NMEA-0183) sont pris en compte pour le moment. Cependant, ceci fonctionne aussi pour les GPS compatible avec ce standard. Il faut définir le port de communication :

Déclarer le GPS

Contrôles :

Ce menu permet de vérifier le fonctionnement du capteur afin de récupérer les informations de base :

Au lancement de cette fonction, la fenêtre suivante apparaît :

L'écran de contrôle
L'écran de contrôle

Après avoir lancé la communication, l'écran suivant apparaît, où sont renseignés les données de base : La longitude, la latitude, l'altitude. Cette dernière peut être inexacte car la modélisation utilisée pour la Terre ne respecte pas parfaitement sa forme réelle. C'est suivant nos latitudes que la différence est la pire.

L'écran principal
L'écran principal

Ces trois données sont moyennées sur plusieurs valeurs (il vaut mieux une bonne cinquantaine de mesures avant de valider ces valeurs). Pour chacune de ces grandeurs, une erreur RMS est fournie avec la distance correspondante en mètres. Cette erreur correspond à l'écart-type de toutes les valeurs mesurées par rapport à la valeur moyenne. Elle ne correspond nullement à celle estimée par rapport aux valeurs fournies, donnée un peu plus loin.
Une fois que l'utilisateur estime que l'erreur est minimale, ce dernier peut alors rentrer ce site dans la base de données, les coordonnées se complètant automatiquement :

Ajouter un site
Ajouter un site dans la base de données

Différents résultats sont alors fournis :

  • Temps (UTC) : Horaire lu à partir du GPS (en UT)
  • Erreur sphérique :
  • Erreur verticale estimée :Erreur estimée par PRiSM sur l'altitude donnée; cette valeur ne correspond pas nécessairement à celle fournie par l'erreur RMS car n'a rien à voir !
  • Erreur horizontale estimée : Erreur estimée par PRiSM sur la position donnée; cette valeur ne correspond pas nécessairement à celle fournie par l'erreur RMS car n'a rien à voir !
  • Dilution Horizontale de position :
  • Nombre de satellites Visibles : Nombre maximal de satellites qui pourront être captés.

Pour vérifier les satellites captés, il faut aller sur l'écran suivant :

Les satellites visibles et captés
Les satellites; en rouge, les satellites visibles et en jaunes, ceux visibles et captés.

L'écran suivant permet de vérifier la communication entre le PC et le GPS par l'intermédiaire de caractères ASCII :

Les informations lues par le PC
Le langage NMEA

Dans le cas où "Ajouter UTC" est coché, devant chaque mot clé lu, il apparait le temps PC à la lecture (ceci permet d'estimer la différence de temps entre le PC et le GPS) :

Ajouter UTC est coché
Ajouter UTC est coché

Les commandes exploitées par PRiSM sont les suivantes :

  • $GPGSV : Pour lire la position des satellites en vue
  • $GPGLL : Donne la position géographique sur Terre
  • $PGRMC : Données minimales recommandées de spécification GPS
  • $GPGGA : Données d'acquisition du FIX notamment ici pour lire le temps UTC.

    • Pour plus d'informations sur le détail de ces différentes trames, aller sur cet extrait tiré du forum GPS-PASSION.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Avoir déclaré le GPS utilisée

Voir aussi :
Lieu

Version Déc 2005


Télescope / Etat du télescope

> Télescope > Etat du télescope

Lancement : Menu [Télescope] > [Etat du télescope]

Onglet Equatorial

L'onglet

Sont indiqués :

  • Le temps sidéral local.

  • Les coordonnées 2000.0 connus par les codeurs, coordonnées vers lesquelles le télescope est censé pointer.

  • Les coordonnées apparentes sont les coodonnées "réelles" vers lesquelles pointe le télescope. Ces dernières sont différentes des coordonnées 2000.0 de part la prise en compte automatique de la précession des équinoxe et d ela réfraction atmosphérique. Cette différence est d'autant plus flagrante qu'un modèle de pointage a été intégré au système. Dans ce cas, le système tient compte en plus d'erreurs mécaniques, optiques et de mise en station.

  • L'angle horaire vers lequels pointe le télescope, la masse d'air entre l'objet et le télescope ainsi que l'heure en UT sont indépendant de l'éventuelle existance d'un modèle de pointage. Ces paramètres ne dépendent pas du modèle. Ces données sont sauvegardées dans l'information des images CPA si la caméra est prise en compte par PRiSM.

  • Une carte montrant la position de l'objet visé par rapport aux coordonnées horaires : "points cardinaux" et hauteur.

  • Le status du télescope. Lorsque ce dernier est en attente, c'est qu'il attend un ordre de pointage.

Onglet Azimutal

L'onglet

Sont indiqués :

  • L'azimuth représente l'angle entre le méridien nord et l'objet pointé, compté positivement dans le sens (N-E-S-O).

  • La hauteur de la position pointée est donnée.

  • La donnée paralactique : angle entre la direction Pôle-Astre et la direction zénithale Astre-Zénith, comme représenté sur la figure ci-dessous

  • La hauteur apparente diffère de la hauteur précédente, même si un modèle de pointage n'est pas donné : elle vient de la correction de la réfraction atmosphérique.

Onglet Geneurs

L'onglet Geneurs

Sont indiqués :

  • La position apparente de la Lune. Ceci permet à l'utilisateur d'apprécier la qualité de la nuit noire !

  • La position apparente du Soleil. Le crépuscule nautique correspond au moment où le Soleil a une hauteur inférieure à -12° (sous l'horizon ...).

Onglet Modèle de pointage

Sont indiqués :

  • Si le modèle de pointage est activé. Il est rappelé qu'un modèle de pointage correspond à la modélisation des différents défauts mécaniques de l'instruments, constants ou dû au mouvement de ce dernier dans le ciel. Piur la déclaration, voir la page de configuration.

  • Les tableaux fournis ensuite montrent la différence entre un pointage tenant compte du modèle de pointage ou non.

  • Les deux dernières vitesses indiquées donnent les vitesses différentielles à appliquer aux moteurs qui le supportent de façon à contrer les défauts de l'instrument mis en évidence par ce modèle de pointage.

Onglet Subtils

L'onglet

Sont indiqués :

  • La vitesse de king à l'endroit où pointe le télescope. C'est une vitesse qui tient compte du fait que la vitesse "sidérale" n'est pas constante sur la voûte céleste. Pour plus d'informations, aller à cette page. Cette vitesse peut être prise en compte par la monture suivant l'affichage de la correction dans la raquette télescope.

  • La différence de hauteur due à la réfraction et la hauteur réelle de l'objet au dessus de l'horizon.

  • La différence de position entrainée par les coordonnées apparentes par rapport aux coordonnées 2000.0. Cette dernière valeur est rarement nulle , qu'un modèle de pointage ait été intégré ou non, dû à la réfraction atmosphérique et à la précession des équinoxes.

  • Temps restant jusqu'à la hauteur limite défini lors de la configuration.

  • Le rappel des hauteurs critique et limite fournies lors de la configuration.

Onglet Dôme

L'onglet

Sont indiqués :

  • La position absolue de l'ouverture de la coupole. Cette dernière vaut 0° au Nord et est repérée en dégrés, comptés positifs dans le sens N-E-S-O.

  • La position de l'ouverture par rapport à l'endroit où pointe le tube optique. En général, cette valeur est nulle puisque le dome suit le télescope (notamment lorsque l'ensemble est guidé par PRiSM).

Onglet Météo

L'onglet

Sont indiqués :

  • Les données météo mesurées par la sonde météo si elle a été déclarée.

  • La date de dernière mesure des données météo.

Onglet Axes de guidage

Cet onglet permet de rappeler le système utilisé pour le guidage de la monture.

Son réglage se réalise par l'intermédiaire de la configuration du télescope.

Moniteur de nuages

La gestion du moniteur de nuage

Sont indiqués :

  • Les données météo mesurées par le moniteur de nuages s'il a été déclaré.

  • La date de dernière mesure de ces données.

Fonction(s) Script associée(s):
GetDataWeatherStation, Get_Telescope_Position, Get_Telescope_Position_App

Conditions d'activation :
Avoir connecté le télescope et les accessoires

Décembre 2010


Télescope / Horloge

> Télescope > Horloge

Lancement : Menu [Télescope] > [Horloge]

Cette fenêtre permet d'obtenir les informations suivantes :

L'horloge
L'écran horloge
  • Local : Heure locale connue par le PC.
  • TU : Heure en temps universel déduite de l'heure locale.
  • Sideral : Ascension droite du méridien SUD.
  • Jour Julien : Jour julien correspondant à l'heure TU.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Déc 2005


Télescope / Retrouver la position du télescope dans tout le ciel

> Télescope > Création d'un modèle de pointage

Lancement : Menu [Télescope] > [Pointer des champs pour réaliser un modèle de pointage]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction permet de déterminer le décalage obtenu (Angle horaire et Déclinaison) entre l'endroit où aurait dû pointer l'instrument et l'endroit où il pointe réellement. Le principe de fonctionnement est le suivant :

  • Création de la liste de champs à réaliser en intégrant ces champs dans le tableau obtenu depuis le menu [Télescope] > [Liste d'objets - Champs]. En cas de non satisfaction des champs choisis, il faut effacer la liste avant d'en créer une autre. Les champs à pointer (en bleus sur la carte du ciel) disparaissent alors une fois la liste effacée. Il ne faut pas effacer cette liste durant l'execution de cette fonction.
  • Lancement des acquisitions.
  • Pour chaque champ pointé, une comparaison sera effectuée entre les coordonnées (AH et DEC) du centre de l'image réellement obtenu et les coordonnées du centre auxquelles le logiciel s'attendait.
  • Une fois la liste effectuée, un lien direct vers la fonction [Télescope] > [Modèle de pointage] est effectué avec la liste de champs mesurés.

Paramètres à régler pour le choix des champs à effectuer. Dans tous les cas, il est essentiel de prévisualiser les champs à pointer sur la carte du ciel.

Pour une monture à fourche :
Choisir l'option "Tout le ciel". Les écarts sont à régler suivant le nombre de champs désirés. Les contraintes limites peuvent permettre également de limiter les zones de pointage.

Pour une monture allemande :
Suivant la popsition du tube par rapport au pied, choisir le côté du ciel à effectuer : Si le tube est à l'OUEST de la monture, il faut effectuer des mesures "Côté EST du ciel". Au contraire, si le tube est à l'EST de la monture, il faut effectuer des mesures "Côté OUEST du ciel".
De même, les écarts sont à régler suivant le nombre de champs désirés. Les contraintes limites peuvent permettre également de limiter les zones de pointage.
Paramètres de prise d'images à régler.
Le catalogue d'étoiles choisi pour l'étalonnage astrométrique.
Les chemins des catalogues doivent être à jour et sont réglables depuis le menu [Options] > [Chemin des catalogues].
Les paramètres inclus dans le menu [Télescope] > [Paramètres de centrage auto du télescope] n'ont aucune importance pour cette fonction.
Les options de parcours des champs.

Une fois les paramètres réglés, il faut cliquer sur le bouton [image] afin de lancer la création des champs à saisir. Si ces derniers conviennent, il faut alors cliquer sur le bouton de lancement des acquisitions pour lancer le processus (ce bouton devient "annuler" en cours de processus).

Voici par exemple quelques saisies d'écran (en langue FR) lors des mesures pour la création d'un modèle de pointage lorsque le tube est à l'OUEST d'une monture allemande (donc lorsque le tube pointe vers le côté EST du ciel). L'utilisateur a choisi malgré tout l'option de "Tout le ciel" afin de pouvoir régler ces paramètres comme désiré et afin de réaliser quelques pointages alors que la monture dépasse le méridien sud.

Vidéo exemple :
Pointer des champs pour créer un modèle de pointage (FR, 13.6 Mo)

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Télescope et Caméra connectés.

Version Mai 2010


Télescope / Modèle de pointage

> Télescope > Modèle de pointage : de l'acquistion à l'utilisation

Lancement : Menu [Télescope] > [Calcul du modèle de pointage]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Qu'est-ce qu'un "modèle de pointage" ?

Un tel modèle n'est utile que si la monture est entièrement prise en compte par PRiSM et permettra de contrer "automatiquement" les corrections mécaniques à apporter à la monture de façon à ce que le pointage GOTO de la monture soit le plus précis possible.

Un modèle de pointage ne prend pas en compte des problèmes indépendants de l'instrument comme la réfraction atmosphérique de l'astre, le mouvement propre de l'astre, la correction de la précession et de la nutation, la prise en compte de l'aberration annuelle : ces derniers paramètres sont automatiquement corrigés lorsque PRiSM envoie les coordonnées à l'instrument (PRiSM n'envoie pas directement les coordonnées 2000.0 de l'objet mais les coordonnées rectifiées de tous ces paramètres). De ce fait, il faut désactiver toutes les corrections internes de la montures lorsque que cette dernière est connectée à PRiSM, de façon à éviter que ces corrections aient lieu deux fois !

Par contre, un tel modèle permet de prendre en compte tout ce qui est "problème" mécanique de l'instrument. En effet, un télescope ne pointe pas exactement là où il est sensé pointer : Le centre du champ ne correspond pas aux coordonnées Alpha et Delta demandées. Cette erreur est plus ou moins importante, et elle dépend des facteurs suivants :

  • Il existe toujours un décalage de pointage dû à l'imprecision de la mise en station du télescope.
  • La perpendicularité entre l'axe optique et l'axe delta, par construction mécanique, peut être inexacte de plusieurs degrés.
  • Il existe des flexions diverses du tube ou d'autres éléments optiques.
  • D'autres effets géométriques plus difficiles à identifier ....

Cette méthode est utilisée dans tous les observatoires professionnels. A l'aide de PRiSM, cette méthode peut ne pas demander plus de 20 minutes pour quelqu'un de bien entrainé ... Dans le cas où le télescope n'est pas bougé, elle peut être utilisée d'un soir sur l'autre.

Mise en garde pour les montures de type allemande : Ce modèle n'est pas exploitable après un retournement au méridien ("meridian swap") ... Il faut créer deux modèles, un lorsque le tube est orienté vers le coté OUEST et l'autre lorsque ce dernier est orienté vers le côté EST. La gestion de l'instrument par PRiSM permet ensuite de choisir le modèle qui convient suivant le "côté du tube" renvoyé par la monture ... commande optionelle suivant la monture (l'utilisateur aura évidemment défini auparavant les chemins des 2 modèles à la configuration de l'instrument).

I. Prise des mesures pour effectuer un modèle de pointage :

Résumé : Tout d'abord, un nombre suffisant d'étoiles bien réparties dans tout le ciel doit être pointé. Ensuite, il faut mesurer la distance entre la position théorique (celle sur la carte du ciel renvoyée par les codeurs) et la position réelle du telescope (celle vue par le pixel central d'une camera CCD). La position théorique correspond à la position Alpha et Delta dans le ciel exprimée en coordonnées apparentes déjà corrigées de la precession et des effets comme la réfraction, la nutation ... De plus, en réalité, ce n'est pas l'angle Alpha qui est concerné mais l'angle horaire apparent, c'est à dire la distance au méridien du telescope. Par la suite, PRISM va calculer un modèle de pointage permettant de prendre en compte les paramètres géométriques, et de flexion de votre telescope pour reduire les erreurs de pointage.

1. Méthode automatique : (conseillée)

Cette méthode ne peut être effectué que si la monture est prise en compte par PRiSM. Cependant, ceci est obligatoire par la suite pour exploiter le modèle de pointage !
Une fonction a été spécialement développée à cette fin : voir page de la fonction (animation flash correspondante incluse dans la page).

2. Méthode manuelle :

Cette méthode est l'ancienne méthode de saisie des points (hors scripts). Son principe de saisie reste simple : il est basé sur le schéma suivant remarqué lors d'un pointage :

La différence entre 'position codeur' et 'position réelle'

Il faut enregistrer pour chaque pointage la position réelle du télescope (déclinaison réelle : DEC_REEL et Angle horaire réel : AHor_REEL) et la position connue à l'heure actuelle par l'instrument (déclinaison connue : DEC_CODEUR et angle horaire connu : AHor_CODEUR). En ce qui concerne l'angle horaire, ce dernier est calculé à partir du temps sidéral local et de l'ascension droite. Il faut faire la transcription au même instant pour passer de AD_REEL à AHor_REEL et de AD_CODEUR à AHor_CODEUR. Par la suite, le modèle de pointage ne sera valable que pour la zone dont les valeurs extrêmes de déclinaisons et Angles Horaires correspondent aux valeurs extrêmes enregistrées lors de l'établissement du modèle.

il y a deux possibilités :

  • Si l'instrument pointe suffisamment correctement sur une grande partie du ciel pour que le champ soit clairement reconnaissable sur le capteur CCD par astrométrie automatique (comme en apparence sur la figure ci-dessus), il est fortement conseillé d'utiliser le script créé à cet effet pour créer la liste des pointages rééls et des positions codeurs lus. Il est conseillé d'adapter les paramètres de ce script pour utiliser un champ maximum correspondant au champ (Déclinaison et angle horaire) utilisé régulièrement ... : Aller au Script.
  • Si l'instrument pointe moyennement, il faut utiliser une méthode "plus manuelle" et donc un peu moins rapide :
    1. Etablir la liaison avec le télescope et la caméra. Afin de pouvoir utiliser toutes les fonctionnalités de PRiSM, il est nécessaire que les images obtenues par la caméra soient orientées identiquement à celle de la carte du ciel. Une page sur l'orientation de la caméra a été créée afin de définir cette dernière parfaitement (bientôt une animation flash).
    2. Ouvrir la fenêtre de correction des codeurs accessible à partir du menu "Télescope / Modèle correction codeurs"
    3. Calibrer sur un objet connu en le centrant à l'aide du chercheur ou à l'aide du CCD. A ce sujet, il sera préférable de travailler pour un tel modèle "manuel" sur des objets brillants comme des étoiles brillantes afin de les repérer facilement dans le chercheur.
    4. Cliquer avec le bouton droit de la souris au niveau de l'objet centré et atteindre le menu contextuel. Cliquer alors sur "Envoyer Alpha-Delta" pour modèle de pointage comme ci-dessous.

      Ceci a pour but d'envoyer la position réelle du télescope et la position lue sur les codeurs. Pour le premier objet, ces dernières doivent être strictement identiques comme le prouve l'image ci-dessus. Afin de valider les mesures, cliquer sur l'icône [image] de la boite de dialogue sur le modèle de pointage
    5. Pointer à l'aide du logiciel (et surtout pas manuellement !) le télescope vers un autre objet brillant. Corriger à l'aide de la raquette l'erreur de pointage afin de centrer l'objet désiré sur le capteur CCD ou au chercheur. Les nouvelles valeurs à intégrer sont donc différentes comme on peut le voir ci-dessous ...

      Les valeurs diffèrent maintenant à cause de l'erreur de pointage. Les codeurs lisent une position qui ne correspondent pas tout à fait à la position réelle de l'instrument. Afin de valider les mesures, cliquer sur l'icône [image] de la boite de dialogue sur le modèle de pointage. Dans la partie "position mesurée" s'affichent les coordonnées connues par les codeurs. Dans la partie "position réelle" s'affichent les coordonnées correspondant au point à partir duquel on a ouvert le menu contextuel de la carte du ciel soit les coordonnées apparentes de l'étoile que l'on est censé avoir repéré au centre du chercheur ou du CCD.
    6. Répéter l'étape 4. autant de fois que nécessaire pour couvrir un champ le plus grand possible. Une mesure sur une trentaine d'objets sera une bonne mesure. ATTENTION : Ne pas recalibrer le télescope entre chaque mesure. Le modèle serait alors à recommencer puisqu'il faut connaître la dose d'erreur pour chaque pointage afin de tenir de toutes ces erreurs en même temps pour les corriger ensemble ultérieurement.
    7. Durant l'enregistrement ou à la fin, enregistrer dans un fichier texte les différentes positions pointés à l'aide de l'icône [image]. Un exemple d'un tel fichier (avec le minimum de mesure) est proposé ici.

Une animation flash montre la prise de mesure et l'enregistrement de ces dernières par la méthode manuelle qui vient d'être décrite précedemment.

Que ce soit par la méthode automatique ou manuelle, on peut arriver à un tableau qui a l'allure suivante :

Un exemple de mesures

II. Exploiter les mesures

Les données enregistrées vont servir à établir le modèle de pointage. Il faut alors choisir l'onglet "Calculs" :

Le résidu d'erreur sans modèle est de 4.6 arcmin (c'est l'erreur moyenne de pointage dans tout le ciel) et avec ce modèle, il tombe en moyenne à 1.1 arcminute.
Si on ajoute un polynome de degré 4, le résidu tombe à 16 arcsec, soit une amélioration d'un facteur 17 dans la precision du pointage du télescope !

On peut aussi choisir les erreurs à intégrer dans le calcul.

Après calcul, il faut sauvegarder les coefficients du polynôme de passage dans un fichier *.cor à l'aide de l'icône de la disquette.

Dans l'onglet "Graphique", il est possible d'estimer les erreurs : avant le modèle de pointage, entre ce qui est donné par les codeurs et réellement mesuré et après le modèle de pointage, une estimation de l'erreur résiduelle :

Graphiques des erreurs

Ainsi que projeter graphiquement les erreurs sur le ciel.

En appuyant sur le bouton [Graphique], on obtient les graphes des erreurs sur toutes les mesures effectuées.

Erreur sur l'azimuth entre la valeur obtenue par codeur et la valeur réellement obtenue. | Erreur sur la hauteur entre la valeur obtenue par codeur et la valeur réellement obtenue.
Erreur avant application du modèle de pointage | Erreur que l'on devrait obtenir sur les mêmes étoiles après application du modèle de pointage

III. Intégrer le modèle :

Après avoir créer le fichier COR, il faut l'inclure dans la configuration du télescope si on désire s'en servir.

Animations FLASH :
Définir l'orientation de la caméra.

Conditions d'activation :
Graphe ouvert
Que le télescope et la caméra soient supportés par PRiSM.

Fonction(s) Script associée(s):
Get_Telescope_Position_App

Prérequis :
Menu contextuel

Version Avril 2009


Télescope / Réglage du PEC

> Télescope > PEC

Lancement : Menu [Télescope] > [Analyse de l'erreur périodique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Il n'y a pas pour le moment de page écrite spécifiquement pour cette fonction. Cependant, la suite des opérations PRiSM pour utiliser l'erreur périodique a très bien été résumé par Laurent Bernasconi ci-dessous en rapport avec le système de GOTO MCMT II. Il faut qu'ensuite la monture puisse supporter cette fonction (montures gérées par DLL).
Attention : cette aide n'est plus à jour depuis la version 6.00.140 mais on retrouve tous les principes de base.

Une complément de cette aide est proposé par Cyril Cavadore à cette adresse. On y trouvera une partie très intéressante sur l'acquisition par WEBCAM et sur la fin du traitement.

Le PEC de MCMTII utilise directement les données issues de votre camera CCD. Aucune commande sur la raquette n'est utile. 3 opérations sont nécessaires:

  • Acquisition de la courbe d'erreur périodique.
  • Analyse et mesure de l'erreur périodique.
    • Réglage de la raquette informatique de MCMT.

Acquisition de la courbe d'erreur périodique.

Régler la position de la camera CCD pour que le capteur soit aligné avec la monture. Généralement l'axe X du CCD est utilisé pour l'alignement Alpha et bien sûr l'axe Y sera dans le même sens que l'axe Delta.

C'est le mode "Focalisation" de PRiSM qui sera utilisé pour récupérer l'erreur périodique. Pour cela régler le temps de pose à 5 sec et faire une acquisition pleine trame, puis aller dans [Caméra] > [Focalisation]. PRiSM vous demande alors de choisir une étoile. La sélectionner assez brillante mais non saturée et si possible vers le centre du CCD. Elle doit se trouver aux environs de l'équateur, plutôt juste au dessus, et juste après le méridien (afin de ne pas souffrir du basculement du télescope au passage du méridien). Voici le type d'écran que vous devez obtenir:

On y retrouve trois fenêtres:

Les deux fenêtres à gauche montrent la position de l'étoile choisie en temps réel... elles ne sont pas visibles immédiatement.

A droite nous retrouvons la fenêtre de contrôle du mode Focalisation.

Le principe va être de lire en temps réel la position de l'étoile et ainsi de visualiser et d'enregistrer la courbe de l'erreur périodique.

Il vous faut valider les options suivantes dans la fenêtre de focalisation: (voir l'image au dessus)
* "Fenêtre Fixe"
* "Encodeur en X" si c'est bien l'axe X de votre camera qui est aligné avec l'axe Alpha.

Puis cliquer sur "Graphique X tp Réel" et si vous le désirez (car ce n'est pas utile pour le PEC mais seulement pour vous donner une idée de la qualité de votre mise en station) "Graphique Y tp réel". Les deux fenêtres "Position en X et "position en Y" sont maintenant devant vous. Il vous reste juste à patienter et à suivre en direct l'évolution de la position de votre étoile. Vous pouvez observer que le "graphique X" est gradué sur l'axe X en sec d'arc alors que le "graphique Y" est gradué en seconde.

Le but est d'enregistrer au moins une période entière de l'erreur périodique de la monture. Pour ma monture NJP 160 cela représente:
86164,2sec / Rapport de réduction soit environ 359sec car ma réduction est de 240. Cela veut dire aussi que le télescope s'est déplacé d'un angle de 359 * 15sec d'arc. soit 5385 sec d'arc. Ce nombre est à calculer pour votre télescope. Il sera utilisé au moment de l'analyse de l'erreur périodique.

Au fur et à mesure que le temps passe vous devriez observer que l'étoile oscille en X autour d'une certaine valeur... c'est votre erreur périodique. Si vous observez aussi une pente, elle représente une erreur sur la vitesse sidérale. Ne pas chercher à la corriger systématiquement sauf si elle est importante.

Sur le graph. Y, vous observez peut-être une pente régulière... elle est l'image de votre erreur de mise en station. Même chose, si elle est importante je vous conseille de revoir votre mise en station avant d'aller plus loin.

Au bout par exemple d'environ deux périodes vous devriez obtenir quelque chose comme ceci:

C'est un exemple on ne peut plus réel qui est tiré de ma NJP160. On y observe bien une erreur périodique ayant une amplitude d'environ 3 pixels pic à pic ( 6,6 sec d'arc à première vue car ma résolution est de 2.2 sec d'arc/Pixel ).

Regarder les valeurs de l’échelle en X…. Elles sont en secondes d’arc sur le ciel. Si vous voyer des sec de temps sur l’échelle X, c’est que vous avez oublié de valider l’option "Encodeur en X". C’est l’erreur classique …

Il est temps de sortir du mode focalisation. Nous allons sauvegarder cette courbe sous un fichier TXT. Cliquer sur "Réglages" ( un nouveau menu est visible )puis "Entrée-sortie" et enfin "Sauver les données". Donner un nom au fichier (par exemple PECX.TXT) et l'enregistrer dans un répertoire que vous retrouvez facilement.

Analyse et mesure de l'erreur périodique.

Avec les mesures effectuées, nous allons les utiliser pour quantifier l'erreur périodique et la simuler face à une courbe sinusoïdale afin d'en déterminer la période, la phase et l'amplitude. Aller dans [Télescope] > [Analyse de l'erreur périodique]. Voici la fenêtre que vous devez obtenir:

Entrer la valeur de votre réduction au niveau de "Nombre de dents" puis faire [calcul]. Dans cet exemple ma réduction est de 240. Le résultat me donne 5400 sec d'arc. Puis charger la courbe que vous avez sauvée tout à l'heure grâce à [Charger une courbe]. A ce moment la, vous retrouver plusieurs tableaux…. Ils n’ont pas grande importance a notre niveau, vous pouvez les fermer. Maintenant cliquer sur [Modélise la courbe]. Voici ce que j'obtiens:

La sinusoïde rouge la plus proche de votre erreur périodique a été tracée et dans la fenêtre "Analyse de l'erreur périodique", on trouve les renseignements suivants:

  • Phase pour le PEC=2198. C'est l'image de la distance entre l'origine de l'erreur périodique et la position de référence indiquée par le capteur inductif placé sur la vis sans fin de votre monture.

  • Amplitude=1.12" ou pixels. Dans notre cas ce sont toujours des Pixels. En multipliant par 2 l'amplitude, on retrouve pratiquement la mesure pic à pic réalisée un peu plus haut par simple observation de la courbe. Mais c'est la mesure en sec d'arc qui nous intéresse donc il faut multiplier l'Amplitude par la résolution du télescope (ici 1.92 sec d’arc par pixel) ... soit 1.12*1.92sec d'arc= 2.1 sec d'arc.

  • Période=5400 sec d'arc... mesure que nous avons calculée plus haut.

L'analyse est maintenant terminée!

Réglage de la raquette informatique de MCMT.

Il vous reste maintenant à entrer les paramètres dans la raquette informatique de MCMT. Aller à [Télescope] > [Raquette] et choisir l'onglet [Vitesses différentielles].

La Période sera de 5400. La Phase de 2198 et l'Amplitude de 2.1 sec d'arc.

Ne pas oublier de valider "Activer la correction erreur périodique" et pourquoi pas aussi la vitesse de king si supoorté par la monture.

Remarque Importante : En fonction du sens de rotation moteur, il est possible que vous soyer obliger de mètre – 2.1 sec d’arc pour l’amplitude. C’est normal. En fait, c’est facile à vérifier : Il suffit de refaire une mesure de l’EP après mise en service du PEC. Si l’erreur est toujours bien visible, placer le "-".

PRiSM offre aussi la possibilité de corriger l’harmonique 1 de l’erreur périodique. La méthode sera la même à ceci près que la période de base sera deux fois plus rapide. Dans l’exemple, je prend 5400/2=2700. Il suffit donc de refaire une mesure avec la correction de la fondamentale en service, de sauver les mesures et de faire l’analyse avec la période régler à 2700 ou faire le calcul avec un nombre de dent deux fois plus grand soit 480 dents.

J’ai appliqué cette méthode sur ma monture et voici le résultat :

J’ai essayé de garder à peu près la même échelle en Y. On observe que l’étoile cette fois-ci reste la plupart du temps sur 1 bon pixel soit 2 à 3 sec d’arc pic pic !
Même chose, si vous avez appliqué le signe "–" pour une bonne correction de la fondamentale, il faudra aussi inverser la valeur pour l’harmonique 1.


Télescope / Aide à la mise en station

> Télescope > Aide à la mise en station par la méthode de KING

Lancement : Menu [Télescope] > [Aide à la mise en station]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Cette fonction concerne une aide à la mise en station de la monture.

Orientation de la caméra :

La camera doit être orientée de façon à obtenir l’image de la camera CCD comme sur une carte du ciel (c.a.d Nord en haut, Sud en bas, Est a gauche et ouest à droite). Cette orientation est dite orientation de « base ».

La méthode de King peut aussi gérer des images qui sont tournées d'un angle positif ou négatif par rapport à l’orientation de base, par exemple une rotation de 90° dans le sens inverse des aiguilles d’une montre, aboutissant au Nord à gauche de l’image, l’Ouest en haut, le Sud a droite ou l’Est en bas. Cette orientation est tout aussi valide. Par contre, on évitera de faire un miroir X ou Y seul par rapport à cette orientation de base.

Objet à pointer :

Pointer une étoile entre le Zénith et le pole céleste comme indiqué sur la carte du ciel suivante :

Exemple de pointage

Le binning de la camera n’a aucune incidence sur la méthode, à part peut être, une perte de précision.

Ce pointage n’a en réalité aucune importance, on peut pointer à plusieurs degrés du pôle céleste mais en étant vers l’ouest (par exemple), le pointage proposé (entre le pole et le zénith) a pour but de rendre plus facile les corrections à effectuer sur la monture et leur interprétation sur l’image.
Par exemple, un réglage d’élévation de l’axe horaire du télescope va faire monter et descendre l’étoile dans l’image suivant l’axe des Y, un réglage azimutal va faire déplacer l’étoile horizontalement dans l’image en suivant l’axe des X. Si le télescope est pointé dans une autre direction les mouvements de la monture vont se faire sur des directions indépendantes de l’axe X et Y, et donc difficile a estimer.

Déroulement des opérations :

Réaliser une pose de 60s en laissant le télescope suivre, il est convenu que la vitesse sidérale devra être approchée, mais il n’y a pas besoin qu’elle soit exacte.

Une fois l’image acquise, cliquer sur « ajouter mesure », un carré rouge se place sur l’étoile sélectionnée par l’utilisateur pour ne pas la perdre de vue.

Laisser passer 10 à 15 minutes.
Faire une autre acquisition de 60s et cliquer sur « ajouter mesure » sur la même étoile. PRISM calcule le vecteur de déplacement de monture à effectuer. Il montre où l’étoile doit être placée grâce au mouvement que l’utilisateur fera en agissant sur l’axe polaire de la monture.

Dans ce cet exemple l’axe de la monture est à 9.6 arcmin de l’axe polaire terrestre. (ce qui en pratique interdit tout pose non guidée).

Par acquisitions d’images et retouches successives de la position de la monture en élévation et azimutal, l’étoile et amenée peu à peu dans le carré vert.

A chaque acquisition d’images, on cliquera sur le bouton « Afficher graphique » pour voir le vecteur de déplacement et centrer l’étoile dans le carré vert.

L’image suivante montre l’étoile de référence quasiment dans le carré vert (un peu au dessus encore).
Il ne faudra absolument pas toucher aux mouvements Alpha et Delta de la monture pendant ces déplacements.

Il est possible de vérifier que ce procédé a pu améliorer la mise en station en cliquant « remise à zéro » et en reprenant un cycle de mesures.

C’est qu’il est montré sur l’image suivante où la distance de déplacement de la monture à été réduite de 9.5 minutes d’arc à 1.5 minutes d’arc en une seule itération.

Dans cet exemple, la monture était à 9.5 minutes d’arc de l’axe polaire terrestre et a pu être ramené a 10 secondes d’arc du pole en trois cycles de mesure. Cette méthode est donc très efficace est très précise !

Cette précision d’alignement de l’axe polaire de 10’’ permet de réaliser des poses de 5 minutes sans corrections en Delta.

Fonction(s) Script associée(s):
Aucune

Mars 2008


Telescope / Observation automatique

> Télescope > Observation automatique

Lancement : Menu [Télescope] > [Observation automatique]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

But : Gérer des observations automatiques.
Ce menu s'apparente à un séquenceur d'observation à partir des objets définis dans l'onglet "Cibles ou objets". Cette page d'aide est complétée au fur et à mesure des demandes d'aide sur la liste PRiSM ...

Attention : Ce menu remplace l'"observing block" des versions 5 et 6 de PRiSM.

Les paramètres généraux de toute la session d'observation se règlent de l'onglet "Focalisation" à l'onglet "Fin des observations". La liste des objets à observer se règle à partir de l'onglet "Cibles ou objets". Enfin, l'ensemble se lance à partir de l'onglet "Execution" :

Les menus proposés

Il est possible de sauvegarder (et donc rappeler ultérieurement) les paramètres qui ont été validés. Ces paramètres sont sauvés dans un fichier texte ".ini" dans lequel on retrouve toutes les informations de l'onglet "Focalisation" à l'onglet "Fin des observations".

Charger / Sauver les observations auto

Pour exemple, un extrait de ce fichier ini :

[Flats]
DoFlats=0
DoFlatsMatin=1
ElevationSunMin=-5
ElevationSunMax=-2
StopEngines=0
ExposureMax_sec=30
ExposureMin_sec=0.1
CloseDome=0
ForcePositionTelescopeTo=0
Azimuth=180
Elevation=45

Avant de lancer l'exécution d'une session, il faut s'assurer que tout le matériel dont on demande l'utilisation durant la session soit connecté au programme ...

Onglet Cibles ou Objets

Un onglet complété

Cette partie se gère comme la liste d'objets. D'ailleurs, il est possible d'importer directement les objets de la liste d'objets.
Supposons une liste d'objet ayant été complétée au préalable :

A l'aide du bouton [Importer la liste d'objets], on récupère la liste au format de l'observation automatique :

En répondant par l'affirmative, on ouvre une fenêtre demandant des renseignements sur les objets importés :

On renseigne les colonnes sur tous les objets : le temps de pose. Le binning utilisé pour les champs. Le nombre d'images successives à faire sur chaque objet. Le filtre utilisé (le nom du filtre est rappelé s'il a été déclaré). Le temps de pose de guidage optimal à utiliser (ce dernier pourra être changé par le programme suivant ce qui est détecté). Ce temps de pose aura une importance que si la case à cocher "Effectuer le guidage" est validée. Si de plus, on désire réaliser une focalisation sur tous les obejts avant la première pose sur ce dernier, il faut cocher la case "Effectuer la focalisation sur cet objet".

Il est possible ensuite de changer les paramètres pour chacun des objets en sélectionnant au préalable l'objet et en cliquant sur le bouton [Editer].

Il est conseillé ensuite de sauver la liste d'observation automatique de façon à pouvoir la rappeler à volonté. Le format de sauvegarde est en "*.lst_obsauto".

Lorsque la liste affichée est terminée, il est possible de la faire s'éxécuter à l'infini (ou jusqu'au lever du Soleil) en cochant la case "Exécution en boucle" du même onglet.

Onglet Focalisation

Un onglet complété
  • Conditions de focalisation : Ces paramètres permettent de régler la répétitivité en temps de la focalisation : à des temps bien précis ou en fonction du déplacement du télescope. Pour les focusers équipés d'un capteur de température, il est possible de régler le changement de pente qui a été étalonné en fonction du changement de température.

  • Configuration de la focalisation : les premiers paramètres sont sur le choix des étoiles pour la focalisation et notamment la distance maximum autorisée entre la position actuelle du télescope et l'étoile de focalisation. Une fois l'étoile de focalisation "utilisée", le télescope revient à sa position intiale. PRiSM choisira la première étoile (depuis la base de donnée) la plus proche de la position actuelle dans la zone de magnitude choisie.
    Les paramètres qui suivent sont réservés pour la focalisation automatique en elle-même et sont en tous points identiques aux paramètres de la fonction [Caméra] > [Focalisation automatique]
Onglet Acquisition

Un onglet complété
  • Options : cadran intuitif.

  • Caméra : cadran intuitif.

  • Fenêtrage : cadran intuitif.

  • Autoguidage : Ce cadran est aussi très intuitif. Pour les paramètres de calibration, il faut faire un étalonnage AVANT le lancement de l'observation automatique, de façon à ce que ces paramètres puissent être réutilisés. Il est proposé plusieurs alternatives si l'étoile guide n'est pas trouvée.

Onglet Telescope

Un onglet complété
  • Pointages : Règle les paramètres après chaque pointage de façon à éviter un angle horaire, la lune ou à recalibrer le télescope. De ce fait, PRiSM ne prend pas en compte le modèle d'horizon (affiché à volonté sur la carte du ciel). Cette liste de paramètre vient donc remplacer ce modèle.

  • Général : Permet de stopper les moteurs du télescope si par exemple la séance n'est pas encore lancée. Ceci permet donc de lancer l'execution de la séance automatique très longtemps avant son exécution réelle. Cette fonction n'est exécutabl que si la monture supporte l'arrêt des moteurs.

  • Astrométrie : Paramètres utilisés pour réaliser l'astrométrie des images de recalibration.

  • Catalogue : Catalogue utilisé pour réaliser l'astrométrie des images de recalibration.

Onglet Acquisition des flats
Un onglet complété

Les paramètres à fournir sont intuitifs pour ce cadran. La technique utilisée est identique à celle du menu [Caméra] > [Acquisition des Flats].

Onglet Début des observations

Un onglet complété

Onglet Fin des observations

Un onglet complété
  • Envoyer un e-mail : Il faut alors compléter son adresse mail pour recevoir un e-mail marquant la fin des observations. Dans cet e-mail est indiqué la bonne exécution des paramètres de cet onglet (et uniquement de cet onglet) notamment, le parking du télescope, la fermeture du dome, le contrôle de la température du CCD et la prise en compte d'un script dans PRiSM. Par contre, l'e-mail ne résumera pas ce qui s'est passé durant la session automatique.
    Les informations sur le compte mail sont à compléter à partir de l'onglet e-mail du menu [Options] > [Options générales de PRiSM]

Onglet Exécution

Pour lancer le programme d'observation !

Foire aux questions :

Q1 : Après importation d'une liste d'objet où on définit le temps de pose, le filtre, le nombre de pose ... , que faire pour réaliser une pose sur un même objet mais avec un filtre différent ?
Il faut "dupliquer" l'objet pour le placer à la suite de l'objet de départ et changer uniquement le numéro du filtre que l'utilisateur souhaite sélectionner.

Décembre 2008


Télescope / Liste d'objets - Champs

> Télescope > Liste d'objets - Champs

Lancement : Menu [Télescope] > [Liste d'objets - Champs]

Cette fonction n'est pas accessible depuis la version light. Afin de pouvoir l'utiliser, il est nécessaire d'obtenir une clé "version complète" pour le logiciel.

Compléter la liste des objets :

Il y a deux manières de compléter la liste des objets depuis la carte du ciel :

  • A partir de l'identificateur d'objets, en cochant la case correspondante :
  • A partir du menu contextuel (bouton droit de la souris) et de n'importe quel endroit de la carte du ciel, il faut choisir l'option correspondante : . Une fenêtre s'ouvre alors pour compléter les informations restantes :

    L'objet se rajoute alors dans la liste.

Utiliser la liste des objets :

Une fois complétée, la liste a l'apparence suivante :

La liste d'objet complétée
La liste d'objets complétée

Une fois complétée, différentes actions sont possibles afin de modifier la liste. A partir du menu dans la partie supérieure de la liste:

  • Fichier : Pour sauvegarder une liste (*.LST) ou charger une liste précédemment sauvegardée.
  • Effacer : Pour effacer toute la liste; ceci est nécessaire pour la création d'une nouvelle liste car PRiSM garde tout le temps en mémoire la liste,une fois définie.
  • Tri : Tri des objets par différentes grandeurs come alpha, delta, angle horaire ...
  • Cacher : permet de cacher la liste des objets.

Dans la partie inférieure de la liste, il est possible d'accéder à différentes actions :

  • Choix d'afficher la liste des objets par identification dans la carte du ciel

  • : Enlever un objet de la liste après avoir sélectionné une de ses propriétés dans la liste.

  • : Monter un objet de la liste après avoir sélectionné son nom.

  • : Editer un objet dont une de ses propriétés est sélectionnée. La fenêtre d'édition apparaît alors :

    Editer des données déja inscrites

    Il suffit alors de changer les propriétés voulues ...

  • : Descendre un objet de la liste après avoir sélectionné une de ses propriétés.

  • : Ajouter un objet à la liste à partir de propriétés vierges

  • : Positionner la carte du ciel sur cet objet

  • : Pointer le télescope sur cet objet; il faut que l'instrument soit en liaison avec PRiSM.

Les informations suivantes apparaissent au bas de la fenêtre : Le nombre d'objets dans la liste, le numéro sélectionné, et les temps sidéral local et UT

Fonction(s) Script associée(s):
Aucune

Version Déc 2005


Télescope / Paramètres de centrage automatique

> Télescope > Paramètres de centrage automatique du télescope

Lancement : Menu [Télescope] > [Paramètres de centrage auto du télescope]

Ce menu est utile pour toutes les fonctions qui font appel à des catalogues pour une calibration automatique d'une image. Ceci est le cas pour les fonctions comme :

  • Menu contextuel d'une image : "Recentrage automatique du télescope".
  • ...

Les paramètres à remplir apparaissent comme ci-dessous. Ce panel est en fait un "extrait" de celui pour l'étalonnage automatique. Les parties spécifiques à ne pas remplir pour cette fonction générale sont en couleur grisées :

Paramètres à remplir
  • Le catalogue de référence est le catalogue qui sera utilisé pour l'étalonnage.

    PRiSM nous laisse le choix entre plusieurs catalogues : GSC, USNO SA2, USNO A1 (obsolète maintenant !), USNO A2, Hipparcos, SAO, BSC, Tycho1, GSC-ACT, Tycho2, UCAC 1 et 2. Seuls les catalogues GSC, SAO, BSC, Tycho 1 et 2 sont compilés sous PRiSM et il n'est donc pas nécessaire d'indiquer le chemin d'accès. Par contre, pour les autres catalogues, le chemin d'accès fourni dans les options est indiqué en dessous et peut encore être changé. Chaque catalogue a ses propres défauts :

    • Le GSC indique toutes les étoiles jusqu'à la magnitude 16 et est compilé directmement sous PRiSM. A cause de son âge, on ne peut pas faire de l'astrométrie précise ( c'est-à-dire à moins de 1" d'arc d'erreur). On lui préfèrera le GSC-ACT téléchargeable sur internet et plus précis. Il faudra alors compléter le menu [Options] > [Option de démarrage de la carte du ciel].
    • Le catalogue USNO-SA contient des étoiles régulièrement espacées sur la sphère céleste jusqu'à la magnitude 20, mais il ne les contient pas toutes. Il peut donc apparaître sur l'image des étoiles qui ne sont pas dans le catalogue. Le choix de ce catologue pourra donc, mais très rarement, ne pas fonctionner. Plus précis que l catalogue GSC, on lui préfèrera le catalogue USNO A2 : plus d'étoiles pour un champ donné donc un plus grand choix pour la comparaison afin de limiter les erreurs.
    • Les autres catalogues sont décrits dans la section sur les catalogues. On remarque que, d'un point de vu astrométrique, les catalogues à privilégier sont Hipparcos et Tycho 1 et 2. Cependant, le nombre d'étoiles de référence parfois insuffisant mène à continuer à privilégier l'utilisation de catalogue comme USNO A2.

  • Le nombre d'étoiles maximum les plus brillantes du catalogue de référence avec lesquels PRiSM formera des triangles. Ces derniers seront comparés avec les triangles obtenus à l'aide du nombre maximum d'étoiles les plus brillantes de l'image. La méthode utilisée est la méthode des triangles.

  • Redéfinir les niveaux de messages : Cette option permet de choisir d'avoir toutes les informations essentielles lors de l'étalonnage (niveau 4) ou alors, le minimum (niveau 1). Le niveau choisi est indiqué au dessus du bouton correspondant.

  • Réglage de la reconnaissance auto : permet d'afficher le menu option de reconnaissance automatique sans avoir à fermer la fenêtre d'étalonnage automatique.

  • Si l'image est orientée Nord en haut, alors on cochera la case "Image orientée Nord/Sud". Ceci permet de réduire le temps de calcul. Cependant, ce paramètre est pondéré par celui de l'option de reconnaissance auto : Marge d'erreur sur la rotation

  • Si on souhaite voir l'avancement des calculs, alors on cochera la case "Voir état du calcul" et les informations seront fournies en fonction du niveau des messages définis.

En cas de non réglage correct de ces paramètres, voici un extrait du message renvoyé par exemple par le menu contextuel d'une image / Recentrage automatique :

Ne peut trouver les fichiers du GSC  ! [K:\Catalogues_etoiles\Gsc-Act\S0730\5292.CSC]
Le calibration automatique a échoué, menu de contrôle : "Telescope/Paramètres de centrage auto du télescope "

Voir aussi
Option pour la reconnaissance de champ

Version Décembre 2006


Télescope / Retrouver la position du télescope dans tout le ciel

> Télescope > Reconnaissance de champ

Lancement : Menu [Télescope] > [Retrouver la position du télescope dans tout le ciel]

Attention : cette fonction n'est actuellement pas disponible que ce soit dans la version complète ou light.

Une image doit être ouverte. Pour le moment, cette image doit être orientée aux environs de 0° (Est à gauche et Nord en haut). De façon générale, ces images ne doivent pas contenir trop d'étoiles et sont donc des images de poses courtes. Il est préférable pour les champs suffisamment important d'utiliser le GSC-ACT mais si le nombre d'étoiles est très limité dû à un champ faible, il est possible d'utiliser l'USNO A2.

La fenêtre de configuration suivante s'ouvre alors :

  • Les coordonnées très approximatives du centre de l'image sont demandées de façon à commencer le calcul. Cette dernière peut évidement être très loin de la position réelle mais doit rester inférieure à la zone de recherche demandée par rapport à la position réelle. Il est possible de récupérer les coordonnées enregistrées dans le presse-papier.

  • La fonction récupère les informations essentielles de l'entête de l'image comme la focale de l'instrument et la taille de chaque pixel.

  • Le catalogue choisi doit être déclaré. Ce dernier doit être choisi en fonction du nombre d'étoiles dans le champ et de la taille du champ.

  • Un rappel sur l'orientation du champ est effectué en bas de page.

Il est alors possible de lancer la reconnaissance de champ.

Le résultat est fourni avec plusieurs indications :

  • Les coordonnées calculées pour le centre de l'image.

  • La distance par rapport au point de calcul de départ.

  • La focale déduite.

  • Les résidus pour le calcul des coordonnées du centre de l'image.

  • Le nombre d'étoiles à partir duquel a été effectué la reconnaissance.

  • L'indice de confiance, qui même si dans ce cas était affiché comme mauvais, était pourtant bon !

Images de test :
Image dont les coordonnées du centre sont faussées de 1.1°

Vidéo exemple :
Tutorial (FR, 3.6 Mo)

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Avoir ouvert une image

Version Décembre 2009


Fenêtre / Réorganiser icones

> Fenêtre > Réorganiser icones

Lancement : Menu [Fenêtre] > [Réorganiser icones]

But : Cette fenêtre permet d'aligner les icônes de toutes les fenêtres qui ont été minimisées.

Les icones sont alignées en bas de la fenêtre principale.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Janvier 2008


Fenêtre / Tout réduire

> Fenêtre > Tout réduire

Lancement : Menu [Fenêtre] > [Tout réduire]

But : Cette fonction permet de minimiser toutes les fenêtres ouvertes.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Janvier 2008


Fenêtre / Dupliquer image

> Fenêtre > Dupliquer image

Lancement : Menu [Fenêtre] > [Dupliquer image]

But : Cette fonction permet de dupliquer une image préalablement sélectionnée. Aucun fichier n'est créé, l'image dupliquée est simplement ouverte dans une nouvelle fenêtre.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Janvier 2008


Fenêtre / Fermer toutes les fenêtres

> Fenêtre > Fermer toutes les fenêtres

Lancement : Menu [Fenêtre] > [Fermer toutes les fenêtres]

But : Cette fonction permet de fermer toutes les fenêtres ouvertes.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Janvier 2008


Options / Priorité des calculs

> Options > Priorité des calculs

Lancement : Menu [Options] > [Priorité des calculs]

Ce paramètre détermine la priorité des calculs multitâches. Plus cette priorité est importante, plus la manipulation du logiciel sera difficile pendant les calculs.

La valeur par défaut (comme représenté ci-dessus) est une optimale pour la plupart des utilisations et des machines.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Fev 2006


Options / Options générales de PRiSM

> Options > Options générales de PRiSM

Lancement : Menu [Options] > [Options générales de PRiSM]

Ce menu permet de régler quelques paramètres généraux de PRiSM:

Onglet IMAGES

L'onglet image

Qualité de la compression JPEG :
(1-100), règle le taux de compression d'une image sauvegardée en format JPEG (de 1 à 100%, sachant que plus le taux est faible, plus la qualité de l'image est réduite, et vice-versa).

TIFF :
Permet de choisir le type d'image CPA dans laquelle sera encapsulé l'image TIFF.

BMP / JPEG :
Choix du message d'avertissement.

Onglet TELESCOPE

  • Succès de la connexion : Une fois la connexion réussi, une fenêtre marquant la réussite s'affiche. Ceci a lieu lors de l'utilisation du menu [Telescope] > [Etablir connexion]

  • Mettre carte à jour : Ceci permet de toujours voir la position du télescope (et donc son icône correspondant) sur la carte du ciel même après un mouvement; cette dernière peut alors se centrer sur la position du télescope.

  • Désactiver affichage position : Lors de l'exécution d'un script, l'icône de position du télescope met à jour la carte du ciel après tout mouvement. Il faut cocher cette case si l'utilisateur désire que la carte du ciel reste fixe.

  • Montrer la raquette du télescope au démarrage : pour forcer l'affichage de la raquette du telescope dès la connexion de ce dernier ou non.

  • Activer son à la fin d'un pointage : pour forcer le son à la fin d'un pointage.
Onglet INTERFACE

  • Mise à jour du programme : Vérifie automatiquement l'existence d'une mise à jour du programme dès que le PC est connecté sur Internet.

  • Connexion Bureau à distance : Lors d'une connexion à distance par le bureau à distance sur le PC sur lequel PRiSM est installé, et lorsque l'option est cochée, l'image s'affiche en grisée sur le PC à distance (où PRiSM n'est pas nécessairement installé). Cependant, un déplacement de la souris sur l'image affiche quand même la position de la souris sur le pixel ainsi que l'intensité du pixel. De plus, le mode loupe est disponible et l'image s'affiche dans la petite fenêtre accordée à la loupe.

  • Intensité couleur nuit : Permet de régler la puissance de l'éclairage nuit en couleur rougeatre.

  • Forcer la position de la fenêtre image à la création : Lors de l'ouverture ou de la création d'une image, cette dernière peut apparaître décalée d'un certain nombre de pixel en X et en Y à indiquer dans la fenêtre de PRiSM.

  • Forcer le zoom : Ceci permet de choisir automatiquement le zoom à appliquer à une image de façon à ce que cette dernière apparaisse en totalité dans la fenêtre de PRiSM. Cette option ne choisit pas des zomms supérieurs à 1 ! Il est également possible de forcer le zomm à une valeur bien précise.

  • Se souvenir de la position des fenêtres : Par défaut, à la première ouverture d'une fenêtre du programme, elle s'affiche au milieu de l'écran. Si cette option est activée, la position de la fenêtre ouverte est retenue.

  • Se souvenir de la position des fenêtres : Permet de se souvenir de la position des fenêtres citées sur l'écran. Si ce bouton n'est pas coché, toutes les fenêtres reviennent au centre de l'écran. Ceci est surtout utile lors de l'utilisation d'un système bi-écran ou d'une connexion à distance.
Onglet SCRIPTS

L'onglet Scripts

Permet de donner au programme le chemin exact où chercher les librairies ( = DLL de script) lors de l'utilisation du mot clé INCLUDESCRIPT dans un script. Il est rappelé qu'un tel chemin n'est pas fourni en paramètre pour ce mot clé.

Onglet ACQUISITION

L'onglet Acquisition

Permet de donner au programme le chemin par défaut à partir duquel seront sauvegardées les images de la nuitou à partir duquel sera créé le répertoire de la nuit. Par exemple, ceci permet ensuite de créer automatiquement le répertoire nuit dans ce répertoire à partir du panel d'acquisition.

Un bouton permet de montrer les informations d eliaison avec la caméra à chaque connexion.
Onglet E-MAIL

L'onglet E-Mail

Permet de donner au programme les informations nécessaires pour l'envoi d'un e-mail, utilisé dans certaines fonctions de PRiSM.
Pour le moment, l'envoi d'un e-mail ne concerne que la session d'observation automatique, dans l'onglet "Fin des observations", dont l'aide est accessible ici.
Onglet Infos sur le WEB

L'onglet E-Mail

Cette option permet d'envoyer des informations relatives au telescope sur une page web (à condition que la case correspondante soit cochée). Une fois la case cochée, la mise à jour de ces informations commence dès la connexion du télescope.

L'utilisateur doit définir l'intervalle de mise à jour ainsi que des informations sur le compte FTP pour que la page web soit envoyée (l'emplacement de la page web est aussi à définir en local).

Dans la page WEB, les informations à remplacer doivent être déclarées avec un signe "$" avant le nom imposé, du style "Mise &agrave; jour le : <strong>$DATE</strong>". Les noms imposés sont les suivants :

  • $DATE : date de mise à jour.
  • $RA2000 : ascension droite.
  • $DEC2000 : déclinaison.
  • $AZ : azimuth.
  • $HH : hauteur.
  • $SIDE : côté du pied (pour les montures allemandes)
  • $AZD : azimuth de la coupole.
  • $FOC : focalisation primaire en mm.
  • $FOCsec : focalisation secondaire en mm.
  • $NAMEFLT : nom du filtre utilisé.

Onglet MENUS

L'onglet Menus

Permet de choisir entre une liste de menus "débutant" ou la liste complète des menus en mode expert.

Pour qu'il y ait confirmation avant de quitter PRiSM, cocher la case correspondante.

Onglet PRETRAITEMENTS

L'onglet Pré-traitements

Permet de tenir compte de la différence entre les miroirs des images et ceux des darks, offsets et flats lors d'un prétraitement.

Pour plus de sûreté, cette option est rappelée en bas de la fenêtre des prétraitements automatiques.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2008


Options / Option fichier FITS et APN

> Options > Option fichier FITS et APN

Lancement : Menu [Options] > [Option fichier FITS et APN]

But : Cette fonction permet de configurer le mode de conversion des fichiers FITS et APN vers le format CPA.

Onglet APN

L'onglet APN

Cet onglet rassemble les paramètres essentiels d'importation des images d'appareil photo numérique.

  • La case à cocher "débayeriser au chargement" : pour transformer à l'ouverture une image d'APN (en fichier RAW) directement au format CPA. La méthode utilisée peut être précisée par l'utilisateur.

  • La case à cocher "Trouver la matrice de bayer automatiquement" permet au logiciel de trouver seul, en fonction de l'extension du fichier, la matrice de Bayer à utiliser. Il est aussi de préciser cette matrice de façon non automatique.

Onglet FITS

La plupart des images sauvegardées sous le format FITS sont codées en entiers sur 16 bits non signés c'est-à-dire que les pas codeurs s'échelonnent de 0 à 65535. De par sa construction, PRiSM fonctionne sur des images en entier qui sont codées sur 16 bits signés. Ceci signifie que le bit de poids maximum représente en fait le signe + ou - en ce qui concerne le pas codeur. Les pas codeurs s'échelonnent alors de -32767 à +32767.
Au départ, il y a donc incompatibilité entre ces deux formats d'images. Cependant, le programme permet de régler des options afin d'éviter de futurs déboires ...
Pour transformer une image d'entiers de 16 bits non signés (image de départ) en 16 bits signés (image pour fonctionner sous PRiSM ), il y a plusieurs possibilités :

  1. Mettre tous les pas codeurs supérieurs à 32768 à la valeur de 32767. On garde le codage des intensités lumineuses de l'image mais on perd la dynamique de l'image. La conséquence est alors une perte sur les images qui utilisent la quasi totalité de la capacité des pixels.

  2. Reduire le codage des intensités lumineuses de l'image FITS en gardant la dynamique de l'image ( il y a plus de différences de luminosité entre chaque pas codeurs mais la luminosité totale de l'image est conservée ). La conséquence est une dégradation au niveau de la détectivité.

  3. Décaler tous les pas codeurs de l'image intiale de -32767. On garde alors la dynamique de l'image initiale ainsi que le codage des intensités lumineuses.

  4. Transformer l'image en réel.

  • La case à cocher "Trouver les seuils automatiquement" : cette case permet de régler les seuils automatiquement à l'ouverture de l'image sans tenir compte des éventuels mots-clés FITS de réglage de seuils.

Remarque sur le changement du facteur de rééchantillonnage :

Cette option n'est utile que si la précédente n'a pas été cochée. Dans ce cas, l'image ouverte restera codée en entiers.
Si on désire ouvrir une image FITS en 16 bits non signés sous forme d'image codée en entiers, il faut tenir compte que PRiSM codera l'image de -32767 à 32767. En fait les pas de -32767 à 0 sont réservés pour des résultats suites à des opérations mathématiques. Une image de départ codée de 0 à 65535 sera retranscrite de 0 à 32767. Il est alors possible de diviser l'écart de luminosité réel entre deux valeurs de pas codeurs ( pour garder la dynamique ) ... ou plutôt de le multiplier par une constante inférieure à 1. Pour retranscrire entièrement l'image de départ, il faut multiplier la dynamique par 0,5 pour retrouver la même image entre 0 et 32767 ( le raisonnement est le même avec le codage en intensités lumineuses ) . On peut cependant changer cette valeur pour tenir compte de l'image. Si les pixels de l'image FITS sont tous situés entre 0 et 32767 bien qu'étant codée sur 16 bits non signés, il n'est alors pas nécessaire de rendre le coefficient différent de 1.
Il faut donc multiplier la dynamique de l'image par un coefficient judicieusement évalué en fonction de la dynamique de l'image de départ

résultats avec l'image exemple

Cette partie permet de gérer des fichiers FITS avec extension : ce sont des fichiers images correpondant à des mosaïques de CCD. Les différents capteurs constituant le capteur global sont organisés comme donné par l'utilisateur dans le tableau : Xcoord donne l'agencement horizontal des images de chaque CCD alors que Ycoord donne l'agencement vertical. Par défaut, pour le profil WFI, la mosaïque est constituée de 8 images, 4 images dans la partie supérieure et 4 images dans la partie inférieure. Un mirroir différent peut être choisis pour chaque capteur.

Le nombre d'extension correspond au nombre d'images constituant l'image globale. Cependant, il est possible pour l'image globale de n'importer que les informations d'une entête choisie par l'utilisateur à condition d'utiliser la case à cocher correspondante.

Cet onglet rassemble les paramètres essentiels de sauvegarde des images au format FITS :

  • La case à cocher "Sauver image réelles en FITS 16 bits" : cette case permet de sauver une image nativement en format réel au format entier 16 bits (si l'enregistrement au format FITS est demandé). Dans ce cas, les intensités des pixels ne sont pas signées mais cependant, toute intensité supérieure à 65535 sera écrêtée à cette valeur.

  • La case à cocher "Effectuer un miroir Y à chaque ouverture ou sauvegarde" : Lorsque cette case est cochée et à l'ouverture ou la sauvegarde d'une image FITS, un miroir est effectué suivant Y. Cette option a été rajoutée dans le but de rester compatible avec d'autres logiciels, l'orientation selon Y n'étant pas nécessairement défini de la même façon.
Onglet FITS / CPA

L'onglet FITS / CPA
  • La case à choisir "Type de fichier standard" : choix sur le type de fichier d'enregistrement.

  • La case à cocher "Considérer une image à trois plans ..." : Une image peut être à 3 plans parce que cette image est une image trichrome (valable indifféremmment pour les extensions FITS et CPA). C'est le cas pour la majorité des utilisateurs. Cependant, il existe aussi les images type FITS cube qui sont en fait des plans d'images indépendantes les unes des autres contenus dans un même fichier FITS. Ces fichiers correspondent à des applications bien spécifiques et dans ce dernier cas, la case à cocher devra être décochée.

  • La case à cocher "CPA version 4D" : le format d'enregistrement correspond donc à l'entête CPA d'avant la création du FITS cube. Il faut utiliser cette option pour ceux qui désirent lire par la suite les images acquises avec PRiSM avec d'anciennes vresions du logiciel.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / Réglage des mots clés FITS

> Options > Liste des mots clés du format FITS

Lancement : Menu [Options] > [Liste des mots clés du format FITS]

But : Cette fonction permet de visionner et changer les mots clés du format FITS.

Pour les utilisateurs peu habitués au maniement de ces mots, il est conseillé de ne toucher à aucune option pour chacun des mots car par défaut, les mots clés existants ont été conservés à l'identique. Il est rappelé que ces mots peuvent être lus et modifiés dans l'entête d'une image à partir du menu [Fichier] > [Voir entête FITS]

Un certain nombre de mots clés sont définis dans PRiSM pour le format FITS (certains spécifiques au FITS 1D qui concerne la spectroscopie et d'autres pour les images FITS courantes en 2D). Pour information, ces mots-clés ont été définis par défaut pour essayer de concilier les mots utilisés par les fichiers FITS de l'ESO ainsi que les mots utilisés par d'autres programmes d'acquisition d'images. Ce menu permet de préciser ces mots clés utilisés et permet aussi à l'utilisateur de les changer si ces derniers ne lui conviennent pas.

Pour chaque mot-clé, il est précisé si on désire l'utiliser lors d'enregistrement d'image au format FITS ou d'images spectroscopiques au format FITS1D. Le mot utilisé dans le logiciel est précisé et l'éventuel mot choisi par l'utilisateur après réglage. Enfin, apparaît la description du mot qui apparaîtra aussi dans l'entête lors de l'enregistrement du fichier. Il faut savoir cependant que le changement du mot-clé par l'utilisateur ne changera en rien son action dans le programme.
Pour exemple, le mot "EXPOSURE" pourra être changé en "TEMPSEXP", mais le temps d'exposition sera toujours enregistré en secondes (et non subitement en milli-secondes).

La fenêtre a l'apparence suivante :

La liste des 70 mots clés FITS apparaît.

Afin de changer un mot clé, il faut cliquer sur une cellule de la ligne contenant le mot. Les paramètres apparaissent alors au bas de la fenêtre. Il est alors possible de changer les 2 cases à cocher ainsi que le nouveau mot et sa description, sachant que l'action de mot en enregistrement et en lecture sera strictement identique à la description par défaut.

Pour valider les changement, il faut cliquer sur le bouton correspondant.

Pour exemple, le mot clé "BSS_SITE" qui n'était enregistré QUE pour les fichiers FITS1D sera dorénavant enregistré sous le mot clé "MON_SITE". Attention, de ce fait, lors de la lecture d'un fichier FITS (indifféremment 1D, 2D ou 3D), le mot "BSS_SITE" ne sera alors plus pris en compte mais "MON_SITE" à la place. Libre à l'utilisateur de réinitier le mot de départ (voir bouton à cocher correspondant).

Toutes les modifications seront sauvegardées dans la base de registre et l'utilisateur n'aura pas à redéfinir ses propres mots clés à chaque ouverture du programme.

Il n'est donc pas exclu de pouvoir rajouter à l'avenir des mots clés sur demande des utilisateurs ou en cas de besoin des programmeurs.

Remarque: un bouton de réinitialisation des mots par défaut a été ajouté et n'apparaît pas dans les copies d'écran. (Ceci n'est pas valable pour les descriptions).

Fonction(s) Script associée(s):
GetHeaderStringFITS

Conditions d'activation :
Aucune

Novembre 2009


Options / Option de visualisation

> Options > Option de visualisation

Lancement : Menu [Options] > [Option de visualisation]

But : Permet de régler par défaut les paramètres de visualisation

Les options de visualisation

En construction

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Janvier 2008


Options / Fixer les options de démarrage de la carte du ciel

> Options > Fixer les options de démarrage de la carte du ciel

Lancement : Menu [Options] > [Options de démarrage de la carte du ciel]

But : Définir un certain nombre d'options avant démarrage de la carte du ciel.

Ces options doivent être réglées lors du premier démarrage de PRiSM ou à chaque fois que la base de registre windows a été perdu.
Il s'affiche l'écran suivant :

Différentes paramètres peuvent être réglés à partir de cette fonction :

  • Taille de la fenêtre du ciel en % :
    Permet de régler la taille initiale d'une nouvelle fenêtre déclarée à partir du menu "Fichier / Nouvelle fenêtre du ciel". Une taille de 100% permet d'utiliser le maximum d'espace disponible dans l'écran de présentation de PRiSM. Cette option est pratique lors de l'ouverture d'une fenêtre qui est distinée à ne pas être manipulée souvent : ceci permet de l'avoir constamment sous les yeux.

  • Taille de la fenêtre automatique :
    Ouvre une fenêtre dont la taille est gérée par le programme lui-même en fonction de la place disponible.

  • Options chargées depuis "options.mapsky" :
    Lors de l'ouverture d'une nouvelle carte du ciel, les options par défaut du programme sont récupérées. Lors de l'enregistrement d'une carte du ciel, il est possible de générer un fichier MAPSKY. Il est alors possible de récupérer les options d'une carte du ciel préalablement enregistrées dans le répertoire principal sous le nom "options.mapsky", cette carte du ciel présentant les options voulues par l'utilisateur.

  • Voir bulle info sur la carte du ciel :
    Permet de choisir ou non la présence des petites phrases explicatives sur fond jaune lorsque l'on déplace la souris sur l'écran d'une fenêtre du ciel.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Novembre 2009


Options / Site d'observation par défaut

> Options > Site d'observation par défaut

Lancement : Menu [Options] > [Site d'observation par défaut]

Cette fonction permet de paramétrer le lieu à partir duquel l'utilisateur effectue ses acquisitions et ses observations. Un réglage correct est nécessaire pour la visualisation de la carte du ciel, les informations de l'entête d'une image ainsi que le positionnement du télescope.

L'utilisateur peut sélectionner une ville dans la liste. En fonction de la région du globe, cliquer sur :

  • Sites de France
  • Sites des USA
  • Sites dans le monde
  • Sites des Observatoires

Le bouton [Voir les fichiers de base de données] permet d'ouvrir le répertoire contenant les fichiers de base de données.
Il est possible de chercher un lieu dans la base de données. Une fois le lieu trouvé, cliquer dessus et sur [Sélectionner ce site par défaut].

Si l'utilisateur souhaite paramétrer un lieu ne se trouvant pas dans la liste, cliquer sur [Entrer un nouveau site dans la liste]

Remplir les différents champs et validez en cliquant sur [Entrer ce site dans la liste]

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Décembre 2010


Options / Chemin des catalogues

> Options > Chemin des catalogues

Lancement : Menu [Options] > [Chemin des catalogues]

But : Permet de connaître les chemins où atteindre les fichiers de carte du ciel et d'images.

Ces options doivent être réglées lors du premier démarrage de PRiSM ou à chaque fois que la base de registre windows a été perdu.
Il s'affiche l'écran suivant :

Les différents paramètres sont à régler à volonté ensuite suivant les catalogues que l'utilisateur compte utiliser :

  • Racine du répertoire des images du Pises Atlas :
    Ce chemin indique ou trouver les images de l'atlas des Pises ( CD-ROM ou disque dur ). Ces images doivent se trouver obligatoirement dans le répertoire "\Images" du disque dur ( elles se trouve dans le même répertoire du CD des Pises ). On indiquera le chemin du repertoire principal contenant ce sous-répertoire "\Images" où sont incluses les images des Pises.

  • Racine du répertoire du BT-ATLAS :
    Lettre du lecteur contenant le CD du BT-ATLAS ou chemin où a été copié le CD du BT-ATLAS sur le disque dur.

  • Chemin des USNO-A et USNO-SA :
    Lettre du lecteur où le programme peut trouver le ou les CD de l'USNO. Ce chemin peut également indiquer le répertoire du disque dur où les fichiers du CD-ROM ont été copiés. Ce répertoire doit contenir les fichiers du catalogues du type "Zone0000.ACT, Zone0000.CAT, Zone0075.ACT, Zone0075.CAT, .....".

  • Chemin du GSC / GSC-ACT :
    Après le choix sur le catalogue désiré, on indique la lettre du lecteur où le programme peut trouver le répertoire du disque dur où les fichiers du GSC-ACT ont été copiés. Ce répertoire doit contenir les répertoires du catalogues du type "N0000, N0730, .....".

  • Chemin de l'UCAC 1/2/3 :
    Lettre du lecteur où le programme peut trouver le répertoire du disque dur où les fichiers du catalogue UCAC ont été copiés. Ce répertoire doit contenir les fichiers du catalogues du type "z001, z002, .....".

  • Chemin du NOMAD1 :
    Lettre du lecteur où le programme peut trouver le répertoire du disque dur où les fichiers du catalogue NOMAD1 ont été copiés. Ce répertoire doit contenir les fichiers du catalogues du type "m0146.cat, m0147.cat, .....". Ce catalogue est un ensemble d'informations sur 1 milliards d'étoiles. Il résulte de la réunion des catalogues USNO B1, 2MASS, TYCHO2, HIPPARCOS et UCAC2.

Pour le chargement des catalogues, on pourra se référer aux indications au bas de chaque onglet où à la page de chargement de certains catalogues.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Novembre 2009


Options / Chemin internet de l'aide et proxy

> Options > Chemin internet de l'aide et proxy

Lancement : Menu [Options] > [Chemin internet de l'aide et proxy]

But : Cette fonction permet de paramétrer les différents chemins d'accès vers la documentation internet de PRiSM.

Les réglages intenet

Si l'utilisateur passe par un Proxy HTTP, cochez cette case et remplissez les deux champs suivants.

Par défaut, les chemins "Info du produit" et "Aide par internet" sont corrects. Il n'est en principe pas nécessaire de les modifier. Cependant, l'évolution du logiciel peut faire que ces paramètres peuvent changer.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Novembre 2009


Options / Allocation mémoire

> Options > Allocation mémoire

Lancement : Menu [Options] > [Surveillance allocation mémoire]

But : Permet de connaître la quantité de mémoire alloué au logiciel

Le bouton [référence] permet de fixer la référence pour le calcul du delta.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Janvier 2011


Options / Allocation mémoire

> Options > Ouvrir le répertoire utilisateur

Lancement : Menu [Options] > [Ouvrir le répertoire utilisateur]

But : Ouvrir directement dans l'explorateur windows le chemin du répertoire où sont stockées les informations relatives à l'utilisateur.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Janvier 2011


Options / Réinitialiser position fenêtres

> Options > Réinitialiser position des fenêtres

Lancement : Menu [Options] > [Réinitialiser positions des fenêtres caméra/télescope]

Cette fonction permet de recentrer les fenêtres permettant de commander une caméra ou des accessoires. Cette fonction devient utile notamment lorsque les fenêtres sont dispersées sur l'écran et notamment pour les réorganiser lorsqu'il faut utiliser l'ascenseur pour y avoir accès.

Avant réorganisation | Après réorganisation
Avant | Après

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Octobre 2008


Options / Barre d'icônes

> Options > Barre d'icônes

Lancement : Menu [Options] > [Barre d'icônes]

But : Permet de faire disparaître/apparaître la barre d'icônes du logiciel.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Janvier 2008


Options / Fichier monitoring

> Options > Fichier monitoring

Lancement : Menu [Options] > [Fichier de monitoring (ou fichier LOG)]

But : Permet de monitorer les différentes actions essentielles du logiciel afin de cerner les bugs.

Un exemple de fichier monitoring

Il faut cliquer sur le bouton correspondant afin d'activer l'enregistrement dans le fichier log. Un click sur le bouton droit permet d'ouvrir directement l'explorateur windows afin de visualiser la présence de ce fichier.

Il est possible" de régler la mise à jour des informations ainsi que le nombre de ligne maximale à afficher. Pour sélectionner un mot, marquer ce mot dans la première case et l'ajouter ensuite afin qu'il soit inclus dans la deuxième case. Ceci permet ensuite d'afficher les lignes contenant ce mot recherché.

Enfin, il est possible de remettre le fichier à zéro en effaçant toutes les données dessus.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / Niveau d'information

> Options > Niveau des messages d'information

Lancement : Menu [Options] > [Niveau des messages d'information]

But : Quantité d'informations à fournir pour une fonction dans la fenêtre script.

Lors d'analyse d'images, PRiSM affichent une quantité de messages. Des renseignements qui peuvent être intéressant pour certains observateurs et totalement inutiles pour d'autres.
On reçoit alors une fenêtre de saisie pour choisir le niveau des messages :

Plus le chiffre indiqué est grand ( de 1 à 4 ), plus le nombre de renseignement sera important.

Prenons l'exemple suivant d'étalonnage astrométrique, sachant que ceci peut s'appliquer aussi à l'étalonnage photométrique (avec bien sûr d'autres renseignements dans les messages) ou de recherche automatique d'astéroïdes :

niveau 1 | niveau 2
niveau 1 de l'étalonnage astrométrique | niveau 2 de l'étalonnage astrométrique
niveau 3 | niveau 4
niveau 3 de l'étalonnage astrométrique | niveau 4 de l'étalonnage astrométrique; on ne voit pas tous les résultats. Ils sont disponibles dans un fichier texte en sauvegardant à partir de l'icône disquette.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / MPC Checker

> Options > Rapports > MPC Checker

Lancement : Menu [Options] > [Rapports] > [MPC Checker]

But : Permet de vérifier un fichier texte à envoyer au MPC.

Le fichier est alors formatté afin de vérifier les éléments présents.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / Activer "défaire" la dernière opération

> Options > Activer "défaire" la dernière opération

Lancement : Menu [Options] > [Activer "défaire" la dernière opération]

But : Permet d'annuler une opération de transformation effectuée sur une image

Cette fonction permet de permettre à l'utilisateur de se servir de la fonction "Annuler" (Menu Edition-Annuler). L'élément de menu doit être coché pour que les annulations soient possibles.

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / Basculer infos dans la barre supérieure

> Options > Basculer infos dans la barre supérieure

Lancement : Menu [Options] > [Basculer infos dans la barre supérieure]

But : Permet d'afficher quelques informations système dans la barre de fenêtre de PRiSM:

Avant affichage :

Après affichage :

Après demande de l'option

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / Couleurs nuit

> Options > Couleurs nuit

Lancement : Menu [Options] > [Couleurs nuit (Rouge)]

But : Permet de réduire l'éblouissement lorsque l'on utilise PRiSM dans l'obscurité. L'écran apparaît masqué de rouge :

L'intensité des couleurs est réglable à partir du menu : [Options] > [Options générales de PRiSM]

Fonction(s) Script associée(s):
Aucune

Conditions d'activation :
Aucune

Version Décembre 2007


Options / Reconnaissance des champs d'étoiles

> Options > Reconnaissance des champs d'étoiles

Lancement : Menu [Options] > [Reconnaissance des champs d'étoiles]

Cette fonction permet de définir quelques paramètres utilisés par PRiSM lors des étapes de détection des étoiles présentes sur une image. Ces options sont à régler lors de l'utilisation de menus avec calibration de champs.

Au lancement, la fenêtre suivante s'ouvre :

Le réglage des options

Prérequis :
La méthode des triangles

Le réglage de ces paramètres est d'une importance capitale. Plus la latitude de réglage des paramètres est importante, plus les calculs seront longs mais à l'heure actuelle, la longueur des calculs passe quasiment inaperçu. Par contre, des paramètres trop restrictifs peuvent laisser penser à une mauvaise image ou un nombre d'étoiles d'étalonnage insuffisant alors que ce n'est pas nécessairement le cas ! Il faut cependant rester lucide à vérifier que les distorsions autorisées par des paramètres très larges ne fournisse pas un résultat qui malgré tout sera faux.

On décrit dans un premier temps les paramètres utiles dans la reconnaissance d'étoiles proprement dite, donc utiles pour l'astrométrie, la photométrie, la recherche des astéroïdes et la composition automatique des images entre elles.

Voici des paramètres qui ont lieu lors de la comparaison d'images ou entre une image et un catalogue ... bref, des paramètres importants durant les étalonnages et les compositions d'images :

  • Marge d'erreur sur la position des étoiles (rapport avec l'espace des triangles) : (Nombre sans limite) Les étoiles possèdent un mouvement propre parfois important et entre la date d'édition du catalogue de référence et la prise de l'image, certaines étoiles auront légèrement bougé. Ce paramètre permet de tenir compte de ce mouvement en définissant l'erreur acceptée dans l'espace des triangles afin de supposer que les triangles sont identiques (un équivalent du cercle d'erreur représenté dans l'espace des triangles). Un nombre trop petit entrainera un manque d'étoiles retenues pour la reconnaissance.

  • Limite du rapport des côtés des triangles (rapport avec l'espace des triangles) : (nombre entre 0.1 et 0.9) Ce paramètre permet de limiter l'exploration dans l'espace des triangles en limitant la zone où la comparaison est effectuée en donnant une valeur maximale au rapport "b/a".
    Pour rappel, un graphe utilisé dans la méthode des triangles :

    l'espace des triangles

    Ci dessus, la longueur des triangles est utilisé pour former les rapports des longueurs b/a et c/a et ces rapports définissent un espace à deux dimensions appelé l'espace des triangles. A cause de l'agencement des longueurs dans le triangle ( a > b > c ) les tringles occupent uniquement la partie l'espace à l'intérieur du triangle rouge. Les triangles formés par les deux images peuvent être considérés comme étant "identifiés" quand ils sont à une distance de moins de epsilon l'un de l'autre dans l'espace des triangles.
    Une propriété de l'espace des triangles veut que si deux objets sont relativement proches l'un de l'autre, ils définissent des triangles qui auront une longueur c dans la majorité des cas très inférieure au longueur a et b. La valeur de b/a serait proche de 1 et c/a proche de zéro. Le nombre de point produit dans un coin du triangle rouge sera alors très important et donc les triangles deviendront difficilement identifiables les uns des autres. Il y aura donc un grand nombre de points dans cette zone de l'espace des triangles rendant la reconnaissance longue et difficile. L'expérience prouve qu'il vaut mieux choisir une valeur telle que le rapport "b/a < 0,9". Ainsi, on éliminera tous les triangles très allongés et de plus, on aura donc tendance à augementer fortement la vitesse de l'algorithme. Attention cependant à ne pas choisir une valeur trop faible au risque d'éliminer tous les triangles !

Les paramètres à suivre sont là essentiellement pour limiter les comparaisons et donc pour limiter le temps de calcul afin de limiter le nombre de combinaisons lors de la comparaison. Cependant, ils sont tout autant valables pour des étalonnages que pour des compositions d'images :

  • Marge d'erreur sur la rotation entre les champs d'étoiles (rapport avec l'orientation de la caméra) : (Nombre entre 0.01 et PI = 3,141). Ce paramètre est TRES important et peut donner lieu à croire que beaucoup d'images ne sont pas viables et donc forcer à faire des acquisitions avec des miroirs ! Pour ma part, je place ce paramètre maintenant à 3.14 !
    Lors de la reconnaissance d'un champ, on indique au programme l'orientation prévue de l'image (orientation de l'axe des Y = "Nord/Sud" ou non). Cependant, la caméra n'est jamais orientée parfaitement suivant une direction et qui plus est, dans le "bon sens". Ce paramètre autorise une plus ou moins latitude d'orientation. Evidemment, les calculs seront d'autant plus longs que ce paramètre est proche de PI. Avec les ordinateurs actuels, ce temps passe inaperçu ! Il est donc tout à fait possible d'étalonner des images très inclinées :
  • Marge d'erreur sur le facteur d'aggrandissement entre les champs d'étoiles (rapport avec les paramètres instrumentaux fournis) : (Nombre entre 0.1 et 0.99) Ce nombre est le correspondant du précédent mais cette fois pour la focale de l'instrument et les coordonnées du centre de l'image. Il indique l'erreur que l'utilisateur s'autorise sur le rapport entre "focale réelle de l'instrument " et "focale donnée de l'instrument". Plus ce nombre sera inférieur à 1, plus le programme va lister sur une zone d'autant plus large dans le catalogue d'étoiles de référence. Cette zone sera centrée par rapport au centre donné sur l'image. Ceci autorise une erreur d'autant plus importante sur la focale fournie ou les coordonnées du centre de l'image. Une image avec des paramètres instrumentaux fournis très corrects peut être étalonnée avec un tel paramètre égal à 0,99.
    Attention cependant : plus le paramètre sera proche de 0.1, plus les erreurs de reconnaissance pourront être importantes ! Une fois de plus, c'est à l'utilisateur de rester lucide quant aux paramètres fournis et de rester critique face au résultat.

Une fois la comparaison effectuée, on peut limiter le nombre d'étoiles validées afin de minimiser les erreurs. Ce paramètre n'est utile que pour un étalonnage astrométrique ou photométrique :

  • Résidus minimums pour l'astrométrie auto(") : (Nombre sans limite) Lorsque PRiSM a déterminé une transformation entre l'image et le catalogue à l'aide de l'algorithme des moindres carrés, les paramètres de la transformation sont adaptés pour convenir au mieux à la comparaison. Cependant, pour chaque objet validé comme commun, il reste donc un résidu entre les coordonnées calculées sur l'image grâce aux paramètres de la transformation et les coordonnées obtenues à partir du catalogue. Il est alors possible de choisir une valeur maximale de résidu (en seconde d'arc) au dessus de laquelle l'objet ne sera plus pris en compte pour établir la transformation (ceci a donc pour effet de "dévalider" l'objet !). Cependant, le logiciel n'aura peut être pas besoin de pousser jusqu'à cette valeur pour trouver suffisamment d'étoiles validées comme commune et c'est pour celà que le résidu maximum gardé sera souvent très inférieur à la valeur limite fournie.
Malgré un paramètre réglé à 2.5", On a déjà 31 étoiles de comparaison pour un résidu de moins de 0.5" d'arc !

Des paramètres à régler qui parlent d'eux-mêmes :

  • Demi-largeur de la fenêtre du centroïde : Pour régler la taille du fenêtrage utilisé lors de la modélisation de l'intensité lumineuse de l'étoile par une gaussienne. Paramètre à régler que ce soit pour les étalonnages ou les compositions d'images.
  • Magnitude Min/Max : Ces paramètres sont utiles uniquement lorsqu'il y a un catalogue en jeu, en d'autres termes lors d'étalonnage d'images.

Fonction(s) Script associée(s):
Aucune

Prérequis :
La méthode des triangles

Version Décembre 2006


Aide / A propos de ce logiciel

> Aide > A propos de ce logiciel

Lancement : Menu [Aide] > [A propos de ce logiciel]

Cette fonction permet d'afficher diverses informations concernant le logiciel.

Nov 2006


Aide / Accès HTML

> Aide > Fichier d'aide local

Lancement : Menu [Aide] > [Accès index page d'aide HTML (local)]

Cette fonction permet de lancer le fichier d'aide présent sur le disque dur au format WINDOWS 32 bits.

Ce fichier doit être placé dans le répertoire local de PRiSM.

Ce fichier est téléchargeable ici.

Nov 2006


Aide / Accès au site WEB de l'aide

> Aide > Accès au site WEB de l'aide du logiciel

Lancement : Menu [Aide] > [Aide HTML (accès internet)]

Cette fonction permet de se connecter au site web de l'aide du logiciel PRiSM, dont l'adresse est :

http://www.prism-astro.com/fr/aide/

Nov 2006


Aide / Accès au site WEB

> Aide > Accès au site WEB du logiciel

Lancement : Menu [Aide] > [Le site WEB du logiciel (accès internet)]

Cette fonction permet de se connecter au site web du logiciel PRiSM, dont l'adresse est :

http://www.prism-astro.com/

Nov 2006


Aide / Mise à jour de PRiSM

> Aide > Mise à jour

Lancement : Menu [Aide] > [Mettre à jour PRiSM par internet]

Cette fonction permet de mettre le logiciel à jour.

Nov 2006


Fenêtre du ciel / Menu contextuel

> Fichier > Nouvelle fenêtre du ciel > Configuration > Menu Contextuel

Le menu contextuel, accessible en cliquant avec le bouton droit de la souris sur la fenêtre de la carte du ciel, a l'aspect suivant:

cliquer pour aide |
Version complète | Version Light
  1. Zoom : Cette fonction permet de choisir entre un zoom de 1 x et 2048 x ( utile pour les possesseur de l'USNO-A2.0 ).

  2. Horizon : permet de changer d'horizon ( surtout fait pour les grands zooms ) : on choisit entre le sud, le nord, l'est, l'ouest ou le zénith.

Les quatre fonctions qui suivent ne sont accessibles uniquement si une image est ouverte dans PRiSM.

  3. Envoyer Alpha-Delta dans l'entête de l'image : Si, après avoir réalisé une image, on a repéré le centre de cette dernière sur la carte, il suffit de cliquer sur cette option pour que les coodonnées d'où l'utilisateur a cliqué soient envoyées comme position centrale de l'image (résultats tant utile pour l'astrométrie et la photométrie automatique, dans le cas où ces dernières n'auraient pas été complétées lors de l'observation). Il faut cependant sélectionner l'image parmi celle ouverte à laquelle on veut les informations de coordonnées :

    Evidement, cette opération se fait automatiquement pour ceux qui ont des codeurs étalonnés ou un télescope sous le protocole LX200 ou MCMT.

  4. Inclure une image CCD dans la carte du ciel : Au contraire, si on possède une image dont on connait toutes les coordonnées de tous les objets c'est-à-dire une image qui a été ETALONNEE ASTROMETRIQUEMENT au moins une fois (les coefficients de plaque étant ensuite sauvegardés dans l'entête CPA de l'image), on connait donc toutes les caractéristiques de l'image. On peut en cliquant sur cette option et en sélectionnant l'image à inclure ( demandé par le programme ) inclure son image en toile fond sur la carte du ciel.

    Prenons un exemple :
    Si on regarde dans la carte du ciel les alentours de la nébuleuseplanétaire M27, on remarque que les contours de nébuleuses diffuses ont bien évidemment laissé tomber cette nébuleuse planétaire malgré tout assez étendue. On peut vouloir, pour une raison ou une autre intégrer une image de M27 à la carte du ciel en toile de fond. Ceci peut être pour une raison purement esthétique ou pour vérifier le calibrage astrométrique de son image. Inutile de préciser que ce qui va suivre peut être réalisé pour n'importe quelle image à d'autres fins qu'esthétique !
    Voici les alentours de M27, défini en zoom x128 pour une ST7 et son capteur d'autoguidage :

    la fenêtre du ciel autour de M27

    L'image a introduire est un plan rouge d'une image trichrome de M27 prise par l'auteur de ces lignes. Elle est déjà calibrée astrométriquement et photométriquement comme le prouve les informations sur l'image.
    Il suffit pour celà d'ouvrir l'image concernée et d'aller dans le menu contextuel de la fenêtre et de demander " inclure une image dans la carte du ciel ". Une demande de sélection sur les images ouvertes apparaît alors :

    Sélection de l'image

    Sélectionner l'image désirée et si, comme c'est le cas ici, l'image a été étalonnée astrométriquement ( et pas obligatoirement photométriquement ) celle-ci est incluse à la carte du ciel :

    L'image incluse dans la carte du ciel

    On voit bien que l'image a d'ailleurs été parfaitement calibrée astrométriquement vu que les étoiles de l'image correspondent bien aux étoiles de la carte du ciel.
    Pour rappel, le nom de l'image est alors indiqué dans la configuration de la carte du ciel / option CCD et Telescope.

  5. Centrer la carte du ciel sur une image CCD : Permet, une fois que l'on a les coordonnées du centre d'une image, de centrer la carte du ciel par rapport au coordonnée du centre de l'image. Le programme demande de sélectionner l'image à partir d'une boite de dialogue. Cette fonction est particulièrement utile si on veut utiliser par la suite "Inclure une image CCD dans la carte".

  6. Mettre la carte à la date d'une image CCD : Pour se repérer facilement, cette fonction met la date de la carte du ciel à celle d'une image CCD.

  7. Recevoir Focale / Orientation CCD depuis une image CCD : Permet de copier les infos de focale, d'angle CCD et de type de repère depuis les informations contenues dans l'entête d'une image CCD.
    Voir la page sur la définition de l'orientation du CCD.

Les quatre fonctions qui suivent sont toujours accessibles.

  8. Envoyer RA-DEC dans le presse-papier : Permet d'envoyer les coordonnées du point à partir duquel on a ouvert le menu contextuel dans le presse-papier. Les coordonnées sont envoyées sous la forme 21h12m53.390s | -18°50'35.82".

  9. Envoyer RA-DEC à la liste des objets : ajoute un objet de la carte du ciel dans la liste des objets à observer. Cette liste des objets à observer est accessible à partir du menu "Télescope". Il sera cependant demandé de compléter le nom et la magnitude de l'objet.

  10. Réglage de la carte : Ouvre la boite de dialogue des options d'affichage de la carte.

  11. Aller au point Anti-solaire : Montre la carte du ciel à l'opposé du soleil sur la ligne Soleil-Terre. C'est l'endroit on a le plus de chance de découvrir des astéroïdes assez brillant encore non découverts !

Les quatre fonctions qui suivent sont uniquement accessibles si un système ou des encodeurs sont en liaison avec PRiSM.

  12. Réaligner encodeurs : réinitialise les encodeurs sur une position de la carte du ciel

  13. Envoyer RA-DEC dans le modèle de pointage : Permet d'envoyer les coordonnées du point à partir duquel on a ouvert le menu contextuel dans le modèle de pointage. Ce dernier est accessible à partir du menu "Telescope".

  14. Déplacer le télescope sur ce point : Pour tout télescope sous le protocole LX200, déplace automatiquement le télescope jusqu'au point à partir duquel on a ouvert le menu contextuel.

  15. Aller sur la position du télescope : Centre la carte du ciel sur la position vers laquelle pointe le télescope.

  16. Sauver la position du télescope dans un fichier Excel : Sauvegarde la position du telescope dans un fichier excel dont il faut indiquer le chemin. Ce fichier peut être nouveau ou déjà existant. Sont sauvegardés l'azimuth, la hauteur, l'angle horaire ainsi que les coordonnées équatoriales.

Les six fonctions qui suivent sont toujours accessibles.

  17. Trouver objets autour de ce point : Cette fonction mérite une page à elle seule.

  18. Ajouter ce point à la liste des objets à observer : Il apparait une boite de dialogue qui doit être complétée avant que l'objet ne soit inclus dans la liste. Cette liste des objets à observer est accessible à partir du menu "Télescope".

  19. Télécharger Champ digital sky survey correspondant : télécharge une image du DSS correspondant à la zone sélectionnée sur la carte du ciel. Une boite de dialogue intuitive apparaît alors, identique à celle obtenue à partir du menu "Fichier / Télécharger image DSS".

  20. Faire une copie haute résolution : copie dans le presse-papier une copie haute résolution de la carte du ciel affichée.

  21. Dupliquer cette carte vers une autre fenêtre du ciel : Permet d'ouvrir une nouvelle carte du ciel avec les mêmes paramètres.

  22. Sauver configuration carte du ciel : Permet de sauver la configuration d ela carte duciel dans un fichier MAPSKY dans le répertoire principal de PRiSM.

Conditions d'activation :
Fenêtre du ciel ouverte

Nov. 2005


MANUEL du langage de programmation SCRIPT

1. Introduction

2. Les variables de PRiSM

2.1. Les divers types de variables
2.2. Les variables de type numérique
2.3. Les variables de type chaîne de caractères
2.4. Les variables de type image
2.5. Les variables de type graphe
2.6. Les variables de type texte
2.7. Les opérations entre les variables numériques
2.8. Les opérations entre les chaînes de caractères
2.9. Les opérations entre les variables numériques et les chaînes de caractères

3. Les mots-clés et les constantes de PRiSM

4. Les fonctions de PRiSM

4.1. Les fonctions propres au langage de programmation
4.1.1. Fonctions dédiées aux Entrées - Sorties
4.1.2. Commandes internes au langage SCRIPT
4.1.3. Fonctions dédiées aux opérations entre variables
4.1.4. Fonctions dédiées à la mise en place de commentaires
4.2. Les fonctions mathématiques
4.3. Les fonctions du langage SCRIPT
4.3.1. Fonctions de traitement d'images
4.3.2. Fonctions d'analyse d'images
4.3.3. Fonctions de manipulations de graphiques
4.3.4. Fonctions de visualisation d'images
4.3.5. Fonctions de prétraitement d'images
4.3.6. Fonctions spécifiques aux images couleurs et APN
4.3.7. Fonctions de manipulation de fichiers
4.3.8. Fonctions de manipulation de fichiers textes
4.3.9. Fonctions de conversions et d'angles
4.3.10. Fonctions de transformation d'images
4.3.11. Fonctions permettant d'obtenir des informations sur les images
4.3.12. Fonctions de manipulation d'objets

5. Les conditions et sauts dans le langage SCRIPT

5.1. Les boucles
5.2. Les tests ou sauts conditionnels
5.3. Branchement inconditionnel
5.4. Les sous-routines

6. Exécuter un SCRIPT

6.1. Editer un script avec CRIMSON
6.2. Lancer un SCRIPT PGM
6.3. Déboguer un SCRIPT à l’aide de PRiSM
6.4. Un premier programme sous PRiSM

7. Gérer sa caméra et son télescope par SCRIPT avec PRiSM

7.1. Les fonctions "caméra"
7.2. Les fonctions "télescope"

8. Les limitations du langage SCRIPT

9. Une base de scripts

Voir partie concernée dans le sommaire ("Une base de scripts").


Introduction

Un langage de programmation est destiné à éviter à l'utilisateur de répéter des taches parfois lourdes pour arriver à ses fins, notamment en ce qui concerne le traitement automatique d'une série d'images. Sans ce langage, l'utilisateur devrait inlassablement cliquer toujours sur les mêmes touches. Afin d'éviter ces désagréments, il a été créé dans PRiSM un langage de programmation interne. De ce fait, l'utilisateur devra donc "se creuser la tête" une fois pour toute pour créer son programme et par la suite, le traitement des images de tout ce qui peut se faire automatiquement n'aura comme vitesse limite ... que celle du processeur de la machine !

Le langage interne à PRiSM est un langage bien particulier qui n'a rien à voir avec les langages modernes actuels orientés objet. Ce langage ayant été créé pour répondre au besoin d'une exécution ciblée de tâches déjà présentes dans le logiciel, il n'est donc pas nécessaire qu'il soit très évolué ! Il devait cependant rester facile d'accès (contrairement à certains langages évolués !). Pour essayer de rapprocher ce langage d'un langage connu, on peut dire le langage de PRiSM se rapproche du BASIC : une suite d'instruction simple qui sont exécutée dans l'ordre de lecture du programme, avec des boucles conditionnelles et des renvoi de type "Goto" pour faciliter l'écriture des programmes. La compilation, qui reste interne au logiciel, ne sera donc pas très rapide mais pour exécuter un programme d'une dizaine de Ko en fichier texte, ce n'est pas nécessaire.

Tous les programmes peuvent êtres écrits sous un éditeur de texte ASCII quelconque. Les programmes devront être sauvegardés au format .PGM pour être directement reconnus comme tel par le logiciel PRiSM. Les fichiers en *.PGM seront donc des fichiers programme.

Les majuscules et minuscules n'ont aucune importance : le langage n'est pas "case sensitive".
Il revient au même d'écrire : FOR, fOR, for, For. Les quatre expressions précédentes seront prises pour la même !
Chaque ligne ne doit comporter qu'une seule commande ! En effet, contrairement à beaucoup de langage qui n'ont pas cette exigence, il n'est par contre pas nécessaire de rajouter un signe distinctif comme ";" pour indiquer que l'instruction est terminée. Ce sera le retour de chariot qui l'indiquera. Dans la suite de cette aide, toutes les fonctions SCRIPT utilisées dans les exemples seront notées en majuscules. Pour connaître l’utilité de ces divers fonctions, il est conseillé de se reporter à la partie de l’aide sur les " fonctions SCRIPT ".


Les divers types de variables

Les variables de PRiSM se décomposent en 5 grandes familles :

  • Les variables numériques
  • Les chaînes de caractères
  • Les variables images
  • Les variables graphes
  • Les variables texte

Les variables sont des entités qui contiennent des informations. En mathématique, ces informations sont en général des grandeurs numériques, mais pour la commodité du langage SCRIPT, ces dernières peuvent être autres. Toutes les variables citées précédemment ont leur spécificité. Elles feront d’ailleurs chacune l’objet d’une étude à part. Cependant, leur déclaration seront toujours les mêmes au sein d’un programme.

Contrairement à la majorité des langages de programmation, on ne déclare pas une variable à l'avance sous PRiSM pour pouvoir s'en servir. C'est au programmeur d'initialiser lui-même ses variables soit en leur affectant une valeur soit en l’appelant implicitement à partir d’une des 200 fonctions de PRiSM. Il en sera notamment ainsi pour les variables images, graphes et texte. Pour une variable de type numérique, on peut utiliser la syntaxe suivante :

b=2

où le programme la reconnaîtra comme telle.
On notera qu’il ne doit pas exister d’espaces entre le nom de la variable, le signe " = ", et la valeur de cette dernière.

Pour une variable de type propriétaire à PRiSM, on utilisera une fonction prédéfinie dans le langage SCRIPT afin de la déclarer ; Pour exemple avec une variable image :

OPEN img_prem "C:\essai.cpa"

Il est conseillé de donner un nom évocateur aux variables de ses propres programmes. En effet, ceci permet à n’importe quelle utilisateur de comprendre immédiatement l’utilité d’un tel objet dans l’algorithme du SCRIPT. Les noms de ces dernières ne devront contenir que des caractères alphanumériques de A à Z et de 1 à 9. Les lettres ne devront pas comporter d’accent. Cependant, il ne sera pas possible de donner à une variable un nom qui sera un mot-clé du langage SCRIPT, comme un nom de fonction ou de constante utilisées par PRiSM. Il est conseillé ( surtout pour les longs programmes ) de clarifier le type d’une variable en rajoutant un préfixe devant le nom, ce dernier étant évocateur quant au type de variable utilisé : int_b, f_b, img_b, graph_b, texte_b, str_b….

Du fait qu’on ne puisse pas définir des procédures et des fonctions dans le langage script, la notion de variables globales ou locales n’a pas de sens dans ce langage. On peut considérer que toutes les variables utilisées sont des variables globales !


Les variables de type numérique

Ces variables désignent indifféremment des variables réelles ou entières. Elles s’écrivent de la façon la plus naturelle possible :

i
EchelleX
Dx
Alpha
Compteur

Pour PRiSM, il n'existe aucune différence entre les variables réelles et les variables entières. Il s'agit seulement de nombres. D'ailleurs, il est tout à fait possible de déclarer une variable à partir d'un entier et au cours du même programme, lui attribuer à un certain moment une valeur réelle. Pour exemple, essayer le Télécharger le PGM suivant :

b=2
PRINT b
// b est toujours un entier
b=b*30.256
PRINT b
// b est maintenant un réel !

Ceci n’ayant pas encore été mentionné dans cette aide, les caractères comme "//" , "#" et "REM" permettent d’ajouter des commentaires dans les PGM sans que les phrases qui suivent ces caractères soient interprétés par le programme !Il y a deux façons d’instancier une variable numérique :

  • En l’initialisant avec une valeur numérique comme : b=2.
  • En l’intégrant dans une fonction qui utilise cette variable comme valeur de sortie, comme : INT 3.25 b dans ce dernier cas, la valeur de b sera fixée à 3 et toute autre initialisation précédente de cette même variable sera effacée.

Comme dans tous les langages de programmation, il est possible de créer des tableaux de variables. Des tableaux permettent de réunir plusieurs valeurs dans une même variable. L’organisation sera identique aux matrices. Cependant, il n’est possible de déclarer sous PRiSM que des tableaux colonnes (ou lignes) c’est-à-dire des tableaux à une seule dimension. Ces derniers peuvent s’initialiser de la même façon que les variables simples à la différence qu’on est obligé de rajouter une information sur l’index du tableau : entre crochet, se trouve le numéro d'index, et en préfixe, le nom du tableau.

int_tab[i] f_vals[j]

L’indexation commence à la valeur " 0 ". Mais, le fait d’initialiser le tableau avec l’index [n] renverra une erreur si un appel est fait à [n-1] ou [n+1] si ces dernières variables du tableau n’ont pas été initialisées. De façon générale, il FAUT initialiser une variable avant d’en demander sa valeur !
Par exemple, tester le PGM suivant :

REM On initialise int_b[2]
int_b[2]=23
PRINT int_b[2]
REM En aucun cas, ceci aura initialisé int_b[0] !
PRINT int_b[0]

Les tableaux ne peuvent dépasser une taille de 16384 éléments. Les opérations entre les variables numériques sont décrites plus loin.
Programme utilisant un tableau de valeurs.


Les variables de type chaîne de caractères

Ces variables renferment du texte. La déclaration de ces dernières respectent les règles évoquées ci-dessus. L’unique différence réside dans le fait de la présence du "$" à la fin du nom de la variable indiquant à PRiSM que cette variable ne contiendra que du texte :

a$
Nom$
Nom_Image$
Reponse$

Comme ces variables renferment du texte, elles s’initialisent, comme les variables numériques, de deux façons :

  • A partir d’une fonction SCRIPT.
  • En donnant directement le texte qu’elle doit contenir : Nom$="IC434" ; on notera que le texte devra être accompagné de guillemets " ² " en début et en fin de chaîne.

Il est possible de réaliser des opérations entre variables de chaîne de caractères ou entre variable de chaîne et variable numérique et ceci sera décrit plus loin.
Il existe également des tableaux de chaînes de caractères qui fonctionnent comme les tableaux numériques. Leur syntaxe est du type "tableau_chaine[i]$ ".
On notera la présence de l’index AVANT le caractère " $ " indiquant la présence d’une chaîne de caractère. L’initialisation respecte celle des tableaux numériques avant les contraintes précédemment citées sur les chaînes de caractères.
Par exemple, voir le programme suivant :

REM On initialise les chaînes de caractères et on les concatène
str_b[2]$="Bonjour,"
str_b[3]$="Ca va !"
str_b[4]$=str_b[2]$+" "+str_b[3]$
PRINT str_b[4]$


Les variables de type image

S’il suffisait de mémoriser le chemin d’accès de chaque image, une chaîne de caractère pourrait parfaitement convenir. Or, le langage SCRIPT de PRiSM possède un type de variable bien spécifique : les variables images.

Dès qu’une variable image est déclarée, celle-ci est en rapport avec l’image physique CPA ou FITS correspondante qui sera alors chargée en mémoire. Tout traitement ultérieur sur cette image dans le SCRIPT sera dorénavant effectué à partir du nom de la variable. A chaque appel de ce nom dans le SCRIPT, l’image sera automatiquement affichée et il sera possible également d’obtenir les informations sur l’image à partir de son nom dans le SCRIPT sous forme de variable image.

Le nom des variables de type image s'écrit le plus naturellement possible. De par leur nature, elles sont obligatoirement initialisées par une fonction SCRIPT afin de faire pointer le nom vers une adresse mémoire où sera stockée l’image.

Seules les instructions OPEN nom_image chemin_image ou GETIMAGE nom_image permettront d’effectuer ce travail. Par exemple, voir le programme suivant :

REM Ouvre une image à partir d'une boîte de dialogue de type WIN 95
GetImage Img

Une fois la variable image déclarée, cette dernière sera désignée par son nom dans toute la suite du script. Toutes les fonctions SCRIPT de traitement d’image gèreront des variables images qui auront été préalablement assignées à une image FITS ou CPA.

Il est également possible de créer des tableaux d'images ( syntaxe du type img[i] ) qui fonctionnent comme les tableaux numériques ou de chaînes de caractères. Entre crochet, se trouve le numéro d'index, et en préfixe, le nom du tableau. Les tableaux ne peuvent dépasser une taille de 16384 éléments. Comme pour les autres tableaux, aucune déclaration du tableau concernant sa taille n’est nécessaire. Par exemple, essayer le programme suivant :

A$="C:\prism\Imagesdetest\Pretrait\"
Nom$=A$+"vdb37-1.cpa"
open img[1] Nom$
Nom$=A$+"vdb37-2.cpa"
open img[2] Nom$
Nom$=A$+"vdb37-3.cpa"
open img[3] Nom$
Nom$=A$+"vdb37-4.cpa"
open img[4] Nom$


Les variables de type graphe

Ces variables sont encore spécifiques au langage SCRIPT de PRiSM. Elles ont été introduites dans le même but que les variables images : donner un nom à chaque graphique plutôt que d’indiquer le chemin d’accès à chaque fois que l’on désire s’en servir.La façon de procéder est donc identique aux variables images : A chaque appel d’un graphique par son nom, la variable pointera vers l’adresse mémoire où sont stockés les paramètres du graphique. Tous les traitements du graphique dans le PGM se feront pas son nom de variable. La déclaration est du même style que pour les variables images : en utilisant la fonction SCRIPT OPENGRAPH Nom Chemin.

Cependant, contrairement aux variables images, il n’existe pas encore de variables tableaux de graphiques.


Les variables de type texte

Ces variables sont spécifiques au langage SCRIPT de PRiSM. Elles ont été introduites dans le but de pouvoir écrire dans un fichier texte depuis un script un ensemble de données et éventuellement de pouvoir les lire !

La façon de procéder est la suivante : il faut déclarer le fichier texte par un nom de variable à l’intérieur du script en l’ouvrant à partir de la fonction Open_FileTxt_For_Append pour un nouveau fichier texte et à partir de la fonction Open_FileTxt_For_Rewrite pour un fichier texte existant. On utilisera par la suite les fonctions déclarées dans fonctions script / Fichier-texte pour manier ces variables.

Il n’existe pas de variables tableaux pour les fichiers textes. PRiSM ne gère pas en tant que variables :les pointeurs d'adresses et les variables structurées...


Les opérations entre les variables numériques

Les opérations classiques entre les variables numériques sont possibles comme l’addition au sens large ( +, - ) ou la multiplication au sens large ( *, / ). Par exemple :

Compteur=Compteur+1
Compteur=Compteur-1
i=i+j-1+Compteur

Ou

EchelleX=1.2*4.23
EchelleX=EchelleY*1.23
EchelleX=EchelleY/Facteur

On fera attention aux domaines de validité des opérations mathématiques. Une division par zéro est impossible. Il est possible de mélanger les deux types d’opérations :

Beta=(Echelle+4.1)*(EchelleX/Fact)
Alpha=((EchelleX+Compteur)/(3.12*Alpha))

On peut fixer, pour une meilleure précision par rapport à la précision par défaut de PRiSM, le nombre de chiffres significatifs pour les nombres réels ou le nombre de chiffres après la virgule. On utilisera à cette fin les fonctions SETDISPLAY_FLOAT ou SETDISPLAY_FRAC.


Les opérations entre les chaînes de caractères

L’opération entre les chaînes de caractères principales est la concaténation de chaînes. Ce principe consiste à additionner deux chaînes pour n’en former qu’une seule.

Les concaténations suivantes sont possibles :

Name$="IMA"+"GE"+"S"
Nom$=Name$+"sub "+"3.1"
PRINT Nom$

D’autres fonctions permettent de manier les chaînes de caractères :

  • NBMOT
  • CUTSTR
  • SUBSTRING
  • CUT
  • POSSTR

D'autres fonctions ont été ajoutées et sont plus spécifiques sur le traitement des chaînes de caractères :

  • ExtractFileName
  • ExtractFilePath
  • ChangeFileExt
  • CreateDir


Les opérations entre les variables numériques et les chaînes de caractères

Il est possible de rendre une chaîne de caractères en variable numérique et vice-versa. Pour passer d'une variable numérique à une chaîne de caractère, on utilisera l'une des deux fonctions :

Fonction STR Nombre Chaîne$

Cette fonction transforme une variable numérique ( entière ou réelle ) en chaîne de caractère.

a=1.34
STR a a$
PRINT a$
b=3
STR b b$
PRINT b$

Télécharger l'exemple

Fonction STRF Nombre Chiffre Chaîne$

Cette fonction permet de préciser le nombre de chiffre après la virgule (et non significatifs) que l'on désire garder par rapport à la fonction précédente.

a=1.34
STRF a 1 a$
PRINT a$

Télécharger l'exemple

Fonction STRFF Nombre Largeur NbVirgule Chaîne$

Cette fonction permet de renvoyer un résultat numérique (Nombre) formaté de largeur définie (Largeur) et dont le nombre de chiffre après la virgule (NbVirgule) est lui aussi défini. Le résultat se situera dans le paramètre Chaîne$.

Input a
STRFF a 10 3 a$
PRINT "Valeur affichée : " a$

Télécharger l'exemple

Fonction VAL Chaîne$ Nombre

Cette fonction permet de transcrire la variable Chaîne$ en variable numérique Nombre.
Si la variable Chaîne$ n'est pas un nombre, le nombre correspondant prendra une valeur nulle.

a$="1.34"
VAL a$ a
PRINT a

Télécharger l'exemple


Les mots-clés et les constantes de PRiSM

PRiSM possède dans son langage script des mots-clés qui ne doivent être utilisés que comme constantes. En effet, dans le langage script, contrairement à beaucoup d'autres langages, il n'est pas possible de déclarer à proprement parler des constantes. Cependant, comme tous mots-clés ( comme les fonctions du langage ), il sera impossible de nommer une variable comme un mot-clé ou de chercher à modifier la valeur de cette constantes.
Il est rappelé que le langage script n'est pas "case-sensitive" c'est-à-dire que les majuscules et minuscules ne sont pas distinguées.
Ces mots-clés sont les suivants :

PI : variable numérique qui prend la valeur du nombre mathématique pi = 3,141592654.

PRINT PI

TODEG : Variable qui permet de retranscrire un angle de radians en degrés. TODEG = 180 / pi = 57,29577950.

INPUT "Angle en radians" Angle
Angle=Angle*TODEG
PRINT "Angle en degrés = " Angle

TORAD : Variable qui permet de retranscrire un angle de degrés en radians. TORAD = pi / 180 = 0,01745329252.

INPUT "Angle en degrés" Angle
Angle=Angle*TORAD
PRINT "Angle en radians = " Angle

TRUE = 1 : cette variable s'apparente à un booléen. Elle prend la valeur VRAIE.

FALSE = 0 : cette variable s'apparente à un booléen. Elle prend la valeur FAUX.

Val=1
IF Val=TRUE THEN
    PRINT "Val a la valeur TRUE"
ELSE
    PRINT "Val a la valeur FALSE"
ENDIF


Fonctions dédiées aux Entrées - Sorties

Ces fonctions permettent à l’utilisateur de communiquer avec le script, c’est-à-dire de fournir des données non connues à l’avance au script.

Communication fenêtre script | Boîte de dialogue | Liste | Pause / Fin | Gestion mémoire
PRINT SETDISPLAY_FLOAT SETDISPLAY_FRAC INPUT GetYesNo GetLang | ADDDLGBOX DISPDLGBOX GETDLGBOX RESETDLGBOX | GetFileName GetListFileName GetListFileNameEx GetRepName | PAUSE Delay WaitForEndDelay END EXIT | GetMemStat


Fonctions dédiées au langage interne des scripts

Ces fonctions sont les mots-clés dédiés aux boucles et sauts

  • IF ... THEN ... ELSE ... ENDIF
  • FOR ... NEXT

  • GOTO
  • GOSUB


Fonctions dédiées aux opérations entre variables

Ces fonctions sont des rappels des chapitres précédents sur les opérations entre variables.

Pour les opérations entre chaînes de caractères : voir opérations entre les chaînes de caractères

Pour les opérations entre chaînes de caractères et variables numériques : voir les opérations entre les variables numériques et les chaînes de caractères

  • VAL
  • STR
  • STRF


Fonctions dédiées à la mise en place de commentaires

Ces fonctions permettent de rajouter des commentaires dans un script sans que ce dernier puisse interpréter ce qui suit comme une fonction. L’utilisateur peut rajouter autant de caractères qu’il désire sur la même ligne que le caractère de commentaire. Les accents et autres caractères spéciaux sont acceptés dans la version française. Cependant, la validité du commentaire se limite à la ligne où se situe le caractère de commentaire. Il faut les rajouter à chacune des lignes de commentaires. Enfin,il est plutôt conseillé d’abuser de ces caractères plutôt que ne pas mettre de commentaires dans ses programmes : cela permet à d’autres utilisateurs de pouvoir relire facilement le programme !

  • REM
  • //
  • #


Les fonctions mathématiques

Ces fonctions regroupent toutes les fonctions essentielles qui correspondent à des opérations mathématiques sur les nombres. Ces fonctions sont quasiment toutes de la même forme : FONCTION In Out

Les fonctions mathématiques sont :

  • COS
  • SIN
  • TAN
  • ATN
  • DECR
  • INCR
  • ABS
  • EXP
  • LOG
  • SQR
  • POWER
  • MOD
  • FRAC
  • INT
  • ROUND
  • RANDOM
  • RANDOMG

Un script de test permet de rendre compte de toutes ces fonctions :

RANDOM Valeur1
RANDOMG Valeur2
PRINT "Valeur aléatoire entre 0 et 1 = " Valeur1
PRINT "Valeur aléatoire = " Valeur2
Print "Racine carrée de 2,4334 :"
Sqr 2.4334 a
print a
PRINT " "
Print "Calculer Log(5.33) :"
Log 5.33 a
print a
PRINT " "
Print "Calculer Exp(2.45) :"
exp 2.45 a
print a
PRINT " "
Print "Calculer Cos(Pi/3) :"
cos Pi/3 a
print a
PRINT " "
Print "Calculer Sin(45.63) :"
sin 45.63 a
print a
PRINT " "
Print "Calculer Tan(45.0) :"
tan 45.0 a
print a
PRINT " "
Print "Calculer ArcTan(1.00) :"
Atn 1.00 a
print a
PRINT " "
Print "Partie entière de 3,14 :"
Int 3.65 a
print a
PRINT " "
Print "Nombre entier le plus proche de 3,9 :"
round 3.9 a
print a
PRINT " "
Print "Partie fractionnaire de 3,9 :"
frac 3.9 a
print a
PRINT " "
Print "Calculer 20 modulo 10 :"
a=20
b=10
mod a b
print b
PRINT " "
Print "Valeur absolue de -12,2 :"
abs -12.2 a
print a
PRINT " "
Print "2^4 :"
a=2
b=4
power a b
PRINT b


Les fonctions du langage SCRIPT

On regroupe dans cette partie toutes les fonctions qui s’appliquent à des images, des fichiers ou des graphes du script. On trouvera d’autres fonctions de calcul spécifiques aux coordonnées des images astronomiques. Bien que ces fonctions s’appliquent indifféremment sur des images au format FITS ou CPA, il est FORTEMENT conseillé d’appliquer ces fonctions sur des images CPA en utilisant l’outil de conversion de format que l’utilisateur trouvera dans le menu "Fichier / Conversion de format". Cette dernière opération est surtout importante pour des images trichromes et/ou codées avec des pixels réels et non entiers.

Les fonctions sont classées par thème afin que l’utilisateur puisse se repérer le plus facilement possible. Afin d’obtenir des renseignements sur chacune des fonctions, l’utilisateur devra cliquer sur la fonction. Les renseignements suivants seront alors fournis :

  • Le nom de la fonction !
  • Description de la fonction
  • La syntaxe de la fonction
  • La description de chacun des paramètres sous la forme d'un tableau
  • Pour les fonctions qui utilisent des images, la possibilité d'utiliser cette fonction sur des images monochromes ou trichromes, codées en entiers, réels ou complexes et le type de format utilisable avec cette fonction.
  • Les fonctions associées, c'est-à-dire les fonctions que l'on rencontre couramment avant la fonction étudiées. Un simple clic sur chacune des fonctions permet de connaître le descriptif de ces fonctions. On rencontrera aussi les fonctions liées, c'est-à-dire les fonctions qui sont du même type que la fonction étudiée.
  • Un petit programme de test de la fonction téléchargeable.

En face de chaque grand thème, il pourra exister un numéro qui renverra à une partie importante pour les commentaires … Ne pas oublier d'y jeter un petit coup d'œil !


Fonctions de traitement d'images

Fonctions de traitement d'images (1, 2)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : fonctions essentielles du menu "traitement" des images

Statistique | Filtres | Divers | Espace de Fourier
Noise NoiseGauss | Gauss Add Sub Div Mult MultImg Offset LogImg Dilatation Erosion Gradient HighPass LowPass Median | InverseCadrans Wavelet Create_Pupil Fill_Circ | FFT FFTInverse InterCor Module ImgProd


Fonctions d'analyse d'images

Fonctions d'analyse d'images (1, 2, 4, 5)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : fonctions d'analyse d'images comme centroïde, astrométrie et photométrie.

Astrométrie | Photométrie | Pixels | Statistique | Divers
EtalonAstrometrieAuto GetAstrometrie GetAstrometrieXY XYToAlphaDelta GetImg_XY_TO_RADDEC GetImg_RADDEC_TO_XY GetStarList GetStarListCat TrigMatch Astrom_From_Bin | EtalonPhotometrie EtalonPhotometrieAuto EtalonPhotometrieF GetPhotometrie APC APE CentroideGauss CentroideMoffat CentroidBarycentre CentroidBarycentreThresholding PRC_Flux_Radius | GetPixelValue SetPixelValue NbPixAboveThres Gauss1D CosH_1D | Stat StatWindow GetMinMax | Equalisation EqualisationGauss GetDecalagePlanete REduc_Coll


Fonctions graphiques

Fonctions de manipulation de graphiques

Sont regroupées dans ce paragraphe toutes les fonctions permettant : gestion de graphiques.

  • OpenGraph

  • DisplayGraph

  • SetGraphRange
  • SetAxisInc

  • AddPoint

  • ClearGraphWindows


Fonctions de visualisation d'images

Fonctions de visualisation d'images (1, 2)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : visualisation d'images, fenêtrage, gestion des fenêtres à l'écran.

Curseur Fenêtre Etoiles artificielles Visualisation


Fonctions de prétraitement d'images

Fonctions de prétraitement d'images (1, 2)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : prétraitement d'images à l'intérieur d'un script

Série | Cosmétiques | Fond de ciel
AverageStack MedianStack SameAverage | BoucherZone CicatX CicatY CollapseLine GetHotPixels Exec_CosmeScript | PreProcess SubDarkOpt GetBackGround Deflat_Sky_Bkgnd


Fonctions spécifiques aux images couleurs

Fonctions spécifiques aux images couleurs et APN

Sont regroupées dans ce paragraphe toutes les fonctions spécifiques au traitement des images couleurs, dont certaines sont spécifiques aux appareils photo numériques (APN).

Images RVB Appareils photos numériques (APN)


Fonctions de manipulation de fichiers

Sont regroupées dans ce paragraphe toutes les fonctions permettant : ouverture d'images, sauvegardes, suppression, gestion d'écran.

Ouverture / Fermeture | Gestion | Sauvegardes | Divers
Open OpenFree GetImage OpenBMP Duplicate NewImage SelectImg ClearImgWindows Close | ExtractFileName ExtractFilePath ChangeFileExt CreateDir FileExists GetRepDir GetRepDirAll Delete AssignName | SaveBMP SaveCPA SaveFIT SaveFITS1D SaveJPG SaveGIF SaveTIFF | SetLoadFITsToFloating SetTransformRescaleFITsDynamic Copy Rename ExecExternal PutFTP GetFTP GetScreenX GetScreenY GetVersionScript Beep IncludeScript WriteText GetColor


Fonctions de manipulation de fichiers "texte"

Sont regroupées dans ce paragraphe toutes les fonctions permettant : gestion de fichiers texte de données (ou autre) dans un PGM.

Ouverture Lecture / Ecriture Fermeture


Fonctions de conversions et d'angles

Fonctions de conversions et d'angles (4)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : fonctions de conversion d'angles et de dates.

Date / Heure / Lieu | Carte du ciel | Conversion
Now ConvertDateToJulian DateToStr EncodeDateTime GetStdrLatitude GetStdrLongitude | SideralTime ComputeAngleHor DistSky GetHeight GetAirMass GetDistanceToMeridien GetAzimuth Convert_RADECApp_To_2000 Convert_RADEC2000_To_App | RA_TO_RAD RAD_TO_RA STR_RA_TO_RAD STR_RAD_TO_RA RAD_TO_DEC DEC_TO_RAD STR_DEC_TO_RAD STR_RAD_TO_DEC


Fonctions de transformation d'images

Fonctions de transformation d'images (1, 2)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : fonctions essentielles du menu "transformations" de PRiSM

Général | Conversion
Translate Shift_SPL MirrorX MirrorY Image_Flip QuarterRot Rotate Scale BinningExpand BinningReduce BinningSum DetourageExt DetourageInt ClipH ClipL CompositeAuto CompositeAuto_Evol RecalageAuto RecalageAuto_Inter UnSharp Homothetie DDP | Int2Real Real2Int


Fonctions permettant d'obtenir des informations sur les images

Fonctions permettant d'obtenir des informations sur les images (1, 2, 3, 4)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : gestion entête des images.

Général | Prise de vue | Astrométrie / Photométrie | Spectroscopie | Commentaires
GetExpTime GetJulianDay GetTime GetDate Width Height SetObjectName GetObjectName GetHeaderStringFITS | GetCamera GetBandWidth SetBandWidth GetWaveLength SetWaveLength GetFilter Set_Filtername_Header GetBinX GetBinY GetCVFFactor GetDiameter GetFocus GetMirrorX GetMirrorY GetSizePixX GetSizePixY GetTimeReadCCD Get_WL_BW_FLX GetTCCD GetText Set_Header_Exptime Set_Header_Datetime | GetFlux SetFlux GetImageAirMass GetLatitude GetLongitude GetLowerThrhold GetUpperThrhold GetObservatory GetObserver GetSeeing GetTelescope GetAlpha GetDelta PutAlpha PutDelta GetPierSide GetCCDOri GetRepDirHeader | SetSpectroName SetReseauSpec GetSpectroName GetReseauSpec | SetComment Set_Header_Usr Get_Header_Usr

Programme de Test d'un grand nombre de fonctions d'entête d'images


Fonctions de manipulation d'objets

Fonctions de manipulation d'objets (4)

Sont regroupées dans ce paragraphe toutes les fonctions permettant : gestion de coordonnées d'objets

  • GetObjectCoord

  • GetRaDecMoon
  • GetRaDecSun

  • GetAsterCoord

  • GetCometCoord


Fonctions spécifiques à la gestion des télescopes et caméras

Gérer sa caméra et son télescope par SCRIPT avec PRiSM

Ces fonctions permettent de gérer par SCRIPT ses propres instruments ( à condition qu’il puisse être gérés par PRiSM ) jusqu’à programmer sa soirée d’observation à l’aide des fonctions SCRIPT classiques.
Il est possible de séparer l’ensemble de ces fonctions en deux parties : caméra et télescope. Toutes les fonctions dans la catégorie "caméra" seront utilisées afin d'acquérir une image alors que les fonctions de la catégorie "télescope" seront utilisées pour bouger le télescope vers un objet. Il y a seulement un petit nombre de fonctions d'acquisition dans PRiSM, mais ceci est bien suffisant !

  • Fonctions sur la gestion des caméras.
  • Fonctions sur la gestion des télescopes.


Fonctions spécifiques à la gestion des caméras

Les fonctions "caméra"

Ces fonctions peuvent être testée avec les caméras SBIG en mode démonstration.

POUR TOUTES VERSIONS DE PRISM : Il y a deux façons d'utiliser les caméras dans les scripts :

  • Lancer la caméra indépendamment ("Caméra / Initialisation") après avoir régler le type de caméra. Il ne sera alors pas la peine de réintialiser la caméra grâce à la commande "Init_CCD_Camera" !
  • Ne pas lancer la caméra avant l'exécution du script. L'appel de la fonction de connexion "Init_CCD_Camera" sera alors obligatoire afin de pouvoir utiliser les fonctions scripts sur les caméras CCD. Les paramètres de la caméra CCD ayant été conservés dans la base de registre lors de l'observation précédentes, ces derniers seront repris à l'identique (température à atteindre et autres). Libre à l'utilisateur de faire cependant une pause dans le script afin de vérifier ces paramètres. Le script pourra alors se dérouler ensuite normalement.
  • Les fonctions se terminant par "_EX" (= "extended") sont des commandes identiques à celles sans ce suffixe à la différence prêt qu'elles peuvent être appliquées sur l'une des 3 caméras déclarées (nommées dans le logiciel caméras principale, de guidage ou tertiaire).

Les fonctions sont les suivantes :

Etablir la liaison avec la caméra | Paramètres à fixer avant la pose | Récupérations de données | Pause | Divers et autoguidage | Tests de la caméra | Déconnecter la liaison avec la caméra
Init_CCD_Camera Init_CCD_Camera_EX | SetBinningX SetBinningX_EX SetBinningY SetBinningY_EX SetMirror SetMirror_EX SetFlagShutter SetFlagShutter_EX SetWindow SetWindow_EX SetWindowFullFrame SetWindowFullFrame_EX SetCCDTemperature SetCCDTemperature_EX | StartExposure StartExposure_EX WaitForEndExposure WaitForEndExposure_EX GetLastImageExposure GetLastImageExposure_EX GetCCDTemperature GetCCDTemperature_EX | Delay WaitForEndDelay | ActiveRelayXY GetMaxADU GetMaxADU_EX Shutter StartGuide StartGuideConsigne StartGuideSlit StartGuide_EX StopGuide StopGuide_EX Get_Guide_Status Get_Guide_Status_EX | Get_CCD_Status getLinearity GetNoise GetDark GetCTE GetQE GetConvertFactor CCDTest_TDI_Linearity | Close_CCD_Camera Close_CCD_Camera_EX


Fonctions spécifiques à la gestion des télescopes

Les fonctions " télescope "

Ces commandes peuvent être exécutées depuis le menu " Fichier / Executer Scripts " comme toutes les fonctions scripts classiques. En effet, notamment pour PRiSM v5.xx.xx, il n'est nullement nécessaire de s'assurer que la caméra est en fonctionnement car l'un peut fonctionner sans l'autre !

Les fonctions sont les suivantes :

Etablir la liaison avec le télescope | Fonctions de position (codeurs) | Fonctions moteurs | Fonctions accessoires | Déconnecter la liaison avec le télescope
Open_Telescope_Devices | Calibrate_Telescope Get_Telescope_Position Get_Telescope_Position_App ShowRaDec_Skymap Park_Telescope UnPark | MoveTelescope WaitForEndMoveTelescope GetLastImageExposure ShiftTelescope StopTelescope Return_Telescope_To_Sideral | SetFilter Set_Focuser Get_Focuser_Temp Get_Focuser_Pos Reset_Focuser AutoFoc AutoFoc_EX Get_Dome_Pos MoveDome SetDomeToTelescope Reset_Dome Close_Dome Open_Dome GetDataWeatherStation | Close_Telescope_Devices


Fonctions spécifiques à la gestion des APN

Les fonctions APN

Ces fonctions ne peuvent être testées sans appareil photo.

Etablir la connexion avec l'appareil photo à partir du menu "Caméra / Acquisition avec APN".

Ensuite, les fonctions sont les suivantes :

Etablir la liaison avec l'APN Paramètres à fixer avant la pose Récupérations de données Pause Déconnecter la liaison avec la caméra


Les boucles

Dans le langage Script, il est proposé une seule structure de boucle : La boucle FOR … NEXT

La syntaxe en est la suivante :

FOR Variable=Debut Fin [Pas]
... Instructions ...
NEXT [Variable]

A noter qu’il ne doit pas y avoir d’espace entre la "Variable" et la valeur "Debut". Les [] indiquent un paramètre optionnel. Ce paramètre règle le pas de variation de "Variable".

Il n’est pas possible d’écrire la boucle sur une seule ligne et une boucle FOR … NEXT s’écrit sur au moins 3 lignes !

Les boucles peuvent êtres imbriquées :

FOR Variable1=Debut1 Fin1 [Pas1]
... Instructions ...
FOR Variable2=Debut2 Fin2 [Pas2]
... Instructions ...
 NEXT Variable2
... Instructions ...
NEXT Variable1

Pour la clarté du programme, il est conseillé de donner la variable à laquelle se reporte l'instruction NEXT ... mais libre au programmeur de l'écrire !

Voici un exemple donné dans le fichier TEST_FOR.PGM :

For i=1 50
    Print "Bonjour i="; i
Next i

For i=1 50
    Print "le monde i="; i
Next i

For i=0 1000 10
    Print "merci i="; i
Next i


Les tests et sauts conditionnels

Les tests ou sauts conditionnels

Ils sont générées à partir du jeu d'instructions IF, THEN, ELSE et ENDIF :

IF Condition THEN
 ... Instructions ...
ELSE
 ... Instructions ...
ENDIF

La " Condition " doit résulter d’une comparaison entre 2 variables ( =, >, < ). Une condition qui serait écrite " TRUE " ou " FALSE " ne renverra aucun résultat.

De même que pour la condition FOR … NEXT, il faut respecter le passage à la ligne pour chaque partie de l’instruction !

Les test et sauts peuvent êtres imbriqués :

IF Condition1 THEN
 ... Instructions ...
IF Condition2 THEN
 ... Instructions ...
 ELSE
 ... Instructions ...
 ENDIF
... Instructions ...
ELSE
 ... Instructions ...
ENDIF

Voici un exemple :

Input "Entrez un nombre : "; n

If n<>0 Then
    Print "N<>0"
Else

    Print "N=0"

Endif


Les branchements inconditionnels

Branchement inconditionnel

Un branchement inconditionnel est utilisé pour passer une partie du script ( en général, le branchement est utilisé dans une instruction de type branchement conditionnel ). Par la suite, on ne reviendra pas à l'endroit où le programme a été quitté.

Ils sont générés à partir de l'instruction GOTO :

... Instructions ...
GOTO Etiquette:
... Instructions ...
Etiquette:
... Instructions ...

On notera l’usage des deux-points " : " après le nom de l’étiquette.

Voici un exemple donné dans le fichier TestGoto.pgm
Il faut sauter une ligne après l'étiquette !

Print "début "
Goto Etiquette1:
Print "on n'ira jamais ici !!"
Etiquette1:
Print "fin"


Les sous-routines

Une sous-routine peut être comparée à une procédure. Le programme y va quand on lui demande et dès que le mot clé RETURN est rencontré, le programme revient à l'endroit il a été laissé pour la sous-routine.

Elles sont générées à partir du jeu d'instructions GOSUB et RETURN.

GOSUB Etiquette1:
... Instructions ...

GOSUB Etiquette2:
... Instructions ...
... Instructions ...
... Instructions ...

END

Etiquette1:
... Instructions ...
RETURN

Etiquette2:
... Instructions ...
RETURN

On notera encore la présence obligatoire de " : " après le nom de l’étiquette.

A la fin du programme principal, il faut mettre le mot " END " si on ne veut pas que le PGM continu à exécuter la première étiquette (le mot RETURN renverra ensuite une erreur !).

Voici un exemple donné dans le fichier TestSP.pgm :

PRINT "Exécution de la première sous-routine"
GOSUB Toto:
PRINT "Exécution de la deuxième sous-routine"
GOSUB Tata:
End

Toto:
print "Sous Programme TOTO"
RETURN

Tata:
print "Sous Programme TATA"
RETURN


Les sous-routines de scripts extérieurs

La sous-routine provient alors d'un script externe à celui exécuté. Le programme y va quand on lui demande et dès que le mot clé RETURN est rencontré, le programme revient à l'endroit il a été laissé pour le script principal. Le but principal de cette fonction est d'utiliser des librairies (scripts) de référence contenant des routines pouvant être utilisées par d'autres scripts. Il est alors facile de se créer ses propres routines (avec beaucoup de commentaires car destinées à être réutilisé) et de les appeler depuis d'autres scripts plutot que de "jouer" au copier-coller !

Le chemin où le logiciel trouve ces sous-routines est à régler dans le menu "Option / Options générales de PRiSM" et dans l'onglet "Script" :

Ces librairies sont appelées à partir du jeu d'instructions "INCLUDESCRIPT" dans le script maître et "etiquette: / RETURN" dans le sous-script.

Script maître :

INCLUDESCRIPT "sous-script_1.pgm" Etiquette1:

... Instructions ...

INCLUDESCRIPT "sous-script_2.pgm" Etiquette2:

... Instructions ...
... Instructions ...
... Instructions ...

Script secondaire "sous-script_1.pgm" :

Etiquette1:
... Instructions ...
RETURN

Script secondaire "sous-script_2.pgm" :

Etiquette2:
... Instructions ...
RETURN

On notera encore la présence obligatoire de " : " après le nom de l'étiquette.

Voici un exemple donné dans le script maître TestSSM.pgm et dans le script secondaire TestSSS.pgm :

TestSSM.pgm :

a$="10"
b$="222"
X1=10
X2=20

INCLUDESCRIPT "TestSSS.pgm" Fonction1:
Print c$

INCLUDESCRIPT "TestSSS.pgm" Fonction2:
Print S

TestSSS.pgm :

Fonction1:
 c$=a$+b$
RETURN

Fonction2:
 S=X1+X2
 S=S*2
RETURN


Editer un script avec CRIMSON

Editer un script de PRiSM

La majorité des utilisateurs utilisent un éditeur comme NOTEPAD® pour modifier leur script. Cet éditeur n'est pas très adapté ... Il est proposé ici deux éditeurs : "ULTRAEDIT" qui est un shareware et "CRIMSON", un éditeur de texte freeware téléchargeable à l'adresse : http://www.crimsoneditor.com/. Ces éditeurs reconnaissent les commandes scripts de PRiSM en les mettant en une autre couleur dans le texte, ce qui permet de les remarquer du premier coup d'oeil.

CRIMSON :

Il faut apporter quelques compléments après l'installation :

  • Dans le répertoire principal de l'éditeur + "\spec\", mettre les fichiers "pgm.key" et "pgm.spc"

    pgm.key : contient les commandes (à mettre à jour en fonction des nouvelles commandes script de PRiSM). Les couleurs d'apparition dans l'éditeur se modifient à partir du menu "View / Set colors ... / General / Colors". Pour vérification, on pourra utiliser ce fichier d'extension ".pgm" où les commandes doivent s'afficher suivant la couleur choisie dans les "Préférences".

    pgm.spc : contient les types de syntaxe (les commentaires, etc etc)

  • Dans le répertoire principal de l'éditeur + "\link\" mettre le fichier "link.pgm"

    extension.pgm : fichier de lien ... ne pas le changer

ULTRAEDIT : (par Nicolas Ruffier)

Il faut apporter quelques compléments après l'installation :

  • Télécharger le fichier suivant : wordfile.txt
  • Copier ce fichier dans le répertoire de UltraEdit (Attention : faire une sauvegarde de l'ancien fichier)
  • Depuis le menu "Avancé", sélectionner "Configuration..."

  • Cocher alors l'option "Activer la coloration syntaxique" comme indiqué dans l'image ci-dessous :

  • Faire un test avec un script, les fonctions script devant apparaître en couleur. Une autre fonctionnalité permet de lister les fonctions et de sélectionner celles-ci plus rapidement; par exemple : Taper "ex" puis CTRL-ESPACE : UltraEdit affiche alors les 6 fonctions possibles commencant par "ex", et il ne reste plus qu'à sélectionner l'option de votre choix et taper sur ENTER.

    Comment intégrer l'aide des scripts Prism dans "UltraEdit" ou "Crimson" ?

    Pour faciliter la création des scripts dans votre éditeur, il est possible de paramétrer votre éditeur pour plus de simplicité et avoir une aide contextuelle. Par exemple, vous tapez la fonction GETDATAWEATHERSTATION mais vous ne vous rappelez plus comment coder les paramètres.
    Vous faites un double-clic sur le mot puis F1 et la page de la fonction GETDATAWEATHERSTATION s'affiche.
    Pour mettre vos scripts en couleur, voir plus haut.

    CRIMSON : (par Nicolas Ruffier)

    • Lancer Crimson.
    • Dans le menu "Tools", sélectionner "Preferences..."

    • Dans la fenêtre "Preferences", choisissez la Categories "User Tools" de "Tools". Puis saisir les champs comme indiqué ci-dessous. Si vous voulez télécharger le fichier "script.chm" cliquer ici. Saisir les champs "Menu Text:", "Command", "Argument", "Initial Dir:" et "Hot Key". Pour le champ "Command", indiquer le répertoire où se trouve le fichier script.chm.

    • Cliquer sur OK pour terminer.
    • Faire un test, en positionnant le curseur sur une fonction PRiSM puis cliquer sur F1.

    ULTRAEDIT : (par Nicolas Ruffier)

    • Lancer UE..
    • Dans le menu "?", sélectionner "Ajouter des fichiers d'aide".

    • Dans la fenêtre "Ajouter des fichiers d'aide", saisir les champs comme indiqué ci-dessous. Si vous voulez télécharger le fichier "script.chm" cliqué ici. Saisir les champs "Fichier d'aide:", "Nom de l'élément... ". Pour le champ "Fichier d'aide", indiquer le répertoire ou se trouve le fichier script.chm. Une fois la saisie terminée, cliquez sur le bouton "Insérer" et vous devez voir apparaitre la ligne entourée en rouge.

    • Cliquer sur OK pour terminer.
    • Faire un test, en sélectionnant une fonction PRiSM puis cliquer sur F1.


Lancer un script

Lancer un SCRIPT PGM

Cette partie est consacrée à l'exécution d'un fichier Script. Il faut, évidemment, déjà en posséder un !

Copiez le code source du programme ci-dessous et enregistrez-le dans un fichier texte que vous appellerez SIMPLE.PGM

REM Le plus Simple !

PRINT "Je suis un fichier programme PGM !"

Pour exécuter ce petit programme, il suffit de lancer PRiSM et d'aller dans le menu Fichier. On peut remarquer au bas du menu quatre lignes dédiées aux scripts :

  • Ajouter Script : Cette fonction permet de demander à intégrer au logiciel un fichier Script. Il sera alors ouvert une boîte de dialogue demandant de fournir le répertoire et le nom du fichier programme. Le nom de ce dernier viendra s'ajouter ( aux autres éventuels ) sous les quatre commandes dédiées au langage SCRIPT. Même à la sortie du programme, le chemin de ces PGM seront sauvegardés dans la base de registre WINDOWS et à chaque démarrage, tant qu'il ne sera pas demandé au logiciel de les enlever, ces PGM apparaîtront dans cette liste. Ils seront précédé d'une étoile "*". Pour faire fonctionner directement ces PGM ( au chemin mémorisé dans la base de registre WINDOWS ), il suffit de cliquer directement dessus.

  • Supprimer Script : Cette fonction est l'inverse de la précédente. Il suffit de sélectionner un ou un ensemble de script dans la fenêtre proposée et le chemin mémorisés de ces derniers seront effacés dans la base de registre ( Pas d'inquiétude, le PGM ne sera pas effacé ! )

  • Exécuter Script : Cette fonction permet d'exécuter un script en fournissant au logiciel le nom et le chemin du PGM à partir d'une boite de dialogue type WIN95, sans pour autant le faire rentrer dans la liste des PGM dont le chemin est mémorisé.

  • Exécuter Script en mode débug : Cette fonction permet d'exécuter un script en fournissant au logiciel le nom et le chemin du PGM à partir d'une boite de dialogue type WIN95, sans pour autant le faire rentrer dans la liste des PGM dont le chemin est mémorisé. La différence avec la fonction précédente est qu'il est ouvert en même temps une fenêtre rendant compte d'un ensemble de renseignements permettant de déboguer plus facilement un SCRIPT boggé ! L'explication sur cette fenêtre a lieu dans une page suivante.

Revenons maintenant à notre petit programme. Il y a donc, à la lumière de ce qui vient d'être précédemment décrit, deux façons de le lancer :

  • Soit on désire le lancer une seule fois ( ce qui pour ce programme-là paraît plus que légitime ! ). Dans ce cas, il suffit de cliquer sur Fichier > Exécuter Script et une boite de dialogue invite l'utilisateur à fournir le nom et le chemin du programme ( .PGM par défaut ) où se trouve son programme.
    Essayez ! Une boite de suivi apparaît où s'affiche des commentaires et des résultats. La description de cette boite se fera plus loin dans le manuel.

  • Si maintenant, on désire garder toujours à portée de la main ce petit programme, il va falloir le déclarer comme programme ( important ! ) dans la liste des programmes dont les chemins ont été mémorisés.
    On place dans cette catégorie les programmes dont on se sert souvent ! Aller alors dans le menu Fichier > Ajouter Script et saisir le nom et le chemin ( .PGM par défaut ) du programme à intégrer. Le menu doit maintenant apparaître sous la forme suivante montrant que le programme Simple.PGM a été intégré dans la liste essentielle :

    Il suffit maintenant de directement cliquer dessus pour le lancer sans avoir à saisir de nouveau le nom et le chemin d'accès.

Si ce programme ne sert plus, autant le supprimer de la liste. Il suffit alors d'aller dans le menu Fichier/Supprimer Script et de sélectionner le ou les programmes dont le chemin n'a plus besoin d'être mémorisé. On peut sélectionner plusieurs PGM à la fois en cliquant simultanément sur "Ctrl" et les programmes. Si on n'a pas supprimé tous les PGM, le menu Fichier doit être redevenu identique à la première image de cette page.


Déboguer un script

Déboguer un SCRIPT à l’aide de PRiSM

Le débogueur est intégré à PRiSM afin de corriger facilement des scripts .PGM .
Il y a deux façons d'y accéder :

  • 1ère possibilités : à partir du menu Fichier > Exécuter Script (mode débug). Il faut alors indiquer le chemin du PGM (comme pour la commande classique) mais en plus de la fenêtre d'exécution habituelle, une fenêtre de déboguage s'ouvre :

  • 2ème possibilité : à partir de la fenêtre d'exécution des scripts habituelle, l'icône [image] permet d'ouvrir la fenêtre de déboguage. A cette fin, pour se donner le temps d'ouvrir cette fenêtre à tout moment, il faut rajouter l'instruction " PAUSE " au début du programme pour que le programme s'arrête momentanément ( voir exemple ci-dessus dans la fenêtre du débogueur ). On pourra alors ouvrir le déboggeur et s'en servir ou ignorer cette commande et relancer l'exécution du programme à partir de l'icône [image]. Il est également possible de mettre le programme en " PAUSE " pendant son exécution grâce à la commande pause [image], mais il faut être rapide !

Une fois le déboggeur ouvert, on peut remarquer qu'il se compose de trois parties principales :

  • La série des 3 boutons désormais classiques : "Exécuter", "Pause" et "Stop".
  • La fenêtre de renseignements sur toutes les variables utilisées (numérique et de chaînes, mais pas de variables d'images, graphiques ou de texte) avec leur nom et en face la valeur prise par ces dernières (il n'y aura que les variables définies par défaut qui apparaîtront à l'ouverture du déboggueur : PI, TODEG, TORAD, TRUE et FALSE ... voir les mots-clés de PRiSM).
  • La fenêtre de commandes qui retrace toutes les lignes du programme.

On rappelle qu'il est impossible, à l'heure actuelle, de modifier le programme à partir de la fenêtre du déboggeur.

L'exécution du programme peut être vue à partir de ce dernier bien que les résultats dus à l'instruction "PRINT" s'affiche dans la fenêtre d'exécution classique. En voici la description des différents éléments :

  • Le bouton [image] permet de lancer le programme à partir du niveau où se situe le pointeur rouge
  • Pour exécuter le programme pas à pas, il suffit d'appuyer à chaque fois sur le bouton pause [image]. Les lignes du programme seront exécutées une à une. Les résultats des variables seront fournis au fur et à mesure dans la fenêtre prévue à cet effet et les renseignements de liaison avec l'utilisateur ( commande "PRINT" ) seront également inscrits dans la fenêtre au fur et à mesure.
  • Pour faire repartir le programme , il suffit d'appuyer sur le bouton " Start " :
  • On peut vouloir exécuter un bloc de fonctions sans devoir appuyer sur le bouton " Pause " à chaque instant. Par contre, on peut désirer s'arrêter à un instant bien précis. Il suffit pour celà de placer ce qu'on appelle " un point d'arrêt " dans le débogueur.
    A cette fin, repérer la ligne à la fin de laquelle on désire que le programme s'arrête (le programme s'arrêtera après l'exécution de cette ligne). Cliquer une fois sur les commandes de cette ligne et un bouton rouge apparaît à gauche de la ligne : . Ce bouton indique que cette ligne sera désignée comme point d'arrêt de l'exécution du programme. En appuyant alors sur le bouton " Start ", le programme s'exécutera jusqu'à rencontrer ce bouton, auquel cas il arrêtera son exécution à la fin de la ligne. On peut rajouter de tel boutons au fur et à mesure pendant le déboguage.
    Pour poursuivre le programme, appuyer de nouveau sur le bouton "Start" et le programme continuera jusqu'au prochain point d'arrêt ... ou jusqu'à la prochaine erreur qui aura pour effet de vider alors complètement le débogueur de son contenu.
  • Sinon, le carré noir permet de tout arrêter :

Durant l'exécution du Script, au fur et à mesure que les fonctions sont exécutées, le débogueur affiche les variables numériques et de chaînes utilisées, ainsi que leur valeur numérique ou de caractères en face.
Attention : les variables images, graphiques et textes ne sont pas affichées.

Remarque : le fait d'utiliser le débogueur ralenti un peu l'exécution du script ... même si l'exécution a lieu d'un trait.

Exemple d'application :

Considérons le programme suivant qui possède un bug très banal ! (le but de cette aide n'est pas d'étudier les cas les plus durs !). Copiez et collez le programme ci-dessous dans un fichier texte que vous appellerez par exemple "BUGS.PGM"

REM Test des fonctions Stat et StatWindow
REM Stat calcule les informations statistiques sur la totalité de l'image
REM StatWindow calcule les informations statistiques sur une fenêtre de l'image

PRINT " Démarrer le débogueurs ou continuer "
PAUSE

GetImage Img

Stat Img Moyenne MoyenneQuadratique EcartType Max Min Flux Mediane

Print "Moyenne=" Moyenne
Print "MoyenneQuadratique=" MoyenneQuadratique
Print "EcartType=" EcartType
Print "Max=" Max
Print "Min=" Min
Print "Flux=" Flx
Print "Mediane="  Mediane

Le lancer d'une façon ou d'une autre afin d'ouvrir le déboggeur. Une commande "PAUSE" a été introduite afin de pouvoir lancer le déboggeur à partir de l'icône. Mais on peut aussi utiliser le menu pour le lancer directement.

Si on exécute directement ce programme, on se rend vite compte qu'il réalise la statistique de la totalité d'une image et qu'il affiche les principaux résultats mais qu'il renvoie le message d'erreur suivant : " Variable FLX non reconnue " : Il y a donc une variable non déclaré. Un coup d'oeil avec un éditeur de texte et l'erreur serait vite réparé mais ce n'est pas le but de cette partie, alors, utilisons le déboggeur.

On peut, d'une part, exécuter les commandes pas à pas ...
Le plus simple est de poser des points d'arrêts à des niveaux stratégiques du script.
Après avoir ouvert le déboggeur, on posera alors un point d'arrêt au niveau de la fonction pour verifier que le mauvais fonctionnement ne vient pas d'elle.

mettre un point d'arrêt dans le déboggeur

Les commandes à venir sont des commandes d'affichage. On les exécutera pas à pas grâce à la touche " PAUSE " afin de vérifier que le disfonctionnement ne vient pas de l'une d'elle.
Lorsqu'on lance l'exécution du script grâce à la commande [image], le programme s'exécute jusqu'à la fonction " Stat ". Les variables correpondantes prennent alors des valeurs qui sont affichées dans la partie correspondante.

les variables correspondantes

Cependant, l'erreur ne semble pas là !
On exécute alors la suite du script pas à pas et on suivant en même temps la petite flèche rouge [image] indiquant la fonction exécutée par le programme. A partir du moment où on arrive sur le flux, l'erreur est décelée et alors facilement corrigible grâce à n'importe quel éditeur de texte.

l'erreur est décelée


Mon premier script

Un premier programme sous PRiSM

Le plus simple pour apprendre à programmer est d'aller voir la page consacrée à une réunion de script déjà conçus et approuvés ...


Les limitations

Les limitations du langage SCRIPT

Les programmes pourront utiliser au plus :

  • 200 Labels (GOTO).
  • 300 niveaux de conditions (IF).
  • 300 niveaux de boucles (FOR).
  • 300 variables de type num?riques.
  • 16384 variables dans le m?me tableau.
  • 300 variables de cha?nes de caract?res.
  • 100 niveaux de parenth?se.
  • 80 caract?res par ligne.
  • 1 seule commande par ligne.
  • 40 variables par ligne de commande.


Les fonctions scripts de PRiSM v6

Les fonctions scripts de PRiSM

Cette partie donne toutes les fonctions existantes dans PRiSM.

Pour chaque fonction, il sera indiqué :

  • Le nom de la fonction !
  • Description de la fonction
  • La syntaxe de la fonction
  • La description de chacun des paramètres sous la forme d'un tableau
  • Pour les fonctions qui utilisent des images, la possibilité d'utiliser cette fonction sur des images monochromes ou trichromes, codées en entiers, réels ou complexes et le type de format utilisable avec cette fonction.
  • Les fonctions associées, c'est-à-dire les fonctions que l'on rencontre couramment avant la fonction étudiées. Un simple clic sur chacune des fonctions permet de connaître le descriptif de ces fonctions. On rencontrera aussi les fonctions liées, c'est-à-dire les fonctions qui sont du même type que la fonction étudiée.
  • Un petit programme de test de la fonction téléchargeable.

L'apparence sera alors la suivante :

XXXXXXXXXXXXXXXXXX

Description :

Cette fonction permet de ??????????????????????????????

Syntaxe :

XXXXXXXXXXXXXXX X

Variables :

Paramètres | Entrées / Sorties | Type | Description
X | Entrée | Entier | XXXXXXXXXXXXXXXXXXXXx

Voir aussi :

XXXXXXXXXXXXX

Exemple :

........................
REM XXXXXXXXXXXXXXXXXX
xxxxx = 1
XXXXXXXX xxxxx
.....................................

Télécharger l'exemple


Entrées_Sorties / GetYesNo

GetYesNo

Description :

Cette fonction ouvre une boite de dialogue posant une question de type "oui / non".
La réponse est de type Booléen : 1=OUI et 0=NON.

Syntaxe :

GETYESNO question$ rep

Variables :

Paramètres | Entrées / Sorties | Type | Description
question$ | Entrée | Chaîne de caractères | question à répondre ...
rep | Sortie | Booléen | Réponse à la question ...

Voir aussi :

Exemple :

a$="Voulez-vous continuer ?"

GETYESNO a$ YesNo

If YesNo=1 then
...........................................

Télécharger l'exemple


Entrées-Sorties / GetLang

GetLang

Description :

Cette fonction permet de connaître le langage utilisé pour cette version de PRiSM ( au cas où l'utilisateur ne l'aurait pas reconnue ! ).
La valeur de "Lang" est de 0 (= FALSE) pour le français et de 1 (= TRUE) pour l'Anglais.

Syntaxe :

GETLANG Lang

Variables :

Paramètres | Entrées / Sorties | Type | Description
Lang | Sortie | Booléen | Langue utilisée dans cette version de PRiSM

Exemple :

................................
GETLANG Language

if Language=1
   Print "PRiSM is in English"
else
   Print "PRiSM est en Français"
endif

Télécharger l'exemple


Entrées_Sorties / INPUT

INPUT

Description :

Cette fonction permet de demander une valeur éventuellement précédé d'un texte explicatif.
On ne peut afficher que du texte. Il faut obligatoirement demander la valeur d'une variable.

Syntaxe :

INPUT [texte] resultat

Variables :

Paramètres | Entrées / Sorties | Type | Description
texte | Entrée optionnelle | Chaîne de caractères | Texte affiché à côté de la fenêtre pour rentrer le résultat de la variable.
resultat | Entrée | Entier / Réel | résultat numérique de la variable

Voir aussi :
PRINT

Exemple :

INPUT "Valeur ?" a
PRINT "résultat :" " a=" a " et voilà !"
...........................................


Entrées_Sorties / PRINT

PRINT

Description :

Cette fonction permet d'afficher un résultat éventuellement précédé d'un texte explicatif.
On peut afficher que du texte, un résultat ou les deux à la fois.

Syntaxe :

PRINT [texte] [resultat] [[texte] [resultat] ... ]

Variables :

Paramètres | Entrées / Sorties | Type | Description
texte | Entrée | Chaîne de caractères | Texte affiché
resultat | Entrée | Entier / Réel | resultat numérique à afficher

Voir aussi :
INPUT

Exemple :

a=2
PRINT "résultat :" " a=" a " et voilà !"
...........................................


SETDISPLAY_FLOAT

Description :

Cette fonction permet dans un script de fixer le nombre de chiffres significatifs pour les nombres réels. Les chiffres significatifs sont tous les chiffres qui apparaissent lorsque l'on note un nombre en notation scientifique du type X,XXX.10X, pourvu que le premier chiffre ici ne soit pas 0 (les autres peuvent l'être !). Dans l'exemple précédent on note qu'il y a 4 chiffres significatifs.
En réalité, par défaut, PRiSM travaille avec un grand nombre de chiffres significatifs. Cependant, lors de l'utilisation de la fonction "PRINT", seulement quelques chiffres significatifs apparaissent (8 par défaut). Grâce à cette fonction, l'utilisateur controle ce nombre.

Syntaxe :

SETDISPLAY_FLOAT Digits

Variables :

Paramètre | Entrées / Sorties | Type | Description
Digits | Entrée | Entier | Nombre de chiffres significatifs.

Exemple :

SETDISPLAY_FLOAT 15
GETJULIANDAY Img dy
PRINT "Datation milieu de la pose à 15 chiffres significatifs = " dy

Télécharger l'exemple


SETDISPLAY_FRAC

Description :

Cette fonction permet chiffres après la virgulepour les nombres réels. Les nombres entiers seront fournis avec des "0" correspondant au nombre de chiffres après la virgule choisi.
En réalité, par défaut, PRiSM travaille avec un grand nombre de chiffres significatifs. Cependant, lors de l'utilisation de la fonction "PRINT", seulement quelques chiffres significatifs apparaissent (8 par défaut). Grâce à cette fonction, l'utilisateur controle le nombre de chiffres après la virgule.

Syntaxe :

SETDISPLAY_FRAC Digits

Variables :

Paramètre | Entrées / Sorties | Type | Description
Digits | Entrée | Entier | Nombre de chiffres après la virgule.

Exemple :

SETDISPLAY_FRAC 3
GETJULIANDAY Img dy
PRINT "Datation milieu de la pose à 3 chiffres après la virgule = " dy

Télécharger l'exemple


Entrées_Sorties / AddDlgBox

AddDlgBox

Description :

Cette fonction permet d'ajouter des paramètres dans une boite de dialogue.
Il faut s'assurer auparavant que la mémoire des boites de dialogue est bien vide et utiliser la fonction ResetDlgBox.
L'utilisation et le nombre de variables dépend du type de champ.
Voici les syntaxes possibles :

  • typeChamps réel : ADDDLGBOX 1 BorneMax BorneMin Label$ ValeurInitiale.
  • typeChamps entier : ADDDLGBOX 2 BorneMax BorneMin Label$ ValeurInitiale
  • typeChamps bouton déroulant : ADDDLGBOX 3 BorneMax BorneMin Label$ ValeurInitiale
  • typeChamps chaîne de caractère : ADDDLGBOX 4 Label$ ValeurInitiale$
  • typeChamps booléen : ADDDLGBOX 5 Label$ ValeurInitiale avec ValeurInitiale = 1 si TRUE et 0 si FALSE
  • typeChamps répertoire : ADDDLGBOX 6 Label$ RépertoireInitial$
  • typeChamps liste de fichiers : ADDDLGBOX 7 Label$..

Syntaxe :

ADDDLGBOX typeChamps [BorneMax] [BorneMin] Label ValeurInitiale

Variables :

Paramètres | Entrées / Sorties | type | Description
typeChamps | Entrée | Entier | Nombre indiquant le type de champ choisi ( de 1 à 7 )
BorneMax | Entrée | Entier / Réel | Borne maximum imposée pour certains types de champs
BorneMin | Entrée | Entier / Réel | Borne minimum imposée pour certains types de champs
Label | Entrée | Chaîne | Nom précédent le type de champ
ValeurInitiale | Entrée | Tous types | Valeur intiale du champ

Voir aussi :

ResetDlgBox

Exemple :

// BUT DU PGM : Utiliser les boîtes de dialogue avec PRiSM

resetdlgbox

REM initialisation des paramètres
adddlgbox 1 10 0 "Real format (1)" 4.5
adddlgbox 2 10 0 "Integer format (2)" 6
adddlgbox 3 10 0 "spin edit format (3)" 6
adddlgbox 4 "String format (4)" "chaine"
adddlgbox 5 "boolean format (5)" 0
adddlgbox 6 "directory (6)" "C:\"
adddlgbox 7 "list of files (7)"
...........................................

Télécharger l'exemple


Entrées_Sorties / DispDlgBox

DispDlgBox

Description :

Cette fonction permet d'afficher une boite de dialogue en fonction des champs définis grâce à la fonction AddDlgBox.
La variable "result" permet au programme de savoir si la boite s'est correctement affichée.

Syntaxe :

DISPDLGBOX result

Variables :

Paramètres | Entrées / Sorties | Type | Description
result | Sortie | Booléen (Entier) | Réussite de l'affichage

Voir aussi :
AddDlgBox
ResetDlgBox

Exemple :

// BUT DU PGM : Utiliser les boîtes de dialogue avec PRiSM

resetdlgbox

REM initialisation des paramètres
adddlgbox 1 10 0 "Real format (1)" 4.5
adddlgbox 2 10 0 "Integer format (2)" 6
adddlgbox 3 10 0 "spin edit format (3)" 6
adddlgbox 4 "String format (4)" "chaine"
adddlgbox 5 "boolean format (5)" 0
adddlgbox 6 "directory (6)" "C:\"
adddlgbox 7 "list of files (7)"

REM La boîte de dialogue apparaît à l'écran
dispdlgbox result
...........................................

Télécharger l'exemple


Entrées_Sorties / GetDlgBox

GetDlgBox

Description :

Cette fonction permet de lire la valeur d'un paramètre " type de champ " d'une boite de dialogue.
TOUS les paramètres doivent être lus dans l'ordre d'inscription dans la boite de dialogue. La boite de dialogue doit aussi être affichée précédemment avec "DISPDLGBOX".

Les divers "Valeur" possible sont suivant les types de champ :

  • type réel : GETDLGBOX Valeur
  • type entier : GETDLGBOX Valeur
  • type chaîne de caractère : GETDLGBOX Valeur$
  • type boolean : GETDLGBOX Valeur ( = 1 si TRUE et 0 si FALSE )
  • type répertoire : GETDLGBOX Valeur$
  • type liste de fichiers : GETDLGBOX ListeFile$ NbFile ( ListeFile$ = Liste des fichiers (type tableau de chaine) ; NbFile = Nombre de fichiers ).

Syntaxe :

GETDLGBOX Valeur

Variables :

Paramètres | Entrées / Sorties | Type | Description
Valeur | Sortie | Divers | Dépend du paramètre à récupérer : voir Description de la fonction

Voir aussi :
DispDlgBox

Exemple :

.....................................
adddlgbox 1 10 0 "Real format (1)" 4.5
adddlgbox 2 10 0 "Integer format (2)" 6
...............................................
........
................................................
REM La boîte de dialogue apparaît à l'écran
dispdlgbox result
...........................................
.........
..............................................
getdlgbox reel
getdlgbox entier
............................................
.....
.............................................
print "Resultats dans la boîte de dialogue : "
print "Réel :" Reel
print "Entier :" Entier
............................................

Télécharger l'exemple


Entrées_Sorties / ResetDlgBox

ResetDlgBox

Description :

Cette fonction permet d'éliminer tous les paramètres "type de champs" d'une boite de dialogue.
Elle doit être appelée avant toute construction d'une nouvelle boite de dialogue

Syntaxe :

RESETDLGBOX

Voir aussi :
AddDlgBox

Exemple :

................................
// BUT DU PGM : Utiliser les boîtes de dialogue avec PRiSM

resetdlgbox

REM initialisation des paramètres
adddlgbox 1 10 0 "Real format (1)" 4.5
...........................................

Télécharger l'exemple


Entrées_Sorties / GetFileName

GetFileName

Description :

Cette fonction ouvre une boite de dialogue de type WINDOWS d'ouverture de fichiers en *.*
Il suffit alors de "double-cliquer" sur le fichier sélectionné.
Par la suite, seul le chemin complet + nom du fichier sera retenu dans la variable "chemin$".
Si la fonction est annulé, chemin$ est une variable vide.

Syntaxe :

GETFILENAME chemin$

Variables :

Paramètres | Entrées / Sorties | Type | Description
chemin$ | Sortie | Chaîne de caractères | chemin complet + nom du fichier

Voir aussi :
GetListFileName

Exemple :

GetFileName path$

PRINT path$
...........................................

Télécharger l'exemple


Entrées_Sorties / GetListFileName

GetListFileName

Description :

Cette fonction ouvre une boite de dialogue de type WINDOWS d'ouverture de fichiers en *.*
Il suffit alors de sélectionner l'ensemble de fichiers retenus.
Par la suite, seuls les chemins complets + nom des fichiers seront retenus dans la variable tableau "chemin$".
Si la fonction est annulée, NbImage=0 et chemin$ est une variable vide.
L'indexation des tableaux commence à 1 (un).

Syntaxe :

GETLISTFILENAME chemin$ NbFichier

Variables :

Paramètres | Entrées / Sorties | Type | Description
chemin$ | Sortie | TABLEAU de Chaînes de caractères | chemin complet + nom des fichiers
NbFichier | Sortie | Entier | Nombre de fichiers sélectionnés

Voir aussi :
GetFileName

Exemple :

GetListFileName chemin$ Nb

For i=1 To Nb
   PRINT chemin[i]$
Next i
...........................................

Télécharger l'exemple


Entrées_Sorties / GetListFileNameEx

GetListFileNameEx

Description :

Cette fonction ouvre une boite de dialogue d'ouverture de fichiers de type WINDOWS, non pas en *.*, mais en fonction du filtre d'extension demandé.
Il est possible de donner un nom à la boite de dialogue, de définir le chemin de départ de la sélection et l'extension des fichiers retenus.
Une fois la boite de dialogue affichée, il suffit alors de sélectionner l'ensemble de fichiers retenus.
Par la suite, seuls les chemins complets + nom des fichiers seront retenus dans la variable tableau "chemin$".
Si la fonction est annulée, NbImage=0 et chemin$ est une variable vide.

Syntaxe :

GETLISTFILENAMEEX titre$ filtre$ dir_ini$ chemin$ NbFichier

Variables :

Paramètres | Entrées / Sorties | Type | Description
titre$ | Entrée | Chaîne de caractères | Titre de la boite de dialogue
filtre$ | Entrée | Chaîne de caractères | filtre du type "YYYYYYY|*.XXX" sélectionnant l'extension des fichiers affichés. "YYYYYY" représente le nom donné au type de fichiers. "XXX" est le nom de famille WINDOWS des fichiers sélectionnés.
dir_ini$ | Entrée | Chaîne de caractères | Chemin complet du répertoire d'ouverture de la boite de dialogue
chemin$ | Sortie | TABLEAU de Chaînes de caractères | chemin complet + nom des fichiers
NbFichier | Sortie | Entier | Nombre de fichiers sélectionnés

Voir aussi :
GetListFileName
GetFileName

Exemple :

titre$="Ouvrir des fichiers au formlat FIT"
filtre$="FIT|*.fits"
dir_ini$="F:\Nuit_2005_09_21\"

GetListFileNameEx titre$ filtre$ dir_ini$ FileList$ NbImage
...........................................

Télécharger l'exemple


Entrées_Sorties / GetRepName

GetRepName

Description :

Cette fonction ouvre une boite de dialogue qui monte l'arborescence des répertoires pour sélectionner un nouveau répertoire.
Par la suite, le chemin complet du répertoire sera retenu dans la variable tableau "chemin$".
Si la fonction est annulée, chemin$ sera une variable vide.

Syntaxe :

GETREPNAME chemin$

Variables :

Paramètres | Entrées / Sorties | Type | Description
chemin$ | Sortie | Chaîne de caractères | chemin complet du répertoire retenu

Voir aussi :
GetFileName

Exemple :

GETREPNAME chem$

PRINT chem$
...........................................

Télécharger l'exemple


Caméra / Delay

Delay

Description :

Cette fonction permet de faire une pause déterminée dans les script ACQ d'acquisition ( à ne pas confondre avec la fonction PAUSE dans les fonctions classiques qui demande une intervention de l'utilisateur ). Le paramètre "duree" permet de déterminer le temps d'interruption des fonctions d'acquisition en millisecondes.

Syntaxe :

DELAY duree

Variables :

Paramètres | Entrées / Sorties | Type | Description
duree | Entrée | Entier | Durée de la pause en millisecondes

Voir aussi :
WaitForEndDelay

Exemple :

..................................
REM Délai entre fin de pointage et observation
DelayBeforeExposure=2000
....................................
....................................
DELAY DelayBeforeExposure
Print "Applying delay..."
.....................................

Télécharger l'exemple


Entrées - Sorties / PAUSE

PAUSE

Description :

Cette fonction permet de faire une pause dans un PGM.
Cette dernière peut servir à lancer le déboggueur ... ou à faire tout simplement une PAUSE !!
Le PGM continue en frappant la barre d'espace.

Syntaxe :

PAUSE

Voir aussi :
END
EXIT


Caméra / WaitForEndDelay

WaitForEndDelay

Description :

Cette fonction permet d'attendre la fin de la commande "DELAY" avant de relancer une nouvelle procédure de commande de la caméra CCD. Le principe est le même que la commande "WaitForEndExposure" ... ainsi, il est possible de traiter des images avant la fin de la pause mais il est impossible de controler la caméra durant ce laps de temps !

Syntaxe :

WAITFORENDDELAY

Voir aussi :
Delay

WaitForEndExposure

Exemple :

..................................
REM Délai entre fin de pointage et observation
DelayBeforeExposure 2000
....................................
....................................
Delay DelayBeforeExposure
Print "Applying delay..."
WaitForEndDelay
.....................................

Télécharger l'exemple


Entrées - Sorties / END

END

Description :

Cette fonction permet de stopper un PGM.
Cette dernière peut notamment servir à éviter un plantage de l'ordinateur en cas de mauvaise saisie de paramètres d'entrées.

Syntaxe :

END

Voir aussi :
PAUSE
EXIT


Entrées - Sorties / EXIT

EXIT

Description :

Cette fonction permet de stopper un PGM.
Cette dernière peut notamment servir à éviter un plantage de l'ordinateur en cas de mauvaise saisie de paramètres d'entrées.

Syntaxe :

EXIT

Voir aussi :
PAUSE
END


Analyse / GetMemStat

GetMemStat

Description :

Cette fonction permet de connaître la quantité de mémoire (en octet) allouée par le système à PRiSM.

Syntaxe :

GETMEMSTAT Mem

Variables :

Paramètres | Entrées / Sorties | Type | Description
Mem | Sortie | Entier | Mémoire système allouée à PRiSM

Exemple :

GETMEMSTAT TotalAllocated

PRINT "Mémoire allouée pour PRiSM :"
PRINT TotalAllocated

Télécharger l'exemple


Commentaires

"REM" ---ou---- "//" ------ou---- "#"

Description :

Ces trois mots clés peuvent être employés indifféremment en début de ligne pour ne pas tenir compte du reste de la ligne. La principale utilité de ces mots clés est de pouvoir faire des commentaires dans un programme.

Syntaxe :

REM
//
#

Exemple :

REM Commentaire
// Commentaire
# Commentaire


Chaînes / Cut

Cut

Description :

Cette fonction permet de récupérer le Nième mot Word$ dans la chaîne de caractère Line$ avec des espaces comme séparateur. L’indexation commence à 1.

Syntaxe :

CUT Line$ Word$ N

Variables :

Paramètres | Entrées / Sorties | Type | Description
Line$ | Entrée | Chaîne de caractère | Chaîne de caractère à examiner
Word$ | Sortie | Chaîne de caractère | Nième mot dnas la chaîne de caractère Line$
N | Entrée | Entier | Rang du mot à récupérer

Exemple :

Line$="Vous utilisez le langage SCRIPT de PRiSM"
CUT Line$ Word$ 4
PRINT "Le 4ième mot de la chaîne est : " Word$

Télécharger l'exemple


Chaînes / CutStr

CutStr

Description :

Cette fonction permet de récupérer le Posième mot res$ dans la chaîne de caractère Line$ avec comme séparateur sep$. L’indexation commence à 1.

Syntaxe :

CUTSTR Line$ sep$ Pos res$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Line$ | Entrée | Chaîne de caractère | Chaîne de caractère à examiner
sep$ | Entrée | Chaîne de caractère | Séparateur utilisé entre les mots
Pos | Entrée | Entier | Rang du mot à récupérer
word$ | Sortie | Chaîne de caractère | Mot récupéré

Exemple :

Line$="Vous utilisez le langage SCRIPT de PRiSM"
CUTSTR Line$ " " 4 Word$
PRINT "Le 4ième mot de la chaîne est : " Word$

Télécharger l'exemple


Chaînes / NbMot

NbMot

Description :

Cette fonction permet de connaître le nombre de mots ( dans la variable Nbre ) contenu dans la chaîne Line$.

Syntaxe :

NBMOT Line$ Nbre

Variables :

Paramètres | Entrées / Sorties | Type | Description
Line$ | Entrée | Chaîne de caractère | Chaîne de caractère à examiner
Nbre | Sortie | Entier | Nombre de mots dans la chaîne de caractères

Exemple :

Line$="Vous utilisez le langage SCRIPT de PRiSM"
NBMOT Line$ Nbre
PRINT "Il y a " Nbre " mots dans la phrase Line$"

Télécharger l'exemple


Chaînes / PosStr

PosStr

Description :

Cette fonction permet de positionner le mot Word$ dans la chaîne de caractère Line$ à la position Pos. L’indexation commence à 1.

Syntaxe :

POSSTR Line$ Word$ Pos

Variables :

Paramètres | Entrées / Sorties | Type | Description
Line$ | Entrée | Chaîne de caractères | Chaîne de caractère à examiner
Word$ | Entrée | Chaîne de caractères | Position du mot à identifier
Pos | Sortie | Entier | Rang du mot à identifier

Exemple :

Line$="Vous utilisez le langage SCRIPT de PRiSM"
Word$="langage"
POSSTR Line$ Word$ Pos
PRINT "Le mot " Word$ " est à la " Pos "ième position !"

Télécharger l'exemple


Chaînes / SubString

CutStr

Description :

Cette fonction permet de récupérer une partie de la chaîne de caractère

Syntaxe :

SUBSTRING In$ Deb Fin Out$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Line$ | Entrée | Chaîne de caractère | Chaîne de caractère à couper
Deb | Entrée | Entier | Numéro caractère de début de découpe
Fin | Entrée | Entier | Numéro caractère de fin de découpe
Out$ | Sortie | Chaîne de caractère | Mot coupé

Exemple :

Line$="Bonjour"
CUTSTR Line$ 1 4 Word$
PRINT "Le mot découpé est : " Word$

Télécharger l'exemple


Fichiers / ChangeFileExt

ChangeFileExt

Description :

Cette fonction permet de changer l'extension (nom de famille) d'un fichier à l'intérieur d'une chaîne de caractère contenant le chemin d'accès global du fichier.
La fonction prend le nom de fichier transmis par chem$ et modifie l'extension du fichier par celle transmise par ext$. Extension spécifie la nouvelle extension, y compris le caractère point initial.
ChangeFileExt crée simplement une chaîne contenant le nouveau nom du fichier dans result$.

Syntaxe :

CHANGEFILEEXT chem$ ext$ result$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Chem$ | Entrée | Chaîne de caractères | Chemin complet pour accéder à un fichier
ext$ | Entrée | Chaîne de caractères | Nouvelle extension du fichier y compris le point "." du début
result$ | Sortie | Chaîne de caractères | Chemin complet pour accéder au fichier avec sa nouvelle extension

Exemple :

varin$="C:\Temp\essai.txt"
ext$=".cpa"

ChangeFileExt varin$ ext$ result$

PRINT "Nouveau chemin du fichier : " result$

Télécharger l'exemple


Fichiers / CreateDir

CreateDir

Description :

Cette fonction permet de créer un répertoire en fournissant son chemin complet.
Si le répertoire existe déjà, le précédent ne sera pas écrasé et son contenu sera gardé.
A la fin du nom du nouveau répertoire, le paramètre "\" peut être omis.

Syntaxe :

CREATEDIR dir$

Variables :

Paramètres | Entrées / Sorties | Type | Description
dir$ | Entrée | Chaîne de caractères | Chemin complet pour créer le répertoire

Exemple :

dir$="C:\Temp2\"
CreateDir dir$

Télécharger l'exemple


Fichiers / ExtractFileName

ExtractFileName

Description :

Cette fonction permet de déterminer uniquement le nom du fichier ( et son nom de famille ) dans une chaîne de caractère contenant le chemin complet pour accéder à un fichier.
La chaîne renvoyée est composée des caractères de droite de chem$, en commençant par le premier caractère après les deux points ou la barre oblique inverse séparant le chemin du nom et de l'extension. La chaîne renvoyée est égale à chem$ si chem$ ne contient pas de lecteur et de répertoire.

Syntaxe :

EXTRACTFILENAME chem$ fichier$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Chem$ | Entrée | Chaîne de caractères | Chemin complet pour accéder à un fichier
Fichier$ | Sortie | Chaîne de caractères | Nom du fichier suivi de son nom de famille

Voir aussi :
ExtractFilePath

Exemple :

varin$="C:\Temp\essai.txt"

ExtractFileName Varin$ varout$

PRINT "Nom du fichier : " varout$

Télécharger l'exemple


Fichiers / ExtractFilePath

ExtractFilePath

Description :

Cette fonction permet de déterminer le répertoire dans lequel est contenu un fichier à partir d'une chaîne de caractère contenant le chemin complet pour accéder à un fichier.
La chaîne renvoyée est composée des caractères de gauche de chem$, jusqu'aux deux points ou la barre oblique inverse qui séparent le chemin du nom et de l'extension. La chaîne renvoyée est vide si chem$ ne contient pas de partie lecteur et répertoire.

Syntaxe :

EXTRACTFILEPATH chem$ rep$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Chem$ | Entrée | Chaîne de caractères | Chemin complet pour accéder à un fichier
rep$ | Sortie | Chaîne de caractères | Répertoire dans lequel est contenu le fichier

Voir aussi :
ExtractFileName

Exemple :

varin$="C:\Temp\essai.txt"

ExtractFilePath Varin$ varout$

PRINT "Chemin du répertoire : " varout$

Télécharger l'exemple


Mathématiques / ABS

ABS

Cette fonction mathématique permet d'obtenir la "valeur absolue" d'un nombre !

Syntaxe :

ABS In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Entier / Réel | Valeur reçue
Out | Sortie | Entier / Réel | Valeur retournée

Exemple :

INPUT "Entrer un nombre négatif :" Nbre_Neg
ABS Nbre_Neg Nbre_Pos
PRINT "Le nombre positif est :" Nbre_Pos

Télécharger l'exemple


Mathématiques / ATN

ATN

Description :

Cette fonction mathématique est la fonction trigonométrique inverse de TAN pour un nombre.
Attention, le paramètre de sortie OUT est en degrés.

Syntaxe :

ATN In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Entier / Réel | Valeur reçue
Out | Sortie | Entier / Réel | Valeur retournée

Voir aussi :

TAN

Exemple :

PRINT "Calculer ArcTan(1.00) :"
ATN 1.00 a
PRINT a

Télécharger l'exemple


Mathématiques / COS

COS

Description :

Cette fonction mathématique permet d'obtenir le cosinus d'un angle en radian.

Syntaxe :

COS In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Réel | Angle en radian
Out | Sortie | Réel | Cosinus de l'angle

Exemple :

Print "Calcul de Cos(Pi/3) :"
COS Pi/3 a
print a

Télécharger l'exemple


Mathématiques / DECR

DECR

Description :

Cette fonction permet de décrémenter un nombre (entier ou réel) de 1 unité. Cette opération est équivalente à soustraire 1 d'un nombre.
on prendra soin à sauvegarder le nombre avant car l'opération se fera sur le nombre lui-même et donc en changera sa valeur afin d'y loger le résultat.

Syntaxe :

DECR Nbre

Variables :

Paramètres | Entrées / Sorties | Type | Description
Nbre | Entrée / Sortie | Réel / Réel | Nombre qui est décrémenté

Exemple :

PRINT "Décrément du nombre 3,1 :"

a = 3.1

DECR a
PRINT a

Télécharger l'exemple


Mathématiques / EXP

EXP

Description :

Cette fonction mathématique permet d'obtenir l'exponentielle d'un nombre

Syntaxe :

EXP In Out

Variables :

Paramètre |  | Entrées / Sorties | type | Description
In | Entrée | Réel | Nombre
Out | Sortie | Réel | Exponentielle du nombre

Exemple :

Print "Calcul de Exp(3) :"
EXP 3 a
print a

Télécharger l'exemple


Mathématiques / FRAC

FRAC

Description :

Cette fonction mathématique permet d'obtenir la partie fractionnaire d'un nombre réel. Le résultat est renvoyé sous la forme d'un nombre compris entre 0 et 1.

Syntaxe :

FRAC In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Réel | Nombre
Out | Sortie | Réel | Partie fractionnaire du nombre

Exemple :

Print "Calcul de la partie fractionaire du nombre Pi :"
FRAC PI a
print a

Télécharger l'exemple


Mathématiques / INCR

INCR

Description :

Cette fonction permet d'incrémenter un nombre (entier ou réel) de 1 unité. Cette opération est équivalente à additionner 1 à un nombre.
on prendra soin à sauvegarder le nombre avant car l'opération se fera sur le nombre lui-même et donc en changera sa valeur afin d'y loger le résultat.

Syntaxe :

INCR Nbre

Variables :

Paramètre | Entrées / Sorties | Type | Description
Nbre | Entrée / Sortie | Réel / Réel | Nombre qui est incrémenté

Exemple :

PRINT "Incrément du nombre 3 :"

a = 3

INCR a
PRINT a

Télécharger l'exemple


Mathématiques / INT

INT

Description :

Cette fonction mathématique permet d'obtenir la partie entière d'un nombre réel

Syntaxe :

INT In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Réel | Nombre
Out | Sortie | Entier | Partie entière du nombre

Exemple :

Print "Calcul de la partie entière du nombre Pi :"
INT PI a
print a

Télécharger l'exemple


Mathématiques / LOG

LOG

Description :

Cette fonction mathématique permet d'obtenir le logarithme népérien d'un nombre. (Attention : ce n'est pas le logarithme décimal !)

Syntaxe :

LOG In Out

Variables :

Paramètre | Entrées / Sorties | Type | Description
In | Entrée | Réel | Nombre
Out | Sortie | Réel | Logarithme du nombre

Exemple :

Print "Calcul de LOG(10) :"
LOG 10 a
print a

Télécharger l'exemple


Mathématiques / MOD

MOD

Description :

Cette fonction mathématique permet d'obtenir le résultat entier de la division d'un nombre par un autre.
Cette fonction est communément appelée "modulo".

Syntaxe :

MOD In Out-Result

Variables :

Paramètre |  | Entrées / Sorties | type | Description
In | Entrée | Réel | Nombre à diviser
Out-Result | Entrée / Sortie | Réel / Entier | Nombre diviseur PUIS résultat du calcul

Exemple :

PRINT "Calcul de 2Pi modulo Pi :"

a = 2*Pi
b = Pi

MOD a b
PRINT b

Télécharger l'exemple


Mathématiques / SQR

SQR

Description :

Cette fonction mathématique permet d'obtenir la racine carrée d'un nombre

Syntaxe :

SQR In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Réel | Nombre
Out | Sortie | Réel | racine carrée du nombre

Exemple :

Print "Calcul de Racine carrée de 100 :"
SQR 100 a
print a

Télécharger l'exemple


Mathématiques / POWER

POWER

Description :

Cette fonction mathématique permet d'obtenir la puissance d'un nombre.

Syntaxe :

POWER In Out-Result

Variables :

Paramètre | Entrées / Sorties | Type | Description
In | Entrée | Réel | Nombre
Out-Result | Entrée / Sortie | Réel / Réel | Puissance du nombre PUIS résultat du calcul

Exemple :

PRINT "Calcul de 2,1^2,1 :"

a = 2.1
b = 2.1

POWER a b
PRINT b

Télécharger l'exemple


Mathématiques / ROUND

ROUND

Description :

Cette fonction mathématique permet d'obtenir le nombre entier le plus proche d'un nombre réel.

Syntaxe :

ROUND In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Réel | Nombre
Out | Sortie | Entier | Nombre entier le plus proche du nombre

Exemple :

Print "Calcul du nombre entier le plus proche de 3,55 :"
ROUND 3.55 a
print a

Télécharger l'exemple


Mathématiques / RANDOM

RANDOM

Description :

Cette fonction mathématique permet de générer un ensemble de nombres aléatoires compris entre 0 et 1.

Syntaxe :

RANDOM Valeur

Variables :

Paramètre | Entrées / Sorties | Type | Description
Valeur | Sortie | Réel | Nombre aléatoire

Exemple :

FOR i=1 10
   RANDOM Valeur
   PRINT Valeur
NEXT i

Télécharger l'exemple


Mathématiques / RANDOMG

RANDOMG

Description :

Cette fonction mathématique permet de générer un ensemble de nombres aléatoires, même négatifs.

Syntaxe :

RANDOMG Valeur

Variables :

Paramètre | Entrées / Sorties | Type | Description
Valeur | Sortie | Réel | Nombre aléatoire

Exemple :

FOR i=1 10
   RANDOMG Valeur
   PRINT Valeur
NEXT i

Télécharger l'exemple


Mathématiques / SIN

SIN

Description :

Cette fonction mathématique permet d'obtenir le sinus d'un angle en radian.

Syntaxe :

SIN In Out

Variables :

Paramètres | Entrées / Sorties | Type | Description
In | Entrée | Réel | Angle en radian
Out | Sortie | Réel | Sinus de l'angle

Exemple :

Print "Calcul de Sin(Pi/3) :"
sin Pi/3 a
print a
Télécharger l'exemple


Mathématiques / TAN

TAN

Description :

Cette fonction mathématique permet d'obtenir la tangente d'un angle en radian.

Syntaxe :

TAN In Out

Variables :

Paramètres | sEntrées / Sortiess | Type | Description
In | Entrée | Réel | Angle en radian
Out | Sortie | Réel | Tangente de l'angle

Exemple :

Print "Calcul de Tan(Pi/4) :"
TAN Pi/4 a
print a

Télécharger l'exemple


Prétraitements / AverageStack

AverageStack

Description :

Cette fonction permet de faire une pile moyenne sur une série d'image.
Attention : La variable "ImgTable" est à intialiser avant utilisation : c'est une variable d'entrée !

Syntaxe :

AverageStack ImgTable IndexDeb IndexFin ImgOut

Variables :

Paramètres | Entrées / Sorties | Type | Description
ImgTable | Entrée | Tableau d'images | Liste des chemins complets menant aux images
IndexDeb | Entrée | Entier | Index dans le tableau de la première image à traiter
IndexFin | Entrée | Entier | Index dans le tableau de la dernière image à traiter
ImgOut | Sortie | Image | Image correspondant à la pile moyenne

Voir aussi :

MedianStack

Exemple :

A$="C:\prism\Images de test\Pretrait\"

Nom$=A$+"vdb37-1.cpa"
open img[1] Nom$

Nom$=A$+"vdb37-2.cpa"
open img[2] Nom$

Nom$=A$+"vdb37-3.cpa"
open img[3] Nom$

Nom$=A$+"vdb37-4.cpa"
open img[4] Nom$

IndexDeb=1
IndexFin=4
AVERAGESTACK Img IndexDeb IndexFin ImgOut

// Le Résultat est dans ImgOut
for i=1 4
  close img[i]
next i

Télécharger l'exemple


Prétraitements / MedianStack

MedianStack

Description :

Cette fonction permet de faire une pile médiane sur une série d'image.

Syntaxe :

MedianStack ImgTable IndexDeb IndexFin ImgOut

Variables :

Paramètres | Entrées / Sorties | Type | Description
ImgTable | Entrée | Tableau d'images | Liste des chemins complets menant aux images
IndexDeb | Entrée | Entier | Index dans le tableau de la première image à traiter
IndexFin | Entrée | Entier | Index dans le tableau de la dernière image à traiter
ImgOut | Sortie | Image | Image correspondant à la pile moyenne

Voir aussi :
AverageStack

Exemple :

IndexDeb=1
IndexFin=4

MedianStack Img IndexDeb IndexFin ImgOut

// Le Résultat est dans ImgOut
for i=1 4
  close img[i]
next i

Télécharger l'exemple


Prétraitements / SameAverage

SameAverage

Description :

Cette fonction permet de réaliser une fonction "moyenne identique" sur une série d'images. Il faut indiquer une variable chaîne de caractères sous forme de tableau où sont contenus les chemins où atteindre les images. La même série d'images est créée dans le répertoire où sont les images de départ et il est rajouté un préfixe "SAVERAGE_" avant chaque nom d'images.

Syntaxe :

SameAverage Chemin$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Chemin$ | Entrée | Tableau de chaînes de caractères | Tableau des liste des chemins complets menant aux images

Exemple :

GETLISTFILENAME chemin$ Nb

// Réaliser une moyenne identique
SAMEAVERAGE chemin$

Télécharger l'exemple


Traitement / BoucherZone

BoucherZone

Description :

Cette fonction permet de boucher une zone de pixels, de dimension donnée, en fonction des pixels environnants. La taille de la zone utilisée pour les pixels environnants dépend du paramètre "Size".
Ceci permet notamment d'effacer un point chaud ou tout autre objet dérangeant dans une zone.

Syntaxe :

BOUCHERZONE Img X Y Size

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position horizontale du pixel représentant le centre de la zone à boucher.
Y | Entrée | Entier | Position verticale du pixel représentant le centre de la zone à boucher.
Size | Entrée | Entier | Demi-largeur de la fenêtre à boucher.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img

Input "Demi-Largeur de la fenêtre (1-20) : " DemiLarg

PRINT "Cliquer sur le pixel au centre de la fenêtre cosmétique"
GetPoint Img X Y

BOUCHERZONE Img X Y DemiLarg

Télécharger l'exemple


Traitement / CicatX

CicatX

Description :

Cette fonction permet de "cicatriser" une ligne, en fonction des pixels de la ligne supérieure et ceux de la ligne inférieure (moyenne des 2 pixels verticaux environnants).
Ceci permet notamment d'effacer une ligne défectueuse ou tout autre objet dérangeant sur une ligne.

Syntaxe :

CICATX Img X

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position horizontale d'un pixel de la ligne

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetPoint Img X Y

CICATX Img Y

Télécharger l'exemple


Traitement / CicatY

CicatY

Description :

Cette fonction permet de "cicatriser" une colonne, en fonction des 2 colonnes environnantes (moyenne du pixel de gauche et celui de droite sur la même ligne).
Ceci permet notamment d'effacer une ligne défectueuse ou tout autre objet dérangeant sur une ligne.

Syntaxe :

CICATY Img Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Y | Entrée | Entier | Position verticale d'un pixel de la ligne

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetPoint Img X Y

CICATY Img Y

Télécharger l'exemple


Traitement / CollapseLine

CollapseLine

Description :

Cette fonction permet de faire la moyenne ou la médiane sur une ligne ou une colonne. Tous les pixels de cette ligne ou colonne sont remplacés cette moyenne ou médiane.

Syntaxe :

COLLAPSELINE Img X1 Y1 X2 Y2 Med Horz

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X1 | Sortie | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Sortie | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Sortie | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Sortie | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre
Med | Entrée | Booléen | Permet de faire la médiane si le paramètre est à 1 (TRUE) et la moyenne si ce paramètre est à 0 (FALSE)
Horz | Entrée | Booléen | Permet de réaliser l'opération sur une ligne si le pramètre est à 1 (TRUE) et sur un colonne si ce paramètre est à 0 (FALSE)

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
PRINT "Fenêtre à sélectionner"
GETWINDOW Img X1 Y2 X2 Y1
COLLAPSELINE Img X1 Y1 X2 Y2 0 1

Télécharger l'exemple


Traitement / Exec_CosmeScript

Exec_CosmeScript

Description :

Cette fonction réalise des opérations cosmétiques automatiques sur une image à partir d'un ficher préalablement enregistré (éventuellement avec PRiSM)

Syntaxe :

EXEC_COSMESCRIPT Img FileScript$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
FileScript$ | Entrée | Chaîne de caractères | Chemin complet du fichier cosmétique

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

racine$="C:\partage\Temp\"

FileC$=racine$+"cosme.cos"
ImageT$=racine$+"Alemannia_62.cpa"

OPEN  ImgT ImageT$

EXEC_CosmeScript ImgT FileC$

PRINT "Prétraitement effectué !"

Télécharger l'exemple


Prétraitement / GetHotPixels

GetHotPixels

Description :

Cette fonction permet de déterminer l'ensemble des pixels au-dessus ou en-dessous d'un certain seuil au sens large ( "Threshold" en anglais ). Un fichier texte est créé et sur chaque ligne est sauvegardée les coordonnées d'un pixel suivi de son intensité.

Syntaxe :

GETHOTPIXELS Img Seuil HighLow Fichier_resultat$ Nbre

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image ouverte dans le programme PGM
Seuil | Entrée | Entier / Réel | Seuil limite
HighLow | Entrée | Booléen | Permet de seuiller haut ou bas ... =1 pour seuiller haut et =0 pour seuiller bas
Fichier_resultats$ | Entrée | Chaîne de caractères | Chemin complet du fichier de sortie
Nbre | Sortie | Entier | Nombre de pixels dont l'intensité est <= ou >= au seuil

Voir aussi :
ClipH
ClipL

Exemple :

................................
Threshold=140
HighLow=1
OutPutFile$="H:\PRiSM v5\Images de travail\PC_M27.txt"

GETHOTPIXELS Img Threshold HighLow OutPutFile$ Nbre
PRINT "Nombre de pixels chauds = " Nbre

Télécharger l'exemple


Prétraitement / GetBackGround

GetBackGround

Description :

Cette fonction permet d'obtenir la valeur moyenne du fond de ciel ainsi que le bruit moyen (sigma) d'une image.

Syntaxe :

GETBACKGROUND Img Background Sigma

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image à analyser
Background | Sortie | Réel | Fond de ciel
Sigma | Sortie | Réel | Bruit moyen

Exemple :

PRINT "Charger l'image :"
GetImage Img

GETBACKGROUND Img Background Sigma
PRINT "Fond de ciel = " Background
PRINT "Ecart type sigma = " Sigma

Télécharger l'exemple


Prétraitement / Deflat_Sky_Bkgnd

Deflat_Sky_Bkgnd

Description :

Cette fonction permet de retirer le fond de ciel considéré comme un polynome de degré fixé par l'utilisateur. Le nombre de points à choisir pour ajuster ce polynome est fixé et dédié aux pixels de plus bas niveau en intensité. Le fond de ciel est ensuite retiré.

Syntaxe :

DEFLAT_SKY_BKGND Img NbPoints Degre

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image à analyser
NbPoints | Entrée | Entier | Nombre de points de plus bas niveau pour ajuster le polynôme
Degre | Entrée | Entier | Degré du polynôme à ajuster

Exemple :

PRINT "Charger l'image :"
GetImage Img

INPUT "Nombre de points ?" NbPoints
INPUT "Degré du polynôme ?" Degre
DEFLAT_SKY_BKGND Img NbPoints Degre

Télécharger l'exemple


Prétraitement / PreProcess

PreProcess

Description :

Cette fonction prétraite une image en ayant connaissance des images de prétraitements.

Syntaxe :
PREPROCESS ImgIn ImgBias ImgNoir ImgFlat CoefMultNoir

Variables :

Paramètres | Entrées / Sorties | Type | Description
ImgIn | Entrée | Image | Nom interne de l'image à prétraiter ouverte dans le programme PGM
ImgBias | Entrée | Image | Nom interne de l'image d'offset ouverte dans le programme PGM
ImgNoir | Entrée | Image | Nom interne de l'image de noir ouverte dans le programme PGM
ImgFlat | Entrée | Image | Nom interne de l'image de flat ouverte dans le programme PGM
CoefMultNoir | Entrée | Réel | Coefficient multiplicatif à appliquer au noir. Cette grandeur peut être déterminée à partir de la fonction SUBDARKOPT

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img_xxx | oui / non | oui / oui / oui | oui / oui

Voir aussi :
SubDarkOpt

Exemple :

................................
OPEN  ImgN ImageN$
OPEN  ImgF ImageF$
OPEN  ImgO ImageO$
OPEN  ImgT ImageT$

...............................................

IF ErrorCode=0 THEN
  PREPROCESS ImgT ImgO ImgN ImgF CoefMultNoir
.............................................

Télécharger l'exemple


Prétraitement / SubDarkOpt

SubDarkOpt

Description :

Cette fonction permet de déterminer un noir optimisé pour une image.
Attention, il faut penser à soustraire l'offset à l'image avant d'appliquer une telle fonction et donc à additionner l'offset soustrait après application de la fonction.

Syntaxe :
SUBDARKOPT ImgT ImgN CoefMultNoir CoefMax CoefMin Bruit Iterations ErrorCode

Variables :

Paramètres | Entrées / Sorties | Type | Description
ImgT | Entrée | Image | Nom interne de l'image à prétraiter ouverte dans le programme PGM
ImgN | Entrée | Image | Nom interne de l'image de noir ouverte dans le programme PGM
CoefMultNoir | Sortie | Réel | Coefficient multiplicatif à appliquer au noir
CoefMax | Sortie | Réel | Coefficient multiplicatif maximum calculé (suivant les zones examinées)
CoefMin | Sortie | Réel | Coefficient multiplicatif minimum calculé (suivant les zones examinées)
Bruit | Sortie | Réel | Bruit du résultat (s'apparente à une variance sur les coefficients)
Iterations | Sortie | Entier | Nombre d'itérations pour le calcul
ErrorCode | Sortie | Entier | Erreur de traitement : =0 si pas d'erreur =0 si erreur sur calcul du fond de ciel =2 si trop d'étoiles dans l'image =3 si erreur de convergence de l'algorithme =4 si erreur de taille d'images.

Exemple :

................................
OPEN  ImgN ImageN$
OPEN  ImgF ImageF$
OPEN  ImgO ImageO$
OPEN  ImgT ImageT$

sub ImgT ImgO
Close ImgO

SUBDARKOPT ImgT ImgN CoefMultNoir CoefMax CoefMin Bruit Iterations ErrorCode
print "CoefMultNoir= " CoefMultNoir "   ErrorCode= " ErrorCode
.............................................

Télécharger l'exemple


Traitement / Noise

Noise

Description :

Cette fonction ajoute du bruit uniforme à toute l'image.

Syntaxe :

NOISE Img Variance

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Variance | Entrée | Entier | Variance du bruit uniforme

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

REM Rajouter du bruit
Variance=100
NOISE Img Variance

Télécharger l'exemple


Traitement / Noise

NoiseGauss

Description :

Cette fonction ajoute du bruit gauss à toute l'image avec une certaine variance.

Syntaxe :

NOISEGAUSS Img Variance

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Variance | Entrée | Entier | Variance du bruit gaussien

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

REM Rajouter du bruit
Variance=100
NOISEGAUSS Img Variance

Télécharger l'exemple


Traitement / Add

Add

Description :

Cette fonction permet d'additionner deux images.
Le résultat est copié dans la variable IMG1.

Syntaxe :

ADD Img1 Img2

Variables :

Paramètre | Entrées / Sorties | type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM qui doit être ajoutée avec l'image 2 "IMG2"
Img2 | Entrée | Image | Nom interne de l'image dans le programme PGM qui doit être ajoutée avec l'image 1 "IMG1"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Fonction correspondante :
Menu [Traitement] > [Addition]

Exemple :

...................................
GetImage Img2

ADD Img1 Img2
Close Img2

Télécharger l'exemple

Images de test :

Image de référence : Champ stellaire.
Image à additionner : Même champ stellaire où tous les pixels ont été multipliés par deux.


Traitement / Dilatation

Dilatation

Description :

Cette fonction applique un filtre dilatation (filtre statistique) sur l'image.
DemLarg correspond à la demi-largeur du filtre en pixels et doit être compris entre 1 et 10.
Motif correspond au motif du masque utilisé pour ce filtre érosion. Les motifs correspondant aux valeurs sont les suivantes :

  • 1 -> Carré
  • 2 -> Croix diagonale
  • 3 -> Croix horizontale
  • 4 -> Ligne
  • 5 -> Colonne
  • 6 -> Cercle

Syntaxe :

EROSION Img DemLarg Motif

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
DemLarg | Entrée | Entier | DemLarg correspond à la demi-largeur du filtre en pixels (compris entre 1 et 10)
Motif | Entrée | Entier | Type de filtre utilisé

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Motif choisi : " Motif
DILATATION Img DemiLarg Motif

Télécharger l'exemple


Traitement / Div

Div

Description :

Cette fonction permet de diviser deux images entre elles. Afin que les valeurs ne soient ensuite pas trop "écrasées", on multipliera le résultat par un coefficient de normalisation.
Pour remarque, ceci n'est pas identique à faire la division PUIS à multiplier par une constante. En effet, PRiSM garde en mémoire le résultat avant de le multiplier avec tous les chiffres significatifs, puis éventuellement de l'"écrêter" en 16 bits signés.
Le résultat est copié dans la variable IMG1.

Syntaxe :

DIV Img1 Img2 CoeffNorm

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM qui doit être divisée par l'image 2 "IMG2"
Img2 | Entrée | Image | Nom interne de l'image dans le programme PGM qui divise l'image 1 "IMG1"
CoeffNorm | Entrée | Entier / Réel | Coefficient de normalisation ( multiplicatif du résultat).

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img2

INPUT "Facteur de normalisation : " FactorNormalisation

DIV Img1 Img2 FactorNormalisation
Close Img2

Télécharger l'exemple


Traitement / Erosion

Erosion

Description :

Cette fonction applique un filtre érosion (filtre statistique) sur l'image.
DemLarg correspond à la demi-largeur du filtre en pixels et doit être compris entre 1 et 10.
Motif correspond au motif du masque utilisé pour ce filtre érosion. Les motifs correspondant aux valeurs sont les suivantes :

  • 1 -> Carré
  • 2 -> Croix diagonale
  • 3 -> Croix horizontale
  • 4 -> Ligne
  • 5 -> Colonne
  • 6 -> Cercle

Syntaxe :

EROSION Img DemLarg Motif

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
DemLarg | Entrée | Entier | DemLarg correspond à la demi-largeur du filtre en pixels (compris entre 1 et 10)
Motif | Entrée | Entier | Type de filtre utilisé

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Motif choisi : " Motif
EROSION Img DemiLarg Motif

Télécharger l'exemple


Traitement / Gauss

Gauss

Description :

Cette fonction applique un filtre de convolution avec un noyau gaussien.

Syntaxe :

GAUSS Img Sigma

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Sigma | Entrée | Réel | Paramètre de la gaussienne

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Sigma :" Sigma
GAUSS Img Sigma

Télécharger l'exemple


Traitement / Gradient

Gradient

Description :

Cette fonction applique un filtre gradient sur l'image.

Syntaxe :

GRADIENT Img Angle

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Angle | Entrée | Entier | Indique l'angle du gradient en degrés. Les valeurs possibles sont 0, 45, 90 ou 135.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Angle du filtre (0,45,90,135) : " Angle
GRADIENT Img Angle

Télécharger l'exemple


Traitement / HighPass

HighPass

Description :

Cette fonction applique un filtre passe-haut sur l'image.

Syntaxe :

HIGHPASS Img Intensite

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Intensite | Entrée | Entier | Nombre compris entre 1 et 4 marquant l'intensité du filtre passe-haut.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Puissance du filtre (1-4) :" Puiss
HIGHPASS Img Puiss

Télécharger l'exemple


Traitement / LogImg

LogImg

Description :

Cette fonction applique une fonction logarithme de l'image.

Syntaxe :

LOGIMG Img Offset

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Offset | Entrée | Entier / Réel | Valeur de soustraction des pixels avant d'appliquer la fonction logarithme.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
GetPoint Img x y
GetPixelValue Img x y Offset

LOGIMG Img Offset*0.70
...................................

Télécharger l'exemple


Traitement / LowPass

LowPass

Description :

Cette fonction applique un filtre passe bas sur l'image.

Syntaxe :

LOWPASS Img Intensite

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Intensite | Entrée | Entier | Nombre compris entre 1 et 4 marquant l'intensité du filtre passe-bas.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Puissance du filtre (1-4) :" Puiss
LOWPASS Img Puiss

Télécharger l'exemple


Traitement / Median

Median

Description :

Cette fonction applique un filtre médian (filtre statistique) sur l'image.
DemLarg correspond à la demi-largeur du filtre en pixels et doit être compris entre 1 et 10.
Motif correspond au motif du masque utilisé pour ce filtre médian. Les motifs correspondant aux valeurs sont les suivantes :

  • 1 -> Carré
  • 2 -> Croix diagonale
  • 3 -> Croix horizontale
  • 4 -> Ligne
  • 5 -> Colonne
  • 6 -> Cercle

Syntaxe :

MEDIAN Img DemLarg Motif

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
DemLarg | Entrée | Entier | DemLarg correspond à la demi-largeur du filtre en pixels (compris entre 1 et 10)
Motif | Entrée | Entier | Type de filtre utilisé

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

.............................................
Input "Motif choisi : " Motif
MEDIAN Img DemiLarg Motif

Télécharger l'exemple


Traitement / Mult

Mult

Description :

Cette fonction permet de multiplier tous les pixels d'une image par un même coefficient.
Le résultat est copié dans la variable IMG1.

Syntaxe :

MULT Img Coeff

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM qui doit être multipliée par un coefficient
Coeff | Entrée | Entier / Réel | Coefficient multiplicatif des pixels de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img

Input "Facteur de multiplication : " Factor

MULT Img Factor

Télécharger l'exemple


Traitement / MultIMG

MultIMG

Description :

Cette fonction permet de multiplier deux images entre elles. Afin que les valeurs ne soient ensuite pas trop "écartées", on multipliera le résultat par un coefficient de normalisation (souvent donc inférieur à 1).
Pour remarque, ceci n'est pas identique à faire la multiplication PUIS à multiplier par une constante inférieure à 1. En effet, PRiSM garde en mémoire le résultat avant de le multiplier avec tous les chiffres significatifs, puis éventuellement de l'"écrêter" en 16 bits signés.
Le résultat est copié dans la variable IMG1.

Syntaxe :

MULTIMG Img1 Img2 CoeffNorm

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM qui doit être multipliée par l'image 2 "IMG2"
Img2 | Entrée | Image | Nom interne de l'image dans le programme PGM qui doit être multipliée par l'image 1 "IMG1"
CoeffNorm | Entrée | Entier / Réel | Coefficient de normalisation ( multiplicatif du résultat).

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img2

INPUT "Facteur de normalisation : " FactorNormalisation

MULTIMG Img1 Img2 FactorNormalisation
Close Img2

Télécharger l'exemple


Traitement / Offset

Offset

Description :

Cette fonction permet d'additionner une valeur à tous les pixels d'une image.
Le résultat est dans la variable image "IMG".

Syntaxe :

OFFSET Img Offset

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM
Offset | Entrée | Entier / Réel | Offset appliqué à tous les pixels de l'image.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img

INPUT "Valeur de l'Offset ?" OST

OFFSET Img OST

Télécharger l'exemple


Traitement / Sub

Sub

Description :

Cette fonction permet de soustraire deux images.
Le résultat est copié dans la variable IMG1.

Syntaxe :

SUB Img1 Img2

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM qui doit être soustraite d'avec l'image 2 "IMG2"
Img2 | Entrée | Image | Nom interne de l'image dans le programme PGM qui doit être soustraite à l'image 1 "IMG1"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img2

SUB Img1 Img2
Close Img2

Télécharger l'exemple


Traitement / Create_Pupil

Create_Pupil

Description :

Cette fonction crée une pupille (ou un anneau) dans l'image, de rayon Rmax, de valeur Val, avec une obstruction centrale Rmin.
Sert à créer des pupilees de tests pour une analyse ultérieure.

Syntaxe :

CREATE_PUPIL IMG RMAX RMIN VAL

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
RMAX | Entrée | Entier | Rayon de la pupille
RMIN | Entrée | Entier | Taille de l'obstruction centrale
VAL | Entrée | Entier / Réel | Valeur en ADU de la pupille

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

NewImage Img "ESSAI" 512 512 2 216

Create_Pupil Img 16 10 300
................................................

Télécharger l'exemple


Traitement / InverseCadrans

InverseCadrans

Description :

Cette fonction inverse les 4 cadrans d'une image.

Syntaxe :

INVERSECADRANS Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img

INVERSECADRANS Img

Télécharger l'exemple


Traitement / Fill_Circ

Fill_Circ

Description :

Cette fonction remplit un cercle aux coordonnées X et Y avec la valeur "Value" (en ADU) et avec le bruit gaussien "noise".

Syntaxe :

FILL_CIRC Img X Y Noise Offset Rayon

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X | Entrée | Entier | Coordonnée horizontale du centre du cercle
Y | Entrée | Entier | Coordonnée verticale du centre du cercle
Noise | Entrée | Réel | Valeur en ADU du bruit gaussien
Offset | Entrée | Entier / Réel | Valeur Maximum en ADU de l'étoile
Rayon | Entrée | Entier | Rayon de l'étoile

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

REM Créer un cercle à la coordonnées X = 30 et Y = 30, de rayon 10, d'offset 1500 et de bruit 150
X=30
Y=30
Noise=1500
Offset=1500
Rayon=10
FILL_CIRC Img X Y Noise Offset Rayon

Télécharger l'exemple


Propriétés images / Width

Wavelet

Description :

Cette fonction ne garde que des détails plus ou moins importants suivant le plan d'ondelettes considéré.
Un détail fin sera considéré comme un détail de "haute fréquence" alors que quelque chose de flou sera considéré comme un détail de "basse fréquence". L'espace des ondelettes ressemblant à l'espace de Fourier, permet donc une analyse en fréquence. A ceci près qu'au lieu de fournir une image finale dans l'espace fréquentiel (comme dans l'espace de Fourier), on obtient un série de plans d'images où ne sont conservés pour chaque plan que des détails de taille différentes. Le plan n°1 ne garde que des détails très fin (inclus le bruit de l'image !) alors que les détails s'estompent au fur et à mesure que l'on se dirige vers de splans de numéro élevé. Pour de plus amples explications, on se reportera à la fonction [Traitements] -> [Ondelettes] (pas de lien pour le moment).

Syntaxe :

WAVELET Img TypeSpline NbPlans Image1 [Image2 [Image3 [...]]] ImageResidus

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
TypeSpline | Entrée | Booléen | Type de Spline à utiliser. 0 : Spline de degré 1. 1 : Spline de dégré 3.
Nbplans | Entrée | Entier (entre 1 et 10) | Nombre de plan d'ondelettes à créer.
Image_X | Sortie | Image | Nom de l'image résultante correspondant au plan n°X. Ces images s'afficheront dans PRiSM.
ImageResidus | Sortie | Image | Nom de l'image résultant de la soustraction de l'image de départ par tous les plans d'images affichés.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
Wavelet Img 1 4 Img1 Img2 Img3 Img4 ImgReste

Télécharger l'exemple


Traitement / FFT

FFT

Description :

Cette fonction permet de passer une image dans l'espace fréquentiel de Fourier.

Syntaxe :

FFT Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le script

Exemple :

..................................
FFT Img1
Autovisu Img1

Télécharger l'exemple


Traitement / FFTInverse

FFTInverse

Description :

Cette fonction permet de passer une image de l'espace fréquentiel de Fourier à l'espace temporel classique.

Syntaxe :

FFTINVERSE Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le script

Exemple :

..................................
MODULE Img2
FFTINVERSE Img2
Autovisu Img2

Télécharger l'exemple


Traitement / InterCor

InterCor

Description :

Cette fonction permet de faire le produit d'intercorrélation entre deux images dans l'espace de Fourier. Le résultat sera sauvé dans l'image n°1.

Syntaxe :

INTERCOR Img1 Img2

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image n°1 dans le script
Img2 | Entrée | Image | Nom interne de l'image n°2 dans le script

Exemple :

...........................................
INTERCOR IMG1 IMG2
FFTINVERSE Img1
Autovisu Img1

Télécharger l'exemple


Traitement / Module

Module

Description :

Cette fonction permet de montrer le module d'une image définie à partir de pixels en intensité complexe.

Syntaxe :

MODULE Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le script

Exemple :

....................................
MODULE Img2
FFTINVERSE Img2
Autovisu Img2

Télécharger l'exemple


Traitement / ImgProd

ImgProd

Description :

Cette fonction permet de multiplier deux images mais sa particularité par rapport à MultImg est de permettre deux coefficients de normalisation pour les images complexes : un pour la partie réelle et l'autre pour la partie imaginaire. C'est pourquoi elle est préférentiellement utilisée pour le traitement des images dans l'espace de Fourier.

Il est cependant possible d'utiliser une telle fonction pour des images non complexes et donc, le dernier coefficient de normalisation est optionnel.

L'image résultante est sauvée dans l'image n°1.

Syntaxe :

IMGPROD Img1 Img2 CoeffN_R [CoeffN_C]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image n°1 dans le script
Img2 | Entrée | Image | Nom interne de l'image n°2 dans le script
CoeffN_R | Entrée | Réel | Coefficient de normalisation de la partie réelle
CoeffN_C | Entrée | Réel | Coefficient de normalisation de la partie complexe (optionnel)

Exemple :

....................................
IMGPROD Img2 Img1 10 0.1
.........................................

Télécharger l'exemple


Analyse / EtalonAstrometrieAuto

EtalonAstrometrieAuto

Description :

Cette fonction permet de réaliser un étalonnage astrométrique automatique.

On peut utiliser les différents catalogues suivant : "GSC", "GSC-ACT", "USNO SA", "USNO A1", "USNO A2", "Hipparcos", "SAO", "BSC", "Tycho1", "Tycho2" et "UCAC1/2"( Attention : Les majuscules et minuscules doivent être respectées et vérifier que la vesion de PRiSM supporte le catalogue demandé).

Un paramètre supplémentaire doit être donné pour tous les catalogues non livrés avec PRiSM ( GSC-ACT et les catalogues à base USNO) : Le paramètre "DirCat$" est le chemin complet où PRiSM peut trouver le chemin d'un tel catalogue.Pour les autres catalogues, ce paramètre peut être donné avec une valeur nulle : "".

La valeur de la variable "VALID" est de 1 (TRUE) si la calibration a réussie et de 0 (FALSE) en cas d'échec.
Les paramètres d'étoiles de comparaison doivent être entre 20 et 190 ( voir la Description des variables ).
Attention : plus le paramètre de comparaison est important, plus le temps de calcul sera aussi important !.

Syntaxe :

ETALONASTROMETRIEAUTO Img Cat$ Focus SizePixX SizePixY Alpha Delta StarCompCat StarCompImg Nso PolyDegree DirCat$ Valid [Focale]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Cat$ | Entrée | Chaîne | Nom du catalogue à utiliser; doit respecter la syntaxe donnée dans le PGM exemple
Focal | Entrée | Entier / Réel | Focale du télescope de prise de vue
SizePixX | Entrée | Entier | Taille du pixel suivant X en µm
SizePixY | Entrée | Entier | Taille du pixel suivant Y en µm
Alpha | Entrée | Réel | Ascension droite approximative du centre de l'image en radian
Delta | Entrée | Réel | Déclinaison approximative du centre de l'image en radians
StarCompCat | Entrée | Entier | Nombre d'étoiles les plus brillantes du catalogue que PRiSM doit utiliser pour la comparaison ( entre 20 et 190 )
StarCompImg | Entrée | Entier | Nombre d'étoiles les plus brillantes de l'image que PRiSM doit utiliser pour la comparaison ( entre 20 et 190)
Nso | Entrée | Entier | Orientation de l'image : 1 (TRUE) si orientation Nord/Sud et 0 (FALSE) sinon
PolyDegree | Entrée | Entier | Degré du polynome utilisé durant la transformation entre coordonnées équatoriales et coordonnées rectangulaires ( utiliser généralement un degré 2 )
DirCat$ | Entrée | Chaîne | Chemin où PRiSM peut trouver les catalogues non livrés avec PRiSM (comme GSC-ACT, USNO ...)
Valid | Sortie | Entier | Pour savoir si la calibration est un succès!
Focale | Sortie | Entier | Focale calculée en mm

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

................................
// Catalogues qui peuvent être utilisés
Cat[1]$="GSC"
Cat[2]$="USNO SA"
Cat[3]$="USNO A1"
Cat[4]$="USNO A2"
Cat[5]$="Hipparcos"
Cat[6]$="SAO"
Cat[7]$="BSC"
Cat[8]$="Tycho1"
Cat[9]$="GSC-ACT"
Cat[10]$="Tycho2"

Cat$=Cat[9]$
...........................................
...
NbStarCat=50
NbStarImg=50

// Orientation Nord-Sud
NSo=FALSE

PolyDeg=2
...
...........................................
// Doit mettre "\" à la fin du chemin
Chem$="H:\PRiSM v5\Gsc-Act\"

EtalonAstrometrieAuto Img Cat$ Focal TaillePixX TaillePixY AD DC NbStarCat NbStarImg NSo PolyDeg Chem$ Valid

If Valid=TRUE then
 Print "OK.. l'étalonnage est OK"
 WIDTH img wx
 HEIGHT img hx
 X=wx/2
 Y=hx/2
..................................

Télécharger l'exemple


Analyse / GetAstrometrie

GetAstrometrie

Description :

Cette fonction permet d'obtenir les coordonnées équatoriales d'une étoile.
Attention : l'image doit être calibrée astrométriquement avant d'exécuter la fonction. Les images au format FITS ne pouvant retenir la calibration astrométrique dans leur entête, cette fonction est inutilisable directement avec une image au format FITS !
La valeur du paramètre "DEM_LARG" doit être entre 3 et 25 !

Syntaxe :

GETASTROMETRIE Img X Y Dem_Larg Alpha Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Dem_Larg | Entrée | Entier | Demi-Largeur de la fenêtre de modélisation par gaussienne ( entre 3 et 25 )
Alpha | Sortie | Réel | Ascension droite de l'étoile en radians
Delta | Sortie | Réel | Déclinaison de l'étoile en radians

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / non

Voir aussi :
Open
GetImage
EtalonAstrometrieAuto
GetAstrometrieXY

Exemple :

................................
GetPoint Img X Y

GetAstrometrie Img X Y 7 Alpha Delta

REM Résultats
RAD_TO_RA Alpha Alpha$
RAD_TO_DEC Delta Delta$
PRINT "Ascension doite : " Alpha$
PRINT "Déclinaison : " Delta$

Télécharger l'exemple


Analyse / GetAstrometrieXY

GetAstrometrieXY

Description :

Cette fonction permet d'obtenir les coordonnées équatoriales d'un pixel fractionnaire.
Attention : l'image doit être calibrée astrométriquement avant d'exécuter cette fonction. Les images au format FITS ne pouvant retenir la calibration astrométrique dans leur entête, cette fonction est inutilisable directement avec une image au format FITS !

Syntaxe :

GETASTROMETRIE Img X Y Alpha Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Réel | Position rectangulaire EXACTE ( fractionnaire) suivant X du pixel
Y | Entrée | Réel | Position rectangulaire EXACTE ( fractionnaire) suivant Y du pixel
Alpha | Sortie | Réel | Ascension droite de l'étoile en radians
Delta | Sortie | Réel | Déclinaison de l'étoile en radians

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / non

Voir aussi :
Open
GetImage
EtalonAstrometrieAuto
GetAstrometrie

Exemple :

................................
GetImage Img

INPUT "Coordonnée X ?" X
INPUT "Coordonnée Y ?" Y
GETASTROMETRIEXY Img X Y Alpha Delta

REM Résultats
RAD_TO_RA Alpha Alpha$
RAD_TO_DEC Delta Delta$
PRINT X " --> " Alpha$
PRINT Y " --> " Delta$

Télécharger l'exemple


Analyse / XYToAlphaDelta

XYToAlphaDelta

Description :

Cette fonction permet des coordonnées rectangulaires exactes sur une image à partir d'une position astrométrique.
Attention : l'image doit être calibrée astrométriquement avant d'exécuter cette fonction. Les images au format FITS ne pouvant retenir la calibration astrométrique dans leur entête, cette fonction est inutilisable directement avec une image au format FITS !

Syntaxe :

GETASTROMETRIE Img Alpha Delta X Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Alpha | Sortie | Réel | Ascension droite EXACTE en radians
Delta | Sortie | Réel | Déclinaison EXACTE en radians
X | Entrée | Réel | Position rectangulaire EXACTE ( fractionnaire) suivant X du pixel correspondant
Y | Entrée | Réel | Position rectangulaire EXACTE ( fractionnaire) suivant Y du pixel correspondant

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / non

Voir aussi :
Open
GetImage
EtalonAstrometrieAuto
GetAstrometrie
GetAstrometrieXY

Exemple :

................................
PRINT "Cliquer sur un objet ponctuel"
GetPoint Img X Y
PRINT "X = " X
PRINT "Y = " Y

GetAstrometrie Img X Y 7 Alpha Delta
RAD_TO_RA Alpha Alpha$
RAD_TO_DEC Delta Delta$
PRINT Alpha$ " " Delta$

XYToAlphaDelta Img Alpha Delta X0 Y0

REM Résultats
PRINT "Position du centre de l'étoile"
PRINT "X = " X0
PRINT "Y = " Y0

Télécharger l'exemple


Analyse / GetImg_XY_TO_RADDEC

GetImg_XY_TO_RADDEC

Description :

Cette fonction permet de fournir les coordonnées équatoriales correspondant à la position non entière d'un pixel.
L'ascension droite et la déclinaison sont fournis en radians. Pour une expression dans des unités plus usuelles, il est alors conseillé d'utiliser les fonctions de conversions.
Attention : l'image doit être calibrée astrométriquement avant d'exécuter la fonction. Les images au format FITS ne pouvant retenir la calibration astrométrique dans leur entête, cette fonction est inutilisable directement avec une image au format FITS !

Syntaxe :

GETIMG_XY_TO_RADDEC Img X Y RA DEC ERROR

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Réel | Position FRACTIONNAIRE du pixel suivant X
Y | Entrée | Réel | Position FRACTIONNAIRE du pixel suivant Y
RA | Sortie | Réel | Ascension droite en radians sur l'image correspondant à X
DEC | Sortie | Réel | Déclinaison en radians sur l'image correspondant à Y
ERROR | Sortie | Booléen | Paramètre de réussite de la convertion : Pas d'erreur si 1 et 0 sinon

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / non

Voir aussi :
Open
GetImage

EtalonAstrometrieAuto

Exemple :

................................
Centroidegauss Img X Y 9 PosX PosY SigW SigH Angle Flux OMC HOMC Err

GetImg_XY_TO_RADDEC Img PosX PosY Alpha Delta

REM Résultats
RAD_TO_RA Alpha Alpha$
RAD_TO_DEC Delta Delta$
PRINT "Ascension doite : " Alpha$
PRINT "Déclinaison : " Delta$

Télécharger l'exemple


Analyse / GetImg_RADDEC_TO_XY

GetImg_RADDEC_TO_XY

Description :

Cette fonction donne la position non entière d'un pixel d'une image correspondant à des coordonnées équatoriales.
L'ascension droite et la déclinaison sont donnés en radians. Pour une expression dans des unités plus usuelles, il est alors conseillé d'utiliser les fonctions de conversions.
Attention : l'image doit être calibrée astrométriquement avant d'exécuter la fonction. Les images au format FITS ne pouvant retenir la calibration astrométrique dans leur entête, cette fonction est inutilisable directement avec une image au format FITS !

Erreur prend la valeur FALSE (0) si l'opération a réussi et TRUE (1) dans le cas contraire

Syntaxe :

GETIMG_RADDEC_TO_XY Img RA DEC X Y Erreur

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
RA | Entrée | Réel | Ascension droite en radians sur l'image
DEC | Entrée | Réel | Déclinaison en radians sur l'image
X | Sortie | Réel | Position FRACTIONNAIRE du pixel correspondant suivant X
Y | Sortie | Réel | Position FRACTIONNAIRE du pixel correspondant suivant Y
Erreur | Sortie | Entier / Booléen | Echec de l'opération !

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / non

Voir aussi :
Open
GetImage

Exemple :

................................
GETIMG_RADDEC_TO_XY Img RA DEC X Y Erreur
If Erreur=0 Then
   PRINT "X = " X
   PRINT "Y = " Y
Else
   PRINT "Echec !"
EndIf

Télécharger l'exemple


Analyse / GetStarList

GetStarList

Description :

Cette fonction permet de créer une liste sous forme de tableau avec tous les objets ponctuels avec la résolution du matching "RESOL".
Pour la liste, les objets sont classés par valeurs décroissantes de flux.

Attention : Cette fonction a changée depuis la version 1.00.

Syntaxe :

GETSTARLIST Img Resol NbStars ListX[] ListY[] ListFlux[]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Resol | Entrée | Entier | Paramètre à donner indiquant avec quelle résolution la recherche doit se faire ( entre 0 et 3 )
NbStars | Sortie | Entier | Le nombre d'objets ponctuels que PRiSM a déterminé dans l'image
ListX[] | Sortie | TABLEAU d'entiers | Liste des coordonnées horizontales de tous les objets ponctuels avec la résolution "Resol" ( l'index du tableau va de 0 à NbStar-1)
ListY[] | Sortie | TABLEAU d'entiers | Tableau d'Entier.Liste des coordonnées horizontales de tous les objets ponctuels avec la résolution "Resol" ( l'index du tableau va de 0 à NbStar-1 )
ListFlux[] | Sortie | TABLEAU d'entiers | Flux des objets ponctuels de coordonnées rectangulaires "ListX[i], ListY[i]" ( l'index du tableau va de 0 à NbStar-1 )

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
Print "Liste d'étoiles ..."
Param = 0
GetStarList Img Param NbStar ListX ListY ListFlux

Télécharger l'exemple


Analyse / GetStarListCat

GetStarListCat

Description :

Cette fonction permet de lister les objets d'un catalogue dans une zone de champ donnée. Ces derniers sont affichés sous la forme d'une image CCD dont les paramètres sont fournis. Cela permet ensuite de faire manuellement des comparaisons.

On peut utiliser les différents catalogues suivant : "GSC", "GSC-ACT", "USNO SA", "USNO A1", "USNO A2", "Hipparcos", "SAO", "BSC", "Tycho1" et "Tycho2"( Attention : Les majuscules et minuscules doivent être respectées et vérifier que la vesion de PRiSM supporte le catalogue demandé).

Un paramètre supplémentaire doit être donné pour tous les catalogues non livrés avec PRiSM ( GSC-ACT et les catalogues à base USNO) : Le paramètre [DirCat$] est le chemin complet où PRiSM peut trouver le chemin d'un tel catalogue. Pour les autres catalogue, ce paramètre ne doit pas être donné.
Attention : les index des tableaux commencent à 1 (un).

Syntaxe :

GETSTARLISTCAT Catalog$ Focal TaillePixX TaillePixY AD DC [Coul$] [Chem$] [FactC] MagMin MagMax DateUTC SizeX SizeY DistAS NbEtoile ListeAD ListeDEC ListMagn

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Catalog$ | Entrée | Chaîne | Nom du catalogue à utiliser; doit respecter la syntaxe donnée dans le PGM exemple
Focal | Entrée | Entier / Réel | Focale du télescope de prise de vue
TaillePixX | Entrée | Entier | Taille du pixel suivant X en µm
TaillePixY | Entrée | Entier | Taille du pixel suivant Y en µm
AD | Entrée | Réel | Ascension droite approximative du centre de l'image en radian
DC | Entrée | Réel | Déclinaison approximative du centre de l'image en radians
Coul$ | Entrée | Chaîne de caractères | Paramètre optionnel représentant la référence en couleur choisie pour les catalogues qui le permettent.
Chem$ | Entrée | Chaîne de caractères | Chemin optionnel où PRiSM peut trouver les catalogues non livrés avec PRiSM
FactC | Entrée | Réel | Facteur de champ en rapport avec la taille finale de l'image (de 0.0001 à 0.9999)
MagMin | Entrée | Réel | Magnitude minimum des étoiles affichées
MagMax | Entrée | Réel | Magnitude maximum des étoiles affichées
DateUTC | Entrée | Réel | Date de l'image de simulation (voir la fonction NOW)
SizeX | Entrée | Entier | Taille du capteur en X
SizeY | Entrée | Entier | Taille du capteur en Y
DistAS | Entrée | Entier | Distance d'exclusion en secondes d'arc
NbEtoile | Sortie | Entier | Nombre d'étoiles dans l'image
ListeAD | Sortie | Tableau de réels | Tableau représentant les valeurs des ascensions droites des différentes étoiles affichées (en radians)
ListeDEC | Sortie | Tableau de réels | Tableau représentant les valeurs des déclinaisons des différentes étoiles affichées (en radians)
ListeAD | Sortie | Tableau de réels | Tableau représentant les valeurs des magnitudes des différentes étoiles affichées

Voir aussi :

Exemple :

................................
// Catalogues qui peuvent être utilisés
Cat[1]$="GSC"
Cat[2]$="USNO SA"
Cat[3]$="USNO A1"
Cat[4]$="USNO A2"
Cat[5]$="Hipparcos"
Cat[6]$="SAO"
Cat[7]$="BSC"
Cat[8]$="Tycho1"
Cat[9]$="GSC-ACT"
Cat[10]$="Tycho2"

Cat$=Cat[4]$

...........................................
// Pixels amount
SizeX=1000
SizeY=1000
// Distance d'exclusion
DistAS=10

GETSTARLISTCAT Catalog$ Focal TaillePixX TaillePixY AD DC Coul$ Chem$ FactC MagMin MagMax DateUTC SizeX SizeY
DistAS NbEtoile ListeAD ListeDEC ListMagn

Print "NbEtoile=" NbEtoile
..................................

Télécharger l'exemple


Analyse / TrigMatch

TrigMatch

Description :

Cette fonction permet de comparer deux listes d'étoiles.
Elle essaie de reconnaître les mêmes étoiles dans les deux listes. Ainsi, les deux listes qui correspondent aux deux images doivent avoir la même dimension. Si la fonction est un succès, List1[I] et List2[I] contiennent les mêmes étoiles.
Par exemple, ListX1[List1[I]] et ListX2[List2[I]] sont les positions en X de la même étoile, une dans la liste 1 et l'autre dans la liste 2.
Attention : les index des tableaux commencent à 0 (zéro).

Syntaxe :

TRIGMATCH NbStar1 ListX1 ListY1 ListFlux1 NbStarRef NbStar2 ListX2 ListY2 ListFlux2 NbStarRef flux_bool ori_bool scale_bool List1 List2

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
NbStar1 | Entrée | Entier | Nombre d'étoiles référencées de la liste 1 correspondant à l'image 1
ListX1 | Entrée | Tableau de réels | Liste des positions en X d'étoiles de l'image 1
ListY1 | Entrée | Tableau de réels | Liste des positions en Y d'étoiles de l'image 1
ListFlux1 | Entrée | Tableau de réels | Liste des flux d'étoiles de l'image 1
NbStarRef1 | Entrée | Entier | Nombre d'étoiles d ela liste 1 qui peuvent servir de référence
NbStar2 | Entrée | Entier | Nombre d'étoiles référencées de la liste 2 correspondant à l'image 2
ListX2 | Entrée | Tableau de réels | Liste des positions en X d'étoiles de l'image 2
ListY2 | Entrée | Tableau de réels | Liste des positions en Y d'étoiles de l'image 2
ListFlux2 | Entrée | Tableau de réels | Liste des flux d'étoiles de l'image 2
NbStarRef2 | Entrée | Entier | Nombre d'étoiles de la liste 2 qui peuvent servir de référence
flux_bool | Entrée | Booléen | Pour privilégier la reconnaissance par le flux des étoiles (1 pour privilégier)
ori_bool | Entrée | Booléen | Pour privilégier la reconnaissance par l'orientation des étoiles (1 pour privilégier)
scale_bool | Entrée | Booléen | Pour privilégier la reconnaissance par l'échelle des listes (1 pour privilégier)
List1 | Sortie | Tableau d'entiers | Tableau des numéros des étoiles de la liste 1 qui ont une correspondance avec celles de la liste 2
List2 | Sortie | Tableau d'entiers | Tableau des numéros des étoiles de la liste 2 qui ont une correspondance avec celles de la liste 1

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Exemple :

Print "Chargement Image 1"
GetImage Img1
Print "Chargement Image 2"
GetImage Img2

Print "Recherches de étoiles dans l'image 1"
GetStarList Img1 0 NbStar1 ListX1 ListY1 ListFlux1
Print "Recherches de étoiles dans l'image 2"
GetStarList Img2 0 NbStar2 ListX2 ListY2 ListFlux2

if NbStar1<NbStar2
   NbStarRef=NbStar1
else
   NbStarRef=NbStar2
endif

if NbStarRef>50
   NbStarRef=50
endif

Print "Matching des deux listes d'étoiles"
TRIGMATCH NbStar1 ListX1 ListY1 ListFlux1 NbStarRef NbStar2 ListX2 ListY2 ListFlux2 NbStarRef 1 0 0 List1 List2

Print "Correspondance Liste1 / Liste2"
for i=0 NbStarRef-1
   Print "(" ListX1[List1[i]] "," ListY1[List1[i]] ")=(" ListX2[List2[i]] "," ListY2[List2[i]] ")"
next i

Télécharger l'exemple


Analyse / Astrom_From_Bin

Astrom_From_Bin

Description :

Cette fonction permet de récupérer les paramètres de calibration astrométriques à partir de la même image, déjà calibrée, mais réduite d'un facteur N (binning NxN).
Le résultat ne sera pas de la même précision que l'image n°1 directement calibrée et donc, de ce fait, cette fonction est à éviter si on peut réaliser la calibration astrométrique directe de l'image n°1.

Syntaxe :

ASTROM_FROM_BIN Img1 Img2 BIN

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée / Sortie | Image | Nom interne de l'image dans le programme PGM qui doit être calibrée astrométriquement
Img2 | Entrée | Image | Nom interne de l'image dans le programme PGM qui est calibrée mais réduite d'un facteur 2 par rapport à la première
BIN | Entrée | Entier | Facteur de binning de l'image calibrée

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

...................................
GetImage Img2

ASTROM_FROM_BIN Img1 Img2
Close Img2

Télécharger l'exemple


Analyse / EtalonPhotometrie

EtalonPhotometrie

Description :

Cette fonction permet de réaliser un étalonnage photométrique manuel à partir d'une ou de deux étoiles étalons.

On peut choisir entre deux méthodes de modélisation d'étoiles : Moffat ou Gauss.

Syntaxe :

ETALONPHOTOMETRIE Img Dem_Larg Modele$ X Y MgEtalon [ X' Y' MgEtalon']

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Dem_Larg | Entrée | Entier | Demi-Largeur de la fenêtre de modélisation ( entre 3 et 25 )
Modele$ | Entrée | "Moffat" / "Gauss" | Choix du modèle utilisé
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile de référence suivant la coordonnée X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile de référence suivant la coordonnée Y en entier de pixel
MgEtalon | Entrée | Réel | Magnitude EXACTE de l'étoile étalon
[X'] | Entrée | Entier | Position APPROXIMATIVE de la 2ème étoile de référence optionnelle suivant la coordonnée X en entier de pixel
[Y'] | Entrée | Entier | Position APPROXIMATIVE de la 2ème étoile de référence optionnelle suivant la coordonnée Y en entier de pixel
[MgEtalon'] | Entrée | Réel | Magnitude EXACTE de la 2ème étoile étalon optionnelle

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage
GetPoint

Exemple :

................................
GetPoint Img X Y
Input "Magnitude de l'étoile ? " MgEtalon

EtalonPhotometrie Img 9 Gauss X Y MgEtalon
REM  EtalonPhotometrie Img 9 Moffat X Y MgEtalon X2 Y2 MgEtalon2 ... marche aussi avec 2 étoiles étalons ...
.................................

Télécharger l'exemple


Analyse / EtalonPhotometrieAuto

EtalonPhotometrieAuto

Description :

Cette fonction permet de réaliser un étalonnage photométrique automatique.

On peut utiliser les différents catalogues suivant : "GSC", "GSC-ACT", "USNO SA", "USNO A1", "USNO A2", "Hipparcos", "SAO", "BSC", "Tycho1", "Tycho2" et "UCAC1/2"( Attention : Les majuscules et minuscules doivent être respectées et vérifier que la vesion de PRiSM supporte le catalogue demandé).

Un paramètre supplémentaire doit être donné pour tous les catalogues non livrés avec PRiSM ( GSC-ACT et les catalogues à base USNO) : le paramètre optionnel [DirCat$] est le chemin complet où PRiSM peut trouver le chemin d'un tel catalogue. Pour les autres catalogues, ce paramètre ne doit pas être donné.
Le paramètre NON optionnel de couleur est celui dont il faut tenir compte pour l'étalonnage en magnitude est à choisir suivant le rouge, le V ou le bleu ( "r", "v", "b"). Ce paramètre est à donner pour tous les catalogues même si uniquement les catalogues s'en servent !

La valeur de la variable "VALID" est de 1 (TRUE) si la calibration a réussie et de 0 (FALSE) en cas d'échec.
Les paramètres d'étoiles de comparaison doivent être entre 20 et 190 ( voir la Description des variables ).
Attention : plus le paramètre de comparaison est important, plus le temps de calcul sera aussi important !.

Syntaxe :

ETALONPHOTOMETRIEAUTO Img Cat$ Focus SizePixX SizePixY Alpha Delta StarCompCat StarCompImg Nso Coul$ [DirCat$] Valid

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Cat$ | Entrée | Chaîne | Nom du catalogue à utiliser; doit respecter la syntaxe donnée dans le PGM exemple
Focal | Entrée | Entier / Réel | Focale du télescope de prise de vue
SizePixX | Entrée | Entier | Taille du pixel suivant X en µm
SizePixY | Entrée | Entier | Taille du pixel suivant Y en µm
Alpha | Entrée | Réel | Ascension droite approximative du centre de l'image en radian
Delta | Entrée | Réel | Déclinaison approximative du centre de l'image en radians
StarCompCat | Entrée | Entier | Nombre d'étoiles les plus brillantes du catalogue que PRiSM doit utiliser pour la comparaison ( entre 20 et 190 )
StarCompImg | Entrée | Entier | Nombre d'étoiles les plus brillantes de l'image que PRiSM doit utiliser pour la comparaison ( entre 20 et 190)
Nso | Entrée | Entier | Orientation de l'image : 1 (TRUE) si orientation Nord/Sud et 0 (FALSE) sinon
Coul$ | Entrée | "r" / "v" / "b" | Couleur utilisée pour les catalogues photométriques
DirCat$ | Entrée | Chaîne | Chemin optionnel où PRiSM peut trouver les catalogues non livrés avec PRiSM
Valid | Sortie | Entier | Pour savoir si la calibration est un succès!

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

................................
Cat$="USNO A2"
Chem$="F:\"
...........................................
...
...........................................
NSo=FALSE
NbStarCat=60
NbStarImg=90
Couleur$="r"

EtalonPhotometrieAuto Img Cat$ Focus TaillePixX TaillePixY AD DC NbStarCat NbStarImg NSo Couleur$ Chem$ Valid
.................................

Télécharger l'exemple


Analyse / EtalonPhotometrieF

EtalonPhotometrieF

Description :

Cette fonction permet de réaliser un étalonnage photométrique d'une image : on indique une magnitude correspondant à un flux de référence pour l'image étudiée. L'entête CPA de l'image sera alors complétée en conséquence.

Syntaxe :

ETALONPHOTOMETRIEF Img Mag FluxRef

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Mag | Entrée | Réel | Magnitude correspondant au flux donné
FluxRef | Entrée | Entier | Flux en ADU correspondant à la magnitude donnée

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

................................
centroidegauss img x y 10 PosX PosY SigX SigY Angle FluxRef Omc HOmc Err
if FluxRef=-1 then
  print "Impossible de modéliser l'étoile "
  end
endif

INPUT "Magnitude de l'étoile " Mg

REM Etalonnage (MagnitudeRef=0)
etalonphotometrieF Img Mg FluxRef
.................................

Télécharger l'exemple


Analyse / Getphotometrie

Getphotometrie

Description :

Cette fonction permet d'obtenir la magnitude d'un objet ponctuel.
Attention : l'image doit être calibrée astrométriquement avant d'exécuter la fonction. Les images au format FITS ne pouvant retenir la calibration astrométrique dans leur entête, cette fonction est inutilisable directement avec une image au format FITS !
La valeur du paramètre "DEM_LARG" doit être entre 3 et 25 !

Syntaxe :

GETPHOTOMETRIE Img X Y Dem_Larg PosX PosY Mag ErrMag

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Dem_Larg | Entrée | Entier | Demi-Largeur de la fenêtre de modélisation par gaussienne ( entre 3 et 25 )
PosX | Sortie | Réel | Position EXACTE de l'étoile modélisée suivant X par une gaussienne
PosY | Sortie | Réel | Position EXACTE de l'étoile modélisée suivant Y par une gaussienne
Mag | Sortie | Réel | Magnitude calculée de l'objet ponctuel
ErrMag | Sortie | Réel | Erreur estimée sur la magnitude calculée

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / non

Voir aussi :
Open
GetImage

Exemple :

................................
GetPoint Img X Y
Input "Magnitude de l'étoile ? " MgEtalon

EtalonPhotometrie Img 9 Gauss X Y MgEtalon

GETPHOTOMETRIE Img X Y 9 PosX PosY Mag ErrMag

PRINT "Position de l'étoile :"
PRINT "X = " PosX ";Y = " PosY
PRINT "Magnitude = " Mag " +/- " ErrMag
.................................

Télécharger l'exemple


Analyse / APC

APC

Description :

Cette fonction permet d'obtenir le flux d'une étoile par photométrie d'ouverture.
Le principe revient à tenir compte que l'étoile occupe un cercle de rayon Rin et que le fond de ciel au niveau de l'étoile est le même que celui autour de l'étoile compris entre les cercles de rayons Rout et Rin.

Syntaxe :

APC Img Posx Posy Rin Rout Flux NbPixels

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
PosX | Entrée | Entier | Position du centre des cercles de photométrie suivant X
PosY | Entrée | Entier | Position du centre des cercles de photométrie suivant Y
Rin | Entrée | Entier | Rayon du cercle interne de photométrie
Rout | Entrée | Entier | Rayon du cercle externe de photométrie
Flux | Sortie | Entier / Réel | Flux correspondant à l'étoile en ADU
NbPixels | Sortie | Entier | Nombre de pixels entre les deux cercles de photométrie

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Open
GetImage
GetPoint

Exemple :

................................
getpoint img Posx Posy

for Rin=0 20

   Rout=Rin+10
   APC img Posx Posy Rin Rout Flux NbPixels
.................................

Télécharger l'exemple

Image de test :

Etoile de référence.


Analyse / APE

APE

Description :

Cette fonction permet d'obtenir le flux d'une étoile par photométrie d'ouverture elliptique.
Le principe revient à tenir compte que l'étoile occupe une ellipse et que le fond de ciel au niveau de l'étoile est le même que celui autour de l'étoile compris entre deux ellipses.

Syntaxe :

APE Img Posx Posy DemiGrandAxeIn DemiPetitAxeIn AngleIn DemiGrandAxeOut DemiPetitAxeOut AngleOut FluxE NbPixels

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
PosX | Entrée | Entier | Position du centre des ellipses de photométrie suivant X
PosY | Entrée | Entier | Position du centre des ellipses de photométrie suivant Y
DemiGrandAxeIn | Entrée | Réel | Demi-grand axe de l'ellipse interne de photométrie
DemiPetitAxeIn | Entrée | Réel | Demi-petit axe de l'ellipse interne de photométrie
AngleIn | Entrée | Réel | Angle du demi-grand axe l'ellipse interne de photométrie par rapport à l'axe des abcisses
DemiGrandAxeOut | Entrée | Réel | Demi-grand axe de l'ellipse interne de photométrie
DemiPetitAxeOut | Entrée | Réel | Demi-petit axe de l'ellipse interne de photométrie
AngleOut | Entrée | Réel | Angle du demi-grand axe l'ellipse interne de photométrie par rapport à l'axe des abcisses
FluxE | Sortie | Réel | Flux correspondant à l'étoile en ADU
NbPixels | Sortie | Entier | Nombre de pixels entre les deux ellipses de photométrie

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

APC

Exemple :

................................
.................................
Télécharger l'exemple

Image de test :

Etoile de référence.


Analyse / CentroideGauss

CentroideGauss

Description :

Cette fonction permet d'appliquer un centroïde gaussien sur une étoile, dans l'image Image.
Si cette fonction échoue, celle-ci renvoie -1 dans toutes les variables de sortie.
Dans le programme de test proposée, comme on ne connaît pas la position exacte du centroïde de l'étoile, la fonction est testée sur un ensemble de pixels présumés autour du centre de l'étoile. Ceci permet ensuite de choisir les meilleurs résultats afin de ne garder que ces derniers ...

Syntaxe :

CENTROIDEGAUSS Img X Y Dem_Larg PosX PosY SigW SigH Angle Flux OMC HOMC ErrFlux

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Dem_Larg | Entrée | Entier | Demi-Largeur de la fenêtre à considérer autour de l'étoile
PosX | Sortie | Réel | Position exacte à la fraction de pixel près du centroïde de l'étoile suivant X
PosY | Sortie | Réel | Position exacte à la fraction de pixel près du centroïde de l'étoile suivant Y
SigW | Sortie | Réel | Plus grande largeur à mi-hauteur de l'étoile
SigH | Sortie | Réel | Plus petite largeur à mi-hauteur de l'étoile
Angle | Sortie | Réel | Orientation de l'étoile selon sa plus grande largeur (en radians)
FluxEtalon | Sortie | Réel | Flux de l'étoile
OMC | Sortie | Réel | différence entre l'étoile et le modèle
HOMC | Sortie | Réel | rapport signal sur bruit entre le l'étoile et le modèle
Err | Sortie | Entier | Erreur sur la mesure de flux

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
Centroidegauss Img MesureX MesureY DemiLargFen PosX PosY SigW SigH Angle Flux Omc HOmc Err
if HOmc>Note
...........................................

Télécharger l'exemple


Analyse / CentroideMoffat

CentroideMoffat

Description :

Cette fonction permet d'appliquer un centroïde gaussien sur une étoile, dans l'image Image.
Si cette fonction échoue, celle-ci renvoie -1 dans toutes les variables de sortie.
Dans le programme de test proposée, comme on ne connaît pas la position exacte du centroïde de l'étoile, la fonction est testée sur un ensemble de pixels présumés autour du centre de l'étoile. Ceci permet ensuite de choisir les meilleurs résultats afin de ne garder que ces derniers ...

Syntaxe :

CENTROIDEMOFFAT Img X Y Dem_Larg PosX PosY SigW SigH Angle Flux OMC HOMC ErrFlux

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Dem_Larg | Entrée | Entier | Demi-Largeur de la fenêtre à considérer autour de l'étoile
PosX | Sortie | Réel | Position exacte à la fraction de pixel près du centroïde de l'étoile suivant X
PosY | Sortie | Réel | Position exacte à la fraction de pixel près du centroïde de l'étoile suivant Y
SigW | Sortie | Réel | Plus grande largeur à mi-hauteur de l'étoile
SigH | Sortie | Réel | Plus petite largeur à mi-hauteur de l'étoile
Angle | Sortie | Réel | Orientation de l'étoile selon sa plus grande largeur (en radians)
FluxEtalon | Sortie | Réel | Flux de l'étoile
OMC | Sortie | Réel | différence entre l'étoile et le modèle
HOMC | Sortie | Réel | rapport signal sur bruit entre le l'étoile et le modèle
Err | Sortie | Entier | Erreur sur la mesure de flux

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
Centroidemoffat Img MesureX MesureY DemiLargFen PosX PosY SigW SigH Angle Flux Omc HOmc Err
if HOmc>Note
............................................

Télécharger l'exemple


Analyse / CentroidBarycentre

CentroidBarycentre

Description :

Cette fonction permet de calculer la position du centroïde d'un objet ( éventuellement étendu ) suivant le centroïde barycentrique.
Cet objet peut ne pas être ponctuel.
Seulement, les "Nbpixel" de plus grande valeur en ADU sont utilisés pour le calcul. Si cette dernière valeur est plus importante que le paramètre "WINDOW", alors la fonction ne fonctionnera pas !
Voir aussi la fonction : CentroidBarycentreThresholding.

Syntaxe :

CENTROIDBARYCENTRE Img X Y Window NbPixel Xresult Yresult

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Window | Entrée | Entier | Fixe la taille de la fenêtre du centroïde
NbPixel | Entrée | Entier | Nombre de pixels pour le calcul du barycentre
XResult | Sortie | Réel | Position EXACTE de l'étoile suivant X
YResult | Sortie | Réel | Position EXACTE de l'étoile suivant Y

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

REM Charger l'image.
GetImage Image

REM Obtenir approximativement les coordonnées centrales de l'objet à modéliser
GETPOINT Image X Y

PRINT "Coordonnées rectangulaires approximatives de l'objet : " X " , " Y
INPUT "Taille de la fenêtre à utiliser ? " Window
INPUT "Nombre de pixel pour le calcul ? " NbPixel

CENTROIDBARYCENTRE Image X Y Window NbPixel Xbary Ybary

PRINT "Coordonnées rectangulaires de l'objet :"
PRINT Xbary " , " Ybary

Télécharger l'exemple


Analyse / CentroidBarycentreThresHolding

CentroidBarycentreThresholding

Description :

Cette fonction permet de calculer le centroïde d'un objet en utilisant le centroïde barycentrique.
Cet objet peut ne pas être ponctuel.
Seuls les pixels qui ont une valeur en ADU supérieur à "Threshold" sont utilisés pour réaliser le centroïde.
Les trois paramètres "Theta", "A" et "B" sont optionnels mais si un de ces paramètres est demandés, ils doivent tous l'être.
Les utilisateurs doivent être attentif à la valeur du "Seuil". son choix doit être quasiment identique au fond de l'image en ADU.
Voir aussi la fonction : "CentroidBarycentre".

Syntaxe :

CENTROIDBARYCENTRETHRESHOLDING Img X Y Window Threshold Xresult Yresult [Theta A B]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Window | Entrée | Entier | Fixe la taille de la fenêtre du centroïde
Threshold | Entrée | Entier | Valeur en ADU au-dessus de laquelle les pixels sont pris en compte (voir l'aide sur le centroïde)
XResult | Sortie | Réel | Position EXACTE de l'étoile suivant X
YResult | Sortie | Réel | Position EXACTE de l'étoile suivant Y
[Theta] | Sortie | Réel | Direction de l'étoile dépendant de la plus grande FWHM ( en radians )
[A] | Sortie | Réel | Plus grande largeur à mi-hauteur ( FWHM ) estimée pour l'étoile en pixels
[B] | Sortie | Réel | Plus petite FWHM estimée pour l'étoile en pixels

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

REM Charger l'image
GetImage Image

REM Obtenir la coordonnée approximative du pixel
GETPOINT Image X Y

PRINT "Coordonnées rectangulaires entières de l'étoile : " X " , " Y
INPUT "Taille de la fenêtre ? " Window
INPUT "Seuil mini en ADU pour le calcul ? " Thres

CENTROIDBARYCENTRETHRESHOLDING Image X Y Window Thres Xbary Ybary

PRINT "Coordonnées rectangulaires de l'étoile :"
PRINT Xbary " , " Ybary

Télécharger l'exemple


Analyse / PRC_FLUX_RADIUS

PRC_Flux_Radius

Description :

Cette fonction permet, entre autre, de déterminer le rayon du cercle en pixel, d'un objet étendu, pour qu'un certain pourcentage d'énergie lumineuse soit à l'intérieur de ce cercle. Ce résultat est donné au 1/100ème de pixel.
La fenêtre d'analyse doit englober tout l'objet.

Une autre information est également fournie : le fond de l'image autour de l'objet considéré.

Syntaxe :

PRC_FLUX_RADIUS Img HW Xc Yc PRC Radius Seuil

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
HW | Entrée | Entier | Demi-Largeur de la fenêtre de calcul (jusqu'à 50 pixels)
Xc | Entrée | Réel | Centroïde (barycentrique par exemple) de l'objet suivant l'axe Ox
Yc | Entrée | Réel | Centroïde (barycentrique par exemple) de l'objet suivant l'axe Oy
PRC | Entrée | Entier (entre 0 et 100) | Pourcentage d'énergie désirée dans le cercle
Radius | Sortie | Réel | Rayon du cercle où se situe le PRC % d'énergie
Seuil | Sortie | Réel | Fond de ciel au niveau de l'objet

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
CentroidBarycentre, CentroidBarycentreThresholding

Exemple :

................................
// % de l'energie désirée
PRC=50
// demi taille d'analyse (fenetre)
DemiTaille=7

PRC_Flux_Radius Img DemiTaille Xc Yc PRC Radius Seuil

Print "rayon pour l'energie considérée : " Radius
Print "Seuil de fond : " Seuil

Télécharger l'exemple


Analyse / CosH_1D

CosH_1D

Description :

Cette fonction modélise simplement et rapidement une ligne sous la forme d'une fonction en 1/cosh. La fonction cosh est la fonction "cosinus hyperbolique".
Le graphe n'apparaît que si les paramètres "AxeX$ AxeY$ Title$" optionnels sont renseignés.

Syntaxe :

COSH_1D Img X Y Dem_Larg Io Xo Sigma Fond Ecart [AxeX$ AxeY$ Title$]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM.
X | Entrée | Entier | Position approximative du centre du signal à modéliser.
Y | Entrée | Entier | Ligne de l'image sur laquelle le signal est modélisé.
Dem_Larg | Entrée | Entier | Demi-largeur pour la fenêtre de modélisation.
I0 | Sortie | Réel | Valeur de l'intensité de la raie.
X0 | Sortie | Réel | Valeur exacte du centre de la raie.
Sigma | Sortie | Réel | Ecart-type de la modélisation.
Fond | Sortie | Réel | Valeur du continuum pour le signal.
Ecart | Sortie | Réel | Erreur moyenne sur les différents essais de modélisation. Si échec de modélisation, cette valeur est égale à "-1".
AxeX$ | Entrée | Chaîne de caractères | Nom de l'axe des abscisses du graphe.
AxeY$ | Entrée | Chaîne de caractères | Nom de l'axe des ordonnées du graphe.
Title$ | Entrée | Chaîne de caractères | Titre du graphe.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Fonction de référence : Menu [Analyse] > [Centroïde] > [Largeur en 1/cosh (1D)]

Voir aussi :

GetPoint, GetImage

Exemple :

.............................................
GETPOINT Img X Y

Dem_Larg=10

COSH_1D Img X Y Dem_Larg Io Xo FWHM Fond Ecart "Axe X" "AxeY" "1/Cosh"
..............................................

Télécharger l'exemple


Analyse / Gauss1D

Gauss1D

Description :

Cette fonction modélise un signal gaussien à une dimension. Une application peut être la modélisation d'une raie spectroscopique sur une ligne ...
La fonction aura alors pour équation : I = Fond + I0*exp[-(4*ln(2)*(x-x0)^2/FWHM^2)].

Syntaxe :

GAUSS1D Img X Y Dem_Larg I0 X0 FWHM Fond Ecart

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM.
X | Entrée | Entier | Position approximative du centre du signal à modéliser.
Y | Entrée | Entier | Ligne de l'image sur laquelle le signal est modélisé.
Dem_Larg | Entrée | Entier | Demi-largeur pour la fenêtre de modélisation.
I0 | Sortie | Réel | Valeur de l'intensité de la raie.
X0 | Sortie | Réel | Valeur exacte du centre de la raie.
FWHM | Sortie | Réel | Largeur à mi-hauteur du signal.
Fond | Sortie | Réel | Valeur du continuum pour le signal.
Ecart | Sortie | Réel | Erreur moyenne sur les différents essais de modélisation. Si échec de modélisation, cette valeur est égale à "-1".

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Fonction de référence : Menu [Analyse] > [Centroïde] > [Largeur à mi-hauteur d'une raie]

Voir aussi :

GetPoint, GetImage

Exemple :

.............................................
GETPOINT Img X Y

Dem_Larg=10

GAUSS1D Img X Y Dem_Larg Io Xo FWHM Fond Ecart
..............................................

Télécharger l'exemple

Autre exemple : Création d'une étoile artificielle et modélisation de la ligne centrale par une gaussienne 1D.


Analyse / GetPixelValue

GetPixelValue

Description :

Cette fonction permet de déterminer l'intensité d'un pixel d'une image en ADU.

Syntaxe :

GETPIXELVALUE Img X Y Value [Imaginaire]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position Entière du pixel suivant X
Y | Entrée | Entier | Position Entière du pixel suivant Y
Value | Sortie | Entier | Valeur en ADU du pixel en (X,Y) ( partie réelle pour les images codées en complexes )
Imaginaire | Sortie | Entier | Valeur imaginaire en ADU du pixel en (X,Y) pour les images codées en complexes

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

................................
GetImage Img
GetPoint Img X Y

GetPixelValue Img X Y Valeur

Print "Valeur du pixel en ADU : " Valeur

Télécharger l'exemple


Analyse / SetPixelValue

SetPixelValue

Description :

Cette fonction permet de fixer l'intensité d'un pixel d'une image en ADU.

Syntaxe :

SETPIXELVALUE Img X Y Value [Imaginaire]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position Entière du pixel suivant X
Y | Entrée | Entier | Position Entière du pixel suivant Y
Value | Entrée | Entier | Valeur en ADU à donner au pixel en (X,Y) ( valeur de la partie réelle pour les images codées en complexes )
Imaginaire | Entrée | Entier | Valeur imaginaire en ADU à donner au pixel en (X,Y) pour les images codées en complexes

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

................................
PRINT "Position du pixel"
GetPoint Img X Y
INPUT "Valeur du pixel en ADU" Valeur

SetPixelValue Img X Y Valeur

Print "Changement effectué"

Télécharger l'exemple


Analyse / NbPixAboveThres

NbPixAboveThres

Description :

Cette fonction indique le nombre de pixel au dessus d'un certain seuil,dans une fenêtre dont on précisera les coordonnées.

Syntaxe :

NBPIXABOVETHRES img X1 Y1 X2 Y2 Seuil NbPixel

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X1 | Sortie | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Sortie | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Sortie | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Sortie | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre
Seuil | Entrée | Entier / Réel | Seuil haut à donner
NbPixel | Sortie | Entier | Résultat de l'opération

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Exemple :

................................
INPUT "Nombre pixels au dessus ?" Seuil
NBPIXABOVETHRES Img X1 Y1 X2 Y2 Seuil Nombre
PRINT "Nombre de pixel au dessus " Seuil " = " Nombre

Télécharger l'exemple


Analyse / Stat

Stat

Description :

Cette fonction permet d'obtenir tous les paramètres statistiques d'une image.

Syntaxe :

STAT Img Moyenne MoyenneQuadratique Ecarttype Max Min Flux Mediane

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Moyenne | Sortie | Entier / Réel | Moyenne des pixels dans le rectangle
MoyenneQuadratique | Sortie | Entier / Réel | Moyenne quadratique des pixels dans le rectangle
Ecarttype | Sortie | Réel | Ecart-type des pixels dans le rectangle par rapport à la moyenne
Max | Sortie | Entier / Réel | Valeur du pixel maximum dans le rectangle
Min | Sortie | Entier / Réel | Valeur du pixel minimum dans le rectangle
Flux | Sortie | Entier / Réel | Flux total des pixels dans le rectangle
Mediane | Sortie | Réel | Médiane des pixels dans le rectangle

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
StatWindow

Exemple :

......................................
StatWindow Img Moyenne MoyenneQuadratique Ecarttype Max Min Flux Mediane

Print "Moyenne=" Moyenne
........................................

Télécharger l'exemple


Analyse / StatWindow

StatWindow

Description :

Cette fonction permet d'obtenir tous les paramètres statistiques d'une image sur une fenêtre rectangulaire.

Syntaxe :

STATWINDOW Img X1 Y1 X2 Y2 Moyenne MoyenneQuadratique Ecarttype Max Min Flux Mediane

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X1 | Entrée / Sortie | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée /Sortie | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée / Sortie | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée / Sortie | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre
Moyenne | Sortie | Entier / Réel | Moyenne des pixels dans le rectangle
MoyenneQuadratique | Sortie | Entier / Réel | Moyenne quadratique des pixels dans le rectangle
Ecarttype | Sortie | Réel | Ecart-type des pixels dans le rectangle par rapport à la moyenne
Max | Sortie | Entier / Réel | Valeur du pixel maximum dans le rectangle
Min | Sortie | Entier / Réel | Valeur du pixel minimum dans le rectangle
Flux | Sortie | Entier / Réel | Flux total des pixels dans le rectangle
Mediane | Sortie | Réel | Médiane des pixels dans le rectangle

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Stat

Exemple :

......................................
GetWindow Img X1 Y2 X2 Y1
StatWindow Img X1 Y1 X2 Y2 Moyenne MoyenneQuadratique Ecarttype Max Min Flux Mediane

Print "Moyenne=" Moyenne
........................................

Télécharger l'exemple


Analyse / GetMinMax

GetMinMax

Description :

Cette fonction permet de chercher le pixel d'une image d'intensité maximale et le pixel de la même image d'intensité minimale. Les valeurs en ADU des pixels sont fournies.
Cette recherche se fait dans une fenêtre définie sur l'image.

Syntaxe :

GETMINMAX X1 X2 Y1 Y2 Img Xmin Ymin Valmin Xmax Ymax Valmax

Variables :

Paramètres | Entrées / Sorties | Type | Description
X1 | Entrée | Entier | Position suivant X du bord gauche de la fenêtre
X2 | Entrée | Entier | Position suivant X du bord droit de la fenêtre
Y1 | Entrée | Entier | Position suivant Y du bord inférieur de la fenêtre
Y2 | Entrée | Entier | Position suivant Y du bord supérieur de la fenêtre
Img | Entrée | Image | Nom interne de l'image dans le PGM
Xmin | Sortie | Entier | Position suivant X du pixel d'intensité minimum
Ymin | Sortie | Entier | Position suivant Y du pixel d'intensité minimum
Valmin | Sortie | Entier / Réel | Valeur en ADU du pixel d'intensité minimale
Xmax | Sortie | Entier | Position suivant X du pixel d'intensité maximum
Ymax | Sortie | Entier | Position suivant Y du pixel d'intensité maximum
Valmax | Sortie | Entier / Réel | Valeur en ADU du pixel d'intensité maximale

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
Width  img X2
Height img Y2
X1=1
Y1=1
GETMINMAX X1 X2 Y1 Y2 img Xmin Ymin Valmin Xmax Ymax Valmax

Télécharger l'exemple


Analyse / Equalisation

Equalisation

Description :

Cette fonction effectue une égalisation d'histogramme d'une image.
PRiSM effectue une égalisation d'histogramme sur les valeurs des pixels de l'image. Il y alors équipartition de la population des valeurs des pixels de l'image en fonction de leur nombre, dans la fourchette choisie (entre 0 et 32767 pour les images entières). Chaque intensité de pixels a alors la même probabilité d'apparaître. Il est conseillé que l'image ne soit pas trop bruitée.

Syntaxe :

EQUALISATION Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / non / non | oui / oui

Exemple :

REM Obtenir l'image
GetImage Img

REM Statistique
Stat Img Moyenne MoyenneQuadratique Ecarttype Max Min Flux Mediane
PRINT "Moyenne avant égalisation = " Moyenne

REM Egalisation
EQUALISATION Img

REM Statistique
Stat Img Moyenne MoyenneQuadratique Ecarttype Max Min Flux Mediane
PRINT "Moyenne après égalisation = " Moyenne

Télécharger l'exemple


Analyse / EqualisationGauss

EqualisationGauss

Description :

Cette fonction effectue une égalisation d'histogramme d'une image.
PRiSM effectue une égalisation d'histogramme gaussien sur les valeurs des pixels de l'image. Il y alors équipartition de la population des valeurs des pixels de l'image en fonction de leur nombre, suivant une gaussienne, dans la fourchette choisie (entre "ClipMin" et "ClipMax"). Chaque intensité de pixels n'a pas alors la même probabilité d'apparaître. Ceci peut être utile pourt des images bruitées. Cette fonction a tendance à faire ressortir les pixels d'intensité importante.

Syntaxe :

EQUALISATIONGAUSS Img ClipMin ClipMax

Variables :

Paramètre | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
ClipMin | Entrée | Entrée | Intensité minimale à modifier pour commencer l'égalisation gaussienne.
ClipMax | Entrée | Entrée | Intensité maximale à modifier pour commencer l'égalisation gaussienne.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / non / non | oui / oui

Exemple :

REM Obtenir l'image
GetImage Img

REM Statistique
Stat Img Moyenne MoyenneQuadratique EcartType Max Min Flux Mediane
PRINT "Moyenne avant égalisation = " Moyenne

REM Egalisation
REM Clipmin supérieur au bruit de l'image
EQUALISATIONGAUSS Img

REM Statistique
Stat Img Moyenne MoyenneQuadratique EcartType Max Min Flux Mediane
PRINT "Moyenne après égalisation = " Moyenne

Télécharger l'exemple


Analyse / GetDecalagePlanete

GetDecalagePlanete

Description :

Cette fonction donne le décalage entre 2 images pour une même planète.
Les valeurs de décalages représentent les décalages de l'image n°2 par rapport à l'image n°1.

Syntaxe :

GETDECALAGEPLANETE Img1 Img2 dx dy

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée | Image | Nom interne de l'image n°1 dans le programme PGM
Img2 | Entrée | Image | Nom interne de l'image n°2 dans le programme PGM
dx | Sortie | réel | Décalage horizontal de planète2 par rapport à planète 1
dy | Sortie | réel | Décalage vertical de planète2 par rapport à planète 1

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

REM importer les 2 images
Directory$="F:\Mes documents\Mes Travaux\SCRIPTS\Images de travail\"
Name$="Jupiter2.bmp"
OPENBMP Img1 Directory$+Name$

Name$="Jupiter2.bmp"
OPENBMP Img2 Directory$+Name$

GETDECALAGEPLANETE Img1 Img2 DX DY

PRINT "Décalage : DX = " DX ", DY = " DY

Télécharger l'exemple


Analyse / Reduc_Coll

Reduc_Coll

Description :

Cette fonction permet de réduire la taille de l'iamge dans le but d'une recherche de collimation plus aisée.

Pour plus d'information, voir la fonction correspondante : [Analyse] > [Réduit les 4 côtés]

Syntaxe :

REDUC_COLL Img Taille

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Taille | Entrée | Entier | Taille du carré de réduction

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Exemple :

Télécharger l'exemple


Graphe / AddPoint

AddPoint

Description :

Cette fonction permet de placer un point dans un graphique.

Syntaxe :

ADDPOINT GraphName X Y

Variables :

Paramètre | Entrées / Sorties | Type | Description
GraphName | Entrée | Graphe | Nom interne du graphe à ouvrir dans le programme PGM
X | Entrée | Entier / Réel | Coordonnée suivant X du point
Y | Entrée | Entier / Réel | Coordonnée suivant Y du point

Voir aussi :

OpenGraph
SetAxisInc

Exemple :

OpenGraph graph "lines" "graphe d'essai" "X" "Y"

for i=1 10
   AddPoint graph i i*i/10
next i

Télécharger l'exemple


Graphe / ClearGraphWindows

ClearGraphWindows

Description :

Cette fonction permet d'effacer tous les graphes ouverts dans le programme PRiSM.

Syntaxe :

CLEARGRAPHWINDOWS


Graphe / DisplayGraph

DisplayGraph

Description :

Cette fonction permet

Syntaxe :

SETAXISINC NomPGM Inc

Variables :

Paramètres | Entrées / Sorties | Type | Description
 | Entrée | Graphe |
 | Entrée | Entier |

Voir aussi :
OpenGraph

Exemple :

Télécharger l'exemple


Graphe / OpenGraph

OpenGraph

Description :

Cette fonction permet de déclarer l'ouverture d'un graphe sous PRiSM avec une légende. Il existe différents types de graphes :

  • "Points" : pour une série de points
  • "Lines" : pour une courbe.

    • Syntaxe :
    OPENGRAPH NomPGM type$ Nom$ LabelX$ LabelY$

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
NomPGM | Entrée | Graphe | Nom interne du graphe à ouvrir dans le programme PGM
type$ | Entrée | Chaîne de caractères | type de graphe à tracer (voir ci-dessus)
Nom$ | Entrée | Chaîne de caractères | Légende du graphe
LabelX$ | Entrée | Chaîne de caractères | Ce qui est représenté sur l'axe des X
LableY$ | Entrée | Chaîne de caractères | Ce qui est représenté sur l'axe des Y

    Exemple :

    OpenGraph graph "lines" "graphe d'essai" "X" "Y"

Télécharger l'exemple


Graphe / SetGraphRange

SetGraphRange

Description :

Cette fonction permet de fixer les limites d'un graphe.
Ceci peut être fait automatiquement (sans paramètre) ou en fixant les paramètres ...

Syntaxe :
SETGRAPHRANGE
///OU///
SETGRAPHRANGE Xmin Xmax Ymin Ymax

Variables :

Paramètres | Entrées / Sorties | Type | Description
Xmin | Entrée | Réel | Limite inférieure de l'axe des abscisses
Xmax | Entrée | Réel | Limite supérieure de l'axe des abscisses
Ymin | Entrée | Réel | Limite inférieure de l'axe des ordonnées
Ymax | Entrée | Réel | Limite supérieure de l'axe des ordonnées

Exemple :

.........................................
OPENGRAPH GraphObjet "Lines" "Sinus" "JJ" "Mag."

SETGRAPHRANGE 0 20 0 2

Télécharger l'exemple


Graphe / SetAxisInc

SetAxisInc

Description :

Cette fonction permet de fixer la distance entre 2 indications (marquages) sur l'axe des Y.

Syntaxe :

SETAXISINC NomPGM Inc

Variables :

Paramètres | Entrées / Sorties | Type | Description
NomPGM | Entrée | Graphe | Nom interne du graphe à ouvrir dans le programme PGM
Inc | Entrée | Entier | Distance entre 2 indications sur l'axe des Y

Voir aussi :
OpenGraph

Exemple :

OpenGraph graph "lines" "graphe d'essai" "X" "Y"
.....................................
SetAxisInc graph 2

Télécharger l'exemple


Analyse / GetPoint

GetPoint

Description :

Cette fonction permet d'obtenir les coordonnées entières d'un pixel de l'image là où l'utilisateur pointe la souris. La position du pixel est renvoyé dans X et Y.

Syntaxe :

GETPOINT Img X Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Sortie | Entier | Position APPROXIMATIVE de l'étoile de référence suivant la coordonnée X en entier de pixel
Y | Sortie | Entier | Position APPROXIMATIVE de l'étoile de référence suivant la coordonnée Y en entier de pixel

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Open
GetImage

Exemple :

................................
GetImage Img

PRINT "Cliquer sur un objet ponctuel"
GetPoint Img X Y

PRINT "X entier = " X
PRINT "Y entier = " Y

Télécharger l'exemple


Visualisation / GetWindow

GetWindow

Description :

Cette fonction demande à l'utilisateur de sélectionner une fenêtre rectangulaire dans l'image.
La position de cette fenêtre est renvoyée dans les valeurs X1, Y1, X2, Y2 (Attention à l'ordre pour cette fonction !!!)

Syntaxe:
GETWINDOW Img X1 Y2 X2 Y1

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X1 | Sortie | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Sortie | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Sortie | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Sortie | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
Window
GetFixedWindow

Exemple :

......................................
PRINT "Dessine une fenêtre dans l'image"
GetWindow Img X1 Y2 X2 Y1
Print "Fenêtre : Coordonnées des coins X1=" X1 " Y1=" Y1 " X2=" X2 " Y2=" Y2

Télécharger l'exemple


Visualisation / GetFixedWindow

GetFixedWindow

Description :

Cette fonction permet de bouger un rectangle sur l'écran.
Quand l'utilisateur clique sur le bouton gauche de la souris, les coordonnées de la fenêtre sont renvoyées dans les valeurs X1, Y1, X2, Y2 (Attention à l'ordre !!!). Ces paramètres sont des paramètres d'entrées à l'appel de la fonction pour fixer la taille du rectangle à déplacer, mais ces paramètres restent globaux : ils seront changés lorsque le rectangle aura été bougé et feront office de paramètres de sortie.

Syntaxe :

GETFIXEDWINDOW Img X1 Y2 X2 Y1

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X1 | Entrée / Sortie | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée /Sortie | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée / Sortie | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée / Sortie | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
GetWindow

Exemple :

......................................
PRINT "Bouger ce rectangle"
GetFixedWindow Img X1 Y2 X2 Y1
........................................

Télécharger l'exemple


Visualisation / SizeWindowX

SizeWindowX

Description :

Cette fonction permet de fixer la taille horizontale d'une image. L'utilisateur pourra alors voir ensemble les images et la fenêtre de script.

Syntaxe :

SIZEWINDOWX Img Larg

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Larg | Entrée | Entier | Largeur visible de l'image en pixel

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetScreenX LargEcran

SizeWindowX img LargEcran-400

Télécharger l'exemple


Visualisation / SizeWindowY

SizeWindowY

Description :

Cette fonction permet de fixer la taille verticale d'une image. L'utilisateur pourra alors voir ensemble les images et la fenêtre de script.

Syntaxe :

SIZEWINDOWY Img Long

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Long | Entrée | Entier | Longueur visible de l'image en pixel

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetScreenY LongEcran

SizeWindowY img LongEcran-200

Télécharger l'exemple


Visualisation / Window

Window

Description :

Cette fonction permet de fenêtrer une image.

Syntaxe :

WINDOW Img X1 Y2 X2 Y1

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X1 | Entrée | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
GetWindow

Exemple :

......................................
GetWindow Img X1 Y2 X2 Y1
Window Img X1 Y2 X2 Y1

Télécharger l'exemple


Visualisation / SetWindowPos

SetWindowPos

Description :

Cette fonction permet de déplacer en apparence, par rapport à sa position initiale, une image affichée sur l'écran. Ce déplacement a lieu d'un certain nombre de pixels horizontalement et vertical précisé par l'utilisateur.

Syntaxe :

SETWINDOWPOS Img X Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
X | Entrée | Entier | Déplacement horizontal de l'image sur l'écran
Y | Entrée | Entier | Déplacement vertical de l'image sur l'écran

Voir aussi :

Exemple :

PRINT "Ouvrir Image"
GetImage Img1

SETWINDOWPOS Img1 50 50

Télécharger l'exemple


Visualisation / AddStar

AddStar

Description :

Cette fonction permet de créer une étoile avec plusieurs caractéristiques sur une image.

Syntaxe
ADDSTAR Img X Y Intensitypeak SigW SigH Angle Flux

Variables :

Paramètre | Entrées / Sorties | type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier / Réel | Position EXACTE du centre de l'étoile suivant X
Y | Entrée | Entier / Réel | Position EXACTE du centre de l'étoile suivant Y
Intensitypeak | Entrée | Entier | Valeur du pic d'intensité de l'étoile en ADU
SigW | Entrée | Réel | Plus grande largeur à mi-hauteur ( FWHM ) de l'étoile
SigH | Entrée | Réel | Plus petite FWHM de l'étoile
Angle | Entrée | Réel | Direction de l'étoile dépendant de la plus grande FWHM ( en radians )
Flux | Sortie | Réel | Flux total de l'étoile en ADU

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

NewImage
DelStar

Exemple :

REM Créer l'image
NewImage Img "Essai" 300 300 3 164

REM Ajouter l'étoile
AddStar Img 100.123 100.456 14300 3.38 2.69 0 Flux

REM Afficher le flux
Print "Flux de l'étoile = " Flux

Télécharger l'exemple


Visualisation / AddStarB

AddStarB

Description :

Cette fonction permet de créer une étoile avec plusieurs caractéristiques sur une image, ayant subi un bougé
Ceci permet de simuler un bougé pendant l'acquisition, par exemple !

Syntaxe :

ADDSTARB Img X Y Intensitypeak SigW SigH Angle Move Flux

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier / Réel | Position EXACTE du centre de l'étoile suivant X
Y | Entrée | Entier / Réel | Position EXACTE du centre de l'étoile suivant Y
Intensitypeak | Entrée | Entier | Valeur du pic d'intensité de l'étoile en ADU
SigW | Entrée | Réel | Plus grande largeur à mi-hauteur ( FWHM ) de l'étoile
SigH | Entrée | Réel | Plus petite FWHM de l'étoile
Angle | Entrée | Réel | Direction de l'étoile dépendant de la plus grande FWHM ( en radians )
Move | Entrée | Réel | Bougé de l'étoile en pixel ou en fraction de pixel
Flux | Sortie | Réel | Flux total de l'étoile en ADU

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

NewImage
DelStar

Exemple :

REM Créer l'image
NewImage Img "Essai" 300 300 3 164

REM Ajouter l'étoile
AddStar Img 100.123 100.456 14300 3.38 2.69 0 3.3 Flux

REM Afficher le flux
Print "Flux de l'étoile = " Flux

Télécharger l'exemple


Visualisation / DelStar

DelStar

Description :

Cette fonction permet d'effacer une étoile dans une image.
Toutes les caractéristiques de l'étoile doivent être fournies. Il est donc conseillé de modéliser l'étoile par une gaussienne auparavant pour avoir ses caractéristiques totales.

Syntaxe :

DELSTAR Img X Y DemLarg PosX PosY SigW SigH Angle FluxEtalon Omc Homc Err

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant X en entier de pixel
Y | Entrée | Entier | Position APPROXIMATIVE de l'étoile à modéliser suivant Y en entier de pixel
Dem_Larg | Entrée | Entier | Demi-Largeur de la fenêtre à considérer autour de l'étoile
PosX | Entrée | Entier / Réel | Position EXACTE de l'étoile à modéliser suivant X en fraction de pixel
PosY | Entrée | Entier / Réel | Position EXACTE de l'étoile à modéliser suivant Y en fraction de pixel
SigW | Entrée | Réel | Plus grande largeur à mi-hauteur ( FWHM ) de l'étoile
SigH | Entrée | Réel | Plus petite FWHM de l'étoile
Angle | Entrée | Réel | Direction de l'étoile dépendant de la plus grande FWHM ( en radians )
Flux | Entrée | Réel | Flux total de l'étoile en ADU
Omc | Entrée | Réel | Différence O-C, entre l'observé et le calculé
HOmc | Entrée | Réel | Rapport Signal / Bruit
Err | Entrée | Entier | Erreur estimée sur le flux de l'étoile modélisée

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
NewImage
CentroideGauss

Exemple :

...........................................
print "PosX=" PosXf " PosY=" PosYf " RS/B=" Note

DELSTAR img1 Posxf Posyf lf PosX PosY SigX SigY Angle Flux Omc HOmc Err

AutoVisu img1
.........................................

Télécharger l'exemple


Visualisation / EraseStarPSF

EraseStarPSF

Description :

Cette fonction permet de supprimer une étoile à partir de sa modélisation par une gaussienne. Le résultat n'est pas "sensationnel" car la moindre variation d'un paramètre de la gaussienne provoque une large sur-correction ou sous-correction.

Cette fonction prend toute son utilité dans le cas suivant : lors de la modélisation gaussienne de 2 étoiles proches, la modélisation sera réalisée sur l'étoile la plus brillante des deux. En supprimant l'étoile la plus brillante, la modélisation aura alors forcément lieu sur l'étoile la moins brillante.

Syntaxe
ERASESTARPSF Img X Y Dem_Larg

Variables :

Paramètre | Entrées / Sorties | type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Entier / Réel | Position EXACTE du centre de l'étoile suivant X
Y | Entrée | Entier / Réel | Position EXACTE du centre de l'étoile suivant Y
Dem_Larg | Entrée | Entier | Demi largeur de la fenêtre de tracé de PSF

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / non | oui / oui

Voir aussi :

DelStar

Exemple :

REM Test de la fonction ERASESTARPSF
GetImage Img

GETPOINT Img MesureX MesureY

DemiLargFen=4
EraseStarPSF Img MesureX MesureY DemiLargFen

Télécharger l'exemple


Visualisation / AutoVisu

AutoVisu

Description :

Cette fonction permet de régler automtiquement les seuils de visualisation d'une image.
Ces seuils sont déterminés à partir du menu " Options / Options de visualisation ".

Syntaxe :

AUTOVISU Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img

AUTOVISU Img

Télécharger l'exemple

Image de test :

Champ stellaire.


Visualisation / Visu

Visu

Description :

Cette fonction permet de régler les seuils de visualisation bas et haut d'une image.

Syntaxe :

VISU Img UpThreshold LowThreshold

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
UpThreshold | Entrée | Entier / Réel | Seuil haut au dessus duquel le pixel sera blanc
LowThreshold | Entrée | Entier / Réel | Seuil bas en dessous duquel le pixel sera noir

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img

Input "Lower Threshold :" LT
Input "Upper Threshold :" UT

VISU Img UT LT

Télécharger l'exemple


Visualisation / Blink

Blink

Description :

Cette fonction permet d'exécuter le blink ( clignotement ) d'une liste d'images.

Syntaxe :

BLINK Img1 Img2 [Img3 [Img4 [...]]] Speed

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img? | Entrée | Image | Nom interne de l'image au programme PGM que l'utilisateur désire comparer avec les autres
Speed | Entrée | Entier | Temps durant lequel l'image est affichée en millisecondes

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img1
GetImage Img2

Blink Img1 Img2 250

Télécharger l'exemple


Transformation / ClipH

ClipH

Description :

Cette fonction permet de seuiller haut une image.
Les pixels dont la valeur ( en ADU ) est supérieure à "UPTHRES" sont égalisés à UpThres.

Syntaxe :

CLIPH Img UpThres [Imaginaire]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
UpThres | Entrée | Entier / Réel / Complexe ( partie réelle ) | Fixe la valeur supérieure en ADU des pixels
[Imaginaire] | Entrée | Entier / Réel | Paramètre optionnel afin de fixer la partie imaginaire du complexe si l'image est codée en complexe

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
INPUT "Seuil supérieur de l'image ? " SeuilHaut

ClipH Img SeuilHaut

Télécharger l'exemple


Transformation / ClipL

ClipL

Description :

Cette fonction permet de seuiller BAS une image.
Les pixels dont la valeur ( en ADU ) est inférieure à "LOWTHRES" sont égalisés à LowThres.

Syntaxe :

CLIPL Img LowThres [Imaginaire]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
LowThres | Entrée | Entier / Réel / Complexe ( partie réelle ) | Fixe la valeur inférieure en ADU des pixels
[Imaginaire] | Entrée | Entier / Réel | Paramètre optionnel afin de fixer la partie imaginaire du complexe si l'image est codée en complexe

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
INPUT "Seuil inférieur de l'image ? " SeuilBas

ClipL Img SeuilBas

Télécharger l'exemple


Images couleurs et APN / ThresHold

Threshold

Description :

Cette fonction permet se seuiller haut ou bas une image monochrome ou une image couleur RVB.
Dans le cas d'une image monochrome, les valeurs sont à indiquer une fois. Dans le cas d'une image trichrome, si seule une série de valeurs est donnée, ceci ne provoquera pas d'erreur script mais la série sera appliquée à la couleur R. Cependant, il est conseillé dans ce cas de fournir 3 valeurs.

Syntaxe :

THRESHOLD Img HighBool ValueThr [ValueThr] [ValueThr] NewValue [NewValue] [NewValue]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
HighBool | Entrée | Booléen | Si le seuillage est haut, mettre cette valeur à 1. Si le seuillage est bas, mettre cette valeur à 0.
ValueThr | Entrée | Entier / Réel | Valeur à seuiller en grandeur supérieure (seuillage haut) ou en grandeur inférieure (seuillage bas).
[ValueThr] | Entrée, Optionnelle | Entier / Réel | Dans le cas d'une image RVB, les trois valeurs de seuillage suivant : R, V ou B sont à fournir.
NewValue | Entrée | Entier / Réel | Nouvelle valeur à donner au pixel pour ceux qui seront remplacés.
[NewValue] | Entrée,optionnelle | Entier / Réel | Dans le cas d'une image RVB, les trois valeurs de remplacement suivant : R, V ou B sont à fournir.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
INPUT "Seuillage haut (O/N) ?" R$
If R$="O" Then
   HighBool=1
Else
   HighBool=0
EndIf

Input "Valeur de seuillage :" VS
Input "Nouvelle valeur :" NV

THRESHOLD Img HighBool VS NV

Télécharger l'exemple


images couleurs ou APN / Balance_Bayer

Balance_Bayer

Description :

Cette fonction permet de créer une image de type RAW dont la balance des couleurs est modifiée. Cette image provient d'une image CPA monochrome, cette dernière résultant par exemple d'une image RAW d'un APN ayant subie une conversion au format CPA.
Le motif de la matrice de Bayer doit être indiqué par valeurs entières de 1 à 4, correspondant aux motifs rencontrés dans l'onglet "images couleurs APN (Bayer 2Bis)" du menu "Prétraitements / Enlever Offset, Noir, Flat (Auto)".
Les valeurs de chaque couleur peuvent être dosées avant d'appliquer la commande script DEBAYER. Pour les pixels associés aux couleurs R et B, la valeur résultante est égale à (ValeurIni - Offset) * Coef. Lorsqu'un offset est donné aux pixels associés à V, ce sont les pixels R et B qui augmentent leur valeur de 2 * offset. Ces opérations permettent de retranscrire la balance des blancs, celle utilisées naturellement avant que l'APN fournisse une image couleur comme celle de tous les jours.

Syntaxe :

BALANCE_BAYER Img Motif OffsetR CoefR OffsetV OffsetB CoefB

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | Nom interne au PGM de l'image monochrome (type RAW)
Motif | Entrée | Entier (de 1 à 4) | Motif de la matrice de Bayer
OffsetR | Entrée | Entier / Réel | Offset à soustraire aux valeurs des pixels R avant de multiplier par CoefR
CoefR | Entrée | Réel | Coefficient multiplicateur sur les pixels R
OffsetV | Entrée | Entier / Réel | Offset à soustraire aux valeurs des pixels V; en réalité, la valeur est augmentée pour les pixels R et B.
OffsetB | Entrée | Entier / Réel | Offset à soustraire aux valeurs des pixels R avant de multiplier par CoefB
CoefB | Entrée | Réel | Coefficient multiplicateur sur les pixels B

Voir aussi :
DeBayer

Exemple :

.....................................
REM Appliquer la balance R=1.6 , V=1 et B=2
offsetR=0
CoefR=1.6
offsetV=0
offsetB=0
CoefB=2.0

BALANCE_BAYER Img Motif OffsetR CoefR OffsetV OffsetB CoefB

Télécharger l'exemple


Images Couleurs / Combine_Color_Img

Combine_Color_Img

Description :

Cette fonction combine plusieurs images vers une seule image.
Les images de départ peuvent avoir n'importe quel format ( sauf en couleur !). Cependant, Le type de données dans les images doivent être identiques.
Attention : l'image est à sauvegarder APRES combinaison. Elle n'est qu'en mémoire dans PRiSM.

Syntaxe :

COMBINE_COLOR_IMG Img_OUT ImgR ImgV ImgB

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img_OUT | Sortie | image | Nom interne de l'image dans le PGM résultant de la combinaison des 3 plans
ImgR | Entrée | image | Plan rouge de la future image
ImgV | Entrée | image | Plan vert de la future image
ImgB | Entrée | image | Plan bleu de la future image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Split_Color_Img

Exemple :

PRINT "Plan rouge"
GetImage ImgR

PRINT "Plan vert"
GetImage ImgV

PRINT "Plan bleu"
GetImage ImgB

COMBINE_COLOR_IMG IMG ImgR ImgV ImgB

Télécharger l'exemple


Images couleurs et APN / Debayer

DeBayer

Description :

Cette fonction permet de créer une image RVB à partir de l'image RAW fournie par l'appareil numérique (convertie au format propriétaire PRiSM CPA à l'aide du menu "Fichier / Conversion de format de ficbiers par lot"). L'image fournie doit forcément être monochrome.
Il est nécessaire de connaître le type de matrice Bayer utilisé pour le capteur de l'APN. Il faut choisir parmi les quatre filtres connus par PRiSM et reconnaissable à partir de l'onglet "Images couleurs APN (Bayer 2bis)" de la fonction "Prétraitements / Enlever Offet, Noir, Flat (auto)". Si les couleurs primaires utilisées sont Cyan-Magenta-Jaune, il faut transformer avant d'appliquer le motif dans l'espace des couleurs RVB (Rouge-Vert-Bleu). Il faut alors l'indiquer au programme.

Syntaxe :

DEBAYER Img Motif CMYBool

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | Nom interne au PGM de l'image
Motif | Entrée | Entier (de 1 à 4) | Motif RVB utilisé pour la matrice de Bayer
CMYBool | Entrée | Booléen | Si les couleurs primaires utilisées sont le Cyan, Magenta et Jaune, mettre cette valeur à 1 sinon la mettre à 0.

Voir aussi :

Exemple :

.......................................
PRINT "Fournir l'image CPA monochrome"
GetImage Img

Motif=2
CMYBool=0

DEBAYER Img Motif CMYBool

Télécharger l'exemple


Images Couleurs / Split_Color_Img

Split_Color_Img

Description :

Cette fonction permet de séparer les différents plans R, V et B d'une image couleur.
L'image de départ doit bien sûr est une image couleur au format CPA.
Attention : les images sont à sauvegarder APRES séparation. Elles ne seront qu'en mémoire dans PRiSM.

Syntaxe :

SPLIT_COLOR_IMG Img ImgR ImgV ImgB

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
ImgR | Sortie | image | Plan rouge de Img
ImgV | Sortie | image | Plan vert de Img
ImgB | Sortie | image | Plan bleu de Img

Voir aussi :
Combine_Color_Img

Exemple :

................................
if i=1 then
  SPLIT_COLOR_IMG img imgS imgV imgB
  INT2REAL ImgS
else
................................................

Télécharger l'exemple


Images Couleurs et APN / SplitBayerImg

SPLITBAYERIMG

Description :

Cette fonction charge une image d'APN qui a une matrice de bayer. Selon le motif de Bayer choisi, la fonction renvoie 3 images R, V et B brutes en les affichant à l'écran. Ces dernières ne sont par défaut pas sauvegardées.
Ceci permet de respecter le "filtre" devant chaque pixel de la matrice. Il est possible de regarder la forme des matrices dans un des onglets dans le menu "Prétraitement / Auto". Il ne faut donc pas être étonné de voir des images de dimensions en rapport avec le nombre de pixels de couleurs considérées dans un carré de 2x2 pixels.

Attention, il faut utiliser une image monochrome en entrée.

Syntaxe :

SPLITBAYERIMG Img_In Motif Img_Out_R Img_Out_V Img_Out_B

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img_In | Entrée | image | Nom interne de l'image à traiter
Motif | Entrée | Entier (de 1 à 4) | Motif de Bayer de la matrice
Img_Out_R | Sortie | image | Plan rouge de la future image
Img_Out_V | Sortie | image | Plan vert de la future image
Img_Out_B | Sortie | image | Plan bleu de la future image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
Split_Color_Img

Exemple :

PRINT "Plan rouge"
GetImage ImgR

PRINT "Plan vert"
GetImage ImgV

PRINT "Plan bleu"
GetImage ImgB

COMBINE_COLOR_IMG IMG ImgR ImgV ImgB

Télécharger l'exemple


Fichiers / Open

Open

Description :

Cette fonction permet d'ouvrir une image dans un script en donnant le chemin complet pour atteindre l'image. L'image portera un nom dans le script permettant de la repérer.
Le format de l'image doit être CPA, FITS, PIC, STX, BMP ou JPEG.

Syntaxe :

OPEN Img Chem$ [MINIMIZE]

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | Nom de l'image dans le script lors de l'appel de cette dernière
Chem$ | Entrée | Chaîne de caractères | Chemin complet pour atteindre l'image
MINIMIZE | Entrée | tel quel ... | Paramètre optionnel afin de minimiser l'image à l'ouverture pour ne pas encombrer l'écran.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
GetImage
OpenFree

Exemple :

Input "Nom de l'image : " Name$
GetRepName Directory$
    Open Image Directory$+Name$
    /// OU ///
    Open Image Directory$+Name$ MINIMIZE

Télécharger l'exemple


Fichiers / OpenFree

OpenFree

Description :

Cette fonction permet d'ouvrir toute sorte d'image dans un script. Ceci permet d'importer sous PRiSM des formats propriétaires provenant d'images sauvegardées à partir de caméra non implémentées dans PRiSM.

La variable "Motorola" est égale à 0 pour un PC (= FALSE) et sinon égale à 1 (= TRUE) si les octets sont rangés dans l'ordre Mototrola.

La variable "type" peut prendre plusieurs valeurs possibles :

  • =1 pour 8 octets non signés.
  • =2 pour 8 octets signés.
  • =3 pour 16 octets non signés.
  • =4 pour 16 octets signés.
  • =5 pour 32 bits signés.
  • = 6 pour des pixels de format single (réels) sur 4 octets.
  • = 7 pour des pixels de format Real (réels) sur 6 octets.
  • = 8 pour des pixels de format Double (réels) sur 8 octets.

Pour les différents intervalles autorisés pour chaque type, l'utilisateur se reportera à la fonction "Fichier/Importer/Image au format libre".

Syntaxe :
OPENFREE Img Chem$ LargX LargY Prop Kind Motorola

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | Nom de l'image dans le script lors de l'appel de cette dernière
Chem$ | Entrée | Chaîne de caractères | Chemin complet pour atteindre l'image
LargX | Entrée | Entier | Taille de l'image suivant X
LargY | Entrée | Entier | Taille de l'image suivant Y
Prop | Entrée | Entier | Taille réservée à l'entête du fichier (en octets)
Kind | Entrée | Entier | type de données (voir commentaires)
Motorola | Entrée | Entier | Si les octets sont organisés du type Motorola ou non

Voir aussi :
GetImage
Open

Exemple :

REM Here for an acquisition with a SBIG ST4

Input "Name of image : " Name$
GetRepName Directory$
Prop=0
Motorola=0
LargX=192
LargY=164
Kind=1
type=1

OpenFree Img1 Directory$+Name$ LargX LargY Prop Kind Motorola

Télécharger l'exemple


Fichiers / GetImage

GetImage

Description :

Cette fonction permet de déclarer et de nommer une image dans un script. Ainsi, une boîte de dialogue est ouverte pour donner le chemin où obtenir l'image. Dans le même temps, l'image est affichée à l'écran. Cette fonction est plus simple que "GetRepName"+"Open" pour une unique image à ouvrir.
Le format de l'image doit être CPA, FITS, PIC, STX, BMP ou JPEG.

Syntaxe :

GETIMAGE Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | Nom de l'image dans le script lors de l'appel de cette dernière

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
Open
OpenFree

Exemple :

GetImage Img

Télécharger l'exemple


Fichiers / OpenBMP

OpenBMP

Description :

Cette fonction permet d'ouvrir une image BMP dans un script en donnant le chemin complet pour atteindre l'image. Attention : il n'y a cependant pas de variable Image associée à cette fonction !

Syntaxe :

OPENBMP Img Chem$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Sortie | Image | Futur nom interne de l'image dans le programme PGM, une fois importée !
Chem$ | Entrée | Chaîne de caractères | Chemin complet pour atteindre l'image

Voir aussi :
GetImage
OpenFree

Exemple :

Input "Nom de l'image : " Name$
GetRepName Directory$

OpenBMP Img Directory$+Name$

Télécharger l'exemple


Visualisation / Duplicate

Duplicate

Description :

Cette fonction permet de dupliquer une image de manière interne au PGM.
Attention, cette image ne sera pas sauvegardée sur le disque dur !

Syntaxe :

DUPLICATE Img NewImg

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
NewImg | Entrée | Image | Nom interne au PGM de l'image identique à "IMG"

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img

Duplicate Img NewImage

Close Img
REM L'image de travail porte désormais le nom de NewImage

Télécharger l'exemple


Fichier / NewImage

NewImage

Description :

Cette fonction permet de créer une image vierge en vue de futur test avec les fonctions scripts
Le type d'image peut être divers et est défini par la variable d'entrée "type" :
type=2 pour Entier court (byte)
type=3 pour Entier
type=6 pour Réel
type=11 pour Complexe

Syntaxe :

NEWIMAGE Img Name$ LargX LargY type Level

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name$ | Entrée | Chaîne de caractères | Nom de l'image
LargX | Entrée | Entier | Largeur de l'image suivant X
LargY | Entrée | Entier | Largeur de l'image suivant Y
type | Entrée | Entier | type d'image
Level | Entrée | Entier / Réel / Complexe | Niveau d'Offset de l'image ( réel, entier ou complexe)

Voir aussi :
Open

Exemple :

................................
INPUT "Nom de l'image" Name$
NewImage Img Name$ 512 512 2 216

Télécharger l'exemple


Fichier / SelectImg

SelectImg

Description :

Cette fonction demande à l'utilisateur de sélectionner une image parmis celles déja ouvertes.
L'image est renvoyée dans la variable logique "Image" sous son nom donnée dans le script (On rappelle que le nom script d'une image correspond à une adresse pointant vers le répertoire et le nom du fichier image).
Ce nom peut être réutilisé par la suite pour d'autres opérations.

Syntaxe :

SELECTIMG ImgSelect

Variables :

Paramètres | Entrées / Sorties | Type | Description
ImgSelect | Entrée | Image | Nom de l'image sélectionnée

Voir aussi :

Exemple :

PRINT "Image n°1 :"
GETIMAGE Img1

PRINT "Image n°2 :"
GETIMAGE Img2

PRINT "Image à fermer ?"
SELECTIMG Image
CLOSE Image

Télécharger l'exemple


Fichier / ClearImgWindows

ClearImgWindows

Description :

Cette fonction permet d'effacer toutes les images ouvertes dans le programme PRiSM.

Syntaxe :

CLEARIMGWINDOWS


Fichier / Close

Close

Description :

Cette fonction permet de fermer une image dans un script.

Syntaxe :

CLOSE Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
ClearImgWindows

Exemple :

......................................
Print "Flux=" Flux
Print "Mediane="  Mediane

Close Img

Télécharger l'exemple


Fichier / FileExists

FileExists

Description :

Cette fonction permet de connaître l'existence d'un fichier.
Renvoie TRUE si le fichier existe ou FALSE sinon.

Syntaxe :

FILEEXISTS File$ YesNo

Variables :

Paramètres | Entrées / Sorties | Type | Description
File$ | Entrée | Chaîne de caractères | Chemin complet ( répertoire + nom ) de l'image qui doit être trouvée
YesNo | Sortie | Booléen | Résultat de la recherche


Fichier / Delete

Delete

Description :

Cette fonction permet d'effacer un fichier.

Syntaxe :

DELETE File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
File$ | Entrée | Chaîne de caractères | Chemin complet ( répertoire + nom ) de l'image qui doit être effacée

Voir aussi :
ClearImgWindows
Close


Fichier / GetRepDir

GetRepDir

Description :

Cette fonction permet d'obtenir la liste des fichiers correpondant à une extension particulière.

Syntaxe :

GETREPDIR chemin$ filtre$ fichiers$ nb_fichiers

Variables :

Paramètres | Entrées / Sorties | Type | Description
chemin$ | Entrée | Chaîne de caractères | Chemin du répertoire d'exploration.
filtre$ | Entrée | Chaîne de caractères | filtre d'extension type "*.cpa" ou "*.fits"
fichiers$ | Sortie | Table de chaîne de caractères | Liste du chemin d'accès complet des fichiers concernés
nb_fichiers | Sortie | Entier | Nombre de fichiers retenus

Voir aussi :

.

Exemple :

................................
GETREPDIR chemin$ filtre$ fichiers$ nb_fichiers

Print "Fichiers trouvés : " nb_fichiers
.................................
Télécharger l'exemple


Fichier / GetRepDirAll

GetRepDirAll

Description :

Cette fonction permet d'obtenir la liste des fichiers correpondant à une extension particulière dans le répertoire fourni ainsi que dans les sous-répertoires de ce répertoire.

Syntaxe :

GETREPDIRALL chemin$ filtre$ fichiers$ nb_fichiers

Variables :

Paramètres | Entrées / Sorties | Type | Description
chemin$ | Entrée | Chaîne de caractères | Chemin du répertoire d'exploration (à partir duquel seront cherchés les sous-répertoires).
filtre$ | Entrée | Chaîne de caractères | filtre d'extension type "*.cpa" ou "*.fits"
fichiers$ | Sortie | Table de chaîne de caractères | Liste du chemin d'accès complet des fichiers concernés
nb_fichiers | Sortie | Entier | Nombre de fichiers retenus

Voir aussi :

.

Exemple :

................................
GETREPDIRALL chemin$ filtre$ fichiers$ nb_fichiers

Print "Fichiers trouvés : " nb_fichiers
.................................
Télécharger l'exemple


Fichiers / AssignName

AssignName

Description :

Cette fonction permet de donner un nom à l'image (qui sera en général le nom de sauvegarde de l'image) ainsi qu'un nom générique.

Syntaxe :

ASSIGNNAME Img Titre1$ Titre2$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le script
Titre1$ | Entrée | Chaîne de caractères | Titre de l'image qui sera celui de sauvegarde
Titre2$ | Entrée | Chaîne de caractères | Titre de l'image qui sera le nom du groupe

Exemple :

REM Test de la fonction ASSIGNNAME

GetImage Img

ASSIGNNAME Img "Titre1" "Titre2"

Télécharger l'exemple


Fichier / SaveBMP

SaveBMP

Description :

Cette fonction permet de sauvegarder une image au format BMP. Il faudra que l'image ait comme nom de famille ".bmp".

Syntaxe :

SAVEBMP Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".bmp"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
SaveCPA

Exemple :

......................................
Open Image Directory$+Name$

SaveBMP Image Directory$+"Test.bmp"
........................................

Télécharger l'exemple


Fichier / SaveCPA

SaveCPA

Description :

Cette fonction permet de sauvegarder une image au format CPA. Il faudra que l'image ait comme nom de famille ".cpa".

Syntaxe :

SAVECPA Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".cpa"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
SaveFit

Exemple :

......................................
Open Image Directory$+Name$

SaveCPA Image Directory$+"Test.cpa"
........................................

Télécharger l'exemple


Fichier / SaveFIT

SaveFIT

Description :

Cette fonction permet de sauvegarder une image au format FITS. L'image aura comme nom de famille ".fits".

Syntaxe :

SAVEFIT Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".fit"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
SaveCPA

Exemple :

......................................
Open Image Directory$+Name$

SaveFIT Image Directory$+"Test.fit"
........................................

Télécharger l'exemple


Fichier / SaveFITS1D

SaveFITS1D

Description :

Cette fonction permet de sauvegarder une image au format FITS1D; ceci est valable pour des profils spectroscopiques. L'image aura comme nom de famille ".fits" et sa valeur NAXIS sera de 1.

Syntaxe :

SAVEFITS1D Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".fits"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :
SaveCPA

Exemple :

......................................
Open Image Directory$+Name$

SaveFITS1D Image Directory$+"Test.fits"
........................................

Télécharger l'exemple


Fichier / SaveJPG

SaveJPG

Description :

Cette fonction permet de sauvegarder une image au format JPG.
Il faudra que l'image ait comme nom de famille ".bmp". La qualité de la compression se règle avant dans le menu "Option / Options générales de PRiSM".

Syntaxe :

SAVEJPG Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".jpg"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
SaveCPA

Exemple :

......................................
Open Image Directory$+Name$

SaveJPG Image Directory$+"Test.jpg"
........................................

Télécharger l'exemple


Fichier / SaveGIF

SaveGIF

Description :

Cette fonction permet de sauvegarder une image au format GIF.

Syntaxe :

SAVEGIF Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".gif"

Voir aussi :
SaveCPA

Exemple :

......................................
Open Image Directory$+Name$

SaveGIF Image Directory$+"Test.gif"
........................................

Télécharger l'exemple


Fichier / SaveTIFF

SaveTIFF

Description :

Cette fonction permet de sauvegarder une image au format TIFF 8 bits ou 16 bits (voir l'option à régler). Il faudra que l'image ait comme nom de famille ".tiff".

Syntaxe :

SAVETIFF Img Name_File$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Name_File$ | Entrée | Chaîne de caractères | Chemin total où sauvegarder l'image A terminer par ".bmp"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
SaveBMP

Exemple :

......................................
Open Image Directory$+Name$

SaveTIFF Image Directory$+"Test.tiff"
........................................

Télécharger l'exemple


Fichier / SetLoadFITsToFloating

SetLoadFITsToFloating

Description :

Cette fonction force les fichiers d'images FITS à être chargées sous le format flottant.

Syntaxe :

SETLOADFITSTOFLOATING Bool

Variables :

Paramètres | Entrées / Sorties | Type | Description
Bool | Entrée | Booléen | Obligation de faire la conversion ou non

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | non / oui

Voir aussi :

Exemple :

................................
SetLoadFITsToFloating TRUE

PRINT "Télécharger une image au foramt FITS"
GetImage Img

Télécharger l'exemple


Fichier / SetTransformRescaleFITsDynamic

SetTransformRescaleFITsDynamic

Description :

Cette fonction correspond à l'option de PRiSM dasn le menu "Option / Option de chargement des fichiers FITS-CPA" : Facteur de rééchantillonnage de la dynamqiue des fichiers FITS 16 bits non signés.
En effet, un fichier FITS 16 bits non signés est échantillonné de 0 à 65 535 ADU. Or, le format CPA étant en 16 bits signés est échantillonné de - 32 767 à + 32 767. Pour une telle image, si le facteur est choisi à 1, tous les pixels de l'image FITS qui auront une intensité supérieure à 32 767 ADU seront fixés à 32 767. Par contre, dans le cas d'un facteur fixé à 0.5, toute la dynamique de l'image FITS apparaîtra entre 0 et 32767. Dans ce dernier cas, l'intensité de tous les pixels de l'image FITS sera divisée par 2.

Syntaxe :

SETTRANSFORMRESCALEFITSDYNAMIC Factor

Variables :

Paramètres | Entrées / Sorties | Type | Description
Factor | Entrée | Réel | Facteur de compression de l'intensité de l'image FITS

Voir aussi :

Exemple :

PRINT "Ouvrir une image FITS"
GetImage Img

SETTRANSFORMRESCALEFITSDYNAMIC 0.5

SAVECPA Img "C:\Toto.cpa"

Télécharger l'exemple


Fichier / Copy

Copy

Description :

Cette fonction permet de copier un fichier image dans un autre ( inexistant ).

Syntaxe :

COPY Name1$ Name2$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Name1$ | Entrée | Chaîne de caractères | Chemin complet ( répertoire + nom ) où PRiSM peut trouver l'image à copier
Name2$ | Entrée | Chaîne de caractères | Chemin complet ( répertoire + nom ) où PRiSM doit copier l'image "Name1$"

Voir aussi :

Exemple :

Télécharger l'exemple


Fichier / Rename

Rename

Description :

Cette fonction permet de renommer le fichier correspondant à une image en indiquant le chemin complet où est sauvegardé cette dernière.

Syntaxe :

RENAME file$ new_file$

Variables :

Paramètres | Entrées / Sorties | Type | Description
file$ | Entrée | Chaîne de caractères | Chemin complet ( répertoire + nom ) où PRiSM peut trouver l'image à renommer
new_file$ | Entrée | Chaîne de caractères | Chemin complet ( répertoire + nom ) où PRiSM doit renommer l'image "file$"


Fichiers / ExecExternal

ExecExternal

Description :

Cette fonction permet d'ouvrir un programme totalement extérieur à PRiSM avec des paramètres d'ouverture.
A l'aide des fonctions SCRIPT de lecture et d'écriture dans un fichier (cf. 4.3.8) , il est alors possible de passer des valeurs de variables du PGM dans un programme extérieur.

Syntaxe :

EXECEXTERNAL NomFichier$ param$

Variables :

Paramètres | Entrées / Sorties | Type | Description
NomFichier$ | Entrée | Chaîne de caractères | Chemin complet où trouver le programme externe
param$ | Entrée | Chaîne de caractères | paramètre(s) supplémentaire(s) à fournir au programme externe au lancement de ce dernier. En cas d'absence des ces derniers, indiquer "" à la place de param$.

Exemple :

.................................................
ExecExternal "C:\Astro\EXTERNE.EXE" "C:\essai.dat"

Télécharger l'exemple


Fichiers / GetFTP

PutFTP

Description :

Cette fonction permet de récupérer un fichier directement sur un site FTP.
Un minimum d'information doit être fourni au script !

Syntaxe :

GETFTP hostname$ UserName$ password$ ModeTRSF DirRemote$ fileRemote$ LocalDir$ Localfilename$

Variables :

Paramètres | Entrées / Sorties | Type | Description
hostname$ | Entrée | Chaîne de caractères | Chemin d'accès au site FTP
UserName$ | Entrée | Chaîne de caractères | Nom d'utilisateur
password$ | Entrée | Chaîne de caractères | Mot de passe
ModeTRSF | Entrée | Booléen | Mode de transfert : 0 = Binaire et 1 = ASCII.
DirRemote$ | Entrée | Chaîne de caractères | Répertoire de copie sur le site FTP.
FileRemote$ | Entrée | Chaîne de caractères | Nom complet du fichier à récupérer par le FTP.
LocalDir$ | Entrée | Chaîne de caractères | Répertoire du disque local où copier le fichier.
Localfilename$ | Entrée | Chaîne de caractères | Nom complet à donner au fichier lors de sa copie.

Exemple :

.................................................
DirRemote$="\images\"

GETFTP hostname$ userName$ password$ ModeTRSF DirRemote$ fileRemote$ LocalDir$ Localfilename$

Télécharger l'exemple


Fichier / GetScreenX

GetScreenX

Description :

Cette fonction donne la largeur d'un écran en pixels.
Cette valeur dépend de la résolution choisie sous Windows.

Syntaxe :

GETSCREENX Width

Variables :

Paramètres | Entrées / Sorties | Type | Description
Width | Sortie | Entier | Largeur de l'écran en pixel dépendant de la résolution

Exemple :

Télécharger l'exemple


Fichier / GetScreenY

GetScreenY

Description :

Cette fonction donne la hauteur d'un écran en pixels.
Cette valeur dépend de la résolution choisie sous Windows.

Syntaxe :

GETSCREENY Height

Variables :

Paramètres | Entrées / Sorties | Type | Description
Height | Sortie | Entier | Hauteur de l'écran en pixel dépendant de la résolution

Exemple :

Télécharger l'exemple


Fichier / GetVersionScript

GetVersionScript

Description :

Cette fonction permet d'avoir le numéro de version de l'interpréteur des scripts afin de pouvoir tenir compte de l'évolution de PRiSM.

Syntaxe :

GETVERSIONSCRIPT Version

Variables :

Paramètres | Entrées / Sorties | Type | Description
Version | Sortie | Réel | Version de l'interpréteur de Script

Voir aussi :

Exemple :

GetVersionScript Version
if Version<1.9
   print "L'interpréteur script est de version inférieure à 1.90"
   exit
endif

Télécharger l'exemple


Fichiers / PutFTP

PutFTP

Description :

Cette fonction permet de déposer un fichier directement sur un site FTP.
Un minimum d'information doit être fourni au script !

Syntaxe :

PUTFTP hostname$ UserName$ password$ ModeTRSF DirRemote$ Localfilename$

Variables :

Paramètres | Entrées / Sorties | Type | Description
hostname$ | Entrée | Chaîne de caractères | Chemin d'accès au site FTP
UserName$ | Entrée | Chaîne de caractères | Nom d'utilisateur
password$ | Entrée | Chaîne de caractères | Mot de passe
ModeTRSF | Entrée | Booléen | Mode de transfert : 0 = Binaire et 1 = ASCII.
DirRemote$ | Entrée | Chaîne de caractères | Répertoire de copie sur le site FTP
Localfilename$ | Entrée | Chaîne de caractères | Chemin complet du fichier à transmettre

Exemple :

.................................................
DirRemote$="\images\"

PUTFTP hostname$ userName$ password$ ModeTRSF DirRemote$ Localfilename$

Télécharger l'exemple


Fichier / Beep

Beep

Description :

Cette fonction permet d'émettre un son à volonté. Ce son est contenu dans le fichier "Beep.wav" qui doit être placé dans le répertoire principal de PRiSM.

Syntaxe :

BEEP

Voir aussi :

Exemple :

BEEP

Télécharger l'exemple
Télécharger un son BEEP exemple


Fichier / IncludeScript

IncludeScript

Description :

Cette fonction permet d'appeler une fonction ou une partie de script incluse dans un autre script. Ces appels fonctionnent par étiquette. Ceci ressemble beaucoup à l'appel d'une fonction d'une unité de programmation alors que le programme effectué est dans une autre unité.

Utilisation : lien


Visualisation / WriteText

WriteText

Description :

Cette fonction permet d'écrire du texte directement dans une image.
Deux variables font appel à des couleurs. Dans tous les logiciels de traitement d'images grand public, ces dernières sont représentées par une suite de nombres au format hexadécimal du type "FFFFFF" (pour le blanc). Dans cette fonction, ces grandeurs sont à indiquer en entier (par exemple, en hexadécimal, FFFFFF correspond à 16777215 en décimal). Une fonction script a été developpée pour fournir la valeur de la couleur en entier en fournissant l'intensité pour les 3 plans R, V et B de 0 à 255 : GETCOLOR

Syntaxe :

WRITETEXT Img PosX PosY Taille Text$ ColorText ColorBackGND FontName$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
PosX | Entrée | Entier | Position entière en X où écrire le texte
PosY | Entrée | Entier | Position entière en Y où écrire le texte
Taille | Entrée | Entier | Taille du texte à écrire
Text$ | Entrée | Chaîne de caractères | Texte à écrire !
ColorText | Entrée | Couleur | Couleur du texte à écrire. Il est conseillé d'utiliser la fonction script GETCOLOR.
ColorBackGND | Entrée | Couleur | Couleur du fond à l'endroit où est écrit le texte. Il est conseillé d'utiliser la fonction script GETCOLOR.
FontName$ | Entrée | Chaîne de caractères | Nom de la font windows utilisée.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
GETCOLOR

Exemple :

................................
FontName$="Verdana"
WRITETEXT Img PosX PosY Taille Text$ ColorText ColorBackGND FontName$

Télécharger l'exemple


Visualisation / GetColor

GetColor

Description :

Cette fonction permet d'obtenir le code d'une couleur en entier.
A cette fin, il faut fournir la valeur de 0 à 255 des trois couleurs fondamentales : Rouge, Vert et Bleu

Syntaxe :

GETCOLOR IntB IntV IntR Color

Variables :

Paramètres | Entrées / Sorties | Type | Description
IntB | Entrée | Entier | Valeur de 0 à 255 de l'intensité de la couleur désirée dans le bleu.
IntV | Entrée | Entier | Valeur de 0 à 255 de l'intensité de la couleur désirée dans le vert.
IntR | Entrée | Entier | Valeur de 0 à 255 de l'intensité de la couleur désirée dans le rouge.
Color | Sortie | Entier | Code de la couleur recherchée.

Voir aussi :
WRITETEXT

Exemple :

GETCOLOR IntB IntV IntR Color

PRINT "Valeur" Color

Télécharger l'exemple


Fichier / Open_FileTxt_For_Append

Open_FileTxt_For_Append

Description :

Cette fonction permet de déclarer l'ouverture d'un fichier de données (.txt ou autre) déjà existant dans lequel sera sauvegardé des données provenant des scripts de PRiSM. Le nom de famille du fichier peut être autre que .txt !

Syntaxe :

Open_FileTxt_For_Append fichier fichier$

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier à ouvrir dans le programme PGM
fichier$ | Entrée | Chaîne de caractères | Chemin total où écrire le fichier

Voir aussi :
Open_FileTxt_For_Rewrite

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Append fichier Dir$
............................................

Télécharger l'exemple


Fichier / Open_FileTxt_For_Rewrite

Open_FileTxt_For_Rewrite

Description :

Cette fonction permet de déclarer l'ouverture d'un nouveau fichier de données (.txt ou autre) dans lequel sera sauvegardé des données provenant des scripts de PRiSM. Le nom de famille du fichier peut être autre que .txt !

Syntaxe :

Open_FileTxt_For_Rewrite fichier fichier$

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier à créer dans le programme PGM
fichier$ | Entrée | Chaîne de caractères | Chemin total où écrire le fichier

Voir aussi :
Open_FileTxt_For_Append

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Rewrite fichier Dir$
............................................

Télécharger l'exemple


Fichier / Open_FileTxt_For_Read

Open_FileTxt_For_Read

Description :

Cette fonction permet de déclarer l'ouverture d'un nouveau fichier de données (.txt ou autre) dans lequel les données ne pourront être que lues dans un script de PRiSM. Le nom de famille du fichier peut être autre que .txt !

Syntaxe :

Open_FileTxt_For_Read fichier fichier$

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier à ouvrir dans le programme PGM
fichier$ | Entrée | Chaîne de caractères | Chemin total où lire le fichier

Voir aussi :
Open_FileTxt_For_Append
Open_FileTxt_For_ReWrite

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Read fichier Dir$
............................................

Télécharger l'exemple


Fichier / ReadFileTXT

ReadFileTXT

Description :

Cette fonction permet de lire une ligne de caractères alphanumériques dans un fichier préalablement ouvert. Les lignes sont lues les unes après les autres mais la fonction READFILETXT doit être rappelée à chaque fois pour chaque ligne.

Syntaxe :

READFILETXT fichier texte$

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier ouvert dans le programme PGM
fichier$ | Sortie | Chaîne de caractères | ligne à lire dans le fichier

Voir aussi :
Open_FileTxt_For_Read

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Read fichier Dir$
.............................................
ReadFileTxt fichier ligne1$
............................................

Télécharger l'exemple


Fichier / WriteFileTXT

WriteFileTXT

Description :

Cette fonction permet d'écrire une ligne de caractères alphanumériques dans un fichier préalablement ouvert

Syntaxe :

WRITEFILETXT fichier texte$

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier ouvert dans le programme PGM
fichier$ | Entrée | Chaîne de caractères | ligne à écrire dans le fichier

Voir aussi :
Open_FileTxt_For_Append
Open_FileTxt_For_Rewrite

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Rewrite fichier Dir$
.............................................
WriteFileTxt fichier ligne1$
............................................

Télécharger l'exemple


Fichier / EndOfFile

EndOfFile

Description :

Cette fonction permet de savoir si on a atteint la fin d'un fichier texte. Le résultat sera renvoyé sous la forme d'un booléen : ce dernier sera à TRUE si on a atteint la fin du fichier et à FALSE dans le cas où il existerait encore des lignes dans le fichier.

Syntaxe :

ENDOFFILE fichier resultat

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier ouvert dans le programme PGM
resultat | Sortie | Booléen (entier) | Résultat du test

Voir aussi :
Open_FileTxt_For_Read

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Read fichier Dir$
.............................................
ENDOFFILE fichier resultat
if resultat=FALSE then
............................................

Télécharger l'exemple


Fichier / CloseFileTXT

CloseFileTXT

Description :

Cette fonction permet de fermer un fichier préalablement ouvert dans lequel ont été écrites des données à partir du programme script.

Syntaxe :

CLOSEFILETXT fichier

Variables :

Paramètres | Entrées / Sorties | Type | Description
fichier | Entrée | Fichier | Nom interne du fichier ouvert dans le programme PGM

Voir aussi :
Open_FileTxt_For_Append
Open_FileTxt_For_Rewrite

Exemple :

Dir$="C:\essai.dat"
Open_FileTxt_For_Rewrite fichier Dir$
.............................................
WriteFileTxt fichier ligne1$
...............................................
CloseFileTxt fichier
............................................

Télécharger l'exemple


Carte du ciel / ConvertDateToJulian

ConvertDateToJulian

Description :

Cette fonction permet de convertir une date au format de celui renvoyé par la fonction NOW à un paramètre vers une date au format Jour Julien.
La fonction NOW renvoie une date comptée depuis une référence connue : le 30/12/1899 à 0h00 (date choisie par les concepteurs de DELPHI !).

Syntaxe :

CONVERTDATETOJULIAN Date JJDate

Variables :

Paramètres | Entrées / Sorties | Type | Description
Date | Entrée | Réel | Date au format Delphi
JJDate | Sortie | Réel | Jour julien correspondant

Voir aussi :
NOW
DateToStr

Exemple :

NOW  Date
CONVERTDATETOJULIAN Date JJDate
Print "Jour Julien actuel : " JJDATE
Télécharger l'exemple


Carte du ciel / DateToStr

DateToStr

Description :

Cette fonction permet de convertir une date au format de celui renvoyé par la fonction NOW à un paramètre vers une date sous forme de chaîne de caractères.
La fonction NOW renvoie une date comptée depuis une référence connue : le 30/12/1899 à 0h00 (date choisie par les concepteurs de DELPHI !).

Syntaxe :

DATETOSTR Date Date$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Date | Entrée | Réel | Date au format Delphi
Date$ | Sortie | Chaîne | Date correspondante ... et compréhensible !

Voir aussi :
NOW

Exemple :

NOW  Date
CONVERTDATETOJULIAN Date JJDate
Print "Jour Julien actuel : " JJDATE

DATETOSTR Date Date$
PRINT "Date correspondante : " Date$

Télécharger l'exemple


Objets / GetStdrLatitude

GetStdrLatitude

Description :

Cette fonction permet d'obtenir la latitude du lieu d'observation défini dans le menu "Option/Lieu d'observation par défaut".
Ce nombre est en radians ( entre -PI/2 et PI/2). Sa valeur en DMS s'obtient grâce à une des fonctions de conversions du type RAD_TO_DEC.

Syntaxe :

GETSTDRLATITUDE Latitude

Variables :

Paramètres | Entrées / Sorties | Type | Description
Latitude | Sortie | Réel | Latitude en radians du lieu d'observation par défaut

Voir aussi :
GetStdrLongitude

Fonctions de conversions

Exemple :

......................................
GETSTDRLATITUDE Latitude

PRINT Latitude
RAD_TO_DEC Latitude Latitude$
PRINT "Latitude = " Latitude$

Télécharger l'exemple


Objets / GetStdrLongitude

GetStdrLongitude

Description :

Cette fonction permet d'obtenir la longitude du lieu d'observation défini dans le menu "Option/Lieu d'observation par défaut".
Ce nombre est en radians ( entre -PI et PI). Sa valeur en DMS s'obtient grâce à une des fonctions de conversions du type RAD_TO_DEC.
La valeur de Longitude est renvoyée positive pour une longitude OUEST et négative pour une longitude EST.

Syntaxe :

GETSTDRLONGITUDE Longitude

Variables :

Paramètres | Entrées / Sorties | Type | Description
Longitude | Sortie | Réel | Longitude en radians du lieu d'observation par défaut

Voir aussi :
GetStdrLatitude

Fonctions de conversions

Exemple :

......................................
GETSTDRLONGITUDE Longitude

PRINT Longitude
RAD_TO_DEC Longitude Longitude$
PRINT "Longitude = " Longitude$

Télécharger l'exemple


Carte du ciel / NOW

NOW

Description :

Cette fonction permet de dater un évènement. Elle permet d'obtenir l'heure et la date actuel en temps universel (UT).

Il existe deux syntaxes pour cette fonction :

  • La première renvoie terme à terme la date et l'heure jusqu'à une précision de la milliseconde. C'est l'heure connue par WINDOWS qui est renvoyée.

  • La deuxième renvoie une date fractionnaire ( correspondant à l'heure à la milliseconde près ); pour résumer, cette dernière est comptée depuis une référence connue : le 30/12/1899 à 0h00 ( date choisie par les concepteurs de DELPHI ! ). Cette deuxième syntaxe est surtout utile quand il s'agit de connaître l'intervalle de temps écoulé entre deux évènements; bien sûr, cette différence de temps entre ces deux évènements sera donné en jour fractionnaire.

    • Syntaxe :

    NOW année mois jour heure minute seconde MS
    ///OU///
    NOW param

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
année | Sortie | Entier | Année durant laquelle s'exécute la fonction NOW
mois | Sortie | Entier | Mois durant lequel s'exécute la fonction NOW
jour | Sortie | Entier | Jour durant lequel s'exécute la fonction NOW
heure | Sortie | Entier | Heure durant laquelle s'exécute la fonction NOW
minute | Sortie | Entier | Minute durant laquelle s'exécute la fonction NOW
Seconde | Sortie | Entier | Seconde durant laquelle s'exécute la fonction NOW
MS | Sortie | Entier | Milliseconde durant laquelle s'exécute la fonction NOW
    ///OU///

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
param | Sortie | Réel | nombre de jours fractionnaires écoulés depuis le 30/12/1899 à 00h00

    Voir aussi :
    DateToStr
    ConvertDateToJulian

    Exemple :

    PRINT "Temps entre deux exécution de la fonction NOW"
NOW date1
DELAY 10
WAITFORENDDELAY
NOW date2
PRINT "Date 1 = " Date1
PRINT "Date 2 = " Date2
Date=(Date2-Date1)*24*3600*1000
PRINT "Temps écoulé en ms = " Date

NOW Annee Mois Jour Heure Minutes Secondes MS
PRINT "Nous sommes le " Jour "/" Mois "/" Annee
PRINT "à " Heure ":" Minutes ":" Secondes "," MS "( en UT ! )"

Télécharger l'exemple


Carte du ciel / EncodeDateTime

EncodeDateTime

Description :

Cette fonction permet d'encoder une date sous forme de JJ/MM/AA à HH:MM:SS.SSS sous forme de date compréhensible par les autres fonctions scripts utilisant des dates.

Syntaxe :

ENCODEDATETIME AA Mo JJ HH MM SS MSec Date

Variables :

Paramètres | Entrées / Sorties | Type | Description
AA | Entrée | Entier | Année
Mo | Entrée | Entier | Mois
JJ | Entrée | Entier | Jour
HH | Entrée | Entier | Heure
MM | Entrée | Entier | Minutes
SS | Entrée | Entier | Seconde
MSec | Entrée | Entier | Milliseconde
Date | Sortie | Réel | Date encodée

Voir aussi :

Exemple :

...................................
INPUT "Millisecondes ?" MSec

EncodeDateTime AA Mo JJ HH MM SS MSec Date
PRINT "Date =" Date

Télécharger l'exemple


Carte du ciel / ComputeAngleHoraire

ComputeAngleHor

Description :

Cette fonction permet de renvoyer l'angle horaire d'un objet dont l'ascension droite est connu. Cet angle est renvoyé en radian (compris entre -PI et PI) qui représente le décalage horaire depuis le méridien SUD ( en allant vers l'EST).
La valeur de l'angle en HMS s'obtient grâce à une des fonctions de conversions du type RAD_TO_RA.
Cet angle correspont juste à l'opération du temps sidéral local ôté de l'ascension droite de l'objet.

Syntaxe :

COMPUTEANGLEHOR TSL alpha AngleHor

Variables :

Paramètres | Entrées / Sorties | Type | Description
TSL | Entrée | Réel | Temps sidéral local (voir la fonction SideralTime)
Alpha | Entrée | Réel | Ascension droite de l'objet en radians (compris entre 0 et 2*PI).
AngleHor | Sortie | Réel | Angle horaire de l'objet en radians (compris entre -PI et PI).

Voir aussi :
SideralTime

Fonctions de conversions

Exemple :

...................................
GETOBJECTCOORD objet$ Alpha Delta

if Alpha=-100
  PRINT "L'objet " objet$ " n'existe pas !"
  EXIT
endif

NOW  Date
GetStdrLongitude Longitude
SideralTime Date Longitude TSL
ComputeAngleHor TSL Alpha AngleHor
RAD_TO_RA AngleHor AngleHor$
PRINT "Angle Horaire de l'objet : " AngleHor$

Télécharger l'exemple


Carte du ciel / DistSky

DistSky

Description :

Cette fonction permet d'obtenir la distance d'un objet à un autre par la connaissance des coordonnées équatoriales de chacun des objets.La distance est exprimée en radians (compris en radians entre 0 et 2*PI).

Syntaxe :

DISTSKY Alpha1 Alpha2 Delta1 Delta2 Dist

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha1 | Entrée | Réel | Ascension droite de l'objet 1 en radians (voir la fonction GetObjectCoord)
Alpha2 | Entrée | Réel | Ascension droite de l'objet 2 en radians (voir la fonction GetObjectCoord)
Delta1 | Entrée | Réel | Déclinaison de l'objet 1 en radians (voir la fonction GetObjectCoord)
Delta2 | Entrée | Réel | Déclinaison de l'objet 2 en radians (voir la fonction GetObjectCoord)
Dist | Sortie | Réel | Distance entre les 2 objets en radians

Voir aussi :
GetObjectCoord

Exemple :

NOW Date
GETRADECMOON Date AlphaM DeltaM ElevationM
GETRADECSUN Date AlphaS DeltaS ElevationS
DISTSKY AlphaM AlphaS DeltaM DeltaS Dist
Dist=Dist*TODEG
PRINT "Distance Soleil-Lune en ° = " Dist

Télécharger l'exemple


Objets / GetAirMass

GetAirMass

Description :

Cette fonction permet de calculer la masse d'air entre un point visé et l'observateur. La masse d'air est définie comme étant la quantité 1/(cos ß), où ß représente la hauteur du point de visé corrigé de la réfraction atmosphérique.
La grandeur "Elevation" doit nécessairement être positive et être exprimée en radians (entre 0 et PI/2).

Syntaxe :

GETAIRMASS Elevation AirMass

Variables :

Paramètres | Entrées / Sorties | Type | Description
Elevation | Entrée | Réel | Elevation du point visé au dessus de l'horizon exprimé en radian
AirMAss | Sortie | Réel | Masse d'air équivalente entre l'observateur et le point visé

Voir aussi :
GetHeight
GetObjectCoord

Fonctions de conversions

Exemple :

......................................
GetHeight alpha delta Date Longitude latitude hauteur

REM Calculer la masse d'air
GETAIRMASS hauteur airMass
PRINT "Masse d'air : " airMass

Télécharger l'exemple


Carte du Ciel / GetAzimuth

GetAzimuth

Description :

Cette fonction permet d'obtenir l'angle en radian par rapport au méridien NORD (en passant par l'OUEST). Cet angle est nommé "Azimuth". Sa valeur est donnée en radian.
Cet angle est compris entre 0 et 2*PI (transcriptible grâce à "STR_RAD_TO_DEC" entre 0 et 360°).

Syntaxe :

GETAZIMUTH Alpha Delta Date Longitude latitude Azimuth

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha | Entrée | Réel | Ascension droite de l'objet en radians (voir la fonction GetObjectCoord)
Date | Entrée | Réel | La date actuelle (voir la fonction Now)
Longitude | Entrée | Réel | Longitude du lieu d'observation (voir la fonction GetStdrLongitude)
Latitude | Entrée | Réel | Latitude du lieu d'observation (voir la fonction GetStdrLatitude)
Azimuh | Sortie | Réel | Azimuth de l'objet (angle en radian par rapport au méridien nord par l'Ouest)

Voir aussi :
Now
GetStdrLongitude

Exemple :

......................................
NOW Date
GetStdrLongitude Longitude
GetStdrLatitude Latitude
GETAZIMUTH alpha delta Date Longitude Latitude Azimuth

REM Angle par rapport au méridien nord
PRINT "Azimuth (radians) : " Azimuth

Télécharger l'exemple


Objets / GetDistanceToMeridien

GetDistanceToMeridien

Description :

Cette fonction permet d'obtenir la distance d'un objet par rapport au méridien Sud directement en heures à un instant donné. Sa valeur est donc comprise entre -11.999999 et +11.999999. La distance horaire est positive pour un décalage vers le méridien OUEST et négative dans le cas contraire.

Syntaxe :

GETDISTANCETOMERIDIEN Alpha Date Longitude Distance

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha | Entrée | Réel | Ascension droite de l'objet en radians (voir la fonction GetObjectCoord)
Date | Entrée | Réel | La date actuelle (voir la fonction Now)
Longitude | Entrée | Réel | Longitude du lieu d'observation (voir la fonction GetStdrLongitude)
Distance | Sortie | Réel | Distance de l'objet par rapport au méridien SUD en heures

Voir aussi :
Now
GetStdrLongitude

Exemple :

......................................
NOW Date
GetStdrLongitude Longitude
GetDistanceToMeridien alpha Date Longitude Distance

REM Distance en fraction d'heure
PRINT "Angle horaire (en heures) : " alpha$

Télécharger l'exemple


Objets / GetHeight

GetHeight

Description :

Cette fonction permet d'obtenir la hauteur d'un objet en radians (compris entre 0 et PI/2) en fonction de ses coordonnées équatoriales.
Si l'objet n'est pas reconnu, Alpha et Delta prennent la valeur -100.
Cette fonction fonctionne même avec des objets sous l'horizon (hauteur négative).

Syntaxe :

GETHEIGHT Alpha Delta Date Longitude Latitude Elevation

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha | Entrée | Réel | Ascension droite de l'objet en radians (voir la fonction GetObjectCoord)
Delta | Entrée | Réel | Déclinaison de l'objet en radians (voir la fonction GetObjectCoord)
Date | Entrée | Réel | La date actuelle (voir la fonction Now)
Longitude | Entrée | Réel | Longitude du lieu d'observation (voir la fonction GetStdrLongitude)
Latitude | Entrée | Réel | Latitude du lieu d'observation (voir la fonction GetStdrLatitude)
Elevation | Sortie | Réel | Hauteur de l'objet par rapport à l'horizon en radians

Voir aussi :
Now
GetObjectCoord
GetStdrLongitude
GetStdrLatitude

Fonctions de conversions

Exemple :

......................................
NOW Date
GetStdrLongitude Longitude
GetStdrLatitude Latitude
GETHEIGHT alphaobject deltaobject Date Longitude latitude hauteur

REM Conversion de radian en dégrés
RAD_TO_DEC hauteur hauteur$
PRINT "Elevation actuelle de l'objet : " hauteur$

Télécharger l'exemple


Carte du ciel / SideralTime

SideralTime

Description :

Cette fonction renvoie l'heure sidéral locale à un instant donné.
La date est au format de celui renvoyé par la fonction NOW à un paramètre. La fonction NOW renvoie une date comptée depuis une référence connue : le 30/12/1899 à 0h00 (date choisie par les concepteurs de DELPHI !).
La longitude doit être précisée en radian.
La valeur TSL est renvoyée en radians (compris entre 0 et 2*PI). La valeur de l'angle en HMS s'obtient grâce à une des fonctions de conversions du type RAD_TO_RA.

Syntaxe :

SIDERALTIME Date Longitude TSL

Variables :

Paramètres | Entrées / Sorties | Type | Description
Date | Entrée | Réel | La date actuelle (voir la fonction Now)
Longitude | Entrée | Réel | Longitude du lieu d'observation (voir la fonction GetStdrLongitude)
TSL | Sortie | Réel | Heure sidérale en radians

Voir aussi :
NOW
GetStdrLongitude

Exemple :

.....................................
NOW Date
GetStdrLongitude Longitude
SIDERALTIME Date Longitude Tsl
ComputeAngleHor TSL Alpha AngleHor
RAD_TO_RA AngleHor AngleHor$
PRINT "Angle Horaire de l'objet :" AngleHor$

Télécharger l'exemple


Carte du ciel / Convert_RADECApp_To_2000

Convert_RADECApp_To_2000

Description :

Cette fonction permet de calculer les coordonnées équatoriales datées 2000.0 d'un objet depuis ses coordonnées apparentes. Pour les coordonnées apparentes, sont corrigés automatiquement les grandeurs suivantes : la précession des équinoxes, la nutation, la réfraction atmosphérique ainsi que la correction de l'abbération diurne.

Attention : cette fonction a besoin d'éléments connus par les codeurs pour pouvoir fonctionner; ces derniers doivent donc être connectés !

Syntaxe :

CONVERT_RADECAPP_TO_2000 DateUTC Alpha_App Delta_App Alpha2000 Delta2000

Variables :

Paramètres | Entrées / Sorties | Type | Description
DateUTC | Entrée | Réel | Date en temps universel
ALPHA_APP | Entrée | Réel | Ascension droite apparente de l'objet, en radians
DELTA_APP | Entrée | Réel | Déclinaison apparente de l'objet, en radians
ALPHA2000 | Sortie | Réel | Ascension droite de l'objet dans le système 2000.0, en radians
DELTA2000 | Sortie | Réel | Déclinaison de l'objet dans le système 2000.0, en radians

Exemple :

..................................

Télécharger l'exemple


Carte du ciel / Convert_RADEC2000_To_App

Convert_RADEC2000_To_App

Description :

Cette fonction permet de calculer les coordonnées apparentes d'un objet suivant ses coordonnées équatoriales datées 2000.0. Sont corrigés automatiquement les grandeurs suivantes : la précession des équinoxes, la nutation, la réfraction atmosphérique ainsi que la correction de l'abbération diurne.

Attention : cette fonction a besoin d'éléments connus par les codeurs pour pouvoir fonctionner; ces derniers doivent donc être connectés !

Syntaxe :

CONVERT_RADEC2000_TO_APP DateUTC Alpha2000 Delta2000 Alpha_App Delta_App

Variables :

Paramètres | Entrées / Sorties | Type | Description
DateUTC | Entrée | Réel | Date en temps universel
ALPHA2000 | Entrée | Réel | Ascension droite de l'objet dans le système 2000.0, en radians
DELTA2000 | Entrée | Réel | Déclinaison de l'objet dans le système 2000.0, en radians
ALPHA_APP | Sortie | Réel | Ascension droite apparente de l'objet, en radians
DELTA_APP | Sortie | Réel | Déclinaison apparente de l'objet, en radians

Exemple :

..................................

Télécharger l'exemple


Carte du ciel / DEC_TO_RAD

DEC_TO_RAD

Description :

Cette fonction est une fonction de conversion pour les angles de type déclinaison ( ou latitude, altitude, hauteur ... ); elle permet de changer :

  • un angle en -degrés, minutes et secondes d'arc- sous forme de chaîne de caractère dont le format est indiqué ci-dessous compris entre "-89d59m59.999s" et "+89d59m59.999s"

    • EN
  • un angle en radians c'est à dire compris entre -PI/2 et PI/2 = 1.5708...

    • Le résultat renvoyé est donné à 10-10 radian près, correspondant à 2,1.10-5 " = 0,021 ms d'arc et donc, il n'y a pas de perte de précision dans la conversion ( le dernier chiffre est même sans signification ! )

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    DEC_TO_RAD Angle_dms Angle_DEC

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Angle_dms | Entrée | Chaîne | Valeur de l'ascension droite en DMS sous la forme : +XXdXXmXX[.XXX]s
Angle_DEC | Sortie | Réel | Valeur de la déclinaison en radians

    Voir aussi :
    STR_DEC_TO_RAD
    RAD_TO_DEC
    STR_RAD_TO_DEC

    Exemple :

    Sign$="-"
Degres$="00"
MinutesD$="10"
SecondesD$="20"
Chaine$=Sign$+Degres$+"d"+MinutesD$+"m"+SecondesD$+"s"
DEC_TO_RAD Chaine$ delta
print "DEC en radians = " delta

Télécharger l'exemple


Carte du ciel / RA_TO_RAD

RA_TO_RAD

Description :

Cette fonction est une fonction de conversion pour les angles de type ascension droite ( ou longitude ); elle permet de changer :

  • un angle en -heures, minutes et secondes- sous forme de chaîne de caractère dont le format est indiqué ci-dessous compris entre "00h00m00.000s" et "23h59m59.999s"

    • EN
  • un angle en radians c'est à dire compris entre 0.00 et 2*PI = 6.2832.

    • Le résultat renvoyé est donné à 10-7 radian près, correspondant à 1,4 ms = 1,4.10-3 s et donc, il n'y a pas de perte de précision dans la conversion.

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    RA_TO_RAD Angle_hms Angle_RAD

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Angle_hms | Entrée | Chaîne de caractères | Valeur de l'ascension droite en HMS sous la forme : XXhXXmXX[.XXX]s
Angle_RAD | Sortie | Réel | Valeur de l'ascension droite en radians

    Voir aussi :
    STR_RA_TO_RAD
    RAD_TO_RA
    STR_RAD_TO_RA

    Exemple :

    Heure$="22"
Minutes$="15"
Secondes$="52"
Chaine$=Heure$+"h"+Minutes$+"m"+Secondes$+"s"
RA_TO_RAD Chaine$ alpha
print "RA en radians = " alpha

Télécharger l'exemple


Carte du ciel / RAD_TO_DEC

RAD_TO_DEC

Description :

Cette fonction est une fonction de conversion pour les angles de type déclinaison ( ou latitude, altitude, hauteur ... ); elle permet de changer :

  • un angle en radians c'est à dire compris entre -PI/2 et PI/2 = 1.5708...

    • EN
  • un angle en -degrés, minutes et secondes d'arc- sous forme de chaîne de caractère dont le format est indiqué ci-dessous compris entre "-89d59m59.999s" et "+89d59m59.999s"

    • Le résultat renvoyé est donné au centième de seconde d'arc près, correspondant à 5.10-8 radian et donc, il ne sert à rien de fournir un angle en radian à plus de 8 chiffres après la virgule !
    La variable d'entrée en radian ne sera retournée ( si demandé ! ) qu'à 8 chiffres significatifs c'est-à-dire pour un angle fourni entre -PI/2 et PI/2, la valeur ne sera retournée qu'à 10-7 radian près; mais que l'utilisateur se rassure, le PGM gardera en mémoire TOUS les chiffres rentrés.
    Il est possible de fournir un angle non compris dans [-PI/2;PI/2]; cependant, ces valeurs en radians proviennent le plus souvent d'autres fonctions SCRIPT qui se débrouillent pour donner un angle dans l'intervalle [-PI/2;PI/2] ( voir toutes les fonctions du thème "carte du ciel" ). Par contre, Pour une fonction comme "Azimuth", un angle supérieur à PI/2 est pris en compte.

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    RAD_TO_DEC Angle_RAD Angle_dms$

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Angle_RAD | Entrée | Réel | Valeur de la déclinaison en radians
Angle_dms$ | Sortie | Chaîne | Valeur de l'ascension droite en DMS sous la forme : "+XXdXX'XX.XX''"

    Voir aussi :
    STR_RAD_TO_DEC
    DEC_TO_RAD
    STR_RAD_TO_DEC

    Exemple :

    NOW date
GetRADECSUN date AlphaS DeltaS Elevation
RAD_TO_DEC DeltaS delta$
RAD_TO_DEC Elevation Elev$
PRINT "DEC Soleil = " delta$
PRINT "Elévation Soleil = " Elev$

Télécharger l'exemple


Carte du ciel / RAD_TO_RA

RAD_TO_RA

Description :

Cette fonction est une fonction de conversion pour les angles de type ascension droite ( ou longitude ); elle permet de changer :

  • un angle en radians c'est à dire compris entre 0.00 et 2*PI = 6.2832.un angle en -heures, minutes et secondes- sous forme de chaîne de caractère dont le format est indiqué ci-dessous compris entre "00h00m00.000s" et "23h59m59.999s"

    • EN
  • un angle en -heures, minutes et secondes- sous forme de chaîne de caractère dont le format est indiqué ci-dessous compris entre "00h00m00.000s" et "23h59m59.999s"

    • Le résultat renvoyé est donné à la milliseconde près, correspondant à 7.10-8 radian et donc, il ne sert à rien de fournir un angle en radian à plus de 8 chiffres après la virgule !
    La variable d'entrée en radian ne sera retournée ( si demandé ! ) qu'à 8 chiffres significatifs c'est-à-dire pour un angle fourni entre 0 et 2*PI, la valeur ne sera retournée qu'à 10-7 radian près; mais que l'utilisateur se rassure, le PGM gardera en mémoire TOUS les chiffres rentrés.
    Il est possible de fournir un angle non compris dans [0;2*PI]; cependant, ces valeurs en radians proviennent le plus souvent d'autres fonctions SCRIPT qui se débrouillent pour donner un angle dans l'intervalle [0;2*PI] ( voir toutes les fonctions du thème "carte du ciel" ).

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    RAD_TO_RA Angle_RAD Angle_hms

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Angle_RAD | Entrée | Réel | Valeur de l'ascension droite en radians
Angle_hms | Sortie | Chaîne de caractères | Valeur de l'ascension droite en HMS sous la forme : "XXhXXmXX.XXXs"

    Voir aussi :
    STR_RAD_TO_RA
    RA_TO_RAD
    STR_RAD_TO_RA

    Exemple :

    alpha$=""
NOW date
GetRADECSUN date AlphaS DeltaS Elevation
RAD_TO_RA alphaS alpha$
print "RA Soleil = " alpha$

Télécharger l'exemple


Carte du ciel / STR_DEC_TO_RAD

STR_DEC_TO_RAD

Description :

Cette fonction est une fonction de conversion pour les angles de type déclinaison ( ou latitude, altitude, hauteur ... ); elle permet de changer :

  • un angle en -degrés, minutes et secondes d'arc- sous forme d'une suite de nombres dont le format est indiqué ci-dessous compris entre -89°59'59.999..." et +89°59'59.999..."

    • EN
  • un angle en radians c'est à dire compris entre -PI/2 et PI/ = 1.5708...

    • Le résultat renvoyé est donné à 10-10 radian près, correspondant à 2,1.10-5 " = 0,021 ms d'arc et donc, il ne sert à rien de fournir une valeur de "seconde" à mieux que le dixième de milli-seconde près soit à 10-4 près ( exemple : 23.6598 )

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    DEC_TO_RAD Degré MinutesD SecondesD Delta

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Degré | Entrée | Entier | Valeur entière de la déclinaison comprise entre 0 et 89
MinutesD | Entrée | Entier | Valeur des minutes de la déclinaison en DMS comprise entre 0 et 59
SecondesD | Entrée | Réel | Valeur des secondes ( non entières ) de la déclinaison en DMS sous la forme : XX.XXX...
Delta | Sortie | Réel | Valeur de la déclinaison en radians

    Voir aussi :
    STR_RAD_TO_DEC
    RAD_TO_DEC
    DEC_TO_RAD

    Exemple :

    Degres=0
MinutesD=-10
SecondesD=20
STR_DEC_TO_RAD Degres MinutesD SecondesD delta
print "DEC en radians = " delta

Télécharger l'exemple


Carte du ciel / STR_RA_TO_RAD

STR_RA_TO_RAD

Description :

Cette fonction est une fonction de conversion pour les angles de type ascension droite ( ou longitude ); elle permet de changer :

  • un angle en -heures, minutes et secondes- sous forme d' une suite de nombres dont le format est indiqué ci-dessous compris entre 00h00min00s et 23h59min59.999...s

    • EN
  • un angle en radians c'est à dire compris entre 0.00 et 2*PI = 6.2832.

    • Le résultat renvoyé est donné à 10-7 radian près, correspondant à 1,4 ms = 1,4.10-3 s et donc, il ne sert à rien de fournir une valeur de "seconde" à mieux que la milli-seconde près soit à 10-3 près ( exemple : 23.659 )

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    STR_RA_TO_RAD Heure Minutes Secondes Alpha

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Heure | Entrée | Entier | Valeur de l'heure de l'ascension droite comprise entre 0 et 23
Minutes | Entrée | Entier | Valeur des minutes de l'ascension droite en HMS comprise entre 0 et 59
Secondes | Entrée | Réel | Valeur des secondes ( non entières ) de l'ascension droite en HMS sous la forme : XX.XXX...
Alpha | Sortie | Réel | Valeur de l'ascension droite en radians

    Voir aussi :
    STR_RAD_TO_RA
    RAD_TO_RA
    RA_TO_RAD

    Exemple :

    Heure=22
Minutes=15
Secondes=52
STR_RA_TO_RAD Heure Minutes Secondes alpha
PRINT "RA en radians = " alpha

Télécharger l'exemple


Carte du ciel / STR_RAD_TO_DEC

STR_RAD_TO_DEC

Description :

Cette fonction est une fonction de conversion pour les angles de type déclinaison ( ou latitude, altitude, hauteur ... ); elle permet de changer :

  • un angle en radians c'est à dire compris entre -PI/2 et PI/2 = 1.5708...

    • EN
  • un angle en -degrés, minutes d'arc et secondes d'arc- sous forme d' une suite de nombres compris entre -89°59'59.99" et +89°59'59.99" dont le format est indiqué ci-dessous

    • La variable d'entrée en radian ne sera retournée ( si demandé ! ) qu'à 8 chiffres significatifs c'est-à-dire pour un angle fourni entre -PI/2 et PI/2, la valeur ne sera retournée qu'à 10-7 radian près; mais que l'utilisateur se rassure, le PGM gardera en mémoire TOUS les chiffres rentrés.
    Un angle donné à 10-9 radian près correspondra en retour à une valeur à 0,21 ms d'arc = 2,1.10-4 " et donc, il ne sert à rien de fournir une valeur mieux qu'à 9 chiffres après la virgule pour la valeur en radian ( exemple : 0.569874195).
    Il est possible de fournir un angle non compris dans [-PI/2;PI/2]; cependant, ces valeurs en radians proviennent le plus souvent d'autres fonctions SCRIPT qui se débrouillent pour donner un angle dans l'intervalle [-PI/2;PI/2] ( voir toutes les fonctions du thème "carte du ciel" ). Par contre, Pour une fonction comme "Azimuth", un angle supérieur à PI/2 est pris en compte.

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    STR_RAD_TO_DEC delta Degre$ MinutesD$ SecondesD$

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Delta | Entrée | Réel | Valeur de la déclinaison comprise préférentiellement entre -PI/2 et PI/2
Degre$ | Sortie | Chaîne de caractères | Chaîne correspondant à la valeur des degrés de la déclinaison de la forme "±XX"
MinutesD$ | Sortie | Chaîne de caractères | Chaîne correspondant à la valeur des minutes d'arc de la déclinaison de la forme "XX"
SecondesD$ | Sortie | Chaîne de caractères | Chaîne correspondant à la valeur des secondes d'arc de la déclinaison de la forme "XX.XX"

    Voir aussi :
    STR_DEC_TO_RAD
    RAD_TO_DEC
    DEC_TO_RAD

    Exemple :

    Debut:
INPUT "Déclinaison en radians" delta
STR_RAD_TO_DEC delta Degre$ MinutesD$ SecondesD$
PRINT "DEC en radians = " delta
PRINT "DEC = " Degre$ "°" MinutesD$ "'" SecondesD$ "''"
INPUT "Continuer (o/n) ?" Rep$
IF Rep$="o" THEN
   GOTO Debut:
ENDIF

Télécharger l'exemple


Carte du ciel / STR_RAD_TO_RA

STR_RAD_TO_RA

Description :

Cette fonction est une fonction de conversion pour les angles de type ascension droite ( ou longitude ); elle permet de changer :

  • un angle en radians c'est à dire compris entre 0.00 et 2*PI = 6.2832

    • EN
  • un angle en -heures, minutes et secondes- sous forme d' une suite de nombres compris entre 00h00min00.000s et 23h59min59.999s dont le format est indiqué ci-dessous

    • La variable d'entrée en radian ne sera retournée ( si demandé ! ) qu'à 8 chiffres significatifs c'est-à-dire pour un angle fourni entre 0 et 2*PI, la valeur ne sera retournée qu'à 10-7 radian près; mais que l'utilisateur se rassure, le PGM gardera en mémoire TOUS les chiffres rentrés. Cependant, un angle donné à 10-8 radian près correspondra en retour à une valeur à 0,14 ms = 1,4.10-4 s et donc, il ne sert à rien de fournir une valeur mieux qu'à 8 chiffres après la virgule pour la valeur en radian ( exemple : 3.56987419).
    Il est possible de fournir un angle non compris dans [0;2*PI]; cependant, ces valeurs en radians proviennent le plus souvent d'autres fonctions SCRIPT qui se débrouillent pour donner un angle dans l'intervalle [0;2*PI] ( voir toutes les fonctions du thème "carte du ciel" ).

    Cette fonction est utile sachant notamment que la majorité des fonctions de PRiSM utilisent des angles d'ascension droite et de déclinaison exprimés en radians ...

    Syntaxe :

    STR_RAD_TO_RA Alpha Heure$ Minutes$ Secondes$

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Alpha | Entrée | Réel | Valeur de l'ascension droite comprise préférentiellement entre 0 et 2*PI
Heures$ | Sortie | Chaîne de caractères | Chaîne correspondant à la valeur de l'heure de l'ascension droite de la forme "XX"
Minutes$ | Sortie | Chaîne de caractères | Chaîne correspondant à la valeur des minutes de l'ascension droite de la forme "XX"
Secondes$ | Sortie | Chaîne de caractères | Chaîne correspondant à la valeur des secondes de l'ascension droite de la forme "XX.XXX"

    Voir aussi :
    STR_RA_TO_RAD

    RAD_TO_RA
    RA_TO_RAD

    Exemple :

    Debut:
INPUT "Ascension droite en radians" alpha
STR_RAD_TO_RA alpha Heure$ Minutes$ Secondes$
PRINT "RA en radians = " alpha
PRINT "RA= " Heure$ "h" Minutes$ "m" Secondes$ "s"
INPUT "Continuer (o/n) ?" Rep$
IF Rep$="o" THEN
   GOTO Debut:
ENDIF

Télécharger l'exemple


Transformation / BinningExpand

BinningExpand

Description :

Cette fonction permet de changer physiquement une image.
L'image garde la même dimension mais la valeur en ADU d'un pixel résulte de la moyenne des valeurs en ADU des pixels environnant dans l'ancienne image.
Aucune information d'entête de l'mage n'est alors modifiée.

Syntaxe :

BINNINGEXPAND Img BinX BinY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | nom interne de l'image dans le PGM
BinX | Entrée | Entier >1 | Facteur d'aggrandissement de l'image suivant X
BinY | Entrée | Entier >1 | Facteur d'aggrandissement de l'image suivant Y

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img

BinningExpand Img 2 2

Télécharger l'exemple


Transformation / BinningReduce

BinningReduce

Description :

Cette fonction permet de changer physiquement une image.
La nouvelle image est plus petite que l'ancienne image car les anciens pixels ont été regroupés par moyennage.

La majorité des paramètres sur l'information de l'image sont conservés.
Paramètres pouvant changer lors de l'application d'une telle fonction:

  • L'astrométrie de l'image n'est conservée que si les 2 paramètres de binning sont identiques mais il est conseillé (dans la mesure du possible) de la refaire.
  • La photométrie n'est pas conservée.
  • Les paramètres d'acquisition ne changent pas mais la taille des pixels est changée en fonction de la valeur retenue pour le binning.

Syntaxe :

BINNINGREDUCE Img BinX BinY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | nom interne de l'image dans le PGM
BinX | Entrée | Entier > 1 | Facteur de réduction de l'image suivant X
BinY | Entrée | Entier > 1 | Facteur de réduction de l'image suivant Y

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img

BinningReduce Img 2 2

Télécharger l'exemple


Transformation / BinningSum

BinningSum

Description :

Cette fonction permet de changer physiquement une image.
La nouvelle image est plus petite que l'ancienne image car les anciens pixels ont été regroupés par somme.
Attention, cette fonction ne peut s'appliquer que sur des images codées 32 bits (codées en réelles) (car la somme peut dépasser un codage sur 16 bits).

La majorité des paramètres sur l'information de l'image sont conservés.
Paramètres pouvant changer lors de l'application d'une telle fonction:

  • L'astrométrie de l'image n'est conservée que si les 2 paramètres de binning sont identiques mais il est conseillé (dans la mesure du possible) de la refaire.
  • La photométrie n'est pas conservée.
  • Les paramètres d'acquisition ne changent pas mais la taille des pixels est changée en fonction de la valeur retenue pour le binning.

Syntaxe :

BINNINGSUM Img BinX BinY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | image | nom interne de l'image dans le PGM
BinX | Entrée | Entier > 1 | Facteur de réduction de l'image suivant X
BinY | Entrée | Entier > 1 | Facteur de réduction de l'image suivant Y

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetImage Img

BinningSum Img 2 2

Télécharger l'exemple


Transformation / CompositeAuto

CompositeAuto

Description :

Cette fonction adapte une image à compositer par rapport à une image de référence : l'image à compositer est translatée et subie un changement d'échelle physique. Ainsi, elle est peut être compositée avec l'image de référence.
Cette fonction mémorise toutes les étoiles des 2 images et, ainsi, peut les correspondre. Elle utilise donc la méthode de reconnaissance des triangles (Chemin : Dossier / Traitement / Reconnaissance). Si l'opération est un succès (penser à adapter les paramètres de reconnaissance depuis le menu "Options"), l'image "IMG1" subit une transformation polynomiale du premier degré et ainsi, peut être superposée avec l'image "IMG2".
Attention : Cette fonction ne peut "que" translater et de tourner l'image. Elle ne permet pas de faire un changement d'échelle en gardant toute l'image. Pour une fonction de compositage plus évoluée, on se reportera à la fonction CompositeAuto_Evol.

Syntaxe :

COMPOSITEAUTO Img1 Img2

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée | image | Nom interne de l'image à compositer dans le programme PGM
Img2 | Entrée | image | Nom interne de l'image de référence dans le programme PGM

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img1 | oui / non | oui / oui / oui | oui / oui
Img2 | oui / non | oui / oui / oui | oui / oui

Voir aussi :
CompositeAuto_Evol

Exemple :

GetImage Img1
GetImage Img2

CompositeAuto Img1 Img2

Télécharger l'exemple


Transformation / CompositeAuto_Evol

CompositeAuto_Evol

Description :

Cette fonction adapte une image à compositer par rapport à une image de référence : l'image à compositer est translatée, tournée et subie un changement d'échelle physique. Ainsi, elle peut être compositée avec l'image de référence.
Cette fonction mémorise toutes les étoiles des 2 images et, ainsi, peut les correspondre. Elle utilise donc la méthode de reconnaissance des triangles. Si l'opération est un succès (penser à adapter les paramètres de reconnaissance depuis le menu "Options"), l'image à compositer subit une transformation polynomiale du premier degré et ainsi, pourra être superposée avec l'image de référence.

Syntaxe :

COMPOSITEAUTO_EVOL ImgRef ImgCompo TransX TransY ScaleX ScaleY RotRad

Variables :

Paramètres | Entrées / Sorties | Type | Description
ImgRef | Entrée | image | Nom interne de l'image de référence dans le programme PGM
ImgCompo | Entrée | image | Nom interne de l'image à compositer avec l'image de référence dans le programme PGM
TransX | Sortie | Réel | Translation effectuée suivant X
TransY | Sortie | Réel | Translation effectuée suivant Y
ScaleX | Sortie | Réel | Changement d'échelle effectué suivant X
ScaleY | Sortie | Réel | Changement d'échelle effectué suivant Y
RotRad | Sortie | Réel | Angle de rotation effectué en radian

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
ImgIn | oui / non | oui / oui / oui | oui / oui
ImgCompo | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

PRINT "Image à compositer"
GetImage ImgCompo

COMPOSITEAUTO_EVOL ImgRef ImgCompo TransX TransY ScaleX ScaleY RotRad

print "Translation X = " TransX

Télécharger l'exemple

Images de test :

Image de référence : Champ stellaire.
Image à compositer : identique à l'image de référence mais ayant subie une rotation de 3° de centre (1,1) et une translation de (10, 30). Une image est aussi fournie ayant subie en plus un changement d'échelle.


Visualisation / DetourageExt

DetourageExt

Description :

Cette fonction permet de remplir une aire rectangulaire extérieure ( la fenêtre ) dans l'image.
L'utilisateur doit donner les coordonnées de la fenêtre dans l'image et la valeur des pixels en ADU à l'extérieur de cette fenêtre.

Syntaxe :

DETOURAGEEXT Img X1 Y1 X2 Y2 Value

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X1 | Entrée | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre
Value | Entrée | Entier / Réel | Valeur à imposer en ADU des pixels à l'extérieur de la fenêtre

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetWindow Img X1 Y1 X2 Y2
DetourageExt Img X1 Y1 X2 Y2 Valeur

Télécharger l'exemple


Visualisation / DetourageInt

DetourageInt

Description :

Cette fonction permet de remplir une aire rectangulaire intérieure ( la fenêtre ) dans l'image.
L'utilisateur doit donner les coordonnées de la fenêtre dans l'image et la valeur des pixels en ADU à l'intérieur de cette fenêtre.

Syntaxe :

DETOURAGEINT Img X1 Y1 X2 Y2 Value

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X1 | Entrée | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre
Value | Entrée | Entier / Réel | Valeur à imposer en ADU des pixels à l'intérieur de la fenêtre

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

................................
GetWindow Img X1 Y1 X2 Y2
DetourageInt Img X1 Y1 X2 Y2 Valeur

Télécharger l'exemple


Transformation / Homothetie

Homothetie

Description :

Cette fonction agrandie l'image de façon différente suivant les deux axes .

Syntaxe :

HOMOTHETIE Img FacteurX FacteurY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
FacteurX | Entrée | Réel | Facteur d'agrandissement suivant l'axe X
FacteurY | Entrée | Réel | Facteur d'agrandissement suivant l'axe Y

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

..........................................
Input "Facteur axe X ?" FacteurX
Input "Facteur axe Y ?" FacteurY

HOMOTHETIE Img FacteurX FacteurY

Télécharger l'exemple


Transformation / MirrorX

MirrorX

Description :

Cette fonction permet de réaliser un miroir de l'image suivant X (horizontalement).

La majorité des paramètres sur l'information de l'image sont conservés.
Paramètres pouvant changer lors de l'application d'une telle fonction:

  • L'astrométrie de l'image est conservée mais il est conseillé (dans la mesure du possible) de la refaire.
  • La photométrie n'est pas conservée.
  • L'angle d'orientation de la caméra et la direction du repère sont automatiquement complétés en fonction des mêmes paramètres de l'image initiale.
  • L'information sur le miroir est automatiquement cochée.

Syntaxe :

MIRRORX Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
MirrorY
Image_Flip

Exemple :

..........................................
GetImage Img

MirrorX Img

Télécharger l'exemple


Transformation / MirrorY

MirrorY

Description :

Cette fonction permet de réaliser un miroir de l'image suivant Y (verticalement).

La majorité des paramètres sur l'information de l'image sont conservés.
Paramètres pouvant changer lors de l'application d'une telle fonction:

  • L'astrométrie de l'image est conservée mais il est conseillé (dans la mesure du possible) de la refaire.
  • La photométrie n'est pas conservée.
  • L'angle d'orientation de la caméra et la direction du repère sont automatiquement complétés en fonction des mêmes paramètres de l'image initiale.
  • L'information sur le miroir est automatiquement cochée.

Syntaxe :

MIRRORY Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
MirrorX
Image_Flip

Exemple :

..........................................
GetImage Img

MirrorY Img

Télécharger l'exemple


Transformation / QuarterRot

QuarterRot

Description :

Cette fonction applique une rotation d'un quart de tour sur l'image dans le sens horaire.

Syntaxe :

QUARTERROT Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img

QUARTERROT Img

Télécharger l'exemple


Transformation / Rotate

Rotate

Description :

Cette fonction permet de faire tourner une image d'un certain angle.

Syntaxe :

ROTATE Img X Y Ang

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
X | Entrée | Réel | Position EXACTE du centre de la rotation suivant X
Y | Entrée | Réel | Position EXACTE du centre de la rotation suivant Y
Angle | Entrée | Réel | Angle de la rotation en radian

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
QuarterRot

Exemple :

..........................................
Angle=Angle*TORAD

Rotate Img CenterX CenterY Angle

Télécharger l'exemple


Transformation / Scale

Scale

Description :

Cette fonction permet de redimensionner physiquement une image.
3 types de rééchantillonnage sont disponibles :

  • PIXEL : rééchantillonnage sans opération particulière
  • LINEAR : rééchantillonnage avec une approximation linéaire entre les pixels
  • BSPLINE : rééchantillonnage par BSpline

    • Syntaxe :

    SCALE Img Factor type$

    Variables :

    Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Factor | Entrée | Réel | Facteur à appliquer à une image pour la redimensionner
type$ | Entrée | Chaîne de caractères | type à déclarer pour le rééchantillonnage : PIXEL, LINEAR ou BSPLINE

    Caractéristiques d'images acceptées :

    Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

    Voir aussi :
    Homothetie

    Exemple :

    ..........................................
Input "Facteur de rééchantillonnage ?" Facteur
PRINT "type de rééchantillonnage :"
PRINT "PIXEL, LINEAR, BSPLINE"
Input "type ?" type$

Scale Img Facteur type$

Télécharger l'exemple


Transformation / Shift_SPL

Shift_SPL

Description :

Cette fonction applique une translation sur l'image par la méthode BSpline.
Dans le cas de coefficients réels, cette fonction donne de meilleurs résultats que la fonction "TRANSLATE".

Syntaxe :

SHIFT_SPL Img Tx Ty

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Tx | Entrée | Réel | Déplacement horizontal de l'image
Ty | Entrée | Réel | Déplacement horizontal de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img

SHIFT_SPL Img 132.36 14.5

Télécharger l'exemple


Transformation / RecalageAuto

RecalageAuto

Description :

Cette fonction calcule automatiquement le déplacement entre deux images.
Les images ne sont pas physiquement modifiées. Si on souhaite corriger physiquement ce déplacement, il faut utiliser la fonction de translation "Translate".

Syntaxe :

RECALAGEAUTO Img1 Img2 DeltaX DeltaY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée | Image | Nom interne de l'image de référence dans le PGM
Img2 | Entrée | Image | Nom interne de l'image à "déplacer" dans le PGM
DX | Sortie | Réel | Valeur du déplacement horizontal de l'image 2 par rapport à l'image 1
DX | Sortie | Réel | Valeur du déplacement vertital de l'image 2 par rapport à l'image 1

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img1 | oui / non | oui / oui / oui | oui / oui
Img2 | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img1
GetImage Img2

RECALAGEAUTO Img1 Img2 Dx Dy

PRINT "Décalage en X de Img2 par rapport à Img1 : " Dx
Print "Décalage en Y de Img2 par rapport à Img1 : " Dy

Télécharger l'exemple


Transformation / Translate

Translate

Description :

Cette fonction applique une translation sur l'image.
Dans le cas de coefficients réels, la translation a lieu par interpolation linéaire.

Syntaxe :

TRANSLATE Img Tx Ty

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image dans le PGM
Tx | Entrée | Réel | Déplacement horizontal de l'image
Ty | Entrée | Réel | Déplacement horizontal de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img

TRANSLATE Img 12 14.5

Télécharger l'exemple


Traitement / UnSharp

UnSharp

Description :

Cette fonction permet d'appliquer un masque flou sur une image.
L'opération consiste à fabriquer une image FLOUE de l'objet en faisant passer un filtre passe-bas de gauss avec un certain sigma. On considère l'IMAGE de départ comme la réunion d'une image floue + des détails. Par la suite l'opération IMAGE - COEFF MULTIPLICATEUR * FLOUE est effectuée pour faire ressortir les détails.

Syntaxe :

UNSHARP Img Sigma Mult TraitStell

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Sigma | Entrée | Réel | Sigma de la gaussienne appliquée pour le masque flou
Mult | Entrée | Réel | Coefficient multiplicateur de l'image floue
TraiStell | Entrée | Entier (booléen) | Booléen indiquant si l'image est une image stellaire ou planétaire : TraiStell = 1 pour des images stellaires et TraitStell=0 pour des images planétaires.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
Gauss
LowPass

Exemple :

................................
GetImage Img

Unsharp img 1.5 2 0

Télécharger l'exemple


Transformation / DDP

DDP

Description :

Cette fonction execute l'algorithme du DDP sur une image.

Pour plus d'information, voir la fonction correspondante : [Transformation] > [Digital Developpment Processing (DDP)]

Syntaxe :

DDP Img Sigma Level

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Sigma | Entrée | Réel | Facteur de netteté
Level | Entrée | Réel | Effet de Gamma

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

..........................................
Input "Facteur de netteté ?" Sigma
Input "Effet de Gamma ?" Level

DDP Img Sigma Level

Télécharger l'exemple


Transformation / Int2Real

Int2Real

Description :

Cette fonction convertie une image codée par des valeurs entières en une image sur des valeurs réelles.

Syntaxe :

INT2REAL Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image à convertir

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img

INT2REAL Img

Télécharger l'exemple


Transformation / Real2Int

Real2Int

Description :

Cette fonction convertie une image codée par des valeurs réelles en une image sur des valeurs entières.

Syntaxe :

REAL2INT Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée / Sortie | Image | Nom interne de l'image à convertir

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img

REAL2INT Img

Télécharger l'exemple


Propriétés images / GetDate

GetDate

Description :

Cette fonction permet de lire les champs "Général / ANNEE,MOIS,JOUR" dans les propriétés d'une image.
Même si les champs sont des chaînes de caractères, les valeurs "An,Mois,Jour" sont des nombres.
Attention : Pour fonctionner, les champs "ANNEE,MOIS,JOUR" doivent être complétés dans l'entête de l'image. Si ces champs sont vides, les valeurs de "An,Mois,Jour" seront de 0.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entêtes "Jour / Mois / Année " ) que des images au format FITS ( entête "DATE-OBS=" qui représente la date d'observation et non d'enregistrement dans "DATE=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".
Attention : Cette fonction n'indique pas l'heure d'acquisition.\nPour celà, voir la fonction associée "GetTime".

Syntaxe :

GETDATE Img An Mois Jour
/// OU ///
GETDATE Img Annee

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
An | Sortie | Entier | Variable dans laquelle est contenue l'année d'acquisition
Mois | Sortie | Entier | Variable dans laquelle est contenue le mois de l'acquisition
Jour | Sortie | Entier | Variable dans laquelle est contenu le jour de l'acquisition
/// OU /// |  |  |
Annee | Sortie | Réel | Format de date Delphi. Représente le nombre de jours qui se sont écoulés depuis le 30 décembre 1899. Voir aussi : les commentaires sur la fonction NOW

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GetImage Img
GETDATE Img AA MM JJ
.............................................
.............................................
GETDATE Img AnneeD
.............................................

Télécharger l'exemple


Propriétés images / GetExpTime

GetExpTime

Description :

Cette fonction permet de lire le champ "Général / Temps d'exposition" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "TIME" est un nombre, dont l'unité est en millisecondes.
Attention : Pour fonctionner, le champ "Temps d'exposition" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "TIME" est 0
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Temps de pose (sec)" ) que des images au format FITS ( entête "EXPOSURE=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".
Dans le cas d'une image couleur (RVB), ce temps représente le temps de pose cumulée dans les trois couleurs.

Syntaxe :

GETEXPTIME Img Time

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Time | Sortie | Entier | Temps de pose de l'image en milliseconde

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GetImage Img
REM Obtenir le test d'exposition
GETEXPTIME Img ExpTime
......................................

Télécharger l'exemple


Fichiers / GetHeaderStringFITS

GetHeaderStringFITS

Description :

Cette fonction permet de récupérer la valeur (sous forme de chaîne de caractères) d'un mot clé d'une entête FITS.
Pour rappel, un mot clé FITS a une longueur maximale de 8 caractères.

Syntaxe :

GETHEADERSTRINGFITS chemin$ KW$ Value$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Chemin$ | Entrée | Chaînes de caractères | Chemin complet où trouver l'image.
KW$ | Entrée | Chaînes de caractères | Mot clé à chercher.
Value$ | Sortie | Chaînes de caractères | Liste des caractères de l'entête à la suite du mot clé.

Exemple :

GETFILENAME chemin$

.....................
GETHEADERSTRINGFITS chemin$ KW$ Value$

Télécharger l'exemple


Propriétés images / GetJulianDay

GetJulianDay

Description :

Cette fonction permet de lire le champ "Général / Jour Julien intermédiare" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Jday" est un nombre.
Attention : Pour fonctionner, le champ "Jour Julien Intermédiaire" doit être complété dans l'entête de l'image. Si ce champ est vide ( très rare !), une erreur sera renvoyée.
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Jour julien intermédiaire" indiquant le JJ du mileu de la pose ) que des images au format FITS ( entête "JDAY=" mais cette fois n'indique pas le JJ du milieu de la pose mais du début ... de toute façon, la précision n'est pas meilleure que le centième de jour ! )
A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETJULIANDAY Img Jd

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Jd | Sortie | Réel | Date du milieu de la pose en JJ

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETJULIANDAY Img dy
Print "Datation milieu de la pose = " dy

Télécharger l'exemple


Propriétés images / GetTime

GetTime

Description :

Cette fonction permet de lire les champs "Général / HEURE,MINUTES,SECONDES" dans les propriétés d'une image, qui indique l'heure du début de l'acquisition.
Même si les champs sont des chaînes de caractères, les valeurs "HOUR,MIN,SEC,MSEC" sont des nombres.
Attention : Pour fonctionner, les champs "HEURE,MINUTES,SECONDES,MS" doivent être complétés dans l'entête de l'image. Si ces champs sont vides, les valeurs de "HOUR,MIN,SEC,MSEC" seront de 0
Cette fonction fonctionne aussi bien pour des images au format CPA ( entêtes "Heure / Minutes / Secondes" ) que des images au format FITS ( dans entête "DATE-OBS=" ou "UT-START" qui représente la date d'observation et non d'enregistrement comme pour "DATE=" ).
A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".
Pour une image en couleur (RVB), cette donnée donne l'heure du début de la première acquisition.

Attention : Cette fonction n'indique pas la date d'acquisition. Pour celà, voir la fonction associée "GETDATE".

Syntaxe :

GETTIME Img HR MM SS MS
/// OU ///
GETTIME Img heureD

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
HR | Sortie | Entier | Heure du début de la prise de vue
MM | Sortie | Entier | Minute de la date du début de la prise de vue
SS | Sortie | Entier | Seconde de la date du début de la prise de vue
MS | Sortie | Entier | Miliseconde de la date du début de la prise de vue
/// OU /// |  |  |
HeureD | Sortie | Réel | Nombre fractionnaire entre 0 et 1 0 = 00h00m00.0s et 1 = 24h00m00.0s

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GetImage Img
GETTIME Img Hour Min Sec MSec
.............................................
.............................................
GETTIME Img HeureD
.............................................

Télécharger l'exemple


Propriétés images / Height

Height

Description :

Cette fonction donne la hauteur physique d'une image contenant dans le champ "Général / Hauteur " d'une image.
Attention : Pour fonctionner, le champ "HAUTEUR" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "height" est "0"
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Hauteur" ) que pour des images au format FITS ( entête "NAXIS2" ).
A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

HEIGHT Img height

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
height | Sortie | Entier | Hauteur de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
HEIGHT Img Height
Print "Hauteur de l'image = " Height

Télécharger l'exemple


Propriétés images / SetObjectName

SetObjectName

Description :

Cette fonction permet d'écrire dans le champ "Général / Nom de l'objet" dans les propriétés de l'image CPA.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Nom de l'objet" ) mais pas pour des images au format FITS.

Syntaxe :

SETOBJECTNAME Img Name$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Name$ | Entrée | Chaîne de caractères | Nom de l'objet

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
Input "Nom de l'objet ?" Name$
SETOBJECTNAME Img Name$
.............................................

Télécharger l'exemple


Propriétés images / GetObjectName

GetObjectName

Description :

Cette fonction permet de lire le champ "Général / Nom de l'objet" dans les propriétés de l'image CPA.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Nom de l'objet" ) mais pas pour des images au format FITS.

Syntaxe :

GETOBJECTNAME Img Name$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Name$ | Sortie | Chaîne de caractères | Nom de l'objet contenu dans l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETOBJECTNAME Img Name$
PRINT "Nom de l'objet : " Name$
.............................................

Télécharger l'exemple


Propriétés images / Width

Width

Cette fonction donne la largeur physique d'une image contenant dans le champ "Général / Largeur " d'une image.
Attention : Pour fonctionner, le champ "LARGEUR" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "width" est "0"
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Hauteur" ) que pour des images au format FITS ( entête "NAXIS1" ).
A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

WIDTH Img width

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
width | Sortie | Entier | Largeur de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
WIDTH Img Width
Print "Largeur de l'image = " Width

Télécharger l'exemple


Propriétés images / GetBandWidth

GetBandWidth

Description :

Cette fonction permet de lire le champ "Prise de vue / Bande passante" dans les propriétés de l'image CPA.
Même si le champ est une chaîne de caractère, la valeur "BANDE" est un nombre dont l'unité est en nm.
Attention : Pour fonctionner, le champ "Bande passante" doit être complété dans l'entête de l'image par un nombre (et non par une chaîne de caractère type "R+V+B"). Si ce champ est vide, la valeur de "BANDE" est 0
Lors d'une observation, ce champ est complété automatiquement en remplissant auparavant le menu "Caméra / Données entête ".
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Bande passante" ) mais pas pour des images au format FITS. Pour ces dernières, la valeur renvoyée sera donc de 0.

Syntaxe :

GETBANDWIDTH Img Bande

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Bande | Sortie | Réel | Bande passante du filtre utilisé

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETBANDWIDTH Img Band
Print "Bande passante = " Band
.............................................

Télécharger l'exemple


Propriétés images / GetBinX

GetBinX

Description :

Cette fonction permet de lire le champ "Prise de vue / Binning X" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "BINX" est un nombre.
Attention : Pour fonctionner, le champ "Binning X" doit être complété dans l'entête de l'image. Pour une image CPA, ceci est toujours le cas, par défaut égal à 1. Si ce champ est vide, la valeur de "BINX" est 0
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Binning X" ) que des images au format FITS ( entête "BINX=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETBINX Img BinX

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
BinX | Sortie | Entier | Binning utilisé sur l'axe des X

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETBINX Img BinX
Print "Binning suivant X = " BinX
.............................................

Télécharger l'exemple


Propriétés images / GetBinY

GetBinY

Description :

Cette fonction permet de lire le champ "Prise de vue / Binning Y" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "BINY" est un nombre.
Attention : Pour fonctionner, le champ "Binning Y" doit être complété dans l'entête de l'image. Pour une image CPA, ceci est toujours le cas, par défaut égal à 1. Si ce champ est vide, la valeur de "BINY" est 0
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Binning Y" ) que des images au format FITS ( entête "BINY=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETBINY Img BinY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
BinY | Sortie | Entier | Binning utilisé sur l'axe des Y

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETBINY Img BinY
Print "Binning suivant Y = " BinY
.............................................

Télécharger l'exemple


Propriétés images / GetCamera

GetCamera

Description :

Cette fonction permet de lire le champ "Prise de vue / Caméra" dans les propriétés d'une image.
Attention : Pour fonctionner, le champ "CAMERA" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "CAM$" est "?"
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Caméra" ) que pour des images au format FITS ( entête "INSTRUME=" ).
A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETCAMERA Img Cam$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Cam$ | Sortie | Chaîne de caractères | Caméra utilisée pour l'acquisition de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETCAMERA Img Camera$
Print "Nom de la caméra = " Camera$

Télécharger l'exemple


Propriétés images / GetCVFFactor

GetCVFFactor

Description :

Cette fonction permet de lire le champ "Prise de vue / Conversion e-/ADU" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Factor" est un nombre.
Attention : Pour fonctionner, le champ "Conversion e-/ADU" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Factor" est de 0.
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement si le menu "Caméra / Données entête" est rempli.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Conversion e-/ADU" ) mais pas pour des images au format FITS. La valeur renvoyée sera alors de 0.

Syntaxe :

GETCVFFACTOR Img Factor

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Factor | Sortie | Réel | Conversion e-/ADU de la caméra lors de la prise de vue

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETCVFFACTOR Img Factor
Print "Gain en e-/ADU = " Factor
.............................................

Télécharger l'exemple


Propriétés images / GetDiameter

GetDiameter

Description :

Cette fonction permet de lire le champ "Prise de vue / Diamètre" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Diameter" est un nombre en mm.
Attention : Pour fonctionner, le champ "Diamètre" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Diameter" est 0
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement si l'utilisateur a pris soin de compléter le menu "Caméra / Données entête ".
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Diamètre (mm)" ) mais pas pour des images au format FITS ( pas d'entête correspondante en tête de fichier ! ). Pour ce dernier, la valeur "DIAMETER" sera alors de 0. A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETDIAMETER Img Diameter

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Diameter | Sortie | Réel | Diamètre de l'instrumùent lors de la prise de vue

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETDIAMETER Img Diametre
Print "Diamètre = " Diametre " millimetres"
.............................................

Télécharger l'exemple


Propriétés images / GetFilter

GetFilter

Description :

Cette fonction permet de lire le champ "Prise de vue / Filtres" dans les propriétés d'une image.
Attention : Pour fonctionner, le champ "Filtres" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "FILTRE$" est "?"
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement si l'utilisateur a pris soin de compléter le menu "Caméra / Données entête ".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Filtres" ) que pour des images au format FITS ( entête "FILTERS=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETFILTER Img Filtre$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Filtre$ | Sortie | Chaîne de caractères | Filtre(s) utilisé(s)

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETFILTER Img Filter$
Print "type de filtre = " Filter$
.............................................

Télécharger l'exemple


Propriétés images / GetFocus

GetFocus

Description :

Cette fonction permet de lire le champ "Prise de vue / Focale" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "FOCALE" est un nombre en mm.
Attention : Pour fonctionner, le champ "Focale" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "FOCALE" est 0
Dans le cas d'une observation avec acquisition par caméra supportée par PRiSM, ce champ sera complété automatiquement si l'utilisateur a pris soin de compléter le menu "Caméra / Données entête ".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Focale (mm)" ) mais aussi pour des images au format FITS ( entête "FOCAL=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETFOCUS Img FOCALE

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
FOCALE | Sortie | Réel | Focale de l'instrumùent lors de la prise de vue

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETFOCUS Img Focus
Print "Focale = " Focus " millimetres"
.............................................

Télécharger l'exemple


Propriétés images / GetMirrorX

GetMirrorX

Description :

Cette fonction permet de lire le champ "Prise de vue / Miroir X" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "MIRROR" est un nombre qui vaut 1 dans le cas positif (=TRUE) et 0 sinon (=FALSE).
Dans le cas d'un enregistrement avec PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Miroir X" ) que des images au format FITS ( entête "MIRORX=" qui est à "T" dans le cas positif et "F" sinon ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETMIRRORX Img MIRRORX

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
MIRRORX | Sortie | Booléen | Si un miroir suivant X a été effectué sur l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETMIRRORX Img MirrorX
if MirrorX=1
   Print "Un Miroir suivant X a été effectué sur cette image"
else
   Print "Pas de Miroir suivant X effectué sur cette image"
endif
.............................................

Télécharger l'exemple


Propriétés images / GetMirrorY

GetMirrorY

Description :

Cette fonction permet de lire le champ "Prise de vue / Miroir Y" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "MIRROR" est un nombre qui vaut 1 dans le cas positif (=TRUE) et 0 sinon (=FALSE).
Dans le cas d'un enregistrement avec PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Miroir Y" ) que des images au format FITS ( entête "MIRORY=" qui est à "T" dans le cas positif et "F" sinon ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETMIRRORY Img MIRRORY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
MIRRORY | Sortie | Booléen | Si un miroir suivant Y a été effectué sur l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETMIRRORY Img MirrorY
if MirrorY=1
   Print "Un Miroir suivant Y a été effectué sur cette image"
else
   Print "Pas de Miroir suivant Y effectué sur cette image"
endif
.............................................

Télécharger l'exemple


Propriétés images / GetSizePixX

GetSizePixX

Description :

Cette fonction permet de lire le champ "Prise de vue / Taille X pixel (µm)" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "TAILLEX" est un nombre, dont l'unité est en µm.
Attention : Pour fonctionner, le champ "Taille X pixel (µm)" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "TAILLEX" est 0.
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM, à condition d'avoir complété le menu "Caméra / Données entête".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Taille X pixel (µm)" ) que pour des images au format FITS ( entête "CDELTM1=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETSIZEPIXX Img TAILLEX

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
TAILLEX | Sortie | Réel | Taille physique du pixel suivant X pour l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETSIZEPIXX Img SizePixX
Print "Taille des pixels suivant X = " SizePixX " microns"
.............................................

Télécharger l'exemple


Propriétés images / GetSizePixY

GetSizePixY

Description :

Cette fonction permet de lire le champ "Prise de vue / Taille Y pixel (µm)" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "TAILLEY" est un nombre, dont l'unité est en µm.
Attention : Pour fonctionner, le champ "Taille Y pixel (µm)" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "TAILLEY" est 0.
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM, à condition d'avoir complété le menu "Caméra / Données entête".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Taille Y pixel (µm)" ) que pour des images au format FITS ( entête "CDELTM2=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETSIZEPIXY Img TAILLEY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
TAILLEY | Sortie | Réel | Taille physique du pixel suivant Y pour l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETSIZEPIXY Img SizePixY
Print "Taille des pixels suivant Y = " SizePixY " microns"
.............................................

Télécharger l'exemple


Propriétés images / GetTCCD

GetTCCD

Description :

Cette fonction permet de lire le champ "Prise de vue / Température CCD" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Temp" est un nombre, dont l'unité est en °C.
Attention : Pour fonctionner, le champ "Température CCD" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Temp" est à 0.
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Température CCD" ) mais pas pour des images au format FITS. Dans ce cas, la valeur renvoyée sera de 0. A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETTCCD Img Temp

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Temp | Sortie | Réel | Température du CCD de la caméra lors de la prise de vue

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETTCCD Img Temp
Print "Température CCD = " Temp " °C"
.............................................

Télécharger l'exemple


Propriétés images / GetTExt

GetTExt

Description :

Cette fonction permet de lire le champ "Prise de vue / Extérieur" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Temp" est un nombre, dont l'unité est en °C.
Attention : Pour fonctionner, le champ "Extérieur" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Temp" est à 0.
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Extérieur" ) mais pas pour des images au format FITS. Dans ce cas, la valeur renvoyée sera de 0. A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETTEXT Img Temp

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Temp | Sortie | Réel | Température extérieure lors de la prise de vue

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETTEXT Img Temp
Print "Température extérieure = " Temp " °C"
.............................................

Télécharger l'exemple


Propriétés images / GetTimeReadCCD

GetTimeReadCCD

Description :

Cette fonction permet de lire le champ "Prise de vue / Temps de lecture" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "TIME" est un nombre, dont l'unité est en secondes.
Attention : Pour fonctionner, le champ "Tps de lecture" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "TIME" est 0.
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Tps de lecture (s)" ) mais pas pour des images au format FITS. La valeur renvoyé pour ce dernier type d'image sera alors de 0.
A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETTIMEREADCCD Img Time

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Time | Sortie | Entier | Temps pour vider la matrice CCD durant l'acquisition

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GetTimeReadCCD Img Time
Print "Temps de lecture = " Time
.............................................

Télécharger l'exemple


Propriétés images / GetWaveLength

GetWaveLength

Description :

Cette fonction permet de lire le champ "Prise de vue / Longueur d'onde centrale" dans les propriétés de l'image CPA.
Même si le champ est une chaîne de caractère, la valeur "WL" est un nombre dont l'unité est en nm.
Attention : Pour fonctionner, le champ "Longueur d'onde centrale" doit être complété dans l'entête de l'image par un nombre. Si ce champ est vide, la valeur de "WL" est 0
Lors d'une observation, ce champ est complété automatiquement en remplissant auparavant le menu "Caméra / Données entête ".
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Longueur d'onde centrale" ) mais pas pour des images au format FITS. Pour ces dernières, la valeur renvoyée sera donc de 0.

Syntaxe :

GETWAVELENGTH Img WL

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
WL | Sortie | Réel | Longueur d'onde centrale

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETWAVELENGTH Img Wave
Print "Longueur d'onde centrale (nm) = " Wave
.............................................

Télécharger l'exemple


Objets / Get_WL_BW_FLX

Get_WL_BW_FLX

Description :

Cette fonction permet de lire le champ "Prise de vue / Longueur d'onde centrale", "Prise de vue / Bande passante" et "Astrométrie - Photométrie / Flux ADU" dans les propriétés d'une image.
Même si ces champs sont des chaînes de caractères, les valeurs sont des nombres.
Attention : Pour fonctionner, les champs "Longueur d'onde centrale", "Bande passante" et "Flux ADU" doivet être complétés dans l'entête de l'image. Si ces champs sont vides, les valeurs seront de 0.
Ces fonctions ne fonctionnent que pour des images au format CPA mais pas pour des images au format FITS.

Syntaxe :

GET_WL_BW_FLX Img WL BW Flux

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
WL | Sortie | Réel | Longueur d'onde centrale
BW | Sortie | Réel | Bande passante du filtre utilisé
Flux | Sortie | Entier / Réel | Champ "FLUX" dans les propriétés de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

......................................
REM Permet de connaître le flux et les données spectrales
Get_WL_BW_FLX Img WL BW FLX
Print "Flux d'une étoile avec la magnitude 0 " FLX
Print "Bande passante = " BW
Print "Longueur d'onde = " WL

Télécharger l'exemple


Propriétés images / SetBandWidth

SetBandWidth

Description :

Cette fonction permet d'écrire dans le champ "Prise de vue / Bande passante" dans les propriétés de l'image CPA.
Même si le champ est une chaîne de caractère, la valeur "BANDE" est un nombre dont l'unité est en nm.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Bande passante" ) mais pas pour des images au format FITS.

Syntaxe :

SETBANDWIDTH Img Bande

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Bande | Entrée | Réel | Bande passante du filtre utilisé pour l'acquisition

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
Input "Bande passante = " Band
SETBANDWIDTH Img Band
.............................................

Télécharger l'exemple


Propriétés images / SetWaveLength

SetWaveLength

Description :

Cette fonction permet d'écrire dans le champ "Prise de vue / Longueur d'onde centrale" dans les propriétés de l'image CPA.
Même si le champ est une chaîne de caractère, la valeur "WL" est un nombre dont l'unité est en nm.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Longueur d'onde centrale" ) mais pas pour des images au format FITS.

Syntaxe :

SETWAVELENGTH Img WL

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
WL | Entrée | Réel | Longueur d'onde centrale pour l'acquisition

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
Input "Longueur d'onde centrale (nm) = " Wave
SETWAVELENGTH Img Wave
.............................................

Télécharger l'exemple


Propriétés images / Set_Header_ExpTime

Set_Header_ExpTime

Description :

Cette fonction permet de modifier la durée de la prise de vue d'une image dans les champs "Général" des propriétés d'une image CPA .
Par défaut, ce champ est toujours complété.
L'image doit être ouverte dans le script et doit être ensuite sauvegardée pour conserver les paramètres de changement.

Syntaxe :

SET_HEADER_EXPTIME Img ExpTime

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
ExpTime | Entrée | Réel | Durée de la pose pour l'image en millisecondes

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
user1=300.0

SET_HEADER_EXPTIME Img user1

savecpa img "c:\temp\totoa.cpa"
.............................................

Télécharger l'exemple


Propriétés images / Set_Header_DateTime

Set_Header_DateTime

Description :

Cette fonction permet de modifier la date de prise de vue d'une image dans les champs "Général" des propriétés d'une image CPA .
Par défaut, ce champ est toujours complété.
L'image doit être ouverte dans le script et doit être ensuite sauvegardée pour conserver les paramètres de changement.

Syntaxe :

SET_HEADER_EXPTIME Img JulianDay

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
JulianDay | Entrée | Réel | Date du début de pose de l'image en Jour Julien

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
user1=300.0

SET_HEADER_DATETIME Img user1

savecpa img "c:\temp\totoa.cpa"
.............................................

Télécharger l'exemple


Propriétés images / Set_Filtername_Header

Set_Filtername_Header

Description :

Cette fonction permet d'écrire dans le champ "Prise de vue / Filtres" dans les propriétés d'une image.

Syntaxe :

SET_FILTERNAME_HEADER Img Filtre$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Filtre$ | Sortie | Chaîne de caractères | Filtre(s) utilisé(s)

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
SET_FILTERNAME_HEADER Img Filter$
GETFILTER Img Filtre$
Print "type de filtre = " Filtre$
.............................................

Télécharger l'exemple


Propriétés images / GetAlpha

GetAlpha

Description :

Cette fonction permet de lire le champ "Astro - Photo / Alpha" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "ALPHA" est un nombre.
Attention : Pour fonctionner, le champ "Alpha" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "ALPHA" est 0,0.
Dans le cas d'une observation avec acquisition par caméra et télescope supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Alpha" ) que des images au format FITS ( entête "RA =" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETALPHA Img Alpha

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Alpha | Sortie | Réel | Ascension droite du centre de l'image en radian

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

REM Permet de connaître l'ascension droite 2000.0 du centre de l'image
GetAlpha Img Alpha

RAD_TO_RA Alpha Alpha$
PRINT "Ascension Droite 2000.0 = " Alpha$

Télécharger l'exemple


Propriétés images / GetDelta

GetDelta

Description :

Cette fonction permet de lire le champ "Astro - Photo / Delta" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "DELTA" est un nombre.
Attention : Pour fonctionner, le champ "Delta" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "DELTA" est 0,0.
Dans le cas d'une observation avec acquisition par caméra et télescope supportée par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Delta" ) que des images au format FITS ( entête "DEC =" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETDELTA Img Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Delta | Sortie | Réel | Déclinaison du centre de l'image en radian

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

REM Permet de connaître la déclinaison du centre de l'image
GetDelta Img Delta

RAD_TO_DEC Delta Delta$
PRINT "Déclinaison 2000.0 = " Delta$

Télécharger l'exemple


Objets / GetFlux

GetFlux

Description :

Cette fonction permet de lire le champ "Astrométrie - Photométrie / Flux ADU" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Flux" est un nombre.
Attention : Pour fonctionner, le champ "Flux ADU" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "FLUX" est 0.
Ce champ est complété automatiquement dès que la calibration photométrique a été effectuée.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Flux ADU" ) mais pas pour des images au format FITS.La valeur renvoyée sera alors de 0.

Syntaxe :

GETFLUX Img Flux magni Err

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Flux | Sortie | Entier / Réel | Champ "FLUX" dans les propriétés de l'image
Magni | Sortie | Réel | Magnitude de l'étoile correspondante
Err | Sortie | Réel | Pourcentage d'erreur estiné sur le flux

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

......................................
GETFLUX Img Flux magni Err
Print "Flux d'une étoile avec la magnitude " magni " = " Flux " erreur =" Err "%"

Télécharger l'exemple


Propriétés images / GetImageAirMass

GetImageAirMass

Description :

Cette fonction permet de calculer la masse d'air entre l'objet et la capteur dans une image.
Les informations nécessaires sont la date de la prise d'image ainsi que les coordonnées 2000.0 du centre de l'image.
Cette fonction fonctionne aussi bien pour des images au format CPA mais aussi pour des images au format FITS.

Syntaxe :

GETIMAGEAIRMASS Img AirMass

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
AirMass | Sortie | Réel | Masse d'air entre capteur et objet

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
REM Permet de connaître la masse d'air entre l'objet le capteur
GetImageAirMass Img AirMass
Print "Masse d'air = " AirMass

Télécharger l'exemple


Objets / GetLatitude

GetLatitude

Description :

Cette fonction permet de lire le champ "Photométrie - Astrométrie / Latitude" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Lat" est un nombre, dont l'unité est en radians.
Attention : Pour fonctionner, le champ "Latitude" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Lat" est 0
Dans le cas d'une observation avec acquisition par caméra et par télescope supportés par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Latitude" ) que des images au format FITS ( entête "SITELAT=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETLATITUDE Img Lat

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Lat | Sortie | Réel | Latitude en radian du lieu d'observation où l'acquisition a été prise

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

......................................
GETLATITUDE Img Latitude
Print "Latitude où a été prise l'acquisition = " Latitude " radians"

Télécharger l'exemple


Objets / GetLongitude

GetLongitude

Description :

Cette fonction permet de lire le champ "Photométrie - Astrométrie / Longitude" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Long" est un nombre, dont l'unité est en radians.
Attention : Pour fonctionner, le champ "Longitude" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Long" est 0
Dans le cas d'une observation avec acquisition par caméra et par télescope supportés par PRiSM, ce champ sera complété automatiquement.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Longitude" ) que des images au format FITS ( entête "SITELONG=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETLONGITUDE Img Long

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Long | Sortie | Réel | Longitude en radian du lieu d'observation où l'acquisition a été prise

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

......................................
GETLONGITUDE Img Longitude
Print "Longitude où a été prise l'acquisition = " Longitude " radians"

Télécharger l'exemple


Propriétés images / GetLowerThrHold

GetLowerThrHold

Description :

Cette fonction permet de lire le champ "SEUIL BAS" du menu "Visualisation / Contraste et Luminosité".
Dans le cas d'un enregistrement avec PRiSM, ce champ sera complété automatiquement. Les valeurs peuvent même être choisie manuellement lors de l'acquisition.
Cette fonction fonctionne aussi bien pour des images au format CPA ( mais non lisible dans l'entête ) que des images au format FITS ( entête "DATAMIN=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETLOWERTHRHOLD Img LowThres

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
LowThres | Sortie | Entier / Réel | Seuil bas de l'image en ADU

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GetLowerThrHold Img LTH
Print "Seuil bas = " LTH
.............................................

Télécharger l'exemple


Propriétés images / GetObservatory

GetObservatory

Description :

Cette fonction permet de lire le champ "Photométrie - Astrométrie / Observatoire" dans les propriétés d'une image.
Attention : Pour fonctionner, le champ "Observatoire" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "OBS$" est "?"
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM, à condition d'avoir complété le menu "Caméra / Configuration Caméra".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Observatoire" ) que pour des images au format FITS ( entête "ORIGIN=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETOBSERVATORY Img OBS$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
OBS$ | Sortie | Chaîne de caractères | Champ "Observatoire" dans l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

...............................
GETOBSERVATORY Img Observatory$
Print "Nom de l'observatoire = " Observatory$
.............................................

Télécharger l'exemple


Propriétés images / GetObserver

GetObserver

Description :

Cette fonction permet de lire le champ "Photométrie - Astrométrie / Observateur" dans les propriétés d'une image.
Attention : Pour fonctionner, le champ "Observateur" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "OBS$" est "?"
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM, à condition d'avoir complété le menu "Caméra / Configuration Caméra".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Observateur(s)" ) que pour des images au format FITS ( entête "OBSERVER=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETOBSERVER Img OBS$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
OBS$ | Sortie | Chaîne de caractères | Champ "Observateur" dans l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

...............................
GETOBSERVER Img Observer$
Print "Nom de l'observateur = " Observer$
.............................................

Télécharger l'exemple


Propriétés images / GetSeeing

GetSeeing

Description :

Cette fonction permet de lire le champ "Photométrie - Astrométrie / Seeing" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Seeing" est un nombre, dont l'unité est en seconde d'arc. Attention : Pour fonctionner, le champ "Seeing" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "Seeing" est 0.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Seeing (")" ) mais pas pour des images au format FITS. La valeur renvoyée sera alors de 0.

Syntaxe :

GETOBSERVATORY Img Seeing

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Seeing | Sortie | Réel | Champ "Seeing" dans l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

...............................
GETSEEING Img Seeing

Print "Seeing durant l'acquisition = " Seeing " secondes"
.............................................

Télécharger l'exemple


Propriétés images / GetTelescope

GetTelescope

Description :

Cette fonction permet de lire le champ "Astrométrie - Photométrie / Télescope" dans les propriétés d'une image.
Attention : Pour fonctionner, le champ "Télescope" doit être complété dans l'entête de l'image. Si ce champ est vide, la valeur de "TEL$" est "?"
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supportée par PRiSM, à condition d'avoir complété le menu "Caméra / Configuration Caméra".
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Télescope" ) que pour des images au format FITS ( entête "TELESCOP=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETTELESCOPE Img tel$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Tel$ | Sortie | Chaîne de caractères | Champ "Télescope" dans l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

...............................
GETTELESCOPE Img Telescope$
Print "type de télescope = " Telescope$
.............................................

Télécharger l'exemple


Propriétés images / GetUpperThrHold

GetUpperThrHold

Description :

Cette fonction permet de lire le champ "SEUIL HAUT" du menu "Visualisation / Contraste et Luminosité".
Dans le cas d'un enregistrement avec PRiSM, ce champ sera complété automatiquement. Les valeurs peuvent même être choisie manuellement lors de l'acquisition.
Cette fonction fonctionne aussi bien pour des images au format CPA ( mais non lisible dans l'entête ) que des images au format FITS ( entête "DATAMAX=" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

GETUPPERTHRHOLD Img UpThres

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
UpThres | Sortie | Entier / Réel | Seuil haut de l'image en ADU

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GetUpperThrHold Img UTH
Print "Seuil HAUT = " UTH
.............................................

Télécharger l'exemple


Propriétés images / PutAlpha

PutAlpha

Description :

Cette fonction permet d'écrire dans le champ "Astro - Photo / Alpha" dans les propriétés d'une image.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Alpha" ) que des images au format FITS ( entête "RA =" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

PUTALPHA Img Alpha

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Alpha | Entrée | Réel | Ascension droite du centre de l'image en radian

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

INPUT "Heure de l'ascension droite " HH
INPUT "Minutes de l'ascension droite " MIN
INPUT "Secondes de l'ascension droite " SEC
STR_RA_TO_RAD HH MIN SEC Alpha

PUTALPHA Img Alpha

Télécharger l'exemple


Propriétés images / PutDelta

PutDelta

Description :

Cette fonction permet d'écrire dans le champ "Astro - Photo / Delta" dans les propriétés d'une image.
Cette fonction fonctionne aussi bien pour des images au format CPA ( entête "Delta" ) que des images au format FITS ( entête "DEC =" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

PUTDELTA Img Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Delta | Entrée | Réel | Déclinaison du centre de l'image en radian

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

INPUT "Degrés de déclinaison " DEG
INPUT "Minutes d'arc de déclinaison " MIN
INPUT "Secondes d'arc de déclinaison " SEC
STR_DEC_TO_RAD DEG MIN SEC Delta

PUTDELTA Img Delta

Télécharger l'exemple


Objets / SetFlux

SetFlux

Description :

Cette fonction permet d'écrire dans le champ "Astrométrie - Photométrie / Flux ADU" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "Flux" est un nombre.
Cette valeur correspond au flux d'une étoile qui aurait la magnitude 0.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Flux ADU" ) mais pas pour des images au format FITS.

Syntaxe :

SETFLUX Img Flux

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Flux | Entrée | Entier / Réel | Champ "FLUX" à compléter dans les propriétés de l'image

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

......................................
Input "Flux d'une étoile avec la magnitude 0 " Flux
SETFLUX Img Flux

Télécharger l'exemple


Propriétés images / GetPierSide

GetPierSide

Description :

Cette fonction permet de lire le champ "Astrométrie-Photométrie / Tube côté Est du pied" dans les propriétés d'une image.
Même si le champ est un booléen, la valeur "East" est un nombre qui vaut 1 dans le cas positif (=TRUE) et 0 sinon (=FALSE).
Dans le cas d'un enregistrement avec PRiSM, ce champ sera complété automatiquement pour une monture allemande.
Cette fonction ne fonctionne que pour des images au format CPA.

Syntaxe :

GETPIERSIDE Img East

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
East | Sortie | Booléen | Si le tube est côté EST du pied (définition ASCOM)

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETPIERSIDE Img Side
if Side=1
   Print "Image acquise lorsque le tube est coté EST"
else
   Print "Image acquise lorsque le tube est coté OUEST"
endif
.............................................

Télécharger l'exemple


Propriétés images / GetCCDOri

GetCCDOri

Description :

Cette fonction permet de lire le champ "Astrométrie-Photométrie / Orientation du CCD (°)" dans les propriétés d'une image.
Même si le champ est une chaîne de caractère, la valeur "TAILLEX" est un nombre, dont l'unité est en degré.
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM, à condition d'avoir correctement complété le menu "Caméra / Données entête".
Cette fonction ne fonctionne que pour des images au format CPA.

Syntaxe :

GETCCDORI Img Ori

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Ori | Sortie | Réel | Orientation de la CCD en °

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETCCDORI Img Ori
Print "Orientation de la CCD = " Ori "°"
.............................................

Télécharger l'exemple


Propriétés images / GetRepDirHeader

GetRepDirHeader

Description :

Cette fonction permet de lire le champ "Astrométrie-Photométrie / Repère direct" dans les propriétés d'une image.
Même si le champ est un booléen, la valeur "Dir" est un nombre qui vaut 1 dans le cas direct (=TRUE) et 0 sinon (=FALSE).
Lors d'une observation, ce champ est complété automatiquement en faisant l'acquisition avec une caméra supporté par PRiSM, à condition d'avoir correctement complété le menu "Caméra / Données entête".
Cette fonction ne fonctionne que pour des images au format CPA.

Syntaxe :

GETREPDIRHEADER Img Dir

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Dir | Sortie | Booléen | Si le repère est direct

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

................................
GETREPDIREHEADER Img Dir
if Dir=1
   Print "Repère DIRECT pour l'image"
else
   Print "Repère INDIRECT pour l'image"
endif
.............................................

Télécharger l'exemple


Propriétés images / SetReseauSpec

SetReseauSpec

Description :

Cette fonction permet d'écrire dans le champ "Spectroscopie / Résolution du spectro" dans les propriétés de l'image CPA.
Même si le champ est une chaîne de caractère, la valeur "Reso" est un nombre dont l'unité est en lignes/mm.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Résolution du spectro" ) mais pas pour des images au format FITS.

Syntaxe :

SETRESEAUSPEC Img Reso

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Reso | Entrée | Entier | Résolution du spectroscope

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
Input "Résolution réseau (traits/mm) ?" Reso
SETRESEAUSPEC Img Reso
.............................................

Télécharger l'exemple


Propriétés images / SetSpectroName

SetSpectroName

Description :

Cette fonction permet d'écrire dans le champ "Spectroscopie / nom du spectroscope" dans les propriétés de l'image CPA.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Nom du spectroscope" ) mais pas pour des images au format FITS.

Syntaxe :

SETSPECTRONAME Img Name$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Name$ | Entrée | Chaîne de caractères | Nom du spectroscope utilisé

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
Input "Nom du spectrographe ?" Name$
SETSPECTRONAME Img Name$
.............................................

Télécharger l'exemple


Propriétés images / GetReseauSpec

GetReseauSpec

Description :

Cette fonction permet de lire le champ "Spectroscopie / Résolution du spectro" dans les propriétés de l'image CPA.
Même si le champ est une chaîne de caractère, la valeur "Reso" est un nombre dont l'unité est en lignes/mm.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Résolution du spectro" ) mais pas pour des images au format FITS.

Syntaxe :

GETRESEAUSPEC Img Reso

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Reso | Sortie | Entier | Résolution du spectroscope

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETRESEAUSPEC Img Reso
PRINT "Résolution du réseau utilisé (traits/mm) : " Reso
.............................................

Télécharger l'exemple


Propriétés images / GetSpectroName

GetSpectroName

Description :

Cette fonction permet de lire le champ "Spectroscopie / nom du spectroscope" dans les propriétés de l'image CPA.
Cette fonction ne fonctionne que pour des images au format CPA ( entête "Nom du spectroscope" ) mais pas pour des images au format FITS.

Syntaxe :

GETSPECTRONAME Img Name$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Name$ | Sortie | Chaîne de caractères | Nom du spectroscope contenu dans les propriétés de l'image.

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
GETSPECTRONAME Img Name$
PRINT "Nom du spectrographe : " Name$
.............................................

Télécharger l'exemple


Propriétés images / Get_Header_Usr

Get_Header_Usr

Description :

Cette fonction permet de lire les champs "Commentaire / Utilisateur" dans les propriétés d'une image.
Par défaut, ces champs sont des nombres réels de valeur nulle.
Cette fonction ne fonctionne que pour des images au format CPA.

Syntaxe :

GET_HEADER_USR Img User1 User2 User3

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
User1 | Sortie | Réel | Nombre utilisateur n°1 de l'entête CPA "Commentaire / Utilisateur"
User2 | Sortie | Réel | Nombre utilisateur n°2 de l'entête CPA "Commentaire / Utilisateur"
User3 | Sortie | Réel | Nombre utilisateur n°3 de l'entête CPA "Commentaire / Utilisateur"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
open img "c:\temp\totoa.cpa"

GET_HEADER_USR Img user1 user2 user3

Print "User1= " user1
.............................................

Télécharger l'exemple


Propriétés images / SetComment

SetComment

Description :

Cette fonction permet d'écrire dans le champ "Commentaires" dans les propriétés d'une image.
Cette fonction fonctionne aussi bien pour des images au format CPA ( onglet "Commentaires" ) que des images au format FITS ( entête "COMMENT" ). A cette fin, voir les mots clés d'une entête FITS à partir du menu "Fichier / Entête FITS".

Syntaxe :

SETCOMMENT Img Comment$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
Comment$ | Entrée | Chaîne de caractères | Commentaire à rajouter sur la 1ère ligne uniquement (par dessus le commentaire existant éventuellement)

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Exemple :

REM Ajouter 2 lignes de commentaire
Com$="Ceci est mon image"
SETCOMMENT Img Com$

Télécharger l'exemple


Propriétés images / Set_Header_Usr

Set_Header_Usr

Description :

Cette fonction permet d'écrire dans les champs "Commentaire / Utilisateur" des propriétés d'une image CPA.
Par défaut, ces champs sont des nombres réels de valeur nulle.
Cette fonction ne fonctionne que pour des images au format CPA.

Syntaxe :

SET_HEADER_USR Img User1 User2 User3

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM
User1 | Entrée | Réel | Nombre utilisateur n°1 de l'entête CPA "Commentaire / Utilisateur"
User2 | Entrée | Réel | Nombre utilisateur n°2 de l'entête CPA "Commentaire / Utilisateur"
User3 | Entrée | Réel | Nombre utilisateur n°3 de l'entête CPA "Commentaire / Utilisateur"

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / non

Exemple :

................................
user3=7.568

SET_HEADER_USR Img user1 user2 user3

savecpa img "c:\temp\totoa.cpa"
.............................................

Télécharger l'exemple


Objets / GetObjectCoord

GetObjectCoord

Description :

Cette fonction permet de connaître les coordonnées équatoriales d'un objet du ciel profond (galaxies, nébuleuses) ou d'une étoile de certains catalogues d'étoiles.
Afin que cette fonction fonctionne, il n'est pas obligatoire d'avoir au préalable ouvert la base de données correspondante à l'objet demandé à partir des options d'affichage de la carte du ciel. Si l'objet n'est pas trouvé, les variables Alpha et Delta prennent la valeur -100.
L'objet devra être désigné par son nom propre ( ex : "PGC701").

Les catalogues de ciel profond supportés sont : M, NGC, IC, PK, ABELL, MCG, PGC, LDN, LBN, SH, UGC, VDB, ARP, B; il suffit de faire précéder le numéro de l'objet précédé de l'abbréviation ci-dessus pour que l'objet soit retrouvé.
Les catalogues d'étoiles supportés sont : BSC, HD, SAO, HIP, T (Tycho), LANDOLT; il suffit de faire précéder le numéro de l'objet précédé de l'abbréviation ci-dessus pour que l'objet soit retrouvé. Pour les catalogues WDS, LEONOS, GCV, il faudra faire précéder le nom réel de l'objet par un de ces trois préfixes car les noms sont tellement divers que la programmation l'a exigé.

Syntaxe :

GETOBJECTCOORD Objet$ Alpha Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
Objet$ | Entrée | Chaîne | Nom de l'objet
Alpha | Sortie | Réel | Ascension droite de l'objet en radians (utiliser les fonctions de conversion)
Delta | Sortie | Réel | Déclinaison de l'objet en radians (utiliser les fonctions de conversions)

Voir aussi :
Fonctions de conversions

Exemple :

......................................
REM Obtenir l'objet.
INPUT " Objet ? " objet$

REM Coordonnées équatoriales de l'objet en radians
GETOBJECTCOORD objet$ alpha delta

if alpha=-100
  PRINT "L'objet " objet$ " n'existe pas !"
  EXIT
endif

RAD_TO_RA  alpha alpha$
RAD_TO_DEC delta delta$

PRINT "Coordonnées équatoriales de l'objet " objet$ " sont :"
PRINT "Ascension droite : " alpha$
PRINT "Déclinaison : " delta$

Télécharger l'exemple


Carte du Ciel / GetRaDecMoon

GetRaDecMoon

Description :

Cette fonction permet de connaître les coordonnées de la Lune à un instant donné ainsi que sa hauteur par rapport à l'horizon.
Toutes les grandeurs de sortie sont en radians et il faut utiliser les fonctions de conversion d'angle pour les obtenir dans une unité plus compréhensible. Les valeurs de sorties sont données en fonction du lieu d'observation par défaut défini dans le menu "Options/Lieu d'observation par défaut".
La date est au format de celui renvoyé par la fonction NOW à un paramètre. La fonction NOW renvoie une date comptée depuis une référence connue : le 30/12/1899 à 0h00 (date choisie par les concepteurs de DELPHI !).

Syntaxe :

GETRADECMOON Date AlphaM DeltaM ElevationM

Variables :

Paramètres | Entrées / Sorties | Type | Description
Date | Entrée | Réel | Date au format Delphi (voir la fonction NOW)
AlphaM | Sortie | Réel | Ascension droite de la Lune en radians (utiliser les fonctions de conversion)
DeltaM | Sortie | Réel | Déclinaison de la Lune en radians (utiliser les fonctions de conversions)
ElevationM | Sortie | Réel | Hauteur de la Lune par rapport à l'horizon en radians (utiliser les fonctions de conversions)

Voir aussi :
NOW

Fonctions de conversions

Exemple :

........................
NOW Date
GetRaDecMoon Date AlphaM DeltaM ElevationM
RAD_TO_RA AlphaM AlphaM$
RAD_TO_DEC DeltaM DeltaM$
RAD_TO_DEC ElevationM ElevationM$
PRINT "LUNE :"
PRINT "AD : " AlphaM$
PRINT "DEC : " DeltaM$
PRINT "Elévation : " ElevationM$

Télécharger l'exemple


Carte du Ciel / GetRaDecSun

GetRaDecSun

Description :

Cette fonction permet de connaître les coordonnées du Soleil à un instant donné ainsi que sa hauteur par rapport à l'horizon.
Toutes les grandeurs de sortie sont en radians et il faut utiliser les fonctions de conversion d'angle pour les obtenir dans une unité plus compréhensible. Les valeurs de sorties sont données en fonction du lieu d'observation par défaut défini dans le menu "Options/Lieu d'observation par défaut".
La date est au format de celui renvoyé par la fonction NOW à un paramètre. La fonction NOW renvoie une date comptée depuis une référence connue : le 30/12/1899 à 0h00 (date choisie par les concepteurs de DELPHI !).

Syntaxe :

GETRADECSUN Date AlphaS DeltaS ElevationS

Variables :

Paramètres | Entrées / Sorties | Type | Description
Date | Entrée | Réel | Date au format Delphi (voir la fonction NOW)
AlphaS | Sortie | Réel | Ascension droite du Soleil en radians (utiliser les fonctions de conversion)
DeltaS | Sortie | Réel | Déclinaison du Soleil en radians (utiliser les fonctions de conversions)
ElevationS | Sortie | Réel | Hauteur du Soleil par rapport à l'horizon en radians (utiliser les fonctions de conversions)

Voir aussi :
NOW

Fonctions de conversions

Exemple :

........................
NOW Date
GetRaDecSun Date AlphaS DeltaS ElevationSun
RAD_TO_RA AlphaS AlphaS$
RAD_TO_DEC DeltaS DeltaS$
RAD_TO_DEC ElevationSun ElevationSun$
PRINT "SOLEIL :"
PRINT "AD : " AlphaS$
PRINT "DEC : " DeltaS$
PRINT "Elévation : " ElevationSun$

Télécharger l'exemple


Objets / GetAsterCoord

GetAsterCoord

Description :

Cette fonction permet de connaître les coordonnées d'un astéroïde à une date donnée. Il sera également précisé sa vitesse apparente et sa magnitude (approximative).
Afin que cette fonction fonctionne, il n'est pas obligatoire d'avoir au préalable ouvert la base de données des astéroïdes à partir des options d'affichage de la carte du ciel.
L'objet pourra indifféremment être désigné par son nom propre ( ex : Ceres) ou son numéro à 5 chiffres (ex: 00001).

Syntaxe :

GETASTERCOORD Objet$ JJDate Alpha Delta Speed ApproxMagn Err

Variables :

Paramètres | Entrées / Sorties | Type | Description
Objet$ | Entrée | Chaîne | Nom de l'objet ( nom propre ou numéro MPC)
JJDate | Entrée | Réel | Date de la prise de vue en jour julien
Alpha | Sortie | Réel | Ascension droite de l'astéroïde en radians (utiliser les fonctions de conversion)
Delta | Sortie | Réel | Déclinaison de l'astéroïde en radians (utiliser les fonctions de conversions)
Speed | Sortie | Réel | Vitesse apparente de l'objet en seconde d'arc par heure
ApproxMag | Sortie | Réel | Magnitude de l'astéroïde
Err | Sortie | Entier (Booléen) | Erreur de repérage de l'astéroïde (Pas d'erreur = 0)

Voir aussi :
GetCometCoord
GetObjectCoord

Fonctions de conversions

Exemple :

Now  Date
CONVERTDATETOJULIAN Date JJDate
Print JJDATE

Objet$="Ceres"

GETASTERCOORD Objet$ JJDate Alpha Delta Speed ApproxMagn Err

RAD_TO_RA  alpha alpha$
RAD_TO_DEC delta delta$

If ERR=0 then
 Print "Asteroid " Objet$
 Print alpha$
 Print Delta$
 Print "Speed= " Speed
 Print "ApproxMagn= " ApproxMagn
endif
.....................................

Télécharger l'exemple


Objets / GetCometCoord

GetCometCoord

Description :

Cette fonction permet de connaître les paramètres d'une comète à une date donnée. Il sera précisé ses coordonnées, sa vitesse apparente et sa magnitude (approximative).
Afin que cette fonction fonctionne, il n'est pas obligatoire d'avoir au préalable ouvert la base de données des comètes à partir des options d'affichage de la carte du ciel.
L'objet devra être désigné par son nom propre ( ex : "C/2001T4(NEAT)" ).

Syntaxe :

GETCOMETCOORD Objet$ JJDate Alpha Delta Speed ApproxMagn Err

Variables :

Paramètres | Entrées / Sorties | Type | Description
Objet$ | Entrée | Chaîne | Nom de l'objet (nom propre)
Alpha | Sortie | Réel | Ascension droite de la comète en radians (utiliser les fonctions de conversion)
Delta | Sortie | Réel | Déclinaison de la comète en radians (utiliser les fonctions de conversions)
Speed | Sortie | Réel | Vitesse apparente de l'objet en seconde d'arc par heure
ApproxMag | Sortie | Réel | Magnitude de l'astéroïde
Err | Sortie | Entier (Booléen) | Erreur de repérage de l'astéroïde (Pas d'erreur = 0)

Voir aussi :
GetAsterCoord
GetObjectCoord

Fonctions de conversions

Exemple :

Now  Date
CONVERTDATETOJULIAN Date JJDate
Print JJDATE

Objet$="C/2001T4(NEAT)"

GETCOMETCOORD Objet$ JJDate Alpha Delta Speed ApproxMagn Err

If ERR=0 then
 Print "Alpha= " Heure$ "h" Minutes$ "m" Secondes$ "s"
.....................................

Télécharger l'exemple


Caméra / Init_CCD_Camera

Init_CCD_Camera

Description :

Cette fonction permet d'établir un lien par script avec la caméra. Cette fonction ne sert à rien si la caméra est déja en liaison avec PRiSM (mais peut quand même être utilisée et renverra dans ce cas "déja connectée !", ceci pour s'assurer que la caméra est déja connectée). Les paramètres utilisées alors pour la caméra seront ceux rencontrés dans le panel "Caméra / Configuration de la caméra". Cependant, il est conseillé de vérifier les paramètres avant que le script ne se déroule (surtout de température !).

Syntaxe :

INIT_CCD_CAMERA Valid erreur$

Variables :

Paramètres | Entrées / Sorties | Type | Description
Valid | Sortie | Booléen : 0 ou 2 | Renvoie "2" (=TRUE) si la liaison a été correctement effectuée sinon "0" (=FALSE) dans le cas d'un échec de connexion.
erreur$ | Sortie | Chaîne de caractères | Message d'erreur renvoyé dans le cas d'un échec de connexion. Message du type : "Cette camera (Sbig cameras ->> ST5,ST7(E),ST8(E),ST9,ST10) n'est pas démarrable par un script!"

Voir aussi :
Close_CCD_Camera

Exemple :

INIT_CCD_CAMERA Valid erreur$

if Valid<>2 then
   PRINT erreur$
Endif

Télécharger l'exemple


Caméra / Init_CCD_Camera_EX

Init_CCD_Camera_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet d'établir un lien par script avec une des trois caméras gérées par PRiSM. Cette fonction ne sert à rien si la caméra est déja en liaison avec PRiSM (mais peut quand même être utilisée et renverra dans ce cas "déja connectée !", ceci pour s'assurer que la caméra est déja connectée). Les paramètres utilisées alors pour la caméra seront ceux rencontrés dans le panel "Caméra / Configuration de la caméra". Cependant, il est conseillé de vérifier les paramètres avant que le script ne se déroule (surtout de température !).

Syntaxe :

INIT_CCD_CAMERA_EX NumCam Valid erreur$

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
Valid | Sortie | Booléen : 0 ou 2 | Renvoie "2" (=TRUE) si la liaison a été correctement effectuée sinon "0" (=FALSE) dans le cas d'un échec de connexion.
erreur$ | Sortie | Chaîne de caractères | Message d'erreur renvoyé dans le cas d'un échec de connexion. Message du type : "Cette camera (Sbig cameras ->> ST5,ST7(E),ST8(E),ST9,ST10) n'est pas démarrable par un script!"

Voir aussi :
Close_CCD_Camera_EX

Exemple :

INIT_CCD_CAMERA_EX 2 Valid erreur$

if Valid<>2 then
   PRINT erreur$
Endif

Télécharger l'exemple


Caméra / SetBinningX

SetBinningX

Description :

Cette fonction permet de fixer le binning suivant X.

Syntaxe :

SETBINNINGX X

Variables :

Paramètres | Entrées / Sorties | Type | Description
X | Entrée | Entier | Binning suivant X lors des prises d'images

Voir aussi :
SetBinningY

Exemple :

........................
REM Facteur de Binning
nBinning=1
SetBinningX nBinning
SetBinningY nBinning
.....................................

Télécharger l'exemple


Caméra / SetBinningX_EX

SetBinningX_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de fixer le binning suivant X.

Syntaxe :

SETBINNINGX_EX NumCam X

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
X | Entrée | Entier | Binning suivant X lors des prises d'images

Voir aussi :
SetBinningX


Caméra / SetBinningX

SetBinningY

Description :

Cette fonction permet de fixer le binning suivant Y

Syntaxe :

SETBINNINGY Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
Y | Entrée | Entier | Binning suivant Y lors des prises d'images

Voir aussi :
SetBinningX

Exemple :

........................
REM Facteur de Binning
nBinning=1
SetBinningX nBinning
SetBinningY nBinning
.....................................

Télécharger l'exemple


Caméra / SetBinningY_EX

SetBinningY_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de fixer le binning suivant Y.

Syntaxe :

SETBINNINGY_EX NumCam Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
Y | Entrée | Entier | Binning suivant Y lors des prises d'images

Voir aussi :
SetBinningY


Caméra / SetCCDTemperature

SetCCDTemperature

Description :

Cette fonction permet de fixer la température à atteindre sur un des capteurs de température de la caméra.

Syntaxe :

SETCCDTEMPERATURE NumCap Temperature

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCap | Entrée | Entier | Numéro du capteur incriminé
Temperature | Entrée | Réel | Température à atteindre

Voir aussi :
GetCCDTemperature

Exemple :

Numero_capteur=1
Temperature=-20

SETCCDTEMPERATURE Numero_capteur Temperature

Télécharger l'exemple


Caméra / SetCCDTemperature_EX

SetCCDTemperature_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de fixer la température à atteindre sur un des capteurs de température de la caméra.

Syntaxe :

SETCCDTEMPERATURE_EX NumCam NumCap Temperature

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
NumCap | Entrée | Entier | Numéro du capteur incriminé
Temperature | Entrée | Réel | Température à atteindre

Voir aussi :
SetCCDTemperature


Caméra / SetFlagShutter

SetFlagShutter

Description :

Cette fonction permet de garder l'obturateur fermé durant la pose si le paramètre "Ferm" passé est à TRUE (Ferm =1).
Dans le cas contraire (Ferm = 0), l'obturateur de la caméra restera ouvert.
Attention, par défaut ( si cette commande n'est pas déclarée dans le PGM), l'obturateur sera ouvert durant la pose.

Syntaxe :

SETFLAGSHUTTER Ferm

Variables :

Paramètres | Entrées / Sorties | Type | Description
Ferm | Entrée | Booléen (Entier) | Ordonne à l'obturateur de rester fermé durant la pose

Exemple :

........................
MiroirX=0
MiroirY=0
SetMirror MiroirX MiroirY
setwindow 1 1 250 250
SetFlagShutter 0
.....................................

Télécharger l'exemple


Caméra / SetFlagShutter_EX

SetFlagShutter_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de garder l'obturateur fermé durant la pose si le paramètre "Ferm" passé est à TRUE (Ferm =1).
Dans le cas contraire (Ferm = 0), l'obturateur de la caméra restera ouvert.
Attention, par défaut ( si cette commande n'est pas déclarée dans le PGM), l'obturateur sera ouvert durant la pose.

Syntaxe :

SETFLAGSHUTTER NumCam Ferm

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
Ferm | Entrée | Booléen (Entier) | Ordonne à l'obturateur de rester fermé durant la pose

Voir aussi :
SetFlagShutter


Caméra / SetMirror

SetMirror

Description :

Cette fonction permet de prendre une acquisition avec un miroir suivant un des axes ( ou les deux !).
Une valeur de "0" = "FALSE" = PAS DE MIROIR et une valeur de "1" = "TRUE" = MIROIR.

Syntaxe :

SETMIRROR X Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
X | Entrée | Booléen (Entier) | Ordonne d'appliquer un miroir à l'acquisition suivant X
Y | Entrée | Booléen (Entier) | Ordonne d'appliquer un miroir à l'acquisition suivant Y

Exemple :

........................
REM Miroir Camera
MiroirX=0
MiroirY=0
SetMirror MiroirX MiroirY
.....................................

Télécharger l'exemple


Caméra / SetMirror_EX

SetMirror_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de prendre une acquisition avec un miroir suivant un des axes ( ou les deux !).
Une valeur de "0" = "FALSE" = PAS DE MIROIR et une valeur de "1" = "TRUE" = MIROIR.

Syntaxe :

SETMIRROR_EX NumCam X Y

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
X | Entrée | Booléen (Entier) | Ordonne d'appliquer un miroir à l'acquisition suivant X
Y | Entrée | Booléen (Entier) | Ordonne d'appliquer un miroir à l'acquisition suivant Y

Voir aussi :
SetMirror


Caméra / SetWindow

SetWindow

Description :

Cette fonction permet de ne lire qu'une partie du capteur d'image après une acquisition.

Syntaxe :

SETWINDOW X1 Y1 X2 Y2

Variables :

Paramètres | Entrées / Sorties | Type | Description
X1 | Entrée | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre

Voir aussi :
SetWindowFullFrameY

Exemple :

........................
REM Mirroir Camera
MiroirX=0
MiroirY=0
SetMirror MiroirX MiroirY
SETWINDOW 1 1 250 250
.....................................

Télécharger l'exemple


Caméra / SetWindow_EX

SetWindow_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de ne lire qu'une partie du capteur d'image après une acquisition.

Syntaxe :

SETWINDOW_EX NumCam X1 Y1 X2 Y2

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
X1 | Entrée | Entier | Coordonnée horizontale du coin supérieur gauche de la fenêtre
Y1 | Entrée | Entier | Coordonnée verticale du coin supérieur gauche de la fenêtre
X2 | Entrée | Entier | Coordonnée horizontale du coin inférieur droit de la fenêtre
Y2 | Entrée | Entier | Coordonnée verticale du coin inférieur droit de la fenêtre

Voir aussi :
SetWindow
SetWindowFullFrame


Caméra / SetWindowFullFrame

SetWindowFullFrame

Description :

Cette fonction permet de lire la totalité du capteur d'image (après acquisition d'une image) = mode peine trame.

Syntaxe :

SETWINDOWFULLFRAME

Voir aussi :
SetWindow

Exemple :

........................
REM Mirroir Camera
MiroirX=0
MiroirY=0
SetMirror MiroirX MiroirY
SetWindowFullFrame
.....................................

Télécharger l'exemple


Caméra / SetWindowFullFrame_EX

SetWindowFullFrame_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de lire la totalité du capteur d'image (après acquisition d'une image) = mode peine trame.

Syntaxe :

SETWINDOWFULLFRAME_EX NumCam

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.

Voir aussi :
SetWindowFullFrame
SetWindow


Caméra / GetCCDTemperature

GetCCDTemperature

Description :

Cette fonction permet d'obtenir la température actuelle sur un des capteurs de température de la caméra.

Syntaxe :

GETCCDTEMPERATURE NumCap Temperature

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCap | Entrée | Entier | Numéro du capteur incriminé
Temperature | Sortie | Réel | Température évaluée sur le capteur

Voir aussi :
SetCCDTemperature

Exemple :

Numero_capteur=1

GETCCDTEMPERATURE Numero_capteur Temperature
PRINT "Température du capteur : " Temperature

Télécharger l'exemple


Caméra / GetCCDTemperature_EX

GetCCDTemperature_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet d'obtenir la température actuelle sur un des capteurs de température de la caméra.

Syntaxe :

GETCCDTEMPERATURE_EX NumCam NumCap Temperature

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
NumCap | Entrée | Entier | Numéro du capteur incriminé
Temperature | Sortie | Réel | Température évaluée sur le capteur

Voir aussi :
GetCCDTemperature


Caméra / GetLastImageExposure

GetLastImageExposure

Description :

Cette fonction permet de nommer la dernière acquisition de façon interne au PGM. Attention, l'acquisition doit être terminée et lue ... c'est pour celà que cette commande intervient après la commande "WaitForEndExposure".

Ainsi, vous pouvez remarquer que les trois fonctions "StartExposure", "WaitForEndExposure" et "GetLastImageExposure" sont souvent écrites ensemble. En effet, si vous écrivez seulement la première fonction ( StartExposure ), l'acquisition ne pourra jamais être sauvegardée ! Très frustrant, non ! Afin de sauvegarder automatiquement cette image, vous devez utiliser le paramètre "GetLastImageExposure " ... Ainsi, vous nommez l'image en interne et vous pouvez la manipuler et la sauver ... Mais, si vous désirez lire l'image avant la fin de l'acquisition, PRiSM ne sera pas d'accord avec vous et vous le fera savoir. Alors, avant d'écrire cette dernière fonction, il est nécessaire d'écrire "WairForEndExposure" ... Par contre, les paramètres du type SETBINNINGX, SETBINNINGY, SETMIRROR et SETFLAGSHUTTER sont à fixer avant de lancer la fonction.
Vous pouvez aussi exécuter les fonctions script classiques pendant une acquisition. Cette option a été réalisée dans le but d'éviter de gacher un temps précieux ( durant l'observation automatique par exemple, où il est alors possible de prétraiter les images acquises précédemment ! ). Dans ce cas, toutes ces fonctions classiques doivent être alors exécutées entre la ligne "StartExposure " et la ligne "WaitForEndExposure". Pour exemple, vous pouvez lancer ce script.

Syntaxe :

GETLASTIMAGEEXPOSURE image

Variables :

Paramètres | Entrées / Sorties | Type | Description
image | Sortie | image | Nom interne au PGM de l'image

Voir aussi :
StartExposure
WaitForEndExposure

Exemple :

REM Prise de la première image
StartExposure 1000
WaitForEndExposure
GETLASTIMAGEEXPOSURE img1
REM Cette première image sera nommée "img1" dans le PGM
.....................................

Télécharger l'exemple


Caméra / GetLastImageExposure_EX

GetLastImageExposure_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de nommer la dernière acquisition de façon interne au PGM. Attention, l'acquisition doit être terminée et lue ... c'est pour celà que cette commande intervient après la commande "WaitForEndExposure_EX".

Ainsi, vous pouvez remarquer que les trois fonctions "StartExposure_EX", "WaitForEndExposure_EX" et "GetLastImageExposure_EX" sont souvent écrites ensemble. En effet, si vous écrivez seulement la première fonction ( StartExposure ), l'acquisition ne pourra jamais être sauvegardée ! Très frustrant, non ! Afin de sauvegarder automatiquement cette image, vous devez utiliser le paramètre "GetLastImageExposure " ... Ainsi, vous nommez l'image en interne et vous pouvez la manipuler et la sauver ... Mais, si vous désirez lire l'image avant la fin de l'acquisition, PRiSM ne sera pas d'accord avec vous et vous le fera savoir. Alors, avant d'écrire cette dernière fonction, il est nécessaire d'écrire "WairForEndExposure" ... Par contre, les paramètres du type SETBINNINGX_EX, SETBINNINGY_EX, SETMIRROR_EX et SETFLAGSHUTTER_EX sont à fixer avant de lancer la fonction.
Vous pouvez aussi exécuter les fonctions script classiques pendant une acquisition. Cette option a été réalisée dans le but d'éviter de gacher un temps précieux ( durant l'observation automatique par exemple, où il est alors possible de prétraiter les images acquises précédemment ! ). Dans ce cas, toutes ces fonctions classiques doivent être alors exécutées entre la ligne "StartExposure_EX" et la ligne "WaitForEndExposure_EX". Pour exemple, vous pouvez lancer ce script.

Syntaxe :

GETLASTIMAGEEXPOSURE_EX NumCam image

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
image | Sortie | image | Nom interne au PGM de l'image

Voir aussi :
GetLastImageExposure


Caméra / StartExposure

StartExposure

Description :

Cette fonction permet de lancer une acquisition de durée "expo". Ce dernier paramètre doit être en millisecondes. Le capteur CCD sera lu après la fin de l'exposition ...
Par exemple, STARTEXPOSURE 1000 signifie que l'utilisateur ordonne de commencer une acquisition d'une seconde. Par contre, les paramètres du type SETBINNINGX, SETBINNINGY, SETMIRROR et SETFLAGSHUTTER sont à fixer avant de lancer la fonction.

Syntaxe :

STARTEXPOSURE expo

Variables :

Paramètres | Entrées / Sorties | Type | Description
expo | Entrée | Entier | Durée de l'acquisition en millisecondes

Voir aussi :
WaitForEndExposure
GetLastImageExposure

Exemple :

REM Prise de la première image
StartExposure 1000
.....................................

Télécharger l'exemple


Caméra / StartExposure_EX

StartExposure_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de lancer une acquisition de durée "expo". Ce dernier paramètre doit être en millisecondes. Le capteur CCD sera lu après la fin de l'exposition ...
Par exemple, STARTEXPOSURE 1000 signifie que l'utilisateur ordonne de commencer une acquisition d'une seconde. Par contre, les paramètres du type SETBINNINGX_EX, SETBINNINGY_EX, SETMIRROR_EX et SETFLAGSHUTTER_EX sont à fixer avant de lancer la fonction.

Syntaxe :

STARTEXPOSURE_EX NumCam expo

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
expo | Entrée | Entier | Durée de l'acquisition en millisecondes

Voir aussi :
StartExposure


Caméra / WaitForEndExposure

WaitForEndExposure

Description :

Cette fonction permet d'attendre la fin de l'acquisition avant d'appeler une nouvelle fonction pour lire l'image en mémoire. Par exemple, cette fonction doit être appelée avant de sauver l'image de l'acquisition. Alors, PRiSM attendra la fin de l'acquisition avant d'essayer de sauver l'image.

Vous pouvez aussi exécuter les fonctions script classiques pendant une acquisition. Cette option a été réalisée dans le but d'éviter de gacher un temps précieux ( durant l'observation automatique par exemple, où il est alors pôssible de prétraiter les images acquises précédemment ! ). Dans ce cas, toutes ces fonctions classiques doivent être alors exécutées entre la ligne "StartExposure " et la ligne "WaitForEndExposure". Pour exemple, vous pouvez lancer ce script.

Syntaxe :

WAITFORENDEXPOSURE

Voir aussi :
StartExposure
GetLastImageExposure

Exemple :

REM Prise de la première image
StartExposure 1000
WaitForEndExposure
.....................................

Télécharger l'exemple


Caméra / WaitForEndExposure_EX

WaitForEndExposure_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet d'attendre la fin de l'acquisition avant d'appeler une nouvelle fonction pour lire l'image en mémoire. Par exemple, cette fonction doit être appelée avant de sauver l'image de l'acquisition. Alors, PRiSM attendra la fin de l'acquisition avant d'essayer de sauver l'image.

Vous pouvez aussi exécuter les fonctions script classiques pendant une acquisition. Cette option a été réalisée dans le but d'éviter de gacher un temps précieux ( durant l'observation automatique par exemple, où il est alors pôssible de prétraiter les images acquises précédemment ! ). Dans ce cas, toutes ces fonctions classiques doivent être alors exécutées entre la ligne "StartExposure " et la ligne "WaitForEndExposure". Pour exemple, vous pouvez lancer ce script.

Syntaxe :

WAITFORENDEXPOSURE_EX NumCam

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.

Voir aussi :
WaitForEndExposure
StartExposure_EX
GetLastImageExposure_EX


Caméra / ActiveRelayXY

ActiveRelayXY

Description :

Cette fonction permet d'activer les moteurs par l'intermédiaires des relais d'autoguidage. Cette commande est utilisable avec des caméras du type SBIG qui possèdent la gestion de l'autoguidage. Il est alors possible de faire du guidage automatique dans les scripts.

Syntaxe :

ACTIVERELAYXY X Y

Variables :

Paramètres | Entrées / Sorties | type | Description
X | Entrée | Entier | Durée d'activation en X du moteur en millisecondes
Y | Entrée | Entier | Durée d'activation en Y du moteur en millisecondes

Exemple :

REM Activer les relais durant 2s en X
ACTIVERELAYXY 2000 0


Caméra / Get_Guide_Status

Get_Guide_Status

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner.

Description :

Cette fonction permet de connaître le status de l'autoguidage par script. Les valeurs renvoyées dépendent de la réussite du lancement de l'autoguidage automatique ou non, à partir du capteur principal ou du capteur auxiliaire.
Cette fonction a été créée dans le but de ne pas provoquer d'erreur fatale dans le script.

Syntaxe :

GET_GUIDE_STATUS CCDNum Status LastErrorMessage$

Variables :

Paramètres | Entrées / Sorties | Type | Description
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.
Status | Sortie | Booléen | Status = 0 si le guidage a échoué. Status = 1 si le guidage a réussi.
LastErrorMessage$ | Sortie | Chaîne de caractères | Message indiquant la réussite ou non de l'autoguidage par script.

Voir aussi :
StartGuide

Exemple :

.................................
GET_GUIDE_STATUS CCDNum Status LastErrorMessage$

  If Status=1
    Print "Status de guidage : Guidage en cours, Dernier Message=[" LastErrorMessage$ "]"

    STARTEXPOSURE ExpoMsMain
.........................

Télécharger l'exemple


Caméra / Get_Guide_Status_EX

Get_Guide_Status_EX

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner.

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de connaître le status de l'autoguidage par script. Les valeurs renvoyées dépendent de la réussite du lancement de l'autoguidage automatique ou non, à partir du capteur principal ou du capteur auxiliaire.
Cette fonction a été créée dans le but de ne pas provoquer d'erreur fatale dans le script.

Syntaxe :

GET_GUIDE_STATUS_EX NumCam CCDNum Status LastErrorMessage$

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.
Status | Sortie | Booléen | Status = 0 si le guidage a échoué. Status = 1 si le guidage a réussi.
LastErrorMessage$ | Sortie | Chaîne de caractères | Message indiquant la réussite ou non de l'autoguidage par script.

Voir aussi :
Get_CCD_Status


Caméra / GetMaxADU

GetMaxADU

Description :

Cette fonction permet d'obtenir la dynamique de la caméra en pas codeurs (par exemple, 65535 pour 16 bits).
La caméra doit être connectée au logiciel afin de connaître la valeur renvoyée par cette caméra. Cette valeur est renvoyée pour les caméras suivantges : Alpha 500, Audine, CookBook, HiSIS 14 .. 22 .. 24 et 44, SBIG, Maya, MX5 et MX916.

Syntaxe :

GETMAXADU MaxADU

Variables :

Paramètres | Entrées / Sorties | Type | Description
MaxADU | Sortie | Entier | Dynamique de la caméra

Voir aussi :
Int2Real
Real2Int

Exemple :

REM Obtenir la dynamique de la caméra
GetMaxADU MaxADU

PRINT "Dynamique de la caméra = " MaxADU

Télécharger l'exemple


Caméra / GetMaxADU_EX

GetMaxADU_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet d'obtenir la dynamique de la caméra en pas codeurs (par exemple, 65535 pour 16 bits).
La caméra doit être connectée au logiciel afin de connaître la valeur renvoyée par cette caméra. Cette valeur est renvoyée pour les caméras suivantges : Alpha 500, Audine, CookBook, HiSIS 14 .. 22 .. 24 et 44, SBIG, Maya, MX5 et MX916.

Syntaxe :

GETMAXADU_EX NumCam MaxADU

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
MaxADU | Sortie | Entier | Dynamique de la caméra

Voir aussi :
GetMaxADU


Caméra / Shutter

Shutter

Description :

Cette fonction permet de controler sur commande l'obturateur de la caméra.
Si le paramètre "ST" passe est à TRUE (ST =1), l'obturateur de la caméra s'ouvre. Pour le refermer, il faut passer le paramètre "ST" à FALSE.

Syntaxe :

SHUTTER ST

Variables :

Paramètres | Entrées / Sorties | Type | Description
ST | Entrée | Booléen (Entier) | Ordonne à l'obturateur de s'ouvrir ou se fermer

Exemple :

........................
Shutter 1
........................


Caméra / StartGuide

StartGuide

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner.

Description :

Cette fonction permet de lancer l'autoguidage par script. En cas d'échec, cette fonction rend la main très vite.

La calibration devra être réalisée en mode non-script préalablement car le guidage est realisé selon cette calibration dont les paramètres sont lus depuis la base de registre. Si la calibration n'est pas realisée préalablement, une erreur est renvoyée et le script est stoppé !
Cette fonction choisit automatiquement l'étoile, la plus brillante du champ, au dessus de "StarThresADU"
Si l'etoile guide n'est pas trouvée :
* soit elle trop faible
* soit PRISM n'arrive pas à en faire le centroïde evolué (pour éliminer tout risque de guidage sur des points chauds ... des étoiles qui seront alors fortement déformées par la coma seront probablement rejetées

Syntaxe :

STARTGUIDE CCDNum ExpTime WindowSize CentroSize StarThresADU AgressRA AgressDelta RaMin RaMax DecMin DecMax CurrentDEC AlarmEnabled DeltaMoveFashion Valid Message$ [MountCalibFlip]

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.
ExpTime | Entrée | Réel | Temps d'exposition en secondes.
WindowSize | Entrée | Entier entre 1(!!) et 60. | Demi Taille de la fenêtre de guidage.
CentroSize | Entrée | Entier entre 1(!!) et 60. | Demi taille de la fenêtre de calcul du centroïde.
StarThresADU | Entrée | Entier | Seuil minimum de l'étoile de guidage.
AgressRA | Entrée | Réel entre 0. et 2. | Coefficient d'agressivité en ascension droite.
AgressDEC | Entrée | Réel entre 0. et 2. | Coefficient d'agressivité en déclinaison.
RAMin | Entrée | Réel entre 0. et 3. | Nombre minimum de pixels de décalage en ascension droite avant rattrapage.
RAMax | Entrée | Réel entre 0. et 20. | Nombre maximum de pixels de décalage en ascension droite avant rattrapage.
DECMin | Entrée | Réel entre 0. et 3. | Nombre minimum de pixels de décalage en déclinaison avant rattrapage.
DECMax | Entrée | Réel entre 0. et 20. | Nombre maximum de pixels de décalage en déclinaison avant rattrapage.
CurrentDEC | Entrée | Réel en radian entre -PI et +PI. | Déclinaison courante (ignorée si codeurs et/ou telescope sont actifs)
AlarmEnabled | Entrée | Booléen (entier = 0 ou 1) | Mise en route d'alarmes de pertes d'autoguidage : 0 = Pas d'alarmes 1 = Alarmes
DeltaMoveFashion | Entrée | Entier entre 0 et 3 | Types de rattrapages : 0 = Rattrapages Normaux 1 = pas de mouvement en delta 2 = Mouvements positifs seulement 3 = Mouvements Négatifs seulement
Valid | Sortie | Entier entre 0 et 2 | Validation de l'autoguidage : 0 = OK 2 = échec de l'autoguidage
Message$ | Sortie | Chaîne de caractères | Message d'erreur si existant.
MountCalibFlip | Entrée | Booléen | Si la monture a subie un retournement depuis la calibration. Paramètre valable si les codeurs ne sont pas pris en compte par PRiSM. 0 = pas de retournement et 1 = retournement. Paramètre optionnel pour conserver l'antériorité notamment quand le télescope n'est pas pris en charge par PRiSM

Voir aussi :
StartGuideConsigne

Exemple :

..........................
STARTGUIDE CCDNum ExpTime WindowSize CentroSize StarThresADU AgressRA AgressDelta RaMin RaMax DecMin DecMax CurrentDEC AlarmEnabled  DeltaMoveFashion Valid Message$

If Valid=2 then
   PRINT "Autoguidage échoué"
Endif
.........................

Télécharger l'exemple


Caméra / StartGuide_EX

StartGuide_EX

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner.

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de lancer l'autoguidage par script. En cas d'échec, cette fonction rend la main très vite.

La calibration devra être réalisée en mode non-script préalablement car le guidage est realisé selon cette calibration dont les paramètres sont lus depuis la base de registre. Si la calibration n'est pas realisée préalablement, une erreur est renvoyée et le script est stoppé !
Cette fonction choisit automatiquement l'étoile, la plus brillante du champ, au dessus de "StarThresADU"
Si l'etoile guide n'est pas trouvée :
* soit elle trop faible
* soit PRISM n'arrive pas à en faire le centroïde evolué (pour éliminer tout risque de guidage sur des points chauds ... des étoiles qui seront alors fortement déformées par la coma seront probablement rejetées

Syntaxe :

STARTGUIDE_EX NumCam CCDNum ExpTime WindowSize CentroSize StarThresADU AgressRA AgressDelta RaMin RaMax DecMin DecMax CurrentDEC AlarmEnabled DeltaMoveFashion Valid Message$

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.
ExpTime | Entrée | Réel | Temps d'exposition en secondes.
WindowSize | Entrée | Entier entre 1(!!) et 60. | Demi Taille de la fenêtre de guidage.
CentroSize | Entrée | Entier entre 1(!!) et 60. | Demi taille de la fenêtre de calcul du centroïde.
StarThresADU | Entrée | Entier | Seuil minimum de l'étoile de guidage.
AgressRA | Entrée | Réel entre 0. et 2. | Coefficient d'agressivité en ascension droite.
AgressDEC | Entrée | Réel entre 0. et 2. | Coefficient d'agressivité en déclinaison.
RAMin | Entrée | Réel entre 0. et 3. | Nombre minimum de pixels de décalage en ascension droite avant rattrapage.
RAMax | Entrée | Réel entre 0. et 20. | Nombre maximum de pixels de décalage en ascension droite avant rattrapage.
DECMin | Entrée | Réel entre 0. et 3. | Nombre minimum de pixels de décalage en déclinaison avant rattrapage.
DECMax | Entrée | Réel entre 0. et 20. | Nombre maximum de pixels de décalage en déclinaison avant rattrapage.
CurrentDEC | Entrée | Réel en radian entre -PI et +PI. | Déclinaison courante (ignorée si codeurs et/ou telescope sont actifs)
AlarmEnabled | Entrée | Booléen (entier = 0 ou 1) | Mise en route d'alarmes de pertes d'autoguidage : 0 = Pas d'alarmes 1 = Alarmes
DeltaMoveFashion | Entrée | Entier entre 0 et 3 | Types de rattrapages : 0 = Rattrapages Normaux 1 = pas de mouvement en delta 2 = Mouvements positifs seulement 3 = Mouvements Négatifs seulement
Valid | Sortie | Entier entre 0 et 2 | Validation de l'autoguidage : 0 = OK 2 = échec de l'autoguidage
Message$ | Sortie | Chaîne de caractères | Message d'erreur si existant.

Voir aussi :
StartGuide


Caméra / StartGuideConsigne

StartGuideConsigne

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner.

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de lancer l'autoguidage par script sur une position consigne. En cas d'échec, cette fonction rend la main très vite (paramètre NbPixelSqLoopMin).

La calibration devra être réalisée en mode non-script préalablement car le guidage est realisé selon cette calibration dont les paramètres sont lus depuis la base de registre. Si la calibration n'est pas realisée préalablement, une erreur est renvoyée et le script est stoppé !
Cette fonction choisit automatiquement de ramener l'étoile, au dessus de "StarThresADU", à la position de consigne. Le choix est laissé à l'utilisiteur de réaliser l'autoguidage en mode pleine fenêtre ou non (voir els paramètres).
Si l'etoile guide n'est pas trouvée :
* soit elle trop faible
* soit PRISM n'arrive pas à en faire le centroïde evolué ou barycentrique (pour éliminer tout risque de guidage sur des points chauds ... des étoiles qui seront alors fortement déformées par la coma seront probablement rejetées

Syntaxe :

STARTGUIDECONSIGNE NumCam CCDNum ExpTime DelayACQSec WindowSize CentroSize StarThresADU AgressRA AgressDEC RaMin RaMax DecMin DecMax Backlash CurrentDEC AlarmEnabled DeltaMoveFashion ConsigneX ConsigneY SaveImagettes DirSaveImg$ AllFrame WindowAllFrame NbPixelSqLoopMin Valid message$

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.
ExpTime | Entrée | Réel | Temps d'exposition en secondes.
DelayACQSec | Entrée | Réel | Délai d'acquisition en secondes.
WindowSize | Entrée | Entier entre 1(!!) et 60. | Demi Taille de la fenêtre de guidage.
CentroSize | Entrée | Entier entre 1(!!) et 60. | Demi taille de la fenêtre de calcul du centroïde.
StarThresADU | Entrée | Entier | Seuil minimum de l'étoile de guidage.
AgressRA | Entrée | Réel entre 0. et 2. | Coefficient d'agressivité en ascension droite.
AgressDEC | Entrée | Réel entre 0. et 2. | Coefficient d'agressivité en déclinaison.
RAMin | Entrée | Réel entre 0. et 3. | Nombre minimum de pixels de décalage en ascension droite avant rattrapage.
RAMax | Entrée | Réel entre 0. et 200. | Nombre maximum de pixels de décalage en ascension droite avant rattrapage.
DECMin | Entrée | Réel entre 0. et 3. | Nombre minimum de pixels de décalage en déclinaison avant rattrapage.
DECMax | Entrée | Réel entre 0. et 200. | Nombre maximum de pixels de décalage en déclinaison avant rattrapage.
Backlash | Entrée | Entier | Nombre de pixels de backlash en delta.
CurrentDEC | Entrée | Réel en radian entre -PI et +PI. | Déclinaison courante (ignorée si codeurs et/ou telescope sont actifs)
AlarmEnabled | Entrée | Booléen (entier = 0 ou 1) | Mise en route d'alarmes de pertes d'autoguidage : 0 = Pas d'alarmes 1 = Alarmes
DeltaMoveFashion | Entrée | Entier entre 0 et 3 | Types de rattrapages : 0 = Rattrapages Normaux 1 = pas de mouvement en delta 2 = Mouvements positifs seulement 3 = Mouvements Négatifs seulement
ConsigneX | Entrée | Réel | Position de la consigne en X.
ConsigneY | Entrée | Réel | Position de la consigne en Y.
SaveImagettes | Entrée | Booléen | Sauver les imagettes de guidage : 0 = NON ; 1 = OUI.
DirSaveImg$ | Entrée | Chaîne de caractères | Répertoire où sauver les imagettes si nécessaire. Si pas d'imagettes sauvées, mettre n'importe quelle chaîne dans cette variable.
AllFrame | Entrée | Booléen (entier = 0 ou 1) | Guidage sur toute l'image (1 = OUI et 0 = NON)
WindowAllFrame | Entrée | Entier | Taille de la fenêtre de recherche autour de la consigne (évite d'aller chercher n'importe quoi dans l'image ALL Frame).
NbPixelSqLoopMin | Entrée | Entier | Nombre minimum de pixel d'écart à la consigne avant de rendre la main.
Valid | Sortie | Entier valant 0 ou 2 | Validation de l'autoguidage : 0 = OK 2 = échec de l'autoguidage
Message$ | Sortie | Chaîne de caractères | Message d'erreur si existant.

Voir aussi :
StartGuide

Exemple :

..........................
STARTGUIDECONSIGNE NumCam CCDNum ExpTime DelayACQSec WindowSize CentroSize StarThresADU AgressRA AgressDEC RaMin RaMax DecMin DecMax Backlash CurrentDEC AlarmEnabled DeltaMoveFashion GuidePosX GuidePosY SaveImagettes DirSaveImg$ ...

If Valid=2 then
   PRINT "Autoguidage échoué"
Endif
.........................


Caméra / StopGuide

StopGuide

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner et qu'un autoguidage ait été lancé !

Description :

Cette fonction permet de stopper l'autoguidage en cours.

Syntaxe :

STOPGUIDE CCDNum

Variables :

Paramètres | Entrées / Sorties | Type | Description
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.

Voir aussi :
StartGuide

Exemple :

.................................
// Arret du guidage
STOPGUIDE CCDNum
Print "Guidage terminé"

Télécharger l'exemple


Caméra / StopGuide_EX

StopGuide_EX

Il faut s'assurer que la caméra est déja en liaison avec PRiSM pour que cette commande puisse fonctionner et qu'un autoguidage ait été lancé !

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de stopper l'autoguidage en cours.

Syntaxe :

STOPGUIDE_EX NumCam CCDNum

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
CCDNum | Entrée | Entier = 1 ou 2 | CCDNum = 1 si le capteur de guidage utilisé est le capteur principal. CCDNum = 2 si le capteur de guidage est le capteur auxiliaire.

Voir aussi :
StopGuide


Camera / CCDTest_TDI_Linearity

CCDTest_TDI_Linearity

Description :

This function allows to compute CCD linearity using two image files, a flat field file and an image file, where the CCD was exposed to light during readout process (this is why this is called TDI method). The light exposition occurs when 5% of the CCD has been readout.
It outputs the detector non linearity figures (Rms and p-p) as well as two plots showing linearity residuals and linearity curve.

Please refers to this link to know more about this function.

Minimum version : 3.00

Syntax :

CCDTEST_TDI_LINEARITY X1 Y1 X2 Y2 Offset FluxMin Filter ImageTDI$ ImageFlat$ Title$ DoPlots_Lin DoPlots_Res FirstLineY RMSLinearity P_PLinearity

Variables :

Parameters | Inputs / Outputs | Type | Description
X1 | Input | Integer | First image column to process, please avoid prescan
Y1 | Input | Integer | Last image column to process, please avoid overscan
Y1 | Input | Integer | First row to process, this row must be illuminated
Y2 | Input | Integer | Last row to process at the top of the image, this row must be illuminated
Offset | Input | Floating point | Offset value in the area in the bottom that has not received any light, must be accurate.
FluxMin | Input | Floating point | This is the minimum light flux that will be used to compute the lowest light level of linearity, and thus will set the FirstLineY to be used.
Filter | Input | Floating point | If 0 no low pass filter is applied to the image, if 4 high low pass filter is performed to the data, allowing to be less sensitive to noise.
ImageTDI$ | Input | String chars | Full qualified path and filename of the TDI image
ImageFlat$ | Input | String chars | Full qualified path and filename of the flat field image file
Title$ | Input | String chars | Provides a Title for the two plots, usually the CCD's name.
DoPlots_Lin | Input | Boolean (0 or 1) | If 1 displays a plot showing linearity plot
DoPlots_Res | Input | Boolean (0 or 1) | If 1 displays a plot showing linearity residuals
FirstLineY | Output | Integer | This returns the first valid row that has been used during computation
RMSLinearity | Output | Floating point | Gives the RMS linearity computed throughout the first row and the last valid row
P_PLinearity | Output | Floating point | Gives the peak to peak linearity computed throughout the first row and the last valid row

Image type that can be used by this function :

Image name | Monochrome / RGB | Integer coding / Floating point / Complex | CPA / FITS file format
Img | Yes / No | Yes / Yes / No | Yes / Yes

Script sample :

PathTDI$="C:\Prism\ESO\TDI-1-WO.cpa"
PathFlat$="C:\Prism\ESO\Flat-1-WO.cpa"

X1=28
X2=536

// Light starts here
Y1=200
// and
endshere
Y2=2045

Title$="TEST"

DoPlot_res=1
DoPlot_lin=1

OffsetADU=1010
FluxMinADU=50
LinA_FitFilter=3

CCDTEST_TDI_LINEARITY X1 Y1 X2 Y2 OffsetADU FluxMinADU LinA_FitFilter PathTDI$ PathFlat$ Title$ DoPlot_res DoPlot_lin FirstLineY RMSLinearity PPLinearity

Print "FirstLineY = " FirstLineY
Print "RMSLinearity = " RMSLinearity
Print "PPLinearity = " PPLinearity


Caméra / Get_CCD_Status

Get_CCD_Status

Description :

Cette fonction permet de connaître le status de la caméra c'est-à-dire le type de liaison établi par PRiSM avec la caméra lors du lancement de la fonction. Les status possibles sont les suivants suivant la valeur renvoyée :

Valeur renvoyée | Signification
1 | Caméra en train de s'intialiser
2 | Exposition du capteur en cours ...
3 | Lecture du capteur CCD
4 | Dernière exposition stoppée
5 | Dernière exposition abandonnée
6 | Caméra (seulement) connectée
7 | Mode vidéo démarrée

Syntaxe :

GET_CCD_STATUS status

Variables :

Paramètres | Entrées / Sorties | Type | Description
status | Sortie | Entier de 1 à 7 | Valeur renvoyée en fonction du status de la caméra. Voir la partie "description"

Voir aussi :
Init_CCD_Camera

Exemple :

GET_CCD_STATUS status
if status=1 then
   PRINT "Caméra en initialisation"
endif
.........................

Télécharger l'exemple


CCD testing functions \GetDark

GetDark

Description :

This function allows to analyze a set of images based on a window statistic to perform dark current analysis and returns two plots, two images and datas.
This function needs a window definition, a master Bias frame (a median stack of 11 bias frames at least).
The computed data is returned into a window, such as drak current rate and cosmic hit rates. One returned image is the median stack of the darks, the bias frame being subtracted on each image. the second image shows the defects from the dark frame. The two plots are collapsed row/collumn in order to spot dark non uniformity.

Please have a look HERE to get important information about CCD testing functions.

Minimum version : 1.61

Syntax :

GETDARK ImagesArray AmtImage ImgBias X1 Y1 X2 Y2 XpixelSize YpixelSize Exposuretime

Variables :

Parameters | Inputs / Outputs | Type | Description
ImagesArray | Input | Array of image handler | An array of images handles (that points the the pixel datas) that needs to be previously loaded.
AmtImage | Input | Integer | Amount of images to analyze
ImgBias | Input | Image variable | Master Bias frame, made of at least 11 elementary bias frame using 0s exposure time
X1 | Input | Integer | Left bottom X image coordinates where the statistic will be computed
Y1 | Input | Integer | Left bottom Y image coordinates where the statistic will be computed
X2 | Input | Integer | Top right X image coordinates where the statistic will be computed
Y2 | Input | Integer | Top right Y image coordinates where the statistic will be computed
XpixelSize | Input | Floating point | X pixel size, overriden if figure found into the image file header
YpixelSize | Input | Floating point | Y pixel size, overriden if figure found into the image file header
Exposuretime | Input | Floating point | Exposure time expressed in sec, overriden if figure found into the image file header

See also :
GETNOISE
GETLINEARITY
STAT
STATWINDOW
GETCONVERFACTOR

Example :

path$="C:\Prism\Images de test\ccd_test\dark\"

// Loads dark files with the same exposure time ...

AmtImage=5
for i=1 AmtImage
str i i$
a$="Dark-"+i$+".cpa"
a$=path$+a$
print a$
open ImagesArray[i-1] a$
next i

// Loads bias file
a$=path$+"Bias.cpa"
open ImgBias a$

X1=200
Y1=200
X2=500
Y2=500

// Overriden if found into the header
XpixelSize=6.4
YpixelSize=6.4
// as seconds
Exposuretime=60

GETDARK ImagesArray AmtImage ImgBias X1 Y1 X2 Y2 XpixelSize YpixelSize Exposuretime

// Close images
for i=1 AmtImage
close ImagesArray[i-1]
next i


CCD testing functions \GetConvertfactor

GETCONVERTFACTOR

Description :

By recording two flat field images and two biases images from the CCD camera, the conversion factor (e-/Adu) and the readout noise (e-) can be computed accurately using this function.

Please have a look HERE to get important information about CCD testing functions.

Minimum version :1.6

Syntax :

GETCONVERTFACTOR ImgFlat1 ImgFlat2 ImgBias1 ImgBias2 X1 Y1 X2 Y2 AWindowsx Awindowsy FactConv RMSNoise [ErrorFactconv ErrorNoise]

Variables :

Parameters | Inputs / Outputs | Type | Description
ImgFlat1 | Input | Image variable | First flat field image handle
ImgFlat2 | Input | Image variable | Second.flat field image handle
ImgBias1 | Input | Image variable | First bias image handle
ImgBias2 | Input | Image variable | Second bias image handle
X1 | Input | Integer | Left bottom X image coordinates where the statistic will be computed
Y1 | Input | Integer | Left bottom Y image coordinates where the statistic will be computed
X2 | Input | Integer | Top right X image coordinates where the statistic will be computed
Y2 | Input | Integer | Top right Y image coordinates where the statistic will be computed
AWindowsx | Input | Integer | Amount of windows in the horizontal direction of the image
AWindowsy | Input | Integer | Amount of windows in the vertical direction of the image, it shall lead to window that have a size of 20x20 pixels to 50x50pixels
FactConv | Output | Floating point | Conversion factor expressed in electrons per ADU
RMSNoise | Output | Floating point | Readout noise, computed from the two biases expressed in electrons RMS
ErrorFactconv | Output | Floating point | Optional : Error related to conversion factor (e-/ADU)
ErrorNoise | Output | Floating point | Optional : Error related to noise (e- rms)

See also :

GETNOISE
GETLINEARITY
STAT
STATWINDOW

Example :

path$="C:\Prism\Images de test\ccd_test\CVF\"

a$=path$+"flat1.cpa"
open ImgFlat1 a$

a$=path$+"flat2.cpa"
open ImgFlat2 a$

a$=path$+"bias1.cpa"
open ImgBias1 a$

a$=path$+"bias2.cpa"
open ImgBias2 a$

Width ImgBias2 Wt
height ImgBias2 Ht

X1=1
Y1=1
X2=Wt
Y2=Ht
NbWindowsx=25
NbWindowsy=50

GETCONVERTFACTOR ImgFlat1 ImgFlat2 ImgBias1 ImgBias2 X1 Y1 X2 Y2 NbWindowsx NbWindowsy FactConv RMSNoise ErrorMeasureStdDeviation ErrorMeasureRMSNoise

print "FactConv=" FactConv " RMSNoise=" RMSNoise " ErrCVF=" ErrorMeasureStdDeviation " ErrNoise=" ErrorMeasureRMSNoise

Close ImgBias2
Close ImgBias1
Close ImgFlat2
Close ImgFlat1


CCD testing functions \GetCTE

GetCTE

Description :

This function allows to analyze an image using the EPER method to compute the vertical and horizontal CTE of a CCD.

Please have a look HERE to get important information about CCD testing functions.

Minimum version : 1.61

Syntax :

GETCTE IMG Xlast YLast X1CTE X2CTE Y1CTE Y2CTE NXtransf NYtransf

Variables :

Parameters | Inputs / Outputs | Type | Description
Img | Input | Image variable | Image handler containing pixel datas
Xlast | Input | Integer | Last light sensitive collumn
Ylast | Input | Integer | Last light sensitive row
X1CTE | Input | Integer | Beginning collumn for computation
X2CTE | Input | Integer | End collumn for computation
Y1CTE | Input | Integer | Beginning row for computation
Y2CTE | Input | Integer | End row for computation
NXtransf | Input | Integer | Amount of CCD transfer in the horizontal direction
NYtransf | Input | Integer | Amount of CCD transfer in the vertical direction

See also :
GETNOISE
GETLINEARITY
STAT
STATWINDOW
GETCONVERFACTOR

Example :

open img "c:\temp\CTE.cpa"

Xlast=2048
YLast=1024
X1CTE=100
X2CTE=2000
Y1CTE=100
Y2CTE=1000
NXtransf=2048
NYtransf=1024

GETCTE img Xlast YLast X1CTE X2CTE Y1CTE Y2CTE NXtransf NYtransf


CCD testing functions \Getlinearity

GetLinearity

Description :

This function allows to analyze a set of images based on a window statistic to perform linearity analysis and returns four linearity plots and datas.
This function needs a window definition, and two offsets and noise figures to compute the optimal offset that minimizes the linearity figure results. The optimum offset is returned as result into a display message window.

Warning : pair of images with same exposure time is needed, so for instance :
ImagesArray[0] and ImagesArray[1] shall have the same exposure time.
ImagesArray[2] and ImagesArray[3] shall have the same exposure time, not necessary more or less compared to [0] and [1] pair, no exposure ordering is required.

Please have a look HERE to get important information about CCD testing functions.

Minimum version : 1.61

Syntax :

GETLINEARITY ImagesArray AmtImage X1 Y1 X2 Y2 OffsetMax OffsetMin RmsNoise UseMedian

Variables :

Parameters | Inputs / Outputs | Type | Description
ImagesArray | Input | Array of image handler | An array of images handles (that points the the pixel datas) that needs to be previously loaded.
AmtImage | Input | Integer | Amount of images to analyze
X1 | Input | Integer | Left bottom X image coordinates where the statistic will be computed
Y1 | Input | Integer | Left bottom Y image coordinates where the statistic will be computed
X2 | Input | Integer | Top right X image coordinates where the statistic will be computed
Y2 | Input | Integer | Top right Y image coordinates where the statistic will be computed
offsetMax | Input | Floating point | This figure set the maximum offset that will be used to compute linearity figures
offsetMin | Input | Floating point | This figure set the minimum offset that will be used to compute linearity figures
RmsNoise | Input | Floating point | Noise from the bias, helps to find the optimal offset between offsetMin and offsetMax
UseMedian | Input | Boolean | If 0 statistic will use mean, if 1 statistic will use median and will be more robust to noise/spikes

See also :
GETNOISE
STAT
STATWINDOW
GETCONVERFACTOR

Example :

path$="C:\Prism\Images de test\ccd_test\linearity\"

// Loads files like 1.cpa ...
AmtImage=14
for i=1 AmtImage
str i i$
a$=i$+".cpa"
a$=path$+a$
print a$
open ImagesArray[i-1] a$
next i

X1=200
Y1=200
X2=500
Y2=500

STATWINDOW ImagesArray[0] X1 Y1 X2 Y2 Mean Quad Stddev Max Min Flux Median
OffsetMin=Median-100
OffsetMax=Median+100
Print Median " min=" OffsetMin " max=" OffsetMax
Print "noise=" Stddev
RmsNoise=Stddev
UseMedian=1
Print "-------------"

GETLINEARITY ImagesArray AmtImage X1 Y1 X2 Y2 OffsetMax OffsetMin RmsNoise UseMedian

for i=1 AmtImage
close ImagesArray[i-1]
next i


CCD testing functions \ Getnoise

GetNoise

Description :

This function allows to analyze a set of images based on a window statistic to perform noise tests. It returns rms noise expressed in ADUs
This function needs a window definition, an array of images.
It returns two images : a median stack image and an image showing defective pixels below/above +/- 5 sigmas with red or green crosses
It shows two plots, one is statistic row collapse, the other is statistic collumn collapse.

It also display noise results as following :
Noise : 4.516 ± 0.04179 ADU
Amount of pixels at +(green) -(red) 5 sigmas : 11
Threshold (ADU) : 14.21

Please have a look HERE to get important information about CCD testing functions.

Minimum version : 1.61

Syntax :

GETNOISE ImagesArray AmtImage X1 Y1 X2 Y2

Variables :

Parameters | Inputs / Outputs | Type | Description
ImagesArray | Input | Array of images | An array of images handles (that points the the pixel datas) that needs to be previously loaded.
AmtImage | Input | Integer | Amount of images to analyze
X1 | Input | Integer | Left bottom X image coordinates where the statistic will be computed
Y1 | Input | Integer | Left bottom Y image coordinates where the statistic will be computed
X2 | Input | Integer | Top right X image coordinates where the statistic will be computed
Y2 | Input | Integer | Top right Y image coordinates where the statistic will be computed

See also :
GETCONVERFACTOR

Example :

Path$="C:\Prism\Images de test\ccd_test\noise\"

// Loads n1.cpa ... images

AmtImage=5

for i=1 AmtImage

str i i$
a$="n"+i$+".cpa"
a$=path$+a$
print a$
open ImagesArray[i-1] a$

next i

X1=200
Y1=200
X2=500
Y2=500

GETNOISE ImagesArray AmtImage X1 Y1 X2 Y2

for i=1 AmtImage

close ImagesArray[i-1]

next i


CCD testing functions \GetQE

GetCTE

Description :

This function allows to analyze a image series so as to retrieve the CCD (or CMOS) sensor absolute quantum efficiency (QE) versus wavelength.

This function needs a set of images, for each image important information is required into input tables such as reference photodiode flux, wavelength, and so on (see variable tables).

As result, this function outputs two plots, one is Quantum Efficiency versus wavelength, and the other is Photo Response Non Uniformity plot.

Warning this function as a lot of parameters, so please be carrefull and patient when using it.

Please have a look HERE to get important information about CCD testing functions.

Minimum version : 18/04/2002

Syntax :

GETQE ImageArray AmtImages BiasImg X1 Y1 X2 Y2 PixelSizeX PixelSizeY CvF CalDist MeaDist Bw Wl Flux refMea DebgMode [PhotonErr DiodeFluxErr Wtrans] Wal QE errQE PRNU Entropy

[are optionnal parameters]

Variables :

Parameters | Inputs / Outputs | Type | Description
ImagesArray | Input | Array of image handler | An array of images handles (that points the the pixel datas) that needs to be previously loaded.
AmtImage | Input | Integer | Amount of images to analyze
BiasImg | Input | Image variable | Image variable that points to a MASTER bias made of at least 5 bias frames
X1 | Input | Integer | Left bottom X image coordinates where the statistic will be computed
Y1 | Input | Integer | Left bottom Y image coordinates where the statistic will be computed
X2 | Input | Integer | Top right X image coordinates where the statistic will be computed
Y2 | Input | Integer | Top right Y image coordinates where the statistic will be computed
PixelSizeX | Input | Floating point | X Pixel size as microns, overriden if read from the image file header
PixelSizeY | Input | Floating point | Y Pixel size as microns, overriden if read from the image file header
CvF | Input | Floating point | Conversion factor, expressed as electrons per ADUs
CalDist | Input | Floating point | Distance monochromator output - photodiode during calibration (mm)
MeaDist | Input | Floating point | Distance monochromator output - CCD surface during image recording (mm)
Bw | Input | Floating point | Bandwidth (nm) fixed for the whole image set.
Wl | Input | Array of floating point | Wavelength (nm) for each image
Flux | Input | Array of floating point | Photodiode flux for each image as amperes
refMea | Input | Array of floating point | Reference photodiode flux for this wavelength as amperes.
DebgMode | Input | Boolean | Debug mode, if =1 display more information
PhotonErr | Input | Array of floating point | Optional : mesurment error during image exposure as ADUs
DiodeFluxErr | Input | Array of floating point | Optional : photodiode error as amperes
Wtrans | Output | Array of floating point | Optional : optical window transmission (0 to 1)
Wal | Output | Array of floating point | Wavelength as nm
QE | Output | Array of floating point | Computed quantum efficiency as %
errQE | Output | Array of floating point | Quantum efficiency error as %
PRNU | Output | Array of floating point | Photoresponse non uniformity as %
Entropy | Output | Array of floating point | Entropy computation

See also :

GETNOISE
GETLINEARITY
STAT
STATWINDOW
GETCONVERFACTOR

Example :

path$="C:\Prism\Images de test\ccd_test\QE\"

// Loads files like 1.cpa ... each file is a different wavelength
AmtImage=14
for i=1 AmtImage
str i i$
a$=i$+".cpa"
a$=path$+a$
print a$
open ImagesArray[i-1] a$
next i

X1=200
Y1=200
X2=500
Y2=500

PixelSizeX=15
PixelSizeY=15

CvF=1.02
CalDist=550
MeaDist=720

.............

GETQE ImageArray AmtImages BiasImg X1 Y1 X2 Y2 PixelSizeX PixelSizeY CvF CalDist MeaDist Bw Wl Flux refMea DebgMode Wal QE errQE PRNU Entropy

.............


Caméra / Close_CCD_Camera

Close_CCD_Camera

Description :

Cette fonction permet de couper la liaison par script avec la caméra. Cette fonction fonctionne même si la liaison n'a pas été intialisée avec "Init_CCD_Camera".

Syntaxe :

CLOSE_CCD_CAMERA

Voir aussi :
Init_CCD_Camera

Exemple :

.............................
CLOSE_CCD_CAMERA

Télécharger l'exemple


Caméra / Close_CCD_Camera_EX

Close_CCD_Camera_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de couper la liaison par script avec la caméra primaire, secondaire ou tertiaire. Cette fonction fonctionne même si la liaison n'a pas été intialisée avec "Init_CCD_Camera_EX".

Syntaxe :

CLOSE_CCD_CAMERA_EX NumCam

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.

Voir aussi :
Init_CCD_Camera_EX

Exemple :

.............................
CLOSE_CCD_CAMERA_EX

Télécharger l'exemple


Telescope / Open_Telescope_Devices

Open_Telescope_Devices

Description :

Cette fonction permet d'établir un lien par script avec le télescope. Ce dernier n'était pas encore en liaison avec PRiSM. Les paramètres correspondent aux paramètres usuels rencontrés dans le panel "Telescope / Setup / Codeurs ou Moteurs". Certains télescope ne nécessitent même pas l'utilisation de ces paramètres.
Attention : Le télescope (codeurs ou moteurs) initialisé sera celui défini à partir du menu "Telescope / Setup", dont les paramètres réutilisables d'une fois sur l'autre sont gardés dans la base de registre.

Syntaxe :

OPEN_TELESCOPE_DEVICES RaREF DecREF [MountOrientation]

Variables :

Paramètres | Entrées / Sorties | Type | Description
RaREF | Entrée | Réel | Ascension droite de calibration en RADIAN
DecREF | Entrée | Réel | Déclinaison de calibration en RADIAN
MountOrientation | Entrée, optionnelle | Booléen | Orientation initiale de la monture. Paramètre optionnel, utile pour les montures allemandes. "0" pour l'EST et "1" pour l'OUEST.

Voir aussi :
Close_Telescope_Devices

Exemple :

REM Nous voulons fixer le télescope à 1h 00 m 00s et -10° 00' 00"
REM 1 h = 15° = 15*Pi/180 = 0,2617994
REM 10° = 10*Pi/180 = 0,1745329

OPEN_TELESCOPE_DEVICES 0.2617994 -0.1745329
// On n'a pas intégré le paramètre optionnel ...
...........................................

Télécharger l'exemple


Telescope / Calibrate_Telescope

Calibrate_Telescope

Description :

Cette fonction permet de calibrer les codeurs du télescope à une position donnée. Seuls des codeurs (et non des moteurs) peuvent être déclarés. Les coordonnées fournies sont des coordonnées 2000.0, ces dernières étant transformées en coordonnées apparentes si un modèle de pointage a été défini pour le télescope. Voir la fonction Get_Telescope_Position_App.
Il faut que la liaison avec le télescope ait été au préalable effectué grâce au menu "Télescope / Etablir communication"

Syntaxe :

CALIBRATE_TELESCOPE Alpha2000 Delta2000

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha2000 | Entrée | Réel | Ascension droite 2000.0 vers laquelle le télescope doit être calibré, en radians
Delta2000 | Entrée | Réel | Déclinaison 2000.0 vers laquelle le télescope doit être calibré, en radians

Exemple :

.....................................
GETIMG_XY_TO_RADDEC img Xcentre Ycentre  AlphaCenter DeltaCenter
Close img

REM Recalibration du télescope
CALIBRATE_TELESCOPE AlphaCenter DeltaCenter

Télécharger l'exemple


Telescope / Get_Telescope_Position

Get_Telescope_Position

Description :

Cette fonction permet de connaître la position vers laquelle pointe le télescope au moment où la fonction est lancée. Les paramètres renvoyés sont les coordonnées 2000.0 vers lesquels le télescope est censé pointer. (et pointe réellement si aucun modèle de pointage n'a été défini au préalable).
Il faut que la liaison avec le télescope ait été au préalable effectué grâce au menu "Télescope / Etablir communication"

Syntaxe :

GET_TELESCOPE_POSITION Alpha2000 Delta2000 Hauteur Azimuth AngleHor

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha2000 | Sortie | Réel | Ascension droite 2000.0 vers laquelle le télescope "croit pointer" en radians
Delta2000 | Sortie | Réel | Déclinaison 2000.0 vers laquelle le télescope "croit pointer" en radians
Hauteur | Sortie | Réel | Hauteur, au moment où est demandée la fonction, vers laquelle pointe le télescope
Azimuth | Sortie | Réel | Azimuth, au moment où est demandée la fonction, vers lequel pointe le télescope
AngleHor | Sortie | Réel | Angle horaire, au moment où est demandée la fonction, vers lequel pointe le télescope

Exemple :

REM Obtenir la position 2000.0 connue par le télescope
GET_TELESCOPE_POSITION AD2000 DEC2000 Haut Azi AHor
STR_RAD_TO_RA AD2000 HH$ MM$ SS$
STR_RAD_TO_DEC DEC2000 DD$ DM$ DS$
PRINT "Ascension droite 2000.0 = " HH$ "h " MM$ "m " SS$ "s"
PRINT "Déclinaison 2000.0 = " DD$ "° " DM$ "' " DS$ "''"

Télécharger l'exemple


Telescope / Get_Telescope_Position_App

Get_Telescope_Position_App

Description :

Cette fonction permet de connaître la position vers laquelle pointe le télescope réellement au moment où la fonction est lancée. Les paramètres renvoyés sont les coordonnées apparentes vers lesquels le télescope pointe. Sans modèle de pointage, ces coordonnées sont les mêmes que les coodonnées 2000.0. Par contre, lorsqu'un modèle de pointage a été introduit, ces coordonnées diffèrent (légèrement, il faut espérer ...) des coordonnées 2000.0.
ATTENTION : PRiSM ne gère cette fonction uniquement pour les télescopes qui supporte le modèle de pointage : LX200, MCMT, DLL_Telescope. Dans le cas contraire, une erreur sera renvoyée. Comme pour les autres fonctions de ce type, il faut que la liaison avec le télescope ait été au préalable effectué grâce au menu "Télescope / Etablir communication"

Syntaxe :

GET_TELESCOPE_POSITION_APP Alpha_App Delta_App

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha_App | Sortie | Réel | Ascension droite apparente vers laquelle le télescope pointe, en radians
Delta_App | Sortie | Réel | Déclinaison apparente vers laquelle le télescope pointe, en radians

Exemple :

REM Obtenir la position apparente du téléscope.
REM cette position ne différera de la précédente que si un modèle de pointage a été introduit pour le télescope
REM Dans le cas contraire, La position apparente ne diffèrera pas de la position 2000.0
GET_TELESCOPE_POSITION_APP ADAPP DECAPP
STR_RAD_TO_RA ADAPP HH$ MM$ SS$
STR_RAD_TO_DEC DECAPP DD$ DM$ DS$
PRINT "Ascension droite 2000.0 = " HH$ "h " MM$ "m " SS$ "s"
PRINT "Déclinaison 2000.0 = " DD$ "° " DM$ "' " DS$ "''"

Télécharger l'exemple


Télescope / ShowRaDec_Skymap

ShowRaDec_Skymap

Description :

Cette fonction permet de marquer sur la fenêtre du ciel un objet dont on connaît ses coordonnées équatoriales en radians. La position est alors marquée par un petit carré jaune avec une croix à l'intérieur. Même lors du déplacement du télescope, ce petit carré restera toujours centré sur l'objet
Cependant, ce carré n'apparaîtra que si la communication est établie avec le télescope. Attention : Le télescope doit être reconnu par PRiSM comme un moteur dans la liste des moteurs ou doit être une monture type LX200 ou commandée par l'intermédiaire de Telescope.DLL. Le lien avec le télescope doit être effectué avant de commencer le script !
Dans le but de tester le script de test, vous devez choisir les encodeurs et moteurs de test ...

Syntaxe :

SHOWRADEC_SKYMAP Alpha Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha | Entrée | Réel | Ascension droite de l'objet en radians
Delta | Entrée | Réel | Déclinaison de l'objet en radians

Exemple :

........................
GETOBJECTCOORD objet$ alpha delta

if alpha=-100
  PRINT "L'objet " objet$ " n'existe pas !"
  EXIT
endif

ShowRaDec_Skymap Alpha Delta

Télécharger l'exemple


Telescope / Park_Telescope

Park_Telescope

Description :

Cette fonction permet de mettre le télescope en position de parking. Ceci n'est valable que pour les instruments à poste fixe. Avant de stopper les moteurs pour les instruments supportant cette fonction, le télescope se dirige vers les coordonnées horaires indiquées.
Il faut que la liaison avec le télescope ait été au préalable effectué grâce au menu "Télescope / Etablir communication". Il faut vérifier que son système puisse supporter la méthode du parking (Système complet, géré par DLL ou par plugin ASCOM).

Syntaxe :

PARK_TELESCOPE AH Delta

Variables :

Paramètres | Entrées / Sorties | Type | Description
AH | Entrée | Réel | Angle horaire à atteindre avant de stopper les moteurs, en radians. Ce paramètre varie de 0 à 2*Pi.
Delta | Entrée | Réel | Déclinaison à atteindre avant de stopper les moteurs, en radians. Ce paramètre varie de -Pi à +Pi.

Exemple :

.....................................
NOW date
GetStdrLongitude Longitude
SIDERALTIME Date Longitude TSL
GETRADECMOON Date AlphaM DeltaM ElevationM
ComputeAngleHor TSL AlphaM AngleHor
PARK_TELESCOPE AngleHor DeltaM

Télécharger l'exemple
Decembre 2006


Telescope / UnPark

UnPark

Description :

Cette fonction permet de relancer le télescope après une position de parking. Ceci n'est valable que pour les instruments à poste fixe.
Il faut que la liaison avec le télescope ait été au préalable effectué grâce au menu "Télescope / Etablir communication". Il faut vérifier que son système puisse supporter la méthode du parking (Système complet, géré par DLL ou par plugin ASCOM).

Syntaxe :

UNPARK

Exemple :

.....................................
UnPark_Telescope 1.3456 0.2389

UnPark

Télécharger l'exemple
Decembre 2006


Télescope / MoveTelescope

MoveTelescope

Description :

Cette fonction permet au télescope de bouger vers les coordonnées "ALPHA" ( Ascension droite ) et "DELTA" ( Déclinaison ).
"ALPHA" et "DELTA" doivent être en radians.
On peut aussi exprimer ALPHA et DELTA en unité classique à condition de respecter la deuxième syntaxe.
Attention : Le télescope doit être reconnu par PRiSM comme un moteur dans la liste des moteurs ou doit être une monture type LX200 ou commandée par l'intermédiaire de Telescope.DLL.
Le lien avec le télescope doit être effectué avant de commencer le script !
Dans le but de tester le script de test, vous devez choisir les encodeurs et moteurs de test ...

Syntaxe :

MOVETELESCOPE Alpha Delta
OU
MOVETELESCOPE Hour Minutes Seconds Degrees MinutesD SecondsD

Variables :

Paramètres | Entrées / Sorties | Type | Description
Alpha | Entrée | Réel | Ascension droite en radians vers où le télescope doit pointer
Delta | Entrée | Réel | Déclinaison en radians vers où le télescope doit pointer
----- | ------ | ------- | ---------------------------------------
Hour | Entrée | Entier | Heure de l'ascension droite vers où le télescope doit pointer
Minutes | Entrée | Entier | Minutes de l'ascension droite vers où le télescope doit pointer
Seconds | Entrée | Entier | Secondes de l'ascension droite vers où le télescope doit pointer
Degrees | Entrée | Entier | Degrés de la déclinaison vers où le télescope doit pointer
MinutesD | Entrée | Entier | Minutes de la déclinaison vers où le télescope doit pointer
SecondsD | Entrée | Entier | Secondes de la déclinaison vers où le télescope doit pointer

Voir aussi :
ShiftTelescope

Exemples :

REM Test de la fonction : MoveTelescope
REM Nous voulons bouger le télescope vers 1h 00 m 00s and -10° 00' 00"
REM 1 h = 15° = 15*Pi/180 = 0,2618
REM 10° = 10*Pi/180 = 0,3141

MOVETELESCOPE 0.2618 -0,3141

PRINT "Cliquer sur 'PLAY' pour bouger le télescope"
PAUSE
MOVETELESCOPE 1 00 00 -10 00 00

Télécharger l'exemple

..........MaxHR) then
Print "Pointing to " Alpha$ " " delta$
MOVETELESCOPE Heure[i] Minutes[i] Secondes[i] Degres[i] MinutesD[i] SecondesD[i]
SHOWRADEC_SKYMAP Alpha Delta
WaitForE............

Télécharger l'exemple


Telescope / Return_Telescope_To_Sideral

Return_Telescope_To_Sideral

Description :

Cette fonction permet de relancer les moteurs d'un télescope à la vitesse sidérale, ces derniers ayant été précedemment arrêté avec la commande "STOPTELESCOPE" ou par lancement du PEC ou par mode KING. Si la motorisation ne le supporte pas, une erreur est renvoyée. A ce sujet :
Attention : Il faut que la procédure de liaison avec le télescope soit intialisée. Voir la fonction MOVETELESCOPE. De plus, cette fonction ne fonctionne que pour les montures qui ont été programmée pour réagir à cette commande. Cette fonction correspond à l'implémentation de la fonction "Stop_All_Telescope" dans la DLL Telescope.DLL. Elle ne fonctionne pas, par exemple, pour le mode LX200 de PRiSM car elle n'est pas prise en compte par le télescope mais fonctionne avec la DLL pour les montures Astrophysics GTO ...

Syntaxe :

RETURN_TELESCOPE_TO_SIDERAL

Voir aussi :
StopTelescope

Exemple :

REM Test de la fonction RETURN_TELESCOPE_TO_SIDERAL

PRINT ""
PRINT "On demande les coordonnées d'un objet"

GetObjectCoord "NGC2273" Alpha Delta

PRINT Alpha  "    "  Delta

MoveTelescope Alpha Delta
WAITFORENDMOVETELESCOPE

PRINT "Arrêt du télescope..."
STOPTELESCOPE
Delay 30000
waitforEnddelay

PRINT "Le télescope est relancé ..."
RETURN_TELESCOPE_TO_SIDEREAL
PRINT "Program finished..."

Télécharger l'exemple


Télescope / ShiftTelescope

ShiftTelescope

Description :

Cette fonction permet de bouger le télescope de quelques secondes d'arc en ascension droite et en déclinaison.
"SHIFTALPHA" et "SHIFTDELTA" doivent être en secondes d'arc.
Le lien avec le télescope sous PRiSM doit être au préalable établi. A cette fin, voir les commentaires sur la fonction MOVETELESCOPE.

Syntaxe :

SHIFTTELESCOPE ShiftAlpha ShiftDelta

Variables :

Paramètres | Entrées / Sorties | Type | Description
ShiftAlpha | Entrée | Entier | Offset du déplacement en ascension droite
ShiftDelta | Entrée | Entier | Offset du déplacement en déclinaison

Voir aussi :
MoveTelescope

Exemples :

REM Nous voulons bouger le télescope en ascension doite
REM et en déclinaison de 1' d'arc.

SHIFTTELESCOPE 60 60

Télécharger l'exemple


Telescope / StopTelescope

StopTelescope

Description :

Cette fonction permet d'arrêter le suivi sidéral d'un télescope, c'est-à-dire de stopper entièrement les moteurs.
Attention : Il faut que la procédure de liaison avec le télescope soit intialisée. Voir la fonction MOVETELESCOPE. De plus, cette fonction ne fonctionne que pour les montures qui ont été programmée pour réagir à cette commande. Cette fonction correspond à l'implémentation de la fonction "Stop_All_Telescope" dans la DLL Telescope.DLL. Elle ne fonctionne pas, par exemple, pour le mode LX200 de PRiSM car elle n'est pas prise en compte par le télescope mais fonctionne avec la DLL pour les montures Astrophysics GTO ...
Cette commande peut-être annulée à partir de la commande "RETURN_TELESCOPE_TO_SIDERAL".

Syntaxe :

STOPTELESCOPE

Voir aussi :
Return_Telescope_To_Sideral

Exemple :

.......ndif
else
   DATETOSTR date date$
   Print date$ " -> Will stop telescope...SUN too high..."
   STOPTELESCOPE
   Goto end:
endif
Nex.........

Télécharger l'exemple


Télescope / WaitForEndMoveTelescope

WaitForEndMoveTelescope

Description :

Cette fonction permet d'attendre la fin de la commande "MOVETELESCOPE" avant de relancer une nouvelle procédure de commande du télescope.
Intérêt d'une telle commande : Cette option a été réalisée dans le but d'éviter de gâcher un temps précieux ( durant l'observation automatique par exemple ). Dans ce cas, un certain nombre de fonctions classiques doivent être alors exécutées entre la ligne "MOVETELESCOPE" et la ligne "WAITFORENDMOVETELESCOPE".

Syntaxe :

WAITFORENDMOVETELESCOPE

Voir aussi : MoveTelescope

Exemples :

............MaxHR) then
Print "Pointing to " Alpha$ " " delta$
MoveTelescope Heure[i] Minutes[i] Secondes[i] Degres[i] MinutesD[i] SecondesD[i]
REM Excécution d'une commande SCRIPT classique :
SHOWRADEC_SKYMAP Alpha Delta
WaitForEndMoveTelescope
Dela.............

Télécharger l'exemple


Télescope / AutoFoc

AutoFoc

Description :

Cette fonction permet de réaliser la focalisation automatique à partir de la HFD (2ème méthode exposée).
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que le focuser ait été déclaré dans le panel de configuration "Telescope / Setup".

Syntaxe :

AUTOFOC ExpTimeSec Cx Cy Size CentroidSize MinDep MaxDep Step ValueOpt Valid

Variables :

Paramètres | Entrées / Sorties | Type | Description
ExpTimeSec | Entrée | Réel entre 0.1 et 10 | Temps de pose de chaque pose de focalisation en secondes
Cx | Entrée | Entier | coordonnée horizontale du centre de la fenêtre de focalisation
Cy | Entrée | Entier | coordonnée verticale du centre de la fenêtre de focalisation
Size | Entrée | Entier entre 20 et 100 | Rayon d'analyse FWHM (en pixels)
CentroidSize | Entrée | Entier entre 3 et 30 | Demi-Taille de la fenêtre (en pixels)
MinDep | Entrée | Réel entre 0. et 200. | Point de départ de la focalisation (en mm)
MaxDep | Entrée | Réel entre 0. et 200. | Point d'arrivée de la focalisation (en mm)
Step | Entrée | Réel entre 0.001 et 1. | Pas de focalisation (en mm)
ValueOpt | Sortie | Réel | Valeur Optimal retenue pour la focalisation après convergence de l'algorithme (en mm)
Valid | Sortie | Entier de 0 à 5 | Validation de la focalisation ou code d'erreur : 0 = AUTOFocalisation OK 1 = calcul du HDF a échoué ! 2 = Etoile trop proche du bord de l'image CCD ! 3 = Etoile trop proche de la saturation 4 = Erreur inconnue dans la boucle d'analyse ! 5 = Erreur de régression du polynôme de degré 4 sur les points !

Exemple :

ExptimeSec=2
Cx=200
Cy=200
Size=30
CentroidSize=10
MinDep=1.2
MaxDep=2.0
Step=0.05

AUTOFOC ExptimeSec Cx Cy Size CentroidSize MinDep MaxDep Step ValueOpt Valid

Télécharger l'exemple


Télescope / AutoFoc_EX

AutoFoc_EX

Description :

Attention : Cette fonction n'est accessible qu'à partir de la version 9 de PRiSM !

Cette fonction permet de réaliser la focalisation automatique à partir de la HFD (2ème méthode exposée).
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que le focuser ait été déclaré dans le panel de configuration "Telescope / Setup".

Syntaxe :

AUTOFOC_EX NumCam ExpTimeSec Cx Cy Size CentroidSize MinDep MaxDep Step ValueOpt Valid

Variables :

Paramètres | Entrées / Sorties | Type | Description
NumCam | Entrée | 1, 2 ou 3 | Caméra primaire, secondaire ou tertiaire.
ExpTimeSec | Entrée | Réel entre 0.1 et 10 | Temps de pose de chaque pose de focalisation en secondes
Cx | Entrée | Entier | coordonnée horizontale du centre de la fenêtre de focalisation
Cy | Entrée | Entier | coordonnée verticale du centre de la fenêtre de focalisation
Size | Entrée | Entier entre 20 et 100 | Rayon d'analyse FWHM (en pixels)
CentroidSize | Entrée | Entier entre 3 et 30 | Demi-Taille de la fenêtre (en pixels)
MinDep | Entrée | Réel entre 0. et 200. | Point de départ de la focalisation (en mm)
MaxDep | Entrée | Réel entre 0. et 200. | Point d'arrivée de la focalisation (en mm)
Step | Entrée | Réel entre 0.001 et 1. | Pas de focalisation (en mm)
ValueOpt | Sortie | Réel | Valeur Optimal retenue pour la focalisation après convergence de l'algorithme (en mm)
Valid | Sortie | Entier de 0 à 5 | Validation de la focalisation ou code d'erreur : 0 = AUTOFocalisation OK 1 = calcul du HDF a échoué ! 2 = Etoile trop proche du bord de l'image CCD ! 3 = Etoile trop proche de la saturation 4 = Erreur inconnue dans la boucle d'analyse ! 5 = Erreur de régression du polynôme de degré 4 sur les points !

Voir aussi :
AutoFoc


Télescope / Set_Focuser

Set_Focuser

Description :

Cette fonction permet de faire bouger le focuser à la position "Value". Dans le cas où le temps de mouvement n'ait pu être réglé dans la DLL, le paramètre "TimeOutSec" permet de fixer le temps avant de vérifier la nouvelle position du focuser. Ce paramètre n'étant pas optionnel, il faut lui donner une valeur pour tous les focusers, même si cette dernière est souvent inutile.
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que le focuser ait été déclaré dans le panel de configuration "Telescope / Setup".

Syntaxe :

SET_FOCUSER Value TimeOutSec

Variables :

Paramètres | Entrées / Sorties | Type | Description
Value | Entrée | Réel | Position ABSOLUE (ou relative par rapport à la position de parking) du focuser, en millimètre.
TimeOutSec | Entrée | Entier | Temps d'attente en seconde avant de récupérer la position du focuser

Exemple :

REM Le Focuser doit être en route !
REM OPEN_TELESCOPE_DEVICES

SET_FOCUSER 0.23 60
SET_FOCUSER 0.10 10

Télécharger l'exemple


Télescope / Get_Focuser_Pos

Get_Focuser_Pos

Description :

Cette fonction permet de récupérer la valeur du tirant du focuser depuis la position de référence, en millimètres.
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que le focuser ait été déclaré dans le panel de configuration "Telescope / Setup".

Syntaxe :

GET_FOCUSER_POS Pos Status

Variables :

Paramètres | Entrées / Sorties | Type | Description
Pos | Sortie | Réel | Position actuelle en mm depuis la position de référence (dite de parking)
Status | Sortie | Entier | Entier qui est égal à : 0 si le focuser est au repos. 1 si le focuser est en mouvement 2 si le mouvement du focuser n'est pas reconnu.

Exemple :

REM Le Focuser doit être en route !
REM OPEN_TELESCOPE_DEVICES

GET_FOCUSER_POS Pos Status
PRINT "Tirant du focuser = " Temp "mm"

Télécharger l'exemple


Télescope / Get_Focuser_Temp

Get_Focuser_Temp

Description :

Cette fonction permet de récupérer la valeur de température en Kelvin mesurée par le focuser (si ce dernier le permet !).
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que le focuser ait été déclaré dans le panel de configuration "Telescope / Setup".

Syntaxe :

GET_FOCUSER_TEMP Temp

Variables :

Paramètres | Entrées / Sorties | Type | Description
Temp | Sortie | Réel | Température en KELVIN connue par la sonde optionnelle du focuser

Exemple :

REM Le Focuser doit être en route !
REM OPEN_TELESCOPE_DEVICES

GET_FOCUSER_TEMP Temp
PRINT "Température = " Temp "K"

Télécharger l'exemple


Télescope / Reset_Focuser

Reset_Focuser

Description :

Cette fonction permet de faire bouger le focuser à sa position de parking. Dans le cas où le temps de mouvement n'ait pu être réglé dans la DLL, le paramètre "TimeOut" permet de fixer le temps avant de vérifier la nouvelle position du focuser. Ce paramètre n'étant pas optionnel, il faut lui donner une valeur pour tous les focusers, même si cette dernière est souvent inutile.
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que le focuser ait été déclaré dans le panel de configuration "Telescope / Setup".

Syntaxe :

RESET_FOCUSER TimeOutSec

Variables :

Paramètres | Entrées / Sorties | Type | Description
TimeOutSec | Entrée | Entier | Temps d'attente en seconde avant d'envoyer un nouvel ordre au focuser.

Exemple :

REM Le Focuser doit être en route !
REM OPEN_TELESCOPE_DEVICES

RESET_FOCUSER 20

Télécharger l'exemple


Telescope / SetFilter

SetFilter

Description :

Cette fonction permet de sélectionner un filtre de la roue à filtre. Elle peut être utilisée que la roue à filtre soit indépendante de la caméra (du type gouvernée par FILTER_DLL.DLL) ou qu'elle soit relié par l'intermédiaire de la caméra type roue à filtre SBIG.

Attention : Dans le cas d'une roue à filtre indépendante de la caméra, il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la roue à filtre ait été déclarée dans le panel de configuration "Telescope / Setup".

Syntaxe :

SETFILTER Index

Variables :

Paramètres | Entrées / Sorties | Type | Description
Index | Entrée | Entier | Numéro du filtre dans l'ordre de programmation

Exemple :

SETFILTER 5


Télescope / Get_Dome_Pos

Get_Dome_Pos

Description :

Cette fonction permet de connaître le statut de la coupole.
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la roue à filtre ait été déclarée dans le panel de configuration "Telescope / Setup".

Syntaxe :

GET_DOME_POS Azimuth Status

Variables :

Paramètres | Entrées / Sorties | Type | Description
Azimuth | Sortie | Réel | Azimuth (par rapport au NORD) de l'ouverture de la coupole, en radian.
Status | Sortie | Entier | Statut de la coupole: 1 : Coupole à l'arrêt 2 : Coupole en mouvement 3 : La coupole est en train de s'ouvrir 4 : La coupole est en train de se fermer.


Télescope / MoveDome

MoveDome

Description :

Cette fonction permet de bouger la coupole vers un certain azimuth
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la coupole ait été déclarée dans le panel de configuration "Telescope / Setup / Dome".

Syntaxe :

MOVEDOME Azimuth

Variables :

Paramètres | Entrées / Sorties | Type | Description
Azimuth | Entrée | Réel | Azimuth (par rapport au NORD) vers lequel l'ouverture de la coupole doit se diriger, en radian.


Télescope / Reset_Dome

Reset_Dome

Description :

Cette fonction termine la liaison avec la coupole ...
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la coupole ait été déclarée dans le panel de configuration "Telescope / Setup / Dome".

Syntaxe :

RESET_DOME

Voir aussi :
MoveDome


Télescope / SetDomeToTelescope

SetDomeToTelescope

Description :

Cette fonction aligne le dome sur la position actuelle du télescope.
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la coupole ait été déclarée dans le panel de configuration "Telescope / Setup / Dome".

Syntaxe :

SETDOMETOTELESCOPE

Voir aussi :
MoveDome


Télescope / Close_Dome

Close_Dome

Description :

Cette fonction ferme la coupole ...
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la coupole ait été déclarée dans le panel de configuration "Telescope / Setup / Dome".

Syntaxe :

CLOSE_DOME

Voir aussi :
Open_Dome


Télescope / Open_Dome

Open_Dome

Description :

Cette fonction ouvre la coupole ...
Attention : Il faut que la liaison avec le télescope ait été au préalable effectuée à partir du menu "Télescope / Etablir communication" (ou la fonction script OPEN_TELESCOPE_DEVICES) et que la coupole ait été déclarée dans le panel de configuration "Telescope / Setup / Dome".

Syntaxe :

OPEN_DOME

Voir aussi :
Close_Dome


Telescope / GetDataWeatherStation

GetDataWeatherStation

Description :

Cette fonction permet de récupérer les dernières informations reçues par les stations météo Lacrosse Technology WS-2300 et WS-3600. La fonction va lire le fichier "cur.lst" produit par le programmme Heavy Weather, utilisé avec ces stations météo. Ce fichier contient les dernières informations météo relevées par la station (et peut être mis à jour régulièrement grâce au logiciel Heavy Weather). Le chemin où atteindre ce fichier doit être précisé dans le menu Telecope / Configuration / Station météo.

Syntaxe :

GETDATAWEATHERSTATION TempEx ValidTempEx HumidityEx ValidHumidityEx WindSpeed ValidWindSpeed WindDir ValidWindDir DewPoint ValidDewPoint Pression ValidPression

Variables :

Paramètres | Entrées / Sorties | Type | Description
TempEx | Sortie | Réel | Température extérieure mesurée
ValidTempEx | Sortie | Booléen | Existence d'une température extérieure mesurée
HumidityEx | Sortie | Réel | Humidité extérieure mesurée
ValidHumidityEx | Sortie | Booléen | Existence d'une humidité extérieure mesurée
WindSpeed | Sortie | Réel | Vitesse du vent mesurée
ValidWindSpeed | Sortie | Booléen | Existence d'une vitesse de vent mesurée
WindDir | Sortie | Réel | Direction du vent mesurée
ValidWindDir | Sortie | Booléen | Existence d'une direction du vent mesurée
DewPoint | Sortie | Réel | Point de rosée calculé
ValidDewPoint | Sortie | Booléen | Existence du point de rosée calculé
Pression | Sortie | Réel | Pression mesurée
ValidPression | Sortie | Booléen | Existence d'une pression mesurée

Exemple :

.....................................
GETDATAWEATHERSTATION TempEx ValidTempEx HumidityEx ValidHumidityEx WindSpeed ValidWinSpeed WindDir ValidWinDir DewPoint ValidDewPoint Pression ValidPression

If ValidTempEx=TRUE
 Print "Temperature exterieure= " TempEx "°C"
else
 Print "Temperature Ext invalide"
endif

Télécharger l'exemple


Telescope / Close_Telescope_Devices

Close_Telescope_Devices

Description :

Cette fonction permet de couper la liaison par script avec le télescope.Cette fonction fonctionne même si la liaison n'a pas été intialisée avec "Open_Telescope_Devices".

Syntaxe :

STOP_TELESCOPE_DEVICES

Voir aussi :
Open_Telescope_Devices

Exemple :

.............................
CLOSE_TELESCOPE_DEVICES

Télécharger l'exemple


Caméra / DLSR_SetExposure

DLSR_SetExposure

Description :

Cette fonction permet de fixer la durée de l'acquisition avant le lancement. Ce paramètre doit être en millisecondes. Pour des temps de pose inférieurs à la seconde, l'APN se cale sur le temps de pose interne de l'APN le plus approchant.

Syntaxe :

DLSR_SETEXPOSURE expo

Variables :

Paramètres | Entrées / Sorties | Type | Description
expo | Entrée | Entier | Durée de l'acquisition en millisecondes

Voir aussi :
DLSR_StartExposure
DLSR_GetLastExposure

Exemple :

Msec=1000
ExpTimeMs=51*Msec
DLSR_SETEXPOSURE ExpTimeMs
print "Temps de pose établi !"
.....................................

Télécharger l'exemple


Caméra / DLSR_StartExposure

DLSR_StartExposure

Description :

Cette fonction permet de lancer une acquisition de durée fixée à partir de la fonction "DLSR_SetExposure". Le capteur CCD sera lu après la fin de l'exposition si l'utilisateur en fait la demande.

Syntaxe :

DLSR_STARTEXPOSURE

Voir aussi :
DLSR_SetExposure
DLSR_GetLastExposure

Exemple :

DLSR_STARTEXPOSURE
print "Pose démarrée !"
.....................................

Télécharger l'exemple


Caméra / DLSR_WaitEndExp

DLSR_WaitEndExp

Description :

Cette fonction permet d'attendre la fin de l'acquisition avant d'appeler une nouvelle fonction pour lire l'image en mémoire. Par exemple, cette fonction doit être appelée avant de sauver l'image de l'acquisition. Alors, PRiSM attendra la fin de l'acquisition avant d'essayer de sauver l'image.

Vous pouvez aussi exécuter les fonctions script classiques pendant une acquisition. Cette option a été réalisée dans le but d'éviter de gacher un temps précieux ( durant l'observation automatique par exemple, où il est alors pôssible de prétraiter les images acquises précédemment ! ). Dans ce cas, toutes ces fonctions classiques doivent être alors exécutées entre la ligne "DLSR_StartExposure " et la ligne "DLSR_WaitEndExp".

Syntaxe :

DLSR_WAITENDEXP

Voir aussi :
DLSR_StartExposure
DLSR_GetLastExposure

Exemple :

...................................
print "Attente de FIN de Pose..."
DLSR_WAITENDEXP
print "Fin d'attente Attente de Pose..."
.....................................

Télécharger l'exemple


APN / GetLastExposure

DLSR_GetLastExposure

Description :

Cette fonction permet de nommer la dernière acquisition de façon interne au PGM. Attention, l'acquisition doit être terminée et lue ... c'est pour celà que cette commande intervient après la commande "DLSR_WaitEndExp".

Ainsi, vous pouvez remarquer que les trois fonctions "DLSR_StartExposure", "DLSR_WaitEndExp" et "DLSR_GetLastExposure" sont souvent écrites ensemble. En effet, si vous écrivez seulement la première fonction (DLSR_StartExposure), l'acquisition ne pourra jamais être sauvegardée ! Très frustrant, non ! Afin de sauvegarder automatiquement cette image, vous devez utiliser le paramètre "DLSR_GetLastExposure " ... Ainsi, vous nommez l'image en interne et vous pouvez la manipuler et la sauver ... Mais, si vous désirez lire l'image avant la fin de l'acquisition, PRiSM ne sera pas d'accord avec vous et vous le fera savoir. Alors, avant d'écrire cette dernière fonction, il est nécessaire d'écrire "DLSR_WaitEndExp" ... Par contre, le paramètre du type "DLSR_SETEXPOSURE" est à fixer avant de lancer la fonction.
Vous pouvez aussi exécuter les fonctions script classiques pendant une acquisition. Cette option a été réalisée dans le but d'éviter de gâcher un temps précieux (durant l'observation automatique par exemple, où il est alors possible de prétraiter les images acquises précédemment !). Dans ce cas, toutes ces fonctions classiques doivent être alors exécutées entre la ligne "DLSR_StartExposure" et la ligne "DLSR_WaitEndExp".

Syntaxe :

DLSR_GETLASTEXPOSURE image

Variables :

Paramètres | Entrées / Sorties | Type | Description
image | Sortie | image | Nom interne au PGM de l'image

Voir aussi :
Fonctions en description

Exemple :

.....................................
DLSR_GETLASTEXPOSURE img1
REM Cette première image sera nommée "img1" dans le PGM
.....................................

Télécharger l'exemple


Base de scripts pour PRiSM

La base des scripts de PRiSM

Cette partie donne plusieurs scripts, dont certains sont déja très anciens.

Pour chaque script, il sera indiqué :

  • La version script minimum de PRiSM à utiliser.
  • Le nom du programme.
  • Le but.
  • Le mode d'emploi.
  • Les principales variables employées dans le script.
  • Le programme à télécharger.
  • l'auteur du script
            •
    Dossier | Titre du script
Fichier | Lecture d'un fichier LST
Prétraitement | Création d'un flat générique
 | Acquisition automatique des images de calibration 1
 | Acquisition automatique des images de calibration 2
Série d'images | Tri dans l'ordre des dates
 | Division d'une série par une image
 | Conversion de format par lot d'images
 | Ajouter date et heure dans les noms des fichiers images
Observation - Télescope | Calibration du télescope
 | Modèle de pointage
 | Tracé de l'horizon d'observation
 | Routine de focalisation automatique
Images couleurs | Création d'une mire


 Traitement des fichiers/ Fichier LST

Récupérer les données d'un fichier LST

Nom : LST.pgm

But :

Lire les données d'un fichier LST sauvegardé par PRiSM. Les données sont séparées par des séparateurs connus et constants.

Mode d'emploi :

Remplir d'abord le renseignement essentiel :

  • Chemin complet pour lire le fichier LST.

    • Le script procède de la façon suivante :
    Il est à exécuter en mode DEBUG car ne renvoie aucun renseignement. Mettre des points d'arrêts pour chaque coupure de ligne pour comprendre l'éxecution du script. Chaque donnée est enregistrée dans une variable type chaîne de caractère.

    Script :
    Télécharger le script

    Auteur du script : Stéphane Charbonnel

    retour base des scripts


 Prétraitement/ Création d'un flat générique

Création d'un flat générique

Nom : Pretrait_Flat.pgm

But :

Créer un flat générique à partir de flats individuels, ces derniers ayant un temps de pose non négligeable.

Mode d'emploi :

Il est nécessaire d'avoir une série de noirs de flats de même temps de pose que le flat (chacun contenant en fait le noir par définition et l'offset).
Le script demande la sélection de la série de flat ainsi que celle de la série de noirs de flat. Il est réalisé ensuite les :

  • Création du noir générique.
  • Soustraction à chaque flat.
  • Création du flat générique.
  • Sauvegarde du flat générique au format CPA dans le même répertoire que les flats sous le nom de "Flat.cpa".

    • Principales variables utilisées:

    Nom | Type | Description
CheminFlat$, CheminDark$ | Tableau de chaines de caractères | Chemin où trouver les images de base.
NbFlat, NbDark | Entiers | Nombre de flats de base ainsi que de noirs de base.
ImgDarkMed | Image | Image médiane des noirs de flat
ImgFlatMed | Image | Image médiane des flats

    Script :
    Télécharger le script

    Auteur du script :Stéphane Charbonnel

    retour base des scripts


 Prétraitement / Acquisition automatique des images de calibration

Acquisition automatique des images de calibration

Nom : ONF_auto.pgm

Version du script : 2.1

But :

Acquérir automatiquement les images de prétraitement (flats, offsets et noirs) et créer les images maitres correspondantes.

Mode d'emploi :

Suivre les indications dans la fenêtre texte du script. Des paramètres sont à régler au début du script, dépendant de chaque utilisateur ...
Une attention toute particulière est attirée à la fin du script où l'auteur du script supprime du disque dur les images brutes et intermédiaires. Ce dernier indique la méthode à suivre dans le cas où l'utilisateur voudrait garder les images brutes ainsi que les images intermédiaires. Par principe, il est fortement conseillé de conserver au minimum toutes les images brutes.

Principales variables utilisées:

Nom Type Description

Un très grand nombre de variables est proposé. Il serait inutile de toutes les répertorier !

Script :
Télécharger le script

Auteur du script :Patrick Sogorb

retour base des scripts


Observation / Acquisition automatique des images de calibration

Acquisition automatique des images de calibration (sans création de fichier cosmétique)

Nom : ONF_MASTER.pgm

But :

Automatiser l'acquisition des images de calibration (flat, offset, dark) et le calcul des fichiers Master-flat, Master-offset, Master-dark

Mode d'emploi :

Le seul point à verifier est la fenêtre d'acquisition de votre CCD qui est définie à la ligne n°50 : "SETWINDOW 49 35 2228 1500".
Les chiffres indiqués ici renvoient à un capteur type KAF-3200E. Au besoin si vous ne connaissez pas la zone sensible de votre CCD, vous pouvez remplacer la ligne par SETWINDOWFULLFRAME.
Le script est à mettre en route alors qu'il fait encore jour, le telescope pointant le ciel, motorisation coupée. Au départ, le script demandera d'indiquer le répertoire de sauvegarde, puis le nombre d'images flat, d'offset, de dark et enfin le temps de pose pour les images dark (dans la mesure du possible, il doit être égal au temps de pose que vous utiliserez pour vos acquisitions en cours de nuit).
Pour plus de confort dans la visualisation de ce qui se passe, il faut agrandir largement la fenetre log. Le sript fera régulierement (variable: "IntervalMesure") des mesures du fond de ciel avec le temps de pose mini des flats. Lorsque la luminosité sera bonne (moyenne image inferieure à 22000 ADU), l'acquisition des flats démarre. A chaque image, le temps de pose sera ajusté afin de viser une moyenne à 22000 ADU dans les limites indiquées par les variables "TempsDePoseFlatMini" et "TempsDePoseFlatMax". Une fois l'acquisition des flats terminée, le srcipt fera l'acquisition des offsets et des darks. Il calculera ensuite les fichiers Master-flat, Master-offset, Master-dark et effacera les images d'acquisition et celles réalisées en cours de calcul.
Si vous désirez conserver les bruts d'acquisition et/ou les images de calculs intermédiaires, il suffit de supprimer les deux derniers paragraphes du script (ou des les rendre inactif en ajouter REM au début de chaque ligne).

NDLR : Ce script sera sûrement agrémenté de la création d'un fichier texte cosmétique lorsque les fonctions scripts le permettront.

Principales variables utilisées (et à ajuster !):

Nom | Type | Description
IntervalMesure | Entier | Intervale de temps entre chaque mesure du fond de ciel
TempsDePoseFlatMini | Entier | Temps de pose minimum des flats (et temps de pose initial)
TempsDePoseFlatMax | Entier | Temps de pose maximum des flats

Script :
Télécharger le script

Auteur du script et de la page d'aide : Patrick Sogorb

retour base des scripts


 Série d'images/ Tri dans l'ordre des dates

Tri d'images dans l'ordre des dates de prise de vue

Nom : TRI.pgm

But :

Trier les images dans l'ordre des dates de prise de vue. Le résultat sera rendu dans la fenêtre des scripts ET dans un fichier texte.

Mode d'emploi :

Remplir d'abord les différents renseignements utilisateurs :

  • Sélection des images à comparer
  • Répertoire et nom du fichier texte à créer

    • Le programme va alors créer une variable tableau "sASort[]$" contenant le Jour Julien (simplifié !) de prise de vue suivi du numéro interne de sélection de l'image dans la liste.
    Suivant la valeur du Jour Julien, le tableau va être remanié de façon à créer un nouveau tableau numérique "nAOrder[]" contenant, dans l'ordre des dates, le numéro interne de chacune des images.
    Par exemple "nAOrder[5]=10" signifie que l'image sélectionnée en n°10 sera positionnée à la 5ième position dans les dates.
    Il sera alors affiché (et écrit) le numéro de datation suivi du chemin complet de l'image.
    Remarque : Ce script est issu du programme de courbe de lumière automatique sous PRiSM (www.astrosurf.com/bernasconi/CourPhot/Intro.htm)

    Principales variables utilisées:

    Nom | Type | Description
nI, nJ, NImage | Entiers | Compteurs d'images
sOrder[]$ | Tableau de caractères | Tableau contenant la date ( dans l'ordre croissant ) et le numéro de l'image
nAOrder[] | Tableau de réels | Tableau contenant dans l'ordre des numéros d'images en fonction de la date
Ligne$ | Chaîne de caractères | Chaque ligne qui sera écrite dans la fenêtre des résultats ou le fichier texte

    Script :
    Télécharger le script

    Auteur du script :Laurent Bernasconi

    retour base des scripts


Série d'images / Division d'une série par une image

Division d'une série par une image

Nom : SERIEDIVIMAGE.pgm

But :

Diviser une série d'images à sélectionner dans un répertoire par une autre image.

Mode d'emploi :

L'utilisateur doit d'abord vérifier si les images désirent être sauvegardées au format CPA. Dans le cas contraire, il faut changer la partie correspondante dans PRiSM grâce aux fonctions de sauvegardes.
Le script demandera de sélectionner les images à diviser à partir d'une fenêtre WINDOWS; il est rappelé que les fichiers peuvent être ajoutés un à un grâce à la touche "CTRL" ou blocs par blocs grâce à la touche "SHIFT". L'image qui va diviser est aussi à sélectionner ainsi que le facteur de normalisation dans la fenêtre script. Les nouveaux fichiers seront copiés dans le même répertoire avec un suffixe du type "Div_", ceci grâce au maniement des chaînes de caractères dans les scripts.

Principales variables utilisées:

Nom | Type | Description
chemin$ | tableau de chaîne | "Répertoire + nom.xxx" des fichiers à diviser
FactorNomalisation | Réel | facteur de normalisation
ImgDiv | Image | Image de division

Script :
Télécharger le script

Auteur du script : Stéphane Charbonnel

retour base des scripts


 Série d'images / Conversion de format

Conversion de format

Nom : Conversion_format.pgm

But :

Convertir un lot d'images au format souhaité.

Mode d'emploi :

Suivre les indications dans la fenêtre texte du script.

Principales variables utilisées:

Nom | Type | Description
Format$ | Chaine de caractères | Format choisi
chemin$ | Tableau de chaines de caractères | Liste des chemins où sont sauvegardés tous les fichiers
save$ | Chaine de caractères | Chemin où sauvegarder l'image converties

Script :
Télécharger le script

Auteur du script :Stéphane Charbonnel

retour base des scripts


Série d'images / Ajout Date et heure dans le nom du fichier image

Ajout Date et heure dans le nom du fichier image

Nom : SERIEDATEENTETE.pgm

But :

Rajouter la date et l'heure dans le nom du fichier image.

Mode d'emploi :

L'utilisateur doit d'abord vérifier si les images que l'on désire renommer doivent contenir la date et l'heure ou chacun des deux.
Le programme procède de la façon suivante :

  • Pour une série d'image :
  • On lit l'image
  • On lit la date et l'heure
  • On isole l'ancien nom et on le complète
  • On sauvegarde à nouveau l'image
  • Fin de la série

Principales variables utilisées:

Nom | Type | Description
LireDate | booléen | variable = 1 si on désire ajouter la date ou 0 sinon
LireHeure | booléen | variable = 1 si on désire ajouter l'heure ou 0 sinon

Script :
Télécharger le script

Auteur du script : Stéphane Charbonnel

retour base des scripts


Série d'images / Addition d'images par lots

Additions de plusieurs séries d'images par lot

Nom : ADDITION_LOTS.pgm

But :

Additionner X images dans une série d'images paquets par paquets.

Mode d'emploi :

L'utilisateur doit compléter les paramètres de départ demandés comme le nom des images résultantes, et le nombre d'images à garder par paquets. Le script demandera de sélectionner les images à diviser à partir d'une fenêtre WINDOWS; il est rappelé que les fichiers peuvent être ajoutés un à un grâce à la touche "CTRL" ou blocs par blocs grâce à la touche "SHIFT". Ces images résultantes seront sauvegardées dans le même répertoire que les images à additionner.

Principales variables utilisées:

Nom | Type | Description
chemin$ | tableau de chaîne | "Répertoire + nom.xxx" des fichiers à additionner par paquets
Img[] | Tableau d'images | Utilisé pour stocker les images avant de les recaler et les additionner

Script :
Télécharger le script

Auteur du script : Stéphane Charbonnel

retour base des scripts


Observation / Calibration du télescope

Calibration du télescope

Nom : RECALIBRATION.pgm

But :

Calibrer le télescope. Le télescope et la caméra doivent déjà être intialisés sous PRiSM.

Mode d'emploi :

L'utilisateur doit d'abord vérifier tous les paramètres fixés au début du script et les rectifier en fonction de sa configuration.
Ensuite, le script prendra une image du champ d'étoile, les coordonnées connues par le télescope pouvant être déterminées. Ces dernières coordonnées seront utilisées pour calibrer l'image astrométriquement. Le télescope recevra alors les coordonnées rectifiées du centre de l'image (il va de soi que les coordonnées connues par l'instrument et celles réelles ne doivent pas être trop différentes, soit environ un quart de champ d'imagerie).

Principales variables utilisées:

Nom | Type | Description
NSo, NbStarCat .......................... | Entiers / Réels / chaîne$ | Tous pleins de pramètres à régler par l'utilisateur avant de lancer le script ...
Focus, TaillePixX, TaillePixY, BinX, BinY, AD, DC | Entiers / Réels | REnseignements nécessaires sur l'image
Xcenter, Ycentre, AlphaCEnter, DeltaCenter | Réels | Coordonnées mésurées et connues pour le centre de l'image, en radians ...

Script :
Télécharger le script

Auteur du script : Laurent Bernasconi

retour base des scripts


Observation / Modèle de pointage

Créer un modèle de pointage

Nom : MODELEPOINTAGE.pgm

But :

Faire apparaître les coordonnées pointées et celles réellement mesurées dans le but de l'intégrer au modèle de pointage de PRiSM. Le télescope et la caméra doivent déjà être initialisés sous PRiSM. (Etablir communication caméra et télescope).

Mode d'emploi :

L'utilisateur doit d'abord vérifier tous les paramètres fixés au début du script et les rectifier en fonction de sa configuration.
Ensuite, le script fera 25 mesures réparties uniformément autour du méridien SUD suivant les paramètres imposés pour DeplacementAlpha et DeplacementDelta : il sera alors affiché les coordonnées pointées ainsi que celles réellement mesurées, indiquant les erreurs de pointages. Dans le cas où une mesure aurait fourni une image qui ne soit pas étalonnable, cette dernière n'est pas retenue. Ces résultats sont enregistrés dans un fichier texte sous la forme suivante :

1     5.54236     1.03237     5.55259     1.03236
2     5.27896     0.62160     5.29330     0.62169
3    -0.43321     0.48991    -0.43226     0.49013
4     0.49992     0.48788     0.50621     0.48799
5     0.51774     0.90289     0.52489     0.90286
6     1.11428     0.64224     1.12034     0.64244

Dans la première colonne, on rencontre le numéro de la mesure, puis la déclinaison et l'angle horaire (en radians) réellement pointés et enfin la déclinaison et l'angle horaire (en radians) lus à partir des codeurs (donc que l'instrument "pense" avoir pointés).

Ce fichier doit être ensuite dans la moulinette du modèle de pointage pour être utilisé ...

Principales variables utilisées:

Nom | Type | Description
DeplacementAlpha, DeplacementDelta | Réels | Paramètres importants à régler pour les déplacements en radians en DEC et AD entre 2 prises d'images.
NSo, NbStarCat .......................... | Entiers / Réels / chaîne$ | Tous pleins de paramètres à régler par l'utilisateur avant de lancer le script ...
Focus, TaillePixX, TaillePixY, BinX, BinY, AD, DC | Entiers / Réels | Renseignements nécessaires sur l'image
Xcenter, Ycentre, AlphaCEnter, DeltaCenter | Réels | Coordonnées mesurées et connues pour le centre de l'image, en radians ...

Script :
Télécharger le script

Auteur du script : Laurent Bernasconi / S. Charbonnel

retour base des scripts


 Observations / Création d'un horizon

Création d'un fichier PRF pour délimiter son horizon

Nom : Horizon.pgm

But :

Créer un fichier horizon ".prf" à partir de l'enregistrement des positions du télescope
Une liaison avec le télescope est nécessaire. Le déplacement de ce dernier se fera à la raquette de commande pour ne pas perdre les informations des codeurs ...

Mode d'emploi :

  • Effectuer la liaison avec le télescope et calibrer ce dernier.
  • Modifier les paramètres utilisateurs du PGM pour l'enregistrement automatique
  • Déplacer le télescope (à la raquette) jusqu'en bord d'horizon.
  • Appuyer sur ENTREE pour la saisie des premières valeurs d'azimuth et de hauteur.
  • Déplacer le télescope (toujours à la raquette) jusqu'à un nouveau bord d'horizon. Appuyer sur ENTREE pour saisir la nouvelle valeur et ainsi de suite ...
  • Saisir "STOP" dans la fenêtre de saisie du programme pour arrêter la saisie des valeurs : ceci a pour effet de recopier la première ligne dans le fichier PRF pour "fermer l'horizon" ainsi que de clore l'utilisation du fichier d'enregistrement des valeurs.
  • Sous PRiSM, aller dans les options de configuration de la carte du ciel. Dans l'onglet "Affichage général", pointer vers le fichier d'horizon...

Principales variables utilisées:

Nom | Type | Description
Dir$ | Chaîne de caractères | Répertoire où sauvegarder le fichier PRF
Fichier$ | Chaîne de caractères | Nom du fichier PRF
Azi, AziPrem, AziTemp | Réels puis Entiers | Azimuths recueilli, sauvegardés en premier puis les uns après les autres
Haut, HautPrem, HautTemp | Réels puis Entiers | Hauteurs recueilli, sauvegardées en premier puis les unes après les autres
Ligne$ | Chaîne de caractères | Lignes écrites dans le fichier texte

Prinicipales fonctions utilisées :

  • Fonctions de gestion des fichiers textes
  • Get_Telescope_Position

Script :
Télécharger le script

Auteur du script :Stéphane Charbonnel

retour base des scripts


 Observation - Telescope/ Focalisation automatique

Focalisation automatique

Nom : AutoFoc.pgm
Librairie : Library.pgm

But :

Réaliser la focalisation automatique sur le centre du champ et sur une étoile de magnitude ciblée.
Les instruments : télescope, caméra et focuser DOIVENT être connecté au logiciel.

Mode d'emploi :

Remplir d'abord les différents renseignements utilisateurs :

  • Paramètres pour le pointage du télescope.
  • Paramètres pour la focalisation automatique.

    • Le script procède de la façon suivante :

  • Récupération des coordonnées connues par le télescope.
  • Recherche d'une étoile autour de la position du télescope dont la magnitude est dans un intervalle donné par l'utilisateur.
  • Bouger le télescope vers l'étoile retenue.
  • Faire une reconnaissance de champ (en utilisant la routine "Recalibre_telescope" de la librairie library.pgm grâce à la commande INCLUDESCRIPT).
  • Recentrer l'étoile pour être sur que cette dernière est au centre du champ.
  • Réalise la focalisation automatique (en utilisant la routine "FocAuto" de la librairie library.pgm grâce à la commande INCLUDESCRIPT).
  • Retour du télescope sur sa position de départ (en deux fois après recalibration entre les deux)

    • Script :
    Télécharger le script
    Télécharger la librairie

    Auteur du script : Laurent Bernasconi

    retour base des scripts


 Images couleurs / Création d'une mire

Création d'une mire

Nom : Couleur.pgm

But :

Créer une image remplies de carrés, de 18 couleurs différentes sur 8 bits et de 6 niveaux de gris.

  • Trois images rouges, bleues et vertes sont crées avec des pixels de valeur 0 ADU
  • Pour chaque image, il est créé :
    • un tableau de 24 valeurs aléatoires sur 8 bits permettant de définir "l'intensité" de la couleur correspondante.
    • Une succession de 24 carrés par détourage dans l'image (de valeur nulle au départ). L'intensité de la couleur pour chaque carré est "piochée" dans la variable tableau contenant les valeurs aléatoires.

Mode d'emploi :

Principales variables utilisées:

Nom | Type | Description
ImgR, ImgB, ImgV | Image | Nom des 3 images RVB
Val[] | Tableau d'entiers | Valeurs aléatoires d'intensité en 8 bits
LargX, LargY | Entiers | Taille de l'image résultante
DX, DY | Entiers | Taille de chaque carré

Script :
Télécharger le script

Auteur du script :Cyril Cavadore

retour base des scripts


Fichier / Fenêtre du ciel / Zoom

> Fichier > Nouvelle fenêtre du ciel > Zoom

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel] + icone

Lorsqu'on appuie sur zoom plus, la carte grandit d'un facteur 2 et zoom moins provoque la diminution d'un facteur 2.
Les facteurs de zoom s'échelonnent de 1 à 2048: 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024 ou 2048.
Le facteur 1 est la sphère complète du ciel dans la fenêtre (180° de champ) et le facteur 512 représente un champ d'environ 21 par 13 minutes d'arc. Il n'est pas possible de realiser des zooms intermediaires entre 128 et 256 par exemple.
Lorsque l'on zoome, il est normal de voir apparaître ou disparaître certains objets (au sens large). Par exemple, les étoiles du Guide Star Catalog n'apparaissent que si le zoom est égal à 16 ou les constellations disparaissent lorsque le zoom est supérieur à 16 ... Il en est de même pour les étoiles des catalogues sélectionnés qui renferment beaucoup d'étoiles.

Nov. 2005


Fichier / Fenêtre du ciel / Recherche

> Fichier > Nouvelle fenêtre du ciel > Recherche

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel] + icone

Cette fonction permet de rechercher un objet sur la carte du ciel. Si l'objet recherché est un objet du ciel profond, il faut avoir au préalable sélectionné le catalogue contenant l'objet (voir fonction configuration)

En cliquant sur l'icone [image], la fenêtre suivante s'ouvre :

Il suffit alors de donner le nom de l'objet recherché, puis de cliquer sur le bouton [OK]. Si l'objet est visible du la zone de la carte du ciel en cours d'affichage, alors PRiSM indique où se trouve l'objet. Si l'objet n'est pas visible, alors PRiSM l'indique et propose de recentrer la carte du ciel sur l'objet recherché.

  • Liste des noms supportés : le caractère # est un nombre entier ou non (M# est M10 ou M52...); la recherche n'est pas sensible aux majuscules et minuscules (M52 est équivalent à m52). Pour les objets Messier activer au préalable le catalogue NGC.
    • Messier : M#
    • New General Catalog : NGC# ou N#
    • Planetary Catalog : PK#-# (Entrer la référence exacte, ne pas éliminer les 0: PK000.0-06.8 n'est pas PK0-6.8 ou PK013.7-10.6 n'est pas PK13.7-10.6)
    • Upsala General Catalog : UGC#
    • Abell Catalog : ABELL#
    • Index catalog : IC# ou I#
    • MorphologicalCG : MCG+#-#-# ou MCG-#-#-# (Entrer là aussi la référence exacte: MCG+15-01-001 n'est pas MCG+15-1-1)
    • Lynds Dark Nebula : LDN#
    • Lynds Bright Nebula : LBN#
    • Sharpless II catalog : SH2-#
    • Van Den Berg Nebula : VDB#
    • ARPgalaxies catalog : ARP#
    • Barnard catalog : B#
    • Peculiar Galaxy Catalog : PGC#
    • ESO catalog : ESO#
    • Catalogue des quasars : Pas de dénomination spéciale. Connaître le catalogue !
    • Galaxies du catalogue Markarian : MRK####
    • Galaxies du catalogue Arp-Madore : AM####-###

    Pour les catalogues d'étoiles : il suffit de rentrer le nom abrégé du catalogue si beosin est suivi du numéro de l'objet dans ce catalogue, de la même façon qu'on le rencontre sur la carte du ciel.

    • Bright Star Catalog : BSC#
    • WDS Catalogue : #####
    • SAO Catalogue : SAO#
    • Catalogue Hipparcos : HIP#
    • Etoiles Henry Draper : HD#
    • Etoiles Tycho1 : T# (la dénomination PRiSM n'est pas la dénomination officielle : voir la page des catalogues d'étoiles).
    • Etoiles Tycho2 : T# (la dénomination PRiSM n'est pas la dénomination officielle : voir la page des catalogues d'étoiles).
    • Etoiles UBVRI Landolt : Landolt_#

  • Recherche par Alias : Lorsque l'on ne connaît pas exactement le numéro de l'objet, on peut le chercher grâce à un alias ou surnom.
    Voici la liste des alias (langue US) reconnus par le logiciel (sources: URANOMETRIA 2000.0):
    • NGC140 : 47 Tucanae
    • NGC224 : Andromeda Galaxy
    • NGC6822 : Barnard's Galaxy
    • SH2-276 : Barnard's Loop
    • NGC2632 : Beehive Cluster
    • NGC4826 : Blackeye Galaxy
    • NGC6826 : Blinking Planetary
    • NGC7662 : Blue Snowball Nebula
    • NGC7635 : Bubble Nebula
    • NGC6302 : Bug Nebula
    • NGC6405 : ButterFly Cluster
    • IC5146 : Cocoon Nebula
    • NGC1499 : California Nebula
    • PK064.7+05.0 : Campbell's Hydrogen Star
    • NGC6543 : Cat's Eye Nebula
    • NGC5128 : Centaurus A
    • NGC6960 : Cirrus Nebula
    • NGC2392 : Clown Nebula
    • NGC3745 : Cone Nebula
    • NGC1952 : Crab Nebula
    • NGC6888 : Crescent Nebula
    • NGC869 : Double cluster
    • UGC10822 : Draco Dwarf
    • NGC6853 : Dumbell nebula
    • IC4703 : Eagle Nebula
    • NGC3132 : Eight Burst Nebula
    • NGC2392 : Eskimo Nebula
    • NGC3372 : Eta Carina Nebula
    • IC405 : Flaming Star Nebula
    • NGC3242 : Ghost of Jupiter
    • NGC6205 : Great Hercule Cluster
    • NGC7293 : Helix Nebula
    • NGC1555 : Hind's Variable Nebula
    • NGC1554 : Hind's Variable Nebula
    • NGC6811 : Hole in a Cluster
    • IC434 : HorseHead Nebula
    • NGC6523 : Hourglass Nebula
    • NGC2261 : Hubble's Variable Nebula
    • NGC2419 : Intergalactic Wanderer
    • NGC4755 : Jewel Box
    • NGC6523 : Lagoon Nebula
    • UGC5470 : Leo 1
    • UGC6253 : Leo 2
    • NGC650 : Little Dumbell
    • NGC6818 : Little Gem
    • NGC6369 : Little Ghost
    • SH2-261 : Lower's Nebula
    • MAFFEI1 : UA34
    • MAFFEI2 : UA39
    • PK205.1+14.2 : Medusa Nebula
    • NGC7000 : North America Nebula
    • NGC5139 : Omega Centauri
    • NGC6618 : Omega Nebula
    • NGC1976 : Orion Nebula
    • NGC3587 : Owl Nebula
    • B87 : Parrot's Head
    • IC5070 : Pelican Nebula
    • NGC1275 : Perseus A
    • NGC869 : Perseus Double Cluster
    • NGC884 : Perseus Double Cluster
    • NGC598 : Pinwheel Galaxy
    • LDN1773 : Pipe Nebula
    • LDN1773 : Pipe Stem Nebula
    • NGC2573 : Polarissima Australis
    • NGC3172 : Polarissima
    • NGC2632 : Praesepe Cluster
    • NGC6720 : Ring Nebula
    • NGC2237 : Rosette Nebula
    • NGC2239 : Rosette Nebula
    • NGC2246 : Rosette Nebula
    • NGC7009 : Saturn Nebula
    • NGC2032 : Seagull Nebula
    • NGC6027 : Seyfert's Sextet
    • SH2-240 : S147
    • SH2-240 : Simeis 147
    • NGC292 : Small Magellanic Cloud
    • B72 : Snake Nebula
    • NGC4594 : Sombrero Galaxy
    • IC4073 : Star Queen Nebula
    • NGC7320 : Stephan's Quintet
    • NGC6618 : Swan Nebula
    • NGC2070 : Tarantula Nebula
    • NGC1435 : Tempel's Nebula
    • NGC598 : Triangulum Galaxy
    • NGC6514 : Trifid Nebula
    • UGC9749 : Ursa Minor Dwarf
    • NGC6960 : Veil Nebula
    • NGC5194 : Whirpool Galaxy
    • NGC6705 : Wild Duck Cluster
    • IC2118 : Witch Head Nebula

    Pour les étoiles, on peut entrer le numéro ou l'ordre de l'étoile dans la constellation, comme "3 Boo" ou "Alpha Vir" pour chercher respectivement 3 du Bouvier ou Alpha de la Vierge. Note: les noms propres des étoiles comme Spica, Antarés, Rigel, Sirius... sont aussi supportés.
Juin 2008


Fenêtre du ciel / Icône éphéméride

> Fichier > Nouvelle fenêtre du ciel > Ephémérides

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel] + icone

Cette fonction permet de lancer le calcul d'éphémérides concernant les objets du Système Solaire.

En cliquant sur l'icone [image] , la fenêtre suivante s'ouvre :

Il est possible de sélectionner la date de début et la date de fin de la période couverte par les éphémérides.

Diverses cases à cocher permettent de sélectionner les objets dont on souhaite connaitre les éphémérides.

En cliquant sur le bouton [compute] on obtient les résultats sous forme textuelle, comme on peut voir sur la fenêtre ci-dessous :

Conditions d'activation :
Fenêtre du ciel ouverte

Fonction(s) Script associée(s):
GetRaDecMoon, GetRaDecSun

Voir aussi :
Fenêtre du ciel

Nov. 2005


Fenêtre du ciel / Icône identification

> Fichier > Nouvelle fenêtre du ciel > Identification

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel] + icone

Cet outil permet d'obtenir des informations sur un objet visualisé sur la carte du ciel. Il faut au préalable sélectionner le mode "Identification" en cliquant sur l'icone

Ensuite, il suffit de cliquer sur l'objet pour lequel on souhaite obtenir plus d'informations. La fenêtre suivante s'ouvre alors :

Fenêtre d'identification d'objets

Sur cette fenêtre apparaîssent les caractéristiques générales observationnelles de l'objet :

  • Le nom principal de l’objet dans son catalogue.
  • Les coordonnées alpha et delta en équinoxe 2000.
  • La distance à la Lune.
  • Le type de l’objet (galaxie, étoile,...).
  • La constellation où se trouve l’objet en notation IAU..
  • Les pages correspondantes de l'Uranométria et du SkyAtlas.
  • Le lever, passage au méridien et coucher à la date spécifiée par l’onglet DATE de la boite de dialogue « options d’affichage ». Les heures sont données en Temps Local par rapport à l'ordinateur, c'est à dire que si votre ordinateur est configuré en temps TU, les heures seront en TU. Si l'ordinateur est configuré en temps local avec un décalage heure solaire-heure locale, alors les heures de lever coucher seront celles de l'ordinateur (temps local).

En dessous, il est indiqué les caractéristiques intrinsèques de l'objet qui dépendent des catalogues de provenance; Dans la majorité des cas, on rencontre :

  • Equivalence 1 et 2 sont les noms de l'objet dans d'autres catalogues ( sélectionnés ou pas dans les options ).
  • Son angle d'extension maximum.
  • Sa taille ou mieux son grand axe et son petit axe ( en seconde d'arc ).

Plus en dessous sont indiquées les caractéristiques observationnelles du moment de l'objet

  • La date.
  • L’heure.
  • Le temps sidéral local.
  • L’angle horaire.
  • La hauteur de l’astre par rapport à l’horizon.
  • Azimut de l’astre par rapport au nord.
  • Le bouton [Ajouter à la base de réduction] est utile lorsqu'on désire étalonner ces images manuellement photométriquement ou astrométriquement.
  • La valeur de la masse d’air pour les calculs de photométrie. La masse d'air est définie par :
    m = 1 / cos ( Théta ) Théta étant la hauteur de l'astre au dessus de l'horizon.

On voit apparaître, ensuite, les boutons suivants :

  1. [Ecrire Label] : Cette fonction met un nom à l'objet directement dans la fenêtre de l'atlas
    Un exemple de Label
  2. [Objet suivant] et [objet précédent] : Si la sélection est grossière ( petit zoom ), il arrive souvent de sélectionner plusieurs objets à la fois. Pour changer d'objet, il faut cliquer sur objet suivant suivant pour avancer dans les pages ou objets précédents pour reculer. Le numéro de page est indiqué en bas à gauche.
  3. Si l'objet a son image dans l'atlas des Pises ou le BT-ATLAS (chemin indiqué dans les options de démarrage de la carte du ciel), le bouton [Voir Objet Atlas des Pises] ou [Voir Objet BT-ATLAS] correspondant se mettra en surbrillance prêt à répondre à la demande de l'observateur.
  4. Le bouton [Pointer sur] est destiné aux télescopes (ou moteurs) pilotés par PRiSM. Le bouton pointage permet de pointer le télescope sur cet objet à condition que :
    • Le telescope ou le couple moteur soit actif
    • La carte du ciel a les coordonnnes geographiques definies par defaut dans PRiSM.
  5. Le bouton [Calibrer avec] est destiné aux télescopes (ou codeurs) pilotés par PRiSM. Le bouton calibrage permet de calibrer le télescope sur cet objet à condition que :
    • Le telescope ou l'encodeur soit actif
    • La carte du ciel a les coordonnnes geographiques definies par defaut dans PRiSM. Attention : Les coordonnées envoyées à la monture ne sont pas exactement les coordonnées 2000.0. Ces sont ces dernières corrigées des effets de précession d'équinoxe et des effets de la réfraction atmosphérique.
  6. Le bouton [Ajouter à la liste des objets à observer] est destiné à compléter l'"Observing block" ou la liste d'observation gérée à partir du menu "Télescope".
  7. Le bouton [Ajouter liste codeurs (modèle pointage)] est destiné à compléter le modèle de pointage du système gérée à partir du menu "Télescope".

Pour quitter la fenêtre, cliquer sur le bouton [OK].

  • Durant l'observation, même sans encodeur ou télescope du type LX200, il est possible de se servir des fenêtres. En effet, pour pointer sur un objet, il faut juste repérer l'objet brillant le plus proche visible au chercheur. Pour celà, placer l'objet à observer au centre de la fenêtre et faire apparaître le champ de la caméra. Choisir un zoom de 4x. En général, on a un objet facilement visible au checheur. Soit on possède un pointeur automatique (comme on en voit de plus en plus souvent) et tout va bien. Soit on pointe l'objet brillant au chercheur et effectuer des miroirs horizontal et/ou vertical pour que le champ du CCD coïncide avec celui de l'objet le plus brillant. Avec les fonctions de rattrapage des moteurs, passer d'étoiles en étoiles jusqu'à aller sur l'objet. Une lunette guide en parallèle est parfois mieux adapté pour dégrossir le travail à l'oculaire. En conclusion, vive les encodeurs et les pointeurs automatiques !
  • Connaître exactement le centre d'une image : Pour réaliser des analyses astrométriques, il faut connaître avec une bonne précision le centre de l'image. Pour ceux qui ne possèdent pas d'encodeurs ou de telescope de type LX200, la position ne s'affichera pas automatiquement dans l'entête de l'image. Il faut donc la rentrer. Par comparaison avec les étoiles du GSC d'une fenêtre faisant apparaître le champ du CCD, celà suffit en général pour déterminer ces coordonnées et donc compléter l'entête. Prendre soin alors de sauvegarder l'image pour que les coordonnées du centre le soit aussi. En repérant la position de l'objet sur l'image, utiliser le menu contextuel ( bouton droit de la souris ) et choisir Envoyer Alpha-Delta vers l'image. Ceci permet de réaliser cette opération plus rapidement.

Conditions d'activation :
Fenêtre du ciel ouverte

Fonction(s) Script associée(s):
GetObjectCoord, GetAsterCoord, GetCometCoord, Calibrate_Telescope

Voir aussi :
Fenêtre du ciel

Nov. 2005


Fichier / Fenêtre du ciel

> Fichier > Nouvelle fenêtre du ciel > Configuration

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel] + icone

Cette fonction permet de configurer l'ensemble du module de carte du ciel.

En cliquant sur l'icone [image] de la carte du ciel ouverte, la fenêtre suivante s'ouvre :

Cette fenêtre comporte 9 onglets, permettant de nombreuses possibilités de configuration :

  • Ciel Profond, pour toutes les options concernant le ciel profond
  • Système Solaire, pour toutes les options concernant les objets du système solaire
  • Astéroïdes, pour toutes les options concernant les astéroides
  • Options de tri, pour définir les critères d'affichage des objets
  • Lieu et Date, pour définir le lieu et la date d'observation
  • Etoiles, pour les options concernant l'affichage des étoiles
  • CCD/Telescope, pour les options concernant l'instrumentation utilisée
  • Affichage Général, pour les options générales d'affichage

Conditions d'activation :
Fenêtre du ciel ouverte

Nov. 2005


Fenêtre / Onglet Affichage général

> Fichier > Nouvelle fenêtre du ciel > Configuration > Onglet Affichage Général

L'onglet "Affichage Général" permet de sélectionner les catalogues actifs dans la carte du ciel.

Cliquer pour l'aide
  • Case à cocher "Voir les constellations" :
    La carte du ciel montre alors les figures des différentes constellations.On voit notamment des traits bleus reliant les principales étoiles de chaque constellation.

  • Case à cocher "Voir les limites des constellations" : La carte montre alors les limites et noms des différentes constellations. En cas de doute, il suffit d'interroger l'identificateur d'objet qui donne la constellation de l'objet recherché.

  • Case à cocher "Voir les grilles Alpha-Delta" :
    Trace un système de repérage dans le ciel sous forme de quadrillage afin de se repérer plus facilement. Les grilles en alpha sont affichées toutes les 8 minutes et en delta tous les 2°.

  • Case à cocher "Voir grilles Ecliptique" :
    Trace un système de repérage dans le ciel sous forme de quadrillage afin de se repérer plus facilement.
    Dans ce système, on mesure dans le plan de l'écliptique en partant du point vernal la longitude écliptique correspondant à l'ascension droite à l'équateur céleste de 0° à 360°. La latitude de l'écliptique est mesurée verticalement (comme la déclinaison) de 0° à 90° jusqu'aux deux pôles.

  • Case à cocher "Voir les grilles Galactique" :
    Trace un système de repérage dans le ciel sous forme de quadrillage afin de se repérer plus facilement.
    Dans un tel système, le plan de référence est celui de La Voie lactée, notre galaxie. La déviation par rapport à l'équateur céleste est importante, le plan galactique étant incliné de presque 60°. Le point zéro est également différent, il se trouve dans la direction du centre de notre galaxie dans la constellation du Sagittaire, un point de coordonnées équatoriales 17h42m en ascension droite et -28°55' en déclinaison. C'est le point de référence pour la latitude galactique de 0° à 360° dans la direction de la constellation du Cygne, et comme pour les autres systèmes, la latitude galactique part de 0° à l'équateur galactique jusqu'à 90° au pôle galactique.

  • Case à cocher "Inverser Nord/Sud" :
    Inverse le côté Nord - Sud dans la présentation de la carte du ciel. Le pôle Nord a dans ce cas tendance à se trouver au bas de la carte.

  • Case à cocher "Inverser Est/Ouest" :
    Inverse le côté Est - Ouest dans la présentation de la carte du ciel.

  • Case à cocher "Tenir compte de l'horizon pour l'orientation de la carte" :
    Cette option permet de changer l'orientation de la carte par rapport à celle imposée par défaut.
    Elle permet donc d'afficher la carte référence par rapport à l'Azimuth du site d'observation, sinon c'est la référence équatoriale (donc independante du lieu) qui est prise.

  • Case à cocher "Azimuth et hauteur fixe dans le temps" : Cette option permet de pointer dans une direction fixe. Comme si le télescope n'était pas motorisé. Ceci revient à fixer un point de la voute céleste et à ne pas en bouger ...

  • Case à cocher "Voir les objets de l'Atlas des Pises" :
    Une des options très intéressante de cette boite est " Voir les objets du Pises-Atlas". En validant cette option, on voit les objets dont les images sont incluses dans le CD-ROM des Pises.
    Ces objets sont marqués par un rectangle dont la couleur peut soit être bleue pour toutes les cibles ou soit avoir une couleur particulière suivant l'instrument utilisé pour la prise de vue; il suffit pour cela de cocher " Différencier le type de télescope ". On accède aux images à partir de la fonction d'identification des objets.

    Enfin, il est indiqué le chemin où le programme trouvera le répertoire " \images " ( du CD des PISES ) où se trouveront les différents fichiers des images de l'atlas des Pises. Cette option peut être redéfinie à partir du menu "Options > Option démarrage carte du ciel".

  • Case à cocher "Voir les objets du BT-Atlas" :
    Pour ceux qui possèdent en plus le CD-ROM BT-ATLAS, il suffit d'indiquer le chemin où l'ordinateur peut trouver ce CD ou les fichiers correspondants et le Pises-Atlas gère les fichiers ! Les objets du BT-Atlas sont alors affichés sous forme de croix. Pour accéder aux différentes images, il faut utiliser l'identificateur d'objet.
    Enfin, il est indiqué le chemin où le programme trouvera les différents fichiers des images du BT-ATLAS. Cette option peut être redéfinie à partir du menu "Options > Option démarrage carte du ciel".

  • Case à cocher "Affichage négatif Noir et Blanc" :
    Si on préfère que les étoiles soient en noir et le fond de ciel en blanc, surtout pour les impressions de fenêtre du ciel, il faut sélectionner l'option afficher en Noir et blanc.

  • Case à cocher "Voir une échelle" :
    On voit alors une échelle en bas à gauche dans la fenêtre du ciel où l'option est sélectionnée.
    Les options voir échelle et étoiles en noir et blanc sélectionnées

  • Case à cocher "Mettre le nom des objets" :
    Ajoute le nom de tous les objets présents dans la carte du ciel, étoiles ou objets du ciel profond. Cette option n'est à utiliser que lorsque le nombre d'objets dans la fenêtre est faible c'est-à-dire lorsque le zoom est important !
    Pour éviter de surchager la fenêtre, on peut décider aussi de ne pas mettre celui des étoiles en cliquant sur l'option correspondante.
    Il est également possible de régler la taille apparente des noms en choisissant la taille de la police par rapport à une police de référence.

  • Case à cocher "Etoiles séparées" :
    Les étoiles très proches les unes des autres apparaissent séparées les unes des autres sur la fenêtre du ciel au lieu de passer pour une unique étoile. Ceci est valable notamment lors de l'utilisation de plusieurs catalogues d'étoiles pour la représentation.

  • Case à cocher "Ligne d'horizon" :
    L'option ligne d'horizon permet de trace la ligne d'horizon du lieu considéré. Les zones du ciel qui ne sont pas au-dessus de cette ligne apparaissent en grisâtre.
    Active l’affichage de l’horizon en fonction de la date et du lieu indiquée par l’onglet "Lieu et Date". Le fichier ASCII Pises.Prf contient un profil de l’horizon utilisateur. Il permet de vous indiquer la «fermeture» de votre horizon par des collines, des arbres ou des maisons. Il tient à vous de connaître sur votre lieu d’observation avec un théodolite la hauteur de vos obstacles en fonction de l’azimut (origine au nord) et à les mettre à jour dans le fichier ASCII Pises.prf dont voici un exemple (toutes les unités sont en degrés et le fichier ne peut encore être créé automatiquement):

    Le fichier .prf fait apparaître la ligne d'horizon qui est rarement régulière ( Ce pays plat qui est le mien ...

    Le format d'un tel fichier est un format texte. Attention, les données sur une même ligne sont séparées par un espace et non par une tabulation. Il est indiqué la hauteur de l'obstacle au dessus de l'horizon ( en degrés ) par rapport au Nord :

    Le format .prf

  • Case à cocher "Horizon sans profil" :
    On n'a pas besoin de connaitre le profil d'horizon du lieu où on observe ( quoique plus intéressant pour savoir ce qu'on peut réellement observer ). Si on veut quand même distinguer les objets couchés des objets levés, il suffit de cocher cette option qui rend la précédente innaccessible ( de couleur grisée ).

  • Case à cocher "Afficher la couleur du ciel par rapport à la position du Soleil" :
    Cette option permet de donner une couleur bleu ciel aux zones de la carte qui sont proches de la position du Soleil; utile pour examiner des cartes produites au petit matin ou en début de soirée.

  • Boutons "Charger, Sauver" :
    Le bouton "SAUVER" permet de sauver la fenêtre du ciel sous un fichier MAPSKY. Le bouton "CHARGER" permet de rappeler une fenêtre précédemment chargée ... à défaut d'utiliser le menu "fichier / Charger fenêtre du ciel".

Conditions d'activation :
Fenêtre du ciel ouverte

Nov. 2005


Fenêtre du ciel / Onglet Ciel profond

> Fichier > Nouvelle fenêtre du ciel > Configuration > Ciel Profond

L'onglet "Ciel Profond" permet de sélectionner les catalogues actifs dans la carte du ciel.

PRiSM contient un ensemble de catalogue dont voici la description :

  • Le catalogue NGC ( New General Catalog ) et le catalogue IC ( Index Catalog ):

    Types d'objet | Objets du ciel profond de façon général : galaxies, nébuleuses et amas d'étoiles.
    Provenance | Ce catalogue complète le catalogue Messier. Publié par J.L.E. Dreyer (1852-1926) en 1887 (NGC) et complété en 1895 (IC I) et 1907 (IC II). Ce catalogue est donc très ancien et ne peut servir de base sure !
    Nombre | 13000 objets
    Limites célestes | Pas de limites mais certaines zones éparses sont vides ... Cependant, les objets se situent principalement à une déclinaison supérieure à 0°.
    Limites sur les objets | Pas de limite spécifique
    Désignation ( Rechercher un objet ) | Indiquer "NGC" suivi du numéro d'identification ( ou "IC" suivi du numéro dans le catalogue ) de 1 à 4 nombres : "NGCnnnn" ou "ICnnnn", soit par exemple NGC5423 ou NGC18.
    Indications PRiSM
    ( Rechercher un objet )
             Sont indiqués dans la mesure du possible :
    La taille, la magnitude, l'angle, le grand axe et le petit axe. En général, la majorité des objets NGC ont des équivalents dans les autres catalogues; 2 de ces équivalents sont indiqués.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers NGC et LIEN vers NGC.

  • Le catalogue ABELL :

    Types d'objet | Amas de galaxies.
    Provenance Premier catalogue du genre établit en 1958 d'après les Sky Survey du Palomar Observatory.
    Ce type d'amas permettent scientifiquement de déterminer l'âge de l'univers, mais, attention, les galaxies sont toujours très faibles et il faut donc un gros diamètre pour les observer.
    Nombre | 2712 amas
    Limites célestes | Amas au nord de la déclinaison de -20°.
    Limites sur les objets | Pas de limite spécifique.
    Désignation ( Rechercher un objet ) | il faut indiquer le nom "ABELL" suivi du numéro dans le catalogue : "ABELLnnnn". Soit par exemple "ABELL51" ou "ABELL2222".
    Indications PRiSM
    ( Rechercher un objet )
             Sont indiqués dans la mesure du possible :
    La taille de l'amas et la magnitude moyenne.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers ABELL.

  • Le catalogue MCG ( Merged Catalogue Galaxy ) :

    Types d'objet | Catalogue morphologique des galaxies.
    Provenance | Il est formé à partir du Palomar Observatory Sky Survey (POSS). Date de 1962.
    Nombre | 28904 galaxies
    Limites célestes | Déclinaison comprise entre 90° et -33°.
    Limites sur les objets | Galaxies plus brillantes que la magnitude 15.
    Désignation ( Rechercher un objet ) | Une désignation du type MCG consiste en une suite de 3 nombres, avec des espaces ou des tirets entre eux; le premier nombre peut être négatif. Certains objets possèdent une lettre après les nombres pour éviter les confusions. Les noms sont structurés suivant les zones du POSS et le dernier numéro indique le numéro de l'objet sur la plaque. Du type "MCGsnn-nn-nnn" soit par exemple, MCG+08-30-014.
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Sont indiqués dans la mesure du possible :
    La taille de la galaxie, la magnitude V, le petit axe, le grand axe et l'angle d'inclinaison par rapport au Nord.
    Beaucoup d'objets ont leur équivalent NGC / IC.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers MCG.

  • Le catalogue UGC ( Uppsala Galaxy Catalog ) :

    Types d'objet | Catalogue de galaxies.
    Provenance | Réalisé à partir des photos dans le bleu du Palomar Observatory Sky Survey (POSS). Date de 1973. Les galaxies dont le diamètre est inférieur à 1,0' mais dont la magnitude est supérieure à 14,5 proviennent du CGCG ( Catalogue of Galaxies and Clusters of Galaxies; 1961-1968 ).
    Nombre | 12939 galaxies
    Limites célestes | Déclinaison au nord de -02.5°.
    Limites sur les objets | Diamètre limite de 1,0' et/ou une magnitude apparente maximum dans le bleu de 14,5.
    Désignation ( Rechercher un objet ) | Une désignation du type UGC consiste en une suite de 1 à 5 nombres du type "UGCnnnnn" soit par exemple, UGC11226 ou UGC51.
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Sont indiqués dans la mesure du possible :
    La taille de la galaxie, la magnitude V, le petit axe, le grand axe et l'angle d'inclinaison par rapport au Nord.
    Beaucoup d'objets ont leur équivalent NGC / IC ou MCG.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers UGC.

  • Le catalogue PK ( Strasbourg Catalog of Galactic Planetary Nebulae ) :

    Types d'objet | Catalogue de nébuleuses planétaires.
    Provenance | Agnès Acker, European Southern Observatory, 1992.
    Nombre | 1143 objets dont 796 objets avérés.
    Limites célestes | Limites de la voie lactée !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type PK consiste en PK suivi de nombres en rapport avec les coordonnées galactiques. Ces coordonnées sont la longitude en nnn.n et la latitude galactique soit la forme Saa.a. La désignation est donc sous la forme PKnnn.nSaa.a comme par exemple "PK197.4-06.4".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Sont indiqués dans la mesure du possible :
    La taille de l'objet en seconde d'arc et un équivalent dans un autre catalogue.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers PK.

  • Le catalogue LDN (Lynd Dark Nebulae) :

    Types d'objet | Catalogue de nébuleuses diffuses obscures.
    Provenance | Réalisé à partir des photos dans le bleu et le rouge du Palomar Observatory Sky Survey (POSS). Date de 1962.
    Nombre | 1791 objets
    Limites célestes | Limites de la voie lactée !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type LDN consiste en LDN suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 4 nombres). Par exemple, on rencontre "LDN51" et "LDN1002".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Sont indiqués dans la mesure du possible :
    L'équivalent de l'autre grand catalogue de nébuleuses obscures soit le catalogue Barnard, La taille de l'objet en seconde d'arc sur les grand axe et petit axe et le coefficient d'opacité : coefficient de 1 (peu sombre) à 6 (très sombre). Dans le cas où le nuage global puisse être séparé en plusieurs parties, ils sont listés séparément mais portent le même identificateur.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers LDN.

  • Le catalogue LBN (Lynd Bright Nebulae) :

    Types d'objet | Catalogue de nébuleuses diffuses brillantes.
    Provenance | Réalisé à partir des photos dans le bleu et le rouge du Palomar Observatory Sky Survey (POSS). Date de 1965.
    Nombre | 1125 objets
    Limites célestes | Limites de la voie lactée !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type LBN consiste en LBN suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 4 nombres). Par exemple, on rencontre "LBN51" et "LBN1002".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Sont indiqués dans la mesure du possible :
    L'équivalent dans d'autres grands catalogues de nébuleuses comme NGC, IC, S, C et DG, la taille de l'objet en minutes d'arc sur les grand axe et petit axe
    Un coefficient de brillance est fourni : coefficient de 1 (brillante) à 6 (à peine détectable); ce paramètre est à zéro pour les deux mêmes nébuleuses LBN191 et LBN844.
    Un code de couleur est aussi indiqué de 1 à 4 : '1' désigne une nébuleuse plus brillante sur la plaque bleue que sur la plaque rouge; '2' indique une même brillance sur les 2 plaques; '3' une brillance plus importante sur la plaque rouge et '4' si l'objet est seulement visible sur la plaque rouge.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers LBN.

  • Le catalogue VDB (Van den Berg Reflective Nebulae) :

    Types d'objet | Catalogue de nébuleuses à réflexion.
    Provenance | Réalisé à partir des photos dans le bleu et le rouge du Palomar Observatory Sky Survey (POSS). Date de 1966.
    Nombre | 158 objets
    Limites célestes | Limites de la voie lactée !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type VDB consiste en VDB suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 3 nombres). Par exemple, on rencontre "VDB51" et "VDB123".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies sont issus des coordonnées galactiques.
    Sont indiqués :
    Les dimensions sur la plaque rouge et la plaque bleue.
    Un coefficient de brillance est fourni : coefficient de 1 (brillante) à 5 (très faible).
    Un code de couleur est aussi indiqué de 1 à 7 : '1' indique une nébuleuse très bleue, '2' une nébuleuse bleue, '3' une nébuleuse modéremment bleue, '4' une nébuleuse intermédiaire, '5' une nébuleuse modéremment rouge, '6' une nébuleuse rouge et '7' une nébuleuse très rouge.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers VDB.

  • Le catalogue ARP (Atlas of Peculiar Galaxy) :

    Types d'objet | Catalogue de galaxies en intéraction.
    Provenance | Etablit principalement à partir de la NASA-IPAC Extragalactic Database. Date de 1966.
    Nombre | 338 objets
    Limites célestes | Non répartis uniformément.
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type ARP consiste en ARP suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 3 nombres). Par exemple, on rencontre "ARP51" et "ARP123".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies sont issus des coordonnées 2000.0.
    Sont indiqués dans la mesure du possible :
    L'équivalent NGC / IC.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers ARP.

  • Le catalogue Sharpless HII :

    Types d'objet | Catalogue de nébuleuses diffuses à région HII (notation spectroscopique = H-alpha).
    Provenance | Date de 1959.
    Nombre | 313 objets
    Limites célestes | Limites de la voie lactée dans l'hémisphère céleste nord !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type SHII consiste en SH2 suivi d'un tiret et de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 3 nombres). Par exemple, on rencontre "SH2-51" et "SH2-123".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies sont issus des coordonnées 1900.0 qui sont celles indiquées dans PRiSM.
    Sont indiqués si possible :
    La forme : une nébuleuse circulaire (circular), elliptique (elliptical) ou irrégulière (irregular).
    La structure d'une nébuleuse sans forme particulière (amorphous) à une nébuleuse bien formée (fliamentary).
    La dimension maximum en minute d'arc.
    La brillance de '1' pour une nébuleuse faiblement brillante à '3' pour une nébuleuse parmis les plus brillantes.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers Sharpless HII.

  • Le catalogue BDN (Barnard Dark Nebulae) :

    Types d'objet | Catalogue de nébuleuses obscures.
    Provenance | Réalisé par Barnard E.E. en 1919 (172 premiers objets) et 1927.
    Nombre | 349 objets
    Limites célestes | Limites de la voie lactée !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type BDN consiste en B suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 3 nombres). Par exemple, on rencontre "B2" et "B333".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 2000.0.
    Sont indiqués dans la mesure du possible :
    L'équivalent de l'autre grand catalogue de nébuleuses obscures soit le catalogue LDN, La taille de l'objet en minute d'arc (grand axe et petit axe identique) et le coefficient d'opacité : coefficient de 1 (peu sombre) à 6 (très sombre). Dans le cas où le nuage global puisse être séparé en plusieurs parties, ils sont listés séparément mais portent le même identificateur.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers BDN.

  • Le catalogue PGC (Principal Galaxies Catalog) :

    Types d'objet | Catalogue de galaxies.
    Provenance | Paturel, 1989.
    Nombre | 73197 objets
    Limites célestes | En dehors de la voie lactée !
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Une désignation du type PGC consiste en PGC suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 5 nombres). Par exemple, on rencontre "PGC51" et "PGC10021".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0 ou 2000.0.
    Sont indiqués dans la mesure du possible :
    L'équivalent d'autre grand catalogue comme UGC et MCG, La taille de l'objet sur les grand axe et petit axe, l'angle d'inclinaison par rapport au nord et la magnitude globale.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers PGC.

  • Le catalogue Veron-Cetty (Quasars and Active Galactic Nuclei) :

    Types d'objet | Catalogue de Quasars et de noyaux galactiques actifs.
    Provenance | Catalogue créé par Verron et Cetty en 1984. Actuellement, 11ème édition datant de 2003.
    Nombre | 64866 objets : 48921 quasars, 876 objets type BL Lac et 15069 galaxies actives.
    Limites célestes | En dehors de la voie lactée !
    Limites sur les objets | Les objets sont plus brillants que la magnitude absolue -23.
    Désignation ( Rechercher un objet ) | La nomenclature est compliquée car ce catalogue provient de la réunion de plusieurs catalogues. Les premières lettres correspondent au nom du catalogue d'origine. Les chiffres qui suivent sont en rapport avec les coordonnées 1950 du type HHMMS+DDMM. Pour de plus amples renseignements, se reférer à la page suivante.
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par PRiSM sont les coordonnées 2000.0.
    Sont indiqués dans la mesure du possible :
    Le redshift z (sa valeur minimale), La magnitude absolue de l'objet ainsi que sa magnitude visuelle. Dans de très rares cas, le catalogue le permettant, PRiSM indique les magnitudes B-V et U-B.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers VCC.

  • ESO (European Southern Observatory galaxies catalog) :

    Types d'objet | Catalogue de galaxies.
    Provenance | ESO.
    Nombre | Ce catalogue de galaxies étend le catalogue Upsalla à l'hémisphère Sud.
    Limites célestes | Hémisphère SUD en dehors de la voie lactée
    Limites sur les objets | Pas de limite définie
    Désignation ( Rechercher un objet ) | Les galaxies sont désignées par deux nombres séparés par un tiret : par exemple, "ESO 34-12".
    Indications PRiSM
    ( Rechercher un objet )
             Pour chacune de ces galaxies, on obtient comme renseignements leur position, le type, sa nomenclature dans la classification de Hubble, sa magnitude dans le bleu, et pour les plus importantes leur angle d'inclinaison ainsi que les dimensions de leur grand et petit axes.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers ESO.

  • MRK (Markarian galaxies) :

    Types d'objet | Catalogue de galaxies.
    Provenance | Observateur Markarian de 1967 à 1981 à l'observatoire Byurakan. Ces galaxies ont un continuum modéré à sévère dans l'ultraviolet.
    Nombre | 1525 Objets.
    Limites célestes | Hémisphère NORD en dehors de la voie lactée
    Limites sur les objets | Entre magnitude 13 et 17,5.
    Désignation ( Rechercher un objet ) | Une désignation du type MRK consiste en MRK suivi de nombres entiers correpondant au numéro de la nébuleuse (jusqu'à 4 nombres). Par exemple, on rencontre "MRK10" et "ARP1200".
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Pour chacune de ces galaxies, PRiSM indique la magnitude absolue, le redshift ( objets lointains ) ainsi que la taille des petit et grand axes (en secondes d'arc).
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers MRK.

  • AM (Arp-Madore galaxy catalogue) :

    Types d'objet | Catalogue d'association de galaxies.
    Provenance | Arp et Madorre en 1987.
    Nombre | 6445 Objets.
    Limites célestes | Hémisphère SUD en dehors de la voie lactée
    Limites sur les objets | Pas de limite précisé.
    Désignation ( Rechercher un objet ) | Une désignation du type Arp-Madorre consiste en AM suivi de nombres en rapport avec les coordonnées 1950.0. La désignation est de type "HHMM+DDM" où le dernier 'M' représente la dizaine de minutes d'arc en déclinaison (toujours entre 0 et 5).
    Indications PRiSM
    ( Rechercher un objet )
             Les coordonnées fournies par le catalogue et donc PRiSM sont les coordonnées 1950.0.
    Pour chaque groupe de galaxies, PRiSM indique la taille du diamètre ou de la séparation de l'ensemble ainsi que le type S/D à garder : 'S' indique que la mesure est une mesure de la spération des constituants majeurs du groupe alors que 'D' est un diamètre caractéristique du groupe entier.
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers AM.

  • Le catalogue HYPERLEDA 2003 :

    Types d'objet | Galaxies
    Provenance | Ce catalogue résulte d'une combinaison entre les catalogues Leda (1983) et HyperCat (2000). LEDA est le catalogue extragalactique le plus riche sur la position des galaxies de façon homogène sur le ciel. HYPERCAT est une compilation regroupant des paramètres comme la magnitude, la vitesse radiale et divers autres paramètres sur un maximum de galaxies. La réunion de ces deux catalogues en fait le catalogue le plus complet à l'heure actuelle sur les objets extragalactiques. Une grande nouveauté de ce catalogue est qu'il est en constante évolution, chaque astronome pouvant y apporter sa contribution.
    Nombre | 3 millions d'objets
    Limites célestes | Pas de limites si ce n'est une impossibilité d'observation d'objets extragalactiques au niveau de la Voie Lactée (notre galaxie).
    Limites sur les objets | Pas de limite spécifique
    Désignation ( Rechercher un objet ) | Indiquer "LEDA" suivi du numéro d'identification composé obligatoirement de 7 entiers : "LEDAnnnnnnn", où n est un nombre entier de 0 à 9. Par exemple "LEDA1526369" ou "LEDA0000051".
    Indications PRiSM
    ( Rechercher un objet )
             L'angle, le grand axe et le petit axe.
    Sont indiqués dans la mesure du possible : un équivalent dans un autre catalogue et un type morphologique. En ce qui concerne ce dernier paramètre, ....... (non encore clairement complété).
    Catalogue compilé | Ce catalogue est à mettre comme tous les catalogues compilés binaires (*.ccc) dans le répertoire principal de PRiSM et le sous-répetoire "Catalog". LIEN vers HYPERLEDA.

Tous ces catalogues sont dans le répertoire Catalog du répertoire principal de PRiSM et apparaissent sous la forme de fichiers .CCC . (qui sont des fichiers compréssés donc illisibles avec un éditeur de textes ).

En cochant sur Voie Lactée, celle-ci apparaît sous forme de petites étoiles. Ceci est surtout valable pour les petits zooms.

Il est possible de rajouter le contour des nébuleuses diffuses en cochant l'option appropriée. On obtient alors la forme de la nébuleuses pour toutes les nébuleuses diffuses importantes. En voici un exemple sur :

Il y a une remarque importante à la fin de la boîte : le fait de mettre toutes les options prendra beaucoup de temps pour afficher tous les objets. Si on manipule beaucoup les fenêtres avec un ordinateur peu rapide, le travail pourra vite paraitre fastidieux.

Septembre 2006


Fichier / Fenêtre du ciel / Onglet Système Solaire

> Fichier > Nouvelle fenêtre du ciel > Configuration > Onglet Système Solaire

L'onglet "Système Solaire" permet de configurer l'affichage des objets du système solaire (hors astéroïdes, dont l'affichage est régi par l'onglet "Astéroides")

L'onglet système solaire

En voici la description :

  • Voir l'écliptique, le Soleil, la lune, les planètes :
    La première option permet de voir les objets du système solaire les plus connus : le Soleil, la Lune et les planètes. Si cette option n'est pas activée, ce n'est pas la peine de faire une recherche sur une planète puisque le programme n'aura pas calculé sa position.

  • Voir la phase de la lune en icône : Permet de voir l'illumination de la Lune sous forme d'icône (par exemple : ) en haut à gauche de la fenêtre du ciel. En amenant la souris sur cet icône, on connaît directement les heures de lever, passage au méridien et coucher de l'astre. Ces données sont affichées de façon brève sous l'icône et de façon constante dans la ligne en bas à droite.

    • On rappelle que dans l'identificateur d'objet, la distance de l'objet à la Lune est toujours affichée, que les 2 options précédentes soit affichées ou non.

  • Voir la trajectoire des planètes :
    Il est possible de voir la trajectoire des différentes planètes sur plusieurs jours (représentée de la même façon que la trajectoire des astéroïdes). La boîte de dialogue parle d'elle-même.

  • Charger les comètes
    La boîte suivante est une boîte de recherche de comètes connues. Pour qu'apparaisse une liste de toutes les comètes connues jusqu'alors, il faut valider "Charger les comètes".

    1. Si on connait le nom de la comète, il suffit de la rechercher dans "recherche rapide" en indiquant son nom. Lorsque la comète est trouvée, il suffit de cliquer dessus pour la sélectionner. Si on double-clique, il apparaîtra les éléments orbitaux de l'objet. Si on veut sélectionner plusieurs objets, il suffit d'appuyer sur " CTRL " en même temps que la sélection de l'objet.
    2. Si on veut afficher toutes les comètes de la liste, il faut sélectionner l'option "afficher toutes les comètes".
    3. Si la découverte de la comète est récente, elle n'est sûrement pas dans la liste. Il faut alors indiquer ces éléments orbitaux. Pour celà, cliquer sur "Orbite et trajectoire". Il apparaît alors une fenêtre qui doit être complétée à la main. La description des deux fenêtres ci-dessous a déjà été faite dans le cas des astéroïdes (voir la partie correspondante et l'aide des boutons [Charger] et [Calculette]).

      Inscrire les éléments orbitaux d'une comète

      Afficher la trajectoire de l'objet sur plusieurs jours
  • Fichier objet :
    La dernière option permet d'afficher la position de la comète (ou de l'astéroïde) à partir d'un fichier donnant la position de l'objet à différents instants. Il n'est pas possible, dans ce mode, de faire une recherche d'objet. Le programme ne connaît pas la comète ou l'astéroïde. Il faut, évidemment, compléter le nom du fichier dans la boîte de dialogue correspondante.
    La dernière option permet d'afficher les dates en plus des positions dans le mode précédent.

    Pour faire apparaître la trajectoire de l'objet à partir de coordonnées rentrées dans un fichier .DAT. il faut se rendre dans les "options d'affichage" de la fenêtre du ciel et dans l'onglet "Système solaire". Prendre le bas de la fenêtre :

    On doit cocher le "fichier utilisateur" et rentrer le nom du fichier en cliquant sur le petit icône au bas du menu. Indiquer au programme si on veut que les dates des positions s'affichent.

    Chaque ligne du fichier utilisateur doit avoir l'un des formats suivant :
    Année
    Mois
    Jour
    Heure
    Alpha
    Delta
    Fichier exemple
    1995 | 10 | 30.0 | 14 13 00 | +31.5 | 98QT_1.dat
    1995 | 10 | 30.0 | 14 13 00 | -31.5 | 98QT_2.dat
    1995 | 10 | 30.0 | 14 13 00 | -22 15.6
    1995 | 10 | 30.0 | 14 13 00 | -22 15 35 | 98QT_3.dat
    1995 | 10 | 30 | 15 | 14 13 00 | -22 15 35
    1995.2321 | 14.235 | -0.135 | 98QT_4.dat

    La date devra donc être formatée sous une forme décimale (à partir de l'année) ou sous forme d'une suite d'entiers jusqu'aux heures (qui pourront être décimales).
    De même, les coordonnées ( en alpha et delta ) pourront être affichées en valeur décimale à partir de l'heure ou des degrés mais on pourra aussi les indiquer comme une suite de valeurs entières ( sauf la dernière qui pourra être un décimal ).

    On peut aussi mélanger les formats d'une ligne à l'autre. Dans tous les cas, le programme les reconnaîtra.
    On obtient le type de fenêtre suivante :

    Type de fenêtre obtenue

    Afin de supprimer les dates qui peuvent paraître génantes lorsque les points sont trop proches, il faut cocher "Ne pas mettre les Labels".

    Les différentes positions sont repérées par des ronds bleus. La demande d'information sur cet objet n'est pas disponible puisque le programme ne fait que marquer les positions indiquées dans le fichier mais ne calcule rien.
Nov. 2005


Fenêtre du ciel / Onglet Astéroïdes

> Fichier > Nouvelle fenêtre du ciel > Configuration > Astéroïdes

La position calculée des astéroïdes et des planètes atteind une précision de mieux que 0,5 seconde d'arc, à l'aide de la DLL de calcul des perturbations "PERTURBA.DLL" développée par Raoul Behrend et du fichier "18502030.cat" développé par Cyril Cavadore. Ces deux fichiers font partis de la mise à jour de PRiSM par internet et est donc automatique. Lors de leur première utilisation, il est alors nécessaire de recompiler la base d'astéroïdes pour un fonctionnement optimal. On en s'étonnera pas que la trajectoire prévue sur plusieurs jours ne corresponde pas parfaitement avec la position calculée au départ car cette trajectoire est calculée à partir de "l'ancienne méthode", dont le calcul est beaucoup plus rapide. La précision de cet algorithme peut être vérifié à partir des images suivantes.
Enfin, ceci ne concerne pas la position des satellites des planètes.

L'onglet "Astéroïdes" permet de configurer l'affichage des astéroïdes. La fenêtre se présente de la façon suivante :

Il faut avant tout, cliquer sur la case à cocher "Charger la base des astéroïdes" pour charger en mémoire les noms, numéros et numéros provisoires des différents astéroïdes. Le programme indique alors que la base se charge (en indiquant sa taille) et est en train d'être triée. Il bien que cette base soit à jour.
La fenêtre apparaît alors sous la forme suivante (avec quelques options non cochées d'avance) :

Cliquer pour l'aide

Les astéroïdes sont organisées dans deux colonnes de tailles égales : il apparaît le nom "légal" de l'astéroïde, son numéro officiel, son signe particulier (type particulier), sa période totale d'observation ainsi que son paramètre U. Pour ce dernier, un paramètre U=0 indique une position finalisée. C'est à partir de ces astéroïdes qu'il est possible au MPC de juger de la qualité des obsefvations de l'utilisateur. La position connue est d'autant moins précise que l'astéroïde a un paramètre U de 1 à 5. Une valeur U=1 indique que la position de l'astéroïde va être finalisée après peu d'observations supplémentaires.
On peut réaliser une recherche rapide d'un astéroïde bien particulier dont on connaît le nom ( cas ici de l'astéroïde "1999TC36" par exemple) en saisissant ce dernier dans une des deux fenêtres prévue à cet effet ... Lorsqu'on double-clique sur un astéroïde, ces paramètres orbitaux apparaissent :

paramètres orbitaux et autres informations

"Nombre de jours" représente le nombre de jour pendant lesquels la trajectoire sera affichée.

Différents boutons apparaissent aussi :

  • OK : rajoute l'astéroïde à la sélection
  • Sauvegarder paramètres : Permet de sauvegarder, notamment, les paramètres orbitaux dans un fichier TXT dont le format est décrit ci-dessous à partir de l'astéroïde "Pallas" :

    $ASTEROID
 &Priority      = ? // Priorité d'observation entre 1 et 4
 &Name          = Pallas   // Max 17 Char
 &Epoch         = 2453600.5 // JD
 &Eccentricity  = 0.2304899 //degres
 &Node          = 173.15954 //degres
 &SemiMajorAxis = 2.7733087 // ua
 &Perihelie     = 310.50212 //degres
 &Incl.         = 34.84383 //degres
 &AbsMagn       = 4.13000011444092
 &M_anomalie    = 71.3974  //degres
 &Number        = 00002    // Max =8 char, peut etre vide
 &NbreObs       = 5482
 &TypeAster     = 0  //   valeur code MPC
 &Status        = 0 // Valeur code MPC
 &NbreOpp       = 63 // nbre d'oppositions
 &DatesOps      = 1839-1993  // Max =9 char
 &ErreurRMS     = 0.550000011920929       // Arscec
 &U             = ?     // U Parameter 1 to 6, critere de numerotation
$END
    Ce type de fichier avait une utilité pour la version mais n'en a plus à l'heure actuelle ...
  • Ajouter à la liste des objets à observer : Rajoute cet objet dans la liste, accessible à partir du menu "Telescope / Liste des objets à Observer".
  • Courbe de magnitude et d'élongation : fourni les courbes correspondante pour les jours à suivre.

    courbes magnitudes / Elongation

    Ces courbes sont modifiables, comme tout graphique sous PRiSM.

Une fois l'astéroïde sélectionné, il apparaitra avec la liste des astéroïdes sélectionnés dans la carte du ciel en haut à gauche :

La liste des astéroïdes sélectionnés

Le fait de double-cliquer sur l'un d'entre eux centrera la carte du ciel sur l'objet voulu. Un astérisque apparaîtra en face si l'objet est déja dans le champ présenté.

Bouton Orbite et Trajectoire :
Ce bouton a la même utilité que le bouton consacré aux comètes dans l'onglet "Système Solaire" :

Il est alors nécessaire de rentrer les caractéristiques orbitales des objets à afficher dans la carte du ciel. On peut en faire plusieurs en activant la sélection au bas de la fenêtre.
Afin de visualiser la trajectoire prévue pour ces derniers, on peut désirer activer le dessin de la trajectoire sur un nombre de jours à définir.

Le bouton "Charger" permet de compléter les divers éléments des astéroïdes. Trois formats sont proposés :

  • Le format propriétaire PRiSM récupéré à partir d'un fichier TXT dont le formatage se trouve ici.
  • Le format MPC, "Daily Report" au le format DAI : le MPC fournit de tels rapports tous les jours où sont réunis une série de paramètres d'astéroïdes dans un même fichier. Il suffit de copier dans le bloc-note de WINDOWS ou tout autre logiciel de traitement de texte une partie de ce rapport pour obtenir un tel fichier DAI exploitable par PRiSM. Tous les astéroïdes présents dans ce fichier DAI seront mémorisés dans l'onglet. Il suffira ensuite de les sélectionner par leur numéro.
  • Le format MPC, "electronic circular" au format DAT : Pour chaque astéroïde, le MPC publie une circulaire électronique (récupérable sur le WEB ou par courrier électronique) dont un exemple est fourni. Il suffit de copier dans le bloc-note de WINDOWS ou tout autre logiciel de traitement de texte une partie de ce rapport pour obtenir un tel fichier DAT exploitable par PRiSM.
  • Une calculette est également disponible :

    Convertir des dates

    Elle permet de convertir des dates en Jour Julien et vice versa.

    • cadran haut à droite : permet en rentrant une heure précise d'avoir la fraction de jour en fonction de la variable rentrée.

    • cadran haut à gauche : permet en rentrant la date et la fraction de jour (précédemment calculée à partir du cadran précédent) d'obtenir le Jour Julien correspondant.

    • cadran en bas : permet d'obtenir une date à partir d'un Jour Julien ou vice versa. Avant d'appuyer sur JJ -> date, il faut bien évidemment compléter la dernière fenêtre de saisie.

    Dans l'onglet "interpolation", il est possible d'interpoler linéairement la position d'un astéroïde, par exemple, à une date donnée en fonction de ses positions à une date initiale puis à une date finale

    L'interpolation de la position

Onglet Selection :
Le contenu de cet onglet est le suivant :

Si on désire n'afficher que quelques astéroïdes bien particulier, on peut directement cliquer dans ceux de la base. Les éléments orbitaux sont alors affichés. On peut aussi les sauvegarder au format ".txt" comme expliqué ci-dessus. En cliquant sur "OK", on peut ajouter l'astéroïde à ceux que l'on désire afficher. Ces derniers sont tous affichés dans la fenêtre principale de l'onglet de sélection qui apparaît dans l'image ci-dessus.
On peut, évidemment, les supprimer par la suite, un par un ou tous ensemble.

Onglet Général :
Le contenu de cet onglet est le suivant :

On peut afficher tous les astéroïdes en cliquant sur "Afficher tous les astéroïdes". Cependant, cette opération est très longue ! C'est pour celà qu'il est proposé l'option "Ne pas recalculer la position des astéroïdes"; ceci permet lors d'un rafraichissement de fenêtre pour avoir, par exemple, la carte du ciel au moment précis de l'observation, de ne pas recalculer les orbites de trajectoires des petites planètes. Il faut cependant savoir que la position sera d'autant plus erronée que le rafraichissement se fera loin en temps du calcul initial.

Onglet Tri :

On peut également choisir de n'afficher sur la carte du ciel que des astéroïdes de types bien particuliers : Les astéroïdes dit de "type P" ou ceux de "type S" (la liste critique du MPC renferme les astéroïdes qui demandent une attention toute particulière car ils risquent d'être perdus s'il ne sont pas observés). On peut aussi choisir de sélectionner les astéroïdes suivant leur caractéristique.

Pour l'utilisateur qui désire sélectionner une série d'astéroïdes à partir d'un encadrement sur leur magnitude, il est possible d'utiliser l'option correspondante de l'onglet "Option de Tri".

Enfin, tout ceci ne serait interessant que dans le mois qui suit la mise à jour de la base d'astéroïde, car tout astéroïde qui possède un numéro provisoire est soumis à plusieurs changements lors du calcul de son orbite. PRiSM permet de renouveller la base d'astéroïde grâce à Internet. Il faut mettre sa base de donnée d'astéroïdes à jour au moins une fois par mois. Il y a deux sites FTP et donc deux formats de renouvellement possible de cette base.Cette opération est très simple avec l'onglet "Internet". On peut aussi utiliser un logiciel de téléchargement FTP :

Onglet Internet :
Le contenu de cet onglet est le suivant :

On nous laisse le choix entre 2 bases possibles :

  • La plus connue de ces deux bases jusqu'alors était la base de LOWELL téléchargeable en version zippée ou non à l'adresse ftp://ftp.lowell.edu/pub/elgb/. Le fichier zippé est alors astorb.dat.gz ( 15 Mo ) tandis que le fichier de données brutes est astorb.dat ( 50 Mo ). Ces fichiers de données contiennent tous les astéroïdes découverts jusqu'alors ( env 52000 au 08/1999 ) , numérotés définitivement ou provisoirement. Cette base est renouvellée tous les jours.
  • L'autre base est mise à jour tous les jours grâce aux données du MPC. Elle contient moins d'astéroïdes (environ 100000 au 10/2005) car elle ne contient pas d'astéroïdes en double. En effet certains astéroïdes provisoirement numérotés peuvent être en fait d'anciens astéroïdes perdus puis retrouvés. il est donc inutile de les faire apparaître deux fois. L'adresse ftp de cette base est : ftp://cfa-ftp.harvard.edu/pub/MPCORB/. Le fichier incriminé est Mpcorb.zip à télécharger. Cette base est renouvellée aussi tous les jours. Cependant, le fichier n'est pas toujours facilement disponible. Ne pas hésiter à regarder sur un moteur de recherche un site miroir pour le fichier "Mpcorb.dat".

Libre à l'utilisateur de faire son choix parmi toutes ces bases. Le fait d'appuyer sur "Charger" ouvrira sous l'explorateur internet l'arborescence du répertoire FTP correspondant pour MPCORB et la page internet de LOWELL pour les explication sur leur fichier d'astéroïdes. Il suffira alors d'enregistrer le fichier désiré.

Après avoir téléchargé l'un des deux fichiers, il est nécessaire de les dézipper afin d'avoir le fichier de données brutes (à ne faire uniquement que pour les fichiers téléchargés sous forme zippés ). Le fichier doit alors être en .dat. Utiliser l'onglet "Compilation" (voir ci-dessous) pour compiler :

Onglet Compilation :
Le contenu de cet onglet est le suivant :

Cocher l'option au bas de l'onglet correspondant au type de base utilisé. "Ted Lowell" pour le premier type de fichier décrit ou "MPC orbits" pour le deuxième cas. Définir le chemin du fichier en .dat ou sont les données en cliquant sur "Fichier". Cliquer enfin sur "Compiler" pour compiler la nouvelle base de donnée afin de l'adapter à PRiSM. Pour ce dernier, la base de donnée d'astéroïdes se situe dans le répertoire /Catalogue du répertoire principal du logiciel. Son nom est asteroid.ccc. Ce dernier sera alors remplacé par un nouveau contenant la nouvelle base de données d'astéroïde et le précédent sera sauvegardé dans le même répertoire sous le nom asteroid.back. Le nombre d'astéroïdes compilés sera indiqué dans la fenêtre prévue à cet effet.

Cliquer de nouveau sur l'option "Charger la base d'astéroïdes" pour charger la nouvelle base ... Et voilà votre base à jour.

Conditions d'activation :
Fenêtre du ciel ouverte

Fonction(s) Script associée(s):
GetAsterCoord

Voir aussi :
Fenêtre du ciel

Novembre 2006


Fenêtre du ciel / Onglet Option de tri

> Fichier > Nouvelle fenêtre du ciel > Configuration > Options de Tri

L'onglet "Options de Tri" permet de sélectionner les types d'objets qui seront représentés sur la carte du ciel.

  • Tri sur la magnitude et la taille :
    La première partie permet de faire une sélection ( sévère si on le veut ) sur les objets du ciel profond. En effet, il est inutile d'afficher les galaxies très faibles ou très petites pour les petits instruments ! On peut limiter suivant la magnitude et/ou suivant la taille. L'option sur l'encadrement en magnitude peut aussi être utilisé avec des astéroïdes.
  • Choix des objets :
    La deuxième fenêtre permet de faire une restriction sur les objets du ciel profond. Si on ne s'interesse qu'à un seul type d'objet, n'en sélectionner qu'un seul !
    La dernière option ne permet d'afficher uniquement les objets de Messier. Pour que cette option soit valide, il faut que l'option "NGC" soit activée dans l'onglet ciel profond. Malgré celà, seuls les 110 objets Messier paraîtront sur la fenêtre.
  • Tri sur les labels affichés :
    La dernière fenêtre indique tous les labels qui sont actuellement en mémoire. Si on veut effacer tous les labels, il faut aller cliquer sur l'icône correspondant de la fenêtre ( Effacer les labels ). Au contraire, si on ne veut effacer que quelques labels, il suffit de "déseltionner" les labels que l'on veut supprimer !
Nov. 2005


Fenêtre du ciel / Onglet Lieu et Date

> Fichier > Nouvelle fenêtre du ciel > Configuration > Lieu et Date

L'onglet "Lieu et date" permet de définir le lieu et la date qui doivent être pris en compte par le module de carte du ciel pour afficher la vue du ciel.

L'onglet Lieu et Date
  • Lieu :
    Cette partie sert à initialiser les coordonnées du lieu d’observation : la latitude et la longitude. Attention: en France, il est fréquent de se tromper sur le coté ouest ou est de la longitude dans la mesure où on récupère souvent ces coordonnées dans d’autres logiciel qui eux parlent de longitude négative et positive, ce qui est parfois ambigu !
    Ne pas oublier de préciser l’altitude de votre site d’observation, ceci est important pour le calcul de la position topocentrique des planètes.

    On doit saisir son lieu d'observation. Celui-ci n'est pas obligatoirement (et surtout au premier démarrage) le même que le lieu d'observation par défaut définit dans le menu [ Option / Site d'observation par défaut ]. Cependant, en cas de différence, le programme le signale lorsqu'on quitte cet onglet. Il est alors nécessaire de corriger le lieu d'observation par défaut si on compte beaucoup travailler sur des cartes du ciel dans un lieu autre que ce dernier.
    Si le lieu d'observation est exceptionnel, on change directement les coordonnées et l'altitude du lieu dans les fenêtres prévues à cet effet. Cependant, il est parfois intéressant de donner un nom à son lieu d'observation. il faut alors cliquer sur "Choisir dans une liste".

    Il est proposé plusieurs sites déjà disponibles. Les centre ville des plus grandes villes de France, du monde et les plus grands observatoires. Cependant, il se peut que votre site ne correspondent pas à ces différents sites. Il faut alors cliquer sur "Entrer un nouveau site dans la liste" :

    Entrer les paramètres du site et cliquer sur "Ajouter" ou alors "Annuler". Le site est ajouté par mis tous les sites déjà présents. Il suffit juste de la choisir. Tant qu'il ne sera pas volontairement supprimé, il restera dans la base de donnée des sites et sera aussi accessible à partir des "sites par défaut" du menu [ Option / Site d'observation par défaut ].

    A retenir : Lorsqu'une carte du ciel demarre, elle prend en compte le lieu donne par defaut dans le menu option du logiciel.

    Attention : si le lieu ne correspond pas au lieu defini par défaut dans PRiSM, toutes les commandes relatives au controle du telescope seront desactivees par securite.
  • Date
    On peut régler l'heure et la date désirée pour la fenêtre du ciel.
    On peut imposer l'heure ou se baser sur l'heure de l'ordinateur avec ou pas un décalage horaire ( pour le TU ). Les options parlent d'elle-même. On a également le JJ correspondant à la date fournie.
  • Animation :
    Ces options permettent d'animer la voute céleste. L'incrément doit être défini ainsi que la répétition du phénomène. Il suffit ensuite de cliquer sur le bouton [image] de la carte du ciel pour lancer l'animation.
    L'option "Horizon fixe" doit être activée ainsi que l'affichage des couleurs du ciel selon la position du soleil dans l'onglet affichage général. Intéressant par exemple pour suivre une eclipse de Soleil ou de Lune !
Nov. 2005


Fenêtre du ciel / Onglet Etoiles

> Fichier > Nouvelle fenêtre du ciel > Configuration > Etoiles

L'onglet "Etoiles" permet de sélectionner les catalogues d'étoiles actifs dans la carte du ciel.

L'onglet Etoiles; Cliquer pour aide ...
  • Case à cocher "supprimer toutes les étoiles" :
    Cette première option est faite pour supprimer les étoiles ... ce n'est pas celle que l'on utilise le plus souvent !

  • Case à cocher "Voir les étoiles du Bright Star Catalog (BSC)" :
    Active la présence des étoiles du BSC qui vont jusqu’à la magnitude 7. Ce catalogue référence aussi le numéro SAO, l'ordre alphabétique (grec) et le numéro dans la constellation. Le tri par magnitude n'a pas d'effet sur ce catalogue !
    S'il ne faut mettre que quelques étoiles supplémentaires, il faut mettre celles-là. Ce catalogue contient 9096 étoiles et donne beaucoup d'information sur chaque étoile. Le fichier se trouve sous forme compressé dans le répertoire catalogue sous le nom BSC.CCC.
    Dans l'identificateur d'objet, il est indiqué l'équivalent de l'étoile ( lettre, numéro, numéro SAO ) et la magnitude.

  • Case à cocher "Voir les étoiles variables (GCVS4 catalog)" :
    Le GCVS4 est un catalogue de 28484 étoiles variables. Dans le fichier original, il est indiqué beaucoup de données. Dans l'identificateur d'objet, PRiSM indique la magnitude maximum et la magnitude minimum.

  • Case à cocher "Etoiles doubles ( WDS catalogue )" :
    C'est le Washington Double Star Catalog. Date de 1984 et est le successeur du Index Catalogue of Visual Double Stars ( 1961 ). Il contient toutes les étoiles doubles visuelles qui ont fait l'objet d'au moins une mesure jusqu'en 1983. Il contient de ce fait 73610 étoiles doubles résultants de millions d'observations.
    PRiSM donne à chaque fois le type de composante, l'angle entre les deux composantes, la séparation et la magnitude de chacune des composantes.

  • Case à cocher "Etude du catalogue SAO" :
    Catalogue de 258 997 étoiles brillantes, mais avec moins d'informations sur chacune d'elles que dans le BSC. Cependant, beaucoup de magazine définissant les étoiles à partir des étoiles SAO, il a semblé utile d'introduire ce catalogue.

  • Case à cocher "Etoiles Hipparcos" :
    Catalogue de 118000 étoiles construits à partir de la mission "Hipparcos" de l'ESA datant de 1993. C'est un catalogue d'étoiles qui regroupe des informations précises sur certaines étoiles, jamais obtenues jusque là : position, mouvement propre, magnitude, couleur, et de temps à autre type spectral, vitesse radiale, et d'autres informations sur la nature de l'étoile. La magnitude limite du catalogue ne dépasse pas la magnitude V=13. De nos jours, le catalogue "Tycho2" est plus adapté.
    PRiSM indique donc la majorité de ces renseignements en incluant un élément important, justifiant la mission : la parallaxe trigonométrique.

  • Case à cocher "Etoiles photométriques Lonéos" :
    Catalogues d'étoiles photométriques.
    Il est indiqué pour chacune de ces étoiles le type spectral, leur nom dans un catalogue plus connu ( SAO, BSC ou GSC ), leur magnitude et indice B-V, U-B et R-I.

  • Case à cocher "UBVRI Landolt" :
    Le catalogue photométrique UBVRI a été réalisé à partir du système photométrique de Johnson-Kron-Cousins. C'est un catalogue de 526 étoiles, toutes au niveau de l'équateur céleste.Il a été effectué environ une trentaine de mesures sur des nuits différentes sur chaque étoiles pour confirmer les différentes valeurs. La majorité des étoiles des étoiles ont une magnitude visuelle comprise entre 11.5 et 16. L'indice de couleur B-V est compris, lui, entre -0.3 et +2.3.
    Dans le catalogue, pour chacune des étoiles, il est indiqué la désignation, l'ascension droite et la déclinaison, la magnitude V ,les indices B-V, U-B, V-R, R-I et V-I, le nombre d'observations et le nombre de nuits d'observations ainsi que les erreurs sur chacune des mesures de magnitude et d'indices. PRiSM répertorie ces étoiles comme des étoiles photométriques et indique, dans le mode identification d'objets, le nombre d'observations effectués sur cet objet, sa magnitude V ainsi que les indices B-V, U-B, V-R, R-I et V-I et le nombre de nuits d'observations.

  • Case à cocher "Etoiles Tycho 1" :
    Le Catalogue de référence Tycho (TRC) contient la position précise et le mouvement propre de 118218 étoiles du catalogue Tycho. Les mouvements propres ont été "étudiés" à partir du catalogue de Tycho et des données envoyées par le satellite Hipparcos. L'erreur renvoyée sur les mouvements propres est d'environ 2,5 milli-arc-seconde par an. On préfèrera utiliser le catalogue Tycho 2 qui a réactualisé le catalogue Tycho 1.
    Le logiciel PRiSM renvoie ces données à partir d'une identification provenant d'étoiles de ce catalogue.

  • Case à cocher "Etoiles Tycho 2" :
    Le Catalogue de référence Tycho (TRC) contient la position précise et le mouvement propre de 2539913 étoiles du catalogue Tycho. Ce catalogue est un catalogue de référence astrométrique contenant les positions, mouvement propres et 2 couleurs photométriques pour 2539913 étoiles dans le ciel. Pour les couples d'étoiles, la séparation est donné à 0,8 arcsec près. Ce catalogue est donc basé sur le même principe que Tycho1 mais en plus complet et légèrement plus précis grâce à l'amélioration des techniques de réduction. La précision du catalogue est de l'ordre de 25 milli-arc-secondes. Les objets sont offciellement nommés sous la forme "TYC nnnn-nnnnnn-1" mais par soucis de place utilisée par les catalogues sur le disque dur, le logiciel PRiSM utilise un nom du type "Tnn....." où ne figure que les chiffres différents de "0" et où ne figurent pas les "-" et le dernier "1". Le dernier "1" sera précisé pour les objets provenant du catalogue Tycho 1, ces derniers étant référencé de la même manière.

  • Case à cocher "Etoiles H. Draper :
    Cette case activ ele catalogue HD. Ce catalogue est un ensemble de 272150 étoiles. Il est particulièrement utilisé en spectroscopie stellaire.
    Les informations fournies par PRiSM sont le type spectral ainsi que la magnitude de l'objet.
    Une recherhce peut être effectuée à partir du terme "HD" suivi du numéro de 1 à 5 chiffres de l'objet.

D'une façon générale, il ne faut pas être étonné de voir des étoiles portant le même nom (et donc deux mêmes étoiles provenant de deux catalogues différents) être décalées à l'affichage sur la fenêtre du ciel (surtout à zoom important). Les coordonnées provenant de catalogues non astrométriques (comme le GSC) sont plus ou moins précises contrairement à des catalogues modernes comme le catalogue Hipparcos. D'après le nom de l'étoile, on reconnait facilement le catalogue de provenance. Le logiciel PRiSM ne doit en aucun cas être incriminé. Ce dernier dessine l'étoile à la position indiquée par le catalogue et ne peut en aucun cas faire un choix délibéré entre les catalogues. L'utilisateur est cependant mis en garde à ne pas attribuer la présence de 2 étoiles, alors qu'en réalité, sur sa propre image, il n'en verra qu'une ! Ce point est repris dans la page concernant l'onglet d'affichage général.

la même étoile apparaît différentes !

Les options suivantes ne sont valides que si le zoom est d'au moins 16 :

  • Onglet "GSC" :

    Active la présence des étoiles du GSC qui va jusqu’à la magnitude 16. Attention, les étoiles ne sont affichées que si le zoom est supérieur ou égal à 16, sinon cette option est sans effet. Si cette option est active, le contrôle de l’affichage des objets non stellaires du GSC (étoiles de couleur vertes) est lui aussi possible dans l’onglet "Option de tri". Ces objets non stellaires du GSC sont en fait des étoiles proches des galaxies ou des galaxies elliptiques. Si on compare une image à faible champ avec la carte du ciel, on aura intérêt à activer l’affichage des objets non stellaires du GSC sous peine de trouver dans l’image des astéroïdes ou des supernovae fantomes !

    On peut faire apparaître les 15 millions d'étoiles du catalogue GSC de magnitude inférieure à 16. La version originale du GSC tient sur deux CD-ROM mais il y a beaucoup d'indication inutiles au PRiSM. Les informations utiles, une fois compressé, tient sur une petite partie du CD-ROM des Pises !

    Ce catologue a été créé en scannant les plaques de deux observatoires : le Palomar Schmidt ( USA, California ) et le U.K. ( Australia ). Le principal but a été de collecter des étoiles pour en avoir assez afin d'utiliser le Hubble Space Telescope. Dans la Voie Lactée, par exemple dans le Sagittaire, on a obtenu la densité d'étoiles désirée dès la magnitude 13. Par contre, dans des coins pauvres en étoiles, comme par exemple la constellation de la Vierge, il a été nécessaire de sélectionner jusqu'à la magnitude 16. Les magnitudes maximum des étoiles vont donc varier entre 13 et 16 suivant les régions du ciel.
    Les objets ont été collectés automatiquement et ont été classés en deux types d'objets suivant leurs étendus : les objets stellaires et les objets " non-stellaires ". Ces derniers ne sont pas très utiles ( juste pour des comparaisons de champ afin de ne pas prendre un objet flou d'une image pour une comète ). PRiSM permet de ne pas afficher ces objets dans la fenêtre du ciel.
    L'organisation des fichiers du GSC est réalisé de tel sorte que l'on sauvegarde les coordonnées d'étoiles sur une portion de ciel ( dont les coordonnées du centre sont explicitées par le nom du fichier ). Seulement, les plaques se chevauchent les unes avec les autres sur les bords. Les étoiles sur les bords des plaques ont donc été sauvegardées sur 2 plaques différentes.

    Enfin, il est indiqué le chemin où le programme trouvera le répertoire "\GSC" (du CD de PRiSM) où se trouveront les différents fichiers du catalogue GSC. Cette option peut être redéfinie à partir du menu [Options > Option démarrage carte du ciel].

    Remarque importante : Il existe maintenant le catalogue GSC-ACT qui remplace avantageusement le GSC. A cette fin, il suffit de sélectionner l'option dans le menu "Option / Option de démarrage de la carte du ciel". Ce catalogue est le GSC 1.1 corrigé avec le catalogue ACT (Astrographic Catalog/Tycho) pour plus de précision astrométrique. Cependant, même si ce catalogue est meilleur que le GSC1.2 (attendre le GSC 2.0), il est encore préférable d'utiliser le catalogue USNO A2.

  • Onglet "USNO" :

    C'est un autre catalogue classique du même type que le GSC. La magnitude maximale d'apparition des étoiles respecte les mêmes options que pour le GSC.
    La base de données de ces étoiles n'est pas contenue par défaut par PRiSM, elle est disponible sous forme de CDs édités par l'observatoire US Naval, ces CDs peuvent être réclamés à l'US Nay Obs. par internet. Ce catalogue est décline en plusieurs versions :
    • SA1, un CD 55 millions d'étoiles prises de manière régulière sur le ciel. Attention, des étoiles manquent mais c'est suffisant pour de la réduction astrométrique.
    • SA2 est le même que le SA1 mais plus précis.
    • A1 : contient tout le ciel jusqu'à magnitude 20 et nécessite les 10 CDs. Cela aboutit à une base considérable de 550 millions d'étoiles. Le catalogue A2 est le même que le précédent mais mis à jour des bugs et de l'imprécision du A1.
    • A2 est le même que le A1 mais plus précis.
    De manière générale ces catalogues ont deux magnitudes, l'une dans la bande rouge et l'autre dans la bande bleue. On peut afficher indifferemment l'une ou l'autre de ces magnitudes.

    Il est indiqué le chemin où le programme trouvera le répertoire "\GSC" (du CD de PRiSM) où se trouveront les différents fichiers du catalogue GSC. Cette option peut être redéfinie à partir du menu [Options > Option démarrage carte du ciel]

  • Onglet "UCAC" :

    L'UCAC 1 est un catalogue obsolète. Il est donc fortement conseillé d'utiliser l'UCAC2 : Ce catalogue contient 48330571 étoiles. Ce catalogue est un catalogue photométrique. Sont répertoriées toutes les étoiles qui ont une magnitude R entre 7,5 et 16. L'erreur de position est de l'ordre de 20 milli-arc-seconde pour les étoiles entre magnitude 10 et 14 et de l'ordre de 70 milli-arc-second pour les étoiles de magnitude 16. A la base, ce catalogue couvre le ciel de -90° à +40° de déclinaison voire jusqu'à 52° dans certaines zones. Cependant, un additif réalisé par des amateurs (en attendant la version officielle fin 2004) permet de compléter le catalogue jusqu'à +90°. Les mouvements propres et la photométrie sont donnés pour toutes les étoiles. Les positions sont fournies pour l'époque 2000.0.
    Le chemin indiqué est celui dans lequel doivent se trouver le fichier "u2index.da" et tous les fichiers du type zXXX, où X représente un chiffre. Ce chemin se change à partir du menu [Options > Option démarrage carte du ciel]

  • Case à cocher "Magnitude limite" :
    Pour les petits zooms (16, 32 ou 64), afin de ne pas surcharger la fenêtre d'étoiles (surtout en utilisant le GSC), il est possible de limiter la magnitude limite des étoiles (uniquement) de la fenêtre. Les magnitudes prédéfinies par défaut sont les magnitudes maximum à utiliser pour avoir quelque chose de " lisible ".
Nov. 2005


Fenêtre du ciel / Onglet CCD et Télescope

> Fichier > Nouvelle fenêtre du ciel > Configuration > CCD / Télescope

L'onglet "CCD / Telescope" permet de configurer les éléments en rapport avec l'instrumentation utilisée. Afin d'afficher le champ de la caméra dans les cartes de l'atlas, il est nécessaire de préciser à ce dernier plusieurs options.

apparence de l'onglet
  • Case à cocher "Activer l'affichage champ CCD" :
    Permet d'afficher une fenêtre montrant le champ du CCD en fonction des informations fournies sur la caméra et le tube optique. (remarque : pour la plupart des caméras CCD, il faut se mettre en zoom x128 au moins pour voir de façon conséquente le champ du CCD sur l'atlas)

  • Case à cocher "CCD utilisateur" :
    Permet de définir les caractéristique de sa CCD pour celle qui ne se situent pas dans la liste définie.

    le CCD utilisateur

    Il est demandé la largeur et la longueur de la CCD juste pour simuler le capteur sur une fenêtre de l'atlas. On peut préciser la taille du capteur de guidage s'il existe et sa distance par rapport au centre du capteur principal.

  • Case à cocher "Caméra CCD" :
    Liste de caméra prédéfinies dans PRiSM. Permet d'afficher sur la carte du ciel la position du CCD de guidage s'il existe et le capteur principal de ces caméras. Utile si on veut connaître les étoiles de guidage disponibles pour la prise de vue.

    apparence du champ CCD avec CCD de guidage

    Pour les caméras avec capteur d'autoguidage (SBIG ou Chungara), en plus du capteur principal, il est affiché par un rectangle blanc transparent la position sur le ciel du capteur de guidage (cette option est bien sûr réservée aux caméras possédant un capteur de guidage : les caméras SBIG et Chungara). Ceci permet de savoir à l'avance si, par exemple, une étoile assez brillante se situe sur le capteur de guidage.

  • Case à cocher "Focale / Angle" :
    La focale de l'instrument doit être indiquée pour connaitre le champ reçu par le capteur . L'angle d'inclinaison doit être repéré et est utilisé pour un repérage par rapport au Nord. En effet, un angle de 0° signifie que le capteur de guidage est alors représenté sous le capteur principal ( = le capteur de guidage est au SUD du capteur principal ce qui doit être le casphysiquement). Un angle de 90° représente le capteur d'autoguidage à l'Ouest du capteur principal.

  • Case à cocher "Activer un champ circulaire" :
    Permet de définir un champ circulaire. Cette option a surtout été créée pour les observateurs sans instruments car il est également possible de définir un grand champ suivant la vlonté de l'observateur.

    apparence du cercle sur la carte du ciel

  • Case à cocher "Images CCD" :
    Caractéristiques des images CCD qui ont été intégrées à la carte du ciel, à partir de l'option du menu contextuel de la carte du ciel.
    Pour voir apparaître les divers renseignements, il faut cliquer sur le signe "+".

  • Bouton "Centrer Carte sur Télescope" :
    Recentre la carte sur la position du télescope, à condition qu'un système de télescope ou des encodeurs aient été déclarés dans PRiSM. Ce bouton fait doublon avec le raccourci au haut de la fenêtre du ciel :
Nov. 2005


Dossier / Graphiques sous PRiSM

DOSSIER > Les graphiques sous PRiSM

Choisir une fenêtre

Lorsqu'on définit une fenêtre rectangulaire, ses coordonnées ne doivent pas être choisies au hasard sous peine de recevoir de la part du programme un message du type : " mauvaise fenêtre X1, X2, Y1, Y2". Il faut obligatoirement choisir X1 < X2 et Y1 < Y2 c'est-à-dire que les 2 côtés à choisir sont d'abord le coin inférieur gauche puis ensuite le coin supérieur droit.

Aller voir aussi la page sur le fenêtrage d'un lot.

La légende des graphes

Au bas de la fenêtre est affiché sa taille.

Il faut cliquer sur l'icône " Réglages " pour avoir accès aux onglets de la fenêtre.

Contenu :

Cliquer sur l'onglet désiré pour une explication

Echelle axe X,Y :

Régler les axes manuellement

Lorsque le graphe s'ouvre automatiquement pour la première fois, les deux cases "Echelle X Automatique" et "Echelle Y Automatique" sont cochées. Si l'apparence du graphe semble correcte, il n'est pas nécessaire de les décocher mais si l'utilisateur désire retravailler les axes, il faut les décocher.
En cas de changement et si on coche à nouveau ces cases, l'apparence du graphe est le même qu'initialement.

Une fois que ces deux boutons sont décochés ( les boutons ne doivent pas obligatoirement être décochés simultanément ) :
On peut régler manuellement les axes X et Y de telle façon à ce que le graphe rentre entièrement dans l'espace qui lui est imparti. On peut même volontairement définir une amplitude Xmin-Xmax petite pour agrandir fortement le graphe ( ou Ymin-Ymax) . Pour corriger le graphique en fonction des valeurs introduites, il faut appuyer sur l'icône icône de mise à jour afin que les nouvelles valeurs soient prise sen compte. Pour l'axe des X, on peut, cependant, déplacer le graphe vers la gauche ou vers la droite en gardant la même amplitude Xmin-Xmax grâce aux deux flèches Déplacer le graphe vers la gauche ou la droite. Les valeurs Xmin et Xmax sont automatiquement changées en fonction du nombre de fois où on clique sur les flèches. Le principe est exactement le même sur l'axe des Y avec l'icône icône de mise à jour et les deux flèches Déplacer le graphe vers le haut ou vers le bas qui indiquent un déplacement vers le haut ou vers le bas.

Faire un zoom in ou out Ces deux icônes bien connus de PRiSM permettent de réaliser différents agrandissement ou réduction automatiques sur le graphe. Cela permet à l'utilisateur de ne pas toucher à tous ce qui a été décrit précédemment. Il va donc de soi que dès qu'un de ces deux icônes a été saisi, les deux premières cases sont décochées.

En bas du réglage sont indiqué les coordonnées du point vers lequel pointe le curseur de la souris et le nombre de points (échantillons) qui forment le graphe.

Général :

Le menu General

Plutôt qu'un long discours, préférez regarder ce schéma explicatif ci-dessous. La signification de chacune des options y est représentée.

Le menu Général

L'icône " Cacher ce panel " permet de cacher les onglets une fois les changements effectuées.

Graphique des échelles :

On utilise le même principe que précédemment.

Le menu Graphique des échelles

L'icône " Appliquer " permet d'appliquer d'un seul coup les options qui viennent d'être changées.

On peut imposer la " fréquence des labels " par puissance de dix. Les labels sont les graduations écrites sur chacun des axes. Le fait de mettre 2 indique qu'on demande que les axes soient gradués de 100 en 100. On peut également mettre des puissances négatives. Rappelons que 103 = 1000 et que 10-3 = 0,001.
Il est conseillé de ne pas mettre trop de labels pour ne pas surcharger le graphique.

On peut voir l'origine des axes en surimpression par rapport au fond graphique ( on peut même en choisir la couleur ). Il n'est pas toujours nécessaire de voir les origines pour que le graphiques apparaissent sur un maximum de surface. Cependant, on peut toujours se débrouiller pour les voir en changeant les limites des axes.

Entrées / Sorties :

Le menu apparaît de la façon suivante

Les options du menu Entrées/Sorties
  • Sauver les données :
    Permet de sauvegarder les données dans un fichier format texte; la structure du fichier est la suivante pour chaque ligne : Xn + tabulation + Yn + retour chariot. Cela permet de rappeler les données ultérieurement sans être obligé de recommencer les calculs.
    Les trois dernières lignes sont réservées aux légendes du graphe de l'onglet "Général".

  • Charger des données :
    Permet de charger des données au format texte précédemment décrit. Des données sauvegardées avec un autre tableur peuvent même être chargées à condition que ces dernières soient sauvegardées au format texte.
    Le format des données est du type suivant : sur chaque ligne, on a la valeur de X suivie par valeur de celle de Y, ces dernières étant séparées par des tabulations ( voir un fichier exemple ).
    Des informations sont alors affichées dans la boite de dialogue sur la nouvelle série de points importée.

Courbes :

Le menu Courbe
  • Courbe n° : Choix de la courbe sur le graphe.

  • Légende et "afficher la légende" : Cette option devient intéressante à partir du moment où on a plusieurs courbes. La légende est à placer dans la zone de saisie et il faut cocher la boite de dialogue.

  • Points liés : A cocher si on désire avoir le résultat sous forme de courbe et pas seulement une succession de points.

  • Labels sur la courbe : Pour chaque point, il s'affiche le nom du fichier d'où a été mesuré ce point.

  • Effacer cette courbe : Efface la courbe sélectionnée dans la première boite de dialogue.

  • Type de point : Choix de l'apparence des points

  • Taille du point : Choix de la taille du point . Si on veut que le point apparaissent franchement, il ne faut pas choisir une taille trop petite.

  • Ep. du trait : Choix de l'épaisseur du trait.

  • Couleur de courbe : Permet de choisir la couleur de la courbe à partir de la palette Windows.

Graphiques :

Le menu Graphique
  • Copier vers le presse-papier :
    Copie la partie graphique ( avec axes et légendes ... ) dans le presse papier afin que ce dernier puisse être retouché si nécessaire dans un logiciel de traitement d'image "grand public".

  • Copier vers le presse papier en Hires :
    Copie le graphe en format haute résolution dans le but de retoucher l'image sous un logiciel de retouche d'images. Ceci produit alors une carte qui a beaucoup plus de pixels et qui est donc plus jolie pour illustrer des pages webs par exemple !

  • Imprimer :
    Permet d'imprimer tout le graphique sur l'imprimante à sélectionner dans la boite de dialogue "Impression" de Windows ... voire même de faxer le graphique à quelqu'un ...

  • Echelle :
    Permet de spécifier le format d'impression. Cette option n'a aucune action sur le format de copie dans le presse-papier.

  • Sauver en XXX :
    On peut sauver le graphe tel qu'il apparaît dans les trois formats proposées. La taille réelle de l'image peut être changée à volonté en dessous des trois boutons de sauvegardes ... Une boite de dialogue WIN XP s'ouvre alors afin de sauver l'image.

Mathématiques :

Le menu Mathématique

Cet onglet permet de réaliser des opérations mathématiques sur les valeurs du graphe. Les opérations doivent être rempli dans l'ordre.

  • Axe des X :
    On ne peut effectuer que des opérations "simples" sur l'axe des X : "Ajouter", "Multiplier par", "Diviser par" et "Soustraire par" une constante. Afin que cette opération ait lieu, il faut ajouter cette opération dans le cadran grâce au bouton du même nom. Dans ce cas, l'opération apparaît mais n'a pas encore été exécutée. On peut alors ajouter dans le cadran autant d'opération voulue (ou en supprimer grâce au bouton du même nom !) avant de lancer le calcul. Attention : Une fois le calcul effectué, il est IMPOSSIBLE de revenir en arrière !!!!

  • Axe des Y :
    Pour cet axe, il est possible en plus de toutes les opérations décrites pour l'axe des X de faire passer une fonction sur les valeurs. Il faut alors choisir l'option "5" : "Fonction". Dans ce cas, les fonctions mathématiques en grisée apparaissent clairement et on peut en sélectionner une. En plus des fonctions mathématiques comme : tan, cos, sin, ln, log et exp, il apparaît les fonctions de lissages sur un plus grand nombre de points. En ajoutant l'opération, celle-ci apparaît dans le cadran SANS avoir été exécutée (et peut même apparaître avec des opérations concernant l'axe des X). Libre à l'utilisateur de cliquer sur "CALCULER". De même que sur l'axe des X : Attention : Une fois le calcul effectué, il est IMPOSSIBLE de revenir en arrière !!!!

Conditions d'activation :
Graphe ouvert

Fonction(s) Script associée(s):
Voir la partie sur les scripts et les graphiques

Prérequis :
Aucun

Nov. 2005


Dossier / Installer ASCOM dans PRiSM

DOSSIER > Installer ASCOM dans PRiSM

Elle se fait en deux étapes, une étape qui se fait une seule fois, qui est l'installation de la plateforme ASCOM v5.0, et du pilote matériel, qui se réalise autant de fois qu'il y a de matériel compatible ASCOM à installer.

Etape 1 : Aller sur le site http://www.ascom-standards.org/

Télécharger la plateforme ASCOM v5.0 et installez la, cette étape ne se fait qu'une fois pour toutes quelque soit le nombre de pilotes matériel que vous allez installer.

Une fois la plateforme installé, elle apparait dans le menu démarrer.

Etape 2 : J'ai un materiel compatibe ASCOM à installer, par exemple, un système de focalisation Optec TCS-F

Sur la page principale d'Ascom, aller sur ASCOM drivers.

Choisir le même type de matériel, par exemple "Focuser"

Choisir Optec TCF (4.0.1) puis télécharger le pilote :

Une fois le pilote téléchargé, l'installer :

C'est fait votre driver est installé.

Etape 3 : Installation dans PRiSM, choisir le menu telescope/configuration

Puis"Focalisation" dans l'arbre, choisir " Focalisation ASCOM"

Puis "Choisir le type de focalisation", choisir Optec TCF-S , puis cliquer sur "Properties..." pour configurer le focuser focuser TCF-S :

Cliquer sur OK et encore OK et voici ce que l'on obtient.

Votre systeme de focalisation est installé, le mettre en marche et s'y connecter avec "Telescope/Etablir communication" pour l'utiliser.

Juin 2008


Pipeline : Connecter son matériel

Tutorial > Connecter son matériel avec PRiSM

Voici un pipeline pour apprendre à connecter son matériel avec PRiSM :

A. Prise en compte du matériel :

Il faut d'abord configurer son matériel pour que le logiciel puisse reconnaître un certain nombre de variables. Ceci se réalise à partir du menu [Telescope] > [Configuration]. Dans ce menu, il est possible de configurer indépendamment les uns des autres et les uns sans les autres, les moteurs, les codeurs, focusers, roues à filtre et dome-observatoire. En ce qui concerne les caméras, on se refèrera à la page ici.

La liste de matériels pris en charge par PRiSM se situe sur le site WEB du logiciel.

B. Connexion :

Attention, dans certaines configurations d'autoguidage, il est nécessaire de connecter l'ensemble télescope-accessoire AVANT la caméra CCD.

Lors de la connexion, le programme indique la réussite ou l'échec de cette connexion.

C. Commander le télescope :

Si un télescope (système complet, codeur et/ou moteur) est connecté, certains paramètres peuvent être changés.

D. Commander le focuser :

Si un focuser est connecté, certains paramètres peuvent être changés.

E. Commander la roue à filtre :

Si une roue à filtre est connecté, certains paramètres peuvent être changés.

F. Commander l'observatoire :

Si un dome est connecté, certains paramètres peuvent être changés.

G. Commander un GPS :

Si un GPS est connecté, certains paramètres peuvent être changés.

H. Lire la station météo :

La station météo ne se lit pas directement. On peut juste récupérer les dernières mesures afin de les intégrer dans les commentaires des entêtes des images CPA ou FITS.

J. Gérer la caméra :

Novembre 2006


Reduire les données concernant le PEC de votre monture

> Tutorial > Mesure de l'erreur périodique

But : En lisant cette page qui explique comment on acquière les données avec une camera CCD, un fichier resultat est obtenu. Voir ici un exemple de fichier obtenu.

Avec une webcam

Il est aussi possible d'acquérir les données avec une webcam. Il faut orienter la webcam de facon a avoir l'axe ALPHA sur l'axe horizontal en X du ccd de la camera.

Le menu "camera/acquisition avec une WEBCAM" permet de controller la webcam, l'onglet acquisition images par images controle la façon de faire une acquisition image par image de la webcam.

Cochez les cases comme indiqué ci dessous.

Image de l'étoile, et repérage :

Prism affiche un graphique avec la position en X, et il produit les deux fichiers suivants :

  • Fichier en vue de l'analyse avec PRISM (ici) (menu [Télescope] > [Analyse de l'erreur périodique])
  • Fichier pour etre analysé avec EXCEL (ici)
Analyse des données

Ce fichier résultat possède deux colonnes, la premiere colonne represente des secondes de temps (ou des secondes d'arc sur le ciel), la deuxieme colonne represente la position en X de l'etoile sur le capteur CCD.

150.215999619104 470.214385986328
153.841000073589 470.578674316406
157.465999899432 469.83984375
161.090999725275 471.042938232422
164.907000074163 470.512603759766
168.531999900006 470.515533447266
172.156999725848 470.592041015625
...
...
1530.9309997363   461.621124267578
1534.58599965088 461.853942871094
1538.26200000476 461.664245605469
#Heure de début : 20-12-2006 19:03:23 Position en X
#Secondes
#Pixels

Voici ce que cela donne :

6 periodes de 240 sec sont visibles, c'est le nombre de periodes minimal necessaire à l'acquisition d'une bonne sequence.

Le menu [Télescope] > [Analyse de l'erreur périodique] permet d'analyser votre fichier.

Il faut rentrer l'echelle en arcsec par pixels en X, ici 0.84 arsec par pixels
La declinaison lors de la mesure en °, ici à +16°.
La periode de l'EP soit en secondes de temps ou en secondes d'arc, dans ce cas la premiere colonne represente des secondes de temps et sur une G-11, la durée de rotation de la vis sur la roue est de 240 sec.

Une fois ces parametres rentrés, on clique sur "charger une courbe" et le calcul se fait dans la foulée.

La premiere courbe a laquelle nous allons nous interesser est celle de la modelisation : la courbe rouge modélise les erreurs périodiques par une fonction périodique à 5 harmoniques : celle ci "théorise" la mesure d'Erreur Periodique (ou EP) de votre monture.

La courbe verte est le resultat de la soustraction entre la mesure d'EP (noir) et la theorie (rouge). Ce residu doit etre le plus plat possible. On remarquera que la mesure d'EP est corrigée d'une erreur de vitesse siderale de la monture (ce qui se traduit par une pente sur la mesure d'EP). La courbe theorique montre une amplitude de 2" (ce qui est excellent pour une monture de type G11 à vis modifiée).

Cette courbe est la transformee de Fourier de la mesure d'EP, les pics donne les periodes et les amplitudes. Par exemple, le pic à 240s à une amplitude de 2"

puis des pics secondaires peuvent etre distingués (5 pics) à 120s : une amplitude de 0.26 arcsec est mesurée, on peut construire la table suivante en fonction des harmoniques de la vis sans fin :

Periode (sec) | Fraction de periode | Amplitude (arsec)
120 | 1/2 | 0.260
80 | 1/3 | 0.340
60 | 1/4 | 0.203
40 | 1/6 | 0.176
30 | 1/8 | 0.267

Ce qui peut s'interpreter comme le fait que toutes les 30s (ou 1/8 de tours), la vis saute de 0.267 arcsec

Le meme raisonnement peut s'appliquer pour la phase

Mais PRISM réalise l'analyse textuelle des graphiques automatiquement :

Nombre d'échantillons : 417
Regression linéaire (y=ax+b) où a=-0.006309, b=4.88 et correlation = -0.84
0.28 Periodes
Nombre d'échantillons : 379
Regression linéaire (y=ax+b) où a=-0.005234, b=4.41 et correlation = -0.80
5.78 Periodes
328 points, de periodes entières.

Pas X= 3.67 arcsec

Amplitude harmonique (0) = 240.00 arcsec, Amplitude = 1.99 Arcsec
Phase harmonique (0) = 240.00 arcsec, Phase = 226.55 Arcsec, ou -154.85°

Amplitude harmonique (1) = 120.00 arcsec, Amplitude = 0.26 Arcsec
Phase harmonique (1) = 120.00 arcsec, Phase = 32.84 Arcsec, ou -170.82°

Amplitude harmonique (2) = 80.00 arcsec, Amplitude = 0.21 Arcsec
Phase harmonique (2) = 80.00 arcsec, Phase = 43.39 Arcsec, ou 151.22°

Amplitude harmonique (3) = 60.00 arcsec, Amplitude = 0.21 Arcsec
Phase harmonique (3) = 60.00 arcsec, Phase = 55.57 Arcsec, ou 154.72°

Amplitude harmonique (4) = 48.00 arcsec, Amplitude = 0.11 Arcsec
Phase harmonique (4) = 48.00 arcsec, Phase = 2.50 Arcsec, ou 65.39°

Ces informations servent ensuite a renseigner les elements de correction de PEC de MCMTII par exemple


Dossier : Le prétraitement des images APN

Dossier > Le prétraitement des images d'APN
L'appareil de test

Comme pour le pretraitement des images CCD, on aura besoin d'offsets maîtres, de noir maîtres et de flat maître. "Maître" signifie que l'image est issue de plusieurs images de base. Le prétraitement des images APN se réalise donc de manière parfaitement identique à celui des images CCD, tout du moins au départ !

On fournit un exemples de telles images. On va admettre que les images du ciel profond ont été acquises de la façon suivante (par exemple) :

  • 6 images de flats, ou de plage de lumiere uniforme, le temps de pose étant le plus court possible pour éviter de devoir soustraire un noir au flat. Ceci n'est pas trop critique car la dynamique du flat "occulte" fortement celle du noir. (51 Mo)
  • 6 images de noir, c'est-à-dire obturateur fermé et un temps de pose égal au temps de pose utilisé pendant la sequence d'acquisition des images; par exemple, ici 30 secondes. (33 Mo)
  • Une image d'offset : cet offset est en fait une image de même dimension que les noirs et flats. Cependant, tous les pixels sont à zéro. Il ne servira que pour la création de master. Pour le prétraitement, l'offset est compris dans les noirs et sera donc soustrait avec à l'imge. Vu les conditions changeantes durant la nuit, il n'est pas recommandé d'utiliser l'optimisation du noir. (9 Ko)
  • 10 images contenant les informations à visualiser. (73 Mo)

Etape 1 : conversion des images :

Les fichiers images provenant d'APN ont un format qui leur est propre et il faut d'abord les convertir en un format que PRiSM puisse travailler, soit le format CPA ou FITS. On pourra preferer le CPA car les images prennent moins de place sur le disque dur. Par exemple ici, des images au format CR2 (fournies ci dessus) doivent être converties au format CPA : sélectionner le format APN comme format de départ. Utilisez le menu [Fichiers] > [Conversion de format de fichiers par lots].
Il faut ainsi convertir toutes les images !

Etape 2 : Création des images "Maitre" noir, flat et offset :

Une fois les images converties au format CPA, nous allons devoir créer des images "maitres ou master" d'offset, de noir et de flats. Cela s'effectue comme d'habitude, comme l'on procède avec des images CCD.

Selectionner le menu de PRISM [Prétraitement] > [Créer flats, noirs, offsets maitres].

Mettre la liste des images dans la 1ère boite (n'oubliez pas que la touche majuscule de Windows permet de selectionner plusieurs fichiers).

Dans l'exemple fourni et durant la prise d'images, les conditions de température ont changées. Il ne sert à rien dans ce cas de vouloir retirer un faible signal d'offset au flat ou de chercher à faire de l'optimisation du noir. En bref, séparer l'offset du noir est inutile dans ce cas. La dernière fonction le demandant pour créer les "masters", il suffit de créer une image de même dimension avec tous les pixels d'intensité nulle.

Si une image d'offset existe, elle peut ressembler à ceci :

L'offset générique qui va être utilisé

Dans ce cas, il faut cocher la case correspondante dans la création de "masters" :

Le résultat apparaît dans les images suivantes :

Noir générique | Le flat générique
Image maitre de Noir Il est possible de créer un fichier de points cosmétiques à partir de cette image. | Image maitre d'un flat.

Bravo ! Nous avons nos 2 ou 3 images maitres de calibration dans le répertoire (suivant la création d'un offset) où étaient situés les images de prétraitements de base. Pour cet exemple, nous avons :

  • Image maitre de calibration Noir : fichier Dark.cpa
  • Image maitre de calibration Flat : fichier Flat.cpa

Etape 3 : Prétraitement automatique :

Selectionner le menu de PRISM [Prétraitement] > [Enlever Offset Noir Flat (auto)].

Dans l'onglet n°1, il faut entrer le chemin et les noms des deux ou trois fichiers de calibration (ici , deux !).

On fournit le chemin des images de prétraitement

S'il n'y pas eu de fichier cosmétique créé, passer directement a l'onglet "APN (3)" et selectionner le bon motif de Bayer, pour CANON c'est le Motif 2. Cependant, certains APN fournissent des images dans l'espace "Cyan/Magenta/Yellow"

Choix de la matrice

Na pas faire de tri dans l'onglet n°4. Autoriser un recalage entre les images dans l'onglet n°5 :

Dans l'onglet n°6, sélectionner le compositage de vos images par addition simple :

Demander l'addition :-)

Dans l'onglet n°8, sélectionner les fichiers qui seront traités.

Morceau de l'image exemple, l'image originale faisant 3522x2348 pixels.

Ici on a affaire à 10 fichiers bruts :

Les 10 fichiers

Cliquer sur "OK" et laisser les opérations se dérouler.

Une fois terminé, le résultat (les images compositées) se trouve dans le repertoire "Result" et les images prétraitées, sans être additionnées sont dans le répertoire "Process". Un fichier LOG de traitement est fourni avec TOUTES les informations lors du prétraitement.

On remarque sur certaines images un problème de gradient de lumière dû à la pollution lumineuse.

Selectionner [Prétraitement] > [Soustraction de fond de ciel] pour enlever cet effet; le calcul doit prendre un peu de temps. Pour exemple :

->

Et voila c'est terminé ! Eventuellement on pourra travailler les balances de couleurs, le constraste et la luminosité.

Images supportant cette fonction :
images RVB

Fonction(s) Script associée(s):
SplitBayerImg

Conditions d'activation :
Avoir une image RVB et les images de prétraitement!

Prérequis :
Savoir prétraiter une image CCD

Voir aussi :
xxxxxx

Version Octobre 2006


Prétraitement ... Qu'est-ce ?

Qu'est-ce que le prétraitement de base ?

Le prétraitement regroupe toutes les opérations obligatoires à faire subir à une image de façon à la rendre exploitable. Pas une mince affaire !
Pour exploiter d'une manière optimale une caméra CCD, il est nécessaire de procéder une correction radiométrique très soignée des images.
L'analyse des caractéristiques des détecteurs a permis de mettre en évidence deux types de parasites qui perturbent plus particulièrement les images.

  • le premier : additif dû à des signaux parasites s'ajoutant au signal utile.
  • le second : multiplicatif résultant de la variation de sensibilité d´un pixel par rapport à l´autre, de la régularité d´amincissement du substrat, du vignettage optique, etc.…

La présence de ces perturbations conduit à l'introduction d'un bruit spatial dans l'image qui aura pour effet de limiter la détectivité du capteur Ccd.
Pour éliminer leurs effets, il est donc nécessaire de soustraire de l´image brute, une approximation des charges additives et de diviser le résultat par une image compensant les charges multiplicatives. C'est l'opération de prétraitement.

  • Charges additives.

    Comme nous l´avons vu précédemment , l´image de sortie d´une caméra Ccd n´ayant subi aucune correction automatique est une image brute. Elle contient non seulement l´information que nous souhaitons extraire et visualiser, mais aussi :

    - Une image hermétique correspondant à la réponse du capteur Ccd pour la pose la plus courte possible et réalisée dans l´obscurité totale : c´est l´image de précharge nommée aussi bias ou offset en anglais. Cette image reste en général invariable quel que soit le temps de pose et la température du capteur et évolue peu au cours de la vie d´une caméra. Elle peut donc être réalisée une fois pour toutes à partir de la médiane d´un lot d´une dizaine d´images.
    Si la valeur de tous les pixels de l´image de précharge est constante (au bruit près), on peut aussi soustraire cette constante de l´image brute plutôt que de soustraire l´image de précharge bruitée.

    - Une image correspondant à la réponse thermique du capteur de la caméra pour un temps de pose et une température donnés faite dans l´obscurité totale. C´est le Noir ou Dark en anglais. Pour être valable, cette image doit normalement être réalisée dans les mêmes conditions que celles de l´image à traiter. S´il n'y a généralement pas de problèmes en ce qui concerne la durée du temps de pose, il peut ne pas en être de même pour garder constante la température Ccd.

    - soit la température est très basse (inférieure à -80°C) dans ces conditions les charges thermiques sont faibles et peuvent même être considérée comme négligeables.

    - soit la température est connue (au 1 /10e de degré près) et il est possible de réaliser l´image du noir en différé avec des conditions similaires.

    - soit la température n´est pas connue. Il est alors nécessaire de réaliser l´image du noir avant ou aussitôt après celle de l´objet à traiter.

    De cette manière on passe autant de temps à faire des images qu´à faire des noirs. Dans le cas d´images du ciel profond, cela peut devenir intolérable. C´est pourquoi en 1990 Christian Buil publia une méthode originale basée sur le fait que les noirs sont proportionnels les uns par rapport aux autres quel que soit le temps de pose et la température. C´est la méthode d´optimisation du noir.
    Cette méthode consiste à appliquer au Noir synthétisé à partir d´un maximum d´images un coefficient ajusté de telle manière que la variation de l´intensité des pixels d´une petite zone de l´image soit minimum (en évitant si possible les étoiles). Il est entendu que ce noir synthétique devra être corrigé de l´offset avant de subir l´application du coefficient d´optimisation. Cette méthode peut être mise en échec lorsque l´image à traiter contient un si grand nombre d´étoiles que le fond de ciel n´est plus visible.

  • Charges multiplicatives.

    Les informations correspondant aux écarts de sensibilités des divers photosites du Ccd auxquels s´ajoutent d´autres tels que poussières ou vignettages optiques constituent, comme nous l´avons vu précédemment, les charges multiplicatives. Ces informations sont mises en évidence dans une image réalisée sur un fond ciel brillant et uniforme. C´est la plage de lumière uniforme (P.L.U.) ou flat-field en anglais.
    Elle contient aussi l´image de précharge. Il est absolument essentiel que la P.L.U. soit réalisée dans des conditions identiques à celles de l´image à traiter (même télescope, même filtre, plus généralement même combinaison optique jusque et y compris le capteur). Cela implique que la caméra ne doit pas être démontée entre la capture des images à traiter et celles de la P.L.U., sous peine de rendre la correction de flat-field inopérante.

L´opération "basique" de prétraitement consiste à soustraire l´image du noir ainsi que de la précharge et à diviser le résultat obtenu par l´image de flat-field à laquelle on associera une constante dont la valeur devra correspondre à la moyenne de tous les pixels de la P.L.U.

L´ensemble de ces trois opérations peut se faire d´une manière automatique (voir Enlever offset, noir, flat (auto)) ou d´une manière plus ponctuelle, image par image (voir pour cela Enlever offset, noir, flat).

A chacune de ces opérations, on améliore la qualité du signal, mais on ajoute aussi du bruit car les images de précharge, Noir et P.L.U. sont elles-mêmes bruitées. Il convient donc de synthétiser les images de calibration pour minimiser le bruit (voir la fonction Créer ONF Maîtres).

  • Opérations de prétraitement moins basiques !.

    D'autres opérations de prétraitement peuvent être appliquées :

    • Les opérations cosmétiques : Consiste à corriger l'image de ses points chauds. Il faut d'abord créer le fichier cosmétique à partir du noir maître et ensuite, durant les prétraitements automatique, faire corriger l'ensemble de ces points par le programme.
    • Création de faux flats, recalage d'images et additions spéciales d'images font parti aussi des prétraitements. Ils ne sont pas obligatoire et demandent d'aller voir l'aide sur chacune des parties concernées.
Version Aout 2006


Dossier / Le format RAW et la matrice de Bayer

Dossier > Le format RAW et la matrice de Bayer
  1. I. Les images RAW :

Dans un appareil photo numérique ou pour tout capteur dit couleur, la constitution du capteur est la suivante :

  • Un capteur silicium type CCD : Par définition ce capteur est constitué de pixels et est monochrome.
  • Un jeu de filtres : Chaque pixel est recouvert d'un filtre correspondant à un jeu de couleurs : RVB ou CMY.

Pour un APN ou une WEBCAM, lorsque la "photographie" est prise, le capteur est lu par l'appareil. Avant de fournir une image à l'utilisateur, l'appareil va traiter cette image en interne pour l'enregistrer au format communément JPEG et/ou ne pas la traiter en profondeur pour l'enregistrer telle quelle, mais cette fois au format RAW (ce choix est laissé à l'utilisateur). Dans ce dernier cas, l'image obtenue est sauvegardée avec une extension propriétaire qui permet d'indiquer au logiciel de lecture les infos de l'entête dans un ordre cjoisi par le concepteur de l'appareil comme par exemple le jeu de filtres colorés utilisé. Comme extension, on rencontre par exemple chez CANON l'extension CRW, NEF chez NIKON et PEF chez PENTAX.

L'image obtenue dans ce cas est caractéristique d'une image au format RAW (on peut parler d'image brute en astronomie) qui semble pixelisée. Ceci est normal puisque des pixels voisins munis de filtres de couleurs différents ne sont pas impressionnés de manière identique.

Un exemple d'apparence d'image RAW (monochrome)

Ces images apparaissent sous forme monochrome et n'ont donc subies qu'un minimum de traitement cosmétique après lecture de la part de la marque propriétaire de l'appareil. Elles peuvent donc être considérées comme brutes et d'un point de vue astronomique, ce sont celles à utiliser dans la mesure du possible.

  2. De l'image RAW à l'image couleur :

ans un appareil photographique, une fois que la lecture du CCd effectuée ainsi que le minimum de traitement effectué (image RAW), l'appareil se charge du traitement électronique afin de passer d'une image monochrome à une image couleur. Chaque pixel est codé sur 12 (4096 pas codeurs) voire 14 bits pour les appareils les plus récents. Comme les filtres couleurs devant chaque pixel sont connus, il est donc possible de passer à une image couleur, où chaque pixel contient 3 valeurs correspondant aux 3 composantes de couleur choisies, chacune étant cette fois codée sur 8 bits (256 pas codeurs).

D'un point de vue astronomique, en aprtant de l'image au format RAW, il suffit donc de connaître l'agancement des filtres de couleur devant chaque pixel pour reconstituer une image couleur. Cet agancement de filtres devant chaque pixel se nomme "matrice de Bayer".

  3. La matrice de Bayer :

Dans le système RVB, chaque pixel est recouvert d'un filtre coloré rouge, vert ou bleu selon l'agencement suivant :

L'agencement des filtres

Comme on peut le voir sur la figure ci-dessus, l'agencement est donc toujours le même. Il reste à connaître par quels types de filtres colorés est constitué le carré formé par les 4 premiers pixels d'une image situé au coordonnées X et Y valant 1 et 2. A chaque fois que PRiSM propose de traiter une image nécessitant la connaissance de l'ordre des filtres de ce carré 2x2, le motif est demandé :

Le motif n°1 | Le motif n°21 | Le motif n°3 | Le motif n°4
Le motif n°1 | Le motif n°2 | Le motif n°3 | Le motif n°4

Par exemple, CANON utilise le motif n°2 dans ses appareils reflex du type EOS 300D, 350D et 400D.

Ensuite, pour chaque pixel de l'image, les valeurs RVB de l'image couleur sont données par une moyenne des valeurs des signaux des pixels voisins (cette moyenne est pondérée ou non suivant la fonction utilisée :

Pour un point de l'image qui correspond à un pixel rouge du capteur : R = Signal du pixel rouge. V = Moyenne des signaux des 4 pixels verts voisins. B = Moyenne des signaux des 4 bleus verts voisins. | Pixel rouge au milieu
Pixel vert au milieu | Pour un point de l'image qui correspond à un pixel vert du capteur : R = Moyenne des signaux des 2 pixels rouges voisins. V = Signal du pixel vert. B = Moyenne des signaux des 2 pixels bleus voisins.
Pour un point de l'image qui correspond à un pixel bleu du capteur : R = Moyenne des signaux des 4 pixels rouges voisins. V = Moyenne des signaux des 4 pixels verts voisins. B = Signal du pixel bleu. | Pixel bleu au milieu

Ce principe permet donc de fournir 3 valeurs à chaque pixels correspondant aux 3 filtres RVB

On rencontre maintenant de plus en plus de capteurs avec des filtres CMY (Cyan, Magenta et Jaune). Jusqu'à maintenant, seul la synthèse de ces filtres posait problème. Ils ont l'avantage d'avoir chacun une bande passante plus large que les filtres RVB correspondant ce qui leu confère plus de sensibilité. L'organisation de la matrice CMY ressemble à celle de la matrice RVB :

Dans le cas de l'usage d'un capteur ayant des filtres CMY, PRiSM garde les mtifs RVB dessinés (qui selon l'image ci dessus sont facilement identifiables au motif CMY du capteur) mais propose ensuite de convertir les résultats obtenus normalement dans le système CMY dans le système usuel RVB :

Remarque : Lors de la convertion d'une image monochrome RAW en image RVB (par l'intermédiaire d'un système CMY ou non), tous les calculs de moyenne effectués à parti des pixels voisins altère la capacité de la matrice à résoudre des fins détails et on a donc une perte de résolution du capteur par rapport à ce qu'on pourrait obtenir pour un capteur monochrome. C'est pour ça qu'on a l'habitude dire qu'un capteur de 1000 x 1000 couleur a la même résolution qu'un capteur 500 x 500 monochrome. D'un point de vue astronomique, afin de ne pas dégrader la résolution de l'image couleur, on utilise la technique du LRGB obtenu à partir du menu [Trichromie] > [Assembler 4 images LRVB]

  4. La balance des blancs :

Le principe est simple : un pixel normalement blanc doit apparaître blanc ! Suivant les capteurs utilisés, on a des rendements quantiques différents pour les pixels filtrés et des traitements internes effectués à la lecture différents suivant les appareils. Il est alors parfois nécessaire d'accentuer par exemple le rouge par rapport aux autres couleurs ... bref, de donner des coefficients aux différentes couleurs d'un pixel donné de façon à obtenir des couleurs réalistes. Cette action s'appelle "régler la balance des blancs". Pour des APN, la balance est normalement réglée correctement par défaut et pour les utilisateurs qui par exemple défiltrent partiellement ou totalement leur capteur, il est alors nécessaire de modifier cette balance pour obtenir à nouveaux des couleurs réalistes.
A partir d'une image RAW (monochrome), il est possible de forcer les valeurs de ces coefficients. Ceci a lieu à partir du menu [Trichromie] > [Equilibrer les pixels d'une matrice de Bayer]. Pour le moment, cette fonction n'est pas automatique mais pourrait à terme le devenir.

Fonctions scripts associées :
Fonctions APN

Version Janvier 2008


Dossier / Méthode de morphing pour le recalage planétaire

> Dossier > Méthode de morphing pour le recalage des images planétaires

Image prise au pic du Midi, T1M, Copyright F.Colas, J.Lecacheux

Quand on s'amuse à prendre des images de planètes, on ne se limite pas en général à prendre une seule image. On se retrouve souvent avec beaucoup d'images. Après avoir sélectionné les meilleures, on essaye de les additionner pour en augmenter le rapport signal sur bruit, et faire ressortir les plus fins détails avec un masque flou, par exemple.
Voilà pour le côté basic...

Parlons maintenant des algorithmes. L'addition ne pose pas de problèmes, il s'agit plutôt d'être capable de superposer les images les unes sur les autres.
Parmi les algorithmes les plus connus, on trouve

  • tout d'abord le blink, qui consiste à recaler les images à l'oeil et au doigté en faisant clignoter celles-ci les unes sur les autres et en jouant du clavier (Menu -> Analyse / Blink)
  • Il existe la méthode par intercorrelation dans le domaine spatial (Menu -> Prétraitement / Recalage en série) ou dans l'espace de Fourier (Menu -> Traitements / Fourier).
  • Il y a aussi d'autres méthodes plus compliquées.

Cependant, toutes ces méthodes ont un défaut majeur : elles ne prennent pas en compte les déformations/distorsions des images qui sont dues à la turbulence : c'est l'angle isoplanétique . Cet angle définit une région de cohérence ou le front d'onde est invariant : il est de quelques secondes d'arc dans le visible comparé a une planète de plusieurs dizaines de secondes d'arc de diamètre. La planète est alors complètement distordue.

Habituellement, une translation sur les images est appliquée et on dit qu'il s'agit alors d'une transformation du premier ordre : mais, elle ne compense en rien les distorsions de la planète.
Sur la "vidéo" de Saturne (celle qui clignote, juste en dessous), on essaye de superposer 2 images de saturne, prises avec le même télescope et à quelques secondes d'intervalle. Or, il n'est pas possible superposer l'ensemble de la planète car l'échelle est différente. Quand on veut recadrer le haut, on perd le bas, et inversement.

Cet effet est dû à l'atmosphère, lorsqu'on utilise un temps de pose très court afn de figer la turbulence. Malgré la résolution élevée sur de petits détails, on a des effets de zoom et des déformations à des échelles plus grandes.
Si on ne possède pas de télescope spatial dans son jardin, histoire de s'affranchir de la turbulence, on peut toujours essayer de trouver une solution logicielle. Après tout, en France, on n'a pas de HST, mais on a des idées (on le rabâche assez souvent).
Il suffit alors de déformer à nouveau les images afin d'ajuster le haut avec le bas, et les morceaux les uns avec les autres. On appelle cette transformation du morphing.

Parlons maintenant de choses sérieuses, de mathématiques.... si vous avez déjà la nausée, reportez-vous directement au chapitre des résultats, un peu plus bas.
En gros, on veut trouver une fonction mathématique qui transforme une image vers sa version redéformée, et qui va se superposer au mieux avec l'image qu'on veut additionner. On peut utiliser pour cela un polynôme (p(x,y)=a+b.x+c.y+d.x^2.....).
On se donne ensuite un critère mathématique, basé sur l'algorithme des moindres carrés qui va nous permettre de déterminer la solution optimale :
Min((I1-I2)^2)......
Si vous voulez toujours en savoir plus, cliquez ici.

Les résultats

Après quelques secondes de calcul, le logiciel superpose au mieux les 2 images. On peut maintenant les additionner en toute quiétude, ou presque ...

Avant

et après...

Le côté pratique

L'interface dans Prism se trouve sous la forme suivante:

  • Le paramètre "Degré du polynôme" indique la complexité avec laquelle on va déformer l'image. Un degré 0 correspond a une translation toute bête. Un degré 1 est plus compliqué (modification de l'échelle, ...), un degré 2 est encore plus compliqué, et ainsi de suite, avec des temps de calcul d'autant plus longs.
    Il ne faut pas abuser de ce paramètre, ce qui veut dire ne pas mettre 100... ou même 10.
  • Le paramètre "Nombre d'itération" permet de donner le nombre de boucles de calcul qu'on autorise à l'algorithme pour se rapprocher de la solution. Plus on utilise un polynôme de degré élevé, et plus ce paramètre a tendance a être élevé, avec des temps de calcul toujours plus longs. Une moyenne de 15 pour un polynôme de degré 2 semble être largement suffisante.
  • Le logiciel vous demande ensuite de sélectionner les 2 images que vous voulez superposer.

Tips and tricks (astuces et déboires):

Les images doivent satisfaire a une minimum de critère.

  • Tout d'abord, avant de lancer l'algorithme, la planète doit obligatoirement se recouper entre les 2 images. Un morceau de la planète doit manger un autre morceau de la planète lorsqu'on superpose les images. Dans le cas contraire, l'algorithme ne peut pas converger.
  • Il est conseillé aussi d'avoir une moyenne nulle sur le fond de l'image, même si ce n'est pas indispensable. Pour les matheux, ça rend le critère sur les moindres carrés un peu plus convexe et donc plus facile à résoudre.
  • Il ne faut pas non plus avoir de pixels parasites dans l'image.

Exemple : Dans l'image suivante, les contours ont des valeurs aberrantes (pixels brillants).

Il faut éliminer ces pixels aberrants qui ne correspondent à aucune réalité physique. On peut remplacer ces valeurs par la moyenne du fond de ciel.
Dans le cas contraire, on s'expose à avoir des images plutôt originales, pas toujours complètement laides :

Un dernier conseil : il est possible que l'algorithme échoue (ce n'est pas toujours le cas) si l'ensemble de l'objet n'est pas visible, comme pour les images suivantes:

Pour la Lune, dont seulement un morceau est généralement visible, l'algorithme convergera moins bien mais peut bien marcher aussi ...

Images supportant cette fonction :
Séquence film AVI

Version 2003


Dossier / Reconnaissance des champs stellaires

DOSSIER > La reconnaissance des champs stellaires

La méthode des triangles

Le but de cette page n'est pas de décrire entièrement la reconnaissance des champs stellaires. Cette dernièr a juste pour but de décrire les paramètres importants réglables dans PRiSM. Afin de préciser ces paramètres, il est essentiel de savoir à quoi ils servent !

Initialement, on s'imagine en présence de deux catalogues stellaires : d'un côté, le catalogue stellaire étalonné (du genre catalogue USNO, GSC ...) où chaque objet est décrit par sa magnitude et par ses coordonnées (AD,DEC) et d'un autre côté, le catalogue stellaire provenant de l'image elle-même où chaque étoile est identifiée par son flux et ses coordonnées (X,Y) dans l'image. Le but de cette page est d'expliquer le cheminement pour établir une correspondance entre les deux catalogues.

Extraction

  1. Extraction des étoiles du catalogue de référence. Classement par ordre de flux décroissants et donc de magnitudes croissantes. Les résultats sont du type :
    2. #      X      Y       Mg     Alpha =          Delta =
1      682.1  272.5   4.9    03h14m54.100s    +21°02'40.04''
2      209.4  556     7.7    03h15m45.890s    +21°09'54.35''
3      445.6  327.9   10.5   03h15m20.000s    +21°04'04.97''
4      67.19  257.2   10.6   03h16m01.425s    +21°02'16.12''

    (X,Y) sont ici les positions auxquelles on s'attend à trouver l'objet sur l'image.

  2. Extraction des étoiles de l'image et classement par ordre de flux décroissants. Les résultats sont du type :
    3. #   Xccd    Yccd      -> Image
1   143.6   613.5
2   981.5   433.4
3   855.9   492.6
4   275     516.4
Identification

L'identification est un point crucial de l'algorithme. Il consiste à chercher toutes les combinaisons de triangles existants à partir de chaque étoile pour rejoindre les autres étoiles. Leur nombre Ntriangle peut être très important et varie comme Ntriangle = Nobj(Nobj-1)(Nobj-2)/6. C'est pour cela que sous PRiSM, cette reconnaissance est effectuée d'abord sur les objets les plus brillants et si leur nombre est insuffisant, la comparaison est poussée pour les objets les plus faibles. L'expérience montre qu'il vaut mieux que la reconnaissance fonctionne pour les objets les plus brillants car elle a peu de chance de fonctionner avec les objets les plus faibles (bruit important). Un exemple est fourni ci-dessous :

Un triangle défini à partir des étoiles du catalogues | Le même triangle retrouvé sur l'image

Pour chaque étoile, il est donc tracé tous les triangles possibles reliant cette étoile aux objets les plus brillants de l'image. Pour chaque triangle, "a" est le côté le plus long alors que "c" est le plus court.

Les triangles ainsi formés à partir des deux listes des objets sélectionnés sont représentées sur un graphe à deux dimensions avec en abscisse la grandeur [image] et en ordonnée la grandeur [image]. On obtient alors un graphe de la forme suivante (fourni sur 4 triangles) :

Lors de l'identification (dont on passe l'algorithme ici), on voit clairement que les points correspondants aux triangles verts (pour le catalogue) et jaunes (pour l'images) sont comparés. La marge d'erreur sur la position dans le graphe est un paramètre réglage de PRiSM. : les triangles sont considérés comme identiques s'ils sont à une distance plus petite que D les uns des autres dans "l'espace des triangles", cette grandeur étant fixée par l'utilisateur. Seuls de telles premières identifications sont conservées.

Mais, QUI est QUI ?

Une dernière étape, et non des moins complexes, consiste à retrouver les étoiles correspondantes aux triangles retenus. On en présente très grossièrement le principe ici :

L'idée est basée sur le fait suivant : quand il y a un objet commun entre les deux listes, Il y aura un très grand nombre de triangles en commun faisant intervenir cet objet. En d'autres termes, un objet de la première liste sera à la base de beaucoup de triangles identiques à ceux de l'objet correspondant dans la deuxième liste. Dans une liste de Nobj objets, un objet est à la base de Nobj(Nobj-1)/2 triangles. Si l'objet est en commun, ces triangles devraient se retrouver dans la deuxième liste ce qui n'est pas parfaitement le cas, dus aux distorsions ou mauvaise distance focale indiquée ou autres paramètres assez aléatoires. Cependant, l'expérience prouve que cette technique fonctionne significativement.
D'où l'idée de créer une "matrice de vote" de dimension Nobj x Nobj dont tous les élements sont nuls initialement. Cette matrice permet de compter le nombre de triangles correpondant à l'objet i de la liste 1 en commun avec l'objet j de la liste 2. En cas de succès, le nombre en [i,j] est incrémenté de 1. Les plus grands nombres seront alors les gagnants ! Et voilà les étoiles repérées ...
Afin de valider ou de diminuer le temps de comparaison, il est possible de vérifier à l'aide du flux des objets si ces triangles peuvent bien être retenus.

En résumé, l'utilisateur comprendra facilement que plus le nombre de triangles est important, plus le calcul sera long (quoique peu perceptible à l'heure actuelle grâce à la puissance de calcul des machines) mais alors, plus le résultat aura de chance d'être viable.Des détails pourront être trouvés dans les deux publications en bibliographie.

La Transformation

Il reste maintenant à trouver les paramètres de transformation de plaques. Si (X,Y) sont les coordonnées de l'objet dans le catalogues de référence et (X',Y') sont celles du même objet dans l'image, dans le plus simple des cas, on obtient :

Ici, comme il y a 6 inconnues, il faut un minimum de 6 étoiles reconnues afin d'établir ces paramètres. Ces derniers sont établis par la méthode des moindres carrés ("least-squares"). Par cette technique, on obtient un résidu pour chacune des 6 étoiles en commun. Ce résidu est important dans le réglage des paramètres de reconnaissance sous PRiSM. Il est possible avec un tel algorithme d'ajuster au mieux les 6 paramètres en tenant compte de plus de 6 étoiles reconnues.

6 paramètres avec 50 étoiles reconnues

Plus il y a d'étoiles en commun, et plus il est possible de choisir un polynome de fort degré pour la transformation. Attention cependant à ne pas choisir non plus un polynôme de degré trop élevé sous peine d'introduire des distorsions non justifiées lors de l'établissement des paramètres de plaques.

The End !

Reste ensuite à l'utilisateur de vérifier que l'identification n'est pas complètement absurde :

Fonction(s) du menu associée(s):
Astrométrie automatique, Photométrie automatique, Recherche automatique d'astéroïdes, Composition automatique, Option de reconnaissance d'étoiles.

Bibliographie :
FOCAS Automatic Catalog Matching Algorithms
Pattern Matching With Differential Voting and Median Transformation Derivation.

Version Mars 2006


Correction de blooming

La correction du blomming avec PRiSM

Les CCD présentant des défauts de BLOOMING sont encore bien fréquents, bien qu'aujourd'hui, tous les nouveaux CCD comportent des dispositifs anti-blooming dégradant trés peu les performances de rendement quantique (cf KAI-11002 dans STL-11K).

Dans PRiSM, il existe une fonction qui tente d'enlever le blooming sur les étoiles. Ce n'est pas une fonction facile à coder...et je resterais trés modeste la dessus : j'avais commencé fin 2007 à implémenter une fonction anti-blooming, mais elle n'était pas trés efficace... J'ai repris ces derniers temps (Mars 2009) le travail là dessus suite à une foultitude d'images qui en sont affectées.

Cette fonction doit supprimer les horribles rayures verticales causées par les étoiles trop brillantes SANS ajouter d'artéfacts (ou du moins les minimiser) ! Elle n'a pour vocation que des application pour les belles images, il ne faut pas l'utiliser pour des usages scientifiques des images.

Cela peut être trés utile comme fonctionnalité, dans la mesure où l'enlevement du blooming "à la main" avec un logiciel comme PaintShop Pro ou Photoshop avec ses tampons duplicateurs est une opération assez laborieuse (surtout avec des images à grand champ faits par de grands CCDs).

Cette fonction n'a été validée QUE sur des images brutes, et sur ce type de blooming où la figure de blooming est bien nette et les étoiles sont fines, et elle ne doit être utilisée que sur des images BRUTES, jamais sur des images prétraitées !

Elle a été intégrée dans la fonction de pré-traitement de PRISM, permettant le traitement de l'image brute AVANT TOUT pré-traitement.. Mais elle est aussi active dans le menu traitements pour usage sur une image seule.

Voici son intégration dans les prétraitements automatiques :

Exemple :

Voici une image de NGC 4258, réalisée avec un telescope de 250mm F/3.5 (870mm de focale) sans Filtre, et un KAF-6303 installé dans une camera Chungara. L'image finale est formée de 13 poses individuelles de 300s (soit 1h05 de pose totale).

Si un artefact régulier consécutif au nettoyage de blooming était présent sur les images brutes individuelles (celles qui sont nettoyées), l'addition de 13 images plus un Log montrerait sans équivoque la trace de ces artefacts ! Or ce n'est pas le cas : ceci prouve l'efficacité de la fonction.

Les images de comparaison presentées sont issues de la même somme translatée de 13 images brutes, débarassées individuellement de leur flat/offset et noir. Dans un cas le nettoyage du blooming a été activé, dans l'autre cas il a été désactivé.

Une operation Log a été effectuée afin de montrer tous les niveaux de gris (ou de montrer le coeur brillant des étoiles et le bruit de fond de ciel).

Il est presenté des fenetres d'une image de 3072 x 2048 pixels avec un pixel CCD = un pixel écran.

La largeur à mi hauteur des étoiles (FWHM) est de 1.7 pixels sur les images brutes, soit 3.55" de résolution.

A gauche, avec l'optioon de de-blooming activé dans le pré-traitement, à droite sans le dé-blooming dans le prétraitement.

Les deux images ont subit le meme traitement Log, les seuils de visualisation sont identiques.

Fenêtre 1 :

Cela a été plutot efficace puisque l'étoile la plus brillante du champ (mag 6.4) a été debarassée du blooming. Ainsi que des étoiles plus faibles.

Fenêtre 2 :

La aussi, les trois étoiles sont plutot bien nettoyées de leur blooming.

Fenêtre 3 :

En rouge des étoiles bien nettoyées de leur blooming. Mais en Jaune, quelques artéfacts sont visibles, une etoile qui se trouvait pile en dessous du blooming d'une étoile brillante (1) qu'il faudra reprendre à la main, et (2) la galaxie a subit aussi un leger artéfact.
- Ce sont, sans doute, là les limites de cette fonction -

Fenêtre 4 :

Le nettoyage a fonctionné (cercles rouges), mais une étoile brillante sur le bord de l'image n'a pas été completement nettoyée (1). Les étoiles plus faibles ont leur "petit blooming" parfaitement nettoyé (Hauteur min de blooming = 5 pixels).

Il reste sans doute des améliorations à effectuer sur cette fonction dans le futur.... pour le nettoyage final, le tampon duplicateur reste encore un outil utile (Prism ne disposant pas encore de cette fonctionnalité), mais il faut admettre que le plus gros du travail de nettoyage du blooming s'est effectué avec succés et que cette fonction a une réelle valeur ajoutée ...

Vous trouverez ici l'image en "Pleine résolution" de NGC 4258 avec déblooming et sans déblooming lors du prétraitement.

Version Avril 2009


Les paramètres de visualisation

Dans cette partie, nous allons examiner la représentation d'une image.

Il ne faut perdre de vue que la seule chose que le programme connaît est une succession de chiffre ( image numérique ... ). Chaque chiffre est en rapport avec l'intensité lumineuse qu'a reçu le capteur durant la pose. Plus ce chiffre est important, plus le capteur aura reçu de lumière. Il faut donc trouver un moyen de représenter une image fidèlement à l'écran avec " une couleur " de plus en plus blanche que l'intensité reçue aura été importante.

Lorsqu'une image est affichée à l'écran, un pixel de l'écran représente un pixel de l'image. La taille de l'écran est défini à partir du menu " Affichage '" de Windows. Une image très grande peut, suivant la défintion, ne pas rentrer entièrement dans l'écran. Des barres de défilement horizontale et/ou verticale seront alors proposées pour circuler sur l'image.
Il est à noter que les pixels de l'écran étant carrés, la représentation d'une image obtenue à partir d'un capteur aux pixels rectangulaires ne sera pas exacte. Il faudra alors utiliser le menu "Transformation / Homothétie" pour agrandir ou diminuer physiquement les pixels du capteur dans le rapport des cotés des pixels du capteur.

La représentation Noir et Blanc :

La façon la plus simple de représenter une image est de l'afficher en Noir et blanc ( ou monochrome ) c'est-à-dire la représenter suivant différents niveaux de gris. PRiSM affiche les images monochromes ( Black and White en anglais ) suivant 256 niveaux ce qui est largement suffisant pour afficher une telle image, l'œil ne distinguant plus ensuite les niveaux supplémentaires!

Afin de représenter naturellement une image, on utilise la technique suivante :
Les pixels qui ont des valeurs importantes en intensités sont ceux qui ont reçu le plus de lumière. On les représente alors par des pixels de " niveaux de gris " qui se rapproche d'autant plus du blanc que l'intensité est importante. A l'inverse, plus l'intensité du pixel est faible, moins il a reçu de lumière, et plus sa représentation à l'écran sera noire.
Cependant, il ne faut pas oublier que les images astronomique du ciel profond ont des pixels " intéressant " que sur une plage de luminosité très faible. On défini alors deux paramètres importants de la représentation :

  • Le seuil bas, qui représente l'intensité de référence minimum d'un pixel. Tous les pixels qui auront une intensité inférieure à ce pixel de référence seront représentés en noir sur l'écran.
  • Le seuil haut, qui représente l'intensité de référence maximum d'un pixel. Tous les pixels qui auront une intensité supérieure à ce pixel de référence seront représentés en blanc sur l'écran.

On échelonne ensuite les 256 niveaux de gris entre ces deux seuils. Cet échelonnage se fait suivant une table de transcodage encore appelée LUT ( Look Up Table en anglais ). Comme le lecteur l'a compris maintenant, cette LUT va servir à établir une correspondance entre la valeur de l'intensité d'un pixel et sa représentation à l'écran.
Cette LUT peut être représentée sous forme linéaire ou sous une tout autre forme comme logarithmique ou en dent de scie.

Afin de mieux comprendre la signification d ela table de transcodage, prenons un exemple simple :
Considérons une représentation codées sur 8 bits ( 256 niveaux en ADU ). Supposons que l'on ait à notre disposition 8 niveaux de gris ( 3 bits ) régulièrement échelonnés du noir vers le blanc :

Considérons une partie d'une image. On donne les valeurs en ADU des pixels ( que l'on obtient facilement avec le menu " Prétraitements / Voisinages " ), c'est-à-dire ce le programme retient de l'image en mémoire.

10 | 20 | 10 | 56 | 125 | 10 | 12
23 | 45 | 23 | 45 | 120 | 45 | 11
45 | 89 | 69 | 96 | 96 | 23 | 16
89 | 250 | 56 | 125 | 110 | 50 | 15
45 | 89 | 89 | 80 | 120 | 56 | 10
12 | 50 | 60 | 50 | 23 | 25 | 11
12 | 11 | 10 | 12 | 11 | 10 | 12

En considérant une LUT purement linéaire de 0 ADU à 255 ADU, on aurait 32 pas codeurs ( ADU ) entre chaque niveaux ( = 256 / 8 ) :

entre 0 ADU et 31 ADU :
entre 32 ADU et 63 ADU :
entre 64 ADU et 95 ADU :
entre 96 ADU et 127 ADU :
entre 128 ADU et 159 ADU :
entre 160 ADU et 191 ADU :
entre 192 ADU et 223 ADU :
entre 224 ADU et 255 ADU :

Ce qui se traduirait par la courbe suivante :

LUT purement linéaire
Attention : A la suite de notre exemple, cette courbe devrait être représentée par paliers successifs puisqu'on utilise uniquement 8 niveaux en ordonnée. Cependant, dans la réalité, on utilise 256 niveaux ce qui provoque une apparence continue et non plus par palier.

En ordonnée, on a tracé les différents niveaux ( du noir au blanc ) et en abscisse, on recontre les différentes intensités représentées en mémoire par un nombre sur 8 bits ( de 0 à 256 ). L'image a alors l'apparence suivante et les détails dans l'objet ressortent peu; seule l'étoile apparaît surplombant le reste ...

Cependant, on voit en regardant l'extrait d'image que l'information sur l'objet a lieu entre 45 ADU et 125 ADU. Il faut donc faire apparaître un dégradé maximum sur les informations qui nous intéresse ! L'utilité des seuils bas et haut apparaîssent ici; suivant la définition des seuils, tous les pixels qui auront une intensité en ADU inférieure à celle du seuil bas seront tous à la même couleur, c'est-à-dire dans le cas d'une représentation noir et blanc positive seront tous en noir. De même, tous les pixels qui auront une intensité en ADU supérieure au seuil haut seront représenté en blanc. On disposera maintenant toujours de 8 niveaux de gris mais à échelonner, ici linéairement, entre le seuil bas et le seuil haut ! Des détails apparaîtront alors visuellement, ce qui n'était pas le cas pour un échantillonnage purement linéaire !
La LUT a alors l'apparence suivante :

la LUT linéaire en tenant des seuils bas et des seuils haut !
Attention : A la suite de notre exemple, cette courbe devrait être représentée par paliers successifs entre les 2 seuils puisqu'on utilise uniquement 8 niveaux en ordonnée. Cependant, dans la réalité, on utilise 256 niveaux ce qui provoque une apparence continue et non plus par palier.

Si on fixe le seuil bas à 44 et le seuil haut à 124, on obtient la LUT précise suivante :

entre 0 ADU et 44 ADU :
entre 45 ADU et 56 ADU :
entre 57 ADU et 69 ADU :
entre 70 ADU et 83 ADU :
entre 84 ADU et 96 ADU :
entre 97 ADU et 109 ADU :
entre 111 ADU et 123 ADU :
entre 124 ADU et 255 ADU :

En effet, on doit loger 6 niveaux de gris entre les seuils bas et haut ( du niveau 2 à 7 , le niveau 1 étant le noir en-dessous du seuil bas et le niveau 8 étant le blanc au-dessus du seuil haut ) ... soit loger 6 niveaux dans 80 ADU. Le niveau 2 commencera donc au "seuil_bas+1" ADU et le niveau 7 se terminera au seuil "seuil_haut-1" soit un niveau tous les 80/6 = 13,3 ADU. Mais comme on raisonne ici sur des images codées en valeurs entières ( on peut les transformer en réels ... ), on prend la valeur entière de ce que l'on obtient; la relation générale est :
seuil_mini du niveau N = seuil_bas + Partie_Entiere ( [ (seuil_haut - seuil_bas ) / ( N - 2 ) ] * ( N - 1 ) ). ( en commençant au niveau 1 ). [ (seuil_haut - seuil_bas ) / ( N - 2 ) ] représente le nombre d'ADU entre chaque niveau.
De même, on obtient une relation du même style pour le seuil_maxi. De toute façon, seuil_maxi( N ) = seuil_mini ( N + 1 ).

D'où l'image suivante beaucoup plus contrastée que précédemment ( révellant même des détails insoupsonnés ! ):

Le lecteur peut s'amuser à faire des essais sur des images pour mieux comprendre; en voici un exemple concret :

exemples de bonne et mauvaise visualisations ...

Les autres LUT classiques :

  • LUT négative :
    Par définition, une LUT négative est l'inverse d'une LUT positive ... Prenons le cas d'une LUT linéaire avec un seuil bas et un seuil haut. On connaît déjà la forme de la LUT :

    • la LUT linéaire positive

    Lorsqu'on prend la forme négative; on obtient la LUT suivante :

    La LUT linéaire négative

    Les seuils bas et haut sont intervertis. Ensuite, il suffit de tracer une droite entre les deux points correspondant du graphe. Tous les pixels qui auront une intensité inférieure au seuil bas seront représentés en blanc et tous ceux qui auront une intensité supérieure au seuil haut seront représenté en noir. Entre les deux, les niveaux se succéderont de façon inverse à la LUT linéaire positive :
    Cette LUT trouve son utilité dans l'observation d'objet très faible qui se distinguent à peine du fond de ciel ( il est plus facile pour l'oeil de repérer un niveau un peu foncé sur du blanc que de repérer, par exemple, du gris foncé sur du noir ! ).

    Un exemple de LUT négative
    Un exemple de LUT linéaire négative.

  • LUT en dent de scie :
    Dans une LUT en dent de scie, on passe plusieurs fois par le même niveaux de couleur lorsqu'on évolue en intensité. La forme de la LUT est la suivante :

    la LUT en dents de scie ( représentée de façon positive )

    Cette LUT revient finalement, si on rapproche beaucoup les dents de scie à tracer une image en isophote ...

    un exemple de LUT en dents de scie
    Un exemple de LUT en dent de scie; on commence à voir apparaître la notion d'isophotes ...

  • LUT logarithmique :

    • La LUT logarithmique a la forme suivante :

    la LUT logarithmique

    Comme on peut le voir, elle sert à accentuer les faibles amplitudes d'intensité ( objet ressortant à peine du fond de ciel ) et par contre diminue les différences d'amplitude pour les fortes intensités. Ceci permet de mettre en évidence des détails dans les bras spiraux de galaxies par exemple.

    Il n'est pas prévu de tracer une LUT logarithmique sous PRiSM. Cependant, il existe toutes les fonctions pour y arriver. Il suffit de prendre conscience que la LUT logarithmique est la réunion d'une transformation physique logarithmique d'une image et d'une LUT linéaire. la transformation physique logarithmique s'atteind à partir du menu "Traitement / Logarithme". Par contre, il faut prendre soin de ne pas sauvegarder l'image à sa sortie si on ne veut pas qu'elle soit irrémédiablement modifiée.

    Simuler une LUT logarithmique
    On a simulé une LUT logarithmique sur M27 avec les fonctions de PRiSM

On verra par la suite que PRiSM permet de créer les LUT que l'on désire ...

Réglage automatique des seuils dans PRiSM :
PRiSM peut régler seul automatiquement les seuils bas et haut des images. Suivant les images la technique est différentes :

  • Images à pixels entiers : La technique est basée sur l'histogramme de l'image. Le seuil bas est pris à 5% de l'histogramme ( afin de représenter le fond de ciel par une même couleur ... noire lorsqu'on utilise la palette noir et blanc positive ). Ceci signifie qu'on prend la valeur de l'intensité du pixel qui se situe à la place 5 sur 100, si on classe les pixels par ordre croissant d'intensité. Le seuil haut est pris à 99,5% de l'histogramme.
  • Images à pixels réels : La technique est basée sur la médiane de l'image. PRiSM calcule la médiane et l'écart-type dans l'image. le seuil bas est égal à la médiane soustrait d'un certain nombre de fois l'écart-type. Le seuil haut est égal à la médiane ajoutée d'un certain nombre de fois l'écart-type.

La représentation d'une image couleur :

Il faut distinguer les " vraies " images couleurs et les images monochromes affichées en fausses couleurs pour faire ressortir certains détails par rapport à d'autres.
Avec PRiSM, il est possible d'utiliser ces deux possiblilités.

Pour les images en " fausses " couleurs, on définit de meêm une LUT et on verra comment réaliser ceci dans la partie suivante ( certains utilisateurs auront déjà remarqué que certaines LUT en fausses couleurs étaitent déjà prédéfinies mais la liste n'est nullement exhaustive ).

Une image en " vraies " couleurs est une image dite trichrome c'est-à-dire, à la base, une réunion de trois images R, V et B.
Le réglage de la LUT se fait de façon identique à une image monochrome à la différence qu'il faut alors régler séparemment les LUT pour chacune des couleurs R, V et B. PRiSM gère ceci parfaitement et il est conseillé de se reporter à la partie concernée.

Version Avril 2009


L'éditeur de palettes de PRiSM

Le panel d'édition des palettes s'obtient à partir du bouton "Editer" des paramètres de réglages de visualisation ouverts à partir du menu "Visualisation / Contraste//Luminosité". Il apparaît alors la fenêtre suivante :

l'éditeur de palettes; Cliquer sur partie désirée pour de plus amples explications

Il faut garder à l'esprit que la palette sera une palette de 256 couleurs ( 8 bits ) choisies cependant parmi les 16,4 millions de couleurs ( 32 bits ) que propose WINDOWS.
Durant cette page, nous allons d'abord voir la signification prise séparément puis nous créerons ensuite une palette particulière :

  • index :
    suivi d'un chiffre qui indique la position occupée par le curseur au-dessus.

    l'index correspondant à la position du cruseur sur la palette

    Cet index peut varier de 0 à 255 correpondant aux 256 couleurs de la palette.

  • index choisi :
    Correspond à la position sur la palette ( de 0 à 255 ) des repères que l'on peut se fixer en cliquant avec la souris sur un endroit de la palette. Il est alors dessinné une sorte de clé sur chaque position qui ont été repérée par une clé. On verra plus loin l'utilité de ces repères.

  • Rouge, Vert, Bleu :
    Dans les 16 millions de couleurs définies par WINDOWS , chaque couleur est en fait la composition des trois couleurs primaires Rouge, Vert et bleu ( comme les vraies images couleurs réalisées avec une caméra CCD ). Pour représenter une couleur quelconque parmi ces 16 millions, chacune des trois couleurs primaires a une intensité qui peut varier sur une échelle relative de 0 à 255. La combinaison des 3 donne alors 2563 = 16 millions de possibilités soit 16 millions de couleurs.
    Ces valeurs relatives sont indiquées pour chacune des trois couleurs primaires correspondant à la couleur sélectionnée devant l'index. Les utilisateurs de logiciel de traitement d'image grand public sont bien habitués à utiliser ces 3 données.

  • cadre coloré :
    Indique, dans un carré de taille conséquente, la couleur de la palette sélectionnée devant l'index.
    Le fait de cliquer sur ce carré permettra de remplacer la couleur ( pour l'index courant ) à partir de la boite de dialogue classique de WINDOWS ( il est également possible, dans cette boite, de définir les couleurs en donnant les valeurs d'intensité relative pour les 3 couleurs primaires ).

  • Changer couleur :
    Permet de remplacer la couleur ( pour l'index courant ) à partir de la boite de dialogue classique de WINDOWS.

  • vider palette :
    Remet à zéro toutes les valeurs d'intensité relative pour les 3 couleurs primaires R, V et B ... ceci pour tous les index.
    En résumé, la palette est toute noire !

  • Négatif :
    Prend la LUT négative de la palette sélectionnée.
    Il faut alors raisonner en intensité relative pour chacune des trois couleurs primaires. supposons qu'avant de séléctionner l'option " négatif ", l'intensité de la couleur primaire soit I. Après avoir réalisé la LUT négative, l'intensité sera alors de 255-I. L'opération sera réalisée pour chacune des 3 couleurs primaires et ceci pour les 256 couleurs de la palette.

    prendre la palette négative

  • R <-> B :
    Permet d'inverser les valeurs des intensités relatives entre la couleur primaire rouge et la couleur primaire bleue. La couleur primaire verte reste inchangée.
    Ceci a lieu pour les 256 couleurs de la palette.

  • V <-> R :
    Permet d'inverser les valeurs des intensités relatives entre la couleur primaire rouge et la couleur primaire verte. La couleur primaire bleue reste inchangée.
    Ceci a lieu pour les 256 couleurs de la palette.

  • B <-> V :
    Permet d'inverser les valeurs des intensités relatives entre la couleur primaire bleue et la couleur primaire verte. La couleur primaire rouge reste inchangée.
    Ceci a lieu pour les 256 couleurs de la palette.

  • V = 0 :
    Permet de fixer l'intensité relative correspondant à la couleur primaire verte à zéro.
    Ceci a lieu pour les 256 couleurs de la palette.

  • R = 0 :
    Permet de fixer l'intensité relative correspondant à la couleur primaire rouge à zéro.
    Ceci a lieu pour les 256 couleurs de la palette.

  • B = 0 :
    Permet de fixer l'intensité relative correspondant à la couleur primaire bleue à zéro.
    Ceci a lieu pour les 256 couleurs de la palette.

  • Scie :
    Permet de créer une LUT en dents de scie. On indique le nombre de fois que l'on veut que la LUT courante se répète dans la LUT résultante. ( voir exemple plus loin ).

  • Arc, B&W, Pink, Thermic :
    Permet de visualiser les 4 palettes prédéfinies dans PRiSM : respectivement les palettes arc-en-ciel, Noir et Blanc, Rosée et thermique.

  • Interpoller :
    Cette option est valable si on a placé des repères sur l'image comme vu précédemment : les repères
    Cette option permet de construire une palette en sélectionnant au minimum 2 couleurs dans la palette d'où l'intérêt des repères. Ces derniers peuvent être placé en cliquant sur la couleur dans la modélisation de la palette. Il apparaît alors la description " ! choisie ! " dans la carré de la couleur indéxée.
    La sélection peut se faire dans n'importe quel ordre en se déplaçant dans l'échelle des couleurs. Une fois les repères posés, il ne reste plus qu'à sélectionner l'option qui calcule tous les éléments intermédiaires de la palette à partir des couleurs choisies.
    Par la suite, il est alors possible par la suite d'effectuer tous les traitements décrits dans les options ci-dessus.

  • Rest Mrk :
    Permet d'effacer tous les repères précédemment décrits.

  • Charger :
    Permet de charger une palettte précédemment sauvegardée. L'extention des palettes est un fichier .PAL.

  • Sauver :
    Permet de sauver une palettte pour la rapeller ultérieurement. L'extention des palettes est un fichier .PAL.
    Ce fichier est une suite de 256 lignes ( correspondant aux 256 couleurs ), chaque ligne contenant entre paranthèses une liste de 3 éléments représentant les intesités relatives des trois couleurs primaires, respectivement le rouge, le vert et le bleu.
    En voici un extrait :
    (065,139,105),
    (065,138,107),
    (064,138,108),
    (063,137,110),
    (062,136,112),
    (062,136,113),
    (061,135,115),
    (060,134,117),
    .......................

Exemple de création de palette en couleurs :

  1. Effacer la palette courante. ( bouton " Vider palette " )
  2. Se positionner à l'index de couleur n°0 : créer un repère pour cette couleur en cliquant au dessus de la position de l'index sur la palette ( bouton gauche ou droit de la souris ) ... Un repère rouge doit apparaître au dessus de la palette à l'index correspondant.
  3. Se positionner à l'index n°40 et mettre l'intensité relative du rouge à 60. Ceci se fait en cliquant sur le carré des couleurs pour ouvrir la boite de dialogue des couleurs de WINDOWS. Demander à créer " sa palette personalisée " et remplir alors l'intensité relative du rouge à 60 en laissant celles du vert et du bleu à zéro ( les valeurs de teinte, intensité et saturation sont des données trichromiques décrites dans la partie HSI de l'aide de PRiSM ). Mettre un repère sur cette couleur.
  4. Se positionner à l'index n°80 et mettre l'intensité relative du vert à 60 ( Ceci se fait en cliquant sur le carré des couleurs pour ouvrir la boite de dialogue des couleurs de WINDOWS ). Mettre un repère sur cette couleur.
  5. Se positionner à l'index n°120 et mettre l'intensité relative du bleu à 60 ( Ceci se fait en cliquant sur le carré des couleurs pour ouvrir la boite de dialogue des couleurs de WINDOWS ). Mettre un repère sur cette couleur.
  6. Se positionner à l'index n°160 et mettre les intensités relatives du bleu et du rouge à 60 ( Ceci se fait en cliquant sur le carré des couleurs pour ouvrir la boite de dialogue des couleurs de WINDOWS ). Mettre un repère sur cette couleur.
  7. Se positionner à l'index n°200 et mettre les intensités relatives du vert et du rouge à 60 ( Ceci se fait en cliquant sur le carré des couleurs pour ouvrir la boite de dialogue des couleurs de WINDOWS ). Mettre un repère sur cette couleur.
    L'apparence de la palette doit être la suivante :

    on a sélectionner les couleurs d'interpolation

  8. Cliquer sur la bouton " Interpoler ". Une nouvelle palette apparaît ...

    voir le fichier de sauvegarde de la palette ...

Exemple de création de palette de niveaux de gris en dents de scie :

  1. Demander à voir la palette par défaut en noir et blanc ( bouton " B&W " ).
  2. Imposer un nombre de dent de scie de 4 et cliquer sur le bouton " Scie ".
  3. La nouvelle palette apparaît de la forme suivante :

    palette en dents de scie

    L'utilité d'une telle palette a déjà été discutée précédemment ...
Avril 2009


Caméra / Note d'application d'autoguidage / SBIG AO7

Note d'application > Guidage avec les dispositifs AO tip tilt de SBIG ET le câble relais des cameras SBIG

Prism permet le guidage avec l’AO-7 (ou AO-L, ou AO-8, dit par la suite guidage AO) et les 4 relais de corrections (RA+,RA-,Dec+,Dec-, dit par la suite guidage 4 axes) intégrés à la caméra.

Fonctionnement : le guidage est pris en charge avec le dispositif AO (si la case est cochée dans le panel de la figure ci-dessous) lors des poses avec le grand CCD avec obturateur ouvert.
Lors du bouclage, entre deux prises d'images sur le capteur principal, Prism garde la position du miroir AO à zéro, et recentre l’étoile avec les corrections 4 axes.

Le réglage des paramètres

Pour que cela fonctionne, et que Prism puisse retrouver l'étoile au moment du reset du miroir il faut que :

  • La taille de fenêtre de guidage soit suffisante.
  • Le « décalage max de correction (pixels) » (ici porté a 20 pixels) en Alpha et en Delta se doit d'être suffisamment important pour permettre aux système 4 axes de récupérer l'étoile lorsque le miroir de tip-tilt est remis à zéro.
  • Le télescope guide (vitesse sidérale et mise en station) suffisamment bien pour permettre à la course du miroir de l'AO de rester dans son intervalle de travail. Si le guidage naturel (sans correction) possède une dérive très grande, le miroir de l'AO va vite arriver en butée plus rapidement que la durée de la pose souhaitée avec le capteur principal. Dans ce cas le guidage de l'AO est stoppé et le guidage à 4 axes prend le relais.
  • Mettre « Nbre de pixels de mouvement » à zéro.

Sur le « tracking inspector », on voit bien ce qui se passe : les parties rouges sont les déviations de l'étoile guide pendant la pose avec le capteur principal, les parties vertes correspondent aux temps entre deux poses avec ce capteur principal. Des sauts sont visibles dans cette section, car PRiSM remet le miroir de l'AO a zéro (= un saut), et recentre l'étoile guide avec les mouvements à 4 axes entre les poses.
Cela permet au miroir AO de retrouver sa position initiale avec une étoile guide au centre de la fenêtre de guidage.

Le Tracking Inspector

Fonction script associée :
StartGuide
StopGuide
Get_Guide_Status

Conditions d'activation :
Avoir déclaré la caméra utilisée ainsi que l'AO7

Version Janvier 2008


Caméra / Note d'application d'autoguidage / Reprise de guidage entre les poses bouclées

Note d'application > Reprise de guidage entre les poses bouclées

Lorsqu'un autoguidage est en cours et que le bouclage des poses est actif sur le CCD principal, l'intervalle de temps entre la pose n et la pose n+1 est consacrée à recentrer étoile dans la fenêtre du ccd de guidage pour le guidage de la pose suivante. Ce temps est dit temps d'interpose. A quel moment le logiciel décide-t-il de démarrer la pose suivante en autoguidage ?
Il y a deux conditions :

  • Lorsque l'étoile se trouve dans un carré inferieur au décalage minimal de correction en Alpha et Delta déterminé dans le panneau de la figure ci-dessous, ici un carré de tolérance de 0.3 pixels de coté en Delta et en Alpha.
  • Si le système de guidage n'arrive pas à remettre l'étoile dans ce carré de tolérance, au bout de 18 à 20 tentatives, la pose suivante démarre et le guidage reprend la où se trouve l'étoile. Dans ce cas, cela veut dire que les paramètres en Alpha et Delta « décalage min de correction (pixels) » sont sans doute trop faibles.
La fenêtre de saisie des paramètres

Attention à bien paramétrer les décalages max de correction : s'ils sont trop faibles le guidage va s'arrêter très rapidement, et la reprise de guidage durant l'interpose va échouer. On a intérêt même à y mettre un nombre élevé de pixels pour que l'étoile soit tout le temps rattrapée vers le centre de la fenêtre du ccd de guidage quelle que soit sa position.

Durant l'interpose, il est tout à fait possible de regarder l'inspecteur de suivi (Tracking inspector). Les parties vertes des courbes indiquent que la pose sur le CCD principal (celui sur lequel se fait l'image que l'on va garder) n'est pas active. Les parties rouges, que le CCD principal est en cours de pose. Il est intéressant de regarder ce qu'il se passe durant l'interpose, aussi bien sur les graphiques que sur la fenêtre du bas ou s'écrivent les opérations.

Le tracking inspector

Fonction script associée :
StartGuide
StopGuide
Get_Guide_Status

Conditions d'activation :
Avoir déclaré la caméra utilisée.

Version Janvier 2008


Dossier / Le numéro de série avec PRiSM

> Dossier > Le numéro de série avec PRiSM

Comment PRISM stocke dans la base de registre les informations d'accès au logiciel ?
Dans la base de registre WINDOWS, notamment dans l'ensemble des répertoires "..\HKEY_CURRENT_USER\Software".

Les versions 5 et 6 : ces deux versions cohabitent dans le même répertoire de la base de registre et les réglages de l'une seront utilisés dans l'autre. Le répertoire est "..\HKEY_CURRENT_USER\Software\prism\". La clé de sécurité ne pose pas de problème car porte des noms différents suivant les 2 versions comme le prouve l'image ci-dessous :

La base de registre

Les clefs "KeyUserV5" et "KeyUserV6" et "NameUserV5" et "NameUserV6" sont propres aux versions 5 et 6 respectivement. "SerialNumber" ne change pas entre la version 5 et la version 6.

La version 7 et les suivantes :PRiSM 7 et suivante n'ont pas ce problème et peuvent cohabiter aussi avec les anciennes versions : les caractéristiques sont sauvegardées dans le répertoire "..\HKEY_CURRENT_USER\Software\prism\" du registre et donc ne peuvent venir interférer avec le répertoire "..\HKEY_CURRENT_USER\Software\prism\" des versions 5 et 6. Pour PRiSM, il faut savoir qu'une simple mise à jour du BIOS du PC va changer la clé et va obliger l'utilisateur à en demander une nouvelle au distributeur.

Version Décembre 2008


PRiSM 6 - Traitement d'images CCD en astronomie

Utilisation de l'aide

L'information dans ce document est sujette au changement sans communication préalable et ne représente pas un engagement de la part de l'auteur de ces lignes.

Aucune partie de ces pages ne peut être reproduite ou transmise sous n'importe quelle forme ou par tous les moyens, électronique ou mécanique, y compris (mais être limitée à) au photocopiage, l'enregistrement, ou les systèmes de stockage de l'information et de récupération, pour n'importe quel but autre que l'utilisation personnelle de l'acheteur, sans permission écrite de l'auteur de ces lignes.


Catalogues CD,WEB -> DD

Intaller les trois catalogues sur le disque dur

Catalogue GSC-ACT :

Sur le CD, on trouve un catalogue important et complet : le catalogue GSC-ACT (correction du catalogue GSC). Les fichiers de ce catalogue sont dans le répertoire "\GSC-ACT\" du CD d'installation. Pour les personnes ayant téléchargées le logiciel, ces fichiers sont disponibles sous la forme d'un fichier ZIP sur le site prism-astro.

Afin de copier ce catalogue sur le disque dur, créer un répertoire "Catalogues_Etoiles" par exemple dans le répertoire principal de PRiSM. Y inclure le répertoire "GSC_ACT". Pour le fichier GSC-ACT.ZIP, double-cliquer sur le fichier ZIP (nativement reconnu par WINDOWS), copier le contenu du fichier dans le répertoire du disque dur créé à cet effet. Pour les pocesseurs du CD de PRiSM, copier le contenu du répertoire "\GSC-ACT\" sur le répertoire du disque dur créé pour le GSC-ACT. L'apparence du répertoire sur le disque dur doit avoir la forme suivante :

Le répertoire du catalogue GSC-ACT

Ouvrir alors le logiciel PRiSM et se diriger vers le menu [Options] > [Options de démarrage de la carte du ciel] : Compléter la partie de la fenêtre "Chemin du GSC-ACT" en cochant la case au dessus.

Pour faire apparaître les étoiles, créer une carte du ciel à partir du menu [Fichier] >[Nouvelle fenêtre du ciel] puis aller dans l'icône "configuration de la carte du ciel" depuis la barre supérieure des icônes. Choisir l'onglet "Etoiles". Cocher la partie correspondante dans l'onglet "GSC" : les étoiles du catalogue doivent apparaître mais uniquement à partir d'un certain zoom sur la carte du ciel à cause de la magnitude limite imposée dans l'onglet précédent.

Catalogue USNO-A :

Sur le site WEB du logiciel, il est proposé Adresse FTP pour charger les fichiers d'étoiles correspondant à ce catalogue (attention, la connexion au site est parfois capricieuse vu le nombre de demande !). La fenêtre du navigateur a alors l'allure suivante :

Allure du navigateur

Afin de copier ces catalogues sur le disque dur, créer un répertoire "Catalogues_Etoiles" par exemple dans le répertoire principal de PRiSM. Y inclure le répertoire "USNO_A". Y copier tous les fichers *.CAT et *.ACC de la fenêtre du navigateur dans le répertoire nouvellement créé. L'apparence du répertoire doit avoir la forme suivante :

Le répertoire du catalogue USNO-A

Ouvrir alors le logiciel PRiSM et se diriger vers le menu [Options] > [Options de démarrage de la carte du ciel] : Compléter l'onglet "USNO ..." en indiquant le répertoire où se situent les fichiers CAT et ACC.

Pour faire apparaître les étoiles, créer une carte du ciel à partir du menu [Fichier] >[Nouvelle fenêtre du ciel] puis aller dans l'icône "configuration de la carte du ciel" depuis la barre supérieure des icônes. Choisir l'onglet "Etoiles". Cocher le catalogue correspondant dans l'onglet "USNO" : les étoiles du catalogue doivent apparaître mais uniquement à partir d'un certain zoom sur la carte du ciel à cause de la magnitude limite imposée dans l'onglet précédent.

Catalogue USNO-SA :

Sur le site WEB du logiciel, il est proposé Adresse FTP pour charger les fichiers d'étoiles correspondant à ce catalogue (attention, la connexion au site est parfois capricieuse vu le nombre de demande !). La fenêtre du navigateur a alors l'allure suivante :

Allure du navigateur

Afin de copier ces catalogues sur le disque dur, créer un répertoire "Catalogues_Etoiles" par exemple dans le répertoire principal de PRiSM. Y inclure le répertoire "USNO_SA". Y copier tous les fichers *.CAT et *.ACC de la fenêtre du navigateur dans le répertoire nouvellement créé. L'apparence du répertoire doit avoir la forme suivante :

Le répertoire du catalogue USNO-SA

Ouvrir alors le logiciel PRiSM et se diriger vers le menu [Options] > [Options de démarrage de la carte du ciel] : Compléter l'onglet "USNO ..." en indiquant le répertoire où se situent les fichiers CAT et ACC.

Pour faire apparaître les étoiles, créer une carte du ciel à partir du menu [Fichier] >[Nouvelle fenêtre du ciel] puis aller dans l'icône "configuration de la carte du ciel" depuis la barre supérieure des icônes. Choisir l'onglet "Etoiles". Cocher le catalogue correspondant dans l'onglet "USNO" : les étoiles du catalogue doivent apparaître mais uniquement à partir d'un certain zoom sur la carte du ciel à cause de la magnitude limite imposée dans l'onglet précédent.


Notions de statistique d'image

Dossier > Notions de statistiques d'images

Une image CCD doit être considérée comme une succession de valeurs, dans un plan à deux dimensions pour des images monochromes ( et dans un espace à trois dimensions pour des images trichromes ). Suivant la grandeur de ces valeurs, le pixel apparaîtra plus ou moins brillant ce qui formera l'image. Ces valeurs nous renseignent donc directement sur les caractéristiques de l'image. Dans le cas des prétraitements ( voir la partie correspondante ), on sait qu'il est souvent essentiel de connaître certaines données comme la valeur moyenne des pixels d'une image ou l'écart-type de ces valeurs. Nous allons donc revoir la signification de ces mots.

On parle de valeurs discrètes car le signal lumineux obtenu est échantillonné et n'est donc pas un signal continu. Celà ne se voit plus de nos jours avec les caméras haute technologie ( très grand nombre de pixels sur le capteur ), mais il suffit de prendre une image d'une caméra d'amateur datant des années 1980 pour en être persuadé. Ce phénomène découle directement du fait que le capteur possède des pixels de petites dimensions certes, mais quand même pas de dimensions négligeables.

Considérons un ensemble de N mesures discrètes. Les résultats de ces mesures sont notés Ri. On définit alors la moyenne de ces mesures par la relation suivante :

La variance est une mesure arbitraire servant à caractériser la dispersion d'une série de mesure. Elle se calcule à partir de :

Mathématiquement, l'écart-type est une quantité réelle positive, éventuellement infinie, utilisée dans le domaine des probabilités pour caractériser la répartition d'une variable aléatoire autour de sa moyenne :

Attention : Lorsqu'il s'agit d'estimer la dispersion autour de la moyenne d'un caractère statistique d'une série de n valeurs, on utilise pour l'écart-type la valeur suivante :

L'écart-type revient à calculer un écart à la moyenne. Plus l'écart type va être important, plus les valeurs des résultats vont être dispersées par rapport à la moyenne.

On définit encore la moyenne quadratique par :

Le calcul de cette dernière a un intérêt pour connaître l'uniformité d'une image. Plus ce nombre est important, plus il y a de pixels qui s'écartent fortement de la moyenne.

Enfin, on définit la médiane d'une série de valeur. Considérons par exemple la série de valeur suivante :
45 20 03 96 87 52 12
Si on range ces valeurs par ordre croissant, on obtient : 03 12 20 45 52 87 96
La valeur médiane sera alors la valeur du milieu de la liste c'est-à-dire 45.
Si le nombre de valeur est pair, on prend comme valeur médiane la moyenne des 2 valeurs centrales de la liste rangée en ordre croissant : la valeur médiane de la liste 45 20 03 96 87 52 12 23 est (23 + 45 ) /2 = 34.
Normalement, si les valeurs respectaient bien la forme d'une gaussienne, on devrait avoir une valeur médiane égale à la valeur moyenne. Mais c'est rarement le cas !


Recherche :M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\TDIG3-*
Charge : M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\TDIG3-1.cpa
Date=11/09/1999 23:47:37
Exposition (s)=155.414
Position: RA=01h14m00s DEC=+07°15'00'
[img: 1] 2377 SOURCES TOTALES
[img: 1] 5025 SOURCES TOTALES
[img: 1] 7781 SOURCES TOTALES
[img: 1] 7835 SOURCES TOTALES
Charge : M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\TDIG3-2.cpa
Date=12/09/1999 00:19:32
Exposition (s)=155.414
Position: RA=01h14m00s DEC=+07°15'00'
[img: 2] 2140 SOURCES TOTALES
[img: 2] 4355 SOURCES TOTALES
[img: 2] 6626 SOURCES TOTALES
[img: 2] 6662 SOURCES TOTALES
Charge : M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\TDIG3-3.cpa
Date=12/09/1999 00:50:41
Exposition (s)=155.414
Position: RA=01h14m00s DEC=+07°15'00'
[img: 3] 2514 SOURCES TOTALES
[img: 3] 5156 SOURCES TOTALES
[img: 3] 7924 SOURCES TOTALES
[img: 3] 7991 SOURCES TOTALES
Charge : M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\TDIG3-4.cpa
Date=12/09/1999 01:34:45
Exposition (s)=155.414
Position: RA=01h14m00s DEC=+07°15'00'
[img: 4] 2372 SOURCES TOTALES
[img: 4] 5091 SOURCES TOTALES
[img: 4] 8057 SOURCES TOTALES
[img: 4] 8109 SOURCES TOTALES
Nombre d'&eacute;toiles :7835
Nombre d'&eacute;toiles :6662
Nombre d'&eacute;toiles :7991
Nombre d'&eacute;toiles :8109
D&eacute;bute la recherche auto d'ast&eacute;ro&iuml;des...
Recalage des images...
Elimination des &eacute;toiles...
[img1]Sources potentielles :2653
[img2]Sources potentielles :1255
[img3]Sources potentielles :2319
[img4]Sources potentielles :4156
S&eacute;lection des candidats...
Nombre d'ast&eacute;ro&iuml;des potentiels : 178
Astrom&eacute;trie...
Image N°1
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:1]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
Image N°2
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:2]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
Image N°3
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:3]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
Image N°4
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
[img:4]Nbre d &eacute;toiles limit&eacute; &agrave; : 100 pour la comparaison champ-catalogue.
R&eacute;cup&eacute;ration des imagettes blink...
20/178
40/178
60/178
80/178
100/178
120/178
140/178
160/178
20/178
40/178
60/178
80/178
100/178
120/178
140/178
160/178
20/178
40/178
60/178
80/178
100/178
120/178
140/178
160/178
20/178
40/178
60/178
80/178
100/178
120/178
140/178
160/178
Blinks 178 / 178
Temps de calcul=59.59s
Nombre d'ast&eacute;roides d&eacute;couverts :8

COD A12
CON
OBS L.Bernasconi
MEA
TEL CN212 Newton + NJP160 avec MCMT
NET USNO A2
ACK Batch

     ASTER1 * C1999 09 12.00481 01 20 42.97 +06 54 44.1          17.6        A12
     ASTER1   C1999 09 12.02690 01 20 42.30 +06 54 39.4          17.6        A12
     ASTER1   C1999 09 12.04847 01 20 41.68 +06 54 36.5          17.7        A12
     ASTER1   C1999 09 12.07896 01 20 40.70 +06 54 31.2          17.3        A12

     ASTER2 * C1999 09 11.99218 01 01 30.32 +07 04 06.5          16.7        A12
     ASTER2   C1999 09 12.01430 01 01 29.48 +07 04 02.7          16.9        A12
     ASTER2   C1999 09 12.03590 01 01 28.72 +07 03 58.7          17.0        A12
     ASTER2   C1999 09 12.06646 01 01 27.65 +07 03 53.6          16.9        A12

     ASTER3 * C1999 09 11.99633 01 08 21.26 +07 14 36.4          15.6        A12
     ASTER3   C1999 09 12.01842 01 08 20.76 +07 14 24.3          15.7        A12
     ASTER3   C1999 09 12.03999 01 08 20.26 +07 14 12.4          15.5        A12
     ASTER3   C1999 09 12.07050 01 08 19.54 +07 13 55.3          15.5        A12

     ASTER4 * C1999 09 11.99223 01 01 39.32 +07 33 56.6          16.5        A12
     ASTER4   C1999 09 12.01435 01 01 38.54 +07 33 47.3          16.6        A12
     ASTER4   C1999 09 12.03596 01 01 37.81 +07 33 38.5          16.5        A12
     ASTER4   C1999 09 12.06651 01 01 36.80 +07 33 25.6          16.6        A12

     ASTER5 * C1999 09 11.99952 01 13 00.51 +07 36 30.3          16.0        A12
     ASTER5   C1999 09 12.02161 01 12 59.70 +07 36 22.9          15.9        A12
     ASTER5   C1999 09 12.04318 01 12 58.90 +07 36 14.7          15.7        A12
     ASTER5   C1999 09 12.07368 01 12 57.75 +07 36 04.1          15.4        A12

     ASTER6 * C1999 09 12.00182 01 16 21.81 +07 15 08.4          16.9        A12
     ASTER6   C1999 09 12.02392 01 16 21.17 +07 15 04.5          16.9        A12
     ASTER6   C1999 09 12.04548 01 16 20.45 +07 14 59.8          16.9        A12

     ASTER7 * C1999 09 12.00662 01 23 21.08 +07 25 18.0          17.4        A12
     ASTER7   C1999 09 12.02871 01 23 20.52 +07 25 09.8          17.1        A12
     ASTER7   C1999 09 12.05028 01 23 19.86 +07 25 03.0          17.4        A12

     ASTER8 * C1999 09 12.00898 01 26 47.45 +07 34 56.9          16.9        A12
     ASTER8   C1999 09 12.03107 01 26 46.78 +07 34 53.5          16.8        A12
     ASTER8   C1999 09 12.05265 01 26 46.25 +07 34 50.6          16.9        A12

ASTER1 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
12/09/1999 00:06:55   01h20m42.970s   +06°54'44.10''   X=3497.2  Y=236.12  Mg=17.55    TDIG3-1.cpa
12/09/1999 00:38:44   01h20m42.300s   +06°54'39.41''   X=3537.4  Y=242.18  Mg=17.64    TDIG3-2.cpa
12/09/1999 01:09:48   01h20m41.680s   +06°54'36.51''   X=3573.5  Y=247.8  Mg=17.66    TDIG3-3.cpa
12/09/1999 01:53:42   01h20m40.700s   +06°54'31.17''   X=3640.4  Y=252.24  Mg=17.31    TDIG3-4.cpa

ASTER2 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
11/09/1999 23:48:44   01h01m30.320s   +07°04'06.53''   X=11096  Y=484.81  Mg=16.72    TDIG3-1.cpa
12/09/1999 00:20:36   01h01m29.480s   +07°04'02.75''   X=11145  Y=490.86  Mg=16.86    TDIG3-2.cpa
12/09/1999 00:51:42   01h01m28.720s   +07°03'58.69''   X=11182  Y=496.36  Mg=16.96    TDIG3-3.cpa
12/09/1999 01:35:42   01h01m27.650s   +07°03'53.58''   X=11234  Y=501.27  Mg=16.87    TDIG3-4.cpa

ASTER3 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
11/09/1999 23:54:43   01h08m21.260s   +07°14'36.42''   X=8385.8  Y=763.95  Mg=15.58    TDIG3-1.cpa
12/09/1999 00:26:31   01h08m20.760s   +07°14'24.31''   X=8431.1  Y=766.26  Mg=15.7    TDIG3-2.cpa
12/09/1999 00:57:35   01h08m20.260s   +07°14'12.41''   X=8466.1  Y=767.9  Mg=15.46    TDIG3-3.cpa
12/09/1999 01:41:31   01h08m19.540s   +07°13'55.30''   X=8517.2  Y=767.51  Mg=15.51    TDIG3-4.cpa

ASTER4 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
11/09/1999 23:48:49   01h01m39.320s   +07°33'56.63''   X=11036  Y=1277.7  Mg=16.46    TDIG3-1.cpa
12/09/1999 00:20:40   01h01m38.540s   +07°33'47.32''   X=11084  Y=1281.6  Mg=16.56    TDIG3-2.cpa
12/09/1999 00:51:46   01h01m37.810s   +07°33'38.53''   X=11121  Y=1284.9  Mg=16.46    TDIG3-3.cpa
12/09/1999 01:35:46   01h01m36.800s   +07°33'25.60''   X=11174  Y=1286.5  Mg=16.64    TDIG3-4.cpa

ASTER5 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
11/09/1999 23:59:19   01h13m00.508s   +07°36'30.33''   X=6544.4  Y=1346.3  Mg=16.01    TDIG3-1.cpa
12/09/1999 00:31:07   01h12m59.700s   +07°36'22.94''   X=6589.5  Y=1350.6  Mg=15.87    TDIG3-2.cpa
12/09/1999 01:02:11   01h12m58.900s   +07°36'14.73''   X=6626.7  Y=1354.3  Mg=15.72    TDIG3-3.cpa
12/09/1999 01:46:06   01h12m57.750s   +07°36'04.09''   X=6685.9  Y=1355.5  Mg=15.39    TDIG3-4.cpa

ASTER6 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
12/09/1999 00:02:38   01h16m21.810s   +07°15'08.39''   X=5218.2  Y=778.28  Mg=16.93    TDIG3-1.cpa
12/09/1999 00:34:26   01h16m21.170s   +07°15'04.52''   X=5260.3  Y=784.39  Mg=16.88    TDIG3-2.cpa
12/09/1999 01:05:30   01h16m20.450s   +07°14'59.84''   X=5296.9  Y=789.56  Mg=16.87    TDIG3-3.cpa

ASTER7 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
12/09/1999 00:09:32   01h23m21.080s   +07°25'17.95''   X=2453.8  Y=1048.5  Mg=17.37    TDIG3-1.cpa
12/09/1999 00:41:21   01h23m20.520s   +07°25'09.79''   X=2492.3  Y=1052.9  Mg=17.13    TDIG3-2.cpa
12/09/1999 01:12:24   01h23m19.860s   +07°25'02.96''   X=2529.1  Y=1056.7  Mg=17.36    TDIG3-3.cpa

ASTER8 blinkfile ->M:\PRiSM_v6\Aide v6\aide_CHM\Menu-Analyse\ANALYSE-Rech_Aster-Scan\SCAN\11-12-09-99\blinkfiles\TDIG
12/09/1999 00:12:55   01h26m47.450s   +07°34'56.90''   X=1092.9  Y=1304.6  Mg=16.89    TDIG3-1.cpa
12/09/1999 00:44:45   01h26m46.780s   +07°34'53.47''   X=1131  Y=1311.6  Mg=16.79    TDIG3-2.cpa
12/09/1999 01:15:48   01h26m46.250s   +07°34'50.60''   X=1167.2  Y=1316.9  Mg=16.92    TDIG3-3.cpa


Importer un fichier texte de données UVES depuis l'ESO

> Spectroscopie > Importer un fichier texte de données UVES depuis le site de l'ESO

Voici la procédure à suivre afin d'importer un fichier texte contenant les données UVES depuis le site de l'ESO.

Se rendre à cette page.

On prend l'exemple d'Altair dont on cherche à télécharger le spectre UVES entre 6500 Å et 6700 Å :

Télécharger le fichier texte proposé

Fonction(s) Script associée(s):
Aucune pour le moment

Fichier exemple :
Spectre données UVES d'Altair de 6500 à 6700 Å

Version Mai 2007


SBIG Initialization...
Driver object created...
Driver version : Version 4.37 - April 16, 2004
USB 0 required
No Filter wheel
Try to establish link...
DriverNTCCD SBIG (D6 PRISM) v1.01.01 Modified = 25 July 2004
Driver Infos : version=4.40  Name=SBIGUDrv.DLL Ver 4.40 Build 2, Max allowable Camera connected=2
Device open successfull !
Establish link successfull !
Imaging CCD : Firmware=2.40
CameraType=12
Name=SBIG ST-10 Dual CCD Camera
# ReadoutModes=10
ReadoutModes #1
Command Mode = 0
Width  = 2184
Height = 1472
Pixel_width (µm) = 6.80
Pixel_height (µm)= 6.80
gain (e-/ADU) = 1.33
Binning X =  1
Binning Y =  1
ReadoutModes #2
Command Mode = 1
Width  = 1092
Height = 736
Pixel_width (µm) = 13.60
Pixel_height (µm)= 13.60
gain (e-/ADU) = 1.33
Binning X =  2
Binning Y =  2
ReadoutModes #3
Command Mode = 2
Width  = 728
Height = 490
Pixel_width (µm) = 20.40
Pixel_height (µm)= 20.40
gain (e-/ADU) = 1.33
Binning X =  3
Binning Y =  3
ReadoutModes #4
Command Mode = 3
Width  = 2184
Height = 0
Pixel_width (µm) = 6.80
Pixel_height (µm)= 6.80
gain (e-/ADU) = 1.33
Binning X =  1
Binning Y =  1
ReadoutModes #5
Command Mode = 4
Width  = 1092
Height = 0
Pixel_width (µm) = 13.60
Pixel_height (µm)= 6.80
gain (e-/ADU) = 1.33
Binning X =  2
Binning Y =  1
ReadoutModes #6
Command Mode = 5
Width  = 728
Height = 0
Pixel_width (µm) = 20.40
Pixel_height (µm)= 6.80
gain (e-/ADU) = 1.33
Binning X =  3
Binning Y =  1
ReadoutModes #7
Command Mode = 6
Width  = 2184
Height = 1472
Pixel_width (µm) = 6.80
Pixel_height (µm)= 6.80
gain (e-/ADU) = 1.33
Binning X =  1
Binning Y =  1
ReadoutModes #8
Command Mode = 7
Width  = 1092
Height = 736
Pixel_width (µm) = 13.60
Pixel_height (µm)= 13.60
gain (e-/ADU) = 1.33
Binning X =  2
Binning Y =  2
ReadoutModes #9
Command Mode = 8
Width  = 728
Height = 490
Pixel_width (µm) = 20.40
Pixel_height (µm)= 20.40
gain (e-/ADU) = 1.33
Binning X =  3
Binning Y =  3
ReadoutModes #10
Command Mode = 9
Width  = 242
Height = 163
Pixel_width (µm) = 61.20
Pixel_height (µm)= 61.20
gain (e-/ADU) = 1.33
Binning X =  9
Binning Y =  9
Full Frame device
Shutter required

Guiding CCD : Firmware=2.40
CameraType=12
Name=SBIG ST-10 Dual CCD Camera
# ReadoutModes=3
ReadoutModes #1
Command Mode = 0
Width  = 657
Height = 495
Pixel_width (µm)= 7.40
Pixel_height (µm)= 7.40
gain (e-/ADU) = 0.45
Binning X =  1
Binning Y =  1
ReadoutModes #2
Command Mode = 1
Width  = 328
Height = 247
Pixel_width (µm)= 14.80
Pixel_height (µm)= 14.80
gain (e-/ADU) = 0.45
Binning X =  2
Binning Y =  2
ReadoutModes #3
Command Mode = 2
Width  = 219
Height = 165
Pixel_width (µm)= 22.20
Pixel_height (µm)= 22.20
gain (e-/ADU) = 0.45
Binning X =  3
Binning Y =  3
Frame transfer device
Shutter required
SBIG Camera Initialization went successfully...
Assign Guider engine to SBIG Camera


X1=0 Y1=0 | X2=0 Y2=0 | CX=0  CY=0
11 it&eacute;rations seront r&eacute;alis&eacute;s
Focuser sur la position de d&eacute;part !
Max=4778.00  @X=65 Y=57
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=6422.00  @X=64 Y=57
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=8677.00  @X=65 Y=57
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=13042.00  @X=63 Y=57
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=25046.00  @X=64 Y=58
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=47876.00  @X=64 Y=59
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=28885.00  @X=64 Y=60
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=22053.00  @X=65 Y=58
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=13273.00  @X=66 Y=61
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=8403.00  @X=67 Y=58
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
D&eacute;placement de 0.50 mm requis
D&eacute;placement termin&eacute; !
Max=5055.00  @X=69 Y=57
X1=1135 Y1=684 | X2=1256 Y2=805 | CX=1195  CY=744
Focalisation termin&eacute;e !!


Caméra / Focalisation sur une raie

> Caméra > Focalisation sur une raie

Lancement : Menu [Caméra] > [Focalisation sur Raie]

Cette fonction permet de faire une mise au point manuelle sur une raie. La vision de l'évolution temporelle permet de revenir à la position jugée comme la meilleure.

Avant de pouvoir utiliser cette fonction, il faut :

  • Avoir déjà lancé la fonction d'acquisition d'image [Caméra] > [Activer Paneau Acquisition Caméra]
  • Avoir lancé une acquisition en binning 1x1 avec un temps de pose assez court (1s par exemple)

Si le spectroscope est complètement défocalisé, il faut commencer par un binning 3x3 et réaliser une focalisation la meilleure possible. Revenir ensuite au binning 1x1, et prendre une pose. Les raies ne doivent alors plus apparaître parfaitement comme des rectangles fins. A partir de l'onglet "Fenêtre" ( un des onglets du menu d'acquisition ), sélectionner une fenêtre encadrant une raie qui va servir à la focalisation. Cette manipulation a pour but de diminuer la fenêtre à lire et donc de la lire beaucoup plus vite qu'une fenêtre de taille normale. Essayer d'approcher une bonne focalisation à partir de cette nouvelle fenêtre.
Enfin, une fois que la raie choisie semble focalisée et après avoir cliqué sur le menu [caméra] > [Focalisation sur raie], une croix va circuler sur l'image courante. Il faut amener la croix sur l'endroit de la raie où on désire focaliser (si cette raie est focalisée, les autres le seront aussi ... quoique ...). Cliquer lorsque l'endroit est au centre de la croix. La raie choisie ne doit pas être saturée.

La fenêtre suivante s'ouvre alors :

Le panel de focalisation sur une raie
  • La première fenêtre ( en haut à gauche ) donne l'image de la raie agrandie dans un carré de 50 pixels de côté et permet donc de repérer la raie sur laquelle on focalise (utile lorsqu'on a deux raies très proches l'une de l'autre). Il est quand même conseillé d'éviter de choisir deux raies très proches sous peine de voir passer la croix rouge de focalisation d'une raie à l'autre. La fenêtre contient l'image de la raie en temps réel.

  • Les deux fenêtres en dessous donne l'apparence de la raie sur le fond de ciel dans sa partie modélisée et pour la petite fenêtre de droite la modélisation gaussienne de la raie en fonction des paramètres calculés (le fond de ciel est enlevé).

  • Le rectangle sous les 2 fenêtres permet de situer le cadran utilisé par rapport au capteur CCD. Cela peut être important pour les instruments qui présentent de fortes distorsion sur les bords du champ. Dans le cas où le bouton [fenêtre fixe] est coché, la fenêtre se déplace sur le fond de la matrice de telle façon que la raie reste au centre de la fenêtre où elle apparaît; Cette fenêtre se déplace notamment au fur et à mesure de la focalisation.

  • Effacer Graphique : Cette touche permet d'effacer le graphique supérieur : FWHM de la raie.

  • La fenêtre intensité : Dans cette fenêtre est indiqué le pixel d'intensité minimum ( en ADU ) , le pixel d'intensité maximum ( en ADU ) dans l'image en haut à gauche. Il n'est pas conseillé sur ce point de choisir une raie qui ne sorte qu'à peine du fond de ciel. Ces valeurs nous permettent de le savoir ! Il est indiqué également la position sur le capteur de la raie sur laquelle on réalise la focalisation ainsi qu'il est rappelé sa valeur de largeur à mi-hauteur (FWHM).
    Il est fourni la valeur entière de longueur d'onde sur laquelle on réalise la focalisation et à partir de laquelle est calculée la résolution spectrale approximative atteinte. La valeur de longueur d'onde approximative n'est pas connu au départ. Elle doit être fournie à partir du bouton [Définir longueur d'onde].
    Enfin, il est rappelé la taille de la fenêtre d'analyse choisie à partir de l'imagette en haut à gauche.

  • Pause : Permet de demander à la focalisation assistée de faire une pause ( ... passage d'un nuage à l'humeur vagabonde ! ).

  • FWHM : Donne la largeur à mi-hauteur de la raie au cours du temps lors de la focalisation. Le but est évidemment de réussir à le rendre le plus petit possible.
L'évolution de la FWHM au cours du temps
  • Largeur à mi-hauteur / FWHM : Donne la mesure instantanée de ce qui est résumé dans le graphique ci-dessus. Il est indiqué la taille de la FWHM en pixel ainsi qu'un ordre de grandeur de la résolution atteinte. Cette dernière valeur ne pourra être fournie que si l'échantillonnage connu a été correctement rempli dans l'entête de la caméra ainsi que le bouton bouton [Définir longueur d'onde] correctement complété.
Régler la longueur d'onde
  • Il est possible de visualiser en temps réel, l'évolution de la FWHM de la raie. Pour cela, cliquer sur le bouton [Graphique en temps réel].
Un graphe en temps réel !
  • Lorsque la mise au point est considérée comme correcte, il suffit de cliquer sur le bouton [STOP]. Le logiciel propose alors d'afficher la courbe de variation de la FWHM de la raie au cours du temps.

Animation FLASH :
à venir !

Conditions d'activation :
Avoir déclaré la caméra utilisée et réalisé une acquisition en binning 1x1

Prérequis :
Réaliser une acquisition

Voir aussi :
Utilisation des graphes sous PRiSM.
Focalisation sur une étoile.

Version Octobre 2007


Dossier : Réglage des WEBCAM

> Caméra > Acquisition Mode Vidéo (Réglages Webcam)

Lancement : Menu [Caméra] > [Acquisition mode Vidéo] > [Video Source]

En cliquant sur le bouton [Source vidéo], la fenêtre suivante s'ouvre :

Onglet "Commandes d'images"

En haut de la fenêtre, le "taux d'image" est le nombre d'images affichées par seconde, dans la fenêtre de prévisualisation.

Il est possible de régler la luminosité de l'image à l'aide du curseur "Luminosité" dans la zone "Commandes d'images". Toutefois, il est préférable de le laisser à une position moyenne et éventuellement, de l'ajuster après avoir définit le temps de pose (voir onglet "Commandes Caméra").
Il n'est pas conseillé de modifier les autres réglages (contraste et gamma), à moins que l'utilisateur soit un "habitué" des WEBCAM.

Onglet "Commandes caméra"

En sélectionnant l'onglet "Commandes caméra", la fenêtre suivante s'ouvre :

Cette fenêtre donne accès aux réglages les plus importants : la vitesse d'obturation, qui définit le temps de pose et le gain.

Il est fortement conseillé de décocher la case à cocher "Automatique". En effet, pour les images astronomiques, le mode automatique n'est pas du tout efficace.

Onglet "Capture Source"

En sélectionnant l'onglet "Capture Source", la fenêtre suivante s'ouvre :

Cette fenêtre permet de sélectionner le driver utilisé pour les acquisitions.

Version Nov 2005


Menu / NOM

> Menu > NOM

Lancement : Menu [Menu] > [NOM]

But : xxxxx

DESCRIPTION

Images supportant cette fonction :
xxxxxx

Fonction(s) Script associ?e(s):
xxxxxx

Conditions d'activation :
xxxxxx

Pr?requis :
xxxxxxx

Voir aussi :
xxxxxxx

Date de mise ? jour


Fichier / Créer une nouvelle image

> Fichier > Créer une nouvelle image

Lancement : Menu [Fichier] > [Créer une nouvelle image]

But : Créer une nouvelle image "vide" dans PRiSM.

En construction

Fonction(s) Script associée(s):
NewImage

Version


Fichier / Fenêtre du ciel / Trouver

> Fichier > Menu contextuel fenêtre du ciel > Trouver objet autour de ce point

Lancement : Menu [Fichier] >[Nouvelle fenêtre du ciel] + [Menu contextuel] + [Trouver objet autour de ce point].

La fenêtre de recherche a l'apparence suivante :

  • Coordonnées : Sont affichées les coordonnées où pointait la souris lors de la demande de recherche.

  • Champ à explorer : Rentrer la taille du champ à explorer. Par défaut, 1°.

  • Limites : Fixer, si besoin, une limite Min/Max en taille (seconde d'arc) et en magnitude.

  • Exclure : Exclure le type d'objet désiré.

  • Recherche SN : En construction ...

  • Limites en RA/DEC : Fixer, si besoin, des limites AD et DEC pour la recherche. Permet de fixer une limite rectangulaire et non circulaire comme au début de la fenêtre.

  • Catalogue : Sélectionner les catalogues de recherche. Choix entre PGC, NGC, ARP, IC, ESO, PK et BSC.

  • La fenêtre des résultats arrive après.

  • Boutons : 3 boutons pour quitter la fenêtre, commencer la recherche ou envoyer les résultats vers le fichier des objets à observer (lisible directement à partir du menu "Télescope").

    • Nov. 2005


1982 TA
T=2450400.5
e=0.7728706
Incl.=12.21223
Node=10.17238
Peri.=119.26216
a=2.2976600
M=352.17443// g&eacute;n&eacute;r&eacute; par le PAP direct
$ASTEROID
 &Priority      = ? // Priorit&eacute; d'observation entre 1 et 4
 &Name          = 1999TC36   // Max 17 Char
 &Epoch         = 2453200.5 // JD
 &Eccentricity  = 0.2218091 //degres
 &Node          = 97.14079 //degres
 &SemiMajorAxis = 39.2539436 // ua
 &Perihelie     = 295.33446 //degres
 &Incl.         = 8.41517 //degres
 &AbsMagn       = 4.90000009536743
 &M_anomalie    = 343.92145  //degres
 &Number        = 47171    // Max =8 char, peut etre vide
 &NbreObs       = 60
 &TypeAster     = 14  //   valeur code MPC
 &Status        = 0 // Valeur code MPC
 &NbreOpp       = 4 // nbre d'oppositions
 &DatesOps      = 1999-2002  // Max =9 char
 &ErreurRMS     = 0.540000021457672       // Arscec
 &U             = ?     // U Parameter 1 to 6, critere de numerotation
$END


Les équations de l'algorithme du morphing planétaire

> Dossier > Les équations de l'algorithme du morphing planétaire

Sont juste présentées ici les équations utiles pour l'application du morphing planétaire :


Les Trames NMEA

  1. Préambule.
  2. Définition du Standard NMEA.
  3. La trame : GGA
  4. La trame : GLL
  5. La trame : GSA
  6. La trame : GSV
  7. La trame : VTG
  8. La trame : RMC
  9. Comment visualiser les trames.
  10. Liens utiles.

1 - PREAMBULE

NMEA - National Marine & Electronics Association, est une Association à but non lucratif fondée par un groupement de professionnels de l'industrie de l'électronique des périphériques marine, conjointement avec des fabricants, des distributeurs, des revendeurs, des institutions d'enseignements. Leur but entre autre, harmoniser et standardiser les équipements de la marine.

NMEA est à l'origine de nombreux standards et en particulier du Standard NMEA-0183 qui nous intêresse le plus.

Dans ce qui suit, le Standard NMEA est défini "simplement" et uniquement pour la compréhension de ce topo, comme étant le protocole de transmission des données entre les instruments et équipements électroniques liés au GPS.

La dernière version de ce standard nous précise "Habot", est la version 2000 (Hé oui, nous n'utilisons pas encore la dernière version). Celle ci, apporte surtout un nouveau média (les Bus CAN, que vous connaissez sans le savoir puisqu'ils équipent vos véhicules depuis plusieurs années déjà), mais pas de changements majeurs dans les dialogues. Nous nous intéresserons donc plus particulièrement à la version NMEA-0183, utilisée dans nos appareils actuels.

Les prochains développements seront basés sur la FAQ (en anglais de Peter Bennet), le développement de Glenn Baddeley et quelques autres sources citée en fin d'article). Citons immédiatement, le site de Christian Couderc : Voilelec qui est, à notre sens, une référence pour les aspects 'marins' & électroniques du protocole (et en français).

2 - DEFINITION DU STANDARD NMEA-0183

Sous ce standard, toutes les données sont transmises sous la forme des caractères ASCII, tous imprimables, ainsi que les caratères [CR] Retour Charriot et [LF] Retour à la ligne, à la vitesse de transmission de 4800 bauds.

Les données sont tranmises sous forme de trames (sentences, phrases).

Il y a une transmission de toutes les trames en paquet, toutes les secondes d'horloge interne du GPS soit une fréquence de 1Hz.

Chaque trame commence par le caractère $

Suivi par un groupe de 2 lettres pour l'identifiant du récepteur.(non limitatif) citons:

  • GP pour Global Positioning System.
  • LC Loran-C receiver.
  • OM Omega Navigation receiver.
  • II Integrated Instrumentation (eg. AutoHelm Seatalk system).

(Pour certains fabricants propriétaires comme par exemple : Garmin, l'indication P pour propriétaire est suivie du code 3 lettres du fabricant garmin = $PGRM, puis ensuite l'identifiant de trame et le format des données sont libres pour ce fabriquant). Des exemples complets sont proposés dans les liens ci-dessous.

Puis un groupe de 3 lettres pour l'indentifiant de la trame.
  • GGA : pour GPS Fix et Date.
  • GLL : pour Positionnement Géographique Longitude-Latitude.
  • GSA : pour DOP et satellites actifs.
  • GSV : pour Satellites visibles.
  • VTG : pour Direction (cap) et vitesse de déplacement (en noeuds et Km/h).
  • RMC: pour données minimales exploitables spécifiques.

Suivent ensuite un certain nombre de champs (fields) séparés par une "virgule". Le rôle de la virgule est d'être le séparateur de champs, qui permet la déconcaténation des données dans le programme de traitement des données, calculateur, navigateur.

Et enfin un champs optionnel dit checksum précédé du signe * , qui représente le OR exclusif de tous les caractères compris entre $ et * (sauf les bornes $ et *), certaines trames exigent le checksum.

Suit la fermeture de la séquence avec un [CR][LF].

Un total de 82 caractères maximum pour une trame.

Et on passe à la trame suivante.

Comme indiqué, le Standard NMEA ne se borne pas qu'à ces 5 trames ci-dessus, et dans les liens vous trouverez accès à la documentation complète du Standard.

3 -La trame : GGA

Données d'acquisition du FIX - GPS.

$GPGGA,123519,4807.038,N,01131.324,E,1,08,0.9,545.4,M,46.9,M, , *42
123519 = Acquisition du FIX à 12:35:19 UTC
4807.038,N = Latitude 48 deg 07.038' N
01131.324,E = Longitude 11 deg 31.324' E
1 = Fix qualification : (0 = non valide, 1 = Fix GPS, 2 = Fix DGPS)
08 = Nombre de satellites en pousuite.
0.9 = DOP (Horizontal dilution of position) Dilution horizontale.
545.4,M = Altitude, en Metres, au dessus du MSL (mean see level) niveau moyen des Océans.
46.9,M = Correction de la hauteur de la géoïde en Metres par raport à l'ellipsoîde WGS84 (MSL).
(Champ vide) = nombre de secondes écoulées depuis la dernière mise à jour DGPS.
(Champ vide) = Identification de la station DGPS.
*42 = Checksum
Non représentés CR et LF.

4 - La trame : GLL

Position Géographique - Longitude / Latitude - GPS

$GPGLL,4916.45,N,12311.12,W,225444,A

4916.46,N = Latitude 49 deg. 16.45 min. Nord.
12311.12,W = Longitude 123 deg. 11.12 min. West (ouest)
225444 = Acquisition du Fix à 22:54:44 UTC
A = Données valides
Pas de checksum
Non représentés CR et LF

5 - La Trame : GSA

Satellites actifs - DOP dilution de précision -GPS

$GPGSA,A,3,04,05,,09,12,,,24,,,,,2.5,1.3,2.1*39

A= Sélection Automatique 2D ou 3D du FIX (M=Manuel)
3 = Fix 3D
04,05... = PRNs (N° d'Id) des satellites utilisés pour le FIX (maximum 12 satellites)
2.5 = PDOP (dilution de précision)
1.3 = Dilution de précision horizontale(HDOP)
2.1 = Dilution de précision verticale (VDOP)
*39 = Checksum
Non représentés CR et LF

Note : La DOP, dilution de précision est une indication de l'effet de la géométrie des satellites sur la précision du Fix.

6 - La trame : GSV

Satellites en vue - GPS

$GPGSV,2,1,08,01,40,083,46,02,17,308,41,12,07,344,39,14,22,228,45*75

2 = Nombre de trames GSV avec les données complètes.
1 = Trame 1 de 2 trames (jusqu'à 3 trames)
08 = Nombre de satellites visibles (SV).
01 = N° d'identification du 1er Satellite.
40 = Elevation en degrés du 1er Satellite.
083 = Azimuth en degrés du 1er Satellite.
46 = Force du signal du 1er Satellite (Plus grand=meilleur)

(Cette séquence se répète jusqu'à 4 satellites par trames.
On peut donc avoir jusqu'à 3 trames GSV dans une transmision (12 satellites).)
*75 = cheksum
non représentés les CR et LF

Ce qui vous explique la limitation à 12 satellites de nos petits appareils.

7 -La trame : VTG

Cap (direction) et vitesse sol GPS

$GPVTG,054.7,T,034.4,M,005.5,N,010.2,K

054.7,T = cap réel en Degrés , T (True track made good)
034.4,M = cap vrai magnétique en Degrés (Magnetic track made good)
005.5,N = Vitesse du déplacement par rapport au sol en Noeuds (N)
010.2,K = Vitesse du déplacement par rapport au sol en Kilomètres heure. (K)
non représentés CR et LF

8 - La Trame RMC

Données minimales recommandées de spécification GPS

$GPRMC,225446,A,4916.45,N,12311.12,W,000.5,054.7,191194,020.3,E*68

225446 = Heure du Fix 22:54:46 UTC
A = Alerte du logigiel de navigation ( A = OK, V = warning (alerte)
4916.45,N = Latitude 49 deg. 16.45 min North
12311.12,W = Longitude 123 deg. 11.12 min West
000.5 = vitesse sol, Knots
054.7 = cap (vrai)
191194 = Date du fix 19 Novembre 1994
020.3,E = Déclinaison Magnetique 20.3 deg Est
*68 = checksum obligatoire
Non représentés CR et LF

Ces données "minimales" [image], sont le plus souvent utilisées dans les programmes de navigation-GPS simples.


Matériel / Optec IFW

La roue à filtres Optec IFW et la DLL "Optec_IFW.dll"

Il est proposé ici la DLL pour la roue à filtres OPTEC IFW.

Cette roue à filtres répond à un protocole bien précis. Le moteur est un moteur pas à pas et permet donc de compter facilement le nombre de pas ...

Il est proposé plusieurs documents :

  • Le protocole de la roue à filtre OPTEC.
  • La DLL compilée : Pour la version 6 et une version de déboggage qui crée un fichier "filter_dll.log" dans le répertoire principal de PRiSM. Ce dernier fichier peut devenir très imposant et donc éviter de se servir de cette DLL à moins d'un bogge récurrant. Dans ce cas, le fichier LOG sera envoyé (compressé) à l'auteur de la DLL. Ces DLL sont à placer dans le sous-répertoire "Plugins/Filter" du répertoire principal de PRiSM sous le nom "Optec_IFW.dll".

L'intialisation et le fonctionnement se font comme pour toutes les autres DLL ...
La configuration se fait à partir de la configuration du télescope / Roue à Filtre :

Lors de l'initialisation, cette dernière sera un peu longue, le temps que la roue fasse au maximum un tour afin de repérer parfaitement le filtre utilisé.

Cette roue à filtres est un peu particulière car elle prend en compte la possibilité de l'existance des 5 roues à filtres nommées A, B, C, D ou E, chacune ayant 5 emplacement pour filtres, soit en tout, 25 filtres. On peut donc étalonner non seulement le numéro du filtre mais aussi le numéro de la roue :

Régler les filtres et la roue utilisée ...

Après avoir quitté ce menu de configuration, tous les renseignements sont enregistrés dans la base de registre WINDOWS de façon à pouvoir être réutilisé à chaque fois.

Le lancement de la roue à filtre se fait à la connexion du télescope et est signalé par l'information à la connexion de tous les accessoires. La connexion est longue car suivant le principe de fonctionnement de la roue, il est nécessaire que cette dernière s'intialise sur le filtre n°1. Le message de connexion n'apparaît donc pas tout de suite mais peut demander jusqu'à 15 secondes !

Le changement de filtre se fait toujours de la même façon :

Le changement de filtres

Le changement de filtre a été programmé de telle façon à se réaliser toujours dans le même sens pour eviter des effets de shifting. C'est pourquoi pour franchir 3 filtres, la roue en franchira d'abord 2 puis 1 dernier.

Fonction(s) Script associée(s):
Voir la partie sur les scripts et les fonctions accessoires

Conditions d'activation :
Avoir déclaré le focuser utilisée

Version Fev 2006


Matériel / OPTEC TCF-S

Le focuser OPTEC TCF-S et la DLL "Optec_focuser.dll"

Initialisation

Le TCF-S est pris en compte par PRiSM à partir du menu "Télescope / Configuration Télescope / Focalisation" où il suffit de sélectionner la "DLL" correspondante en ayant pris soin de vérifer son emplacement dans le répertoire "plugins/Focuser/" du répertoire principal de PRiSM.

Sélectionner le focuser

Lors de la configuration de PRiSM au focuser, à l'aide du bouton [Accéder à la configuration], le panel de connexion apparaît.

Le panel de configuration

  • Port série : permet de régler le port COM du TCF-S.

  • Intervalle des codeurs : Il figure dans cette case le nombre total de pas codeurs du TCF-S pour aller du minimum de focalisation au maximum (on peut régler une valeur inférieure à 7000, cette dernière étant la valeur maximale autorisé par le système).

  • mm par pas codeurs : Cette valeur indique le déplacement en mm du porte oculaire lorsque le TCF-S "bouge" d'un pas codeur. Cette valeur est fixée et il n'est pas conseillé de la changer !

  • Allongement du chemin optique : Cette case permet de rendre compte de l'augmentation du chemin optique (ou non) lors de l'augmentation du nombre de pas codeurs.

  • Position de parking : Cette valeur ne peut être changée que si l'option en dessous n'est pas cochée. Elle correspond finalement à la valeur minimale du nombre de pas codeurs lorsque la focalisation est au minimum (ou au maximum suivant le sens du chemin optique). Lors de l'initialisation normale de la focalisation, il faudra passer par cette valeur sachant qu'il sera alors impossible à PRiSM de fixer une valeur plus petite que cette référence. Pour résumer, le nombre de pas codeur du TCF-S ne pourra varier que de "Parking position" à "Parking position + Pas codeurs".

  • Rester en position actuelle lors de l'initialisation : Lors de l'initialisation, PRiSM retourne normalement à la position de parking qui correspond souvent au pas codeur "zéro". Cocher cette case empêche le mouvement et simule le déplacement vers la position de parking et le retour à la position actuelle (quantifiée dans ce cas dans la fenêtre de focalisation). Ceci évite de perdre du temps alors que dans le cas d'un non changmeent de configuration optique, la position de configuration reste sensiblement la même d'une séance à l'autre. Comme précisé ci-dessus, le fait de cocher cette case entraine une position de référence obligatoirement à "zéro", ce qui serait forcément le cas de toute façon !

Toutes ces valeurs seront sauvegardées dans la base de registre associée au logiciel (HKEY_CURRENT_USER/Software/PRiSM6/Telescope/Focuser/TCF-S) lors de la déconnexion du TCF-S et pourront être retrouvées automatiquement lors d'un nouveau lancement du focuser.

Contrôle de Focalisation

Lors du démarrage du contrôle de focalisation, une fenêtre comme ci-dessous apparaît :

Les informations fournies n'ont pour le moment aucune signification. Afin de terminer l'initialisation, il faut cliquer sur le bouton "Position Parking" et le focuser va soit à sa valeur minimale, soit simule un aller-retour entre sa valeur minimale et sa position actuelle suivant les valeurs d'initialisation. Si mouvement il y a, durant le mouvement du TCF-S (et de par la conception de ce dernier), aucune information ne s'affiche. Seul "Moving" s'affiche montrant que le TCF-S est en mouvement. Il faut attendre la fin du mouvement pour que les informations soit actualisées (dans ce cas, l'état est à "Idle") . La fenêtre s'affiche alors :

Sont indiqués :

  • Position courante : La position depuis la position de parking en mm et en pas codeurs. Le nombre de pas codeurs enregistrés par le TCF-S.

  • La température notée par le TCF-S (sonde déportée à l'extérieur pour éviter de tenir compte de l'échauffement des moteurs dû au faible courant circulant dans ces derniers à l'arrêt afin d'éviter une dérive de la focalisation).

  • Le rappel de nombre de pas codeurs et la distance correspondante pour aller du minimum au maximum de focalisation.

  • L'augmentation (Positif) ou la diminution (Négatif) du chemin optique en fonction de l'augmentation des pas codeurs ainsi que l'état du focuser.

  • Les dernières commandes permettent de bouger le focuser. Le mouvement de ce dernier est obligatoirement en distance en mm (et non en pas codeurs). Ce mouvement peut être défini de façon absolue (en fonction de la position de parking, référencée alors par rapport à la case "abs. mm") ou de façon relative (par rapport à la dernière position, référencée alors par rapport à la case "Rel inc" en pas codeurs). Certaines valeurs sont prédéfinies, notamment utiles lors du rajout de filtre donc d'une augmentation du chemin optique. Pour confirmer le déplacement, il faut alors cliquer sur "Appliquer".

    • Un exemple à 10 mm de la position de Parking | Durant le mouvement pour passer en absolu de 10 mm à 16,58 mm. Soit un mouvement relatif de 6,58 mm. | Après le mouvement à 16,58 mm de la position de Parking.

    Fonction(s) Script associée(s):
    Voir la partie sur les scripts et les fonctions "focuser"

    Conditions d'activation :
    Avoir déclaré le focuser utilisée

    Version Fev 2006


Dossier / Trichromie / Changement de repère d'espace HSI

> Dossier > Trichromie > Changement de repère d'espace HSI <-> RVB <-> YUV

But : Les espaces HSI, RVB et YUV.

Ces trois termes désignent tous les trois une façon de fabriquer une image couleur dans un espace donné. Ces trois espaces peuvent être reliés les uns aux autres par des relations plus ou moins compliqués.

  • Espace RGB : R désinge le rouge, G désigne le vert et B désigne le bleu. C'est l'espace le plus commun qui traduit le plus facilement le système de couleur utilisé. L'image résultante provient de la synthèse additive des images.

    La représentation RVB

  • Espace HSI : H pour Hue ou teinte, S pour saturation et I pour intensité. Ce système est proche de la perception humaine de la couleur. Alors que Les coordonnées RGB pourraient s'apparenter aux coordonnées cartésiennes dans cet espace, les coordonnées HSI pourraient elles s'apparenter aux coordonnées cylindriques.

D'après ce schéma, on en déduit que :

  • La valeur H se rapproche de la teinte = couleur souhaitée. H est un angle qui varie de 0° à 360°. Au vu du schéma, la dominante rouge est représenté par une valeur de H proche de 0° par valeurs supérieures et proches de 360° par valeurs supérieures. La dominante verte est représentée par des valeurs autour de 120° alors que la dominante bleue par des valeurs autour de 240° ( = 2 x 120° ).

  • La valeur de S désigne la pureté de la couleur. S est exprimée par l'inclinaison par rapport à un axe dit axe achromatique, c'est-à-dire un axe qui représente dans le repère RVB la première bissectrice ou une demi-droite où les valeurs de R, V et B sont égales. Une faible valeur de S donne une image qui a des couleurs grises alors qu'une forte valeur de S donne une image qui a des couleurs vivesou saturées.

  • Enfin, la valeur de I représente l'éclat de la couleur. I est une donnée qui se rapproche le plus de ce qu'on connait. Elle représente l'intensité globale du pixel c'est-à-dire une "moyenne" des trois composantes R, V et B. Plus la valeur de I est importante, et plus le pixel sera lumineux.

On en déduit qu'un pixel uniquement rouge se situe aux coordonnées ( H = 0°, S = 1, I = 1 ), alors qu'un pixel uniquement vert se situe aux coordonnes ( 120°, 1, 1 ) et qu'un bleu se situe en ( 240°, 1, 1 ).

Depuis ces nouvelles coordonnées de l'espace des couleurs, on peut appliquer des transformations qui permettent soit :

  • De changer les couleurs de l'image.
  • D'intensifier les couleurs de l'image.
  • ...

bref, de manipuler des données plus faciles à appréhender que les trois composantes Rouge, verte ou bleue.

Les relations de passage entre les deux espaces sont plus ou moins compliquées. Pour aperçu, les relations RVB ==> HSI ressemble à ceci :

et la transformation inverse HSI ==> RVB est un peu plus compliquée.

Exemple d'utilisation RVB <==> HSI :

Image tricolore RVB de M51

Avant toutes choses, il faut avoir des images au format flottant ou réel pour executer ces opérations. Ceci est possible par le menu " Transformation / Conversion de types / Entiers vers reels ". En effet, le passage d'un système de coordonnées à l'autre donne des résultats dans l'ensemble des réels. Il faut donc partir également de l'ensemble des réels.
Une fois l'operation executee, on obtient trois images au format reel :

Cette image représente l'intensité, c'est-à-dire la somme des trois images R, V et B

Cette image représente la teinte ou "HUE" , c'est un angle compris entre 0 et 360 degrés, chaque angle représente une couleur donnée.

Cette image représente la saturation; ce sont des nombres entre 0 et 1; plus ce nombre est grand, plus les couleurs sont saturées.

A partir de là, pour augmenter la saturation des couleurs de l'image, on peut multiplier l'image saturation par 1.2, et ensuite appliquer la transformation inverse HSI vers RGB. De plus, un logarithme sur l'image lui donne une meilleure apparence :

Image après recombinaison des trois plans H, S et I. On remarque que les étoiles ont des couleurs plus marquées. A comparer avec l'image du haut.

Image après recombinaison des trois plans H, S et I + log.
  • Espace YUV : Y désigne la luminance alors que U et V désigne la chrominance. Ce format est surtout utilisé en vidéo MPEG (notamment le 4:2:2 par rapport au 4:1:1). L'avantage est que cette espace est parfait pour être utilisé dans le codage de l'image et de la vidéo. Il permet de transmettre aisément de la vidéo sur les téléviseurs en noir et blanc. L'inconvénients de cette espace est qu'il ne suit donc pas vraiment le modèle de vision des couleurs de l'oeil. En bref, ce format se rencontre surtout à partir d'images provenant de vidéos saisies dans ce format (vidéo de WEBCAM par exemple ou de système d'acquisition) et leur représentation sera décrite en détail à partir d'une recherche sur internet à partir du mot "YUV 4:2:2". Des relations arithmétiques existent pour le passage du format RVB <==> YUV, mais les donner ici ne présentent aucun intérêt.

Images nécessaires :
images CPA et FITS trichromes

Images exemple :
M27 RVB

Conditions d'activation du menu :
Qu'une image soit ouverte.

Version Janvier 2008


Visualisation / Edition de la palette

> Visualisation > Edition de la palette

Cette fonction permet de construire et sauvegarder une palette de visualisation.

Au lancement de cette fonction, la fenêtre suivante s'ouvre :

l'éditeur de palettes; Cliquer sur partie désirée pour de plus amples explications

Il faut garder à l'esprit que la palette sera une palette de 256 couleurs (8 bits) choisies cependant parmi les 16,4 millions de couleurs (32 bits) que propose WINDOWS.
Durant cette page, nous allons d'abord voir la signification prise séparément puis nous créerons ensuite une palette particulière :

  • Le champ index indique la position occupée par le curseur au-dessus. Il peut varier de 0 à 255 correpondant aux 256 couleurs de la palette.

  • Le champ index choisi indique la position sur la palette (de 0 à 255) des repères que l'on peut se fixer en cliquant avec la souris sur un endroit de la palette. Il est alors dessinné une sorte de clé sur chaque position qui ont été repérée par une clé.

  • Les champs Rouge, Vert, Bleu indiquent la composante Rouge, Vert, Bleu de la couleur actuellement sélectionnée dans la palette

  • Le cadre coloré à droite des champs Rouge, Vert et Bleu, contient la couleur actuellement sélectionnée dans la palette.

  • Le bouton [Changer couleur] :
    Permet de remplacer la couleur ( pour l'index courant ) à partir de la boite de dialogue classique de WINDOWS.

  • Le bouton [Vider Palettes] permet de remettre à zéro toutes les valeurs d'intensité relative pour les 3 couleurs primaires R, V et B ... ceci pour tous les index.

  • Le bouton [Négatif] fait une inversion de la LUT de la palette sélectionnée. Chaque composante (R,V,B) de chaque point de la palette est remplacé par la valeur complémentaire (255-R, 255-V, 255-B)

  • Le bouton [R<->B] permet d'inverser les valeurs des intensités relatives entre la couleur primaire rouge et la couleur primaire bleue pour toutes les valeurs de la palette. La couleur primaire verte reste inchangée.

  • Le bouton [V<->R] permet d'inverser les valeurs des intensités relatives entre la couleur primaire rouge et la couleur primaire verte pour toutes les valeurs de la palette. La couleur primaire bleue reste inchangée.
    Ceci a lieu pour les 256 couleurs de la palette.

  • Le bouton [B<->V] permet d'inverser les valeurs des intensités relatives entre la couleur primaire bleue et la couleur primaire verte, pour toutes les valeurs de la palette. La couleur primaire rouge reste inchangée.

  • Le bouton [V=0] permet de fixer l'intensité relative correspondant à la couleur primaire verte à zéro, pour toutes les couleurs de la palette

  • Le bouton [R=0] permet de fixer l'intensité relative correspondant à la couleur primaire rouge à zéro, pour toutes les couleurs de la palette.

  • Le bouton [B=0] permet de fixer l'intensité relative correspondant à la couleur primaire bleue à zéro, pour toutes les couleurs de la palette.

  • Le bouton [Scie] permet de créer une LUT en "dent de scie". Il suffit d'indiquer le nombre de fois que l'on veut que la LUT courante se répète dans la LUT résultante.

  • Les boutons [Arc], [B&W], [Pink] et [Thermic] permettent de visualiser les 4 palettes prédéfinies dans PRiSM : respectivement les palettes arc-en-ciel, Noir et Blanc, Rosée et thermique.

  • Le bouton [Interpoler] n'est actif que si on a placé des repères sur la palette (en cliquant sur la palette]. Les repères sont représentés comme cela :

    En cliquant sur ce bouton, les couleurs intermédiaires (entre les repères) sont calculées par le logiciel.
    Par la suite, il est alors possible par la suite d'effectuer tous les traitements décrits dans les options ci-dessus.

  • Le bouton [Rest Mrk] permet d'effacer tous les repères existants.

  • Le bouton [Charger] permet de charger une palettte précédemment sauvegardée. L'extention des palettes est un fichier .PAL.

  • Le bouton [Sauver] permet de sauver une palettte pour la rapeller ultérieurement. L'extention des palettes est un fichier .PAL.
    Ce fichier est une suite de 256 lignes ( correspondant aux 256 couleurs ), chaque ligne contenant entre paranthèses une liste de 3 éléments représentant les intesités relatives des trois couleurs primaires, respectivement le rouge, le vert et le bleu.
    En voici un extrait :
    (065,139,105),
    (065,138,107),
    (064,138,108),
    (063,137,110),
    (062,136,112),
    (062,136,113),
    (061,135,115),
    (060,134,117),
    ....


Commentaires divers sur les fonctions script

Commentaires sur les fonctions

(1) : Format des images :
Toutes les fonctions utilisant une image ou réalisant une transformation d’images, agiront exclusivement sur des images au format FITS ou CPA. Pour les autres images au format propriétaires STX ( SBIG ), PIC ( HiSiS ), JPEG ou à un format libre ( dont les paramètres sont à connaître ), on utilisera l’outil de conversion de format situé dans le menu " Fichier / Conversion de format ". Pour les images BMP, il est possible de les importer directement par script : dans le cas où cette dernière ne serait pas retouchée, elle est à considérer comme une image trichrome (pour l'utilisation des fonctions) et sinon, il faut séparer les 3 plans de couleur pour pouvoir la considérer comme une image monochrome 8 bits.
Enfin, dans le même SCRIPT, il est possible de mélanger des images qui ont été importées à partir des deux formats différents FITS et CPA.

(2) : Images trichromes ou codées en réels / complexes :
La majorité des fonctions agissant ou se servant d’images pourront être utilisées images codées en réel / complexes. Il en va pour une moindre mesure pour des images trichromes. Cependant, l’utilisation, possible ou non, sera précisée pour ces trois types d’images dans les pages d’aides consacrées à chacune des fonctions. En ce qui concerne les images trichromes, il n’est évidemment pas possible de réaliser un traitement entre une image monochrome et une image trichrome.

(3) : Propriétés des images :
Du fait de l’existence d’une multitude de format d’entête FITS ( beaucoup de mots-clés qui ne se retrouvent pas d’une image à une autre ), certaines fonctions de cette partie ne pourront être utilisée qu’avec des images au format propriétaire PRiSM : le format CPA. Notamment, toutes les fonctions qui feront appel à un précédent étalonnage astrométrique ou photométrique ne pourront fonctionner qu’avec des images au format CPA ( puisque les paramètres d’étalonnage sont sauvegardés dans l’entête CPA ).Pour connaître les entêtes de chacun des formats , il est conseillé d’aller voir l’aide sur le format CPA pour les images au format CPA ( FAIRE LE LIEN ), et de sauvegarder une image au format FITS ( une image de démonstration par exemple ), et à partir du menu " Fichier / entête FITS " de regarder les mots-clés de l’entête de ces images ( dans PRiSM, les images FITS ont le format de telles images à l’ESO ).

(4) : Les angles sous PRiSM :
De façon générale, PRiSM raisonne avec des angles exprimés en radians. Ceci sera notamment le cas pour toutes les fonctions qui feront appel à une ascension droite et une déclinaison : ces dernières devront être exprimées en radian. Les déclinaisons sont exprimés avec des angles variant entre –Pi/2 et +Pi/2 ( correspondant de –90° à +90°) . Les ascensions droites sont exprimées avec des angles horaires variant entre 0 et 2*Pi ( correspondant de 0h à 24h ).Cependant, comme il n’est pas très facile de raisonner avec des angles en radians, 8 fonctions de conversion ont été crées afin de réaliser des conversions de façon la plus simple possible de radians vers des angles et angles horaires et vice-versa. Il est conseillé d’aller voir l’aide sur chacune de ces 8 fonctions de conversion : RA_TO_RAD, RAD_TO_RA, RAD_TO_DEC, DEC_TO_RAD, STR_DEC_TO_RAD, STR_RAD_TO_DEC, STR_RA_TO_RAD et STR_RAD_TO_RA.

(5) : Les catalogues supportés par le langage SCRIPT :
Les différents catalogues supportés par le langage SCRIPT ( pour les fonctions d’étalonnage ) sont : Les catalogues USNO, le GSC, GSC-ACT, Hipparcos, SAO, BSC et les catalogues TYCHO.Le nom des catalogues doivent être rentrés dans une variable chaîne de caractères avec une syntaxe du type suivant :

Cat[1]$="GSC"
Cat[2]$="USNO SA"
Cat[3]$="USNO A1"
Cat[4]$="USNO A2"
Cat[5]$="Hipparcos"
Cat[6]$="SAO"
Cat[7]$="BSC"
Cat[8]$="Tycho1"
Cat[9]$="GSC-ACT"
Cat[10]$="Tycho2"
Cat[11]$="UCAC1/2/3"
Cat[12]$="NOMAD v1"

Quelques définitions générales :

  • ADU ( Analog to Digital Unit = Unité Analogique-numérique )
    C’est une unité permettant de comparer la quantité d’électrons ayant rempli les différents pixels. Pour une caméra codée en entier 16 bits non signés, ce nombre va de 0 à 65535 ( = 2^16 ). Par défaut, les images codées en entier au format CPA le seront en 16 bits signés ( de – 2^15 = -32767 à 32767 ), ceci afin de permettre des traitements numériques sur les pixels qui pourrait donner des valeurs négatives en ADU.


/L10"Prism script" Nocase Line Comment = // Line Comment Alt = rem Block Comment On = REM Block Comment On Alt = Rem Escape Char = \ String Chars = "' File Extensions = PGM

/C1"Manipulation de fichiers"
Open OpenFree OpenBMP Open_FileTxt_For_Append Open_FileTxt_For_Rewrite Open_FileTxt_For_Read
GetImage GetScreenX GetScreenY GetVersionScript
Duplicate Delete
NewImage
ClearImgWindows Close ChangeFileExt CreateDir Copy CloseFileTxt
ExtractFileName ExtractFilePath ExecExternal EndOfFile
FileExists
SaveBMP SaveCPA SaveFIT SaveJPG SaveGIF SetLoadFITsToFloating SetTransformRescaleFITsDynamic SelectImg
Rename ReadFileTxt
WriteFileTxt

/C2"Materiel"
ActiveRelayXY
Calibrate_Telescope Close_Telescope_Devices Close_CCD_Camera
Delay
GetLastImageExposure GetCCDTemperature GetMaxADU getLinearity GetNoise GetDark GetCTE GetQE GetConvertFactor Get_Telescope_Position Get_Telescope_Position_App GetLastImageExposure GetDataWeatherStation Get_Dome_Pos
Init_CCD_Camera Get_CCD_Status
SetBinningX SetBinningY SetMirror SetFlagShutter SetWindow SetWindowFullFrame SetCCDTemperature Set_Internal_CCD_Filter StartExposure Shutter Set_Focuser SetDomeToTelescope ShiftTelescope ShowRaDec_Skymap SetFilter StopTelescope
WaitForEndExposure WaitForEndDelay WaitForEndMoveTelescope
Open_Telescope_Devices Get_Focuser_Temp Get_Focuser_Pos
RETURN_TELESCOPE_TO_SIDEREAL Reset_Dome Reset_Focuser
MoveDome MoveTelescope

/C3"Fonctions de traitement d'images"
Add
BinningExpand BinningReduce
Create_Pupil  Combine_Color_Img CompositeAuto CompositeAuto_Evol
Div Dilatation DetourageExt DetourageInt
Erosion
Fill_Circ
Gauss Gradient
HighPass Homothetie Homothetie
InverseCadrans Int2Real
LogImg LowPass
Sub Split_Color_Img SplitBayerImg DeBayer Balance_Bayer Shift_SPL Scale
Mult MultImg Median MirrorX MirrorY
Offset
Wavelet
Noise NoiseGauss
Translate
QuarterRot
RecalageAuto Real2Int Rotate
UnSharp

/C4"Fonctions d'analyse d'images"
EtalonAstrometrieAuto EtalonPhotometrie EtalonPhotometrieAuto EtalonPhotometrieF Equalisation EqualisationGauss
GetAstrometrie GetAstrometrieXY GetImg_XY_TO_RADDEC GetImg_RADDEC_TO_XY GetStarList GetPixelValue GetMinMax GetDecalagePlanete GetPhotometrie GetStarListCat
XYToAlphaDelta
TrigMatch
APC
CentroideGauss CentroideMoffat CentroidBarycentre CentroidBarycentreThresholding
SetPixelValue StatWindow Stat
NbPixAboveThres

/C5"Fonctions de manipulations de graphiques"
DisplayGraph
OpenGraph
SetGraphRange SetAxisInc
AddPoint
ClearGraphWindows

/C6"Fonctions de visualisation d'images"
AverageStack AddStar AddStarB AutoVisu
Blink BoucherZone ThresHold
ClipH ClipL CicatX CicatY CollapseLine
DelStar Deflat_Sky_Bkgnd
Exec_CosmeScript
Height
GetPoint GetWindow GetFixedWindow GetOffsetImg GetExpTime GetJulianDay GetTime GetDate GetCamera GetBandWidth GetWaveLength GetFilter GetBinX GetBinY GetCVFFactor GetDiameter GetFocus GetMirrorX GetMirrorY GetSizePixX GetSizePixY GetTimeReadCCD Get_WL_BW_FLX GetTCCD GetTExt GetFlux GetImageAirMass GetLatitude GetLongitude GetLowerThrhold GetUpperThrhold GetObservatory GetObserver GetSeeing GetTelescope GetAlpha GetDelta GetHotPixels GetBackGround
MedianStack
SizeWindowY SizeWindowX SetWindowPos SetBandWidth SetWaveLength SetComment SetFlux SubDarkOpt
Window Width
Visu
PutAlpha PutDelta PreProcess

/C7"Fonctions internes"
ADDDLGBOX
DISPDLGBOX Delay
END EXIT ELSE ENDIF
FOR
IF INPUT
THEN
NEXT
GOTO GOSUB GetYesNo GetLang GETDLGBOX GetFileName GetListFileName GetListFileNameEx GetRepName GetMemStat
VAL
STR STRF STRFF SETDISPLAY_FLOAT SETDISPLAY_FRAC
PRINT PAUSE
RESETDLGBOX RETURN
WaitForEndDelay

/C8"Fonctions Diverses"
Now NBMOT
ConvertDateToJulian ComputeAngleHor COS CUTSTR CUT
DateToStr DistSky DEC_TO_RAD DECR
GetStdrLatitude GetStdrLongitude GetHeight GetAirMass GetDistanceToMeridien GetAzimuth GetObjectCoord GetRaDecMoon GetRaDecSun GetAsterCoord GetCometCoord
RAD_TO_RA RAD_TO_DEC RA_TO_RAD ROUND RANDOM RANDOMG
STR_RA_TO_RAD STR_RAD_TO_RA STR_DEC_TO_RAD STR_RAD_TO_DEC SideralTime SIN SQR
ATN ABS
EXP
FRAC
TAN
INCR INT
LOG
POWER POSSTR
MOD
REM
# //

/C9"Constantes"
PI TODEG TORAD TRUE FALSE


Visualisation / ChgImgDim

ChgImgDim

Description :

Cette fonction permet de fenêtrer une image des coordonnées inférieures (X=1,Y=1) aux coordonnées supérieures (X=Xmax; Y=Ymax).

Syntaxe :

CHGIMGDIM Img Xmax Ymax

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le PGM
Xmax | Entrée | Entier | Coordonnée horizontale du coin supérieur droit de la fenêtre
Ymax | Entrée | Entier | Coordonnée verticale du coin supérieur droit de la fenêtre

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
Window

Fonction correspondante :
Menu [Transformation] > [Redimension]

Exemple :

......................................
ChgImgDim Img Xmax Ymax

Télécharger l'exemple


Transformation / Image_Flip

Image_Flip

Description :

Cette fonction permet de réaliser un miroir de l'image suivant X (horizontalement) et suivant Y (verticalement). En effet, ceci simule ce qui se passe lors du retournement au méridien pour une monture de type allemande.

La majorité des paramètres sur l'information de l'image sont conservés.
Paramètres pouvant changer lors de l'application d'une telle fonction:

  • L'astrométrie de l'image est conservée mais il est conseillé (dans la mesure du possible) de la refaire.
  • La photométrie n'est pas conservée.
  • L'angle d'orientation de la caméra et la direction du repère sont automatiquement complétés en fonction des mêmes paramètres de l'image initiale.
  • Les informations sur les miroirs sont automatiquement cochées.

Syntaxe :

IMAGE_FLIP Img

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img | Entrée | Image | Nom interne de l'image dans le programme PGM

Caractéristiques d'images acceptées :

Nom de l'image | Gris / Trichrome | Codage Entier / Réel / Complexe | Format CPA / FITS
Img | oui / oui | oui / oui / oui | oui / oui

Voir aussi :
MirrorY
MirrorX

Exemple :

..........................................
GetImage Img

Image_Flip Img

Télécharger l'exemple


Transformation / RecalageAuto_Inter

RecalageAuto_Inter

Description :

Cette fonction calcule automatiquement le déplacement entre deux images par intercorrelation.
Les images ne sont pas physiquement modifiées. Si on souhaite corriger physiquement ce déplacement, il faut utiliser la fonction de translation "Translate".

Cette méthode est celle utilisée dans le menu [Trichromie] > [Recalage Auto des plans de couleur] .

Syntaxe :

RECALAGEAUTO_INTER Img1 Img2 DeltaX DeltaY

Variables :

Paramètres | Entrées / Sorties | Type | Description
Img1 | Entrée | Image | Nom interne de l'image de référence dans le PGM
Img2 | Entrée | Image | Nom interne de l'image à "déplacer" dans le PGM
DX | Sortie | Réel | Valeur du déplacement horizontal de l'image 2 par rapport à l'image 1
DX | Sortie | Réel | Valeur du déplacement vertital de l'image 2 par rapport à l'image 1

Caractéristiques d'images acceptées :

Nom de l'image | Monchrome / RVB | Codage Entier / Réel / Complexe | Format CPA / FITS
Img1 | oui / non | oui / oui / oui | oui / oui
Img2 | oui / non | oui / oui / oui | oui / oui

Voir aussi :

Exemple :

GetImage Img1
GetImage Img2

RECALAGEAUTO_INTER Img1 Img2 Dx Dy

PRINT "Décalage en X de Img2 par rapport à Img1 : " Dx
Print "Décalage en Y de Img2 par rapport à Img1 : " Dy

Télécharger l'exemple


Caméra / Note d'application d'orientation

Note d'application > Orientation de la caméra CCD

Pour le moment, la définition de l'orientation dans PRiSM n'est pas capitale mais il est quand même important, ne serait-ce que pour les applications futures, de définir l'orientation de sa caméra. La définition de l'orientation de la caméra consiste à :

  • Définir le type de repère utilisé, direct ou indirect. Le repère direct est un repère dans le sens tel qu'il existe un angle trigonométrique positif de 90° entre le NORD et l'EST : par exemple, le NORD est en haut et l'EST est à gauche.
  • L'angle entre la direction de l'image Centre-Haut et le Nord céleste tel qu'il est défini sur le schéma suivant :

Suivant l'orientation de la caméra CCD, il est possible de d'afficher sur la carte du ciel la position de l'image suivant ses coordonnées à l'aide de la configuration de la carte du ciel.

I. La détermination des valeurs de référence :

But : déterminer les valeurs d'angle et d'orientation pour un jeu de miroir donné ainsi que pour les montures allemandes, une orientation de tube donné.
Afin de déterminer ces valeurs, il est conseillé de réaliser une image CCD et de procéder à la calibration astrométrique automatique de l'image. Lors de la sélection du polynôme de passage, les caractéristiques déterminées comme la focale, l'angle du CCD et l'orientation du repère sont automatiquement copiées dans l'entête de l'image. Ensuite, à l'aide du menu contectuel de la carte du ciel "Recevoir Orientation / Focale d'une image CCD", ces trois dernières valeurs sont envoyées dans la configuration de la carte du ciel, cette dernière étant mise à jour.

A venir : animation flash

Il est conseillé de compléter l'entête de la caméra CCD avec ces valeurs. La précédente calibration astrométrique automatique permet de le réaliser en cochant la case correspondante. Le menu contextuel des images CCD, "Envoyer informations d'une image CCD dans l'entête de la caméra principale", permet aussi de compléter directement l'entête de la caméra principale (attention, dans ce dernier cas, ce sont toutes les informations de l'image qui sont envoyées dans l'entête de la caméra principale).

II. Un exemple de fonctionnement :

Une vérification du remplissage de l'entête de la caméra :

Ce sont les paramètres par défaut obtenus à l'aide de la calibration d'une image.

Par la suite, lorsqu'un miroir X ou Y sera imposé lors de l'acquisition ou lorsqu'un retournement sera détecté pour une monture allemande, les paramètres d'angle et d'orientation seront automatiquement complété dans l'entête de l'image :

le côté du tube ainsi que les miroirs sont identiques aux paramètres par défaut.
le côté du tube a changé mais les miroirs sont identiques aux paramètres par défaut.
le côté du tube a changé ainsi que le miroir en Y. Le miroir en X est lui identique aux paramètres par défaut.
le côté du tube a changé ainsi que les miroirs par rapport aux paramètres par défaut.
Version Octobre 2010